03-CLI configuration examples (AC+fit AP)

HomeSupportDoc SetsDoc PackagesH3C Wireless Products All-in-One-6W10003-CLI configuration examples (AC+fit AP)
Table of Contents
Related Documents
91-Auto-DFS and Auto-TPC Configuration Examples
Title Size Download
91-Auto-DFS and Auto-TPC Configuration Examples 391.15 KB

 

H3C Access Controllers

Comware 7 Auto-DFS and Auto-TPC

Configuration Examples

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Copyright © 2022 New H3C Technologies Co., Ltd. All rights reserved.

No part of this manual may be reproduced or transmitted in any form or by any means without prior written consent of New H3C Technologies Co., Ltd.

Except for the trademarks of New H3C Technologies Co., Ltd., any trademarks that may be mentioned in this document are the property of their respective owners.

The information in this document is subject to change without notice.



Introduction

The following information provides an example for configuring auto dynamic frequency selection (DFS) and auto transmit power control (TPC).

Prerequisites

The following information applies to Comware 7-based access controllers and access points with a software version of 5439 or later (5411 or later for the WA6600 series access points). Procedures and information in the examples might be slightly different depending on the software or hardware version of the access controllers and access points.

The configuration examples were created and verified in a lab environment, and all the devices were started with the factory default configuration. When you are working on a live network, make sure you understand the potential impact of every command on your network.

The following information is provided based on the assumption that you have basic knowledge of WLAN RRM.

Restrictions and guidelines

·     Auto-DFS and auto-TPC are not supported in the following scenarios or devices:

¡     AC hierarchy network.

¡     Scenarios where the working channels and powers are not allowed to change.

¡     Scenarios where spectrum analysis and WLAN location are not compatible with auto-DFS and auto-TPC.

¡     Local Web interface.

¡     Unified wired and wireless access controller.

¡     WTU420, WTU420H, and X-share series access points.

·     Use the serial ID labeled on the AP's rear panel to specify an AP.

·     Do not manually specify a working channel, because it has a higher priority than the automatically selected channel.

·     Make sure power lock is disabled.

·     As a best practice, set the bandwidth mode for the 5 GHz radio to 40 MHz or 20 MHz.

·     To enable auto-DFS or auto-TPC only for an AP or AP group, use the following commands:

¡     calibrate-channel self-decisive enable

¡     calibrate-power self-decisive enable

Example: Configuring auto-DFS and auto-TPC

Network configuration

As shown in Figure 1, in centralized forwarding mode, the AC is connected to the switch, and the switch assigns an IP address to the AP and clients as a DHCP server. Configure auto-DFS and auto-TPC for the AP to change the working channel and transmit power automatically based on the wireless environment.

Figure 1 Network diagram

 

Procedures

Configuring the AC

1.     Configure interfaces on the AC:

# Create VLAN 100 and VLAN-interface 100, and assign an IP address to the VLAN interface. The AC will use this IP address to establish a CAPWAP tunnel with the AP.

<AC> system-view

[AC] vlan 100

[AC-vlan100] quit

[AC] interface vlan-interface 100

[AC-Vlan-interface100] ip address 192.1.0.1 16

[AC-Vlan-interface100] quit

# Create VLAN 200 and VLAN-interface 200, and assign an IP address to the VLAN interface. VLAN 200 will be used for client access.

[AC] vlan 200

[AC-vlan200] quit

[AC] interface vlan-interface 200

[AC-Vlan-interface200] ip address 192.2.0.1 24

[AC-Vlan-interface200] quit

# Configure GigabitEthernet 1/0/1 that connects the switch to the AC as a trunk port, and assign the trunk port to VLAN1, VLAN 100, and VLAN 200.

[AC] interface gigabitethernet 1/0/1

[AC-GigabitEthernet1/0/1] port link-type trunk

[AC-GigabitEthernet1/0/1] port trunk permit vlan 1 100 200

[AC-GigabitEthernet1/0/1] quit

2.     Configure a wireless service:

# Create a service template named service and enter its view.

[AC] wlan service-template service

# Configure the SSID as service.

[AC-wlan-st-service] ssid service

Specify VLAN 200 in the service template.

[AC-wlan-st-service] vlan 200

# Enable the service template.

[AC-wlan-st-service] service-template enable

[AC-wlan-st-service] quit

3.     Configure an AP:

# Create a manual AP named ap1, and specify the AP model and serial ID.

[AC] wlan ap ap1 model WA6330

[AC-wlan-ap-ap1] serial-id 219801A23V8192E00021

# Enter the view of radio 1.

[AC-wlan-ap-ap1] radio 1

# Set the bandwidth mode to 40 MHz.

[AC-wlan-ap-ap1-radio-1] channel band-width 40

# Bind WLAN service template service to radio 1 and enable the radio.

[AC-wlan-ap-ap1-radio-1] service-template service

[AC-wlan-ap-ap1-radio-1] radio enable

[AC-wlan-ap-ap1-radio-1] quit

[AC-wlan-ap-ap1] quit

# Configure AP 2, AP 3, and AP 4 in the same way AP 1 is configured.

4.     Configure auto-DFS and auto-TPC:

# Enter global configuration view.

[AC] wlan global-configuration

# Enable auto-TPC.

[AC-wlan-global-configuration] calibrate-power self-decisive enable all

# Enable auto-DFS.

[AC-wlan-global-configuration] calibrate-channel self-decisive enable all

[AC-wlan-global-configuration] quit

[AC] quit

Configure the switch

# Create VLAN 100. The switch will use this VLAN to forward the traffic on the CAPWAP tunnels between the AC and AP.

<Switch> system-view

[Switch] vlan 100

[Switch-vlan100] quit

# Create VLAN 200. The switch will use this VLAN to forward packets for wireless clients.

[Switch] vlan 200

[Switch-vlan200] quit

# Configure GigabitEthernet 1/0/1 that connects the switch to the AC as a trunk port, and assign the trunk port to VLAN1, VLAN 100, and VLAN 200.

[Switch] interface gigabitethernet 1/0/1

[Switch-GigabitEthernet1/0/1] port link-type trunk

[Switch-GigabitEthernet1/0/1] port trunk permit vlan 1 100 200

[Switch-GigabitEthernet1/0/1] quit

# Configure GigabitEthernet 1/0/2 that connects the switch to the APs as an access port, and assign the access port to VLAN 100.

[Switch] interface range gigabitethernet 1/0/2 to gigabitethernet 1/0/5

[Switch-if-range] port link-type access

[Switch-if-range] port access vlan 100

# Enable the PoE feature.

[Switch-if-range] poe enable

[Switch-if-range] quit

# Specify an IP address for VLAN-interface 100.

[Switch] interface vlan-interface 100

[Switch-Vlan-interface100] ip address 192.1.0.2 16

[Switch-Vlan-interface100] quit

# Specify an IP address for VLAN-interface 200.

[Switch] interface vlan-interface 200

[Switch-Vlan-interface200] ip address 192.2.0.2 24

[Switch-Vlan-interface200] quit

# Enable DHCP.

[Switch] dhcp enable

# Create DHCP address pool 100. Specify the 192.1.0.0/16 subnet and the 192.1.0.1 gateway for the pool.

[Switch] dhcp server ip-pool 100

[Switch-dhcp-pool-100] network 192.1.0.0 mask 255.255.0.0

[Switch-dhcp-pool-100] gateway-list 192.1.0.1

[Switch-dhcp-pool-100] quit

# Create DHCP address pool 200. Specify the 192.2.0.0/16 subnet and the 192.2.0.1 gateway for the pool.

[Switch] dhcp server ip-pool 200

[Switch-dhcp-pool-200] network 192.2.0.0 mask 255.255.255.0

[Switch-dhcp-pool-200] gateway-list 192.2.0.1

[Switch-dhcp-pool-200] quit

Verifying the configuration

1.     View AP registration information on the AC:

# Verify that the APs have been associated with the AC. If the APs are in R/M state, the APs have been associated with the AC.

<AC> display wlan ap all

                                  AP information

 State : I = Idle,      J  = Join,       JA = JoinAck,    IL = ImageLoad

         C = Config,    DC = DataCheck,  R  = Run,   M = Master,  B = Backup

 

AP name                        APID  State Model           Serial ID

ap1                            1     R/M   WA6330          219801A23V8192E00021

ap2                            2     R/M   WA6330          219801A23V8192E00022

ap3                            3     R/M   WA6330          219801A23V8192E00023

ap4                            4     R/M   WA6330          219801A23V8192E00024

2.     View history and detailed RRM information on the AC.

# Display DFS and TPC information for radio 1 of AP 1 on the AC to verify that the channel and power have been changed.

<AC> display wlan rrm-history ap name ap1

                                 AP RRM History

--------------------------------------------------------------------------------

 Flags : I - Interference,   P - Packets discarded,   F - Retransmission,

         R - Radar,          C - Coverage,            B - Channelbusy,

         M - Manual          O - Others

--------------------------------------------------------------------------------

 

                              AP RRM History : ap1

--------------------------------------------------------------------------------

 Radio : 1                                Basic BSSID : 7848-59f3-df80

--------------------------------------------------------------------------------

        Ch  Power Load Util Intf PER Retry Reason   Date         Time

            (dBm) (%)  (%)  (%)  (%) (%)            (yyyy-mm-dd) (hh:mm:ss)

--------------------------------------------------------------------------------

 Before 36  20    21   0    11   0   1     ----C--- 2021-02-25   15:12:56

 After  36  17    21   0    11   0   1     -        -            -

--------------------------------------------------------------------------------

 Before 36  17    21   0    12   0   0     ----C--- 2021-02-25   15:15:56

 After  36  14    21   0    12   0   0     -        -            -

--------------------------------------------------------------------------------

 Before 36  14    21   0    12   0   0     ----C--- 2021-02-25   15:18:56

 After  36  11    21   0    12   0   0     -        -            -

--------------------------------------------------------------------------------

 Before 36  11    18   0    11   0   10    -----B-- 2021-02-25   15:25:21

 After  40  11    16   0    10   0   8     -        -            -

--------------------------------------------------------------------------------

# Display detailed DFS and TPC information for radio 1 of AP 1 on the AC.

<AC> display wlan rrm-status ap name ap1

 

                              AP RRM Profile : ap1

--------------------------------------------------------------------------------

 Radio   : 1                              Basic BSSID    : 7848-59f3-df80

 Channel : 40                             Tx Power (dBm) : 14

--------------------------------------------------------------------------------

    Ch   Nbrs   Load   Util   Intf   PER   Retry   Radar     Last Detected At

                (%)    (%)    (%)    (%)    (%)

--------------------------------------------------------------------------------

    36   44     23     0      16     0     0       -         2021-02-26 15:30:32

    40   3      9      -      1      0     -       -         2021-02-26 15:30:32

    44   11     18     -      6      0     -       -         2021-02-26 15:30:32

    48   8      30     -      10     0     -       -         2021-02-26 15:30:32

    52   25     17     -      12     0     -       -         2021-02-26 15:30:32

    56   0      7      -      0      0     -       -         2021-02-26 15:30:32

    60   4      8      -      1      0     -       -         2021-02-26 15:30:32

    64   7      7      -      0      0     -       -         2021-02-26 15:30:32

    149  30     32     -      24     0     -       -         2021-02-26 15:30:32

    153  12     10     -      3      0     -       -         2021-02-26 15:30:32

    157  12     14     -      4      0     -       -         2021-02-26 15:30:32

    161  5      8      -      2      0     -       -         2021-02-26 15:30:32

    165  5      7      -      1      0     -       -         2021-02-26 15:30:32

--------------------------------------------------------------------------------

   Nbr-MACAddress   Ch    Intf   SignalStrength  Type        Last Detected At

                          (%)    (dBm)

--------------------------------------------------------------------------------

   0023-89e2-ed80   36    0      -29             Unmanaged   2021-02-26 15:30:40

   0023-ee00-1168   52    0      -88             Unmanaged   2021-02-26 15:30:40

   04d7-a537-8540   149   0      -68             Unmanaged   2021-02-26 15:30:40

   1019-651b-d682   36    0      -7              Unmanaged   2021-02-26 15:30:40

   1019-651b-d691   149   2      -52             Unmanaged   2021-02-26 15:30:40

   346b-5b6c-1e00   36    0      -47             Unmanaged   2021-02-26 15:30:40

   346b-5b6c-1e01   36    0      -53             Unmanaged   2021-02-26 15:30:40

   346b-5b76-1d20   36    0      -35             Managed     2021-02-26 15:30:40

   346b-5b76-1d22   36    0      -23             Managed     2021-02-26 15:30:40

   346b-5b76-1d23   36    0      -17             Managed     2021-02-26 15:30:40

   346b-5b76-1d24   36    0      -20             Managed     2021-02-26 15:30:40

   3891-d502-be60   52    0      -60             Managed     2021-02-26 15:30:40

   3891-d502-be61   52    0      -61             Managed     2021-02-26 15:30:40

   3891-d58a-8f80   44    0      -75             Unmanaged   2021-02-26 15:30:40

   3891-d58a-8f81   44    0      -76             Unmanaged   2021-02-26 15:30:40

   3891-d58a-8f82   44    0      -75             Unmanaged   2021-02-26 15:30:40

   3891-d58a-8f90   161   0      -94             Unmanaged   2021-02-26 15:30:40

   3891-d58d-6d41   52    0      -45             Unmanaged   2021-02-26 15:30:40

   3897-d618-90e0   36    0      -32             Unmanaged   2021-02-26 15:30:40

   3897-d6e0-e860   36    0      -38             Unmanaged   2021-02-26 15:30:40

3.     (Optional.) Connect the AC to the Cloudnet platform to view AP and client statistics.

# View the health status of clients to identify whether the number of clients with a health score of excellent and good has increased.

Figure 2 Client health status

 

# View the health status of APs to identify whether the number of APs with a health score of excellent and good has increased.

Figure 3 AP health status

 

Configuration files

·     Switch:

#

 dhcp enable

#

vlan 100

#

vlan 200

#

dhcp server ip-pool 100

 gateway-list 192.1.0.1

 network 192.1.0.0 mask 255.255.0.0

#

dhcp server ip-pool 200

 gateway-list 192.2.0.1

 network 192.2.0.0 mask 255.255.255.0

#

interface Vlan-interface100

 ip address 192.1.0.2 255.255.0.0

#

interface Vlan-interface200

 ip address 192.2.0.2 255.255.255.0

#

interface GigabitEthernet1/0/1

 port link-type trunk

 port trunk permit vlan 1 100 200

#

interface GigabitEthernet1/0/2

 port link-type access

 port access vlan 100

 poe enable

#

interface GigabitEthernet1/0/3

 port link-type access

 port access vlan 100

 poe enable

#

interface GigabitEthernet1/0/4

 port link-type access

 port access vlan 100

 poe enable

#

interface GigabitEthernet1/0/5

 port link-type access

 port access vlan 100

 poe enable

#

·     AC:

#

wlan global-configuration

 calibrate-channel self-decisive enable all

 calibrate-power self-decisive enable all

#

vlan 100

#

vlan 200

#

wlan service-template service

 ssid service

 vlan 200

 service-template enable

#

interface Vlan-interface100

 ip address 192.1.0.1 255.255.0.0

#

interface Vlan-interface200

 ip address 192.2.0.1 255.255.255.0

#

interface GigabitEthernet1/0/1

 port link-type trunk

 port trunk permit vlan 1 100 200

#

wlan ap ap1 model WA6330

 serial-id 219801A23V8192E00021

 radio 1

  channel band-width 40

  radio enable

  service-template service

#

wlan ap ap2 model WA6330

 serial-id 219801A23V8192E00022

 radio 1

  channel band-width 40

  radio enable

  service-template service

#

wlan ap ap3 model WA6330

 serial-id 219801A23V8192E00023

 radio 1

  channel band-width 40

  radio enable

  service-template service

#

wlan ap ap4 model WA6330

 serial-id 219801A23V8192E00024

 radio 1

  channel band-width 40

  radio enable

  service-template service

#

Related documentation

·     AP Management Configuration Guide in H3C Access Controllers Configuration Guides

·     AP Management Command Reference in H3C Access Controllers Command References

·     WLAN RRM Configuration Guide in H3C Access Controllers Configuration Guides

·     WLAN RRM Command Reference in H3C Access Controllers Command References

  • Cloud & AI
  • InterConnect
  • Intelligent Computing
  • Security
  • SMB Products
  • Intelligent Terminal Products
  • Product Support Services
  • Technical Service Solutions
All Services
  • Resource Center
  • Policy
  • Online Help
All Support
  • Become a Partner
  • Partner Resources
  • Partner Business Management
All Partners
  • Profile
  • News & Events
  • Online Exhibition Center
  • Contact Us
All About Us
新华三官网