03-CLI configuration examples (AC+fit AP)

HomeSupportDoc SetsDoc PackagesH3C Wireless Products All-in-One-6W10003-CLI configuration examples (AC+fit AP)
Table of Contents
Related Documents
88-iBeacon Management Configuration Examples
Title Size Download
88-iBeacon Management Configuration Examples 261.72 KB

 

H3C Access Controllers

Comware 7 iBeacon Management

Configuration Examples

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Copyright © 2022 New H3C Technologies Co., Ltd. All rights reserved.

No part of this manual may be reproduced or transmitted in any form or by any means without prior written consent of New H3C Technologies Co., Ltd.

Except for the trademarks of New H3C Technologies Co., Ltd., any trademarks that may be mentioned in this document are the property of their respective owners.

The information in this document is subject to change without notice.



Introduction

The following information provides an example for configuring WA4320-ACN-B APs to realize iBeacon management.

Prerequisites

This document applies to Comware 7-based access controllers and access points. Procedures and information in the examples might be slightly different depending on the software or hardware version of the access controllers and access points.

The configuration examples in this document were created and verified in a lab environment, and all the devices were started with the factory default configuration. When you are working on a live network, make sure you understand the potential impact of every command on your network.

This document assumes that you have basic knowledge of IoT AP and WLAN location.

Example: Configuring iBeacon management

Network configuration

As shown in Figure 1, configure the AP to manage the iBeacon device. The AP collects BLE information and sends the information to the location server on the IMC server for calculation. Then, users can obtain information including electric quantity and RSSI of the iBeacon device. The AP also assigns management orders from the server to the iBeacon device.

Figure 1 Network diagram

 

Restrictions and guidelines

Use the serial ID labeled on the AP's rear panel to specify an AP.

Procedures

Configuring the AC

1.     Configure interfaces on the AC:

# Create VLAN 100 and VLAN-interface 100, and assign an IP address to the VLAN interface. The AC will use this IP address to establish a CAPWAP tunnel with the AP.

<AC> system-view

[AC] vlan 100

[AC-vlan100] quit

[AC] interface vlan-interface 100

[AC-Vlan-interface100] ip address 192.1.0.1 16

[AC-Vlan-interface100] quit

# Create VLAN 200 and VLAN-interface 200, and configure the VLAN interface to use DHCP for IP address acquisition.

<AC> system-view

[AC] vlan 200

[AC-vlan200] quit

[AC] interface vlan-interface 200

[AC-Vlan-interface200] ip address dhcp-alloc

[AC-Vlan-interface200] quit

# Configure GigabitEthernet 1/0/1 that connects the AC and the switch as a trunk port, remove the port from VLAN 1, and assign it to VLANs 100 and 200.

[AC] interface gigabitethernet 1/0/1

[AC-GigabitEthernet1/0/1] port link-type trunk

[AC-GigabitEthernet1/0/1] undo port trunk permit vlan 1

[AC-GigabitEthernet1/0/1] port trunk permit vlan 100 200

[AC-GigabitEthernet1/0/1] quit

2.     Create a manual AP named ap1, and specify the AP model and serial ID

[AC] wlan ap ap1 model WA4320-ACN-B

[AC-wlan-ap-ap1] serial-id 210236A35VA11A100678ACNB

3.     Configure a module:

# Enter the view of module 1.

[AC-wlan-ap-ap1] module 1

# Specify the supported module type BLE for module 1, and enable module 1.

[AC-wlan-ap-ap1-module-1] type ble

[AC-wlan-ap-ap1-module-1] module enable

[AC-wlan-ap-ap1-module-1] quit

4.     Configure BLE location:

# Enable BLE location.

[AC-wlan-ap-ap1] rfid-tracking ble enable

# Set the IPv4 address and port number of the location server to 192.2.0.1 and 1145, respectively. In this example, the IP address of the BLE location server is the IMC server's IP address obtained through DHCP.

[AC-wlan-ap-ap1] rfid-tracking ble engine-address 192.2.0.1 engine-port 1145

# Enable BLE neighbor list reporting for AP ap1.

[AC-wlan-ap-ap1] rfid-tracking ble report enable

# Configure the AP to send BLE neighbor list reports to the location server every 10 seconds.

[AC-wlan-ap-ap1] rfid-tracking ble report interval 10

# Specify the default password for deploying configuration to iBeacon devices as AprilBrother in plaintext form. Make sure the specified password is the same as the factory password of the iBeacon device.

[AC-wlan-ap-ap1] rfid-tracking ble command-password simple AprilBrother

[AC-wlan-ap-ap1] quit

Configuring the switch

1.     Configure interfaces on the switch:

# Create VLAN 100 and VLAN-interface 100, and assign an IP address to the VLAN interface. The switch will use this VLAN to communicate with the AC.

<Switch> system-view

[Switch] vlan 100

[Switch-vlan100] quit

[Switch] interface vlan-interface 100

[Switch-Vlan-interface100] ip address 192.1.0.2 16

[Switch-Vlan-interface100] quit

# Create VLAN 200 and VLAN-interface 200, and assign an IP address to the VLAN interface. The switch will use this VLAN to forward traffic for the IMC server.

[Switch] vlan 200

[Switch-vlan200] quit

[Switch] interface vlan-interface 200

[Switch-Vlan-interface200] ip address 192.2.0.2 24

[Switch-Vlan-interface200] quit

# Configure GigabitEthernet 1/0/1 that connects the switch and the AC as a trunk port, remove the port from VLAN 1, and assign the trunk port to VLANs 100 and 200.

[Switch] interface gigabitethernet 1/0/1

[Switch-GigabitEthernet1/0/1] port link-type trunk

[Switch-GigabitEthernet1/0/1] undo port trunk permit vlan 1

[Switch-GigabitEthernet1/0/1] port trunk permit vlan 100 200

[Switch-GigabitEthernet1/0/1] quit

# Configure GigabitEthernet 1/0/2 that connects the switch and the IMC server as an access port, and assign the port to VLAN 200.

[Switch] interface gigabitethernet 1/0/2

[Switch-GigabitEthernet1/0/2] port link-type access

[Switch-GigabitEthernet1/0/2] port access vlan 200

[Switch-GigabitEthernet1/0/2] quit

# Configure GigabitEthernet 1/0/3 that connects the switch and AP as an access port, and assign the port to VLAN 100.

[Switch] interface gigabitethernet 1/0/3

[Switch-GigabitEthernet1/0/3] port link-type access

[Switch-GigabitEthernet1/0/3] port access vlan 100

# Enable PoE on GigabitEthernet 1/0/3.

[Switch-GigabitEthernet1/0/3] poe enable

[Switch-GigabitEthernet1/0/3] quit

2.     Configure DHCP services:

# Enable DHCP.

[Switch] dhcp enable

# Create a DHCP address pool named 1 to assign an IP address to the AP.

[Switch] dhcp server ip-pool 1

# In DHCP address pool 1, specify subnet 192.1.0.0/16 for dynamic allocation, exclude IP address 192.1.0.1 from dynamic allocation, and specify gateway IP address 192.1.0.2.

[Switch] dhcp server ip-pool 1

[Switch-dhcp-pool-1] network 192.1.0.0 mask 255.255.0.0

[Switch-dhcp-pool-1] forbidden-ip 192.1.0.1

[Switch-dhcp-pool-1] gateway-list 192.1.0.2

[Switch-dhcp-pool-1] quit

# Create a DHCP address pool named 2, and specify subnet 192.2.0.0/24 and gateway address 192.2.0.2 for the AC's VLAN-interface 200 and the IMC server.

[Switch] dhcp server ip-pool 2

[Switch-dhcp-pool-2] network 192.2.0.0 mask 255.255.255.0

[Switch-dhcp-pool-2] gateway-list 192.2.0.2

[Switch-dhcp-pool-2] quit

Configuring the IMC server

In this example, the RADIUS server runs IMC PLAT 7.2(E0403L02) and IMC WSM 7.2(E0502L03).

To configure the IMC server:

1.     Add a location:

a.     Click the Service tab.

b.     From the navigation tree, select WLAN Manager > Location View.

c.     Click Add.

The Add Location page opens.

d.     Configure the following parameters, as shown in Figure 2:

-     Enter BLE in the Location Name field.

-     Use the default settings for other parameters.

e.     Click OK.

Figure 2 Adding a location

 

2.     Add a Bluetooth AP:

a.     On the newly created location view page, click Add, as shown in Figure 3.

The Select Devices page opens.

b.     On the Device List area, select the target Bluetooth AP, as shown in Figure 4.

e.     Click OK.

Figure 3 Adding a Bluetooth AP

 

Figure 4 Selecting a Bluetooth AP

 

3.     Add a topology:

a.     On the newly created location view page, click the icon of viewing topology, as shown in Figure 5.

The topology configuration page opens.

b.     Click the icon of adding a map, as shown in Figure 6.

c.     Click the icon of setting the measuring scale, as shown in Figure 7.

d.     Click the save icon to save the topology, as shown in Figure 8.

Figure 5 Adding a topology

 

Figure 6 Adding a map

 

Figure 7 Adding a measuring scale

 

Figure 8 Saving the topology

 

Verifying the configuration

1.     Log in to the IMC management platform, and click the Service tab.

2.     From the navigation tree, select WLAN Manager > Location Manager> iBeacon List.

3.     On the page that opens, view the iBeacon information, including electric quantity, RSSI, UUID, Major ID, Minor ID, and transmit power.

Configuration files

·     AC:

#

vlan 100

#

interface Vlan-interface100

 ip address 192.1.0.1 255.255.0.0

#

interface Vlan-interface200

 ip address dhcp-alloc

#

interface GigabitEthernet1/0/1

 port link-type trunk

 port trunk permit vlan 100 200

 undo port trunk permit vlan 1

#

wlan ap ap1 model WA4320-ACN-B

 serial-id 210236A35VA11A100678ACNB

 rfid-tracking ble command-password cipher $c$3$AAu3rmjHUmAE0W12Rk1Jco6MPJ3Iqoh+pFgqhkFihw==

 rfid-tracking ble enable

 rfid-tracking ble engine-address 192.2.0.1 engine-port 1145

 rfid-tracking ble report enable

 rfid-tracking ble report interval 10

 radio 1

 radio 2

 module 1

   type BLE

   module enable

#

·     Switch:

#

dhcp enable

#

vlan 100

#

vlan 200

#

dhcp server ip-pool 1

 gateway-list 192.1.0.2

 network 192.1.0.0 mask 255.255.0.0

 forbidden-ip 192.1.0.1

#

dhcp server ip-pool 2

 gateway-list 192.2.0.2

 network 192.2.0.0 mask 255.255.255.0

#

interface Vlan-interface100

 ip address 192.1.0.2 255.255.0.0

#

interface Vlan-interface200

 ip address 192.2.0.2 255.255.255.0

#

interface GigabitEthernet1/0/1

 port link-type trunk

 port trunk permit vlan 100 200

 undo port trunk permit vlan 1

#

interface GigabitEthernet1/0/2

 port access vlan 200

#

interface GigabitEthernet1/0/3

 port access vlan 100

 poe enable

#

Related documentation

·     Internet of Things Command Reference in H3C Access Controllers Command References

·     Internet of Things Configuration Guide in H3C Access Controllers Configuration Guides

·     WLAN Advanced Features Command Reference in H3C Access Controllers Command References

·     WLAN Advanced Features Configuration Guide in H3C Access Controllers Configuration Guides

  • Cloud & AI
  • InterConnect
  • Intelligent Computing
  • Security
  • SMB Products
  • Intelligent Terminal Products
  • Product Support Services
  • Technical Service Solutions
All Services
  • Resource Center
  • Policy
  • Online Help
All Support
  • Become a Partner
  • Partner Resources
  • Partner Business Management
All Partners
  • Profile
  • News & Events
  • Online Exhibition Center
  • Contact Us
All About Us
新华三官网