03-CLI configuration examples (AC+fit AP)

HomeSupportDoc SetsDoc PackagesH3C Wireless Products All-in-One-6W10003-CLI configuration examples (AC+fit AP)
Table of Contents
Related Documents
16-Inter-AC Roaming with Static Client VLAN Allocation Configuration Examples

 

H3C Access Controllers

Comware 7 Inter-AC Roaming with Static Client VLAN Allocation

Configuration Examples

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Copyright © 2022 New H3C Technologies Co., Ltd. All rights reserved.

No part of this manual may be reproduced or transmitted in any form or by any means without prior written consent of New H3C Technologies Co., Ltd.

Except for the trademarks of New H3C Technologies Co., Ltd., any trademarks that may be mentioned in this document are the property of their respective owners.

The information in this document is subject to change without notice.



Introduction

The following information provides an example for configuring inter-AC roaming with client VLAN unchanged.

Prerequisites

The following information applies to Comware 7-based access controllers and access points. Procedures and information in the examples might be slightly different depending on the software or hardware version of the access controllers and access points.

The configuration examples were created and verified in a lab environment, and all the devices were started with the factory default configuration. When you are working on a live network, make sure you understand the potential impact of every command on your network.

The following information is provided based on the assumption that you have basic knowledge of WLAN access and WLAN roaming.

Example: Configuring inter-AC roaming with static client VLAN allocation

Network configuration

As shown in Figure 1, deploy two ACs connected through a switch to provide wireless services. The switch acts as a DHCP server to assign IP addresses to APs and clients. Specify the same VLAN group for each AP to enable clients to roam between the two ACs without changing client VLANs.

Figure 1 Network diagram

Device

Interface

IP address

AC 1

Vlan-int100

192.1.0.2/16

Vlan-int200

192.2.0.2/16

AC 2

Vlan-int100

192.1.0.3/16

Vlan-int400

192.4.0.2/16

Switch

Vlan-int100

192.1.0.1/16

Vlan-int200

192.2.0.1/16

Vlan-int400

192.4.0.1/16

 

Restrictions and guidelines

When you configure inter-AC roaming with static client VLAN allocation, follow these restrictions and guidelines:

·     Make sure the configured SSID, authentication and key management (AKM) mode, and cipher suite are the same on APs for wireless roaming.

·     Use the serial ID labeled on the AP's rear panel to specify an AP.

Procedures

Configuring AC 1

1.     Configure AC interfaces:

# Create VLAN 100 and VLAN-interface 100, and assign IP address 192.1.0.2/16 to the interface. The AC will use this IP address to establish CAPWAP tunnels with APs.

<AC1> system-view

[AC1] vlan 100

[AC1-vlan100] quit

[AC1] interface vlan-interface 100

[AC1-Vlan-interface100] ip address 192.1.0.2 16

[AC1-Vlan-interface100] quit

# Create VLAN 200 and VLAN-interface 200, and assign IP address 192.2.0.2/16 to the interface. The AC will use this interface to communicate with clients.

[AC1] vlan 200

[AC1-vlan200] quit

[AC1] interface vlan-interface 200

[AC1-Vlan-interface200] ip address 192.2.0.2 16

[AC1-Vlan-interface200] quit

# Create VLAN 400. The AC will use this VLAN to forward traffic of clients roamed from AC 2.

[AC1] vlan 400

[AC1-vlan400] quit

# Set the link type of GigabitEthernet 1/0/1 to trunk and assign the port to VLANs 100, 200, and 400.

[AC1] interface gigabitethernet 1/0/1

[AC1-GigabitEthernet1/0/1] port link-type trunk

[AC1-GigabitEthernet1/0/1] port trunk permit vlan 100 200 400

[AC1-GigabitEthernet1/0/1] quit

# Set the link type of GigabitEthernet 1/0/2 to access and assign the port to VLAN 100.

[AC1] interface gigabitethernet 1/0/2

[AC1-GigabitEthernet1/0/2] port link-type access

[AC1-GigabitEthernet1/0/2] port access vlan 100

[AC1-GigabitEthernet1/0/2] quit

2.     Create VLAN group roam, and add VLANs 200 and 400 to the group.

[AC1] vlan-group roam

[AC1-vlan-group-roam] vlan-list 200 400

3.     Configure wireless services:

# Create service template 1.

[AC1] wlan service-template 1

# Set the SSID to service.

[AC1-wlan-st-1] ssid service

# Set the VLAN allocation method for clients to static.

[AC1-wlan-st-1] client vlan-alloc static

# Enable the service template.

[AC1-wlan-st-1] service-template enable

[AC1-wlan-st-1] quit

4.     Configure AP settings:

# Create AP ap1, and specify the AP model and serial ID.

[AC1] wlan ap ap1 model WA4320i-ACN

[AC1-wlan-ap-ap1] serial-id 210235A1GQC14C000225

# Bind service template 1 and VLAN group roam to radio 1 of AP ap1.

[AC1-wlan-ap-ap1] radio 1

[AC1-wlan-ap-ap1-radio-1] service-template 1 vlan-group roam

# Enable radio 1.

[AC1-wlan-ap-ap1-radio-1] radio enable

[AC1-wlan-ap-ap1-radio-1] quit

[AC1-wlan-ap-ap1] quit

5.     Configure wireless roaming:

# Create mobility group 1 and enter its view.

[AC1] wlan mobility group 1

# Specify the source IPv4 address for establishing IACTP tunnels as 192.1.0.2.

[AC1-wlan-mg-1] source ip 192.1.0.2

# Add AC 2 as a mobility group member.

[AC1-wlan-mg-1] member ip 192.1.0.3

# Enable the mobility group.

[AC1-wlan-mg-1] group enable

[AC1-wlan-mg-1] quit

6.     Configure a static route, whose next hop address is 192.1.0.1.

[AC1] ip route-static 0.0.0.0 0.0.0.0 192.1.0.1

Configuring AC 2

1.     Configure AC interfaces:

# Create VLAN 100 and VLAN-interface 100, and assign IP address 192.1.0.3/16 to the interface. The AC will use this IP address to establish CAPWAP tunnels with APs.

<AC2> system-view

[AC2] vlan 100

[AC2-vlan100] quit

[AC2] interface vlan-interface 100

[AC2-Vlan-interface100] ip address 192.1.0.3 16

[AC2-Vlan-interface100] quit

# Create VLAN 200. The AC will use this VLAN to forward traffic of clients roamed from AC 1.

<AC2> system-view

[AC2] vlan 200

[AC2-vlan200] quit

# Create VLAN 400 and VLAN-interface 400, and assign IP address 192.4.0.2/16. The AC will use this interface to communicate with clients.

[AC2] vlan 400

[AC2-vlan400] quit

[AC2] interface vlan-interface 400

[AC2-Vlan-interface400] ip address 192.4.0.2 16

[AC2-Vlan-interface400] quit

# Set the link type of GigabitEthernet 1/0/1 to trunk and assign the port to VLANs 100, 200, and 400.

[AC2] interface gigabitethernet 1/0/1

[AC2-GigabitEthernet1/0/1] port link-type trunk

[AC2-GigabitEthernet1/0/1] port trunk permit vlan 100 200 400

[AC2-GigabitEthernet1/0/1] quit

# Set the link type of GigabitEthernet 1/0/2 to access and assign the port to VLAN 100.

[AC2] interface gigabitethernet 1/0/2

[AC2-GigabitEthernet1/0/2] port link-type access

[AC2-GigabitEthernet1/0/2] port access vlan 100

[AC2-GigabitEthernet1/0/2] quit

2.     Create VLAN group roam, and add VLANs 200 and 400 to the group.

[AC2] vlan-group roam

[AC2-vlan-group-roam] vlan-list 200 400

3.     Configure wireless services:

# Create service template 1.

[AC2] wlan service-template 1

# Set the SSID to service.

[AC2-wlan-st-1] ssid service

# Set the VLAN allocation method for clients to static.

[AC2-wlan-st-1] client vlan-alloc static

# Enable the service template.

[AC2-wlan-st-1] service-template enable

[AC2-wlan-st-1] quit

4.     Configure AP settings:

# Create AP ap2, and specify the AP model and serial ID.

[AC2] wlan ap ap2 model WA4320i-ACN

[AC2-wlan-ap-ap2] serial-id 210235A1GQC14C000224

# Bind service template 1 and VLAN group roam to radio 1 of AP ap2.

[AC2-wlan-ap-ap2] radio 1

[AC2-wlan-ap-ap2-radio-1] service-template 1 vlan-group roam

# Enable radio 1.

[AC2-wlan-ap-ap2-radio-1] radio enable

[AC2-wlan-ap-ap2-radio-1] quit

[AC2-wlan-ap-ap2] quit

5.     Configure wireless roaming:

# Create mobility group 1 and enter its view.

[AC2] wlan mobility group 1

# Specify the source IPv4 address for establishing IACTP tunnels as 192.1.0.3.

[AC2-wlan-mg-1] source ip 192.1.0.3

# Add AC 1 as a mobility group member.

[AC2-wlan-mg-1] member ip 192.1.0.2

# Enable the mobility group.

[AC2-wlan-mg-1] group enable

[AC2-wlan-mg-1] quit

6.     Configure a static route, whose next hop address is 192.1.0.1.

[AC2] ip route-static 0.0.0.0 0.0.0.0 192.1.0.1

Configuring the switch

1.     Configure AC interfaces:

# Create VLAN 100 and VLAN-interface 100, and assign IP address 192.1.0.1/16 to the interface. The switch will use this interface to communicate with AC 1 and AC 2.

<Switch> system-view

[Switch] vlan 100

[Switch-vlan100] quit

[Switch] interface vlan-interface 100

[Switch-Vlan-interface100] ip address 192.1.0.1 16

[Switch-Vlan-interface100] quit

# Create VLAN 200 and VLAN-interface 200, and assign IP address 192.2.0.1/16 to the interface. The switch will use this interface to communicate with clients associated with AC 1.

[Switch] vlan 200

[Switch-vlan200] quit

[Switch] interface vlan-interface 200

[Switch-Vlan-interface200] ip address 192.2.0.1 16

[Switch-Vlan-interface200] quit

# Create VLAN 400 and VLAN-interface 400, and assign IP address 192.4.0.1/16. The AC will use this interface to communicate with clients associated with AC 2.

[Switch] vlan 400

[Switch-vlan400] quit

[Switch] interface vlan-interface 400

[Switch-Vlan-interface400] ip address 192.4.0.1 16

[Switch-Vlan-interface400] quit

# Set the link type of GigabitEthernet 1/0/1 to trunk and assign the port to VLANs 100, 200, and 400.

[Switch] interface gigabitethernet 1/0/1

[Switch-GigabitEthernet1/0/1] port link-type trunk

[Switch-GigabitEthernet1/0/1] port trunk permit vlan 100 200 400

[Switch-GigabitEthernet1/0/1] quit

# Set the link type of GigabitEthernet 1/0/2 to access and assign the port to VLANs 100, 200, 400.

[Switch] interface gigabitethernet 1/0/2

[Switch-GigabitEthernet1/0/2] port link-type trunk

[Switch-GigabitEthernet1/0/2] port trunk permit vlan 100 200 400

[Switch-GigabitEthernet1/0/2] quit

2.     Configure the DHCP server:

# Enable DHCP.

[Switch] dhcp enable

# Create DHCP address pool vlan100, specify subnet 192.1.0.0/16 in the address pool, exclude IP addresses 192.1.0.2 and 192.1.0.3 from dynamic allocation, and specify the gateway IP address as 192.1.0.1.

[Switch] dhcp server ip-pool vlan100

[Switch-dhcp-pool-vlan100] network 192.1.0.0 mask 255.255.0.0

[Switch-dhcp-pool-vlan100] forbidden-ip 192.1.0.2 192.1.0.3

[Switch-dhcp-pool-vlan100] gateway-list 192.1.0.1

[Switch-dhcp-pool-vlan100] quit

# Create DHCP address pool vlan200, specify subnet 192.2.0.0/16 in the address pool, and exclude 192.2.0.2 from dynamic allocation. Specify the gateway address as 192.2.0.1 and specify the address of the DNS server. In this example, the gateway also acts as the DNS server.

[Switch] dhcp server ip-pool vlan200

[Switch-dhcp-pool-vlan200] network 192.2.0.0 mask 255.255.0.0

[Switch-dhcp-pool-vlan200] forbidden-ip 192.2.0.2

[Switch-dhcp-pool-vlan200] gateway-list 192.2.0.1

[Switch-dhcp-pool-vlan200] dns-list 192.2.0.1

[Switch-dhcp-pool-vlan200] quit

# Create DHCP address pool vlan400, specify subnet 192.4.0.0/16 in the address pool, and exclude 192.4.0.2 from dynamic allocation. Specify the gateway address as 192.4.0.1, and specify the address of the DNS server. In this example, the gateway also acts as the DNS server.

[Switch] dhcp server ip-pool vlan400

[Switch-dhcp-pool-vlan400] network 192.4.0.0 mask 255.255.0.0

[Switch-dhcp-pool-vlan400] forbidden-ip 192.4.0.2

[Switch-dhcp-pool-vlan400] gateway-list 192.4.0.1

[Switch-dhcp-pool-vlan400] dns-list 192.4.0.1

[Switch-dhcp-pool-vlan400] quit

Verifying the configuration

# Make a client come online from AC 1.

# Use the display wlan client command to view the client's VLAN and IP address from AC 1.

[AC] display wlan client

Total number of clients: 1

 

MAC address    User name  AP name        RID IP address      IPv6 address   VLAN

68db-ca64-23fd N/A        ap1            1   192.2.0.3                      200

# Make the client roam to AC 2.

# Use the display wlan client command to view the client's VLAN and IP address from AC 2. Verify that the client's VLAN and IP address are not changed after roaming.

[AC] display wlan client

Total number of clients: 1

 

MAC address    User name  AP name        RID IP address      IPv6 address   VLAN

68db-ca64-23fd N/A        ap2            1   192.2.0.3                      200

Configuration files

·     Switch:

#

dhcp enable

#

vlan 100

#

vlan 200

#

vlan 400

#

dhcp server ip-pool vlan100

gateway-list 192.1.0.1

 network 192.1.0.0 mask 255.255.0.0

 forbidden-ip 192.1.0.2

 forbidden-ip 192.1.0.3

#

dhcp server ip-pool vlan200

gateway-list 192.2.0.1

 network 192.2.0.0 mask 255.255.0.0

dns-list 192.2.0.1

 forbidden-ip 192.2.0.2

#

dhcp server ip-pool vlan400

gateway-list 192.4.0.1

 network 192.4.0.0 mask 255.255.0.0

dns-list 192.4.0.1

 forbidden-ip 192.4.0.2

#

interface Vlan-interface100

 ip address 192.1.0.1 255.255.0.0

#

interface Vlan-interface200

 ip address 192.2.0.1 255.255.0.0

#

interface Vlan-interface400

 ip address 192.4.0.1 255.255.0.0

#

interface GigabitEthernet1/0/1

 port link-type trunk

 port trunk permit vlan 100 200 400

#

interface GigabitEthernet1/0/2

 port link-type trunk

 port trunk permit vlan 100 200 400

#

·     AC 1:

#

vlan 100

#

vlan 200

#

vlan 400

#

vlan-group roam

 vlan-list 200 400

#

wlan service-template 1

 ssid service

client vlan-alloc static

 service-template enable

#

interface Vlan-interface100

 ip address 192.1.0.2 255.255.0.0

#

interface Vlan-interface200

 ip address 192.2.0.2 255.255.0.0

#

interface GigabitEthernet1/0/1

 port link-type trunk

 port trunk permit vlan 100 200 400

#

interface GigabitEthernet1/0/2

 port link-type access

 port access vlan 100

#

ip route-static 0.0.0.0 0.0.0.0 192.1.0.1

#

wlan ap ap1 model WA4320i-ACN

 serial-id 210235A1GQC14C000225

 radio 1

  radio enable

  service-template 1 vlan-group roam

 radio 2

#

wlan mobility group 1

 source ip 192.1.0.2

 member ip 192.1.0.3

 group enable

·     AC 2:

#

vlan 100

#

vlan 200

#

vlan 400

#

vlan-group roam

 vlan-list 200 400

#

wlan service-template 1

 ssid service

client vlan-alloc static

 service-template enable

#

interface Vlan-interface100

 ip address 192.1.0.3 255.255.0.0

#

interface Vlan-interface400

 ip address 192.4.0.2 255.255.0.0

#

interface GigabitEthernet1/0/1

 port link-type trunk

 port trunk permit vlan 100 200 400

#

interface GigabitEthernet1/0/2

 port link-type access

 port access vlan 100

#

ip route-static 0.0.0.0 0.0.0.0 192.1.0.1

#

wlan ap ap1 model WA4320i-ACN

 serial-id 210235A1GQC14C000225

 radio 1

  radio enable

  service-template 1 vlan-group roam

 radio 2

#

wlan mobility group 1

 source ip 192.1.0.3

 member ip 192.1.0.2

 group enable

Related documentation

·     AP and WT Management Command Reference in H3C Access Controllers Command References

·     AP and WT Management Configuration Guide in H3C Access Controllers Configuration Guides

·     User Access and Authentication Command Reference in H3C Access Controllers Command References

·     User Access and Authentication Configuration Guide in H3C Access Controllers Configuration Guides

·     WLAN Access Command Reference in H3C Access Controllers Command References

·     WLAN Access Configuration Guide in H3C Access Controllers Configuration Guides

  • Cloud & AI
  • InterConnect
  • Intelligent Computing
  • Security
  • SMB Products
  • Intelligent Terminal Products
  • Product Support Services
  • Technical Service Solutions
All Services
  • Resource Center
  • Policy
  • Online Help
All Support
  • Become a Partner
  • Partner Resources
  • Partner Business Management
All Partners
  • Profile
  • News & Events
  • Online Exhibition Center
  • Contact Us
All About Us
新华三官网