03-CLI configuration examples (AC+fit AP)

HomeSupportDoc SetsDoc PackagesH3C Wireless Products All-in-One-6W10003-CLI configuration examples (AC+fit AP)
Table of Contents
Related Documents
01-HTTPS Login Configuration Examples
Title Size Download
01-HTTPS Login Configuration Examples 77.54 KB

 

H3C Access Controllers

Comware 7 HTTPS Login

Configuration Examples

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Copyright © 2022 New H3C Technologies Co., Ltd. All rights reserved.

No part of this manual may be reproduced or transmitted in any form or by any means without prior written consent of New H3C Technologies Co., Ltd.

Except for the trademarks of New H3C Technologies Co., Ltd., any trademarks that may be mentioned in this document are the property of their respective owners.



Introduction

The following information provides an HTTPS login configuration example.

Prerequisites

This document applies to Comware 7-based access controllers and access points. Procedures and information in the examples might be slightly different depending on the software or hardware version of the access controllers and access points.

The configuration examples in this document were created and verified in a lab environment, and all the devices were started with the factory default configuration. When you are working on a live network, make sure you understand the potential impact of every command on your network.

This document assumes that you have basic knowledge of WLAN access and HTTPS login.

Example: Configuring HTTPS login

Network requirements

As shown in Figure 1, configure the switch and the AC to achieve the following goals:

·     The AC allows only authorized users to access the Web interface by using HTTPS.

·     The switch acts as the DHCP server to assign IP addresses to the AP and client.

·     The AP and AC use VLAN 100 to establish a CAPWAP tunnel.

·     The client uses VLAN 200 to access the wireless network.

Figure 1 Network diagram

 

Configuration restrictions and guidelines

When you configure HTTPS login, follow these restrictions and guidelines:

·     Use the serial ID labeled on the AP's rear panel to specify an AP.

·     In this example, the CA certificate and local certificate for the AC are transferred in advance to the AC in offline mode. Make sure the certificates have not expired.

·     Only a certificate file in the PKCS#12 or PEM format might contain key pairs.

Configuration procedures

Configuring the AC

1.     Configure interfaces of the AC:

# Create VLAN 100 and VLAN-interface 100, and assign an IP address to the VLAN interface. The AC will use this IP address to establish CAPWAP tunnels with APs.

<AC> system-view

[AC] vlan 100

[AC-vlan100] quit

[AC] interface vlan-interface 100

[AC-Vlan-interface100] ip address 192.1.0.1 16

[AC-Vlan-interface100] quit

# Create VLAN 200 and VLAN-interface 200, and assign an IP address to the VLAN interface. The AC will use VLAN 200 for client access.

[AC] vlan 200

[AC-vlan200] quit

[AC] interface vlan-interface 200

[AC-Vlan-interface200] ip address 192.2.0.1 16

[AC-Vlan-interface200] quit

# Configure the interface that is connected to the switch as a trunk port, and assign the port to VLAN 100 and VLAN 200.

[AC] interface gigabitethernet 1/0/1

[AC-GigabitEthernet1/0/1] port link-type trunk

[AC-GigabitEthernet1/0/1] port trunk permit vlan 100 200

[AC-GigabitEthernet1/0/1] quit

2.     Configure the wireless service:

# Create wireless service template 1 and enter its view.

[AC] wlan service-template 1

# Set the SSID to service.

[AC-wlan-st-1] ssid service

# Assign clients coming online through service template 1 to VLAN 200.

[AC-wlan-st-1] vlan 200

# Enable service template 1.

[AC-wlan-st-1] service-template enable

[AC-wlan-st-1] quit

3.     Configure the AP:

# Create AP ap1. Set the model and serial ID.

[AC] wlan ap ap1 model WA4320-ACN

[AC-wlan-ap-ap1] serial-id 210235A1GUC158005091

# Enter the view of radio 1 and bind service template service with radio 1.

[AC-wlan-ap-ap1] radio 1

[AC-wlan-ap-ap1-radio-1] service-template 1

# Enable radio 1.

[AC-wlan-ap-ap1-radio-1] radio enable

[AC-wlan-ap-ap1-radio-1] quit

[AC-wlan-ap-ap1] quit

4.     Configure HTTPS login:

# Create PKI domain 1 and disable CRL checking. (If CRL checking is required, enable CRL checking.)

[AC] pki domain 1

[AC-pki-domain-1] undo crl check enable

[AC-pki-domain-1] quit

# Import CA certificate file root.pem in PEM format to PKI domain 1.

[AC] pki import domain 1 pem ca filename root.pem

Please input the password:****

# Import local certificate file radius.pem in PEM format to PKI domain 1.

[AC] pki import domain 1 pem local filename radius.pem

Please input the password:****

# Create SSL server policy myssl and specify PKI domain 1 for the policy.

[AC] ssl server-policy myssl

[AC-ssl-server-policy-myssl] pki-domain 1

[AC-ssl-server-policy-myssl] quit

# Apply SSL server policy myssl to the HTTPS service.

[AC] ip https ssl-server-policy myssl

# Enable the HTTPS service.

[AC] ip https enable

# Add device management user usera and set the password. Assign the HTTPS service type and network-admin user role to the user.

[AC] local-user usera

[AC-luser-manage-usera] password simple 123

[AC-luser-manage-usera] service-type https

[AC-luser-manage-usera] authorization-attribute user-role network-admin

[AC-luser-manage-usera] quit

Configuring the switch

1.     Configure interfaces of the switch:

# Create VLAN 100 and VLAN-interface 100, and assign an IP address to the VLAN interface. The switch will use VLAN 100 to forward AC traffic.

<Switch> system-view

[Switch] vlan 100

[Switch-vlan100] quit

[Switch] interface vlan-interface 100

[Switch-Vlan-interface100] ip address 192.1.0.2 16

[Switch-Vlan-interface100] quit

# Create VLAN 200 and VLAN-interface 200, and assign an IP address to the VLAN interface. The switch will use VLAN 200 to forward client traffic.

[Switch] vlan 200

[Switch-vlan200] quit

[Switch] interface vlan-interface 200

[Switch-Vlan-interface200] ip address 192.2.0.2 16

[Switch-Vlan-interface200] quit

# Configure the interface that is connected to the AC as a trunk port, and assign the port to VLAN 100 and VLAN 200.

[Switch] interface gigabitethernet 1/0/1

[Switch-GigabitEthernet1/0/1] port link-type trunk

[Switch-GigabitEthernet1/0/1] port trunk permit vlan 100 200

[Switch-GigabitEthernet1/0/1] quit

# Configure the interface that is connected to the AP as a trunk port, set its PVID to VLAN 100, and assign it to VLAN 100.

[Switch] interface gigabitethernet 1/0/2

[Switch-GigabitEthernet1/0/2] port link-type trunk

[Switch-GigabitEthernet1/0/2] port trunk pvid vlan 100

[Switch-GigabitEthernet1/0/2] port trunk permit vlan 100

# Enable PoE on the interface that is connected to the AP.

[Switch-GigabitEthernet1/0/2] poe enable

[Switch-GigabitEthernet1/0/2] quit

2.     Configure the DHCP server:

# Enable the DHCP service.

[Switch] dhcp enable

# Create DHCP address pool 100. Specify the 192.1.0.0/16 subnet and the 192.1.0.2 gateway for the pool.

[Switch] dhcp server ip-pool 100

[Switch-dhcp-pool-100] network 192.1.0.0 16

[Switch-dhcp-pool-100] gateway-list 192.1.0.2

# Use option 43 to assign the IP address of the AC to the AP. (The last four bytes of the hexadecimal option content are c0010001, which represents 192.1.0.1.)

[Switch-dhcp-pool-100] option 43 hex 8007000001c0010001

[Switch-dhcp-pool-100] quit

# Create DHCP address pool 200. Specify subnet 192.2.0.0/16, gateway 192.2.0.2, and DNS server 192.2.0.2 for the pool. In this example, the DNS server and gateway is assumed by the same device.

[Switch] dhcp server ip-pool 200

[Switch-dhcp-pool-200] network 192.2.0.0 16

[Switch-dhcp-pool-200] gateway-list 192.2.0.2

[Switch-dhcp-pool-200] dns-list 192.2.0.2

[Switch-dhcp-pool-200] quit

Verifying the configuration

# On the client, launch the Web browser and enter https://192.2.0.1 in the address bar. (Details not shown.)

# When the Web login page appears, enter username usera and password 123 to log in to the Web interface of the AC. (Details not shown.)

Configuration files

·     AC:

#

vlan 100

#

vlan 200

#

wlan service-template 1

 ssid service

 vlan 200

 service-template enable

#

interface Vlan-interface100

 ip address 192.1.0.1 255.255.0.0

#

interface Vlan-interface200

 ip address 192.2.0.1 255.255.0.0

#

interface GigabitEthernet1/0/1

 port link-type trunk

 port trunk permit vlan 100 200

#

local-user usera class manage

 password hash $h$6$FOrfdnZ2QRORxu7o$OK/dcQ/N/S7m+zrhpyh+xDm2aerS7vvN8WwFVuhQuk8hdeFjDtqzPJthCen1ylElTkE7OqbCG5YhiRnjHtEr0g==

 service-type https

 authorization-attribute user-role network-admin

#

pki domain 1

undo crl check enable

#

ssl server-policy myssl

 pki-domain 1

#

 ip https ssl-server-policy myssl

 ip https enable

#

wlan ap ap1 model WA4320-ACN

 serial-id 210235A1GUC158005091

 vlan 1

 radio 1

  radio enable

  service-template 1

#

·     Switch:

#

 dhcp enable

#

vlan 100

#

vlan 200

#

interface Vlan-interface100

 ip address 192.1.0.2 255.255.0.0

#

interface Vlan-interface200

 ip address 192.2.0.2 255.255.0.0

#

dhcp server ip-pool 100

 gateway-list 192.1.0.2

 network 192.1.0.0 mask 255.255.0.0

 option 43 hex 8007000001C0010001

#

dhcp server ip-pool 200

 gateway-list 192.2.0.2

 network 192.2.0.0 mask 255.255.0.0

 dns-list 192.2.1.2

#

interface GigabitEthernet1/0/1

port link-type trunk

 port trunk permit vlan 100 200

#

interface GigabitEthernet1/0/2

poe enable

port link-type trunk

 port trunk permit vlan 100

 port trunk pvid vlan 100

#

Related documentation

·     Fundamentals Command Reference in H3C Access Controllers Command References

·     Fundamentals Configuration Guide in H3C Access Controllers Configuration Guides

·     Security Command Reference in H3C Access Controllers Command References

·     Security Configuration Guide in H3C Access Controllers Configuration Guides

·     AP and WT Management Command Reference in H3C Access Controllers Command References

·     AP and WT Management Configuration Guide in H3C Access Controllers Configuration Guides

  • Cloud & AI
  • InterConnect
  • Intelligent Computing
  • Security
  • SMB Products
  • Intelligent Terminal Products
  • Product Support Services
  • Technical Service Solutions
All Services
  • Resource Center
  • Policy
  • Online Help
All Support
  • Become a Partner
  • Partner Resources
  • Partner Business Management
All Partners
  • Profile
  • News & Events
  • Online Exhibition Center
  • Contact Us
All About Us
新华三官网