03-CLI configuration examples (AC+fit AP)

HomeSupportDoc SetsDoc PackagesH3C Wireless Products All-in-One-6W10003-CLI configuration examples (AC+fit AP)
Table of Contents
Related Documents
12-WPA3-SAE PSK Encryption Configuration Examples

 

H3C Access Controllers

Comware 7 WPA3-SAE PSK Encryption

Configuration Examples

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Copyright © 2022 New H3C Technologies Co., Ltd. All rights reserved.

No part of this manual may be reproduced or transmitted in any form or by any means without prior written consent of New H3C Technologies Co., Ltd.

Except for the trademarks of New H3C Technologies Co., Ltd., any trademarks that may be mentioned in this document are the property of their respective owners.

The information in this document is subject to change without notice.



Introduction

The following information provides an example for configuring PSK encryption with the WPA3-SAE security mode.

Prerequisites

The following information applies to Comware 7-based access controllers and access points. Procedures and information in the examples might be slightly different depending on the software or hardware version of the access controllers and access points.

The configuration examples were created and verified in a lab environment, and all the devices were started with the factory default configuration. When you are working on a live network, make sure you understand the potential impact of every command on your network.

The following information is provided based on the assumption that you have basic knowledge of WLAN access and WLAN security.

Example: Configuring PSK encryption with the WPA3-SAE security mode

Network configuration

As shown in Figure 1, the switch acts as a DHCP server to assign IP addresses to the AP and the client. Perform the following tasks:

·     Configure PSK on the AC to enable the client to use PSK for encryption.

·     Configure open system authentication and bypass authentication so that the client can access the WLAN without being authenticated.

·     Configure PSK as the authentication and key management (AKM) mode.

·     Set the cipher suite to CCMP.

·     Set the security IE to RSN.

·     Set the security mode to WPA3-SAE.

Figure 1 Network diagram

 

Restrictions and guidelines

When you configure PSK encryption with the WPA3-SAE security mode, follow these restrictions and guidelines:

·     Use the serial ID labeled on the AP's rear panel to specify an AP.

·     Configure a pre-shared key if the AKM mode is PSK.

Procedures

Configuring the AC

1.     Configure AC interfaces:

# Create VLAN 100 and VLAN-interface 100, and assign an IP address to the VLAN interface. The AC will use this IP address to establish a CAPWAP tunnel with the AP.

<AC> system-view

[AC] vlan 100

[AC-vlan100] quit

[AC] interface vlan-interface 100

[AC-Vlan-interface100] ip address 192.1.1.1 16

[AC-Vlan-interface100] quit

# Create VLAN 200 and VLAN-interface 200, and assign an IP address to the VLAN interface. The client will use this VLAN to access the WLAN.

[AC] vlan 200

[AC-vlan200] quit

[AC] interface vlan-interface 200

[AC-Vlan-interface200] ip address 192.2.1.1 24

[AC-Vlan-interface200] quit

# Configure GigabitEthernet 1/0/1 that connects the AC to the switch as a trunk port, remove the port from VLAN 1, set the PVID to VLAN 100, and assign the port to VLANs 100 and 200.

[AC] interface gigabitethernet 1/0/1

[AC-GigabitEthernet1/0/1] port link-type trunk

[AC-GigabitEthernet1/0/1] undo port trunk permit vlan 1

[AC-GigabitEthernet1/0/1] port trunk permit vlan 100 200

[AC-GigabitEthernet1/0/1] port trunk pvid vlan 100

[AC-GigabitEthernet1/0/1] quit

2.     Configure wireless services:

# Create service template wpa3_personal and enter its view.

[AC] wlan service-template wpa3_personal

# Configure the SSID as wpa3_personal.

[AC-wlan-st-wpa3_personal] ssid wpa3_personal

# Assign clients coming online through the service template to VLAN 200.

[AC-wlan-st-wpa3_personal] vlan 200

# Set the AKM mode to PSK and configure simple character string of 12345678 as the PSK.

[AC-wlan-st-wpa3_personal] akm mode psk

[AC-wlan-st-wpa3_personal] preshared-key pass-phrase simple 12345678

# Set the cipher suite to CCMP and set the security IE to RSN.

[AC-wlan-st-wpa3_personal] cipher-suite ccmp

[AC-wlan-st-wpa3_personal] security-ie rsn

# Set the WPA3 security mode to personal (WPA3-SAE) and specify the mandatory mode.

[AC-wlan-st-wpa3_personal] wpa3 personal mandatory

# Enable mandatory management frame protection.

[AC-wlan-st-wpa3_personal] pmf mandatory

# Enable the service template.

[AC-wlan-st-wpa3_personal] service-template enable

[AC-wlan-st-wpa3_personal] quit

3.     Configure the AP:

# Create manual AP office, and specify the AP model and serial ID.

[AC] wlan ap office model WA6638

[AC-wlan-ap-office] serial-id 219801A24F8198E00012

# Enter radio view of radio 2.

[AC-wlan-ap-office] radio 2

# Bind service template wpa3_personal to radio 2, and then enable the radio.

[AC-wlan-ap-office-radio-2] service-template wpa3_personal

[AC-wlan-ap-office-radio-2] radio enable

[AC-wlan-ap-office-radio-2] quit

[AC-wlan-ap-office] quit

Configuring the switch

1.     Configure switch interfaces:

# Create VLAN 100 and VLAN-interface 100, and assign an IP address to the VLAN interface. The switch will use VLAN 100 to forward packets between the AC and the AP.

<Switch> system-view

[Switch] vlan 100

[Switch-vlan100] quit

[Switch] interface vlan-interface 100

[Switch-Vlan-interface100] ip address 192.1.1.2 16

[Switch-Vlan-interface100] quit

# Create VLAN 200 and VLAN-interface 200, and assign an IP address to the VLAN interface. The switch will use VLAN 100 to forward client traffic.

[Switch] vlan 200

[Switch-vlan200] quit

[Switch] interface vlan-interface 200

[Switch-Vlan-interface200] ip address 192.2.1.2 24

[Switch-Vlan-interface200] quit

# Configure GigabitEthernet 1/0/1 that connects the switch to the AC as a trunk port, remove the port from VLAN 1, set the PVID to VLAN 100, and assign the port to VLANs 100, and 200.

[Switch] interface gigabitethernet 1/0/1

[Switch-GigabitEthernet1/0/1] port link-type trunk

[Switch-GigabitEthernet1/0/1] undo port trunk permit vlan 1

[Switch-GigabitEthernet1/0/1] port trunk permit vlan 100 200

[Switch-GigabitEthernet1/0/1] port trunk pvid vlan 100

[Switch-GigabitEthernet1/0/1] quit

# Configure GigabitEthernet 1/0/2 that connects the switch to the AP as an access port, and assign the port to VLAN 100.

[Switch] interface gigabitethernet 1/0/2

[Switch-GigabitEthernet1/0/2] port link-type access

[Switch-GigabitEthernet1/0/2] port access vlan 100

# Enable PoE on GigabitEthernet 1/0/2.

[Switch-GigabitEthernet1/0/2] poe enable

[Switch-GigabitEthernet1/0/2] quit

2.     Configure DHCP:

# Enable DHCP.

[Switch] dhcp enable

# Create DHCP address pool vlan100 to assign an IP address to the AP, specify subnet 192.1.0.0/16 in the DHCP address pool, and specify the gateway address as 192.1.1.2.

[Switch] dhcp server ip-pool vlan100

[Switch-dhcp-pool-vlan100] network 192.1.0.0 mask 255.255.0.0

[Switch-dhcp-pool-vlan100] gateway-list 192.1.1.2

[Switch-dhcp-pool-vlan100] quit

# Create DHCP address pool vlan200 to assign an IP address to the AP, and specify subnet 192.2.1.0/24 in the DHCP address pool. Specify the gateway address as 192.2.1.2 and specify the DNS server address in the DHCP address pool. In this example, the gateway also acts as the DNS server.

[Switch] dhcp server ip-pool vlan200

[Switch-dhcp-pool-vlan200] network 192.2.1.0 mask 255.255.255.0

[Switch-dhcp-pool-vlan200] gateway-list 192.2.1.2

[Switch-dhcp-pool-vlan200] dns-list 192.2.1.2

[Switch-dhcp-pool-vlan200] quit

Verifying the configuration

# Verify that the client has been associated with the WLAN and the AKM mode is PSK.

[AC] display wlan client verbose

Total number of clients: 1

 

 MAC address                       : ccc9-5de2-512d

 IPv4 address                      : 192.2.1.3

 IPv6 address                      : N/A

 Username                          : N/A

 AID                               : 1

 AP ID                             : 1

 AP name                           : office

 Radio ID                          : 2

 Channel                           : 149

 SSID                              : wpa3_personal

 BSSID                             : f474-8879-ea70

 VLAN ID                           : 200

 Sleep count                       : 0

 Wireless mode                     : 802.11ax

 Channel bandwidth                 : 80MHz

 SM power save                     : Disabled

 Short GI for 20MHz                : Supported

 Short GI for 40MHz                : Supported

 Short GI for 80MHz                : Supported

 Short GI for 160/80+80MHz         : Not supported

 STBC RX capability                : Not supported

 STBC TX capability                : Not supported

 LDPC RX capability                : Supported

 Beamformee STS capability         : N/A

 Number of Sounding Dimensions     : N/A

 SU beamformee capability          : Not supported

 MU beamformee capability          : Not supported

 Block Ack                         : N/A

 Supported VHT-MCS set             : NSS1 0, 1, 2, 3, 4, 5, 6, 7, 8, 9

                                     NSS2 0, 1, 2, 3, 4, 5, 6, 7, 8, 9

 Supported HT MCS set              : 0, 1, 2, 3, 4, 5, 6, 7,

                                     8, 9, 10, 11, 12, 13, 14,

                                     15

 Supported rates                   : 6, 9, 12, 18, 24, 36,

                                     48, 54 Mbps

 5G 40And80MHz Channel bandwidth   : Supported

 5G 160MHz Channel bandwidth       : Not Supported

 5G 8080MHz Channel bandwidth      : Not Supported

 OFDMA random access RUs           : Not supported

 Supported HE-MCS set              : NSS1 0, 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11

                                     NSS2 0, 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11

 TWT scheduled                     : no

 QoS mode                          : WMM

 Listen interval                   : 20

 RSSI                              : 0

 Rx/Tx rate                        : 0/0 Mbps

 Speed                             : N/A

 Authentication method             : SAE

 Security mode                     : RSN

 AKM mode                          : PSK

 Cipher suite                      : CCMP

 User authentication mode          : Bypass

 WPA3 status                       : Enabled

 Authorization CAR                 : N/A

 Authorization ACL ID              : N/A

 Authorization user profile        : N/A

 Roam status                       : N/A

 Key derivation                    : SHA256

 PMF status                        : Enabled

 Forwarding policy name            : Not configured

 Online time                       : 0days 0hours 0minutes 10seconds

 FT status                         : Inactive

 BTM mode                          : Inactive

Configuration files

·     AC:

#

vlan 100

#

vlan 200

#

wlan service-template wpa3_personal

 ssid wpa3_personal

vlan 200

akm mode psk

 preshared-key pass-phrase cipher $c$3$N//5BVbsOqdBTxi+7MJZKT6Zqh5MAmYs2ZzM

 cipher-suite ccmp

 wpa3 personal mandatory

 pmf mandatory

 security-ie rsn

service-template enable

#

interface Vlan-interface100

 ip address 192.1.1.1 255.255.0.0

#

interface Vlan-interface200

 ip address 192.2.1.1 255.255.255.0

#

interface GigabitEthernet1/0/1

 port link-type trunk

 undo port trunk permit vlan 1

 port trunk permit vlan 100 200

 port trunk pvid vlan 100

#

wlan ap office model WA6638

 serial-id 219801A24F8198E00012

 radio 1

 radio 2

  radio enable

  service-template wpa3_personal

 radio 3

 gigabitethernet 1

 ten-gigabitethernet 1

#

·     Switch:

#

 dhcp enable

#

vlan 100

#

vlan 200

#

dhcp server ip-pool vlan100

 gateway-list 192.1.1.2

 network 192.1.0.0 mask 255.255.0.0

#

dhcp server ip-pool vlan200

 gateway-list 192.2.1.2

 network 192.2.1.0 mask 255.255.255.0

 dns-list 192.2.1.2

#

interface GigabitEthernet1/0/1

port link-type trunk

undo port trunk permit vlan 1

 port trunk permit vlan 100 200

 port trunk pvid vlan 100

#

interface GigabitEthernet1/0/2

port link-type trunk

 port trunk permit vlan 100

poe enable

#

Related documentation

·     WLAN Access Command Reference in H3C Access Controllers Command References

·     WLAN Access Configuration Guide in H3C Access Controllers Configuration Guides

·     WLAN Authentication Command Reference in H3C Access Controllers Command References

·     WLAN Authentication Configuration Guide in H3C Access Controllers Configuration Guides

  • Cloud & AI
  • InterConnect
  • Intelligent Computing
  • Security
  • SMB Products
  • Intelligent Terminal Products
  • Product Support Services
  • Technical Service Solutions
All Services
  • Resource Center
  • Policy
  • Online Help
All Support
  • Become a Partner
  • Partner Resources
  • Partner Business Management
All Partners
  • Profile
  • News & Events
  • Online Exhibition Center
  • Contact Us
All About Us
新华三官网