03-CLI configuration examples (AC+fit AP)

HomeSupportDoc SetsDoc PackagesH3C Wireless Products All-in-One-6W10003-CLI configuration examples (AC+fit AP)
Table of Contents
Related Documents
23-Local Portal Authentication and SSID-based Authentication Page Pushing Configuration Examples

 

H3C Access Controllers

Comware 7 Local Portal Authentication and SSID-based Authentication Page Pushing

Configuration Examples

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Copyright © 2022 New H3C Technologies Co., Ltd. All rights reserved.

No part of this manual may be reproduced or transmitted in any form or by any means without prior written consent of New H3C Technologies Co., Ltd.

Except for the trademarks of New H3C Technologies Co., Ltd., any trademarks that may be mentioned in this document are the property of their respective owners.

The information in this document is subject to change without notice.



Introduction

The following information provides examples for configuring local portal authentication and SSID-based authentication page pushing on the AC.

Prerequisites

The following information applies to Comware 7-based access controllers and access points. Procedures and information in the examples might be slightly different depending on the software or hardware version of the access controllers and access points.

The configuration examples were created and verified in a lab environment, and all the devices were started with the factory default configuration. When you are working on a live network, make sure you understand the potential impact of every command on your network.

The following information is provided based on the assumption that you have basic knowledge of portal authentication.

Example: Configuring local portal authentication and SSID-based authentication page pushing

Network configuration

As shown in Figure 1, the AP and the client obtain IP addresses from the DHCP server. The access device AC acts as the portal Web server and the portal authentication server.

Configure the devices to meet the following requirements:

·     The AC provides direct portal authentication for the client. Before passing the authentication, the client can access only the portal Web server. After passing the authentication, the client can access other network resources.

·     The client can access network resources through any Layer 2 ports in its access VLAN without re-authentication.

Figure 1 Network diagram

 

Analysis

To allow an authenticated user to access network resources on any Layer 2 ports in its access VLAN without re-authentication, you must enable the portal roaming feature.

In wireless networks where the AP forwards client traffic, the AC does not have ARP entries for clients. Therefore, the AC cannot check the validity of portal clients by using ARP entries. To ensure that valid users can perform portal authentication, you must enable wireless client validity check on the AC.

To avoid possible authentication failure caused by frequent logins and logouts of portal clients in a short time, disable the Rule ARP entry feature.

Restrictions and guidelines

Use the serial ID labeled on the AP's rear panel to specify an AP.

By default, the portal Web server URL redirected to users does carry parameters. You can configure the parameters to be carried in the redirection URL as needed.

Procedures

Configuring the AC

1.     Configuring VLANs and interfaces:

# Create VLAN 100 and VLAN-interface 100. Assign the VLAN interface an IP address. The AC will use this IP address to establish a CAPWAP tunnel with the AP.

<AC> system-view

[AC] vlan 100

[AC-vlan100] quit

[AC] interface vlan-interface 100

[AC-Vlan-interface100] ip address 2.2.1.1 24

[AC-Vlan-interface100] quit

# Create VLAN 200 and VLAN-interface 200. Assign the VLAN interface an IP address. This VLAN will be used for wireless client access.

[AC] vlan 200

[AC-vlan200] quit

[AC] interface vlan-interface 200

[AC-Vlan-interface200] ip address 2.2.2.1 24

[AC-Vlan-interface200] quit

# Configure the interface connected to the switch (GigabitEthernet 1/0/1) as a trunk port, and add the port to VLAN 100 and VLAN 200.

[AC] interface gigabitethernet 1/0/1

[AC-GigabitEthernet1/0/1] port link-type trunk

[AC-GigabitEthernet1/0/1] port trunk permit vlan 100 200

[AC-GigabitEthernet1/0/1] quit

2.     Configure the wireless service:

# Create a service template named st1 and enter its view.

[AC] wlan service-template st1

# Configure the SSID of the service template as service.

[AC-wlan-st-st1] ssid service

# Assign clients coming online through the service template to VLAN 200.

[AC-wlan-st-st1] vlan 200

[AC-wlan-st-st1] quit

# Create a service template named st2 and enter its view.

[AC] wlan service-template st2

# Configure the SSID of the service template as service2.

[AC-wlan-st-st2] ssid service2

# Assign clients coming online through the service template to VLAN 200.

[AC-wlan-st-st2] vlan 200

[AC-wlan-st-st2] quit

3.     Configure the AP:

# Create an AP named office. Specify the AP model and serial ID.

[AC] wlan ap office model WA4320i-ACN

[AC-wlan-ap-office] serial-id 219801A0CNC138011454

# Enter the view of radio 2.

[AC-wlan-ap-office] radio 2

# Bind service template st1 and service template st2 to radio 2 and enable the radio.

[AC-wlan-ap-office-radio-2] service-template st1

[AC-wlan-ap-office-radio-2] service-template st2

[AC-wlan-ap-office-radio-2] radio enable

[AC-wlan-ap-office-radio-2] quit

[AC-wlan-ap-office] quit

4.     Configure the authentication domain:

# Create an ISP domain named dm1 and enter its view.

[AC] domain dm1

# Configure the authentication method as local, and authorization and accounting methods as none for portal users.

[AC-isp-dm1] authentication portal local

[AC-isp-dm1] authorization portal none

[AC-isp-dm1] accounting portal none

# Configure the idle cut feature for users. Log out a user if the user's traffic is less than 1024 bytes in 15 minutes.

[AC-isp-dm1] authorization-attribute idle-cut 15 1024

[AC-isp-dm1] quit

5.     Configure portal authentication:

# Create a portal Web server named newpt and specify the server's URL as http://2.2.2.1/portal.

[AC] portal web-server newpt

[AC-portal-websvr-newpt] url http://2.2.2.1/portal

# Configure the portal redirection URL to carry the wlanuserip parameter and the parameter value is the user's IP address.

[AC-portal-websvr-newpt] url-parameter wlanuserip source-address

[AC-portal-websvr-newpt] quit

# Create an HTTP-based local portal Web service and enter its view.

[AC] portal local-web-server http

# Configure SSID service to use authentication page file abc.zip and SSID service2 to use authentication page file http.zip. (The files must already exist in the root directory of the storage medium of the AC.)

[AC–portal-local-websvr-http] default-logon-page abc.zip

[AC–portal-local-websvr-http] logon-page bind ssid service2 file http.zip

[AC–portal-local-websvr-http] quit

# Configure a local user for local portal authentication.

[AC] local-user 123 class network

[AC-luser-network-123] password simple 123

[AC-luser-network-123] service-type portal

[AC-luser-network-123] quit

# Enable the portal roaming feature.

[AC] portal roaming enable

# Disable the Rule ARP entry feature for portal clients.

[AC] undo portal refresh arp enable

# Enable the wireless client validity check feature.

[AC] portal host-check enable

6.     Configure service template st1:

# Enable direct portal authentication on service template st1.

[AC] wlan service-template st1

[AC–wlan-st-st1] portal enable method direct

# Configure the authentication domain for portal users as dm1.

[AC-wlan-st-st1] portal domain dm1

# Specify portal Web server newpt on service template st1.

[AC–wlan-st-st1] portal apply web-server newpt

[AC–wlan-st-st1] quit

# Enable service template st1.

[AC–wlan-st-st1] service-template enable

[AC-wlan-st-st1] quit

7.     Configure service template st2:

# Enable direct portal authentication on service template st2.

[AC] wlan service-template st2

[AC–wlan-st-st2] portal enable method direct

# Configure the authentication domain for portal users as dm1.

[AC-wlan-st-st2] portal domain dm1

# Specify portal Web server newpt on service template st2.

[AC–wlan-st-st2] portal apply web-server newpt

[AC–wlan-st-st2] quit

# Enable service template st2.

[AC–wlan-st-st2] service-template enable

[AC-wlan-st-st2] quit

Configuring the switch

# Create VLAN 100. The switch will use this VLAN to forward traffic on the CAPWAP tunnel between the AC and the AP.

<Switch> system-view

[Switch] vlan 100

[Switch-vlan100] quit

# Create VLAN 200. The switch will use this VLAN to forward traffic of wireless clients.

[Switch] vlan 200

[Switch-vlan200] quit

# Create VLAN 2.

[Switch] vlan 2

[Switch-vlan2] quit

# Configure GigabitEthernet 1/0/1 (the port connected to the AC) as a trunk port. Assign the trunk port to VLAN 100 and VLAN 200.

[Switch] interface gigabitethernet 1/0/1

[Switch-GigabitEthernet1/0/1] port link-type trunk

[Switch-GigabitEthernet1/0/1] port trunk permit vlan 100 200

[Switch-GigabitEthernet1/0/1] quit

# Configure GigabitEthernet 1/0/2 (the port connected to the AP) as an access port. Assign the access port to VLAN 100.

[Switch] interface gigabitethernet 1/0/2

[Switch-GigabitEthernet1/0/2] port link-type access

[Switch-GigabitEthernet1/0/2] port access vlan 100

# Enable PoE on the access port.

[Switch-GigabitEthernet1/0/2] poe enable

[Switch-GigabitEthernet1/0/2] quit

# Configure GigabitEthernet 1/0/3 (the port connected to the DHCP server) as an access port. Assign the access port to VLAN 2.

[Switch] interface gigabitethernet 1/0/3

[Switch-GigabitEthernet1/0/3] port link-type access

[Switch-GigabitEthernet1/0/3] port access vlan 2

[Switch-GigabitEthernet1/0/3] quit

# Assign an IP address to VLAN interface 200.

[Switch] interface vlan-interface 200

[Switch-Vlan-interface200] ip address 2.2.2.100 255.255.255.0

[Switch-Vlan-interface200] quit

# Assign an IP address to VLAN interface 2.

[Switch] interface vlan-interface 2

[Switch-Vlan-interface2] ip address 192.168.0.100 255.255.255.0

[Switch-Vlan-interface2] quit

Verifying the configuration

# Use the configured username and password to perform portal authentication through a Web browser on the client. Before passing authentication, all Web accesses are redirected to the portal authentication page (http://2.2.2.1/portal). After passing authentication, you can access other network resources.

# Display the online portal user information on the AC.

[AC] display portal user all

Total portal users: 1

Username: 123

  AP name: office

  Radio ID: 2

  SSID: service

  Portal server: newpt

  State: Online

  VPN instance: N/A

  MAC             IP                    VLAN    Interface

  0021-6330-0933  2.2.2.2               200     WLAN-BSS1/0/1

  Authorization information:

    DHCP IP pool: N/A

    User profile: N/A

    Session group profile: N/A

    ACL number: N/A

    Inbound CAR: N/A

    Outbound CAR: N/A

Configuration files

·     AC:

#

vlan 100

#

vlan 200

#

wlan service-template st1

 ssid service

 vlan 200

 portal enable method direct

portal domain dm1

 portal apply web-server newpt

 service-template enable

#

wlan service-template st2

 ssid service2

 vlan 200

 portal enable method direct

portal domain dm1

 portal apply web-server newpt

 service-template enable

#

interface Vlan-interface100

 ip address 2.2.1.1 255.255.255.0

#

interface Vlan-interface200

 ip address 2.2.2.1 255.255.255.0

#

interface GigabitEthernet1/0/1

 port link-mode bridge

 port link-type trunk

 port trunk permit vlan 1 100 200

#

domain dm1

authorization-attribute idle-cut 15 1024

 authentication portal local

 authorization portal none

 accounting portal none

#

local-user 123 class network

 password cipher $c$3$evSrJBp31wOqEZw7KdwPugEfvJ5M/w==

 service-type portal

#

portal host-check enable

#

portal roaming enable

 undo portal refresh arp enable

#

 portal web-server newpt

 url http://2.2.2.1/portal

 url-parameter wlanuserip source-address

#

portal local-web-server http

 default-logon-page abc.zip

 logon-page bind ssid service2 file http.zip

#

wlan ap office model WA4320i-ACN

 serial-id 219801A0CNC138011454

 radio 1

 radio 2

  radio enable

  service-template st1

  service-template st2

#

·     Switch:

#

vlan 2

#

vlan 100

#

vlan 200

#

interface Vlan-interface2

 ip address 192.168.0.100 255.255.255.0

#

interface Vlan-interface200

 ip address 2.2.2.100 255.255.255.0

#

interface GigabitEthernet1/0/1

 port link-type trunk

 port trunk permit vlan 1 100 200

#

interface GigabitEthernet1/0/2

 port link-type access

 port access vlan 100

poe enable

#

interface GigabitEthernet1/0/3

 port link-type access

 port access vlan 2

#

Related documentation

·     AP and WT Management Command Reference in H3C Access Controllers Command References

·     AP and WT Management Configuration Guide in H3C Access Controllers Configuration Guides

·     User Access and Authentication Command Reference in H3C Access Controllers Command References

·     User Access and Authentication Configuration Guide in H3C Access Controllers Configuration Guides

·     WLAN Access Command Reference in H3C Access Controllers Command References

·     WLAN Access Configuration Guide in H3C Access Controllers Configuration Guides

  • Cloud & AI
  • InterConnect
  • Intelligent Computing
  • Security
  • SMB Products
  • Intelligent Terminal Products
  • Product Support Services
  • Technical Service Solutions
All Services
  • Resource Center
  • Policy
  • Online Help
All Support
  • Become a Partner
  • Partner Resources
  • Partner Business Management
All Partners
  • Profile
  • News & Events
  • Online Exhibition Center
  • Contact Us
All About Us
新华三官网