03-CLI configuration examples (AC+fit AP)

HomeSupportDoc SetsDoc PackagesH3C Wireless Products All-in-One-6W10003-CLI configuration examples (AC+fit AP)
Table of Contents
Related Documents
17-Service Template and Radio Binding Configuration Examples

 

H3C Access Controllers

Service Template and Radio Binding

Configuration Examples

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Copyright © 2022 New H3C Technologies Co., Ltd. All rights reserved.

No part of this manual may be reproduced or transmitted in any form or by any means without prior written consent of New H3C Technologies Co., Ltd.

Except for the trademarks of New H3C Technologies Co., Ltd., any trademarks that may be mentioned in this document are the property of their respective owners.

The information in this document is subject to change without notice.



Introduction

The following information provides an example for binding a service template to a radio.

Prerequisites

The following information applies to Comware 7-based access controllers and access points. Procedures and information in the examples might be slightly different depending on the software or hardware version of the access controllers and access points.

The configuration examples were created and verified in a lab environment, and all the devices were started with the factory default configuration. When you are working on a live network, make sure you understand the potential impact of every command on your network.

The following information is provided based on the assumption that you have basic knowledge of DHCP and WLAN access.

Example: Binding service templates with different SSIDs to radios

Network configuration

As shown in Figure 1, the AC connects to Layer 2 switch 1 and the Layer 3 switch acts as a DHCP server to assign IP addresses to the AP, the host, and the clients. Radio 1 and radio 2 of the AP operates at 5GHz band and 2.4 GHz band, respectively.

Configure network settings to meet the following requirements:

·     Client 1 accesses WLAN service1 over VLAN 201.

·     Client 2 accesses WLAN service2 over VLAN 202.

·     The host accesses the network over VLAN 300.

·     The AC and the AP communicate with each other over VLAN 100.

·     Layer 2 switch 1 supplies power to the AP through PoE.

Figure 1 Network diagram

 

Analysis

·     For the Layer 3 switch to act as a DHCP server, enable the DHCP server feature on the switch.

·     For Layer 2 switch 1 to supply power to the AP, enable the PoE feature on the switch.

·     For the clients to ping the host through different WLANs, configure service templates with different SSIDs on the AC.

Restrictions and guidelines

When you configure a serial ID for the AP, use the serial ID labeled on the AP's rear panel.

Procedures

Configuring the Layer 3 switch

1.     Configure Layer 3 switch interfaces:

# Create VLAN 100 and VLAN-interface 100, and assign IP address 192.168.10.1 to the interface. The switch communicates with the AC over VLAN 100.

<L3 switch> system-view

[L3 switch] vlan 100

[L3 switch-vlan100] quit

[L3 switch] interface vlan-interface 100

[L3 switch-Vlan-interface100] ip address 192.168.10.1 255.255.255.0

[L3 switch-Vlan-interface100] quit

# Create VLAN 201 and VLAN-interface 201, and assign IP address 192.168.21.1 to the interface. Client 1 will use this VLAN to access the WLAN.

[L3 switch] vlan 201

[L3 switch-vlan201] quit

[L3 switch] interface vlan-interface 201

[L3 switch-Vlan-interface201] ip address 192.168.21.1 255.255.255.0

[L3 switch-Vlan-interface201] quit

# Create VLAN 202 and VLAN-interface 202, and assign IP address 192.168.22.1 to the interface. Client 2 will use this VLAN to access the WLAN.

[L3 switch] vlan 202

[L3 switch-vlan202] quit

[L3 switch] interface vlan-interface 202

[L3 switch-Vlan-interface202] ip address 192.168.22.1 255.255.255.0

[L3 switch-Vlan-interface202] quit

# Create VLAN 300 and VLAN-interface 300, and assign IP address 192.168.30.1 to the interface. The host will use this VLAN to access the WLAN.

[L3 switch] vlan 300

[L3 switch-vlan300] quit

[L3 switch] interface vlan-interface 300

[L3 switch-Vlan-interface300] ip address 192.168.30.1 255.255.255.0

[L3 switch-Vlan-interface300] quit

# Set the link type of GigabitEthernet 1/0/1 that connects the switch to Layer 2 switch 1 to trunk. Remove the port from VLAN 1 and assign the port to VLANs 100, 201, and 202.

[L3 switch] interface gigabitEthernet 1/0/1

[L3 switch-GigabitEthernet1/0/1] port link-type trunk

[L3 switch-GigabitEthernet1/0/1] undo port trunk permit vlan 1

[L3 switch-GigabitEthernet1/0/1] port trunk permit vlan 100 201 202

[L3 switch-GigabitEthernet1/0/1] quit

# Set the link type of GigabitEthernet 1/0/3 that connects the switch to Layer 2 switch 2 to trunk. Remove the port from VLAN 1 and assign the port to VLAN 300.

[L3 switch] interfac gigabitEthernet 1/0/3

[L3 switch-GigabitEthernet1/0/3] port link-type trunk

[L3 switch-GigabitEthernet1/0/3] undo port trunk permit vlan 1

[L3 switch-GigabitEthernet1/0/3] port trunk permit vlan 300

[L3 switch-GigabitEthernet1/0/3] quit

2.     Configure the DHCP server feature:

# Enable DHCP server.

[L3 switch] dhcp enable

# Create DHCP address pool 1 for dynamic IP allocation to the AP. Specify 192.168.10.0/24 as the subnet and 192.168.10.1 as the gateway address in the address pool.

[L3 switch] dhcp server ip-pool 1

[L3 switch-dhcp-pool-1] network 192.168.10.0 mask 255.255.255.0

[L3 switch-dhcp-pool-1] gateway-list 192.168.10.1

# Exclude the IP address of VLAN-interface 100 on the AC from dynamic IP allocation in DHCP address pool 1.

[L3 switch-dhcp-pool-1] forbidden-ip 192.168.10.2

[L3 switch-dhcp-pool-1] quit

# Create DHCP address pool 2 for dynamic IP allocation to Client 1. Specify 192.168.21.0/24 as the subnet and 192.168.21.1 as the gateway address in the address pool, and then specify the address of the DNS server. In this example, the gateway also acts as the DNS server.

[L3 switch] dhcp server ip-pool 2

[L3 switch-dhcp-pool-2] network 192.168.21.0 mask 255.255.255.0

[L3 switch-dhcp-pool-2] gateway-list 192.168.21.1

[L3 switch-dhcp-pool-2] dns-list 192.168.21.1

[L3 switch-dhcp-pool-2] quit

# Create DHCP address pool 3 for dynamic IP allocation to Client 2. Specify 192.168.22.0/24 as the subnet and 192.168.22.1 as the gateway address in the address pool, and then specify the address of the DNS server. In this example, the gateway also acts as the DNS server.

[L3 switch] dhcp server ip-pool 3

[L3 switch-dhcp-pool-3] network 192.168.22.0 mask 255.255.255.0

[L3 switch-dhcp-pool-3] gateway-list 192.168.22.1

[L3 switch-dhcp-pool-3] dns-list 192.168.22.1

[L3 switch-dhcp-pool-3] quit

# Create DHCP address pool 4 for dynamic IP allocation to the host. Specify 192.168.30.0/24 as the subnet and 192.168.30.1 as the gateway address in the address pool, and then specify the address of the DNS server. In this example, the gateway also acts as the DNS server.

[L3 switch] dhcp server ip-pool 4

[L3 switch-dhcp-pool-4] network 192.168.30.0 mask 255.255.255.0

[L3 switch-dhcp-pool-4] gateway-list 192.168.30.1

[L3 switch-dhcp-pool-4] dns-list 192.168.30.1

[L3 switch-dhcp-pool-4] quit

Configuring the AC

1.     Configure AC interfaces:

# Create VLAN 100 and VLAN-interface 100, and assign IP address 192.168.10.2 to the interface. The AC will establish a CAPWAP tunnel with the AP in this VLAN.

<AC> system-view

[AC] vlan 100

[AC-vlan100] quit

[AC] interface vlan-interface 100

[AC-Vlan-interface100] ip address 192.168.10.2 255.255.255.0

[AC-Vlan-interface100] quit

# Create VLAN 201. Client 1 will use this VLAN to access the WLAN.

[AC] vlan 201

[AC-vlan201] quit

# Create VLAN 202. Client 2 will use this VLAN to access the WLAN.

[AC] vlan 202

[AC-vlan202] quit

# Set the link type of GigabitEthernet 1/0/1 that connects the AC to Layer 2 switch 1 to trunk. Remove the port from VLAN 1 and assign the port to VLANs 100, 201, and 202.

[AC] interface gigabitethernet 1/0/1

[AC-GigabitEthernet1/0/1] port link-type trunk

[AC-GigabitEthernet1/0/1] undo port trunk permit vlan 1

[AC-GigabitEthernet1/0/1] port trunk permit vlan 100 201 202

[AC-GigabitEthernet1/0/1] quit

2.     Configure wireless services:

# Create service template 1 and enter its view.

[AC] wlan service-template 1

# Set the SSID to service1.

[AC-wlan-st-1] ssid service1

# Enable service template 1.

[AC-wlan-st-1] service-template enable

[AC-wlan-st-1] quit

# Create service template 2 and enter its view.

[AC] wlan service-template 2

# Set the SSID to service2.

[AC-wlan-st-2] ssid service2

# Enable service template 2.

[AC-wlan-st-2] service-template enable

[AC-wlan-st-2] quit

3.     Configure AP settings:

# Create AP officeap, and specify the AP model and serial ID.

[AC] wlan ap officeap model WA6320

[AC-wlan-ap-officeap] serial-id 219801A28N819CE0002T

# Bind service template 1 and VLAN 201 to radio 1.

[AC-wlan-ap-officeap] radio 1

[AC-wlan-ap-officeap-radio-1] service-template 1 vlan 201

# Enable radio 1.

[AC-wlan-ap-officeap-radio-1] radio enable

[AC-wlan-ap-officeap-radio-1] quit

# Bind service template 2 and VLAN 202 to radio 2.

[AC-wlan-ap-officeap] radio 2

[AC-wlan-ap-officeap-radio-2] service-template 2 vlan 202

# Enable radio 2.

[AC-wlan-ap-officeap-radio-2] radio enable

[AC-wlan-ap-officeap-radio-2] quit

[AC-wlan-ap-officeap] quit

[AC] quit

Configuring Layer 2 switch 1

# Create VLAN 100, VLAN 201, and VLAN 202. The switch will use VLAN 100 to forward traffic between the AC and other devices. Client 1 will use VLAN 201 to access the WLAN and Client 2 will use VLAN 202 to access the WLAN.

<L2 switch 1> system-view

[L2 switch 1] vlan 100

[L2 switch 1-vlan100] quit

[L2 switch 1] vlan 201

[L2 switch 1-vlan201] quit

[L2 switch 1] vlan 202

[L2 switch 1-vlan202] quit

# Set the link type of GigabitEthernet 1/0/1 that connects the switch to the AC to trunk. Remove the port from VLAN 1 and assign the port to VLANs 100, 201, and 202.

[L2 switch 1] interface gigabitEthernet 1/0/1

[L2 switch 1-GigabitEthernet1/0/1] port link-type trunk

[L2 switch 1-GigabitEthernet1/0/1] undo port trunk permit vlan 1

[L2 switch 1-GigabitEthernet1/0/1] port trunk permit vlan 100 201 202

[L2 switch 1-GigabitEthernet1/0/1] quit

# Set the link type of GigabitEthernet 1/0/2 that connects the switch to the AP to access. Assign the port to VLAN 100 and enable PoE.

[L2 switch 1] interfac gigabitEthernet 1/0/2

[L2 switch 1-GigabitEthernet1/0/2] port link-type access

[L2 switch 1-GigabitEthernet1/0/2] port access vlan 100

[L2 switch 1-GigabitEthernet1/0/2] poe enable

[L2 switch 1-GigabitEthernet1/0/2] quit

# Set the link type of GigabitEthernet 1/0/3 that connects the switch to the Layer 3 switch to trunk. Remove the port from VLAN 1 and assign the port to VLANs 100, 201, and 202.

[L2 switch 1] interface gigabitEthernet 1/0/3

[L2 switch 1-GigabitEthernet1/0/3] port link-type trunk

[L2 switch 1-GigabitEthernet1/0/3] undo port trunk permit vlan 1

[L2 switch 1-GigabitEthernet1/0/3] port trunk permit vlan 100 201 202

[L2 switch 1-GigabitEthernet1/0/3] quit

Configuring Layer 2 switch 2

# Create VLAN 300. The host will use VLAN 300 to access the network.

<L2 switch 2> system-view

[L2 switch 2] vlan 300

[L2 switch 2-vlan300] quit

# Set the link type of GigabitEthernet 1/0/1 that connects the switch to the Layer 3 switch to trunk. Remove the port from VLAN 1 and assign the port to VLAN 300.

[L2 switch 2] interface gigabitEthernet 1/0/1

[L2 switch 2-GigabitEthernet1/0/1] port link-type trunk

[L2 switch 2-GigabitEthernet1/0/1] undo port trunk permit vlan 1

[L2 switch 2-GigabitEthernet1/0/1] port trunk permit vlan 300

[L2 switch 2-GigabitEthernet1/0/1] quit

# Set the link type of GigabitEthernet 1/0/2 that connects the switch to the host to access. Assign the port to VLAN 300.

[L2 switch 2] interface gigabitEthernet 1/0/2

[L2 switch 2-GigabitEthernet1/0/2] port link-type access

[L2 switch 2-GigabitEthernet1/0/2] port access vlan 300

[L2 switch 2-GigabitEthernet1/0/2] quit

Verifying the configuration

# Use the display wlan ap all command to view AP information on the AC. If the AP has connected to the AC, the state of the AP is R/M.

<AC> display wlan ap all

Total number of APs: 1

Total number of connected APs: 1

Total number of connected manual APs: 1

Total number of connected auto APs: 0

Total number of connected common APs: 1

Total number of connected WTUs: 0

Total number of inside APs: 0

Maximum supported APs: 3072

Remaining APs: 3071

Total AP licenses: 512

Remaining AP licenses: 511

 

                                 AP information

 State : I = Idle,      J  = Join,       JA = JoinAck,    IL = ImageLoad

         C = Config,    DC = DataCheck,  R  = Run,   M = Master,  B = Backup

 

AP name                AP ID   State   Model             Serial ID

officeap               1       R/M     WA6320            219801A28N819CE0002T

# Use the display wlan client command to view client information on the AC. Client 1 has connected to radio 1 of the AP and Client 2 has connected to radio 2 of the AP.

<AC> display wlan client

Total number of clients: 2

 

MAC address    User name            AP name               R IP address      VLAN

109a-dd9d-fc68 N/A                  officeap              1 192.168.21.2    201

109a-dd9d-fc69 N/A                  officeap              2 192.168.22.2    202

# After Client 1 obtains IP address 192.168.21.2 from the DHCP server, the host and Client 1 can ping each other successfully.

C:\Users\system32>ping 192.168.21.2 -t

 

Pinging 192.168.21.2 with 32 bytes of data:

Reply from 192.168.21.2: bytes=32 time=8ms TTL=255

Reply from 192.168.21.2: bytes=32 time<1ms TTL=255

Reply from 192.168.21.2: bytes=32 time<1ms TTL=255

Reply from 192.168.21.2: bytes=32 time<1ms TTL=255

Reply from 192.168.21.2: bytes=32 time<1ms TTL=255

Reply from 192.168.21.2: bytes=32 time<1ms TTL=255

Reply from 192.168.21.2: bytes=32 time<1ms TTL=255

Reply from 192.168.21.2: bytes=32 time<1ms TTL=255

Reply from 192.168.21.2: bytes=32 time<1ms TTL=255

Reply from 192.168.21.2: bytes=32 time<1ms TTL=255

Reply from 192.168.21.2: bytes=32 time<1ms TTL=255

 

Ping statistics for 192.168.21.2:

    Packets: Sent = 11, Received = 11, Lost = 0 (0% loss),

Approximate round trip times in milli-seconds:

    Minimum = 0ms, Maximum = 8ms, Average = 0ms

Control-C

^C

C:\Users\system32>

Configuration files

·     L3 switch

#

 dhcp enable

#

vlan 1

#

vlan 100

#

vlan 201

#

vlan 202

#

vlan 300

#

dhcp server ip-pool 1

 gateway-list 192.168.10.1

 network 192.168.10.0 mask 255.255.255.0

 forbidden-ip 192.168.10.2

#

dhcp server ip-pool 2

 gateway-list 192.168.21.1

 network 192.168.21.0 mask 255.255.255.0

 dns-list 192.168.21.1

#

dhcp server ip-pool 3

 gateway-list 192.168.22.1

 network 192.168.22.0 mask 255.255.255.0

 dns-list 192.168.22.1

#

dhcp server ip-pool 4

 gateway-list 192.168.30.1

 network 192.168.30.0 mask 255.255.255.0

 dns-list 192.168.30.1

#

interface Vlan-interface100

 ip address 192.168.10.1 255.255.255.0

#

interface Vlan-interface200

 ip address 192.168.20.1 255.255.255.0

#

interface Vlan-interface300

 ip address 192.168.30.1 255.255.255.0

#

interface GigabitEthernet1/0/1

 port link-type trunk

 undo port trunk permit vlan 1

 port trunk permit vlan 100 201 202

#

interface GigabitEthernet1/0/3

port link-type trunk

undo port trunk permit vlan 1

 port trunk permit vlan 300

#

·     AC

#

vlan 100

#

vlan 201

#

vlan 202

#

wlan service-template 1

 ssid service1

 service-template enable

#

wlan service-template 2

 ssid service2

 service-template enable

#

interface Vlan-interface1

#

interface Vlan-interface100

 ip address 192.168.10.2 255.255.255.0

#

interface GigabitEthernet1/0/1

 port link-type trunk

 undo port trunk permit vlan 1

 port trunk permit vlan 100 201 202

#

wlan ap officeap model WA6320

 serial-id 219801A28N819CE0002T

vlan 1

 radio 1

  radio enable

  service-template 1 vlan 201

 radio 2

  radio enable

  service-template 2 vlan 202

#

·     L2 switch 1

#

vlan 100

#

vlan 201

#

vlan 202

#

interface GigabitEthernet1/0/1

 port link-type trunk

 undo port trunk permit vlan 1

 port trunk permit vlan 100 201 202

#

interface GigabitEthernet1/0/2

 port link-type access

 port access vlan 100

 poe enable

#

interface GigabitEthernet1/0/3

 port link-type trunk

 undo port trunk permit vlan 1

 port trunk permit vlan 100 201 202

#

·     L2 switch 2

#

vlan 300

#

interface GigabitEthernet1/0/1

 port link-type trunk

 undo port trunk permit vlan 1

 port trunk permit vlan 300

#

interface GigabitEthernet1/0/2

 port link-type access

 port access vlan 300

 poe enable

#

Related documentation

·     AP and WT Management Command Reference in H3C Access Controllers Command References

·     AP and WT Management Configuration Guide in H3C Access Controllers Configuration Guides

·     Network Connectivity Command Reference in H3C Access Controllers Command References

·     Network Connectivity Configuration Guide in H3C Access Controllers Configuration Guides

·     WLAN Access Command Reference in H3C Access Controllers Command References

·     WLAN Access Configuration Guide in H3C Access Controllers Configuration Guides

  • Cloud & AI
  • InterConnect
  • Intelligent Computing
  • Security
  • SMB Products
  • Intelligent Terminal Products
  • Product Support Services
  • Technical Service Solutions
All Services
  • Resource Center
  • Policy
  • Online Help
All Support
  • Become a Partner
  • Partner Resources
  • Partner Business Management
All Partners
  • Profile
  • News & Events
  • Online Exhibition Center
  • Contact Us
All About Us
新华三官网