03-CLI configuration examples (AC+fit AP)

HomeSupportDoc SetsDoc PackagesH3C Wireless Products All-in-One-6W10003-CLI configuration examples (AC+fit AP)
Table of Contents
Related Documents
22-Local Portal Authentication through LDAP Server Configuration Examples

 

H3C Access Controllers

Comware 7 Local Portal Authentication Through the LDAP Server

Configuration Examples

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Copyright © 2022 New H3C Technologies Co., Ltd. All rights reserved.

No part of this manual may be reproduced or transmitted in any form or by any means without prior written consent of New H3C Technologies Co., Ltd.

Except for the trademarks of New H3C Technologies Co., Ltd., any trademarks that may be mentioned in this document are the property of their respective owners.

The information in this document is subject to change without notice.



Introduction

The following information provides an example of configuring the local portal service on the AC to send wireless user information to the LDAP server for authentication.

Prerequisites

The following information applies to Comware 7-based access controllers and access points. Procedures and information in the examples might be slightly different depending on the software or hardware version of the access controllers and access points.

The configuration examples were created and verified in a lab environment, and all the devices were started with the factory default configuration. When you are working on a live network, make sure you understand the potential impact of every command on your network.

The following information is provided based on the assumption that you have basic knowledge of AAA, portal, and WLAN.

Example: Configuring local portal authentication through the LDAP server

Network configuration

As shown in Figure 1, the AP and the client obtain IP addresses from the DHCP server.

Configuration requirements are as follows:

·     Configure the local portal service on the AC to provide authentication pages for clients.

·     Use the LDAP server to authenticate the clients.

Figure 1 Network diagram

 

Restrictions and guidelines

Configure routing to make sure the devices can reach one another.

Use the serial ID labeled on the AP's rear panel to specify an AP.

Edit the authentication pages, compress them to a .zip file (this example uses abc.zip), and then upload the file to the root directory of the storage medium of the AC. On the AC, you must specify this file as the default authentication page file.

To change the default authentication page file, you must first execute the undo default-logon-page command, and then specify a new default authentication page file.

Procedures

Configuring the AC

1.     Configuring VLANs and interfaces:

# Create VLAN 100 and VLAN-interface 100. Assign the VLAN interface an IP address. The AC will use this IP address to establish a CAPWAP tunnel with the AP.

<AC> system-view

[AC] vlan 100

[AC-vlan100] quit

[AC] interface vlan-interface 100

[AC-Vlan-interface100] ip address 2.2.1.1 24

[AC-Vlan-interface100] quit

# Create VLAN 200 and VLAN-interface 200. Assign the VLAN interface an IP address. This VLAN will be used for wireless client access.

[AC] vlan 200

[AC-vlan200] quit

[AC] interface vlan-interface 200

[AC-Vlan-interface200] ip address 2.2.2.1 24

[AC-Vlan-interface200] quit

# Configure GigabitEthernet 1/0/1 (the port connected to the switch) as a trunk port. Assign the port to VLAN 100 and VLAN 200.

[AC] interface gigabitethernet 1/0/1

[AC-GigabitEthernet1/0/1] port link-type trunk

[AC-GigabitEthernet1/0/1] port trunk permit vlan 100 200

[AC-GigabitEthernet1/0/1] quit

2.     Configure the LDAP scheme:

 # Create an LDAP server named ldap and enter its view.

[AC] ldap server ldap

# Specify the administrator DN.

[AC-ldap-server-ldap] login-dn cn=administrator,cn=users,dc=ldap,dc=com

# Specify the base DN for user search.

[AC-ldap-server-ldap] search-base-dn dc=ldap,dc=com

# Specify the IP address of the LDAP server.

[AC-ldap-server-ldap] ip 192.168.0.112

# Specify the administrator password.

[AC-ldap-server-ldap] login-password simple 123456

[AC-ldap-server-ldap] quit

# Create an LDAP scheme named ldap and enter its view.

[AC] ldap scheme ldap

# Specify ldap as the LDAP authentication server.

[AC-ldap-ldap] authentication-server ldap

[AC-ldap-ldap] quit

# Create an ISP domain named ldap and enter its view.

[AC] domain ldap

# Configure the authentication method as LDAP and the authentication and accounting methods as none for portal users in ISP domain ldap.

[AC-isp-ldap]authentication portal ldap-scheme ldap

[AC-isp-ldap] authorization portal none

[AC-isp-ldap] accounting portal none

# Configure the idle cut feature for users in ISP domain ldap. Log out a user if the user's traffic is less than 1024 bytes in 15 minutes.

[AC-isp-ldap] authorization-attribute idle-cut 15 1024

[AC-isp-ldap] quit

3.     Configure portal authentication:

# Create a portal Web server named newpt and specify http://2.2.2.1/portal as the server's URL.

[AC] portal web-server newpt

[AC-portal-websvr-newpt] url http://2.2.2.1/portal

[AC-portal-websvr-newpt] quit

# Create an HTTP-based local portal Web service.

[AC] portal local-web-server http

# Specify file abc.zip as the default authentication page file. (The file must already exist in the root directory of the storage medium of the AC.)

[AC–portal-local-websvr-http] default-logon-page abc.zip

[AC–portal-local-websvr-http] quit

# Configure two destination-based portal-free rules to permit the traffic destined for the DNS server.

[AC] portal free-rule 1 destination ip any udp 53

[AC] portal free-rule 2 destination ip any tcp 53

4.     Configure the wireless service:

# Create a service template named st1 and enter its view.

[AC] wlan service-template st1

# Set the SSID of the service template to service.

[AC-wlan-st-st1] ssid service

# Assign clients coming online through the service template to VLAN 200.

[AC-wlan-st-st1] vlan 200

# Enable direct portal authentication on the service template.

[AC-wlan-st-st1] portal enable method direct

# Specify ISP domain ldap as the portal authentication domain.

[AC-wlan-st-st1] portal domain ldap

# Specify portal Web server newpt on the service template.

[AC-wlan-st-st1] portal apply web-server newpt

# Enable the service template.

[AC-wlan-st-st1] service-template enable

[AC-wlan-st-st1] quit

# Create an AP named officeap with model WA2620E-AGN, and specify the AP model and serial ID.

[AC] wlan ap officeap model WA2620E-AGN

[AC-wlan-ap-officeap] serial-id 21023529G007C000020

# Enter the view of radio 2.

[AC-wlan-ap-officeap] radio 2

# Bind service template st1 to radio 2.

[AC-wlan-ap-officeap-radio-2] service-template st1

[AC-wlan-ap-officeap-radio-2] radio enable

[AC-wlan-ap-officeap-radio-2] quit

[AC-wlan-ap-officeap] quit

Configuring the switch

# Create VLAN 100. The switch will use this VLAN to forward traffic on the CAPWAP tunnel between the AC and AP.

<Switch> system-view

[Switch] vlan 100

[Switch-vlan100] quit

# Create VLAN 200. The switch will use this VLAN to forward traffic of wireless clients.

[Switch] vlan 200

[Switch-vlan200] quit

# Configure GigabitEthernet 1/0/1 (the port connected to the AC) as a trunk port. Assign the trunk port to VLAN 100 and VLAN 200.

[Switch] interface gigabitethernet1/0/1

[Switch-GigabitEthernet1/0/1] port link-type trunk

[Switch-GigabitEthernet1/0/1] port trunk permit vlan 100 200

[Switch-GigabitEthernet1/0/1] quit

# Configure GigabitEthernet 1/0/2 (the port connected to the AP) as an access port. Assign the access port to VLAN 100.

[Switch] interface gigabitethernet1/0/2

[Switch-GigabitEthernet1/0/2] port link-type access

[Switch-GigabitEthernet1/0/2] port access vlan 100

# Enable PoE on the access port.

[Switch-GigabitEthernet1/0/2] poe enable

[Switch-GigabitEthernet1/0/2] quit

Configuring the LDAP server

This example uses Microsoft Windows 2003 Server Active Directory to illustrate the configuration on the LDAP server.

1.     Add a user named aaa.

a.     On the LDAP server, select Start > Control Panel > Administrative Tools.

b.     Double-click Active Directory Users and Computers.

The Active Directory Users and Computers window opens.

c.     From the navigation tree, click Users under the ldap.com node.

d.     Select Action > New > User from the menu to open the dialog box for adding a user.

e.     Enter logon name aaa and click Next.

Figure 2 Adding user aaa

 

f.     In the dialog box, enter password 123456, select options as needed, and click Next.

Figure 3 Setting the user's password

 

g.     Click OK.

2.     Add user aaa to user group Users:

a.     From the navigation tree, click Users under the ldap.com node.

b.     In the right pane, right-click user aaa and select Properties.

c.     In the dialog box, click the Member Of tab and click Add.

Figure 4 Modifying user properties

 

d.     In the Select Groups dialog box, enter Users in the Enter the object names to select field, and click OK.

User aaa is added to group Users.

Figure 5 Adding user aaa to group Users

 

3.     Configure the administrator password:

a.     In the right pane, right-click user Administrator and select Set Password.

b.     In the dialog box, enter the administrator password. (Details not shown.)

Verifying the configuration

# Open a Web browser such as IE on the wireless client. Type an IP address in the address bar and press Enter. The portal authentication page opens. Enter username aaa and password 123456 and then click Logon. User aaa passes authentication successfully.

# Display online portal users on the AC.

<AC> display portal user all

 Index:17

 State:ONLINE

 SubState:NONE

 ACL:3777

 Work-mode:stand-alone

 MAC              IP                Vlan     Interface

 ----------------------------------------------------------------------------

 2477-0341-f118   2.2.2.2           200      Vlan-interface200

 Total 1 user(s) matched, 1 listed.

Configuration files

·     AC:

#

vlan 100

#

vlan 200

#

wlan service-template st1

 ssid service

 vlan 200

 portal enable method direct

 portal domain ldap

 portal apply web-server newpt

 service-template enable

#

interface Vlan-interface100

 ip address 2.2.1.1 255.255.255.0

#

interface Vlan-interface200

 ip address 2.2.2.1 255.255.255.0

#

interface GigabitEthernet1/0/1

 port link-type trunk

 port trunk permit vlan 100 200

#

ldap server ldap

 login-dn cn=administrator,cn=users,dc=ldap,dc=com

 search-base-dn dc=ldap,dc=com

 ip 192.168.0.112

 login-password cipher $c$3$CEz2vKCnA2/51D8rFc/+nTNtOx8Gan+81Q==

#

ldap scheme ldap

 authentication-server ldap

#

domain ldap

 authorization-attribute idle-cut 15 1024

 authentication portal ldap-scheme ldap

 authorization portal none

 accounting portal none

#

portal free-rule 1 destination ip any udp 53

portal free-rule 2 destination ip any tcp 53

#

portal web-server newpt

 url http://2.2.2.1/portal

#

portal local-web-server http

 default-logon-page abc.zip

#

wlan ap officeap model WA2620E-AGN

 serial-id 21023529G007C000020

 radio 2

  radio enable

  service-template st1

#

·     Switch:

#

vlan 100

#

vlan 200

#

interface GigabitEthernet1/0/1

 port link-mode bridge

 port link-type trunk

 port trunk permit vlan 100 200

#

interface GigabitEthernet1/0/2

 port link-mode bridge

 port access vlan 100

 poe enable

#

Related documentation

·     User Access and Authentication Command Reference in H3C Access Controllers Command References

·     User Access and Authentication Configuration Guide in H3C Access Controllers Configuration Guides

·     WLAN Access Command Reference in H3C Access Controllers Command References

·     WLAN Access Configuration Guide in H3C Access Controllers Configuration Guides

 

  • Cloud & AI
  • InterConnect
  • Intelligent Computing
  • Security
  • SMB Products
  • Intelligent Terminal Products
  • Product Support Services
  • Technical Service Solutions
All Services
  • Resource Center
  • Policy
  • Online Help
All Support
  • Become a Partner
  • Partner Resources
  • Partner Business Management
All Partners
  • Profile
  • News & Events
  • Online Exhibition Center
  • Contact Us
All About Us
新华三官网