03-CLI configuration examples (AC+fit AP)

HomeSupportDoc SetsDoc PackagesH3C Wireless Products All-in-One-6W10003-CLI configuration examples (AC+fit AP)
Table of Contents
Related Documents
49-Local Forwarding Mode and Local Portal Authentication Configuration Examples

 

H3C Access Controllers

Comware 7 Local Forwarding Mode and Local Portal Authentication

Configuration Examples

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Copyright © 2022 New H3C Technologies Co., Ltd. All rights reserved.

No part of this manual may be reproduced or transmitted in any form or by any means without prior written consent of New H3C Technologies Co., Ltd.

Except for the trademarks of New H3C Technologies Co., Ltd., any trademarks that may be mentioned in this document are the property of their respective owners.

The information in this document is subject to change without notice.



Introduction

The following information provides an example of configuring local portal authentication on a wireless network where APs forward client traffic locally.

Prerequisites

The following information applies to Comware 7-based access controllers and access points. Procedures and information in the examples might be slightly different depending on the software or hardware version of the access controllers and access points.

The configuration examples were created and verified in a lab environment, and all the devices were started with the factory default configuration. When you are working on a live network, make sure you understand the potential impact of every command on your network.

The following information is provided based on the assumption that you have basic knowledge of AAA, portal authentication, WLAN access, and WLAN high availability.

Example: Configuring local forwarding mode and local portal authentication

Network configuration

As shown in Figure 1:

·     The AP and the client obtain IP addresses from the DHCP server.

·     The AP and the AC use VLAN 100 to establish CAPWAP tunnels, and the client uses VLAN 200 to access the wireless network.

·     The AC acts as the portal authentication server and portal Web server.

Configure the devices to meet the following requirements:

·     The AC uses a service template to provide direct portal authentication for the client. Before passing the authentication, the client can access only the portal Web server. After passing the authentication, the client can access other network resources.

·     The AP forwards the client traffic locally.

·     The client can access network resources through any Layer 2 ports in its access VLAN without re-authentication.

Figure 1 Network diagram

 

Analysis

To allow a client to access network resources through any Layer 2 ports in its access VLAN without re-authentication, enable portal roaming.

In local forwarding mode, to ensure that valid clients can perform portal authentication, enable validity check on wireless clients.

To avoid portal authentication failure caused by frequent logins and logouts in a short time, disable the Rule ARP entry feature.

To use GigabitEthernet 1/0/1 on the AP to forward client traffic, edit a .txt configuration file and upload the file to the AC.

Restrictions and guidelines

Use the serial ID labeled on the AP's rear panel to specify an AP.

By default, the portal Web server URL redirected to users does carry parameters. You can configure the parameters to be carried in the redirection URL as needed.

Procedures

Editing the AP configuration file

# Use a text editor to edit the AP's configuration file. Name the configuration file map.txt, and then upload the file to the storage medium of the AC.

The content of the configuration file is as follows:

system-view

vlan 200

interface gigabitethernet1/0/1

port link-type trunk

port trunk permit vlan 200

Configuring the AC

1.     Configure interfaces:

# Create VLAN 100, create VLAN-interface 100, and assign an IP address to the VLAN interface. The AC will use this IP address to establish CAPWAP control and data tunnels with the AP.

<AC> system-view

[AC] vlan 100

[AC-vlan100] quit

[AC] interface vlan-interface 100

[AC-Vlan-interface100] ip address 2.2.1.1 24

[AC-Vlan-interface100] quit

# Configure GigabitEthernet 1/0/1 (the port connected to the switch) as a trunk port, and assign the port to VLAN 100.

[AC] interface gigabitethernet 1/0/1

[AC-GigabitEthernet1/0/1] port link-type trunk

[AC-GigabitEthernet1/0/1] port trunk permit vlan 100

[AC-GigabitEthernet1/0/1] quit

2.     Configure the wireless service:

# Create a service template named st1.

[AC] wlan service-template st1

# Set the SSID of the service template.

[AC-wlan-st-st1] ssid service

# Specify VLAN 200 for the service template.

[AC-wlan-st-st1] vlan 200

# Configure APs to forward client data traffic from all VLANs.

[AC–wlan-st-st1] client forwarding-location ap

[AC-wlan-st-st1] quit

# Create a manual AP named office with model WA4320i-ACN, and specify the serial ID of the AP.

[AC] wlan ap office model WA4320i-ACN

[AC-wlan-ap-office] serial-id 219801A0CNC138011454

# Deploy configuration file map.txt to the AP.

[AC-wlan-ap-office] map-configuration map.txt

# Bind service template st1 to radio 2, and then enable the radio.

[AC-wlan-ap-office] radio 2

[AC-wlan-ap-office-radio-2] service-template st1

[AC-wlan-ap-office-radio-2] radio enable

[AC-wlan-ap-office-radio-2] quit

[AC-wlan-ap-office] quit

3.     Configure an ISP domain:

# Create an ISP domain named dm1.

[AC] domain dm1

# Configure the AC to perform local authentication and not to perform authorization or accounting on portal users in the ISP domain.

[AC-isp-dm1] authentication portal local

[AC-isp-dm1] authorization portal none

[AC-isp-dm1] accounting portal none

# Configure the idle cut feature so that the AC will log out a user if the user's total traffic in the idle timeout period is less than 1024 bytes.

[AC-isp-dm1] authorization-attribute idle-cut 15 1024

[AC-isp-dm1] quit

4.     Configure portal authentication:

# Create a portal Web server named newpt, and specify http://2.2.2.1:8080/portal as the server's URL

[AC] portal web-server newpt

[AC-portal-websvr-newpt] url http://2.2.2.1:8080/portal

# Add parameter wlanuserip to the URL of the portal Web server and specify the user IP address as the value of the parameter.

[AC-portal-websvr-newpt] url-parameter wlanuserip source-address

[AC-portal-websvr-newpt] quit

# Create an HTTP-based local portal Web service.

[AC] portal local-web-server http

# Specify file abc.zip as the default authentication page file for the local portal Web service.

[AC–portal-local-websvr-http] default-logon-page abc.zip

[AC–portal-local-websvr-http] quit

# Create two destination-based portal-free rules to permit traffic to the DNS server.

[AC] portal free-rule 1 destination ip any udp 53

[AC] portal free-rule 2 destination ip any tcp 53

# Add a network access user named 123, set the password of the user, and assign the portal service to the user.

[AC] local-user 123 class network

[AC-luser-network-123] password simple 123

[AC-luser-network-123] service-type portal

[AC-luser-network-123] quit

# Enable roaming for portal users.

[AC] portal roaming enable

# Disable the Rule ARP entry feature.

[AC] undo portal refresh arp enable

# Enable validity check on wireless portal clients.

[AC] portal host-check enable

# Enable direct portal authentication on service template st1.

[AC] wlan service-template st1

[AC-wlan-st-st1] portal enable method direct

# Specify ISP domain dm1 as the portal authentication domain on service template st1.

[AC-wlan-st-st1] portal domain dm1

# Specify portal Web server newpt on service template st1.

[AC-wlan-st-st1] portal apply web-server newpt

# Enable service template st1.

[AC–wlan-st-st1] service-template enable

[AC-wlan-st-st1] quit

Configuring the switch

# Create VLAN 100, create VLAN-interface 100, and assign an IP address to the VLAN interface. The switch will use this VLAN to forward traffic on CAPWAP tunnels between the AC and the AP.

<Switch> system-view

[Switch] vlan 100

[Switch-vlan100] quit

[Switch] interface vlan-interface 100

[Switch-Vlan-interface100] ip address 2.2.1.100 24

[Switch-Vlan-interface100] quit

# Create VLAN 200, create VLAN-interface 200, and assign an IP address to the VLAN interface. The switch will use this VLAN to forward packets for wireless clients.

[Switch] vlan 200

[Switch-vlan200] quit

[Switch] interface vlan-interface 200

[Switch-Vlan-interface200] ip address 2.2.2.100 255.255.255.0

[Switch-Vlan-interface200] quit

# Configure GigabitEthernet 1/0/1 (the port connected to the AC) as a trunk port, and assign the port to VLAN 100.

[Switch] interface gigabitethernet 1/0/1

[Switch-GigabitEthernet1/0/1] port link-type trunk

[Switch-GigabitEthernet1/0/1] port trunk permit vlan 100

[Switch-GigabitEthernet1/0/1] quit

# Configure GigabitEthernet 1/0/2 (the port connected to the AP) as a trunk port, and assign the port to VLAN 100 and VLAN 200.

[Switch] interface gigabitethernet 1/0/2

[Switch-GigabitEthernet1/0/2] port link-type trunk

[Switch-GigabitEthernet1/0/2] port trunk permit vlan 100 200

[Switch-GigabitEthernet1/0/2] port trunk pvid vlan 100

# Enable PoE on GigabitEthernet 1/0/2.

[Switch-GigabitEthernet1/0/2] poe enable

[Switch-GigabitEthernet1/0/2] quit

Configuring the DHCP server

Configure required settings on the DHCP server. (Details not shown.)

Verifying the configuration

Verifying local portal authentication

# Use the configured username and password to perform portal authentication through a Web browser on the client. Before passing authentication, all Web accesses are redirected to the portal authentication page (http://2.2.2.1:8080/portal). After passing authentication, you can access other network resources. (Details not shown.)

# Display online portal user information on the AC.

[AC] display portal user all

Total portal users: 1

Username: Client

  Portal server: newpt

  State: Online

  VPN instance: N/A

  MAC             IP                    VLAN    Interface

  0021-6330-0933  2.2.2.2               200     Vlan-interface200

  Authorization information:

    DHCP IP pool: N/A

    User profile: N/A

    Session group profile: N/A

    ACL number: N/A

    Inbound CAR: N/A

    Outbound CAR: N/A

The output shows that the user has passed portal authentication.

Verifying local forwarding mode

# Display portal filtering rules on the AC.

[AC] display portal rule all ap office

Slot 1:

The output shows that the AC does not have portal filtering rules, indicating that the AC does not forward client data traffic.

# Display portal filtering rules on the AP.

[AP] display portal rule all

 

IPv4 portal rules on WLAN-BSS1/0/16:

Rule 1:

 Type                : Static

 Action              : Permit

 Protocol            : Any

 Status              : Active

 Source:

    IP             : 0.0.0.0

    Mask           : 0.0.0.0

    Port           : Any

    MAC            : 0000-0000-0000

    Interface      : WLAN-BSS1/0/16

    VLAN           : Any

 Destination:

    IP             : 2.2.2.1

    Mask           : 255.255.255.255

    Port           : Any

 

Rule 2:

 Type                : Dynamic

 Action              : Permit

 Status              : Active

 Source:

    IP             : 2.2.2.2

    MAC            : 0021-6330-0933

    Interface      : WLAN-BSS1/0/16

    VLAN           : Any

 

Rule 3:

 Type                : Static

 Action              : Redirect

 Status              : Active

 Source:

    IP             : 0.0.0.0

    Mask           : 0.0.0.0

    Interface      : WLAN-BSS1/0/16

    VLAN           : Any

    Protocol       : TCP

 Destination:

    IP             : 0.0.0.0

    Mask           : 0.0.0.0

    Port           : 443

 

Rule 4:

 Type                : Static

 Action              : Redirect

 Status              : Active

 Source:

    IP             : 0.0.0.0

    Mask           : 0.0.0.0

    Interface      : WLAN-BSS1/0/16

    VLAN           : Any

    Protocol       : TCP

 Destination:

    IP             : 0.0.0.0

    Mask           : 0.0.0.0

    Port           : 80

 

Rule 5:

 Type                : Static

 Action              : Deny

 Status              : Active

 Source:

    IP             : 0.0.0.0

    Mask           : 0.0.0.0

    Interface      : WLAN-BSS1/0/16

    VLAN           : Any

 Destination:

    IP             : 0.0.0.0

    Mask           : 0.0.0.0

The output shows that the AP has portal filtering rules, indicating that the AP forwards client data traffic.

Configuration files

·     AC:

#

vlan 100

#

wlan service-template st1

 ssid service

 vlan 200

 client forwarding-location ap

 portal enable method direct

portal domain dm1

 portal apply web-server newpt

 service-template enable

#

interface Vlan-interface100

 ip address 2.2.1.1 255.255.255.0

#

interface GigabitEthernet1/0/1

 port link-type trunk

 port trunk permit vlan 1 100

#

domain dm1

authorization-attribute idle-cut 15 1024

 authentication portal local

 authorization portal none

 accounting portal none

#

portal host-check enable

portal free-rule 1 destination ip any udp 53

portal free-rule 2 destination ip any tcp 53

#

portal roaming enable

 undo portal refresh arp enable

#

 portal web-server newpt

 url http://2.2.2.1:8080/portal

 url-parameter wlanuserip source-address

#

wlan ap office model WA4320i-ACN

 serial-id 219801A0CNC138011454

 map-configuration flash:/map.txt

 radio 1

 radio 2

  radio enable

  service-template st1

#

·     Switch:

#

vlan 100

#

vlan 200

#

interface Vlan-interface100

 ip address 2.2.1.100 255.255.255.0

#

interface Vlan-interface200

 ip address 2.2.2.100 255.255.255.0

#

interface GigabitEthernet1/0/1

 port link-type trunk

 port trunk permit vlan 1 100

#

interface GigabitEthernet1/0/2

 port link-type trunk

 port trunk permit vlan 1 100 200

 port trunk pvid vlan 100

poe enable

#

Related documentation

·     User Access and Authentication Command Reference in H3C Access Controllers Command Reference

·     User Access and Authentication Configuration Guide in H3C Access Controllers Configuration Guide

·     WLAN Access Command Reference in H3C Access Controllers Command Reference

·     WLAN Access Configuration Guide in H3C Access Controllers Configuration Guide

 

  • Cloud & AI
  • InterConnect
  • Intelligent Computing
  • Security
  • SMB Products
  • Intelligent Terminal Products
  • Product Support Services
  • Technical Service Solutions
All Services
  • Resource Center
  • Policy
  • Online Help
All Support
  • Become a Partner
  • Partner Resources
  • Partner Business Management
All Partners
  • Profile
  • News & Events
  • Online Exhibition Center
  • Contact Us
All About Us
新华三官网