03-CLI configuration examples (AC+fit AP)

HomeSupportDoc SetsDoc PackagesH3C Wireless Products All-in-One-6W10003-CLI configuration examples (AC+fit AP)
Table of Contents
Related Documents
33-Local MAC Authentication Configuration Examples

 

H3C Access Controllers

Comware 7 Local MAC Authentication

Configuration Examples

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Copyright © 2022 New H3C Technologies Co., Ltd. All rights reserved.

No part of this manual may be reproduced or transmitted in any form or by any means without prior written consent of New H3C Technologies Co., Ltd.

Except for the trademarks of New H3C Technologies Co., Ltd., any trademarks that may be mentioned in this document are the property of their respective owners.

The information in this document is subject to change without notice.



Introduction

The following information provides an example for configuring local MAC authentication in WLAN.

Prerequisites

The following information applies to Comware 7-based access controllers and access points. Procedures and information in the examples might be slightly different depending on the software or hardware version of the access controllers and access points.

The configuration examples were created and verified in a lab environment, and all the devices were started with the factory default configuration. When you are working on a live network, make sure you understand the potential impact of every command on your network.

The following information is provided based on the assumption that you have basic knowledge of MAC authentication, WLAN authentication, and WLAN access.

Example: Configuring local MAC authentication for wireless clients

Network configuration

As shown in Figure 1:

·     The AC centrally forwards the client traffic.

·     The AC acts as a DHCP server to provide IP addresses for the AP and the client.

Configure the AC to perform local MAC authentication to control the network access of the client. The MAC address of the client is used as the username and password for authentication. The MAC address is in hexadecimal notation without hyphens, and letters are in lower case.

Figure 1 Network diagram

 

Restrictions and guidelines

When you configure local MAC authentication for wireless clients, follow these restrictions and guidelines:

·     Use the serial ID labeled on the AP's rear panel to specify an AP.

·     Make sure the username and password configured on the AC are the same as the MAC address of the client. The username and password formats comply with the MAC authentication user account format.

·     Remove the ports that connect the AC to the AP from VLAN 1 in case there are too many packets in VLAN 1.

·     Some endpoints by default use random MAC addresses. To ensure successful MAC authentication for such an endpoint, disable the endpoint from using a random MAC address.

Procedures

Configuring the AC

1.     Configure interfaces on the AC:

# Create VLAN 100 and VLAN-interface 100, and assign an IP address to the VLAN interface. The AC will use this IP address to establish CAPWAP tunnels with the AP.

<AC> system-view

[AC] vlan 100

[AC-vlan100] quit

[AC] interface vlan-interface 100

[AC-Vlan-interface100] ip address 112.12.1.25 16

[AC-Vlan-interface100] quit

# Create VLAN 200 and VLAN-interface 200, and assign an IP address to the VLAN interface. VLAN 200 will be used for client access.

[AC] vlan 200

[AC-vlan200] quit

[AC] interface vlan-interface 200

[AC-Vlan-interface200] ip address 112.13.1.25 16

[AC-Vlan-interface200] quit

# Configure GigabitEthernet 1/0/1 (the port connected to the switch) as a trunk port, remove the port from VLAN 1, and assign it to VLANs 100 and 200.

[AC] interface gigabitethernet 1/0/1

[AC-GigabitEthernet1/0/1] port link-type trunk

[AC-GigabitEthernet1/0/1] undo port trunk permit vlan 1

[AC-GigabitEthernet1/0/1] port trunk permit vlan 100 200

# Set the PVID of GigabitEthernet 1/0/1 to VLAN 100.

[AC-GigabitEthernet1/0/1] port trunk pvid vlan 100

[AC-GigabitEthernet1/0/1] quit

2.     Configure DHCP:

# Enable DHCP.

[AC] dhcp enable

# Create a DHCP address pool named vlan100, and specify subnet 112.12.0.0/16 and gateway IP address 112.12.1.25 in the DHCP address pool.

[AC] dhcp server ip-pool vlan100

[AC-dhcp-pool-vlan100] network 112.12.0.0 mask 255.255.0.0

[AC-dhcp-pool-vlan100] gateway-list 112.12.1.25

[AC-dhcp-pool-vlan100] quit

# Create a DHCP address pool named vlan200, and specify subnet 112.13.0.0/16 and gateway IP address 112.13.1.25 in the DHCP address pool. In this example, the address of the DNS server is 112.13.1.25 (the gateway address). You must replace it with the actual address of the DNS server on your network.

[AC] dhcp server ip-pool vlan200

[AC-dhcp-pool-vlan200] network 112.13.0.0 mask 255.255.0.0

[AC-dhcp-pool-vlan200] gateway-list 112.13.1.25

[AC-dhcp-pool-vlan200] dns-list 112.13.1.25

[AC-dhcp-pool-vlan200] quit

3.     Configure a local authentication domain:

# Create an ISP domain named local-mac and configure the ISP domain to use local authentication for LAN access wireless clients. The AC does not perform authorization and accounting for LAN access nodes (in this example, wireless clients) in the ISP domain.

[AC] domain local-mac

[AC-isp-local-mac] authentication lan-access local

[AC-isp-local-mac] accounting lan-access none

[AC-isp-local-mac] authorization lan-access none

# Configure the idle cut feature for clients in ISP domain local-mac.

[AC-isp-local-mac] authorization-attribute idle-cut 15 1024

[AC-isp-local-mac] quit

4.     Configure a local user:

# Add a network access user. Configure both the username and password as the client's MAC address 3ca9f4144c20.

[AC] local-user 3ca9f4144c20 class network

[AC-luser-network-3ca9f4144c20] password simple 3ca9f4144c20

# Set the service type to lan-access.

[AC-luser-network-3ca9f4144c20] service-type lan-access

[AC-luser-network-3ca9f4144c20] quit

5.     Configure the AC to use the MAC address of each user as both the username and password for MAC authentication. The MAC addresses are in hexadecimal notation without hyphens and with letters in lower case. (The configuration in this step is the default configuration. This step is optional.)

[AC] mac-authentication user-name-format mac-address without-hyphen lowercase

6.     Configure a wireless service:

# Create a service template named 1 and enter its view.

[AC] wlan service-template 1

# Configure the SSID of service template 1 as service.

[AC-wlan-st-1] ssid service

# Assign clients coming online through the service template to VLAN 200.

[AC-wlan-st-1] vlan 200

# Set the authentication mode to MAC authentication.

[AC-wlan-st-1] client-security authentication-mode mac

# Specify ISP domain local-mac for MAC authentication clients on the service template.

[AC-wlan-st-1] mac-authentication domain local-mac

# Enable the service template.

[AC-wlan-st-1] service-template enable

[AC-wlan-st-1] quit

7.     Configure a manual AP, and bind service template 1 to an AP radio:

# Create a manual AP named officeap, and specify the AP model and serial ID.

[AC] wlan ap officeap model WA4320i-ACN

[AC-wlan-ap-officeap] serial-id 210235A1Q2C159000019

# Enter the view of radio 2, and bind service template 1 to radio 2.

[AC-wlan-ap-officeap] radio 2

[AC-wlan-ap-officeap-radio-2] service-template 1

# Enable radio 2.

[AC-wlan-ap-officeap-radio-2] radio enable

[AC-wlan-ap-officeap-radio-2] quit

[AC-wlan-ap-officeap] quit

Configuring the switch

# Create VLAN 100. The switch will use this VLAN to forward the traffic on the CAPWAP tunnels between the AC and AP.

<Switch> system-view

[Switch] vlan 100

[Switch-vlan100] quit

# Create VLAN 200. The switch will use this VLAN to forward packets for wireless clients.

[Switch] vlan 200

[Switch-vlan200] quit

# Configure GigabitEthernet 1/0/1 (the port connected to the AC) as a trunk port, remove the port from VLAN 1, and assign the trunk port to VLAN 100.

[Switch] interface gigabitethernet 1/0/1

[Switch-GigabitEthernet1/0/1] port link-type trunk

[Switch-GigabitEthernet1/0/1] undo port trunk permit vlan 1

[Switch-GigabitEthernet1/0/1] port trunk permit vlan 100

# Set the PVID of GigabitEthernet 1/0/1 to VLAN 100.

[Switch-GigabitEthernet1/0/1] port trunk pvid vlan 100

[Switch-GigabitEthernet1/0/1] quit

# Configure GigabitEthernet 1/0/2 (the port connected to the AP) as an access port. Assign the access port to VLAN 100.

[Switch] interface gigabitethernet 1/0/2

[Switch-GigabitEthernet1/0/2] port link-type access

[Switch-GigabitEthernet1/0/2] port access vlan 100

# Enable PoE on GigabitEthernet 1/0/2.

[Switch-GigabitEthernet1/0/2] poe enable

[Switch-GigabitEthernet1/0/2] quit

Verifying the configuration

# The client requests to access the network. On the AC, verify that the client has passed MAC authentication and come online on VLAN 200.

[AC] display wlan client

 Total Number of Clients           : 1

 

MAC address     Username       AP name     RID   IP address      IPv6 address   VLAN

3ca9-f414-4c20  3ca9f4144c20   officeap    2     112.13.0.2      N/A            200

Configuration files

·     AC:

#

dhcp enable

#

vlan 1

#

vlan 100

#

vlan 200

#

dhcp server ip-pool vlan100

 gateway-list 112.12.1.25

 network 112.12.0.0 mask 255.255.0.0

#

dhcp server ip-pool vlan200

 gateway-list 112.13.1.25

 network 112.13.0.0 mask 255.255.0.0

 dns-list 112.13.1.25

#

wlan service-template 1

 ssid service

 vlan 200

 client-security authentication-mode mac

 mac-authentication domain local-mac

 service-template enable

#

interface Vlan-interface100

 ip address 112.12.1.25 255.255.0.0

#

interface Vlan-interface200

 ip address 112.13.1.25 255.255.0.0

#

interface GigabitEthernet1/0/1

 port link-type trunk

 undo port trunk permit vlan 1

 port trunk permit vlan 100 200

 port trunk pvid vlan 100

#

domain local-mac

 authentication lan-access local

 accounting lan-access none

 authorization lan-access none

 authorization-attribute idle-cut 15 1024

#

local-user 3ca9f4144c20 class network

 password cipher $c$3$KWMkvq/FnQ2opPqBnpSTs3NPhVKrSOvqFPLAECSiDQ==

 service-type lan-access

 authorization-attribute user-role network-operator

#

wlan ap officeap model WA4320i-ACN

 serial-id 210235A1Q2C159000019

 vlan 1

 radio 1

 radio 2

  radio enable

  service-template 1

#

·     Switch:

#

vlan 1

#

vlan 100

#

vlan 200

#

interface GigabitEthernet1/0/1

 port link-type trunk

 undo port trunk permit vlan 1

 port trunk permit vlan 100

 port trunk pvid vlan 100

#

interface GigabitEthernet1/0/2

 port access vlan 100

 poe enable

#

Related documentation

·     AP and WT Management Configuration Guide in H3C Access Controllers Configuration Guides

·     AP and WT Management Command Reference in H3C Access Controllers Command References

·     Network Connectivity Configuration Guide in H3C Access Controllers Configuration Guides

·     Network Connectivity Command Reference in H3C Access Controllers Command References

·     User Access and Authentication Configuration Guide in H3C Access Controllers Configuration Guides

·     User Access and Authentication Command Reference in H3C Access Controllers Command References

·     WLAN Access Configuration Guide in H3C Access Controllers Configuration Guides

·     WLAN Access Command Reference in H3C Access Controllers Command References

 

  • Cloud & AI
  • InterConnect
  • Intelligent Computing
  • Security
  • SMB Products
  • Intelligent Terminal Products
  • Product Support Services
  • Technical Service Solutions
All Services
  • Resource Center
  • Policy
  • Online Help
All Support
  • Become a Partner
  • Partner Resources
  • Partner Business Management
All Partners
  • Profile
  • News & Events
  • Online Exhibition Center
  • Contact Us
All About Us
新华三官网