• 产品与解决方案
  • 行业解决方案
  • 服务
  • 支持
  • 合作伙伴
  • 新华三人才研学中心
  • 关于我们

H3C S5100-SI EI系列以太网交换机 操作手册-Release 2200(V1.02)

08-端口基本配置操作

本章节下载  (310.88 KB)

docurl=/cn/Service/Document_Software/Document_Center/Switches/Catalog/S5500/S5500-SI/Configure/Operation_Manual/S5500-SI_OM_(Release_2200(V1.02)/200801/329345_30005_0.htm

08-端口基本配置操作

v\:* {behavior:url(#default#VML);} o\:* {behavior:url(#default#VML);} w\:* {behavior:url(#default#VML);} .shape {behavior:url(#default#VML);}

第1章  端口基本配置

1.1  以太网端口简介

1.1.1  以太网端口的类型与数量

S5100-SI/EI系列以太网交换机能够提供的以太网端口类型与数量如表1-1所示。

表1-1 端口类型与数量简介

交换机型号

固定端口的类型与数量

扩展槽位数量

S5100-8P-SI

810/100/1000M以太网电口

2个千兆SFP

S5100-16P-SI

1610/100/1000M以太网电口

4个千兆SFP Combo

S5100-24P-SI

2410/100/1000以太网电口

4个千兆SFP Combo

S5100-48P-SI

4810/100/1000以太网电口

4个千兆SFP Combo

S5100-8P-EI

810/100/1000M以太网电口

2千兆SFP

S5100-16P-EI

1610/100/1000M以太网电口

4个千兆SFP Combo

S5100-24P-EI

2410/100/1000M以太网电口

4个千兆SFP Combo

S5100-48P-EI

4810/100/1000M以太网电口

4个千兆SFP Combo

S5100-26C-EI

2410/100/1000M以太网电口

4个千兆SFP Combo

2

S5100-50C-EI

4810/100/1000M以太网电口

4个千兆SFP Combo

2

S5100-8P-PWR-EI

810/100/1000M以太网电口

2个千兆SFP

S5100-16P-PWR-EI

1610/100/1000M以太网电口

4个千兆SFP Combo

S5100-26C-PWR-EI

2410/100/1000M以太网电口

4个千兆SFP Combo

2

S5100-50C-PWR-EI

4810/100/1000M以太网电口

4个千兆SFP Combo

2

 

1.1.2  Combo接口对应关系

&  说明:

在同一时刻,千兆SFP Combo口和对应的10/100/1000M自适应电口只有一个可用。也即是说,只有对SFP Combo口执行shutdown命令后,对应电口才能使用,反之亦然。

 

表1-2 Combo接口对应关系表

产品型号

SFP Combo

对应电口

S5100-16P-SI

S5100-16P-EI

S5100-16P-PWR-EI

GigabitEthernet1/0/17

GigabitEthernet1/0/14

GigabitEthernet1/0/18

GigabitEthernet1/0/16

GigabitEthernet1/0/19

GigabitEthernet1/0/13

GigabitEthernet1/0/20

GigabitEthernet1/0/15

S5100-24P-SI

S5100-24P-EI

S5100-26C-EI

S5100-26C-PWR-EI

GigabitEthernet1/0/25

GigabitEthernet1/0/22

GigabitEthernet1/0/26

GigabitEthernet1/0/24

GigabitEthernet1/0/27

GigabitEthernet1/0/21

GigabitEthernet1/0/28

GigabitEthernet1/0/23

S5100-48P-SI

S5100-48P-EI

S5100-50C-EI

S5100-50C-PWR-EI

GigabitEthernet1/0/49

GigabitEthernet1/0/46

GigabitEthernet1/0/50

GigabitEthernet1/0/48

GigabitEthernet1/0/51

GigabitEthernet1/0/45

GigabitEthernet1/0/52

GigabitEthernet1/0/47

 

1.1.3  以太网端口的链路类型

S5100-SI/EI系列以太网交换机支持的以太网端口链路类型有三种:

l              Access类型:端口只能属于1VLAN,一般用于交换机与终端用户之间的连接;

l              Trunk类型:端口可以属于多个VLAN,可以接收和发送多个VLAN的报文,一般用于交换机之间的连接;

l              Hybrid类型:端口可以属于多个VLAN,可以接收和发送多个VLAN的报文,可以用于交换机之间连接,也可以用于连接用户的计算机。

&  说明:

Hybrid端口可以允许多个VLAN的报文发送时不打标签,而Trunk端口只允许缺省VLAN的报文发送时不打标签。

 

三种类型的端口可以共存在一台设备上,但Trunk端口和Hybrid端口之间不能直接切换,只能先设为Access端口,再设置为其他类型端口。例如:Trunk端口不能直接被设置为Hybrid端口,只能先设为Access端口,再设置为Hybrid端口。

1.1.4  配置以太网端口的缺省VLAN ID

Access端口只能属于1VLAN,所以它的缺省VLAN就是它所在的VLAN,不用设置;Hybrid端口和Trunk端口可以属于多个VLAN,所以需要设置端口的缺省VLAN ID

配置了以太网端口的缺省VLAN ID后,端口对报文的接收和发送的处理有几种不同情况,具体描述请参见表1-3

表1-3 端口对收发报文的处理

端口类型

对接收报文的处理

发送报文时的处理

当接收到的报文不带Tag

当接收到的报文带有Tag

Access端口

接收该报文,并为报文添加缺省VLANTag

l      VLAN ID与缺省VLAN ID相同时:接收该报文

l      VLAN ID与缺省VLAN ID不同时:丢弃该报文

由于VLAN ID就是缺省VLAN ID,不用设置,去掉Tag后发送

Trunk端口

l      VLAN ID与缺省VLAN ID相同时:接收该报文

l      VLAN ID与缺省VLAN ID不同,但VLAN ID是该端口允许通过的VLAN ID时:接收该报文

l      VLAN ID与缺省VLAN ID不同,且VLAN ID不是该端口允许通过的VLAN ID时:丢弃该报文

l      VLAN ID与缺省VLAN ID相同时:去掉Tag,发送该报文

l      VLAN ID与缺省VLAN ID不同时:保持原有Tag,发送该报文

Hybrid端口

当报文中携带的VLAN ID是该端口允许通过的VLAN ID时,发送该报文,并可以通过port hybrid vlan命令配置端口在发送该VLAN(包括缺省VLAN)的报文时是否携带Tag

 

  注意:

建议将本端Hybrid端口或Trunk端口的缺省VLAN ID和相连的对端交换机的Hybrid端口或Trunk端口的缺省VLAN ID配置为一致,否则端口可能无法正确转发报文。

 

1.1.5  将当前端口加入指定VLAN

用户可以将当前以太网端口加入到指定的VLAN中。执行该配置以后,以太网端口就可以转发指定VLAN的报文,从而实现本交换机上的VLAN与对端交换机上相同VLAN的互通。

Access端口只能加入到1VLAN中,Hybrid端口和Trunk端口可以加入到多个VLAN中。

&  说明:

在将Access端口或Hybrid端口加入到指定的VLAN前,指定的VLAN必须已经创建。

 

1.2  配置以太网端口

1.2.1  以太网端口的基本配置

表1-4 以太网端口的基本配置

操作

命令

说明

进入系统视图

system-view

-

进入相应端口的视图

interface interface-type interface-number

-

打开以太网端口

undo shutdown

可选

缺省情况下,端口处于打开状态

如果想关闭端口,可以使用shutdown命令

设置以太网端口描述字符串

description text

可选

缺省情况下,端口没有配置描述字符串

设置以太网端口的双工模式

duplex { auto | full | half }

可选

缺省情况下,端口的双工模式为auto(自协商)

设置以太网端口的速率

speed { 10 | 100 | 1000 | auto }

可选

缺省情况下,端口的速率处于auto(自协商)状态

设置以太网端口的MDIMedium Dependent Interface)模式

mdi { across | auto | normal }

可选

缺省情况下,端口的MDI模式为auto

配置以太网端口允许通过的帧的最大长度为9216字节

jumboframe enable

可选

缺省情况下,以太网端口允许通过的帧的最大长度为9216字节;如果需要配置以太网端口允许通过的帧的最大长度为1536字节,可以使用undo jumboframe enable命令

 

&  说明:

l      Combo光口不支持配置speed命令和mdi命令。

l      扩展接口模块上的以太网端口不支持配置mdi命令。

 

1.2.2  配置当前端口的自协商速率

通过speed auto命令,可配置端口的自协商速率。

比如,对于一个10/100/1000Mbps端口:

l              如果用户希望该端口可以用于协商的速率只有10Mbps,则只需要配置speed auto 10

l              如果用户希望该端口可以用于协商的速率只有100Mbps1000Mbps,则只需要配置speed auto 100 1000

表1-5 配置当前端口的自协商速率

操作

命令

说明

进入系统视图

system-view

-

进入以太网端口视图

interface interface-type interface-number

-

配置端口自协商速率

speed auto [ 10 | 100 | 1000 ]*

可选

缺省情况下,千兆端口可协商的速率为10/100/1000 Mbps

 

&  说明:

l      目前只有设备前面板上的端口支持该特性,扩展接口板上的端口暂不支持。

l      配置了自协商速率后,若再执行undo speed或者speed auto命令,则端口自协商速率会恢复到默认状态。

l      如果配置端口可以支持全部自协商速率(即配置speed auto 10 100 1000),效果等同于speed auto

 

1.2.3  限制端口广播流量

通过以下配置任务,用户可以限制端口上允许接收的广播流量大小。当该类流量超过用户设置的阈值后,系统将对超出流量限制的报文进行丢弃,从而使该类流量所占的比例降低到合理的范围,保证网络业务的正常运行。

表1-6 限制端口广播流量

操作

命令

说明

进入系统视图

system-view

-

限制所有端口允许接收的广播流量的大小

broadcast-suppression { ratio | pps max-pps }

可选

缺省情况下,交换机不对广播流量进行抑制

进入以太网端口视图

interface interface-type interface-number

-

限制当前端口允许接收的广播流量的大小

broadcast-suppression { ratio | pps max-pps }

可选

缺省情况下,交换机不对广播流量进行抑制

 

1.2.4  配置端口的流量控制

当本端交换机和对端交换机都开启了流量控制功能后,如果本端交换机发生拥塞:

l              本端交换机将向对端交换机发送消息,通知对端交换机暂时停止发送报文或减慢发送报文的速度。

l              对端交换机在接收到该消息后,将暂停向本端发送报文或减慢发送报文的速度,从而避免了报文丢失现象的发生,保证了网络业务的正常运行。

表1-7 配置端口的流量控制

操作

命令

说明

进入系统视图

system-view

-

进入以太网端口视图

interface interface-type interface-number

-

开启以太网端口的流量控制功能

flow-control

必选

缺省情况下,端口的流量控制功能处于关闭状态

 

1.2.5  配置Access端口的相关属性

表1-8 配置Access端口的相关属性

操作

命令

说明

进入系统视图

system-view

-

进入以太网端口视图

interface interface-type interface-number

-

配置端口的链路类型为Access

port link-type access

可选

缺省情况下,端口的链路类型为Access

将当前Access端口加入到指定VLAN

port access vlan vlan-id

可选

缺省情况下,所有端口都属于VLAN 1

 

1.2.6  配置Hybrid端口的相关属性

表1-9 配置Hybrid端口的相关属性

操作

命令

说明

进入系统视图

system-view

-

进入以太网端口视图

interface interface-type interface-number

-

配置端口的链路类型为Hybrid

port link-type hybrid

必选

设置Hybrid端口的缺省VLAN ID

port hybrid pvid vlan vlan-id

可选

Hybrid端口的缺省VLANVLAN 1

将当前Hybrid端口加入到指定VLAN

port hybrid vlan vlan-id-list { tagged | untagged }

可选

缺省情况下,所有端口都属于VLAN 1

通过配置taggeduntagged参数,用户可以设置Hybrid端口在转发指定的VLAN报文时是否保留VLAN Tag

 

1.2.7  配置Trunk端口的相关属性

表1-10 配置Trunk端口的相关属性

操作

命令

说明

进入系统视图

system-view

-

进入以太网端口视图

interface interface-type interface-number

-

配置端口的链路类型为Trunk

port link-type trunk

必选

设置Trunk端口的缺省VLAN ID

port trunk pvid vlan vlan-id

可选

Trunk端口的缺省VLANVLAN 1

将当前Trunk端口加入到指定的VLAN

port trunk permit vlan { vlan-id-list | all }

可选

缺省情况下,所有端口都属于VLAN 1

 

1.2.8  取消端口输出Up/Down日志信息功能

以太网端口的物理连接状态有两种:UpDown。当以太网端口的物理连接状态发生改变时,交换机会向日志服务器发送日志信息,日志服务器也会做出相应的响应。如果以太网端口的物理连接状态经常改变,交换机就会频繁向日志服务器发送日志信息,从而加重日志服务器的负担、消耗大量的网络资源。

为了解决上述问题,用户可以有选择地取消某些端口输出Up/Down日志信息的功能,从而控制交换机向日志服务器发送日志信息的数量。

&  说明:

如果以太网端口的物理连接状态没有发生变化,即使启用了端口输出Up/Down日志信息的功能,交换机也不会向日志服务器发送日志信息,但是交换机会实时监控该端口。

 

1. 配置任务

表1-11 取消端口输出Up/Down日志信息功能

操作

命令

说明

进入系统视图

system-view

-

进入以太网端口视图

interface interface-type interface-number

-

取消端口输出Up/Down日志信息的功能

undo enable log updown

必选

缺省情况下,端口输出Up/Down日志信息的功能处于开启状态

 

2. 配置举例

# 在缺省情况下,端口GigabitEthernet 1/0/1输出Up/Down日志信息的功能处于开启状态,如果执行shutdownundo shutdown命令,系统将输出日志信息

<H3C> system-view

[H3C] interface GigabitEthernet 1/0/1

[H3C-GigabitEthernet1/0/1] shutdown

[H3C-GigabitEthernet1/0/1]

%Apr  2 08:11:14:220 2000 H3C L2INF/5/PORT LINK STATUS CHANGE:- 1 -

GigabitEthernet1/0/1 is DOWN

[H3C-GigabitEthernet1/0/1] undo shutdown

[H3C-GigabitEthernet1/0/1]

%Apr  2 08:11:32:253 2000 H3C L2INF/5/PORT LINK STATUS CHANGE:- 1 -

GigabitEthernet1/0/1 is UP

# 取消该功能后,如果执行shutdownundo shutdown命令,系统将不再输出日志信息

[H3C-GigabitEthernet1/0/1] undo enable log updown

[H3C-GigabitEthernet1/0/1] shutdown

[H3C-GigabitEthernet1/0/1] undo shutdown

1.2.9  将指定端口的配置拷贝到其它端口

为了方便将指定端口的配置与其他端口进行同步,用户可以使用copy configuration命令,将指定端口的配置拷贝到其他端口。

可以拷贝的配置包括VLAN配置、基于协议的VLAN配置、LACP配置、QoS配置、GARP配置、STP配置和端口基本配置。具体拷贝内容,请参见命令手册的描述。

表1-12 将指定端口的配置拷贝到其它端口

操作

命令

说明

进入系统视图

system-view

-

将指定端口的配置拷贝到其它端口

copy configuration source { interface-type interface-number | aggregation-group source-agg-id } destination { interface-list [ aggregation-group destination-agg-id ] | aggregation-group destination-agg-id }

必选

 

&  说明:

l      如果将拷贝的配置源(source)指定为聚合组,系统将以该聚合组中端口号最小的端口为配置源进行拷贝。

l      如果将拷贝的目的地(destination)指定为聚合组,则该聚合组内所有端口的配置都将改变为与配置源一致。

 

1.2.10  配置端口组

为了方便用户配置,对某些任务,设备提供对单个端口配置以及同时对一个端口组中的多个端口配置的功能。在端口组视图下,用户只需输入一次配置命令,则该端口组内的所有端口都会配置该功能,以减少重复配置工作。

端口组由用户手工创建,用户可将多个端口手工加入同一个端口组中,但一个端口只能加入一个端口组中。

表1-13 配置端口组

操作

命令

说明

进入系统视图

system-view

-

创建端口组或进入端口组视图

port-group group-id

必选

将指定端口加入到端口组中

port interface-list

必选

 

&  说明:

l      目前仅S5100-EI系列设备支持配置端口组。

l      对于同一个端口,加入聚合组之后则不能再加入端口组;反之亦然。

 

1.2.11  配置以太网端口进行环回监测

环回监测的目的是监测交换机的端口是否出现环路。

当用户开启以太网端口的环回监测功能后,交换机便定时监测各个端口是否被外部环回。如果发现某端口被环回,交换机会使该端口处于受控工作状态。

l              对于Access端口,如果系统发现端口被环回,则关闭该端口,并向终端上报Trap信息,同时删除该端口对应的MAC地址转发表项;

l              对于Trunk端口和Hybrid端口,如果系统发现端口被环回,则向终端上报Trap信息。当端口的环回监测受控功能也同时开启时,系统将关闭该端口,并向终端上报Trap信息,同时删除该端口对应的MAC地址转发表项。

表1-14 配置以太网端口进行环回监测

操作

命令

说明

进入系统视图

system-view

-

开启全局的端口环回监测功能

loopback-detection enable

必选

缺省情况下,全局的端口环回监测功能处于关闭状态

设置定时监测端口环回情况的时间间隔

loopback-detection interval-time time

可选

缺省情况下,系统定时监测端口环回情况的时间间隔30

进入以太网端口视图

interface interface-type interface-number

-

开启指定端口的环回监测功能

loopback-detection enable

必选

缺省情况下,端口环回监测功能处于关闭状态

开启Trunk端口和Hybrid端口的环回监测受控功能

loopback-detection control enable

可选

缺省情况下,端口的环回监测受控功能处于关闭状态

配置系统对当前TrunkHybrid端口上所有的VLAN进行环回监测

loopback-detection per-vlan enable

可选

缺省情况下,系统只对TrunkHybrid端口上的缺省VLAN进行环回监测

 

  注意:

l      只有在系统视图下和指定端口视图下均配置了loopback-detection enable命令后,该端口的环回监测功能才能启动。

l      当在系统视图下配置undo loopback-detection enable后,所有端口的环回监测功能均被关闭。

l      对于端口环回监测(loopback-detection)特性的相关命令和端口聚合的相关命令,不能同时配置。

 

1.2.12  配置以太网端口进行环回测试

用户可以配置以太网端口进行环回测试,检验以太网端口是否能正常工作。测试时端口将不能正确转发数据包,在执行一定时间后,环回测试会自动结束。

表1-15 配置以太网端口进行环回测试

操作

命令

说明

进入系统视图

system-view

-

进入以太网端口视图

interface interface-type interface-number

-

配置以太网端口进行环回测试

loopback { external | internal }

必选

 

&  说明:

l      external:进行外环测试。该测试需要在交换机端口上使用特制自环头(自环头能使端口发出的报文直接被端口接收。对于千兆电口使用的自环头,是用八芯网线中的八芯制作的),可定位该端口的硬件功能是否出现故障。

l      internal:进行内环测试。该测试在交换芯片内部建立自环,可定位芯片内与该端口相关的功能是否出现故障。

 

需要注意的是:

l              如果端口执行了shutdown命令,则不能进行loopback环回测试;

l              在进行环回测试时系统将禁止在端口上进行speedduplexmdishutdown命令的配置;

l              有些端口不支持环回测试,在这些端口上进行环回测试时系统会给出提示。

1.2.13  开启系统对连接电缆的检测功能

通过以下配置任务,用户可以开启系统对以太网电口连接电缆的检测功能,系统将在5秒内返回检测的结果。检测内容包括电缆的接收方向(RX)和发送方向(TX)是否存在短路、开路现象,同时可以检测出故障线缆的长度。

表1-16 开启系统对连接电缆的检测功能

操作

命令

说明

进入系统视图

system-view

-

进入以太网端口视图

interface interface-type interface-number

-

开启系统对以太网电口连接电缆的检测功能

virtual-cable-test

必选

 

&  说明:

l      光口(包括Combo光口)不支持电缆检测功能。

l      Combo电口处于非关闭状态(undo shutdown)时支持电缆检测功能;普通电口处于关闭或非关闭状态时均支持该功能。

 

1.2.14  设置端口统计信息的时间间隔

使用以下的配置任务可以设置端口统计信息的时间间隔。

在使用display interface interface-type interface-number命令显示端口信息时,系统显示的就是此时间间隔内的平均速率信息。比如用户设置统计信息的时间间隔为100秒,则相关显示信息为:

 Last 100 seconds input:  0 packets/sec 0 bytes/sec

 Last 100 seconds output:  0 packets/sec 0 bytes/sec

表1-17 设置端口统计信息的时间间隔

操作

命令

说明

进入系统视图

system-view

-

进入以太网端口视图

interface interface-type interface-number

-

设置端口统计信息的时间间隔

flow-interval interval

可选

缺省情况下,端口统计信息的时间间隔为300

 

1.2.15  端口基本配置显示与维护

在完成上述配置后,在任意视图下执行display命令可以显示配置后以太网端口的运行情况,通过查看显示信息验证配置的效果。在用户视图下执行reset counters命令,可以清除以太网端口的统计信息。

表1-18 端口基本配置显示与维护

操作

命令

说明

显示端口的配置信息

display interface [ interface-type | interface-type interface-number ]

display命令可以在任意视图下执行

显示指定端口组的配置信息

display port-group group-id

显示指定光口的相关信息

display transceiver-information interface interface-type interface-number

显示端口环回监测功能的开启情况

display loopback-detection

显示端口的简要配置信息

display brief interface [ interface-type [ interface-number ] ] [ | { begin | include | exclude } regular-expression ]

显示系统当前存在的指定类型的端口名称

display port { hybrid | trunk | combo }

显示指定Unit的端口信息

display unit unit-id interface

清除以太网端口的统计信息

reset counters interface [ interface-type | interface-type interface-number ]

reset命令请在用户视图下执行

当使能某个端口的802.1x特性后,该端口的统计信息不能被清除

 

1.3  以太网端口配置举例

1. 组网需求

l              交换机Switch A与对端交换机Switch B使用Trunk端口GigabitEthernet1/0/1相连;

l              端口GigabitEthernet1/0/1的缺省VLAN ID100

l              端口GigabitEthernet1/0/1允许VLAN2VLAN6VLAN 50VLAN100的报文通过。

2. 组网图

图1-1 以太网端口配置举例组网图

3. 配置步骤

&  说明:

l      以下只列出了Switch A上的配置,Switch B上应作类似的配置;

l      VLAN2VLAN6VLAN 50VLAN100均已创建。

 

# 进入GigabitEthernet1/0/1以太网端口视图。

<H3C> system-view

[H3C] interface GigabitGigabitEthernet1/0/1

# 配置端口GigabitEthernet1/0/1Trunk端口。

[H3C-GigabitGigabitEthernet1/0/1] port link-type trunk

# 允许VLAN2VLAN6VLAN 50VLAN100的报文通过端口GigabitEthernet1/0/1转发。

[H3C-GigabitGigabitEthernet1/0/1] port trunk permit vlan 2 6 to 50 100

# 配置端口GigabitEthernet1/0/1的缺省VLAN ID100

[H3C-GigabitGigabitEthernet1/0/1] port trunk pvid vlan 100

1.4  以太网端口排错

故障现象:配置端口的缺省VLAN ID不成功。

故障排除:可以按照如下步骤进行。

l              使用display interfacedisplay port命令检查该端口是否为Trunk端口或Hybrid端口。如果不是,则应先将其配置成Trunk端口或Hybrid端口。

l              接着再配置缺省VLAN ID

 

不同款型规格的资料略有差异, 详细信息请向具体销售和400咨询。H3C保留在没有任何通知或提示的情况下对资料内容进行修改的权利!

联系我们