• 产品与解决方案
  • 行业解决方案
  • 服务
  • 支持
  • 合作伙伴
  • 新华三人才研学中心
  • 关于我们

H3C S5100-SI EI系列以太网交换机 操作手册-Release 2200(V1.02)

06-Voice VLAN操作

本章节下载  (355.04 KB)

docurl=/cn/Service/Document_Software/Document_Center/Switches/Catalog/S5500/S5500-SI/Configure/Operation_Manual/S5500-SI_OM_(Release_2200(V1.02)/200801/329343_30005_0.htm

06-Voice VLAN操作

v\:* {behavior:url(#default#VML);} o\:* {behavior:url(#default#VML);} w\:* {behavior:url(#default#VML);} .shape {behavior:url(#default#VML);}

第1章  Voice VLAN配置

&  说明:

H3C S5100-SI/EI系列以太网交换机中,只有S5100-EI系列支持Voice VLAN功能。

 

1.1  Voice VLAN简介

Voice VLAN是为用户的语音数据流划分的VLAN。用户通过创建Voice VLAN并将连接语音设备的端口加入Voice VLAN,可以使语音数据自动被划分到Voice VLAN中进行传输,便于对语音流进行有针对性的QoSQuality of Service,服务质量)配置,提高语音流量的传输优先级,保证通话质量。

1.1.1  IP电话的工作原理

IP电话可以将语音模拟信号转换成数字信号,在IP网络上进行传输,配合其他语音设备为用户提供大容量、低费用的语音通信解决方案。与其他网络设备相同,IP电话也需要IP地址才能在网络中正常进行工作。一般情况下,IP电话通过网络中的DHCP服务器自动获取IP地址。

IP电话在向DHCP服务器申请IP地址过程中,通过Option184选项向DHCP服务器请求语音相关的扩展信息,包括:

l              网络呼叫处理器(Network Call Processor,简称NCP)的IP地址

l              备选NCP服务器的IP地址

l              Voice VLAN配置

l              Failover呼叫路由

下面以常用的组网方案为例介绍IP电话获取IP地址的过程。

&  说明

以下内容仅对一般情况下IP电话获取IP地址的过程进行描述,对于不同厂商的IP电话产品,其工作原理可能与以下的描述有所差异,具体情况请参见IP电话的用户手册。

 

图1-1 IP电话典型组网示意图

图1-1所示,IP电话需要通过与DHCP服务器和网络呼叫处理器配合,建立语音数据的发送路径。如图所示,IP电话从上电开机到具备向外界传输语音数据的能力,需要经历以下三个步骤:

(1)        IP电话上电后,会发出untagDHCP请求报文,报文中除包含请求自身IP的内容外,还会在Option184字段中包含四个特殊的请求信息。此untag报文将在接收端口缺省VLAN内进行广播,位于缺省VLAN内的DHCP Server1接收到该报文后,将回复给IP电话相应的信息:

l              如果DHCP Server1没有配置Option 184功能,则直接回应IP电话,告知为其分配的IP地址。该IP电话由于没有收到Voice VLAN信息,将只能发送untag报文,且在连接交换机的端口所在缺省VLAN内进行通信,因此接入端口的缺省VLAN就需要被手工设置为Voice VLAN

&  说明:

在这种情况下,将跳过后面的步骤23IP电话直接通过网关进行对外通信。

 

l              如果DHCP Server1已经配置了Option 184功能,则向IP电话发送回应报文,在告知为其分配的IP地址的同时携带网络呼叫处理器的IP地址及Voice VLAN的编号等信息。

(2)        如果IP电话通过DHCP Server1的回应报文获得了Voice VLAN信息,将放弃DHCP Server1分配的IP地址,重新构造DHCP请求报文,并为请求报文封装Voice VLANTag,向Voice VLAN中发送。工作在Voice VLAN中的DHCP Server2将为IP电话重新分配IP地址,并发送带Tag的回复报文。IP电话收到后,即可发送带有Voice VLAN Tag的语音数据。此时,需要交换机上连接IP电话的端口允许Voice VLAN报文携带Tag通过。

(3)        在获取到DHCP Server2分配的IP地址之后,IP电话将与DHCP Server1指定的网络呼叫处理器进行连接,下载软件,之后就可以正常进行通信了。

&  说明:

l      untag报文指没有携带VLAN Tag的报文。

l      tag报文指携带VLAN Tag的报文。

 

1.1.2  S5100-EI系列交换机对语音流的识别方法

S5100-EI系列以太网交换机可以根据进入端口的数据报文中的源MAC地址字段来判断该数据流是否为语音数据流,源MAC地址符合系统设置的语音设备OUIOrganizationally Unique Identifier,全球统一标识符)地址的报文被认为是语音数据流,接收语音流的端口将被自动划分到Voice VLAN中,传输语音数据。

用户可以预先设置OUI地址,也可以使用缺省的OUI地址作为判断标准。

&  说明:

OUI地址为MAC地址的前24位,是IEEE为不同设备供应商分配的一个全球唯一的标识符,从OUI地址可以判断出该设备是哪一个厂商的产品。S5100-EI系列交换机支持配置OUI地址的掩码,用户可以通过设定不同的掩码来调节交换机对MAC地址匹配的深度。

 

缺省情况下,S5100-EI系列交换机可以识别的OUI地址有5个,如表1-1所示。

表1-1 交换机预置的缺省OUI地址

序号

OUI地址

生产厂商

1

0003-6b00-0000

Cisco phone

2

000f-e200-0000

H3C Aolynk phone

3

00d0-1e00-0000

Pingtel phone

4

00e0-7500-0000

Polycom phone

5

00e0-bb00-0000

3Com phone

 

1.1.3  根据语音流设置端口的Voice VLAN的工作模式

用户可根据每个语音端口中数据流的实际情况设定端口的Voice VLAN工作模式,包括自动模式和手动模式。当接入的IP电话发送untag报文或tag报文时,交换机会采取不同的操作。

1. IP语音设备发送untag报文时的处理方式

l              自动模式下:S5100-EI系列交换机通过学习IP语音设备上电时发出的untag报文中的源MAC地址,自动将连接IP语音设备的端口加入Voice VLAN,并使用老化机制维护Voice VLAN内的端口数量。当达到端口老化时间时,不能更新OUI地址(没有语音流通过)的语音端口会自动从Voice VLAN 中删除;用户不能通过手工配置命令将端口加入Voice VLAN或从Voice VLAN中删除。

l              手动模式下:需要通过手工配置命令将端口加入Voice VLAN或从Voice VLAN中删除。

2. IP语音设备发送tag报文时的处理方式

对于IP语音设备发出的tag报文,两种模式处理方式一致,根据tag中的VLAN ID将报文在相应的VLAN内进行转发。

  注意:

l      如果用户的IP语音设备发出的是携带VLAN Tag的语音流,且接入的端口上开启了802.1x认证和guest VLAN,为保证各功能的正常使用,请为Voice VLAN、端口的缺省VLAN802.1xguest VLAN分配不同的VLAN ID

l      如果用户的IP语音设备发出的是不携带VLAN Tag的语音流,为实现Voice VLAN功能,只能将接入端口的缺省VLAN配置为Voice VLAN,此时将不能实现802.1x认证功能。

 

1.1.4  各类端口对Voice VLAN的支持情况

Voice VLAN功能支持使用AccessTrunkHybrid端口传输语音数据,交换机上原属于其它VLANTrunkHybrid端口可以通过开启Voice VLAN功能,同时传输语音和业务数据。

对于tag语音流和untag语音流,各种类型的端口需要满足不同的条件才能够支持,详细匹配关系如表1-2所示:

表1-2 端口类型与IP语音设备语音流类型配合关系表

端口Voice VLAN模式

语音流类型

端口类型

支持条件

自动模式

tag语音流

Access

不支持

Trunk

支持

接入端口的缺省VLAN必须存在且不能是Voice VLAN,同时接入端口允许缺省VLAN通过

Hybrid

支持

接入端口的缺省VLAN必须存在且不能是Voice VLAN,同时缺省VLAN应在接入端口允许通过的tagged VLAN列表中

untag语音流

Access

不支持

由于必须保证接入端口的缺省VLANVoice VLAN,且接入端口在Voice VLAN中,相当于通过手工方式将端口加入了Voice VLAN

Trunk

Hybrid

手动模式

tag语音流

Access

不支持

Trunk

支持

接入端口的缺省VLAN必须存在且不能是Voice VLAN,同时接入端口允许该缺省VLAN通过

Hybrid

支持

接入端口的缺省VLAN必须存在且在接入端口允许通过的tagged VLAN列表中

untag语音流

Access

支持

接入端口的缺省VLAN必须是Voice VLAN

Trunk

支持

接入端口的缺省VLAN必须是Voice VLAN,且接入端口允许该VLAN通过

Hybrid

支持

接入端口的缺省VLAN必须是Voice VLAN,且在接入端口允许通过的untagged VLAN列表中

 

1.1.5  Voice VLAN的安全模式

S5100-EI系列以太网交换机提供了Voice VLAN的安全模式功能,在开启安全模式后,Voice VLAN中将只能传输语音数据,有利于对语音流进行特有的传输优先级配置。在关闭安全模式后,Voice VLAN中可以同时传输语音数据和业务数据。

1.2  Voice VLAN配置

1.2.1  配置准备

l              配置Voice VLAN之前,须先创建对应的VLAN

l              VLAN 1是默认VLAN,无需创建,但VLAN 1不能被设置为Voice VLAN

1.2.2  配置自动模式下的Voice VLAN

表1-3 配置自动模式下的Voice VLAN

操作

命令

说明

进入系统视图

system-view

-

设置Voice VLAN可识别的其他OUI地址

voice vlan mac-address oui mask oui-mask [ description text ]

可选

缺省情况下,交换机按照缺省的OUI地址来判断语音流

开启Voice VLAN的安全模式

voice vlan security enable

可选

缺省情况下,端口的Voice VLAN安全模式开启

设置Voice VLAN的老化时间

voice vlan aging minutes

可选

缺省情况下,老化时间为1440分钟

开启全局Voice VLAN

voice vlan vlan-id enable

必选

进入以太网端口视图

interface interface-type interface-number

必选

开启端口Voice VLAN功能

voice vlan enable

必选

缺省情况下,端口的Voice VLAN处于关闭状态

开启端口的Voice VLAN legacy功能

voice vlan legacy

可选

缺省情况下,端口的Voice VLAN legacy功能处于关闭状态

设定端口Voice VLAN的工作模式为自动模式

voice vlan mode auto

可选

缺省情况下,端口的Voice VLAN工作模式为自动模式

 

  注意:

l      由于工作在自动模式下的端口不能通过命令配置加入Voice VLAN,因此,如果用户将某个VLAN同时配置为Voice VLAN和协议VLAN,则协议VLAN功能将不能与该端口进行绑定。关于协议VLAN的介绍请参见本手册“VLAN”部分。

l      工作在自动模式的端口,不能将缺省VLAN设置为Voice VLAN,否则系统会输出信息,提示用户无法进行配置。

 

&  说明:

l       

l      Voice VLAN正常工作时,如果设备重新启动,为保证已经建立的语音连接能够正常工作,系统会在重新启动后,将配置为自动模式的端口重新加入Voice VLAN,而不需要再次通过语音流的触发。

 

1.2.3  配置手动模式下的Voice VLAN

表1-4 配置手动模式下的Voice VLAN

操作

命令

说明

进入系统视图

system-view

-

设置Voice VLAN识别的其他OUI地址

voice vlan mac-address oui mask oui-mask [ description text ]

可选

如不设置,则交换机按照缺省的OUI地址来判断语音流

开启Voice VLAN的安全模式

voice vlan security enable

可选

缺省情况下,端口的Voice VLAN安全模式开启

设置Voice VLAN的老化时间

voice vlan aging minutes

可选

缺省情况下,老化时间为1440分钟

开启全局Voice VLAN

voice vlan vlan-id enable

必选

进入以太网端口视图

interface interface-type interface-number

-

开启端口Voice VLAN功能

voice vlan enable

必选

缺省情况下,端口的Voice VLAN处于关闭状态

开启端口的Voice VLAN legacy功能

voice vlan legacy

必选

缺省情况下,端口的Voice VLAN legacy功能处于关闭状态

设定端口Voice VLAN的工作模式为手动模式

undo voice vlan mode auto

必选

缺省情况下,端口的Voice VLAN工作模式为自动模式

退回到系统视图

quit

-

将手动模式端口加入Voice VLAN

access端口

进入VLAN视图

vlan vlan-id

必选

将端口加入VLAN

port interface-list

TrunkHybrid端口

进入端口视图

interface interface-type interface-number

将端口加入VLAN

port trunk permit vlan vlan-id

port hybrid vlan vlan-id { tagged | untagged }

设定Voice VLAN为端口默认VLAN

port trunk pvid vlan vlan-id

port hybrid pvid vlan vlan-id

可选

TrunkHybrid端口的默认VLAN是否需要设定为Voice VLAN依据表1-2中语音流类型与端口类型对应关系而定

 

  注意:

l      同一时刻只能有一个VLAN被配置为Voice VLAN

l      如果端口已经开启LACPLink Aggregation Control Protocol,链路汇聚控制协议),则不能开启Voice VLAN特性。

l      Voice VLAN功能只支持在静态VLAN上启动,不能配置动态VLAN作为Voice VLAN

l      当端口上应用的ACL数量达到上限时,将不能开启该端口的Voice VLAN功能。用户可以使用display voice vlan error-info命令定位开启失败的端口。

l      Voice VLAN工作在安全模式时,设备只允许源地址是可识别的语音OUI地址的数据通过,源地址不合法的报文将直接被丢弃(包括一些认证报文,如802.1x认证报文)。建议用户尽量不要在Voice VLAN中同时传输语音和业务数据。如确有此需要,请确认Voice VLAN的安全模式已关闭。

l      Voice VLAN legacy功能支持为来自其他友商语音设备的语音数据自动分配Voice VLAN,从而实现我公司设备与其他友商语音设备的互通。voice vlan legacy命令可以在全局及端口的Voice VLAN开启之前执行,但只有全局及端口的Voice VLAN功能开启之后才能生效。

 

&  说明:

TrunkHybrid端口加入Voice VLAN的相关命令,请参见《H3C S5100-SI/EI系列以太网交换机 命令手册》“端口基本配置”部分的介绍。

 

1.3  Voice VLAN配置显示

完成上述配置后,在任意视图下执行display命令,可以显示配置Voice VLAN后的运行情况。通过查看显示信息,用户可以验证配置的效果。

表1-5 Voice VLAN配置显示

操作

命令

说明

显示Voice VLAN开启失败的端口信息

display voice vlan error-info

display命令可以在任意视图下执行

显示Voice VLAN的配置状态

display voice vlan status

显示当前系统支持的OUI地址

display voice vlan oui

显示当前Voice VLAN中工作的端口

display vlan vlan-id

 

1.4  Voice VLAN典型配置举例

1.4.1  自动模式下Voice VLAN的配置举例

1. 组网需求

通过配置自动模式下的Voice VLAN,使接入IP电话的端口能够自动加入/退出Voice VLAN,并将语音流在该VLAN内传输。

l              创建VLAN2Voice VLAN,老化时间是100分钟。

l              IP电话发送tag语音流,接入端口是Hybrid类型端口GigabitEthernet1/0/1,端口的缺省VLANVLAN6

l              端口GigabitEthernet1/0/1工作在自动模式,且允许OUI地址是0011-2200-0000、掩码是ffff-ff00-0000的语音报文通过,描述字符为test

2. 组网图

图1-2 配置自动模式下Voice VLAN组网图

3. 配置步骤

# 创建VLAN2VLAN6

<DeviceA> system-view

[DeviceA] vlan 2

[DeviceA-vlan2] quit

[DeviceA] vlan 6

[DeviceA-vlan6] quit

# 设置Voice VLAN的老化时间。

[DeviceA] voice vlan aging 100

# 设置OUI地址0011-2200-0000Voice VLAN的合法地址,描述字符为“test”。

[DeviceA] voice vlan mac-address 0011-2200-0000 mask ffff-ff00-0000 description test

# 全局开启Voice VLAN功能。

[DeviceA] voice vlan 2 enable

# 将端口GigabitEthernet1/0/1Voice VLAN的工作模式设置为自动模式。可选缺省情况下端口的Voice VLAN工作在自动模式。

[DeviceA] interface GigabitEthernet 1/0/1

[DeviceA-GigabitEthernet1/0/1] voice vlan mode auto

# 将端口GigabitEthernet1/0/1设定为Hybrid端口。

[DeviceA-GigabitEthernet1/0/1] port link-type hybrid

# 设置端口的缺省VLANVLAN6且允许VLAN6的报文通过。

[DeviceA-GigabitEthernet1/0/1] port hybrid pvid vlan 6

[DeviceA-GigabitEthernet1/0/1] port hybrid vlan 6 tagged

# 开启端口Voice VLAN功能

[DeviceA-GigabitEthernet1/0/1] voice vlan enable

1.4.2  手动模式下Voice VLAN的配置举例

1. 组网需求

通过配置手动模式下的Voice VLAN,使接入IP电话的端口通过人为控制加入/退出Voice VLAN,并将语音流在该VLAN内传输。

l              创建VLAN2Voice VLAN

l              IP电话类型发送untag语音流,接入端口是Hybrid类型端口GigabitEthernet1/0/1

l              端口GigabitEthernet1/0/1工作在手动模式,且允许OUI地址是0011-2200-0000、掩码是ffff-ff00-0000的语音报文通过,描述字符为test

2. 组网图

图1-3 配置手动模式下Voice VLAN组网图

3. 配置步骤

# 设置Voice VLAN为安全模式,使得Voice VLAN端口只允许合法的语音报文通过。(可选,系统缺省为安全模式)

<DeviceA> system-view

[DeviceA] voice vlan security enable

# 设置OUI地址0011-2200-0000Voice VLAN的合法地址描述字符为test

[DeviceA] voice vlan mac-address 0011-2200-0000 mask ffff-ff00-0000 description test

# 创建VLAN2开启VLAN2Voice VLAN功能。

[DeviceA] vlan 2

[DeviceA-vlan2] quit

[DeviceA] voice vlan 2 enable

# 设置端口GigabitEthernet1/0/1工作在手动模式。

[DeviceA] interface GigabitEthernet 1/0/1

[DeviceA-GigabitEthernet1/0/1] undo voice vlan mode auto

# 设置端口GigabitEthernet1/0/1Hybrid类型。

[DeviceA-GigabitEthernet1/0/1] port link-type hybrid

# 设置Voice VLAN端口GigabitEthernet1/0/1缺省VLAN且在该端口允许通过的untagged VLAN列表中。

[DeviceA-GigabitEthernet1/0/1] port hybrid pvid vlan 2

[DeviceA-GigabitEthernet1/0/1] port hybrid vlan 2 untagged

# 开启端口GigabitEthernet1/0/1Voice VLAN功能。

[DeviceA-GigabitEthernet1/0/1] voice vlan enable

4. 显示与验证

# 显示当前系统支持的OUI地址、OUI地址掩码和描述信息。

<DeviceA> display voice vlan oui

Oui Address     Mask            Description

0003-6b00-0000  ffff-ff00-0000  Cisco phone

000f-e200-0000  ffff-ff00-0000  H3C Aolynk phone

0011-2200-0000  ffff-ff00-0000  test

00d0-1e00-0000  ffff-ff00-0000  Pingtel phone

00e0-7500-0000  ffff-ff00-0000  Polycom phone

00e0-bb00-0000  ffff-ff00-0000  3Com phone

# 显示当前Voice VLAN的状态。

<DeviceA> display voice vlan status

Voice Vlan status: ENABLE

Voice Vlan ID: 2

Voice Vlan security mode: Security

Voice Vlan aging time: 1440 minutes

Current voice vlan enabled port mode:

PORT                     MODE

----------------------------------------

GigabitEthernet1/0/1  MANUAL

 

 

不同款型规格的资料略有差异, 详细信息请向具体销售和400咨询。H3C保留在没有任何通知或提示的情况下对资料内容进行修改的权利!

联系我们