国家 / 地区

H3C MSR系列路由器典型配置举例(V5)-6W100

88-MSR系列路由器组播over GRE over MPLS功能的配置举例

本章节下载  (125.45 KB)

docurl=/cn/Service/Document_Software/Document_Center/Routers/Catalog/MSR/MSR_50/Configure/Typical_Configuration_Example/H3C_MSR_(V5)-6W100/201401/812799_30005_0.htm

88-MSR系列路由器组播over GRE over MPLS功能的配置举例

MSR系列路由器组播over GRE over MPLS功能的配置举例

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

H3C_彩色.emf

 



1  简介

本文档介绍MSR系列路由器组播over GRE over MPLS功能的配置

2  配置前提

本文档不严格与具体软、硬件版本对应,如果使用过程中与产品实际情况有差异,请参考相关产品手册,或以设备实际情况为准。

本文档中的配置均是在实验室环境下进行的配置和验证,配置前设备的所有参数均采用出厂时的缺省配置。如果您已经对设备进行了配置,为了保证配置效果,请确认现有配置和以下举例中的配置不冲突。

本文档假设您已了解MPLS、GRE隧道和PIM-SM特性。

3  配置举例

3.1  组网需求

图1所示3台MSR设备中有两台是PE设备,一台是P设备,PE1连接着组播源1.0.0.2,PE2连接着组播接收者2.0.0.2,PE1和PE2使用32位掩码地址建立一条GRE隧道,使GRE隧道流量都使用MPLS交换转发,在GRE隧道接口配置PIM SM协议,使组播流通过GRE隧道传到PE2,P设备只运行MPLS即可。

图1 组播over GRE over MPLS功能组网图

 

3.2  配置思路

为了实现组播和MPLS,路由器上启用MPLS LDP动态获取标签,在PE1和PE2的Eth0/0和Tunnel接口上使能PIM SM,并在连接组播接受者的接口上使能IGMP。

3.3  使用版本

本举例是在Release 2317版本上进行配置和验证的。

3.4  配置注意事项

·     保证MPLS基本配置无误,即PE1上有2.2.2.2/32的标签,PE2上有1.1.1.1/32的标签;

·     使用2.2.2.2和1.1.1.1建立GRE隧道;

·     GRE隧道当作普通的连接运行PIM SM。

3.5  配置步骤

3.5.1  PE1的配置

# 使能组播路由功能

<PE1> system-view

[PE1] multicast routing-enable

# 配置MPLS LSR-ID为Loopback0

[PE1] mpls lsr-id 1.1.1.1

# 使能MPLS转发功能

[PE1] mpls

# 使能MPLS LDP

[PE1-mpls] mpls ldp

[PE1-mpls-ldp] quit

# 使用ISIS作为IGP

[PE1] isis 1

[PE1-isis-1] network-entity 11.1111.1111.1111.00

[PE1-isis-1] quit

# Loopback0接口

[PE1] interface LoopBack0

[PE1-LoopBack0] ip address 1.1.1.1 255.255.255.255

[PE1-LoopBack0] isis enable 1

[PE1-LoopBack0] quit

# 连接P设备接口

[PE1] interface ethernet 0/0

[PE1-Ethernet0/0] port link-mode route

[PE1-Ethernet0/0] ip address 1.3.0.1 255.255.255.252

[PE1-Ethernet0/0] isis enable 1

[PE1-Ethernet0/0] isis small-hello

[PE1-Ethernet0/0] mpls

[PE1-Ethernet0/0] mpls ldp

[PE1-Ethernet0/0] quit

# 连接组播源接口

[PE1] interface ethernet 0/1

[PE1-Ethernet0/1] port link-mode route

[PE1-Ethernet0/1] ip address 1.0.0.1 255.255.255.0

[PE1-Ethernet0/1] isis enable 1

[PE1-Ethernet0/1] isis silent

[PE1-Ethernet0/1] pim sm

[PE1-Ethernet0/1] quit

[PE1] interface Tunnel0

[PE1-Tunnel0] ip address 1.2.1.1 255.255.255.252

[PE1-Tunnel0] source 1.1.1.1

[PE1-Tunnel0] destination 2.2.2.2

[PE1-Tunnel0] pim sm

[PE1-Tunnel0] quit

# PIM配置

[PE1] pim

[PE1-pim] c-bsr Tunnel0

[PE1-pim] c-rp Tunnel0

3.5.2  PE2的配置

# 使能组播功能

<PE2> system-view

[PE2] multicast routing-enable

[PE2] mpls lsr-id 2.2.2.2

[PE2] mpls

[PE2-mpls] mpls ldp

[PE2-mpls-ldp] quit

[PE2] isis 1

[PE2-isis-1] network-entity 22.2222.2222.2222.00

[PE2-isis-1] quit

[PE2] interface LoopBack0

[PE2-LoopBack0] ip address 2.2.2.2 255.255.255.255

[PE2-LoopBack0] isis enable 1

[PE2-LoopBack0] quit

# 连接P设备接口

[PE2] interface ethernet 0/0

[PE2-Ethernet0/0] port link-mode route

[PE2-Ethernet0/0] ip address 2.3.0.1 255.255.255.252

[PE2-Ethernet0/0] isis enable 1

[PE2-Ethernet0/0] isis small-hello

[PE2-Ethernet0/0] mpls

[PE2-Ethernet0/0] mpls ldp

[PE2-Ethernet0/0] quit

# 连接组播接收者端口

[PE2] interface ethernet 0/1

[PE2-Ethernet0/1] port link-mode route

[PE2-Ethernet0/1] ip address 2.0.0.1 255.255.255.0

[PE2-Ethernet0/1] isis enable 1

[PE2-Ethernet0/1] isis silent

[PE2-Ethernet0/1] igmp enable

[PE2-Ethernet0/1] quit

[PE2] interface Tunnel0

[PE2-Tunnel0] ip address 1.2.1.2 255.255.255.252

[PE2-Tunnel0] source 2.2.2.2

[PE2-Tunnel0] destination 1.1.1.1

[PE2-Tunnel0] pim sm

[PE2-Tunnel0] quit

[PE2] pim

[PE2-pim] quit

3.5.3  P的配置

<P> system-view

[P] mpls lsr-id 3.3.3.3

[P] mpls

[P-mpls] mpls ldp

[P-mpls-ldp] quit

[P] isis 1

[P-isis-1] network-entity 33.3333.3333.3333.00

[P-isis-1] quit

[P] interface ethernet 0/0

[P-Ethernet0/0] port link-mode route

[P-Ethernet0/0] ip address 1.3.0.2 255.255.255.252

[P-Ethernet0/0] isis enable 1

[P-Ethernet0/0] isis small-hello

[P-Ethernet0/0] mpls

[P-Ethernet0/0] mpls ldp

[P-Ethernet0/0] quit

[P] interface ethernet 0/1

[P-Ethernet0/1] port link-mode route

[P-Ethernet0/1] ip address 2.3.0.2 255.255.255.252

[P-Ethernet0/1] isis enable 1

[P-Ethernet0/1] isis small-hello

[P-Ethernet0/1] mpls

[P-Ethernet0/1] mpls ldp

[P-Ethernet0/1] quit

[P] interface LoopBack0

[P-LoopBack0] ip address 3.3.3.3 255.255.255.255

[P-LoopBack0] isis enable 1

[P-LoopBack0] quit

3.6  验证配置

# 查看PE 2上的LDP信息。

<PE2> display mpls ldp lsp

 

                              LDP LSP Information

 -------------------------------------------------------------------------------

 SN     DestAddress/Mask    In/OutLabel   Next-Hop        In/Out-Interface

 -------------------------------------------------------------------------------

 1      1.1.1.1/32          NULL/1025     2.3.0.2         -------/Eth0/0

 2      2.2.2.2/32          3/NULL        127.0.0.1       -------/InLoop0

 3      3.3.3.3/32          NULL/3        2.3.0.2         -------/Eth0/0

 -------------------------------------------------------------------------------

PE1与PE2与PE1之间已经建立标签。

#  查看PE 2上的PIM路由表信息。

[PE2] display pim routing-table

 VPN-Instance: public net

 Total 16 (*, G) entries; 16 (S, G) entries

 

 (*, 224.1.1.1)

     RP: 1.2.1.1

     Protocol: pim-sm, Flag: WC EXT

     UpTime: 00:02:31

     Upstream interface: Tunnel0

         Upstream neighbor: 1.2.1.1

         RPF prime neighbor: 1.2.1.1

     Downstream interface(s) information: None

 

 (1.0.0.2, 224.1.1.1)

     RP: 1.2.1.1

     Protocol: pim-sm, Flag: SPT ACT

     UpTime: 00:01:49

     Upstream interface: Tunnel0

         Upstream neighbor: 1.2.1.1

         RPF prime neighbor: 1.2.1.1

     Downstream interface(s) information: None

PE2RPF邻居为PE1,组播数据通过GRE隧道由PE1发往PE2

3.7  配置文件

·     设备PE1:

#

 multicast routing-enable

#

 mpls lsr-id 1.1.1.1

#

mpls

#

mpls ldp

#

isis 1

 network-entity 11.1111.1111.1111.00

#

interface Ethernet0/0

 port link-mode route

 ip address 1.3.0.1 255.255.255.252

 isis enable 1

 isis small-hello

 mpls

 mpls ldp

#

interface Ethernet0/1

 port link-mode route

 ip address 1.0.0.1 255.255.255.0

 isis enable 1

 isis silent

 pim sm

#

interface LoopBack0

 ip address 1.1.1.1 255.255.255.255

 isis enable 1

#

interface Tunnel0

 ip address 1.2.1.1 255.255.255.252

 source 1.1.1.1

 destination 2.2.2.2

 pim sm

#

pim

 c-bsr Tunnel0

 c-rp Tunnel0

#

·     设备PE2:

#

 multicast routing-enable

#

 mpls lsr-id 2.2.2.2

#

mpls

#

mpls ldp

#

isis 1

 network-entity 22.2222.2222.2222.00

#

interface Ethernet0/0

 port link-mode route

 ip address 2.3.0.1 255.255.255.252

 isis enable 1

 isis small-hello

 mpls

 mpls ldp

#

interface Ethernet0/1

 port link-mode route

 ip address 2.0.0.1 255.255.255.0

 isis enable 1

 isis silent

 igmp enable

 pim sm

#

interface LoopBack0

 ip address 2.2.2.2 255.255.255.255

 isis enable 1

#

interface Tunnel0

 ip address 1.2.1.2 255.255.255.252

 source 2.2.2.2

 destination 1.1.1.1

 pim sm

#

pim

#

·     设备P:

#

 multicast routing-enable

#

 mpls lsr-id 3.3.3.3

#

mpls

#

mpls ldp

#

isis 1

 network-entity 33.3333.3333.3333.00

#

interface Ethernet0/0

 port link-mode route

 ip address 1.3.0.2 255.255.255.252

 isis enable 1

 isis small-hello

 mpls

 mpls ldp

#

interface Ethernet0/1

 port link-mode route

 ip address 2.3.0.2 255.255.255.252

 isis enable 1

 isis small-hello

 mpls

 mpls ldp

#

interface NULL0

#

interface LoopBack0

 ip address 3.3.3.3 255.255.255.255

 isis enable 1

#

4  相关资料

·     H3C MSR 系列路由器 命令参考(V5)-R2311

·     H3C MSR 系列路由器 配置指导(V5)-R2311

 

不同款型规格的资料略有差异, 详细信息请向具体销售和400咨询。H3C保留在没有任何通知或提示的情况下对资料内容进行修改的权利!

联系我们 联系我们
联系我们
回到顶部 回到顶部