国家 / 地区

H3C MSR系列路由器典型配置举例(V5)-6W100

65-MSR系列路由器MPLS TE双向链路保护FRR功能的典型配置举例

本章节下载  (157.12 KB)

docurl=/cn/Service/Document_Software/Document_Center/Routers/Catalog/MSR/MSR_50/Configure/Typical_Configuration_Example/H3C_MSR_(V5)-6W100/201401/812776_30005_0.htm

65-MSR系列路由器MPLS TE双向链路保护FRR功能的典型配置举例

MSR系列路由器MPLS TE双向链路保护FRR功能的典型配置举例

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

H3C_彩色.emf

目  录

1 简介

2 配置前提

3 配置举例

3.1 组网需求

3.2 配置思路

3.3 使用版本

3.4 配置步骤

3.4.1 设备Router A配置

3.4.2 设备Router B配置

3.4.3 设备Router C配置

3.5 验证配置

3.6 配置文件

4 相关资料


1  简介

本文档介绍使用MPLS TE双向链路保护FRR功能的典型案例。

2  配置前提

本文档不严格与具体软、硬件版本对应,如果使用过程中与产品实际情况有差异,请参考相关产品手册,或以设备实际情况为准。

本文档中的配置均是在实验室环境下进行的配置和验证,配置前设备的所有参数均采用出厂时的缺省配置。如果您已经对设备进行了配置,为了保证配置效果,请确认现有配置和以下举例中的配置不冲突。

本文档假设您已了解MPLS TE的FRR功能特性。

3  配置举例

3.1  组网需求

图1所示,MPLS骨干网中,从Router ARouter C建立MPLS TE隧道Primary LSP,由Router DRouter E的报文优先选择Primary LSP进行转发。要求:

·     建立一条备份MPLS TE隧道Bypass LSP,当Primary LSP中断时,自动快速重路由到备份隧道Bypass LSP

·     MPLS TE隧道使用显式路径方式。

图1 MSR系列路由器MPLS TE双向链路保护FRR功能配置组网图

设备

接口

IP地址

设备

接口

IP地址

Router A

Loop0

1.1.1.1/32

Router B

Loop0

2.2.2.2/32

 

Eth0/1

192.168.1.1/24

 

Eth0/1

1.0.0.2/24

 

Eth0/2

3.0.0.1/24

 

Eth0/2

2.0.0.1/24

 

Eth0/3

1.0.0.1/24

Router D

Loop0

4.4.4.4/32

Router C

Loop0

3.3.3.3/32

 

Eth0/1

192.168.1.2/24

 

Eth0/1

192.168.2.1/24

Router E

Loop0

5.5.5.5/32

 

Eth0/2

3.0.0.2/24

 

Eth0/1

192.168.2.2/24

 

Eth0/3

2.0.0.2/24

 

 

 

 

3.2  配置思路

为了使数据报文在Primary LSP中断后快速重路由到Bypass LSP,需要将Bypass LSP绑定到被保护的接口,使得被保护接口中断时触发Bypass LSP

在配置MPLS TE隧道时,由于MPLS TE的LSP隧道是单向的,因此需要在Router A和Router C都向对方建立LSP,只有双向LSP都建立成功,发送给对方的报文才能正常转发回来。

3.3  使用版本

本举例是在Release 2311版本上进行配置和验证的。

3.4  配置步骤

3.4.1  设备Router A配置

# 配置设备接口地址。

<RouterA> system-view

[RouterA] interface loopback 0

[RouterA-LoopBack0] ip address 1.1.1.1 255.255.255.255

[RouterA-LoopBack0] quit

[RouterA] interface ethernet 0/1

[RouterA-Ethernet0/1] ip address 192.168.1.1 255.255.255.0

[RouterA-Ethernet0/1] quit

[RouterA] interface ethernet 0/2

[RouterA-Ethernet0/2] ip address 3.0.0.1 255.255.255.0

[RouterA-Ethernet0/2] quit

[RouterA] interface ethernet 0/3

[RouterA-Ethernet0/3] ip address 1.0.0.1 255.255.255.0

[RouterA-Ethernet0/3] quit

# 配置OSPF协议,使网络互通。

[RouterA] ospf 1

[RouterA-ospf-1] area 0.0.0.0

[RouterA-ospf-1-area-0.0.0.0] network 1.1.1.1 0.0.0.0

[RouterA-ospf-1-area-0.0.0.0] network 1.0.0.0 0.0.0.255

[RouterA-ospf-1-area-0.0.0.0] network 3.0.0.0 0.0.0.255

[RouterA-ospf-1-area-0.0.0.0] quit

[RouterA-ospf-1] quit

# 配置MPLS LSR-ID,使能MPLS TE和RSVP-TE。

[RouterA] router id 3.3.3.3

[RouterA] mpls lsr-id 3.3.3.3

[RouterA] mpls

[RouterA-mpls] mpls te

[RouterA-mpls] mpls te timer fast-reroute 1

[RouterA-mpls] mpls rsvp-te

[RouterA-mpls] mpls te cspf

[RouterA-mpls] quit

# 在接口使能MPLS基本能力,MPLS TEREVP-TE,并配置转发MPLS TE流量的链路最大带宽和最大可预留带宽

[RouterA] interface ethernet 0/2

[RouterA-Ethernet0/2] mpls

[RouterA-Ethernet0/2] mpls te

[RouterA-Ethernet0/2] mpls te max-link-bandwidth 50000

[RouterA-Ethernet0/2] mpls te max-reservable-bandwidth 50000

[RouterA-Ethernet0/2] mpls rsvp-te

[RouterA-Ethernet0/2] quit

[RouterA] interface ethernet 0/3

[RouterA-Ethernet0/3] mpls

[RouterA-Ethernet0/3] mpls te

[RouterA-Ethernet0/3] mpls te max-link-bandwidth 50000

[RouterA-Ethernet0/3] mpls te max-reservable-bandwidth 50000

[RouterA-Ethernet0/3] mpls rsvp-te

[RouterA-Ethernet0/3] quit

# 使能Opaque LSA能力。

[RouterA] ospf 1

[RouterA-ospf-1] opaque-capability enable

[RouterA-ospf-1] area 0.0.0.0

# 使能OSPF TE

[RouterA-ospf-1-area-0.0.0.0] mpls-te enable

[RouterA-ospf-1-area-0.0.0.0] quit

[RouterA-ospf-1] quit

# 配置主LSP的显式路径primary

[RouterA] explicit-path primary

[RouterA-explicit-path-primary] next hop 3.0.0.2

[RouterA-explicit-path-primary] next hop 3.3.3.3

[RouterA-explicit-path-primary] quit

# 配置主LSP

[RouterA] interface tunnel 0

[RouterA-Tunnel0] ip address 10.0.0.1 255.255.255.252

[RouterA-Tunnel0] tunnel-protocol mpls te

[RouterA-Tunnel0] destination 3.3.3.3

[RouterA-Tunnel0] mpls te tunnel-id 10

[RouterA-Tunnel0] mpls te record-route label

[RouterA-Tunnel0] mpls te bandwidth ct0 30000

#设置隧道优先级为1

[RouterA-Tunnel0] mpls te path explicit-path primary preference 1

# 使能FRR

[RouterA-Tunnel0] mpls te fast-reroute

[RouterA-Tunnel0] mpls te commit

[RouterA-Tunnel0] quit

# 配置Bypass LSP的显式路径bypass

[RouterA-mpls] explicit-path bypass

[RouterA-explicit-path-bypass] next hop 1.0.0.2

[RouterA-explicit-path-bypass] next hop 2.0.0.2

[RouterA-explicit-path-bypass] next hop 3.3.3.3

[RouterA-explicit-path-bypass] quit

# 配置Bypass LSP

[RouterA] interface tunnel 1

[RouterA-Tunnel1] ip address 20.0.0.1 255.255.255.252

[RouterA-Tunnel1] tunnel-protocol mpls te

[RouterA-Tunnel1] destination 3.3.3.3

[RouterA-Tunnel1] mpls te tunnel-id 20

[RouterA-Tunnel1] mpls te record-route label

[RouterA-Tunnel1] mpls te bandwidth ct0 30000

#设置隧道优先级为2

[RouterA-Tunnel1] mpls te path explicit-path bypass preference 2

# 配置Bypass LSP可保护的带宽。

[RouterA-Tunnel1] mpls te backup bandwidth 20000

[RouterA-Tunnel1] mpls te commit

[RouterA-Tunnel1] quit

# 将备份MPLS TE隧道绑定到被保护的接口。

[RouterA] interface ethernet 0/2

[RouterA-Ethernet0/2] mpls te fast-reroute bypass-tunnel tunnel 1

[RouterA-Ethernet0/2] quit

# 配置通过Tunnel隧道到192.168.2.0/24的静态路由,并配置高于OSPF 的优先级。

[RouterA] ip route-static 192.168.2.0 255.0.0.0 tunnel0 preference 1

[RouterA] ip route-static 192.168.2.0 255.0.0.0 tunnel1 preference 2

3.4.2  设备Router B配置

# 配置设备接口地址。

<RouterB> system-view

[RouterB] interface loopback 0

[RouterB-LoopBack0] ip address 2.2.2.2 255.255.255.255

[RouterB-LoopBack0] quit

[RouterB] interface ethernet 0/1

[RouterB-Ethernet0/1] port link-mode route

[RouterB-Ethernet0/1] ip address 1.0.0.2 255.255.255.0

[RouterB-Ethernet0/1] quit

[RouterB] interface ethernet 0/2

[RouterB-Ethernet0/2] port link-mode route

[RouterB-Ethernet0/2] ip address 2.0.0.1 255.255.255.0

[RouterB-Ethernet0/2] quit

# 配置OSPF协议,使网络互通。

[RouterB] ospf 1

[RouterB-ospf-1] area 0.0.0.0

[RouterB-ospf-1-area-0.0.0.0] network 2.2.2.2 0.0.0.0

[RouterB-ospf-1-area-0.0.0.0] network 1.0.0.0 0.0.0.255

[RouterB-ospf-1-area-0.0.0.0] network 2.0.0.0 0.0.0.255

 RouterB-ospf-1-area-0.0.0.0] quit

[RouterB-ospf-1] quit

# 配置MPLS LSR-ID,使能MPLS TE和RSVP-TE。

[RouterB] router id 2.2.2.2

[RouterB] mpls lsr-id 2.2.2.2

[RouterB] mpls

[RouterB-mpls] mpls te

[RouterB-mpls] mpls rsvp-te

[RouterB-mpls] mpls te cspf

[RouterB-mpls] quit

# 在接口使能MPLS基本能力,MPLS TEREVP-TE,并配置转发MPLS TE流量的链路最大带宽和最大可预留带宽

[RouterB] interface ethernet 0/1

[RouterB-Ethernet0/1] mpls

[RouterB-Ethernet0/1] mpls te

[RouterB-Ethernet0/1] mpls rsvp-te

[RouterB-Ethernet0/1] quit

[RouterB] interface ethernet 0/2

[RouterB-Ethernet0/2] mpls

[RouterB-Ethernet0/2] mpls te

[RouterB-Ethernet0/2] mpls rsvp-te

[RouterB-Ethernet0/2] quit

# 使能Opaque LSA能力。

[RouterB] ospf 1

[RouterB-ospf-1] opaque-capability enable

[RouterB-ospf-1] area 0.0.0.0

[RouterB-ospf-1-area-0.0.0.0] mpls-te enable

[RouterB-ospf-1-area-0.0.0.0] quit

[RouterB-ospf-1] quit

3.4.3  设备Router C配置

# 配置设备接口地址。

<RouterC> system-view

[RouterC] interface loopback 0

[RouterC-LoopBack0] ip address 3.3.3.3 255.255.255.255

[RouterC-LoopBack0] quit

[RouterC] interface ethernet 0/1

[RouterC-Ethernet0/1] port link-mode route

[RouterC-Ethernet0/1] ip address 192.168.2.1 255.255.255.0

[RouterC-Ethernet0/1] quit

[RouterC] interface ethernet 0/2

[RouterC-Ethernet0/2] port link-mode route

[RouterC-Ethernet0/2] ip address 3.0.0.2 255.255.255.0

[RouterC-Ethernet0/2] quit

[RouterC] interface ethernet 0/3

[RouterC-Ethernet0/3] port link-mode route

[RouterC-Ethernet0/3] ip address 2.0.0.2 255.255.255.0

[RouterC-Ethernet0/3] quit

# 配置OSPF协议,使网络互通。

[RouterC] ospf 1

[RouterC-ospf-1] area 0.0.0.0

[RouterC-ospf-1-area-0.0.0.0] network 3.3.3.3 0.0.0.0

[RouterC-ospf-1-area-0.0.0.0] network 3.0.0.0 0.0.0.255

[RouterC-ospf-1-area-0.0.0.0] network 2.0.0.0 0.0.0.255

[RouterC-ospf-1-area-0.0.0.0] quit

[RouterC-ospf-1] quit

# 配置MPLS LSR-ID,使能MPLS TERSVP-TE

[RouterC] router id 3.3.3.3

[RouterC] mpls lsr-id 3.3.3.3

[RouterC] mpls

[RouterC-mpls] mpls te

[RouterC-mpls] mpls te timer fast-reroute 1

[RouterC-mpls] mpls te cspf

[RouterC-mpls] quit

# 在接口使能MPLS基本能力,MPLS TEREVP-TE,并配置转发MPLS TE流量的链路最大带宽和最大可预留带宽

[RouterC] interface ethernet 0/2

[RouterC-Ethernet0/2] mpls

[RouterC-Ethernet0/2] mpls te

[RouterC-Ethernet0/2] mpls rsvp-te

[RouterC-Ethernet0/2] mpls te max-link-bandwidth 50000

[RouterC-Ethernet0/2] mpls te max-reservable-bandwidth 50000

[RouterC-Ethernet0/2] quit

[RouterC] interface ethernet 0/3

[RouterC-Ethernet0/3] mpls

[RouterC-Ethernet0/3] mpls te

[RouterC-Ethernet0/3] mpls rsvp-te

[RouterC-Ethernet0/3] mpls te max-link-bandwidth 50000

[RouterC-Ethernet0/3] mpls te max-reservable-bandwidth 50000

[RouterC-Ethernet0/3] quit

# 使能Opaque LSA能力。

[RouterC] ospf 1

[RouterC-ospf-1] opaque-capability enable

[RouterC-ospf-1] area 0.0.0.0

[RouterC-ospf-1-area-0.0.0.0] mpls-te enable

[RouterC-ospf-1-area-0.0.0.0] quit

[RouterC-ospf-1] quit

# 配置主LSP的显式路径primary

[RouterC] explicit-path primary

[RouterC-explicit-path-primary] next hop 3.0.0.1

[RouterC-explicit-path-primary] next hop 1.1.1.1

[RouterC-explicit-path-primary] quit

# 配置主LSP

[RouterC] interface tunnel 0

[RouterC-Tunnel0] ip address 10.0.0.2 255.255.255.252

[RouterC-Tunnel0] tunnel-protocol mpls te

[RouterC-Tunnel0] destination 1.1.1.1

[RouterC-Tunnel0] mpls te tunnel-id 10

[RouterC-Tunnel0] mpls te record-route label

[RouterC-Tunnel0] mpls te bandwidth ct0 30000

#设置隧道优先级为1

[RouterC-Tunnel0] mpls te path explicit-path primary preference 1

# 使能FRR

[RouterC-Tunnel0] mpls te fast-reroute

[RouterC-Tunnel0] mpls te commit

[RouterC-Tunnel0] quit

# 配置Bypass LSP的显式路径bypass

[RouterC] explicit-path bypass

[RouterC-explicit-path-bypass] next hop 2.0.0.1

[RouterC-explicit-path-bypass] next hop 1.0.0.1

[RouterC-explicit-path-bypass] next hop 1.1.1.1

[RouterC-explicit-path-bypass] quit

# 配置Bypass LSP

[RouterC] interface tunnel 1

[RouterC-Tunnel1] ip address 20.0.0.2 255.255.255.252

[RouterC-Tunnel1] tunnel-protocol mpls te

[RouterC-Tunnel1] destination 1.1.1.1

[RouterC-Tunnel1] mpls te tunnel-id 20

[RouterC-Tunnel1] mpls te record-route label

[RouterC-Tunnel1] mpls te bandwidth ct0 30000

#设置隧道优先级为2

[RouterC-Tunnel1] mpls te path explicit-path RouterB preference 2

[RouterC-Tunnel1] quit

# 配置Bypass LSP可保护的带宽。

[RouterC] mpls te backup bandwidth 20000

[RouterC-Tunnel1] mpls te commit

[RouterC-Tunnel1] quit

# Bypass LSP绑定到被保护的接口。

[RouterC] interface ethernet 0/2

[RouterC-Ethernet0/2] mpls te fast-reroute bypass-tunnel tunnel1

[RouterC-Ethernet0/2] quit

# 配置通过Tunnel隧道到192.168.2.0/24的静态路由,并配置高于OSPF 的优先级。

[RouterC] ip route-static 192.168.1.0 255.255.255.0 tunnel0 preference 1

[RouterC] ip route-static 192.168.1.0 255.255.255.0 tunnel1 preference 2

3.5  验证配置

# 在Router A上执行display mpls lsp命令,可以看到LSP表项

<RouterA> display mpls lsp

--------------------------------------------------------------------------

                 LSP Information: RSVP LSP

--------------------------------------------------------------------------

FEC                 In/Out Label  In/Out IF                       Vrf Name

3.3.3.3/32          NULL/1024     -/GE0/1

1.1.1.1/32          3/NULL        GE0/1/-

3.3.3.3/32          NULL/3        -/GE1/7

1.1.1.1/32          3/NULL        GE1/7/-

# 在Router A执行display mpls te tunnel命令,可以看到隧道的建立情况,有两条隧道经过。

<RouterA> display mpls te tunnel

LSP-Id                 Destination     In/Out-If                  Name

1.1.1.1:58             3.3.3.3         -/GE0/1                    Tunnel1

3.3.3.3:77             1.1.1.1         GE0/1/-                    Tunnel1

1.1.1.1:59             3.3.3.3         -/GE1/7                    Tunnel0

3.3.3.3:78             1.1.1.1         GE1/7/-                    Tunnel0

# 在Router A上执行display interface tunnel命令。

<RouterA> display interface tunnel

Tunnel0 current state: UP

Line protocol current state: UP

Description: Tunnel0 Interface

The Maximum Transmit Unit is 64000

Internet Address is 10.0.0.1/30 Primary

Encapsulation is TUNNEL, service-loopback-group ID not set.

Tunnel source unknown, destination 3.3.3.3

Tunnel bandwidth 64 (kbps)

Tunnel protocol/transport CR_LSP

Output queue : (Urgent queuing : Size/Length/Discards)  0/100/0

Output queue : (Protocol queuing : Size/Length/Discards)  0/500/0

Output queue : (FIFO queuing : Size/Length/Discards)  0/75/0

Last clearing of counters:  Never

    Last 300 seconds input:  0 bytes/sec, 0 packets/sec

    Last 300 seconds output:  1 bytes/sec, 0 packets/sec

    0 packets input,  0 bytes

    0 input error

    35 packets output,  2940 bytes

    0 output error

 

Tunnel1 current state: UP

Line protocol current state: UP

Description: Tunnel1 Interface

The Maximum Transmit Unit is 64000

Internet Address is 20.0.0.1/30 Primary

Encapsulation is TUNNEL, service-loopback-group ID not set.

Tunnel source unknown, destination 3.3.3.3

Tunnel bandwidth 64 (kbps)

Tunnel protocol/transport CR_LSP

Output queue : (Urgent queuing : Size/Length/Discards)  0/100/0

Output queue : (Protocol queuing : Size/Length/Discards)  0/500/0

Output queue : (FIFO queuing : Size/Length/Discards)  0/75/0

Last clearing of counters:  Never

    Last 300 seconds input:  0 bytes/sec, 0 packets/sec

    Last 300 seconds output:  1 bytes/sec, 0 packets/sec

    0 packets input,  0 bytes

    0 input error

    15 packets output,  1300 bytes

    0 output error

# 从Router D上ping Router E的接口Ethernet0/1地址,查看能否ping通。

<RouterD> ping 192.168.2.2

  PING 192.168.2.2: 56  data bytes, press CTRL_C to break

    Reply from 192.168.2.2: bytes=56 Sequence=0 ttl=252 time=1 ms

    Reply from 192.168.2.2: bytes=56 Sequence=1 ttl=252 time=1 ms

    Reply from 192.168.2.2: bytes=56 Sequence=2 ttl=252 time=1 ms

    Reply from 192.168.2.2: bytes=56 Sequence=3 ttl=252 time=1 ms

    Reply from 192.168.2.2: bytes=56 Sequence=4 ttl=252 time=1 ms

 

  --- 192.168.2.2 ping statistics ---

    5 packet(s) transmitted

    5 packet(s) received

    0.00% packet loss

    round-trip min/avg/max = 1/1/1 ms

# 继续在Router A上执行display interface tunnel命令,观察到数据包是经由Tunnel 0发送给目的地址。

<RouterA> display interface tunnel

Tunnel0 current state: UP

Line protocol current state: UP

Description: Tunnel0 Interface

The Maximum Transmit Unit is 64000

Internet Address is 10.0.0.1/30 Primary

Encapsulation is TUNNEL, service-loopback-group ID not set.

Tunnel source unknown, destination 3.3.3.3

Tunnel bandwidth 64 (kbps)

Tunnel protocol/transport CR_LSP

Output queue : (Urgent queuing : Size/Length/Discards)  0/100/0

Output queue : (Protocol queuing : Size/Length/Discards)  0/500/0

Output queue : (FIFO queuing : Size/Length/Discards)  0/75/0

Last clearing of counters:  Never

    Last 300 seconds input:  0 bytes/sec, 0 packets/sec

    Last 300 seconds output:  0 bytes/sec, 0 packets/sec

    0 packets input,  0 bytes

    0 input error

    40 packets output,  3360 bytes

    0 output error

 

Tunnel1 current state: UP

Line protocol current state: UP

Description: Tunnel1 Interface

The Maximum Transmit Unit is 64000

Internet Address is 20.0.0.1/30 Primary

Encapsulation is TUNNEL, service-loopback-group ID not set.

Tunnel source unknown, destination 3.3.3.3

Tunnel bandwidth 64 (kbps)

Tunnel protocol/transport CR_LSP

Output queue : (Urgent queuing : Size/Length/Discards)  0/100/0

Output queue : (Protocol queuing : Size/Length/Discards)  0/500/0

Output queue : (FIFO queuing : Size/Length/Discards)  0/75/0

Last clearing of counters:  Never

    Last 300 seconds input:  0 bytes/sec, 0 packets/sec

    Last 300 seconds output:  0 bytes/sec, 0 packets/sec

    0 packets input,  0 bytes

    0 input error

    15 packets output,  1300 bytes

    0 output error

# 在Router A上关闭接口Ethernet0/2

[RouterA] interface Ethernet0/2

[RouterA-Ethernet0/2] shutdown

[RouterA-Ethernet0/2] quit

# 再从Router D上ping Router E的接口Ethernet0/1地址,然后在Router A上执行display interface tunnel命令,观察到数据包是经由Tunnel 1发送给目的地址。

<RouterA> display interface tunnel

Tunnel0 current state: DOWN

Line protocol current state: DOWN

Description: Tunnel0 Interface

The Maximum Transmit Unit is 64000

Internet Address is 10.0.0.1/30 Primary

Encapsulation is TUNNEL, service-loopback-group ID not set.

Tunnel source unknown, destination 3.3.3.3

Tunnel bandwidth 64 (kbps)

Tunnel protocol/transport CR_LSP

Output queue : (Urgent queuing : Size/Length/Discards)  0/100/0

Output queue : (Protocol queuing : Size/Length/Discards)  0/500/0

Output queue : (FIFO queuing : Size/Length/Discards)  0/75/0

Last clearing of counters:  Never

    Last 300 seconds input:  0 bytes/sec, 0 packets/sec

    Last 300 seconds output:  0 bytes/sec, 0 packets/sec

    0 packets input,  0 bytes

    0 input error

    40 packets output,  3360 bytes

    0 output error

 

Tunnel1 current state: UP

Line protocol current state: UP

Description: Tunnel1 Interface

The Maximum Transmit Unit is 64000

Internet Address is 20.0.0.1/30 Primary

Encapsulation is TUNNEL, service-loopback-group ID not set.

Tunnel source unknown, destination 3.3.3.3

Tunnel bandwidth 64 (kbps)

Tunnel protocol/transport CR_LSP

Output queue : (Urgent queuing : Size/Length/Discards)  0/100/0

Output queue : (Protocol queuing : Size/Length/Discards)  0/500/0

Output queue : (FIFO queuing : Size/Length/Discards)  0/75/0

Last clearing of counters:  Never

    Last 300 seconds input:  0 bytes/sec, 0 packets/sec

    Last 300 seconds output:  0 bytes/sec, 0 packets/sec

    0 packets input,  0 bytes

    0 input error

    20 packets output,  1740 bytes

    0 output error

3.6  配置文件

·     Router A配置:

#

 router id 1.1.1.1

#

 mpls lsr-id 1.1.1.1

#

mpls

 mpls te

 mpls te timer fast-reroute 1

 mpls rsvp-te

 mpls te cspf

#

explicit-path RouterB

 next hop 1.0.0.2

 next hop 3.3.3.3

#

explicit-path primary

 next hop 3.0.0.2

 next hop 3.3.3.3

#

interface LoopBack0

 ip address 1.1.1.1 255.255.255.255

#

interface Ethernet0/1

 ip address 192.168.1.1 255.255.255.0

#

interface Ethernet0/2

 ip address 3.0.0.1 255.255.255.0

 mpls

 mpls te

 mpls te max-link-bandwidth 50000

 mpls te max-reservable-bandwidth 50000

 mpls te fast-reroute RouterB-tunnel Tunnel1

 mpls rsvp-te

#

interface Ethernet0/3

 ip address 1.0.0.1 255.255.255.0

 mpls

 mpls te

 mpls te max-link-bandwidth 50000

 mpls te max-reservable-bandwidth 50000

 mpls rsvp-te

#

interface Tunnel0

 ip address 10.0.0.1 255.255.255.252

 tunnel-protocol mpls te

 destination 3.3.3.3

 mpls te record-route label

 mpls te bandwidth ct0 30000

 mpls te path explicit-path primary preference 1

 mpls te fast-reroute

 mpls te commit

#

interface Tunnel1

 ip address 20.0.0.1 255.255.255.252

 tunnel-protocol mpls te

 destination 3.3.3.3

 mpls te tunnel-id 20

 mpls te record-route label

 mpls te bandwidth ct0 30000

 mpls te path explicit-path bypass preference 2

 mpls te backup bandwidth 20000

 mpls te commit

#

ospf 1

 opaque-capability enable

 area 0.0.0.0

  network 1.1.1.1 0.0.0.0

  network 1.0.0.0 0.0.0.255

  network 3.0.0.0 0.0.0.255

#

 ip route-static 192.168.2.0 255.0.0.0 Tunnel0 preference 1

 ip route-static 192.168.2.0 255.0.0.0 tunnel1 preference 2

·     Router B配置:

#

 router id 2.2.2.2

#

 mpls lsr-id 2.2.2.2

#

mpls

 mpls te

 mpls rsvp-te

 mpls te cspf

#

interface LoopBack0

 ip address 2.2.2.2 255.255.255.255

#

interface Ethernet0/1

 port link-mode route

 ip address 1.0.0.2 255.255.255.0

 mpls

 mpls te

 mpls rsvp-te

#

interface Ethernet0/2

 port link-mode route

 ip address 2.0.0.1 255.255.255.0

 mpls

 mpls te

 mpls rsvp-te

#

ospf 1

 opaque-capability enable

 area 0.0.0.0

  network 2.2.2.2 0.0.0.0

  network 2.0.0.0 0.0.0.255

  mpls-te enable

·     Router C配置:

#

 router id 3.3.3.3

#

 mpls lsr-id 3.3.3.3

#

mpls

 mpls te

 mpls te timer fast-reroute 1

 mpls te cspf

#

explicit-path RouterB

 next hop 2.0.0.1

 next hop 1.0.0.1

 next hop 1.1.1.1

#

explicit-path primary

 next hop 3.0.0.1

 next hop 1.1.1.1

#

interface LoopBack0

 address 3.3.3.3 255.255.255.255

#

interface Ethernet0/1

 port link-mode route

 ip address 192.168.2.1 255.255.255.0

#

interface Ethernet0/2

 ip address 3.0.0.2 255.255.255.0

 mpls

 mpls te

 mpls te max-link-bandwidth 50000

 mpls te max-reservable-bandwidth 50000

 mpls te fast-reroute bypass-tunnel Tunnel1

 mpls rsvp-te

#

interface Ethernet0/3

 port link-mode route

 ip address 2.0.0.2 255.255.255.0

 mpls

 mpls te

 mpls te max-link-bandwidth 50000

 mpls te max-reservable-bandwidth 50000

 mpls rsvp-te

#

interface Tunnel0

 ip address 10.0.0.2 255.255.255.252

 tunnel-protocol mpls te

 destination 1.1.1.1

 mpls te tunnel-id 10

 mpls te record-route label

 mpls te bandwidth ct0 30000

 mpls te path explicit-path primary preference 1

 mpls te fast-reroute

 mpls te commit

#

interface Tunnel1

 ip address 20.0.0.2 255.255.255.252

 tunnel-protocol mpls te

 destination 1.1.1.1

 mpls te tunnel-id 20

 mpls te record-route label

 mpls te bandwidth ct0 30000

 mpls te path explicit-path bypass preference 2

 mpls te backup bandwidth 20000

 mpls te commit

#

ospf 1

 opaque-capability enable

 area 0.0.0.0

  network 3.3.3.3 0.0.0.0

  network 3.0.0.0 0.0.0.255

  network 2.0.0.0 0.0.0.255

  mpls-te enable

#

 ip route-static 192.168.1.0 255.255.255.0 Tunnel0 preference 1

 ip route-static 192.168.1.0 255.255.255.0 Tunnel1 preference 2

4  相关资料

·     H3C MSR 系列路由器 命令参考(V5)-R2311

·     H3C MSR 系列路由器 配置指导(V5)-R2311

不同款型规格的资料略有差异, 详细信息请向具体销售和400咨询。H3C保留在没有任何通知或提示的情况下对资料内容进行修改的权利!