国家 / 地区

H3C MSR系列路由器典型配置举例(V5)-6W100

02-MSR系列路由器6to4站点间运行BGP4+功能的配置举例

本章节下载  (123.43 KB)

docurl=/cn/Service/Document_Software/Document_Center/Routers/Catalog/MSR/MSR_50/Configure/Typical_Configuration_Example/H3C_MSR_(V5)-6W100/201401/812713_30005_0.htm

02-MSR系列路由器6to4站点间运行BGP4+功能的配置举例

MSR系列路由器6to4站点间运行BGP4+功能的配置举例

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

H3C_彩色.emf

目  录

1 简介

2 配置前提

3 配置举例

3.1 组网需求

3.2 配置思路

3.3 使用版本

3.4 配置步骤

3.4.1 Router A的配置

3.4.2 Router B的配置

3.5 验证配置

3.6 配置文件

4 相关资料

 


1  简介

本文档介绍MSR路由器6to4站点间运行BGP4+功能的配置。

2  配置前提

本文档不严格与具体软、硬件版本对应,如果使用过程中与产品实际情况有差异,请参考相关产品手册,或以设备实际情况为准。

本文档中的配置均是在实验室环境下进行的配置和验证,配置前设备的所有参数均采用出厂时的缺省配置。如果您已经对设备进行了配置,为了保证配置效果,请确认现有配置和以下举例中的配置不冲突。

本文档假设您已了解6to4隧道和IPv6 BGP的相关特性。

3  配置举例

3.1  组网需求

图1所示,Router A和Router B是IPv6站点(包括6to4站点和非6to4站点)的出口路由器,Router A和Router B中间只能通过IPv4互连,要求采用6to4隧道技术建立IPv6互联,并通过BGP4+传递非6to4 IPv6路由。

图1 MSR路由器6to4站点间运行BGP4+功能的配置组网图

3.2  配置思路

·     普通的6to4隧道只能传递6to4路由,不能传递其它Ipv6路由,将BGP4+功能与6to4隧道结合使用,可以在6to4隧道中引入普通Ipv6路由。

·     为了让6to4隧道传递非6to4路由,指定BGP4+对等体时,必须指定为对端路由器隧道地址。

3.3  使用版本

本举例是在Release 2317版本上进行配置和验证的。

3.4  配置步骤

3.4.1  Router A的配置

# 配置Router A的路由器ID。

<RouterA> system-view

[RouterA] router id 1.1.1.1

# 全局使能IPv6报文转发功能。

[RouterA] ipv6

# 配置Ethernet1/0的IPv6地址。

[RouterA] interface ethernet 1/0

[RouterA-Ethernet1/0] ipv6 address 1::1/64

[RouterA-Ethernet1/0] quit

# 配置Ethernet1/1的6to4地址。

[RouterA] interface ethernet 1/1

[RouterA-Ethernet1/1] ipv6 address 2002:101:101::1/64

[RouterA-Ethernet1/1] quit

# 配置接口LoopBack0的IP地址。

[RouterA] interface loopback 0

[RouterA-LoopBack0] ip address 1.1.1.1 255.255.255.255

[RouterA-LoopBack0] quit

[RouterA] interface ethernet 0/0

[RouterA-Ethernet0/0] ip address 1.2.0.1 255.255.255.0

[RouterA-Ethernet0/0] quit

# 配置6to4隧道。

[RouterA] interface tunnel 0

[RouterA-Tunnel0] ipv6 address 2002:101:101:A::1/64

[RouterA-Tunnel0] tunnel-protocol ipv6-ipv4 6to4

[RouterA-Tunnel0] source loopback0

[RouterA-Tunnel0] quit

# 配置IPv6 BGP的基本功能。

[RouterA] bgp 100

[RouterA-bgp] undo synchronization

[RouterA-bgp] ipv6-family

# 引入非6to4站点的IPv6路由。

[RouterA-bgp-af-ipv6] network 1:: 64

[RouterA-bgp-af-ipv6] undo synchronization

# 指定BGP4+对等体,必须指定为Router B隧道地址。

[RouterA-bgp-af-ipv6] peer 2002:202:202:A::1 as-number 200

# 配置EBGP-MAX-HOP,因为EBGP4+连接地址不在同一网段。

[RouterA-bgp-af-ipv6] peer 2002:202:202:A::1 ebgp-max-hop 64

[RouterA-bgp-af-ipv6] quit

# 配置对方2.2.2.2的路由,保证1.1.1.1和2.2.2.2互通。

[RouterA] ip route-static 2.2.2.2 255.255.255.255 1.2.0.2

# 配置6to4路由。

[RouterA] ipv6 route-static 2002:: 16 tunnel0

[RouterA] quit

3.4.2  Router B的配置

# 配置Router B的路由器ID。

<RouterB> system-view

[RouterB] router id 2.2.2.2

# 全局使能IPv6报文转发功能。

[RouterB] ipv6

# 配置Ethernet1/0的IPv6地址。

[RouterB] interface ethernet 1/0

[RouterB-Ethernet1/0] ipv6 address 2::2/64

[RouterB-Ethernet1/0] quit

# 配置Ethernet1/1的6to4地址。

[RouterB] interface ethernet 1/1

[RouterB-Ethernet1/1] ipv6 address 2002:202:202::1/64

[RouterB-Ethernet1/1] quit

# 配置接口LoopBack0的IP地址。

[RouterB] interface loopback 0

[RouterB-LoopBack0] ip address 2.2.2.2 255.255.255.255

[RouterB-LoopBack0] quit

[RouterB] interface ethernet 0/0

[RouterB-Ethernet0/0] ip address 1.2.0.2 255.255.255.0

[RouterB-Ethernet0/0] quit

# 配置6to4隧道。

[RouterB] interface tunnel 0

[RouterB-Tunnel0] ipv6 address 2002:202:202:A::1/64

[RouterB-Tunnel0] tunnel-protocol ipv6-ipv4 6to4

[RouterB-Tunnel0] source loopback0

[RouterB-Tunnel0] quit

# 配置IPv6 BGP的基本功能。

[RouterB] bgp 200

[RouterB-bgp] undo synchronization

[RouterB-bgp] ipv6-family

# 引入非6to4站点的IPv6路由。

[RouterB-bgp-af-ipv6] network 2:: 64

[RouterB-bgp-af-ipv6] undo synchronization

# 指定BGP4+对等体,必须指定为Router A隧道地址。

[RouterB-bgp-af-ipv6] peer 2002:101:101:A::1 as-number 100

# 配置EBGP-MAX-HOP,因为EBGP4+连接地址不在同一网段。

[RouterB-bgp-af-ipv6] peer 2002:101:101:A::1 ebgp-max-hop 64

[RouterB-bgp-af-ipv6] quit

# 配置对方2.2.2.2的路由,保证1.1.1.1和2.2.2.2互通。

[RouterB] ip route-static 1.1.1.1 255.255.255.255 1.2.0.1

# 配置6to4路由。

[RouterB] ipv6 route-static 2002:: 16 tunnel0

[RouterB] quit

3.5  验证配置

配置正确完成后,路由器可以互相ping通对端路由器的IPv6地址。这里以Router A为例,可以ping通Router B的IPv6地址。

<RouterA> ping ipv6 2002:202:202::1

  PING 2002:202:202::1 : 56  data bytes, press CTRL_C to break

    Reply from 2002:202:202::1

    bytes=56 Sequence=0 hop limit=64  time = 2 ms

    Reply from 2002:202:202::1

    bytes=56 Sequence=1 hop limit=64  time = 2 ms

    Reply from 2002:202:202::1

    bytes=56 Sequence=2 hop limit=64  time = 2 ms

    Reply from 2002:202:202::1

    bytes=56 Sequence=3 hop limit=64  time = 2 ms

    Reply from 2002:202:202::1

    bytes=56 Sequence=4 hop limit=64  time = 2 ms

 

  --- 2002:202:202::1 ping statistics ---

    5 packet(s) transmitted

    5 packet(s) received

    0.00% packet loss

round-trip min/avg/max = 2/2/2 ms

3.6  配置文件

·     Router A:

#

router id 1.1.1.1

#

 ipv6

#

interface Ethernet1/1

 port link-mode route

ipv6 address 2002:101:101::1/64

#

interface Ethernet0/0

 port link-mode route

ip address 1.2.0.1 255.255.255.0

#

interface Ethernet1/0

 port link-mode route

 ipv6 address 1::1/64

#

interface LoopBack0

 ip address 1.1.1.1 255.255.255.255

#

interface Tunnel0

 ipv6 address 2002:101:101:A::1/64

 tunnel-protocol ipv6-ipv4 6to4

 source LoopBack0

#

bgp 100

 undo synchronization

 #

 ipv6-family

  network 1:: 64

  undo synchronization

  peer 2002:202:202:A::1 as-number 200

  peer 2002:202:202:A::1 ebgp-max-hop 64

#

ip route-static 2.2.2.2 255.255.255.255 1.2.0.2

#

 ipv6 route-static 2002:: 16 Tunnel0

#

·     Router B:

#

router id 2.2.2.2

#

 ipv6

#

interface Ethernet1/1

 port link-mode route

ipv6 address 2002:202:202::1/64

#

interface Ethernet0/0

 port link-mode route

ip address 1.2.0.2 255.255.255.0

#

interface Ethernet1/0

 port link-mode route

 ipv6 address 2::2/64

#

interface LoopBack0

 ip address 2.2.2.2 255.255.255.255

#

interface Tunnel0

 ipv6 address 2002:202:202:A::1/64

 tunnel-protocol ipv6-ipv4 6to4

 source LoopBack0

#

bgp 200

 undo synchronization

 #

 ipv6-family

  network 2:: 64

  undo synchronization

  peer 2002:101:101:A::1 as-number 100

  peer 2002:101:101:A::1 ebgp-max-hop 64

#

 ip route-static 1.1.1.1 255.255.255.255 1.2.0.1

#

 ipv6 route-static 2002:: 16 Tunnel0

#

4  相关资料

·     H3C MSR 系列路由器 命令参考(V5)-R2311

·     H3C MSR 系列路由器 配置指导(V5)-R2311

不同款型规格的资料略有差异, 详细信息请向具体销售和400咨询。H3C保留在没有任何通知或提示的情况下对资料内容进行修改的权利!

联系我们 联系我们
联系我们
回到顶部 回到顶部