国家 / 地区

H3C MSR系列路由器典型配置举例(V5)-6W100

49-MSR系列路由器Static Route配置举例

本章节下载  (123.96 KB)

docurl=/cn/Service/Document_Software/Document_Center/Routers/Catalog/MSR/MSR_50/Configure/Typical_Configuration_Example/H3C_MSR_(V5)-6W100/201401/812760_30005_0.htm

49-MSR系列路由器Static Route配置举例

MSR系列路由器静态路由的典型配置举例

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

H3C_彩色.emf

 



1  简介

本文档介绍使用静态路由使网络互通的典型配置举例。

2  配置前提

本文档不严格与具体软、硬件版本对应,如果使用过程中与产品实际情况有差异,请参考相关产品手册,或以设备实际情况为准。

本文档中的配置均是在实验室环境下进行的配置和验证,配置前设备的所有参数均采用出厂时的缺省配置。如果您已经对设备进行了配置,为了保证配置效果,请确认现有配置和以下举例中的配置不冲突。

本文档假设您已了解Static Route的特性。

3  配置举例

3.1  组网需求

图1所示,Router A通过Router B和Cisco 3745连接,现要求:通过配置静态路由,使Router A与Cisco 3745能够互相ping通。

图1 MSR路由器静态路由组网图

 

3.2  使用版本

本举例是在Release 2311版本上进行配置和验证的。

3.3  配置步骤

3.3.1  Router A的配置

# 配置接口IP地址。

<RouterA> system-view

[RouterA] interface gigabitethernet 0/1

[RouterA-GigabitEthernet0/1] ip address 29.61.1.1 24

[RouterA-GigabitEthernet0/1] quit

# 配置静态路由。

[RouterA] ip route-static 23.1.1.0 24 29.61.1.2

3.3.2  Router B的配置

# 配置接口IP地址。

<RouterB> system-view

[RouterB] interface gigabitethernet 0/1

[RouterB-GigabitEthernet0/1] ip address 29.61.1.2 24

[RouterB-GigabitEthernet0/1] quit

[RouterB] interface gigabitethernet 0/0

[RouterB-GigabitEthernet0/0] ip address 23.1.1.2 24

[RouterB-GigabitEthernet0/0] quit

3.3.3  Cisco 3745的配置

# 配置接口IP地址。

Cisco3745> enable

Cisco3745# configure terminal

Cisco3745(config)# interface ethernet 0/1

Cisco3745(config-if)# ip address 23.1.1.1 255.255.255.0

Cisco3745(config-if)# exit

# 配置静态路由。

Cisco3745(config)# ip route 29.61.1.0 255.255.255.0 23.1.1.2

Cisco3745(config)# exit

3.4  验证结果

# 在Router A上ping Cisco 3745的接口地址,能够ping通对方。

<RouterA> ping 23.1.1.1

  PING 23.1.1.1: 56  data bytes, press CTRL_C to break

    Reply from 23.1.1.1: bytes=56 Sequence=1 ttl=254 time=1 ms

    Reply from 23.1.1.1: bytes=56 Sequence=2 ttl=254 time=1 ms

    Reply from 23.1.1.1: bytes=56 Sequence=3 ttl=254 time=1 ms

    Reply from 23.1.1.1: bytes=56 Sequence=4 ttl=254 time=1 ms

    Reply from 23.1.1.1: bytes=56 Sequence=5 ttl=254 time=1 ms

 

  --- 23.1.1.1 ping statistics ---

    5 packet(s) transmitted

    5 packet(s) received

    0.00% packet loss

    round-trip min/avg/max = 1/1/1 ms

# 在Cisco 3745上ping Router A的接口地址,能够ping通对方。

Cisco3745# ping 29.61.1.1

 

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 29.61.1.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms

3.5  配置文件

·     Router A

#

 sysname RouterA

#

interface GigabitEthernet0/1

 port link-mode route

 ip address 29.61.1.1 255.255.255.0

#

 ip route-static 23.1.1.0 255.255.255.0 29.61.1.2

#

·     Router B:

#

 sysname RouterB

#

interface GigabitEthernet0/0

 port link-mode route

 ip address 23.1.1.2 255.255.255.0

#

interface GigabitEthernet0/1

 port link-mode route

 ip address 29.61.1.2 255.255.255.0

#

·     Cisco 3745:

!

hostname Cisco3745

!

interface Ethernet0/1

 ip address 23.1.1.1 255.255.255.0

 duplex auto

 speed auto

!

ip route 29.61.1.0 255.255.255.0 23.1.1.2

!

4  相关资料

·     H3C MSR 系列路由器 命令参考(V5)-R2311

·     H3C MSR 系列路由器 配置指导(V5)-R2311

不同款型规格的资料略有差异, 详细信息请向具体销售和400咨询。H3C保留在没有任何通知或提示的情况下对资料内容进行修改的权利!