国家 / 地区

H3C MSR系列路由器典型配置举例(V5)-6W100

22-MSR系列路由器IPv6 NATPT与DNS-ALG配合功能的配置举例

本章节下载  (595.3 KB)

docurl=/cn/Service/Document_Software/Document_Center/Routers/Catalog/MSR/MSR_50/Configure/Typical_Configuration_Example/H3C_MSR_(V5)-6W100/201401/812733_30005_0.htm

22-MSR系列路由器IPv6 NATPT与DNS-ALG配合功能的配置举例

MSR系列路由器IPv6 NATPT与DNS-ALG配合功能的配置举例

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

H3C_彩色.emf

 



1  简介

本文档介绍MSR系列路由器IPv6 NAT-PT与DNS-ALG配合功能的配置。

2  配置前提

本文档不严格与具体软、硬件版本对应,如果使用过程中与产品实际情况有差异,请参考相关产品手册,或以设备实际情况为准。

本文档中的配置均是在实验室环境下进行的配置和验证,配置前设备的所有参数均采用出厂时的缺省配置。如果您已经对设备进行了配置,为了保证配置效果,请确认现有配置和以下举例中的配置不冲突。

本文档假设您已了解NAT-PT和DNS特性。

3  配置举例

3.1  组网需求

图1所示,Router A是NATPT设备,在IPv4侧分别连接着一个DNS服务器(2.0.0.2)和一个纯IPv4主机(1.0.0.2),IPv6侧使用一台MSR路由器Router B代替。

图1 IPv6 NAT-PT与DNS-ALG配合功能的配置组网图

3.2  配置思路

为了让两侧互通,需要在Router A配置两个地址映射。创建一个静态映射把IPV6侧的RouterB的地址转换为IPv4地址,用于IPv4侧PC根据解析后的IPv4地址访问IPv6侧;动态地址是把符合前缀的源地址为IPv6的地址转换为地址池中的地址。

在DNS服务器 配置Host A和Router B的正向域名解析记录,使双方可以ping通对方域名。

3.3  使用版本

本举例是在Release 2317版本上进行配置和验证的。

3.4  配置注意事项

·     从IPv4 PC发起测试,则该PC必须禁用IPv6,如PC执行ping rtb.h3c,则会向2.0.0.2发送DNS请求,由于PC和DNS服务器都在IPv4侧,RTA并不需要进行特殊处理,只进行正常的IP包转发。

·     从Ipv6侧主动发起测试,路由器要采用静态NATPT映射,并且映射后的IPv4地址要和DNS 正向域名解析记录地址一致。

3.5  配置步骤

3.5.1  Router A的配置

<RouterA> system-view

# 使能DNS解析动态DNS解析功能

[RouterA] dns resolve

# 配置DNS服务器地址

[RouterA] dns server 2.0.0.2

[RouterA] ipv6

# 配置NATPT地址池1,地址范围1.0.0.10到1.0.0.20

[RouterA] natpt address-group 1 1.0.0.10 1.0.0.20

# 配置IPv6侧的静态地址映射,用于IPv4侧PC根据解析后访问IPv6侧,需要与DNS服务器配置一致

[RouterA] natpt v6bound static 0001::0002 3.0.0.1

# 配置NATPT前缀2::,当IPv6侧访问2::时会触发路由器进行NATPT转换

[RouterA] natpt prefix 0002::

# 配置IPv6侧动态地址翻译,将前缀和地址绑定起来

[RouterA] natpt v6bound dynamic prefix 0002:: address-group 1

# 连接DNS服务器的接口,使能NATPT

[RouterA] interface ethernet 0/0

[RouterA-Ethernet0/0] port link-mode route

[RouterA-Ethernet0/0] ip address 2.0.0.1 255.255.255.0

[RouterA-Ethernet0/0] natpt enable

[RouterA-Ethernet0/0] quit

# 连接RTB的IPv6接口,使能NATPT

[RouterA] interface ethernet 0/1

[RouterA-Ethernet0/1] port link-mode route

[RouterA-Ethernet0/1] ipv6 address 1::1/64

[RouterA-Ethernet0/1] natpt enable

[RouterA-Ethernet0/1] quit

# 连接IPv4主机的接口,使能NATPT

[RouterA] interface ethernet 0/2

[RouterA-Ethernet0/2] port link-mode route

[RouterA-Ethernet0/2] ip address 1.0.0.1 255.255.255.0

[RouterA-Ethernet0/2] natpt enable

[RouterA-Ethernet0/2] quit

3.5.2  Router B的配置

<RouterB> system-view

# 使能DNS动态解析功能

[RouterB] dns resolve

# 配置IPv6 DNS服务器地址2::200:2,该地址会被RTA转换成2.0.0.2

[RouterB] dns server ipv6 2::200:2

[RouterB] ipv6

[RouterB] interface gigabitethernet 0/0

[RouterB-GigabitEthernet0/0] port link-mode route

[RouterB-GigabitEthernet0/0] ipv6 address 1::2/64

[RouterB-GigabitEthernet0/0] quit

# 添加一跳指向RTA的2::/16静态路由

[RouterB] ipv6 route-static 2:: 16 1::1

3.5.3  DNS的配置

本配置举例利用模拟软件Simple DNS Plus来充当Host A和Router B的DNS服务器。

(1)     开始菜单启动Simple DNS Plus程序,打开Tools > Options菜单

图2 打开Tools > Options菜单

http://kms.h3c.com/kms/repository/repository/16179.jpg

 

(2)     在DNS>Requests选项中作如下配置,默认该服务器只接受来自127.0.0.1的请求

图3 设置为只接受来自127.0.0.1的请求

http://kms.h3c.com/kms/repository/repository/16184.jpg

 

(3)     首先点击File > New > New Zone,添加一个Primary域,根据向导提示创建一个叫h3c的域

图4 创建一个域

http://kms.h3c.com/kms/repository/repository/16180.jpg

 

图5 选择Primary Zone选项

http://kms.h3c.com/kms/repository/repository/16191.jpg

 

图6 设置域名为h3c

http://kms.h3c.com/kms/repository/repository/16188.jpg

 

(4)     点击Records快捷键,进行DNS纪录配置

图7 点击Records快捷键

http://kms.h3c.com/kms/repository/repository/16187.jpg

 

(5)     在空白区点击鼠标右键添加纪录,如果添加A纪录选择“New Host Address(A-record)”,如果要添加AAAA纪录选择“Other new record”

图8 在空白区点击鼠标右键添加纪录

 

(6)     添加A纪录

图9 添加A纪录

http://kms.h3c.com/kms/repository/repository/16190.jpg

 

(7)     添加AAAA纪录

图10 选择AAAA记录

http://kms.h3c.com/kms/repository/repository/16185.jpg

 

图11 添加AAAA记录

http://kms.h3c.com/kms/repository/repository/16181.jpg

 

(8)     按照同样方法配置RouterB的DNS记录,最终结果如下

图12 DNS记录的最终结果

 

至此配置结束,可以进行测试。

3.6  验证配置

# 在Host A上ping域名rtb.h3c

C:\Windows\System32>ping rtb.h3c

 

Pinging rtb.h3c [3.0.0.1] with 32 bytes of data:

Reply from 3.0.0.1: bytes=32 time=10ms TTL=63

Reply from 3.0.0.1: bytes=32 time=1ms TTL=63

Reply from 3.0.0.1: bytes=32 time=1ms TTL=63

Reply from 3.0.0.1: bytes=32 time=1ms TTL=63

 

Ping statistics for 3.0.0.1:

    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),

Approximate round trip times in milli-seconds:

    Minimum = 1ms, Maximum = 10ms, Average = 3ms

# 在Router B上ping域名pc.h3c

<RouterB>ping ipv6 pc.h3c

 Trying DNS resolve, press CTRL_C to break

 Trying DNS server (2::200:2)

  PING pc.h3c (2::100:2):

  56  data bytes, press CTRL_C to break

    Reply from 2::100:2

    bytes=56 Sequence=0 hop limit=127  time = 2 ms

    Reply from 2::100:2

    bytes=56 Sequence=1 hop limit=127  time = 3 ms

    Reply from 2::100:2

    bytes=56 Sequence=2 hop limit=127  time = 2 ms

    Reply from 2::100:2

    bytes=56 Sequence=3 hop limit=127  time = 2 ms

    Reply from 2::100:2

    bytes=56 Sequence=4 hop limit=127  time = 3 ms

 

  --- zKF3885.h3c ping statistics ---

    5 packet(s) transmitted

    5 packet(s) received

    0.00% packet loss

    round-trip min/avg/max = 2/2/3 ms

3.7  配置文件

·     设备A:

#

 dns resolve

 dns server 2.0.0.2

#

 ipv6

#

natpt address-group 1 1.0.0.10 1.0.0.20

 natpt prefix 0002::

 natpt v6bound static 0001::0002 3.0.0.1

 natpt v6bound dynamic prefix 0002:: address-group 1

#

interface Ethernet0/0

 port link-mode route

 ip address 2.0.0.1 255.255.255.0

 natpt enable

#

interface Ethernet0/1

 port link-mode route

 ipv6 address 1::1/64

 ntpt enable

#

interface Ethernet0/2

 port link-mode route

 ip address 1.0.0.1 255.255.255.0

 natpt enable

#

·     设备B :

#

 dns resolve

 dns server ipv6 2::200:2

#

 ipv6

#

interface GigabitEthernet0/0

 port link-mode route

 ipv6 address 1::2/64

#

ipv6 route-static 2:: 16 1::1

#

4  相关资料

·     H3C MSR 系列路由器 命令参考(V5)-R2311

·     H3C MSR 系列路由器 配置指导(V5)-R2311

不同款型规格的资料略有差异, 详细信息请向具体销售和400咨询。H3C保留在没有任何通知或提示的情况下对资料内容进行修改的权利!

联系我们 联系我们
联系我们
回到顶部 回到顶部