国家 / 地区

H3C MSR系列路由器典型配置举例(V5)-6W100

71-MSR系列路由器同时支持二层桥接和三层路由的方案配置举例

本章节下载  (144.89 KB)

docurl=/cn/Service/Document_Software/Document_Center/Routers/Catalog/MSR/MSR_50/Configure/Typical_Configuration_Example/H3C_MSR_(V5)-6W100/201401/812782_30005_0.htm

71-MSR系列路由器同时支持二层桥接和三层路由的方案配置举例

MSR系列路由器同时支持二层桥接和三层路由的配置举例

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

H3C_彩色.emf



1  简介

本文档介绍MSR系列路由器同时支持二层桥接和三层路由的典型配置举例。

2  配置前提

本文档不严格与具体软、硬件版本对应,如果使用过程中与产品实际情况有差异,请参考相关产品手册,或以设备实际情况为准。

本文档中的配置均是在实验室环境下进行的配置和验证,配置前设备的所有参数均采用出厂时的缺省配置。如果您已经对设备进行了配置,为了保证配置效果,请确认现有配置和以下举例中的配置不冲突。

本文档假设您已了解VLAN和NAT特性。

3  配置举例

3.1  组网需求

图1所示,Device是因特网端设备,Router作为访问因特网的网关,VLAN 3采用私网地址,而VLAN 2采用公网地址,要求:通过对Router进行配置使其既要作为VLAN 3的网关来完成最基本的上网业务,又要作为透明网桥来传递VLAN 2的报文。

图1 二层桥接和三层路由配置举例组网图

 

 

3.2  配置思路

·     Router在上下行都配置三层口,对于上行口Ethernet0/0,除了基本配置(IP,NAT)之外,还要把该接口加入桥组以便透传VLAN 2的报文;对于下行口Ethernet0/1,采用两个子接口分别承载两个VLAN的报文。

·     为了同时传递两个VLAN的报文,Switch的上行链路类型配置成Trunk,交换机Trunk口的PVID采用默认的。该Trunk链路上允许带VLAN 2 tag和VLAN 3 tag的报文通过,然后被对端的两个子接口接收。

3.3  使用版本

本举例是在Release 2317版本上进行配置和验证的。

3.4  配置步骤

3.4.1  Router的配置

# 使能网桥并创建桥组。

<Router> system-view

[Router] bridge enable

[Router] bridge 1 enable

# 配置ACL允许VLAN 3的主机访问网络。

[Router] acl number 2000

[Router-acl-basic-2000] rule permit source 10.0.0.0 0.0.0.255

[Router-acl-basic-2000] quit

 # 使用Ethernet0/0接口的IP地址进行NAT转换,使VLAN 3用户可以正常上网。

[Router] interface ethernet 0/0

[Router-Ethernet0/0] nat outbound 2000

# 把端口加入到桥组1中,实现对VLAN 2二层报文的透传。

[Router-Ethernet0/0] bridge-set 1

[Router-Ethernet0/0] bridge vlanid-transparent-transmit enable

[Router-Ethernet0/0] ip address 1.0.0.2 255.255.255.0

[Router-Ethernet0/0] quit

# 创建子接口Ethernet0/1.2,指定接收报文的VLAN tag并把该子接口加入到桥组1中使接收到的报文进行透传。

[Router] interface ethernet 0/1.2

[Router-Ethernet0/1.2] vlan-type dot1q vid 2

[Router-Ethernet0/1.2] bridge-set 1

[Router-Ethernet0/1.2] quit

# 创建子接口Ethernet0/1.3,定该子接口接收报文的VLAN tag并为该VLAN配置网关地址。

[Router] interface ethernet 0/1.3

[Router-Ethernet0/1.3] vlan-type dot1q vid 3

[Router-Ethernet0/1.3] ip address 10.0.0.1 255.255.255.0

[Router-Ethernet0/1.3] quit

3.4.2  Switch的配置

# 创建两个VLAN,分别为VLAN 2和VLAN 3。

<Switch> system-view

[Switch] vlan 2 to 3

# 将Gigabitethernet2/0/2端口加入VLAN 2。

[Switch] interface gigabitethernet 2/0/2

[Switch-GigabitEthernet2/0/2] port access vlan 2

[Switch-GigabitEthernet2/0/2] quit

# 将Gigabitethernet2/0/3端口加入VLAN 3。

[Switch] interface gigabitethernet 2/0/3

[Switch-GigabitEthernet2/0/3] port access vlan 3

[Switch-GigabitEthernet2/0/3] quit

# 配置GigabitEthernet 2/0/1端口类型为trunk并允许VLAN 2和VLAN 3的报文通过。

[Switch] interface gigabitethernet 2/0/1

[Switch-GigabitEthernet2/0/1] port link-type trunk

[Switch-GigabitEthernet2/0/1] port trunk permit vlan 1 to 3

[Switch-GigabitEthernet2/0/1] quit

3.5  验证配置

# VLAN 2的主机ping网关1.0.0.1能通,说明Router已对VLAN 2的报文作了透传。

C:\Users\Administrator>ping 1.0.0.1

 

Pinging 1.0.0.1 with 32 bytes of data:

Reply from 1.0.0.1: bytes=32 time=10ms TTL=255

Reply from 1.0.0.1: bytes=32 time=2ms TTL=255

Reply from 1.0.0.1: bytes=32 time=1ms TTL=255

Reply from 1.0.0.1: bytes=32 time=1ms TTL=255

 

Ping statistics for 1.0.0.1:

    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),

Approximate round trip times in milli-seconds:

    Minimum = 1ms, Maximum = 10ms, Average = 3ms

# VLAN 3的主机ping 1.0.0.1能通,说明VLAN 3的主机可以正常上网。

C:\Users\Administrator>ping 1.0.0.1

 

Pinging 1.0.0.1 with 32 bytes of data:

Reply from 1.0.0.1: bytes=32 time=6ms TTL=254

Reply from 1.0.0.1: bytes=32 time=1ms TTL=254

Reply from 1.0.0.1: bytes=32 time=1ms TTL=254

Reply from 1.0.0.1: bytes=32 time=1ms TTL=254

 

Ping statistics for 1.0.0.1:

    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),

Approximate round trip times in milli-seconds:

    Minimum = 1ms, Maximum = 6ms, Average = 2ms

3.6  配置文件

·     Router:

bridge enable

bridge 1 enable

#

acl number 2000

rule 0 permit source 10.0.0.0 0.0.0.255

#

interface Ethernet0/0

port link-mode route

nat outbound

bridge-set 1

bridge vlanid-transparent-transmit enable

ip address 1.0.0.2 255.255.255.0

#

interface Ethernet0/1.2

vlan-type dot1q vid 2

bridge-set 1

#

interface Ethernet0/1.3

vlan-type dot1q vid 3

ip address 10.0.0.1 255.255.255.0

#

·     Switch:

vlan 1 to 3

interface GigabitEthernet2/0/1

port link-type trunk

port trunk permit vlan 1 to 3

#

interface GigabitEthernet2/0/2

port access vlan 2

#

interface GigabitEthernet2/0/3

port access vlan 3

#

4  相关资料

·     H3C MSR 系列路由器 命令参考(V5)-R2311

·     H3C MSR 系列路由器 配置指导(V5)-R2311

不同款型规格的资料略有差异, 详细信息请向具体销售和400咨询。H3C保留在没有任何通知或提示的情况下对资料内容进行修改的权利!