国家 / 地区

H3C MSR系列路由器典型配置举例(V5)-6W100

61-MSR系列路由器静态路由与NQA联动典型配置案例

本章节下载  (139.28 KB)

docurl=/cn/Service/Document_Software/Document_Center/Routers/Catalog/MSR/MSR_50/Configure/Typical_Configuration_Example/H3C_MSR_(V5)-6W100/201401/812772_30005_0.htm

61-MSR系列路由器静态路由与NQA联动典型配置案例

MSR系列路由器静态路由与NQA联动典型配置案例

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

H3C_彩色.emf

 



1  简介

本文主要介绍静态路由与NQA联动典型配置。

2  配置前提

本文档不严格与具体软、硬件版本对应,如果使用过程中与产品实际情况有差异,请参考相关产品手册,或以设备实际情况为准。

本文档中的配置均是在实验室环境下进行的配置和验证,配置前设备的所有参数均采用出厂时的缺省配置。如果您已经对设备进行了配置,为了保证配置效果,请确认现有配置和以下举例中的配置不冲突。

本文档假设您已了解静态路由和NQA特性。

3  配置举例

3.1  组网需求

图1所示,RouterA与RouterB在同一网段,在RouterB上创建Loop0口;在Router A上通过静态路由、Track与NQA联动,对监控的静态路由有效性进行实时判断。

图1 静态路由与NQA联动配置组网图

 

3.2  配置思路

·     为监控静态路由,在RouterA上创建NQA测试组;

·     为使能NQA测试组,配置Track和到达RouterB的静态路由并与NQA联动。

3.3  使用版本

本举例是在Release 2207P14版本上进行配置和验证的。

3.4  配置注意事项

·     配置静态路由支持Track监测功能,该条静态路由可以是已经创建的,也可以是未创建的。

¡     对于已经创建的静态路由,只是将静态路由与Track项关联,并根据Track项的状态来判断静态路由的有效性;

¡     对于未创建的静态路由,首先要生成该静态路由,然后将其与Track项关联。

·     静态路由关联的Track项可以是未创建的Track项。通过track命令创建Track项后,探测功能开始生效。

·     Track模块通过NQA探测静态路由中下一跳的可达性,必须保证静态路由下一跳的VPN实例号与NQA测试组配置的实例号相同,才能进行正常的探测。

·     需要注意在静态路由进行迭代时,Track项监测的应该是静态路由真正的下一跳,而不是配置的下一跳。否则,可能导致错误地将有效路由判断为无效路由。

3.5  配置步骤

3.5.1  RouterA的配置

# 创建ICMP类型的NQA测试组并配置相关可选测试参数。

<RouterA>system-view

[RouterA]nqa entry admin icmp  

[RouterA-nqa-admin-icmp]type icmp-echo

[RouterA-nqa-admin-icmp-icmp-echo]destination ip 10.2.2.2

[RouterA-nqa-admin-icmp-icmp-echo]probe count 10

# 配置Reaction监测项1(失败1次触发联动)。

[RouterA-nqa-admin-icmp-icmp-echo]reaction 1 checked-element probe-fail threshold-type consecutive 1 action-type trigger-only    

[RouterA-nqa-admin-icmp-icmp-echo]quit

# 配置所监控的静态路由。

[RouterA]ip route-static 200.1.1.0 24 10.2.2.2 track 1

# 配置Track1,关联NQA测试组(管理员为admin,操作标签为 icmp)的Reaction监测项1

[RouterA]track 1 nqa entry admin icmp reaction 1

# 配置以太口的IP地址。

[RouterA]interface Ethernet 0/0

[RouterA-Ethernet0/0]ip address 10.2.2.1 255.255.255.0

3.5.2  RouterB的配置

# 配置LoopBack0接口。

<RouterB>system-view

[RouterB]interface LoopBack 0

[RouterB-LoopBack0]ip address 200.1.1.1 255.255.255.255 

[RouterB-LoopBack0]quit

# 配置以太口的IP地址。

[RouterB]interface Ethernet 0/0

[RouterB-Ethernet0/0]ip address 10.2.2.2 255.255.255.0

3.6  验证结果

(1)     启动ICMP测试操作。

[RouterA] nqa schedule admin icmp start-time now lifetime forever 

(2)     链路通信正常,显示ICMP测试成功的结果,NQA将探测结果通知给TRACK模块,则对应Track项的状态为positive,就表示静态路由的下一跳可达,配置的静态路由将生效,在路由表里可见。

[RouterA] display nqa result admin icmp

  NQA entry(admin admin, tag icmp) test results:

    Destination IP address: 10.2.2.2

      Send operation times: 10             Receive response times: 10

      Min/Max/Average round trip time: 1/2/1

      Square-Sum of round trip time: 13

      Last succeeded probe time: 2011-09-21 10:34:56.3

    Extend results:

      Packet lost in test: 0%

      Failures due to timeout: 0

      Failures due to disconnect: 0

      Failures due to no connection: 0

      Failures due to sequence error: 0

      Failures due to internal error: 0

      Failures due to other errors: 0 

[RouterA] display track 1

Track ID: 1

  Status: Positive

  Duration: 0 days 0 hours 4 minutes 50 seconds

  Notification delay: Positive 0, Negative 0 (in seconds)

  Reference object:

    NQA entry: admin icmp

    Reaction: 1       

[RouterA] display ip routing-table

Routing Tables: Public

         Destinations : 26       Routes : 26

 

Destination/Mask    Proto  Pre  Cost         NextHop         Interface 

200.1.1.0/24        Static 60   0            10.2.2.2        Eth0/0   

(3)     链路出现故障,显示ICMP测试不成功的结果,NQA将探测结果通知给TRACK模块,则对应Track项的状态为negative,就表示静态路由的下一跳不可达,配置的静态路由无效,在路由表里不可见。

[RouterA] display nqa result admin icmp

  NQA entry(admin admin, tag icmp) test results:

    Destination IP address: 10.2.2.2

      Send operation times: 10             Receive response times: 0

      Min/Max/Average round trip time: 0/0/0

      Square-Sum of round trip time: 0

      Last succeeded probe time: 0-00-00 00:00:00.0

    Extend results:

      Packet lost in test: 100%

      Failures due to timeout: 0

      Failures due to disconnect: 0

      Failures due to no connection: 0

      Failures due to sequence error: 0

      Failures due to internal error: 0

      Failures due to other errors: 10  

[RouterA] display track 1

Track ID: 1

  Status: Negative

  Duration: 0 days 0 hours 4 minutes 50 seconds

  Notification delay: Positive 0, Negative 0 (in seconds)

  Reference object:

    NQA entry: admin icmp

Reaction: 1   

[RouterA] display ip routing-table

Routing Tables: Public

         Destinations : 26       Routes : 26

Destination/Mask    Proto  Pre  Cost         NextHop         Interface 

3.7  配置文件

·     Router A

#

 sysname RouterA

#

interface Ethernet0/0

 port link-mode route

 ip address 10.2.2.1 255.255.255.0

#

nqa entry admin icmp

 type icmp-echo

  destination ip 10.2.2.2

  frequency 6000

  probe count 10

  reaction 1 checked-element probe-fail threshold-type consecutive 1 action-type trigger-only

#

ip route-static 200.1.1.1 255.255.255.255 10.2.2.2 track 1

#

 track 1 nqa entry admin icmp reaction 1

#

 nqa schedule admin icmp start-time now lifetime forever

#

·     Router B

#

 sysname RouterB

#

interface Ethernet0/0

 port link-mode route

 ip address 10.2.2.2 255.255.255.0

#

interface LoopBack0

 ip address 200.1.1.1 255.255.255.255

#

4  相关资料

·     H3C MSR 系列路由器 命令参考(V5)-R2311

·     H3C MSR 系列路由器 配置指导(V5)-R2311

 

不同款型规格的资料略有差异, 详细信息请向具体销售和400咨询。H3C保留在没有任何通知或提示的情况下对资料内容进行修改的权利!