国家 / 地区

H3C MSR系列路由器典型配置举例(V5)-6W100

21-MSR系列路由器IPv6 ISATAP和6to4相结合使用的配置举例

本章节下载  (127.11 KB)

docurl=/cn/Service/Document_Software/Document_Center/Routers/Catalog/MSR/MSR_50/Configure/Typical_Configuration_Example/H3C_MSR_(V5)-6W100/201401/812732_30005_0.htm

21-MSR系列路由器IPv6 ISATAP和6to4相结合使用的配置举例

MSR系列路由器IPv6 ISATAP和6to4相结合使用的配置举例

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

H3C_彩色.emf

目  录

1 简介

2 配置前提

3 配置举例

3.1 组网需求

3.2 配置思路

3.3 使用版本

3.4 配置注意事项

3.5 配置步骤

3.5.1 Router A的配置

3.5.2 Router B的配置

3.6 验证配置

3.7 配置文件

4 相关资料

 


1  简介

本文档介绍了MSR系列路由器IPv6 ISATAP和6to4相结合使用的典型配置举例。

2  配置前提

本文档不严格与具体软、硬件版本对应,如果使用过程中与产品实际情况有差异,请参考相关产品手册,或以设备实际情况为准。

本文档中的配置均是在实验室环境下进行的配置和验证,配置前设备的所有参数均采用出厂时的缺省配置。如果您已经对设备进行了配置,为了保证配置效果,请确认现有配置和以下举例中的配置不冲突。

本文档假设您已了解6to4隧道和ISATAP隧道的特性。

3  配置举例

3.1  组网需求

图1所示,Router A和Router B通过IPv4互连,Router B连接了一个6to4站点。要求在Router A和Router B上建立6to4隧道保证IPv6互连,Router A提供ISATAP接入服务使一些IPv4网络中的双栈主机可以访问IPv6网络,Router A和Router B不需要借用任何静态路由和动态路由即可保证Host A和Host B互连互通。

图1 IPv6 ISATAP和6to4相结合功能配置组网图

3.2  配置思路

·     取消对RA消息发布的抑制,使主机可以通过路由器发布的RA消息获取地址前缀等信息。

·     为了不用再配置其它路由,Tunnel0的IPv6地址使用16位前缀。

3.3  使用版本

本举例是在Release 2317版本上进行配置和验证的。

3.4  配置注意事项

Router A上ISATAP隧道接口IPv6地址为6to4格式前缀2002:101:101:1,后缀为ISATAP格式0:5EFE:10.153.43.121,其中101:101表示1.1.1.1

3.5  配置步骤

3.5.1  Router A的配置

# 使能IPv6转发功能。

<RouterA> system-view

[RouterA] ipv6

# 配置接口Ethernet0/0的地址。

[RouterA] interface ethernet 0/0

[RouterA-Ethernet0/0] ip address 10.153.43.121 255.255.255.0

[RouterA-Ethernet0/0] quit

# 配置接口Serial1/0的地址。

[RouterA] interface serial 1/0

[RouterA-Serial1/0] link-protocol ppp

[RouterA-Serial1/0] ip address 1.1.1.1 255.255.255.252

[RouterA-Serial1/0] quit

# 配置6to4隧道。

[RouterA] interface tunnel 0

[RouterA-Tunnel0] ipv6 address 2002:101:101::1/16

[RouterA-Tunnel0] tunnel-protocol ipv6-ipv4 6to4

[RouterA-Tunnel0] source serial 1/0

[RouterA-Tunnel0] quit

# 配置ISATAP隧道。

[RouterA] interface tunnel 1

[RouterA-Tunnel1] ipv6 address 2002:101:101:1:0:5EFE:A99:2B79/64

[RouterA-Tunnel1] tunnel-protocol ipv6-ipv4 isatap

[RouterA-Tunnel1] source ethernet 0/0

# 取消对RA消息发布的抑制,使主机可以通过路由器发布的RA消息获取地址前缀等信息。

[RouterA-Tunnel1] undo ipv6 nd ra halt

[RouterA-Tunnel1] quit

3.5.2  Router B的配置

# 使能IPv6转发功能。

<RouterB> system-view

[RouterB] ipv6

# 配置接口Ethernet0/0的地址。

[RouterB] interface ethernet 0/0

[RouterB-Ethernet0/0] ipv6 address 2002:202:202:2::1/64

[RouterB-Ethernet0/0] undo ipv6 nd ra halt

[RouterB-Ethernet0/0] quit

# 配置接口Serial2/0的地址。

[RouterB] interface serial 2/0

[RouterB-Serial2/0] link-protocol ppp

[RouterB-Serial2/0] ip address 2.2.2.2 255.255.255.252

[RouterB-Serial2/0] quit

# 配置6to4隧道。

[RouterB] interface tunnel 0

[RouterB-Tunnel0] ipv6 address 2002:202:202::1/16

[RouterB-Tunnel0] tunnel-protocol ipv6-ipv4 6to4

[RouterB-Tunnel0] source serial 2/0

[RouterB-Tunnel0] quit

3.6  验证配置

Host A 可以ping通Host B说明IPv6 ISATAP隧道和6to4隧道相结合成功。

C:\Documents and Settings\Administrator>ping 2002:202:202:2::1

 

Pinging 2002:202:202:2::1 with 32 bytes of data:

 

Reply from 2002:202:202:2::1: time=33ms

Reply from 2002:202:202:2::1: time=32ms

Reply from 2002:202:202:2::1: time=32ms

Reply from 2002:202:202:2::1: time=33ms

 

Ping statistics for 2002:202:202:2::1:

 Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),

Approximate round trip times in milli-seconds:

 Minimum = 32ms, Maximum = 33ms, Average = 32ms

3.7  配置文件

·     Router A:

#

ipv6

#

interface Ethernet0/0

 port link-mode route

ip address 10.153.43.121 255.255.255.0

#

interface Serial1/0

link-protocol ppp

ip address 1.1.1.1 255.255.255.252

#

interface Tunnel0

 ipv6 address 2002:101:101::1/16

 tunnel-protocol ipv6-ipv4 6to4

source Serial1/0

#

interface Tunnel1

 undo ipv6 nd ra halt

 ipv6 address 2002:101:101:1:0:5EFE:A99:2B79/64

 tunnel-protocol ipv6-ipv4 isatap

 source Ethernet0/0

·     Router B:

#

ipv6

#

interface Ethernet0/0

 port link-mode route

undo ipv6 nd ra halt

 ipv6 address 2002:202:202:2::1/64

#

interface Serial2/0

link-protocol ppp

ip address 2.2.2.2 255.255.255.252

#

interface Tunnel0

 ipv6 address 2002:202:202::1/16

 tunnel-protocol ipv6-ipv4 6to4

source Serial2/0

#

4  相关资料

·     H3C MSR 系列路由器 命令参考(V5)-R2311

·     H3C MSR 系列路由器 配置指导(V5)-R2311

不同款型规格的资料略有差异, 详细信息请向具体销售和400咨询。H3C保留在没有任何通知或提示的情况下对资料内容进行修改的权利!

联系我们 联系我们
联系我们
回到顶部 回到顶部