国家 / 地区

H3C MSR系列路由器典型配置举例(V5)-6W100

24-MSR系列路由器IPv6隧道技术之6PE隧道技术配置举例

本章节下载  (144.8 KB)

docurl=/cn/Service/Document_Software/Document_Center/Routers/Catalog/MSR/MSR_50/Configure/Typical_Configuration_Example/H3C_MSR_(V5)-6W100/201401/812735_30005_0.htm

24-MSR系列路由器IPv6隧道技术之6PE隧道技术配置举例

MSR系列路由器IPv6隧道技术之6PE隧道技术配置举例

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

H3C_彩色.emf

目  录

1 简介

2 配置前提

3 配置举例

3.1 组网需求

3.2 配置思路

3.3 使用版本

3.4 配置步骤

3.4.1 Router A的配置

3.4.2 Router B的配置

3.4.3 Router C的配置

3.5 验证配置

3.6 配置文件

4 相关资料

 


1  简介

本文档介绍了利用MPLS技术在IPv4网络上实现IPv6隧道的技术——6PE隧道技术的配置举例。

2  配置前提

本文档不严格与具体软、硬件版本对应,如果使用过程中与产品实际情况有差异,请参考相关产品手册,或以设备实际情况为准。

本文档中的配置均是在实验室环境下进行的配置和验证,配置前设备的所有参数均采用出厂时的缺省配置。如果您已经对设备进行了配置,为了保证配置效果,请确认现有配置和以下举例中的配置不冲突。

本文档假设您已了解MPLS、OSPF、IPv6、6PE和BGP的相关特性。

3  配置举例

3.1  组网需求

图1所示,Router A、Router B和Router C组成IPv4 MPLS网络,它们之间使用OSPF路由协议;路由器Router A和Router C支持6PE特性,要求使用6PE隧道技术将IPv6网络通过IPv4/MPLS网络连接起来。

图1 MSR路由器6PE隧道技术配置组网图

3.2  配置思路

·     为了在IPv4 MPLS网络上转发IPv6报文,必须分别在Router A和Router C上开启IPv6转发功能。

·     6PE路由器将用户的IPv6路由信息转换为带有标签的IPv6路由信息,并且通过IBGP会话扩散到ISP的IPv4骨干网中。通过使能IPv6标签路由的交换功能能够使6PE路由器转发IPv6报文时,首先会将进入骨干网隧道的数据流打上标签。

3.3  使用版本

本举例是在Release 2317版本上进行配置和验证的。

3.4  配置步骤

3.4.1  Router A的配置

# 为路由器指定ID。

<RouterA> system-view

[RouterA] router id 1.1.1.1

# 使能IPv6报文转发功能。

[RouterA] ipv6

# 使能MPLS功能。

[RouterA] mpls lsr-id 1.1.1.1

[RouterA] mpls

[RouterA-mpls] mpls ldp

[RouterA-mpls-ldp] quit

# 配置接口LoopBack0的IP地址。

[RouterA] interface loopback0

[RouterA-LoopBack0] ipv6 address 1::1/128

[RouterA-LoopBack0] ip address 1.1.1.1 255.255.255.255

[RouterA-LoopBack0] quit

# 配置接口Ethernet0/0的MPLS功能。

[RouterA] interface ethernet 0/0

[RouterA-Ethernet0/0] ip address 192.3.2.100 255.255.255.0

[RouterA-Ethernet0/0] mpls

[RouterA-Ethernet0/0] mpls ldp

[RouterA-Ethernet0/0] quit

# 配置IPv6 BGP的基本功能

[RouterA] bgp 100

[RouterA-bgp] undo synchronization

[RouterA-bgp] group in internal

[RouterA-bgp] peer 3.3.3.3 group in

[RouterA-bgp] peer 3.3.3.3 connect-interface LoopBack 0

[RouterA-bgp] ipv6-family

[RouterA-bgp-af-ipv6] import-route direct

[RouterA-bgp-af-ipv6] undo synchronization

[RouterA-bgp-af-ipv6] peer 3.3.3.3 enable

# 使能IPv6标签路由的交换功能。

[RouterA-bgp-af-ipv6] peer 3.3.3.3 label-route-capability

[RouterA-bgp-af-ipv6] quit

[RouterA-bgp] quit

# 配置OSPF的基本功能。

[RouterA] ospf 1

[RouterA-ospf-1] area 0

[RouterA-ospf-1-area-0.0.0.0] network 192.3.2.0 0.0.0.255

[RouterA-ospf-1-area-0.0.0.0] network 1.1.1.1 0.0.0.0

[RouterA-ospf-1-area-0.0.0.0] quit

3.4.2  Router B的配置

# 指定路由器ID。

<RouterB> system-view

[RouterB] router id 2.2.2.2

# 使能MPLS功能。

[RouterB] mpls lsr-id 2.2.2.2

[RouterB] mpls

[RouterB-mpls] mpls ldp

[RouterB-mpls-ldp] quit

# 配置接口Ethernet0/0MPLS功能。

[RouterB] interface ethernet 0/0

[RouterB-Ethernet0/0] ip address 192.3.2.200 255.255.255.0

[RouterB-Ethernet0/0] mpls

[RouterB-Ethernet0/0] mpls ldp

[RouterB-Ethernet0/0] quit

# 配置接口Ethernet0/1MPLS功能。

[RouterB] interface ethernet 0/1

[RouterB-Ethernet0/1] ip address 192.1.2.200 255.255.255.0

[RouterB-Ethernet0/1] mpls

[RouterB-Ethernet0/1] mpls ldp

[RouterB-Ethernet0/1] quit

# 配置OSPF的基本功能。

[RouterB] ospf 1

[RouterB-ospf-1] area 0

[RouterB-ospf-1-area-0.0.0.0] network 2.2.2.2 0.0.0.0

[RouterB-ospf-1-area-0.0.0.0] network 192.3.2.0 0.0.0.255

[RouterB-ospf-1-area-0.0.0.0] network 192.1.2.0 0.0.0.255

[RouterB-ospf-1-area-0.0.0.0] quit

3.4.3  Router C的配置

# 为路由器指定ID。

<RouterC> system-view

[RouterC] router id 3.3.3.3

# 使能IPv6报文转发功能。

[RouterC] ipv6

# 使能MPLS功能。

[RouterC] mpls lsr-id 3.3.3.3

[RouterC] mpls

[RouterC-mpls] mpls ldp

[RouterC-mpls-ldp] quit

# 配置接口Ethernet0/0MPLS功能。

[RouterC] interface ethernet 0/0

[RouterC-Ethernet0/0] ip address 192.1.2.50 255.255.255.0

[RouterC-Ethernet0/0] mpls

[RouterC-Ethernet0/0] mpls ldp

[RouterC-Ethernet0/0] quit

# 配置接口LoopBack0IP地址。

[RouterC] interface loopback 0

[RouterC-LoopBack0] ipv6 address 1::2/128

[RouterC-LoopBack0] ip address 3.3.3.3 255.255.255.255

[RouterC-LoopBack0] quit

# 配置接口LoopBack1的IP地址。

[RouterC] interface loopback 1

[RouterC-LoopBack1] ipv6 address 2::1/128

[RouterC-LoopBack1] quit

# 配置IPv6 BGP的基本功能。

[RouterC] bgp 100

[RouterC-bgp] undo synchronization

[RouterC-bgp] group in internal

[RouterC-bgp] peer 1.1.1.1 group in

[RouterC-bgp] peer 1.1.1.1 connect-interface loopback 0

[RouterC-bgp] ipv6-family

[RouterC-bgp-af-ipv6] import-route direct

[RouterC-bgp-af-ipv6] undo synchronization

[RouterC-bgp-af-ipv6] peer 1.1.1.1 enable

# 使能IPv6标签路由的交换功能。

[RouterC-bgp-af-ipv6] peer 1.1.1.1 label-route-capability

[RouterC-bgp-af-ipv6] quit

[RouterC-bgp] quit

# 配置OSPF的基本功能。

[RouterC] ospf 1

[RouterC-ospf-1] area 0

[RouterC-ospf-1-area-0.0.0.0] network 192.1.2.0 0.0.0.255

[RouterC-ospf-1-area-0.0.0.0] network 3.3.3.3 0.0.0.0

[RouterC-ospf-1-area-0.0.0.0] quit

3.5  验证配置

# 显示路由器Router A的LSP信息。

<RouterA> display mpls lsp

--------------------------------------------------------------------------

LSP Information: BGP IPV6 LSP

--------------------------------------------------------------------------

  FEC                 :  ::1

  In Label            :  1024                  Out Label    :  NULL

  In Interface        :  -----                 Out Interface:  -----

  Vrf Name            :

# 显示路由器Router A的IPv6路由信息。

<RouterA>display bgp ipv6 routing-table

Total Number of Routes: 3

BGP Local router ID is 1.1.1.1

 Status codes: * - valid, ^ - VPN best, > - best, d - damped,

               h - history,  i - internal, s - suppressed, S - Stale

               Origin : i - IGP, e - EGP, ? - incomplete

* >  Network : 1::1                                     PrefixLen : 128

      NextHop : ::                                       LocPrf    :

      PrefVal : 0                                        Label     : NULL

      MED     : 0

      Path/Ogn: ?

    i Network : 1::2                                     PrefixLen : 128

      NextHop : ::FFFF:3.3.3.3                           LocPrf    : 100

      PrefVal : 0                                        Label     : 1024

      MED     : 0

      Path/Ogn: ?

    i Network : 2::1                                     PrefixLen : 128

      NextHop : ::FFFF:3.3.3.3                           LocPrf    : 100

      PrefVal : 0                                        Label     : 1024

      MED     : 0

      Path/Ogn: ?

# 配置成功之后,从Router A上可以ping通Router C的IPv6地址。

<RouterA> ping ipv6 1::2

  PING 1::2: 56  data bytes, press CTRL_C to break

    Reply from 1::2: bytes=56 Sequence=0 ttl=254 time=2 ms

    Reply from 1::2: bytes=56 Sequence=1 ttl=254 time=1 ms

    Reply from 1::2: bytes=56 Sequence=2 ttl=254 time=1 ms

    Reply from 1::2: bytes=56 Sequence=3 ttl=254 time=1 ms

    Reply from 1::2: bytes=56 Sequence=4 ttl=254 time=1 ms

  --- 1::2 ping statistics ---

    5 packet(s) transmitted

    5 packet(s) received

    0.00% packet loss

    round-trip min/avg/max = 1/1/2 ms

3.6  配置文件

·     Router A:

#

router id 1.1.1.1

#

 ipv6

#

mpls lsr-id 1.1.1.1

#

mpls

#

mpls ldp

#

interface Ethernet0/0

 port link-mode route

ip address 192.3.2.100 255.255.255.0

 mpls

 mpls ldp

#

interface LoopBack0

 ipv6 address 1::1/128

 ip address 1.1.1.1 255.255.255.255

#

bgp 100

 undo synchronization

 group in internal

 peer 3.3.3.3 group in

 peer 3.3.3.3 connect-interface LoopBack0

 #

 ipv6-family

  undo synchronization

  peer 3.3.3.3 enable

  peer 3.3.3.3 label-route-capability

#

ospf 1

 area 0.0.0.0

  network 192.3.2.0 0.0.0.255

  network 1.1.1.1 0.0.0.0

#

·     Router B:

#

router id 2.2.2.2

#

mpls lsr-id 2.2.2.2

#

mpls

#

mpls ldp

#

interface Ethernet0/0

 port link-mode route

ip address 192.3.2.200 255.255.255.0

 mpls

 mpls ldp

#

interface Ethernet0/1

 port link-mode route

ip address 192.1.2.200 255.255.255.0

 mpls

 mpls ldp

#

ospf 1

 area 0.0.0.0

  network 2.2.2.2 0.0.0.0

  network 192.3.2.0 0.0.0.255

  network 192.1.2.0 0.0.0.255

#

·     Router C:

#

router id 3.3.3.3

#

 ipv6

#

mpls lsr-id 3.3.3.3

#

mpls

#

mpls ldp

#

interface Ethernet0/0

 port link-mode route

ip address 192.1.2.50 255.255.255.0

 mpls

 mpls ldp

#

interface LoopBack0

 ipv6 address 1::2/128

 ip address 3.3.3.3 255.255.255.255

#

interface LoopBack1

 ipv6 address 2::1/128

#

bgp 100

 undo synchronization

group in internal

 peer 1.1.1.1 group in

 peer 1.1.1.1 connect-interface LoopBack0

 #

 ipv6-family

  import-route direct

  undo synchronization

  peer 1.1.1.1 enable

  peer 1.1.1.1 label-route-capability

 #

ospf 1

 area 0.0.0.0

  network 192.1.2.0 0.0.0.255

  network 3.3.3.3 0.0.0.0

#

4  相关资料

·     H3C MSR 系列路由器 命令参考(V5)-R2311

·     H3C MSR 系列路由器 配置指导(V5)-R2311

不同款型规格的资料略有差异, 详细信息请向具体销售和400咨询。H3C保留在没有任何通知或提示的情况下对资料内容进行修改的权利!

联系我们 联系我们
联系我们
回到顶部 回到顶部