国家 / 地区

H3C MSR系列路由器典型配置举例(V5)-6W100

54-MSR系列路由器备份中心与NQA联动典型配置举例

本章节下载  (138.39 KB)

docurl=/cn/Service/Document_Software/Document_Center/Routers/Catalog/MSR/MSR_50/Configure/Typical_Configuration_Example/H3C_MSR_(V5)-6W100/201401/812765_30005_0.htm

54-MSR系列路由器备份中心与NQA联动典型配置举例

MSR系列路由器备份中心与NQA联动典型配置举例

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

H3C_彩色.emf

 



1  简介

本文主要介绍备份中心与NQA联动典型配置。

1  配置前提

本文档不严格与具体软、硬件版本对应,如果使用过程中与产品实际情况有差异,请参考相关产品手册,或以设备实际情况为准。

本文档中的配置均是在实验室环境下进行的配置和验证,配置前设备的所有参数均采用出厂时的缺省配置。如果您已经对设备进行了配置,为了保证配置效果,请确认现有配置和以下举例中的配置不冲突。

本文档假设您已了解备份中心和NQA特性。

2  配置举例

2.1  组网需求

图1所示,把RouterA的serial0/0口配置为主接口Ethernet0/0的备份接口;在Router A上通过备份接口、Track与NQA联动,对与主接口的有效性进行实时判断。

图1 备份中心与NQA联动配置组网图

 

2.2  配置思路

·     为监控备份路由,在RouterA上创建NQA测试组,配置Track分别与备份接口以及NQA测试组关联;

·     为实现链路备份,在RouterB和RouterA上配置串口为备份接口。

2.3  使用版本

本举例是在Release 2207P14版本上进行配置和验证的。

2.4  配置注意事项

·     一个接口只能关联一个Track项,重复执行standby track命令,后面的配置将覆盖前面的配置。

·     接口上关联的Track项可以是未创建的Track项。通过track命令创建Track项后,探测功能开始生效。

·     应保证Host主机与RouterA路由可达。

2.5  配置步骤

2.5.1  RouterA的配置

# 创建ICMP类型的NQA测试组并配置相关可选测试参数

<RouterA>system-view

[RouterA]nqa entry admin icmp  

[RouterA-nqa-admin-icmp]type icmp-echo

[RouterA-nqa-admin-icmp-icmp-echo]destination ip 10.2.2.2

[RouterA-nqa-admin-icmp-icmp-echo]probe count 10

# 配置Reaction监测项1(失败1次触发联动)

[RouterA-nqa-admin-icmp-icmp-echo]reaction 1 checked-element probe-fail threshold-type consecutive 1 action-type trigger-only

[RouterA-nqa-admin-icmp-icmp-echo]quit

# 配置备份接口Serial 0/0IP地址,并与Track项关联

[RouterA]interface Serial 0/0

[RouterA-Serial0/0]ip address 20.1.1.1 255.255.255.0

[RouterA-Serial0/0]baudrate 2048000

[RouterA-Serial0/0]standby track 1

[RouterA-Serial0/0]quit

# 配置Track1,关联NQA测试组(管理员为admin,操作标签为 icmp)的Reaction监测项1

[RouterA]track 1 nqa entry admin icmp reaction 1

配置以太口的IP地址

[RouterA]interface Ethernet 0/0

[RouterA-Ethernet0/0]ip address 10.2.2.1 255.255.255.0

[RouterA-Ethernet0/0]quit

# 配置到PC所在网段200.1.1.0/24的静态路由

[RouterA]ip route-static 200.1.1.0 255.255.255.0 10.2.2.2

[RouterA]ip route-static 200.1.1.0 255.255.255.0 20.1.1.2 preference 30

2.5.2  RouterB的配置

# 配置备份接口Serial 0/0的IP地址

<RouterB>system-view

[RouterB]interface Serial 0/0  

[RouterB-Serial0/0]ip address 20.1.1.2 255.255.255.0 

[RouterB-Serial0/0]virtualbaudrate 2048000

[RouterB-Serial0/0]quit

# 配置以太口Ethernet 0/0的IP地址

[RouterB]interface Ethernet 0/0

[RouterB-Ethernet0/0]ip address 10.2.2.2 255.255.255.0

# 配置以太口Ethernet 0/1的IP地址

[RouterB]interface Ethernet 0/1

[RouterB-Ethernet0/1]ip address 200.1.1.2 255.255.255.0

2.6  验证结果

(1)     启动ICMP测试操作

[RouterA]nqa schedule admin icmp start-time now lifetime forever 

(2)     显示ICMP测试成功的结果,NQA将探测结果通知给TRACK模块,则对应Track项的状态为positive,就表示被探测接口所在链路通信正常,探测接口作为备份接口进行接口备份

#Aug 16 11:53:33:621 2011 RouterA IFNET/4/INTERFACE UPDOWN:

 Trap 1.3.6.1.6.3.1.1.5.3<linkDown>: Interface 2818048 is Down, ifAdminStatus is 1, ifOperStatus is 2

%Aug 16 11:53:33:621 2007 RouterA DRVMSG/1/DRVMSG:    Serial0/0: change status to down

%Aug 16 11:53:33:622 2007 RouterA IFNET/4/UPDOWN:

 Line protocol on the interface Serial0/0 is DOWN

%Aug 16 11:53:33:622 2007 RouterA IFNET/4/UPDOWN:

 Protocol PPP IPCP on the interface Serial0/0 is DOWN

[RouterA]display interface Serial 0/0

Serial0/0 current state: Standby

Line protocol current state: DOWN

Description: Serial0/0 Interface     

[RouterA]display nqa result admin icmp

  NQA entry(admin admin, tag icmp) test results:

    Destination IP address: 10.2.2.2

      Send operation times: 10             Receive response times: 10

      Min/Max/Average round trip time: 1/1/1

      Square-Sum of round trip time: 10

      Last succeeded probe time: 2011-09-29 11:53:45.7

    Extend results:

      Packet lost in test: 0%

      Failures due to timeout: 0

      Failures due to disconnect: 0

      Failures due to no connection: 0

      Failures due to sequence error: 0

      Failures due to internal error: 0

      Failures due to other errors: 0

[RouterA]dis track 1

Track ID: 1

  Status: Positive

  Duration: 0 days 0 hours 4 minutes 50 seconds

  Notification delay: Positive 0, Negative 0 (in seconds)

  Reference object:

    NQA entry: admin icmp

Reaction: 1   

(3)     显示ICMP测试不成功的结果,NQA将探测结果通知给TRACK模块,则对应Track项的状态为negative,就表示被探测接口所在链路出现故障,探测接口成为主接口负责业务传输

%Aug 16 11:56:51:489 2007 RouterA DRVMSG/1/DRVMSG:    Serial0/0: change status to up

#Aug 16 11:56:54:510 2007 RouterA IFNET/4/INTERFACE UPDOWN:

 Trap 1.3.6.1.6.3.1.1.5.4<linkUp>: Interface 2818048 is Up, ifAdminStatus is 1,ifOperStatus is 1

%Aug 16 11:56:54:510 2007 RouterA IFNET/4/UPDOWN:

 Line protocol on the interface Serial0/0 is UP

%Aug 16 11:56:54:512 2007 RouterA IFNET/4/UPDOWN:

 Protocol PPP IPCP on the interface Serial0/0 is UP

[RouterA]display interface Serial 0/0

Serial0/0 current state: UP

Line protocol current state: UP

Description: Serial0/0 Interface                     

[RouterA]display nqa result admin icmp

  NQA entry(admin admin, tag icmp) test results:

    Destination IP address: 10.2.2.2

      Send operation times: 10             Receive response times: 0

      Min/Max/Average round trip time: 0/0/0

      Square-Sum of round trip time: 0

      Last succeeded probe time: 0-00-00 00:00:00.0

    Extend results:

      Packet lost in test: 100%

      Failures due to timeout: 0

      Failures due to disconnect: 0

      Failures due to no connection: 0

      Failures due to sequence error: 0

      Failures due to internal error: 0

      Failures due to other errors: 10      

[RouterA]display track 1

Track ID: 1

  Status: Negative

  Duration: 0 days 0 hours 4 minutes 50 seconds

  Notification delay: Positive 0, Negative 0 (in seconds)

  Reference object:

    NQA entry: admin icmp

Reaction: 1  

2.7  配置文件

·     Router A

#

 sysname RouterA

#

interface Ethernet0/0

 port link-mode route

 ip address 10.2.2.1 255.255.255.0

#

interface Serial0/0

 baudrate 2048000

 link-protocol ppp

 ip address 20.1.1.1 255.255.255.0

 standby track 1

#

nqa entry admin icmp

 type icmp-echo

  destination ip 10.2.2.2

  frequency 6000

  probe count 10

  reaction 1 checked-element probe-fail threshold-type consecutive 1 action-type trigger-only

#

 ip route-static 200.1.1.0 255.255.255.0 10.2.2.2

 ip route-static 200.1.1.0 255.255.255.0 20.1.1.2 preference 30

#

 track 1 nqa entry admin icmp reaction 1

#

 nqa schedule admin icmp start-time now lifetime forever

#

·     Router B

#

 sysname RouterB

#

interface Ethernet0/0

 port link-mode route

 ip address 10.2.2.2 255.255.255.0

#

interface Ethernet0/1

 port link-mode route

 ip address 200.1.1.2 255.255.255.0

#

interface Serial0/0

 virtualbaudrate 2048000

 link-protocol ppp

 ip address 20.1.1.2 255.255.255.0

#

3  相关资料

·     H3C MSR 系列路由器 命令参考(V5)-R2311

·     H3C MSR 系列路由器 配置指导(V5)-R2311

不同款型规格的资料略有差异, 详细信息请向具体销售和400咨询。H3C保留在没有任何通知或提示的情况下对资料内容进行修改的权利!