国家 / 地区

H3C MSR系列路由器典型配置举例(V5)-6W100

59-MSR系列路由器基于SIP-T架构的QSIG Tunnel典型配置举例

本章节下载  (179.98 KB)

docurl=/cn/Service/Document_Software/Document_Center/Routers/Catalog/MSR/MSR_50/Configure/Typical_Configuration_Example/H3C_MSR_(V5)-6W100/201401/812770_30005_0.htm

59-MSR系列路由器基于SIP-T架构的QSIG Tunnel典型配置举例

MSR系列路由器基于SIP-T架构的QSIG Tunnel典型配置举例

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

H3C_彩色.emf

 



1  简介

本文主要基于SIP-T架构的QSIG Tunnel典型配置。

2  配置前提

本文档不严格与具体软、硬件版本对应,如果使用过程中与产品实际情况有差异,请参考相关产品手册,或以设备实际情况为准。

本文档中的配置均是在实验室环境下进行的配置和验证,配置前设备的所有参数均采用出厂时的缺省配置。如果您已经对设备进行了配置,为了保证配置效果,请确认现有配置和以下举例中的配置不冲突。

本文档假设您已了解QSIG Tunnel特性。

3  配置举例

3.1  组网需求

某企业的两个分部A、B分别拥有内部PBX实现本地呼叫管理,ISDN信令采用QSIG且使用了部分补充业务。为了实现分部之间的VoIP通信,使用MSR设备架设了SIP网络。要求在分部之间实现语音呼叫和补充业务的互通。

图1所示,Router A与Router B分别通过VE1模块与PBX相连,使用QSIG信令。Router A与Router B之间通过VoIP网络相连,运行SIP协议。对于两端ISDN网络之间的呼叫,发送端QSIG信息由入口网关接收处理后,封装到SIP报文中最终发送给出口网关。出口网关收到SIP报文后,重新提取消息中封装的QSIG信令发送到接收端ISDN侧。

图1 基于SIP-T架构的QSIG Tunnel典型组网

 

3.2  配置思路

·     为使链路正常建立,配置VE1中继链路。

·     配置以太网接口地址,保证VoIP网络通畅。

·     为使电话与语音网关和目标地址之间建立联系,配置语音实体。

·     为使QSIG信令穿越SIP网络,使能QSIG Tunnel特性。

3.3  使用版本

本举例是在Release 2207P14版本上进行配置和验证的。

3.4  配置注意事项

·     如果ISDN呼叫采用Overlap发号方式,则不会启用QSIG Tunnel功能,按普通流程处理。

·     如果ISDN呼叫采用无连接方式,则不会启用QSIG Tunnel功能,按普通流程处理。

·     两端的语音网关必须都启用QSIG Tunnel功能。如果本端未开启,收到携带DSS1或QSIG信令格式的消息时,按普通流程处理。

·     开启QSIG Tunnel功能后,不支持DSS1信令。如果收到携带DSS1信令格式的消息,将拆除呼叫。

3.5  配置步骤

3.5.1  Router A的配置

# 配置VE1中继链路,使得链路正常建立。

<RouterA> system-view

[RouterA] controller E1 3/0

[RouterA-E1 3/0] pri-set

[RouterA-E1 3/0] quit

[RouterA] interface Serial 3/0:15

[RouterA-Serial3/0:15] isdn protocol-mode user

[RouterA-Serial3/0:15] isdn protocol-type qsig

[RouterA-Serial3/0:15] quit

# 配置以太网接口地址,保证VoIP网络通畅。

[RouterA] interface GigabitEthernet 0/1

[RouterA-GigabitEthernet0/1] ip address 168.32.45.214 16

[RouterA-GigabitEthernet0/1] quit

# 配置中继POTS实体。

[RouterA] voice-setup

[RouterA-voice] dial-program

[RouterA-voice-dial] entity 010 pots

[RouterA-voice-dial-entity10] match-template 010....

[RouterA-voice-dial-entity10] send-number all

[RouterA-voice-dial-entity10] line 3/0:15

[RouterA-voice-dial-entity10] quit

# 配置到Router BVoIP实体。

[RouterA-voice-dial] entity 020 voip

[RouterA-voice-dial-entity20] match-template 020....

[RouterA-voice-dial-entity20] address sip ip 168.32.45.211

[RouterA-voice-dial-entity20] quit

[RouterA-voice-dial] quit

[RouterA-voice] quit

# 使能QSIG Tunnel特性。

[RouterA] subscriber-line 3/0:15

[RouterA-subscriber-line3/0:15] qsig-tunnel enable

3.5.2  Router B的配置

# 配置VE1中继链路,使得链路正常建立。

<RouterB> system-view

[RouterB] controller E1 6/0

[RouterB-E1 6/0] pri-set

[RouterB-E1 6/0] quit

[RouterB] interface Serial 6/0:15

[RouterB-Serial6/0:15] isdn protocol-mode user

[RouterB-Serial6/0:15] isdn protocol-type qsig

[RouterB-Serial6/0:15] quit

# 配置以太网接口地址,保证VoIP网络通畅。

[RouterB] interface GigabitEthernet 0/1

[RouterB-GigabitEthernet0/1] ip address 168.32.45.211 16

[RouterB-GigabitEthernet0/1] quit

# 配置中继POTS实体。

[RouterB] voice-setup

[RouterB-voice] dial-program

[RouterB-voice-dial] entity 020 pots

[RouterB-voice-dial-entity20] match-template 020....

[RouterB-voice-dial-entity20] send-number all

[RouterB-voice-dial-entity20] line 6/0:15

[RouterB-voice-dial-entity20] quit

# 配置到Router AVoIP实体。

[RouterB-voice-dial] entity 010 voip

[RouterB-voice-dial-entity10] match-template 010....

[RouterB-voice-dial-entity10] address sip ip 168.32.45.214

[RouterB-voice-dial-entity10] quit

[RouterB-voice-dial] quit

[RouterB-voice] quit

# 使能QSIG Tunnel特性。

[RouterB] subscriber-line 6/0:15

[RouterB-subscriber-line6/0:15] qsig-tunnel enable

3.6  验证配置

按照上述配置,Router A和Router B即可在A部和B部之间形成QSIG Tunnel,在SIP报文中以封装的形式透传QSIG报文信息。

(1)     Router A和Router B分别与相连的PBX成功建链。使用display isdn call-info命令,可以看到相应接口处于多帧建链状态。

<RouterA> display isdn call-info interface Serial 3/0:15

Serial3/0:15(User-side) :

  Link Layer 1:  TEI = 0, State = MULTIPLE_FRAME_ESTABLISHED

  Network Layer: 0 connection(s)

 

<RouterB> display isdn call-info interface Serial 6/0:15

Serial6/0:15(User-side) :

  Link Layer 1:  TEI = 0, State = MULTIPLE_FRAME_ESTABLISHED

  Network Layer: 0 connection(s)

(2)     使用A部的电话拨打B部的电话,如用010-1001拨打020-2001,呼叫能够成功建立,话音质量良好。QSIG补充业务能够正常使用。

(3)     在线路上抓包、或者打开debugging voice sip message的调试信息,可以看到SIP消息在SDP中携带了QSIG消息的内容。以Router A上看到的INVITE消息中携带QSIG的Setup消息为例。

·     调试信息中显示的内容如下,由于报文较长,SDP中的QSIG内容被省略了。

*Oct 11 15:44:14:978 2010 RouterA SIP/7/VOICE:                                 

Stack--->NetWork:                                                              

INVITE sip:0202001@168.32.45.211:5060 SIP/2.0                                  

Via: SIP/2.0/TCP 168.32.45.214:5060;branch=z9hG4bKf88fccc5ddd                  

Call-ID: 7d75d420bf498ef7538f4bf4f88fccc5120@168.32.45.214                     

From: <sip:0101001@168.32.45.214:5060>;tag=f88fccc5                            

To: <sip:0202001@168.32.45.211:5060>                                           

CSeq: 1 INVITE                                                                 

Contact: <sip:0101001@168.32.45.214:5060>                                      

Supported: 100rel,timer,join                                                   

Allow: ACK,BYE,CANCEL,INFO,INVITE,NOTIFY,PRACK,REFER,REGISTER,UPDATE,SUBSCRIBE,O

PTIONS                                                                          

Date: Mon, 11 Oct 2010 15:44:14 GMT                                            

Max-Forwards: 70                                                               

Content-Length: 827                                                             

Content-Type: multipart/mixed;boundary=ssboundary-1_                           

                                                                               

--ssboundary-1_                                                                 

Content-Length: 549                                                            

Content-Type: application/sdp                                                  

                                                                                

v=0                                                                            

o=H3C 187390194 187390194 IN IP4 168.32.45.214                                 

s=Sip Call                                                                     

c=IN IP4 168.32.45.214                                                         

t=0 0                                                                          

m=audio 16624 RTP/SAVP 18 8 0 4                                                

a=rtpmap:18 G729/8000                                                          

a=fmtp:18 annexb=no                                                            

a=rtpmap:8 PCMA/8000                                                           

a=rtpmap:0 PCMU/8000                                                            

a=rtpmap:4 G723/8000                                                           

a=crypto:1 AES_CM_128_HMAC_SHA1_80 inline:zTumzx4n9nU46t0FFk+GZHlaw2o0C00WturtUC

np                                                                              

a=cr                                                                           

429 bytes omitted

 

·     我们可以从抓包信息中清楚地看到SDP中携带的内容,如图2所示。SDP封装的类型为multipart/mixed,其中包含了类型为application/qsig的内容。点击可以看到QSIG消息的具体内容。

图2 INVITE报文SDP中携带的QSIG信息

#

3.7  配置文件

·     Router A

#

 sysname RouterA

#

controller E1 3/0

 pri-set

#

interface Serial3/0:15

 link-protocol ppp

 isdn protocol-type qsig

#

interface GigabitEthernet0/1

 port link-mode route

 ip address 168.32.45.214 255.255.0.0

#

#

voice-setup

 #

 sip

 #

 sip-server

#

  call-rule-set

  #

  call-route

 #

 dial-program

  #

  entity 10 pots

   line 3/0:15

   send-number all

   match-template 010....

  #

  entity 20 voip

   address sip ip 168.32.45.211

   match-template 020....

 #

subscriber-line3/0:15

 qsig-tunnel enable

#

·     Router B

#

sysname RouterB

#

controller E1 6/0

 pri-set

#

interface Serial6/0:15

 link-protocol ppp

 isdn protocol-type qsig

#

interface GigabitEthernet0/1

 port link-mode route

 ip address 168.32.45.211 255.255.0.0

#

voice-setup

 #

 sip

 #

 sip-server

  #

  call-rule-set

  #

  call-route

 #

 dial-program

  #

  entity 10 voip

   address sip ip 168.32.45.214

   match-template 010....

  #

  entity 20 pots

   line 6/0:15

   send-number all

   match-template 020....

 #

subscriber-line6/0:15

 qsig-tunnel enable

#

4  相关资料

·     H3C MSR 系列路由器 命令参考(V5)-R2311

·     H3C MSR 系列路由器 配置指导(V5)-R2311

 

不同款型规格的资料略有差异, 详细信息请向具体销售和400咨询。H3C保留在没有任何通知或提示的情况下对资料内容进行修改的权利!