国家 / 地区

H3C MSR系列路由器典型配置举例(V5)-6W100

67-MSR系列路由器使用静态CR-LSP配置MPLS TE隧道功能的典型配置举例

本章节下载  (136.54 KB)

docurl=/cn/Service/Document_Software/Document_Center/Routers/Catalog/MSR/MSR_50/Configure/Typical_Configuration_Example/H3C_MSR_(V5)-6W100/201401/812778_30005_0.htm

67-MSR系列路由器使用静态CR-LSP配置MPLS TE隧道功能的典型配置举例

MSR系列路由器使用静态CR-LSP配置MPLS TE隧道功能典型配置举例

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

H3C_彩色.emf

目  录

1 简介

2 配置前提

3 配置举例

3.1 组网需求

3.2 使用版本

3.3 配置注意事项

3.4 配置步骤

3.4.1 设备Router A配置

3.4.2 设备Router B配置

3.4.3 设备Router C配置

3.5 验证配置

3.6 配置文件

4 相关资料


1  简介

本文档介绍使用静态CR-LSP配置MPLS TE隧道功能的典型案例。

2  配置前提

本文档不严格与具体软、硬件版本对应,如果使用过程中与产品实际情况有差异,请参考相关产品手册,或以设备实际情况为准。

本文档中的配置均是在实验室环境下进行的配置和验证,配置前设备的所有参数均采用出厂时的缺省配置。如果您已经对设备进行了配置,为了保证配置效果,请确认现有配置和以下举例中的配置不冲突。

本文档假设您已了解静态CR-LSP的特性。

3  配置举例

3.1  组网需求

图1所示,在MPLS网络中,Router A,Router B和Router C运行IS-IS路由协议,要求:配置静态CR-LSP建立一条Router A到Router C的MPLS TE隧道。

图1 MSR系列路由器通过静态CR-LSP配置MPLS TE隧道组网图

 

3.2  使用版本

本举例是在Release 2311版本上进行配置和验证的。

3.3  配置注意事项

在入口节点、转发节点、出口节点都要配置静态CR-LSP,使用相同的隧道名称,入站节点的出站标签和转发节点的入站标签、转发节点的出站标签和出口节点的入站标签也必须一一对应。

3.4  配置步骤

3.4.1  设备Router A配置

# 配置Router A的接口地址。

<RouterA> system-view

[RouterA] interface ethernet 1/1

[RouterA-Ethernet1/1] ip address 2.1.1.1 255.255.255.0

[RouterA-Ethernet1/1] quit

[RouterA] interface loopback 0

[RouterA-LoopBack0] ip address 1.1.1.1 255.255.255.255

[RouterA-LoopBack0] quit

# 配置IS-IS协议。

[RouterA] isis 1

[RouterA-isis-1] network-entity 00.0005.0000.0000.0001.00

[RouterA-isis-1] quit

[RouterA] interface ethernet 1/1

[RouterA-Ethernet1/1] isis enable 1

[RouterA-Ethernet1/1] quit

[RouterA] interface loopback 0

[RouterA-LoopBack0] isis enable 1

[RouterA-LoopBack0] quit

# 配置MPLS TE基本能力。

[RouterA] mpls lsr-id 1.1.1.1

[RouterA] mpls

[RouterA-mpls] mpls te

[RouterA-mpls] quit

[RouterA] interface ethernet 1/1

[RouterA-Ethernet1/1] mpls

[RouterA-Ethernet1/1] mpls te

[RouterA-Ethernet1/1] quit

# Router A上配置MPLS TE隧道。

[RouterA] interface tunnel 0

[RouterA-Tunnel0] ip address 6.1.1.1 255.255.255.0

[RouterA-Tunnel0] tunnel-protocol mpls te

[RouterA-Tunnel0] destination 3.3.3.3

[RouterA-Tunnel0] mpls te tunnel-id 10

[RouterA-Tunnel0] mpls te signal-protocol static

[RouterA-Tunnel0] mpls te commit

[RouterA-Tunnel0] quit

# 配置Router A为静态CR-LSP的入口节点。

[RouterA] static-cr-lsp ingress tunnel 0 destination 3.3.3.3 nexthop 2.1.1.2 out-label 20

# 使用静态路由沿MPLS TE隧道转发流量。

[RouterA] ip route-static 3.2.1.2 24 tunnel 0 preference 1

3.4.2  设备Router B配置

# 配置Router B的接口地址。

<RouterB> system-view

[RouterB] interface ethernet 1/1

[RouterB-Ethernet1/1] ip address 2.1.1.2 255.255.255.0

[RouterB-Ethernet1/1] quit

[RouterB] interface ethernet 1/2

[RouterB-Ethernet1/2] ip address 3.2.1.1 255.255.255.0

[RouterB-Ethernet1/2] quit

[RouterB] interface loopback 0

[RouterB-LoopBack0] ip address 2.2.2.2 255.255.255.255

[RouterB-LoopBack0] quit

# 配置IS-IS协议。

[RouterB] isis 1

[RouterB-isis-1] network-entity 00.0005.0000.0000.0002.00

[RouterB-isis-1] quit

[RouterB] interface ethernet 1/1

[RouterB-Ethernet1/1] isis enable 1

[RouterB-Ethernet1/1] quit

[RouterB] interface ethernet 1/2

[RouterB-Ethernet1/2] isis enable 1

[RouterB-Ethernet1/2] quit

[RouterB] interface loopback 0

[RouterB-LoopBack0] isis enable 1

[RouterB-LoopBack0] quit

# 配置MPLS TE基本能力。

[RouterB] mpls lsr-id 2.2.2.2

[RouterB] mpls

[RouterB-mpls] mpls te

[RouterB-mpls] quit

[RouterB] interface ethernet 1/1

[RouterB-Ethernet1/1] mpls

[RouterB-Ethernet1/1] mpls te

[RouterB-Ethernet1/1] quit

[RouterB] interface ethernet 1/2

[RouterB-Ethernet1/2] mpls

[RouterB-Ethernet1/2] mpls te

[RouterB-Ethernet1/2] quit

# 配置Router B为静态CR-LSP的中间节点。

[RouterB] static-cr-lsp transit tunnel 0 incoming-interface ethernet 1/1 in-label 20 nexthop 3.2.1.2 out-label 30

3.4.3  设备Router C配置

# 配置Router C的接口地址。

<RouterC> system-view

[RouterC] interface ethernet 1/1

[RouterC-Ethernet1/1] ip address 3.2.1.2 255.255.255.0

[RouterC-Ethernet1/1] quit

[RouterC] interface loopback 0

[RouterC-LoopBack0] ip address 3.3.3.3 255.255.255.255

[RouterC-LoopBack0] quit

# 配置IS-IS协议。

[RouterC] isis 1

[RouterC-isis-1] network-entity 00.0005.0000.0000.0003.00

[RouterC-isis-1] quit

[RouterC] interface ethernet 1/1

[RouterC-Ethernet1/1] isis enable 1

[RouterC-Ethernet1/1] quit

[RouterC] interface loopback 0

[RouterC-LoopBack0] isis enable 1

[RouterC-LoopBack0] quit

# 配置Router C MPLS TE基本能力。

[RouterC] mpls lsr-id 3.3.3.3

[RouterC] mpls

[RouterC-mpls] mpls te

[RouterC-mpls] quit

[RouterC] interface ethernet1/1

[RouterC-Ethernet1/1] mpls

[RouterC-Ethernet1/1] mpls te

[RouterC-Ethernet1/1] quit

# 配置Router C为静态CR-LSP的尾节点。

[RouterC] static-cr-lsp egress tunnel 0 incoming-interface ethernet 1/1 in-label 30

3.5  验证配置

# 在Router A上执行display interface tunnel命令,查看Tunnel接口的状态

<RouterA> display interface tunnel 0

Tunnel0 current state: UP

Line protocol current state: UP

Description: Tunnel0 Interface

The Maximum Transmit Unit is 64000

Internet Address is 6.1.1.1/24 Primary

Encapsulation is TUNNEL, service-loopback-group ID not set

Tunnel source unknown, destination 3.3.3.3

Tunnel protocol/transport CR_LSP

Output queue : (Urgent queuing : Size/Length/Discards)  0/100/0

Output queue : (Protocol queuing : Size/Length/Discards)  0/500/0

Output queue : (FIFO queuing : Size/Length/Discards)  0/75/0

    Last 300 seconds input:  0 bytes/sec, 0 packets/sec

    Last 300 seconds output:  0 bytes/sec, 0 packets/sec

    0 packets input,  0 bytes

    0 input error

    0 packets output,  0 bytes

    0 output error              

# 在Router A上执行display mpls te tunnel命令,查看MPLS TE隧道的建立情况。

<RouterA> display mpls te tunnel

LSP-Id          Destination     In/Out-If               Name

1.1.1.1:1       3.3.3.3         -/Eth1/1                Tunnel0

# 在Router B上执行display mpls te tunnel命令,查看MPLS TE隧道的建立情况。

<RouterB> display mpls te tunnel

LSP-Id          Destination     In/Out-If               Name

-               -               Eth1/1/Eth1/2           Tunnel0

# 在Router C上执行display mpls te tunnel命令,查看MPLS TE隧道的建立情况。

<RouterC> display mpls te tunnel

LSP-Id          Destination     In/Out-If               Name

-               -               Eth1/1/-                Tunnel0

# 在Router A上执行display mpls lsp命令,查看静态CR-LSP的建立情况。

<RouterA> display mpls lsp

-------------------------------------------------------------------

                 LSP Information: STATIC CRLSP

-------------------------------------------------------------------

FEC             In/Out Label  In/Out IF              Vrf Name

3.3.3.3/32      NULL/20       -/Eth1/1

# 在Router B上执行display mpls lsp命令,查看静态CR-LSP的建立情况。

<RouterB> display mpls lsp

------------------------------------------------------------------

                 LSP Information: STATIC CRLSP

------------------------------------------------------------------

FEC             In/Out Label  In/Out IF               Vrf Name

-/-             20/30         Eth1/1/Eth1/2

# 在Router C上执行display mpls lsp命令,查看静态CR-LSP的建立情况。

<RouterC> display mpls lsp

------------------------------------------------------------------

                 LSP Information: STATIC CRLSP

------------------------------------------------------------------

FEC              In/Out Label  In/Out IF               Vrf Name

-/-              30/NULL       Eth1/1/-

3.6  配置文件

·     Router A配置:

#

 mpls lsr-id 1.1.1.1

#

mpls

 mpls te

#

isis 1

 network-entity 00.0005.0000.0000.0001.00

#

interface Ethernet1/1

 port link-mode route

 ip address 2.1.1.1 255.255.255.0

 isis enable 1

 mpls

 mpls te

#

interface LoopBack0

 ip address 1.1.1.1 255.255.255.255

 isis enable 1

 

#

interface Tunnel0

 ip address 6.1.1.1 255.255.255.0

 tunnel-protocol mpls te

 destination 3.3.3.3

 mpls te signal-protocol static

 mpls te tunnel-id 10

 mpls te commit

#

 ip route-static 3.2.1.0 255.255.255.0 Tunnel0 preference 1

#

 static-cr-lsp ingress Tunnel0 destination 3.3.3.3 nexthop 2.1.1.2 out-label 20

·     Router B配置:

#

 mpls lsr-id 2.2.2.2

#

mpls

 mpls te

#

isis 1

 network-entity 00.0005.0000.0000.0002.00

#

interface LoopBack0

 ip address 2.2.2.2 255.255.255.255

 isis enable 1

#

interface Ethernet1/1

 ip address 2.1.1.2 255.255.255.0

 isis enable 1

 mpls

 mpls te

#

interface Ethernet1/2

 ip address 3.2.1.1 255.255.255.0

 isis enable 1

 mpls

 mpls te

#

 static-cr-lsp transit tunnel0 incoming-interface Ethernet1/1 in-label 20

 nexthop 3.2.1.2 out-label 30

·     Router C配置:

#

 mpls lsr-id 3.3.3.3

#

mpls

 mpls te

#

isis 1

 network-entity 00.0005.0000.0000.0003.00

#

interface LoopBack0

 ip address 3.3.3.3 255.255.255.255

 isis enable 1

#

interface Ethernet1/1

 ip address 3.2.1.2 255.255.255.0

 isis enable 1

 mpls

 mpls te

#

 static-cr-lsp egress tunnel0 incoming-interface Ethernet1/1 in-label 30

4  相关资料

·     H3C MSR 系列路由器 命令参考(V5)-R2311

·     H3C MSR 系列路由器 配置指导(V5)-R2311

不同款型规格的资料略有差异, 详细信息请向具体销售和400咨询。H3C保留在没有任何通知或提示的情况下对资料内容进行修改的权利!