国家 / 地区

H3C MSR系列路由器典型配置举例(V5)-6W100

27-MSR系列路由器L2TP with PPPoE典型配置举例

本章节下载  (142.52 KB)

docurl=/cn/Service/Document_Software/Document_Center/Routers/Catalog/MSR/MSR_50/Configure/Typical_Configuration_Example/H3C_MSR_(V5)-6W100/201401/812738_30005_0.htm

27-MSR系列路由器L2TP with PPPoE典型配置举例

MSR系列路由器L2TP with PPPoE典型配置举例

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



1  简介

本文档介绍L2TP with PPPoE的典型配置举例。

2  配置前提

本文档不严格与具体软、硬件版本对应,如果使用过程中与产品实际情况有差异,请参考相关产品手册,或以设备实际情况为准。

本文档中的配置均是在实验室环境下进行的配置和验证,配置前设备的所有参数均采用出厂时的缺省配置。如果您已经对设备进行了配置,为了保证配置效果,请确认现有配置和以下举例中的配置不冲突。

本文档假设您已了解PPPoE和L2TP特性。

3  配置举例

3.1  组网需求

图1所示,Router A作为PPPoE的Client端和L2TP的User, Router B同时作为LAC和PPPoE server, Router C作为LNS,要求:采用本地认证的方式,Router A通过PPPoE拨上LAC,并触发LAC和LNS建立L2TP隧道。

图1 L2TP with PPPoE配置组网图

 

3.2  使用版本

本举例是在Release 2317版本上进行配置和验证的。

3.3  配置注意事项

·     当PPPoE Client端配置PPPoE会话为报文触发方式时(设置了idle-timeout参数),必须同时设置dialer-rule及相应路由,允许ip报文通过dialer接口被转发,才能使PPPoE会话被正常触发。

·     本用例测试完成后,以防对以后的测试产生影响,须清除掉本测试项中对所有路由器所做的配置。

3.4  配置步骤

3.4.1  Router B的配置

# 配置串口IP地址。

<RouterB> system-view

[RouterB] interface serial 1/0

[RouterB-Serial1/0] ip address 202.115.22.194 24

[RouterB-Serial1/0] quit

# 创建本地用户,配置用户名、密码及服务类型。

[RouterB] local-user h3c

[RouterB-luser-h3c] password simple h3c

[RouterB-luser-h3c] service-type ppp

[RouterB-luser-h3c] quit

# 创建虚接口模板、配置ppp认证。

[RouterB] interface Virtual-Template0

[RouterB-Virtual-Template0] ppp authentication-mode chap

[RouterB-Virtual-Template0] quit 

# 在接口下将PPPoE服务器与Virtual-Template0绑定。

[RouterB] interface gigabitethernet0/0

[RouterB-GigabitEthernet0/0] pppoe-server bind virtual-template 0

[RouterB-GigabitEthernet0/0] quit

# 使能l2tp。

[RouterB] l2tp enable

# 创建l2tp组、配置隧道触发条件、隧道密码和隧道名称。

[RouterB] l2tp-group 1

[RouterB-l2tp1] start l2tp ip 202.115.22.196 fullusername h3c

[RouterB-l2tp1] tunnel password simple h3c

[RouterB-l2tp1] tunnel name lac

[RouterB-l2tp1] quit

3.4.2  Router A的配置

# 配置拨号访问规则。

<RouterA> system-view

[RouterA] dialer-rule 1 ip permit

# 创建dialer接口、设置拨号参数、配置IP地址协商和ppp认证。

[RouterA] interface dialer 0

[RouterA-Dialer0] dialer user PPPoE

[RouterA-Dialer0] dialer bundle 1

[RouterA-Dialer0] dialer-group 1

[RouterA-Dialer0] ip address ppp-negotiate

[RouterA-Dialer0] ppp chap user h3c

[RouterA-Dialer0] ppp chap password simple h3c

[RouterA-Dialer0] quit

# 在GigabitEthernet0/0上使能pppoe client。

[RouterA] interface gigabitethernet 0/0

[RouterA-GigabitEthernet0/0] pppoe-client dial-bundle-number 1

[RouterA-GigabitEthernet0/0] quit

3.4.3  Router C的配置

# 配置串口Serial4/0的IP地址。

<RouterC> system-view

[RouterC] interface serial 4/0

[RouterC-Serial4/0] ip address 202.115.22.196 24

[RouterC-Serial4/0] quit

# 配置接口Ethernet0/0的IP地址。

[RouterC] interface ethernet 0/0

[RouterC-Ethernet0/0] ip address 20.1.1.1 8

[RouterC-Ethernet0/0] quit

# 进入域视图配置地址池。

[RouterC] domain system

[RouterC-isp-system] ip pool 1 20.1.2.1 20.1.2.50

[RouterC-isp-system] quit

# 创建本地用户,配置用户名、密码及服务类型。

[RouterC] local-user h3c

[RouterC-luser-h3c] password simple h3c

[RouterC-luser-h3c] service-type ppp

[RouterC-luser-h3c] quit 

# 创建虚接口模板、配置ppp认证、ip地址借用和地址协商。

[RouterC] interface Virtual-Template 0

[RouterC-Virtual-Template0] ppp authentication-mode chap

[RouterC-Virtual-Template0] ip address unnumbered interface Ethernet0/0

[RouterC-Virtual-Template0] remote address pool 1

[RouterC-Virtual-Template0] quit

# 使能l2tp。

[RouterC] l2tp enable

# 创建l2tp组、配置隧道接受条件、隧道密码和隧道名称。

[RouterC] l2tp-group 1

[RouterC-l2tp1] allow l2tp Virtual-Template 0 remote lac

[RouterC-l2tp1] tunnel password simple h3c

[RouterC-l2tp1] tunnel name lns

[RouterC-l2tp1] quit

3.5  验证配置

# 可以通过如下信息看到,从Router A上可以ping通20.1.1.1。

<RouterA> ping 20.1.1.1

  PING 20.1.1.1: 56  data bytes, press CTRL_C to break

    Reply from 20.1.1.1: bytes=56 Sequence=1 ttl=255 time=3 ms

    Reply from 20.1.1.1: bytes=56 Sequence=2 ttl=255 time=3 ms

    Reply from 20.1.1.1: bytes=56 Sequence=3 ttl=255 time=3 ms

    Reply from 20.1.1.1: bytes=56 Sequence=4 ttl=255 time=3 ms

    Reply from 20.1.1.1: bytes=56 Sequence=5 ttl=255 time=3 ms

 

  --- 20.1.1.1 ping statistics ---

    5 packet(s) transmitted

    5 packet(s) received

    0.00% packet loss

    round-trip min/avg/max = 3/3/3 ms

# 可以在Router B和Router C上用display l2tp session和display l2tp tunnel命令查看l2tp隧道建立情况。以Router B为例:

<RouterB> display l2tp session

 Total session = 1

 

 LocalSID  RemoteSID  LocalTID

  22950     9281       1

<RouterB> display l2tp tunnel

 Total tunnel = 1

 

 LocalTID RemoteTID RemoteAddress    Port   Sessions RemoteName

 1        1         202.115.22.196   1701   1        lns

# 可以在Router B上查看pppoe的会话建立情况。

<RouterB> display pppoe-server session all

Total PPPoE Session(s): 1

 

SID  Intf                      State OIntf          RemMAC       LocMAC

1    Virtual-Template0:0       UP    GE0/0          000f26260011 000f2626000

3.6  配置文件

·     Router B:

#

l2tp enable

#

local-user h3c

 password simple h3c

 service-type ppp

#

l2tp-group 1

 tunnel password simple h3c

 tunnel name lac

 start l2tp ip 202.115.22.196 fullusername h3c

#

interface Serial1/0

 fe1 clock master

 link-protocol ppp

 ip address 202.115.22.194 255.255.255.0

#

interface Virtual-Template0

 ppp authentication-mode chap

#

interface GigabitEthernet0/0

 port link-mode route

 pppoe-server bind Virtual-Template 0

#

·     Router A

#

interface Dialer0

 link-protocol ppp

 ppp chap user h3c

 ppp chap password simple h3c

 ip address ppp-negotiate

 dialer user PPPoE

 dialer-group 1

 dialer bundle 1

#

interface GigabitEthernet0/0

 port link-mode route

 pppoe-client dial-bundle-number 1

#

 dialer-rule 1 ip permit

·     Router C:

#

 l2tp enable

#

domain system

 access-limit disable

 state active

 idle-cut disable

 self-service-url disable

 ip pool 1 20.1.2.1 20.1.2.50

#

 local-user h3c

 password simple h3c

 service-type ppp

#

l2tp-group 1

 allow l2tp virtual-template 0 remote lac

 tunnel password simple h3c

 tunnel name lns

#

interface Ethernet0/0

 port link-mode route

 ip address 20.1.1.1 255.0.0.0

#

interface Serial4/0

 link-protocol ppp

 ip address 202.115.22.196 255.255.255.0

#

interface Virtual-Template0

 ppp authentication-mode chap

 remote address pool 1

 ip address unnumbered interface Ethernet0/0

#

4  相关资料

·     H3C MSR 系列路由器 命令参考(V5)-R2311

·     H3C MSR 系列路由器 配置指导(V5)-R2311

不同款型规格的资料略有差异, 详细信息请向具体销售和400咨询。H3C保留在没有任何通知或提示的情况下对资料内容进行修改的权利!

联系我们 联系我们
联系我们
回到顶部 回到顶部