国家 / 地区

H3C MSR系列路由器典型配置举例(V5)-6W100

81-MSR系列路由器与思科互联互通配置举例(SIP)

本章节下载  (169.39 KB)

docurl=/cn/Service/Document_Software/Document_Center/Routers/Catalog/MSR/MSR_50/Configure/Typical_Configuration_Example/H3C_MSR_(V5)-6W100/201401/812792_30005_0.htm

81-MSR系列路由器与思科互联互通配置举例(SIP)

MSR系列路由器与思科互通配置举例

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

H3C_彩色.emf

 



1  介绍

本文主要介绍与思科互通SIP配置。

2  配置前提

本文档不严格与具体软、硬件版本对应,如果使用过程中与产品实际情况有差异,请参考相关产品手册,或以设备实际情况为准。

本文档中的配置均是在实验室环境下进行的配置和验证,配置前设备的所有参数均采用出厂时的缺省配置。如果您已经对设备进行了配置,为了保证配置效果,请确认现有配置和以下举例中的配置不冲突。

本文档假设您已了解SIP特性。

3  与思科背靠背互通SIP配置举例

3.1  组网需求

通常用于网络内存在不同厂商的路由器设备且有语音业务需求的环境中。如图1所示,MSR路由器与思科ISR系列路由器均开启SIP协议,通过SIP使用背靠背连接方式互联,电话29211与电话4545能够使用SIP打通电话。

图1 与思科互通SIP基本呼叫组网图

 

3.2  配置思路

·     为使网络连通,配置路由器的接口一个网段内;

·     为使电话与语音网关和目的电话联系,配置语音实体。

3.3  使用版本

·     H3C

本举例是在Release 2207P14版本上进行配置和验证的。

·     CISCO

本举例是在RELEASE SOFTWARE (fc4)版本上进行配置和验证的。

3.4  配置注意事项

·     正确选择可用的sip server,选用正确的Cisco版本。

·     两路由器的时隙要一致,若不一致有可能导致呼叫建立不成功。

3.5  配置步骤

3.5.1  H3C路由器的配置

# 配置接口IP地址。

<H3C> system-view

[H3C] interface GigabitEthernet 0/0

[H3C-GigabitEthernet0/0] ip address 172.32.27.1 255.255.0.0

[H3C-GigabitEthernet0/0] quit

# 配置本地POTS实体。

[H3C] voice-setup

[H3C-voice] dial-program

[H3C-voice-dial] entity 29211 pots

[H3C-voice-dial-entity29211] match-template 29211

[H3C-voice-dial-entity29211] line 5/0

[H3C-voice-dial-entity29211] quit

# 配置远端VOIP实体。

[H3C-voice-dial] entity 4545 voip

[H3C-voice-dial-entity4545] address sip ip 172.32.27.45

[H3C-voice-dial-entity4545] match-template 4545

3.5.2  CISCO路由器的配置

# 配置接口IP地址。

ISR#configure terminal

ISR(config)#interface FastEthernet0/0

ISR(config-if)#ip address 172.32.27.45 255.255.0.0

ISR(config-if)#no shutdown

ISR(config-if)#exit

# 配置本地POTS实体。

ISR(config)#dial-peer voice 4545 pots

ISR(config-dial-peer)#destination-pattern 4545

ISR(config-dial-peer)#port 3/1/0

ISR(config-dial-peer)#exit

# 配置远端VOIP实体。

ISR(config)#dial-peer voice 29211 voip

ISR(config-dial-peer)#destination-pattern 29211

ISR(config-dial-peer)#session protocol sipv2

ISR(config-dial-peer)#session target ipv4:172.32.27.1

3.6  验证结果

(1)     使用电话29211拨打号码4545,电话4545振铃,4545摘机后两端能够正常通话,任意一方挂机,均可结束通话;

(2)     使用电话4545拨打号码29211,电话29211振铃,29211摘机后两端能够正常通话,任意一方挂机,均可结束通话。

3.7  配置文件

·     H3C

#

sysname H3C

#

interface GigabitEthernet0/0

 port link-mode route

 ip address 172.32.27.1 255.255.0.0

#

voice-setup

 sip

 #

 dial-program

  #

  entity 4545 voip

   address sip ip 172.32.27.45

   match-template 4545

  #

  entity 29211 pots

   line 5/0

   match-template 29211

#

·     CISCO

Building configuration...

 

Current configuration : 1449 bytes

!

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname ISR

!

interface FastEthernet0/0

 ip address 172.32.27.45 255.255.0.0

 duplex auto

 speed auto

!

!

dial-peer voice 4545 pots

 destination-pattern 4545

 port 3/1/0

!

dial-peer voice 29211 voip

 destination-pattern 29211

 session protocol sipv2

 session target ipv4:172.32.27.1

!

end

4  与思科通过PS互通SIP配置举例

4.1  组网需求

图2所示,MSR路由器与思科ISR系列路由器通过SIP,使用PS方式实现互联互通,电话29211与电话4545能够通过PS打通电话。

图2 与思科通过PS互通组网图

 

4.2  配置思路

·     为开启注册和代理功能,配置注册服务器和代理服务器;

·     为使电话与语音网关和目标地址之间建立联系,配置语音实体。

4.3  使用版本

·     H3C

本举例是在Release 2207P14版本上进行配置和验证的。

·     CISCO

本举例是在RELEASE SOFTWARE (fc4)版本上进行配置和验证的。

4.4  配置注意事项

·     正确选择可用的sip server,选用正确的Cisco版本。

·     注意两端的校验方式要保持一致。

·     两路由器的时隙要一致,若不一致有可能导致呼叫建立不成功。

4.5  配置步骤

4.5.1  H3C路由器的配置

# 配置接口IP地址。

<H3C> system-view

[H3C] interface GigabitEthernet 0/0

[H3C-GigabitEthernet0/0] ip address 172.32.27.1 255.255.0.0

[H3C-GigabitEthernet0/0] quit

# 配置注册服务器地址和注册使用的用户名、密码。

[H3C] voice-setup

[H3C-voice] sip

[H3C-voice-sip] registrar ipv4 172.32.27.101

[H3C-voice-sip] user sip:29211@172.32.27.101 password simple 8048

# 指定本机源IP地址。

[H3C-voice-sip] source-ip 172.32.27.1

# 配置代理服务器地址。

[H3C-voice-sip] proxy ipv4 172.32.27.101

# 使能SIP注册。

[H3C-voice-sip] register-enable on

[H3C-voice-sip] quit

# 配置本地POTS实体相关参数。

[H3C-voice] dial-program

[H3C-voice-dial] entity 29211 pots

[H3C-voice-dial-entity29211] match-template 29211

[H3C-voice-dial-entity29211] line 5/0

[H3C-voice-dial-entity29211] quit

# 配置远端VOIP实体相关参数。

[H3C-voice-dial] entity 4545 voip

[H3C-voice-dial-entity4545] address sip proxy

[H3C-voice-dial-entity4545] match-template 4545

4.5.2  CISCO路由器的配置

# 配置接口IP地址。

ISR#configure terminal

ISR(config)#interface FastEthernet0/0

ISR(config-if)#ip address 172.32.27.45 255.255.0.0

ISR(config-if)#no shutdown

ISR(config-if)#exit

# 配置注册服务器地址和注册使用的用户名、密码。

ISR(config)#sip-ua

ISR(config-sip-ua)#registrar ipv4:172.32.27.101

ISR(config-sip-ua)#authentication username sip:4545@172.32.27.101 password 4545

# 配置代理服务器地址。

ISR(config-sip-ua)#sip-server ipv4:172.32.27.101

ISR(config-sip-ua)#exit

# 配置本地POTS实体。

ISR(config)#dial-peer voice 4545 pots

ISR(config-dial-peer)#destination-pattern 4545

ISR(config-dial-peer)#port 3/1/0

ISR(config-dial-peer)#exit

# 配置远端VOIP实体。

ISR(config)#dial-peer voice 29211 voip

ISR(config-dial-peer)#destination-pattern 29211

ISR(config-dial-peer)#session protocol sipv2

ISR(config-dial-peer)#session target sip-server

4.6  验证配置

·     使用电话29211拨打号码4545,电话4545振铃,4545摘机后两端能够正常通话,任意一方挂机,均可结束通话;

·     使用电话4545拨打号码29211,电话29211振铃,29211摘机后两端能够正常通话,任意一方挂机,均可结束通话。

4.7  配置文件

·     H3C

#

 sysname H3C

#

interface GigabitEthernet0/0

 port link-mode route

 ip address 172.32.27.1 255.255.0.0

#

voice-setup

sip

  user sip:29211@172.32.27.101 password simple 8048

  source-ip 172.32.27.1

  registrar ipv4 172.32.27.101

  proxy ipv4 172.32.27.101

  register-enable on

 #

 dial-program

  #

  entity 4545 voip

   address sip proxy

   match-template 4545

  #

  entity 29211 pots

   line 5/0    

   match-template 29211

 #

#

·     CISCO

Building configuration...

 

Current configuration : 1517 bytes

!

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname ISR

!

boot-start-marker

boot-end-marker

!

!

no network-clock-participate slot 2

voice-card 2

 dspfarm

!

!

interface FastEthernet0/0

 ip address 172.32.27.45 255.255.0.0

 duplex auto

 speed auto

!

dial-peer voice 4545 pots

 destination-pattern 4545

 port 3/1/0

!

dial-peer voice 29211 voip

 destination-pattern 29211

 session protocol sipv2

 session target sip-server

!

sip-ua

 authentication username sip:4545@172.32.27.101 password 06525A7519

 registrar ipv4:172.32.27.101 expires 3600

 sip-server ipv4:172.32.27.101

!

!

end

5  相关资料

·     H3C MSR 系列路由器 命令参考(V5)-R2311

·     H3C MSR 系列路由器 配置指导(V5)-R2311

 

不同款型规格的资料略有差异, 详细信息请向具体销售和400咨询。H3C保留在没有任何通知或提示的情况下对资料内容进行修改的权利!

联系我们 联系我们
联系我们
回到顶部 回到顶部