国家 / 地区

H3C MSR系列路由器典型配置举例(V5)-6W100

08-MSR系列路由器DHCP配置举例

本章节下载  (169.74 KB)

docurl=/cn/Service/Document_Software/Document_Center/Routers/Catalog/MSR/MSR_50/Configure/Typical_Configuration_Example/H3C_MSR_(V5)-6W100/201401/812719_30005_0.htm

08-MSR系列路由器DHCP配置举例

MSR系列路由器DHCP配置的典型配置举例

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

H3C_彩色.emf

 



1  简介

本文档介绍使用DHCP功能实现动态地址分配的典型案例。

2  配置前提

本文档不严格与具体软、硬件版本对应,如果使用过程中与产品实际情况有差异,请参考相关产品手册,或以设备实际情况为准。

本文档中的配置均是在实验室环境下进行的配置和验证,配置前设备的所有参数均采用出厂时的缺省配置。如果您已经对设备进行了配置,为了保证配置效果,请确认现有配置和以下举例中的配置不冲突。

本文档假设您已了解DHCP功能的特性。

3  DHCP同一子网内的动态地址分配配置举例

3.1  组网需求

图1所示,Router A为DHCP服务器,Router B和Host为DHCP客户端,要求:

·     使用DHCP功能静态地址绑定的方式为客户端Router B分配IP地址。

·     使用DHCP功能动态地址池的方式为客户端Host分配IP地址。

图1 MSR路由器同一子网内动态地址分配组网图

 

3.2  配置思路

DHCP服务器可以通过一个网段范围的地址池为DHCP客户端随机分配一个有限期限的地址,客户端在租约到期时续约;也可以为某个特殊客户端分配一个静态绑定地址,使之获取固定的无限期的地址。

3.3  使用版本

本举例是在Release 2311版本上进行配置和验证的。

3.4  配置注意事项

目前DHCP Client只能适用于三层以太网接口(包括子接口)、VLAN虚接口。

3.5  配置步骤

3.5.1  Router A的配置

# 使能DHCP服务。

<RouterA> system-view

[RouterA] dhcp enable

# 配置接口IP地址。

[RouterA] interface ethernet 0/0

[RouterA-Ethernet0/0] ip address 10.10.0.1 16

[RouterA-Ethernet0/0] quit

# 配置给客户端Router B分配静态绑定地址的地址池。

[RouterA] dhcp server ip-pool 1

[RouterA-dhcp-pool-1] static-bind ip-address 10.10.0.10 16

[RouterA-dhcp-pool-1] static-bind client-identifier 3030-3066-2e65-3233-612e-6666-3634-2d45-7468-6572-6e65-7430-2f31

[RouterA-dhcp-pool-1] quit

# 配置给客户端Host分配动态地址的地址池。

[RouterA] dhcp server ip-pool 2

[RouterA-dhcp-pool-2] network 10.10.0.0 16

[RouterA-dhcp-pool-2] dns-list 10.10.0.20

[RouterA-dhcp-pool-2] domain-name mydomain.com

[RouterA-dhcp-pool-2] gateway-list 10.10.0.10

[RouterA-dhcp-pool-2] expired day 2 hour 12 minute 30

[RouterA-dhcp-pool-2] nbns-list 10.10.1.1 10.10.2.2 10.10.3.3 10.10.4.4

[RouterA-dhcp-pool-2] quit

3.5.2  Router B的配置

# 配置Router B接口Ethernet0/1以DHCP方式动态获取地址。

<RouterB> system-view

[RouterB] interface ethernet 0/1

[RouterB-Ethernet0/1] ip address dhcp-alloc

[RouterB-Ethernet0/1] quit

3.5.3  配置客户端Host通过DHCP方式获取地址

WINDOWS XP为例,右击桌面“网上邻居”-> 单击“属性”—> 进入“网络连接”窗口,右击“本地连接”-> 进入“本地连接属性”窗口,选择适当的“连接时使用”的网卡,选择“Internet协议(TCP/IP)”,点击“属性”-> 进入“Internet协议(TCP/IP)属性”窗口,选择“自动获得IP地址”和“自动获得DNS服务器地址”即可。

3.6  验证结果

# 在网络可达的情况下,可以看到Router A已经给Router B分配了静态绑定地址10.10.0.10,给Host动态分配了10.10.0.0/16网段的一个地址:

<RouterA> display dhcp server ip-in-use all

Pool utilization: 0.00%

 IP address       Client-identifier/    Lease expiration          Type

                  Hardware address

 10.10.0.10       3030-3066-2e65-3233-  Unlimited                 Manual

                  612e-6666-3634-2d45-

                  7468-6572-6e65-7430-

                  2f31

 10.10.0.5        0015-e943-7e6a        Sep 30 2011 23:24:38      Auto:COMMITTED

 

 --- total 2 entry ---

# 在Router B端执行命令display dhcp client verbose interface ethernet0/1可以查看到从DHCP服务器获取的地址等信息:

<RouterB> display dhcp client verbose interface ethernet0/1

Ethernet0/1 DHCP client information:

 Current machine state: BOUND

 Allocated IP: 10.10.0.10 255.255.0.0

 Allocated lease: 4294967295 seconds, T1: 2147483647 seconds, T2: 3758096383 sec

onds

 Lease: unlimited

 DHCP server: 10.10.0.1

 Transaction ID: 0x2e17b6f

 Default router: 10.10.0.10

 DNS server: 10.10.0.20

 Domain name: mydomain.com

 Client ID: 3030-3066-2e65-3233-

            612e-6666-3634-2d45-

            7468-6572-6e65-7430-

            2f31

 T1 will timeout in 24855 days 3 hours 5 minutes 2 seconds.

# 在Host的DOS模式下,执行命令ipconfig /all可以查看到对应的网卡已经从DHCP服务器获取到地址和其它配置信息:

Ethernet adapter 本地连接-2:

        Connection-specific DNS Suffix  . : mydomain.com

        Description . . . . . . . . . . . : D-Link DFE-530TX PCI Fast Ethernet A

dapter (rev.C) #2

        Physical Address. . . . . . . . . : 00-15-E9-43-7E-6A

        Dhcp Enabled. . . . . . . . . . . : Yes

        Autoconfiguration Enabled . . . . : Yes

        IP Address. . . . . . . . . . . . : 10.10.0.5

        Subnet Mask . . . . . . . . . . . : 255.255.0.0

        Default Gateway . . . . . . . . . :

        DHCP Server . . . . . . . . . . . : 10.10.0.1

        DNS Servers . . . . . . . . . . . : 10.10.0.20

        Primary WINS Server . . . . . . . : 10.10.1.1

        Secondary WINS Server . . . . . . : 10.10.2.2

                                            10.10.3.3

                                            10.10.4.4

        Lease Obtained. . . . . . . . . . : 2011年9月28日 10:37:12

        Lease Expires . . . . . . . . . . : 2011年9月30日 23:07:12

3.7  配置文件

·     Router A:

#

 sysname RouterA

#

dhcp server ip-pool 1

 static-bind ip-address 10.10.0.10 mask 255.255.0.0

 static-bind client-identifier 3030-3066-2e65-3233-612e-6666-3634-2d45-7468-6572

-6e65-7430-2f31

#

dhcp server ip-pool 2

 network 10.10.0.0 mask 255.255.0.0

 gateway-list 10.10.0.10

 dns-list 10.10.0.20

 domain-name mydomain.com

 nbns-list 10.10.1.1 10.10.2.2 10.10.3.3 10.10.4.4

 expired day 2 hour 12 minute 30

#

interface Ethernet0/0

 port link-mode route

 ip address 10.10.0.1 255.255.0.0

#

 dhcp enable

#

·     Router B:

#

 sysname RouterB

#

interface Ethernet0/1

 port link-mode route

 ip address dhcp-alloc

#

 dhcp enable

#

4  DHCP不同子网间的动态地址分配配置举例

4.1  组网需求

图2所示,Router A为DHCP服务器,DHCP客户端Router C与DHCP服务器通过Router B连接,跨越两个不同子网,要求:Router A跨越具有DHCP中继功能的Router B,向Router C动态分配IP地址及相关配置信息。

图2 MSR路由器不同子网间的动态地址分配组网图

 

4.2  配置思路

为了使DHCP服务器为DHCP客户端分配IP地址,需要在DHCP中继上创建服务器组,在与客户端相连的接口上选择中继模式和对应的服务器组,并开启地址检查功能。

4.3  使用版本

本举例是在Release 2311版本上进行配置和验证的。

4.4  配置注意事项

·     当跨网段动态分配时,需要使用DHCP中继。

·     目前DHCP Server和DHCP Relay对于接口的相关配置只能在三层以太网接口(包括子接口)、虚拟以太网接口、VLAN接口和串口上进行。其中,DHCP服务器的subaddress地址池不适于串口。

4.5  配置步骤

4.5.1  Router A的配置

# 使能DHCP服务。

<RouterA> system-view

[RouterA] dhcp enable

# 配置接口IP地址。

[RouterA] interface ethernet0/0

[RouterA-Ethernet0/0] ip address 2.1.1.1 24

[RouterA-Ethernet0/0] quit

# 配置准备给客户端PC分配动态地址的地址池。

[RouterA] dhcp server ip-pool 1

[RouterA-dhcp-pool-1] network 10.10.0.0 16

[RouterA-dhcp-pool-1] expired day 2 hour 12 minute 30

[RouterA-dhcp-pool-1] gateway-list 10.10.0.10

[RouterA-dhcp-pool-1] dns-list 10.10.0.20

[RouterA-dhcp-pool-1] nbns-list 10.10.1.1 10.10.2.2 10.10.3.3 10.10.4.4

[RouterA-dhcp-pool-1] domain-name mydomain.com

[RouterA-dhcp-pool-1] quit

# 配置能够到达DHCP中继和DHCP客户端网段的静态路由。

[RouterA] ip route-static 10.10.0.0 16 2.1.1.2

4.5.2  Router B的配置

# 使能DHCP服务。

<RouterB> system-view

[RouterB] dhcp enable

# 配置服务器组。

[RouterA] dhcp relay server-group 1 ip 2.1.1.1

# 配置接口地址,并在与客户端相连的接口上选择中继模式和对应的服务器组。

[RouterB] interface ethernet 0/1

[RouterB-Ethernet0/1] ip address 2.1.1.2 24

[RouterB-Ethernet0/1] quit

[RouterB] interface ethernet 0/0

[RouterB-Ethernet0/0] ip address 10.10.0.1 16

[RouterB-Ethernet0/0] dhcp select relay

[RouterB-Ethernet0/0] dhcp relay server-select 1

# 在与客户端连接的接口上开启DHCP中继地址匹配检查功能。

[RouterB-Ethernet0/0] dhcp relay address-check enable

[RouterB-Ethernet0/0] quit

4.5.3  Router C的配置

# 配置Router C的接口Ethernet0/1以DHCP方式动态获取地址。

<RouterC> system-view

[RouterC] interface ethernet 0/1

[RouterC-Ethernet0/1] ip address dhcp-alloc

[RouterC-Ethernet0/1] quit

4.6  验证结果

# 在网络可通的情况下,可以查看到Router A已经为Router C分配了地址池10.10.0.0/16网段的一个地址:

<RouterA> display dhcp server ip-in-use all

Pool utilization: 0.00%

 IP address       Client-identifier/    Lease expiration          Type

                  Hardware address

 10.10.0.2        3030-3066-2e65-3230-  Sep 29 2011 15:25:35      Auto:COMMITTED

                  302e-3030-3033-2d45-

                  7468-6572-6e65-7430-

                  2f31

 

 --- total 1 entry ---

# DHCP中继Router B上可以通过命令display dhcp relay security查看到已经建立客户端Router C关于IP地址和MAC的动态安全表项:

<RouterB> display dhcp relay security

 IP Address      MAC Address       Type

 10.10.0.3       000f-e200-0003    Dynamic

---   1 dhcp-security item(s) found   ---

# 在客户端Router C上可以通过命令display dhcp client verbose interface ethernet0/1查看到从DHCP服务器获取的地址等信息:

<RouterC> display dhcp client verbose interface ethernet0/1

Ethernet0/1 DHCP client information:

 Current machine state: BOUND

 Allocated IP: 10.10.0.2 255.255.0.0

 Allocated lease: 86400 seconds, T1: 43200 seconds, T2: 75600 seconds

 Lease from 2011.09.28 15:19:35   to   2011.09.29 15:19:35

 DHCP server: 2.1.1.1

 Transaction ID: 0xc01eda0d

 Default router: 10.10.0.10

 DNS server: 10.10.0.20

 Domain name: mydomain.com

 Client ID: 3030-3066-2e65-3230-

            302e-3030-3033-2d45-

            7468-6572-6e65-7430-

            2f31

 T1 will timeout in 0 day 11 hours 51 minutes 53 seconds.

4.7  配置文件

·     Router A:

#

 sysname RouterA

#

dhcp server ip-pool 1

 network 10.10.0.0 mask 255.255.0.0

 gateway-list 10.10.0.10

 dns-list 10.10.0.20

 domain-name mydomain.com

 nbns-list 10.10.1.1 10.10.2.2 10.10.3.3 10.10.4.4

#

interface Ethernet0/0

 port link-mode route

 ip address 2.1.1.1 255.255.255.0

#

 ip route-static 10.10.0.0 255.255.0.0 2.1.1.2

#

 dhcp enable

#

·     Router B:

#

 sysname RouterB

#

dhcp relay server-group 1 ip 2.1.1.1

#

interface Ethernet0/0

 port link-mode route

 ip address 10.10.0.1 255.255.0.0

 dhcp select relay

 dhcp relay server-select 1

#

interface Ethernet0/1

 port link-mode route

 ip address 2.1.1.2 255.255.255.0

#

·     Router C:

#

 sysname RouterC

#

interface Ethernet0/1

 port link-mode route

 ip address dhcp-alloc

#

 dhcp enable

#

5  相关资料

·     H3C MSR 系列路由器 命令参考(V5)-R2311

·     H3C MSR 系列路由器 配置指导(V5)-R2311

不同款型规格的资料略有差异, 详细信息请向具体销售和400咨询。H3C保留在没有任何通知或提示的情况下对资料内容进行修改的权利!