国家 / 地区

H3C MSR系列路由器典型配置举例(V5)-6W100

03-MSR系列路由器6to4中继和NAT-PT共同使用配置举例

本章节下载  (152.17 KB)

docurl=/cn/Service/Document_Software/Document_Center/Routers/Catalog/MSR/MSR_50/Configure/Typical_Configuration_Example/H3C_MSR_(V5)-6W100/201401/812714_30005_0.htm

03-MSR系列路由器6to4中继和NAT-PT共同使用配置举例

MSR系列路由器6to4中继和NAT-PT共用的典型配置举例

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

H3C_彩色.emf

 



1  简介

本文档介绍使用6to4中继和NAT-PT共用的典型案例。

2  配置前提

本文档不严格与具体软、硬件版本对应,如果使用过程中与产品实际情况有差异,请参考相关产品手册,或以设备实际情况为准。

本文档中的配置均是在实验室环境下进行的配置和验证,配置前设备的所有参数均采用出厂时的缺省配置。如果您已经对设备进行了配置,为了保证配置效果,请确认现有配置和以下举例中的配置不冲突。

本文档假设您已了解6to4中继和NAT-PT的特性。

3  配置举例

3.1  组网需求

图1所示,Router A为6to4中继路由器,与IPv6网络相连;Router B为6to4路由器,其IPv6侧的网络使用6to4地址。现要求:

·     在Router B上使能NAT-PT,使Router B的6to4网络能够访问IPv4网络。

·     在Router A和Router B之间配置6to4隧道,使得Router B的6to4网络与Router A的IPv6网络主机互通。

图1 MSR路由器6to4中继和NAT-PT共用组网图

 

3.2  配置思路

为了使6to4网络与IPv6网络互通,需要在6to4路由器和6to4中继路由器都配置一条指向对方隧道接口的静态路由,使得IPv6网络的报文都被转发到6to4中继路由器,再由6to4中继路由器转发到6to4网络,实现6to4网络与IPv6网络的互通。

3.3  使用版本

本举例是在Release 2311版本上进行配置和验证的。

3.4  配置注意事项

·     在与IPv6网络连接的设备上需要先使能IPv6转发功能。

·     建立6to4隧道的Tunnel口需要使用被称为“6to4”的特殊地址,该地址的形式为:2002:abcd:efgh:子网号::接口ID/64(其中abcd:efgh表示该6to4隧道对应的32位IPv4源地址)。

·     本案例只支持IPv6侧主机主动和IPv4网络通信,而不支持IPv4网络主动和IPv6侧主机通信。

·     在Router A上需配置到NAT-PT转换后的IPv4地址池中地址的路由。

3.5  配置步骤

3.5.1  Router A的配置

# 全局使能IPv6

<RouterA> system-view

[RouterA] ipv6

# 配置接口IP地址。

[RouterA] interface ethernet 0/0

[RouterA-Ethernet0/0] ip address 1.0.0.2 255.255.255.0

[RouterA-Ethernet0/0] quit

[RouterA] interface ethernet 0/1

[RouterA-Ethernet0/1] ipv6 address 2001:1:1::1/64

[RouterA-Ethernet0/1] quit

# 配置6to4隧道。

[RouterA] interface tunnel 0

[RouterA-tunnel0] ipv6 address 2002:200:1::1/64

[RouterA-tunnel0] tunnel-protocol ipv6-ipv4 6to4

[RouterA-tunnel0] source ethernet0/0

[RouterA-tunnel0] quit

# 配置到6to4网络地址,下一跳为Tunnel接口的静态路由。

[RouterA] ipv6 route-static 2002:100:1:: 64 tunnel 0

# 配置到NAT-PT转换的IPv4地址池的静态路由。

[RouterA] ip route-static 3.0.0.0 24 1.0.0.1

3.5.2  Router B的配置

# 全局使能IPv6。

<RouterB> system-view

[RouterB] ipv6

# 配置接口地址。

[RouterB] interface ethernet 0/0

[RouterB-Ethernet0/0] ip address 1.0.0.1 255.255.255.0

[RouterB-Ethernet0/0] quit

[RouterB] interface ethernet 0/1

[RouterB-Ethernet0/1] ipv6 address 2002:100:1:1::1/64

[RouterB-Ethernet0/1] quit

# 配置6to4隧道。

[RouterB] interface tunnel 0

[RouterB-tunnel0] ipv6 address 2002:100:1::1/64

[RouterB-tunnel0] tunnel-protocol ipv6-ipv4 6to4

[RouterB-tunnel0] source ethernet0/0

[RouterB-tunnel0] quit

# 配置到6to4中继的静态路由。

[RouterB] ipv6 route-static 2002:200:1:: 64 tunnel 0

# 配置到纯IPv6的缺省路由

[RouterB] ipv6 route-static :: 0 2002:200:1::1

# 配置NAT-PT地址池。

[RouterB] natpt address-group 1 3.0.0.1 3.0.0.100

# 配置NAT-PT前缀。

[RouterB] natpt prefix 3001::

# 配置IPv6侧报文的动态映射。

[RouterB] natpt v6bound dynamic prefix 3001:: address-group 1

# 在接口上启用NAT-PT功能。

[RouterB] interface ethernet 0/1

[RouterB-Ethernet0/1] natpt enable

[RouterB-Ethernet0/1] quit

[RouterB] interface ethernet 0/0

[RouterB-Ethernet0/0] natpt enable

[RouterB-Ethernet0/0] quit

3.5.3  Router C的配置

# 全局使能IPv6。

<RouterC> system-view

[RouterC] ipv6

# 配置接口IP地址。

[RouterC] interface ethernet 0/1

[RouterC-Ethernet0/1] ipv6 address 2002:201:101:1::2/64

[RouterC-Ethernet0/1] quit

# 配置到Router B的缺省路由。

[RouterC] ipv6 route-static :: 0 2002:201:101:1::1

# 配置到NAT-PT转换的IPv6地址池的静态路由。

[RouterC] ipv6 route-static 3001:: 16 2002:201:101:1::1

3.6  验证结果

Router C可以ping通Router A的IPv6侧接口地址2001:1:1::1,说明6to4中继正常工作。

<RouterC> ping ipv6 2001:1:1::1

  PING 2001:1:1::1 : 56  data bytes, press CTRL_C to break

    Reply from 2001:1:1::1

    bytes=56 Sequence=0 hop limit=62  time = 2 ms

    Reply from 2001:1:1::1

    bytes=56 Sequence=1 hop limit=62  time = 1 ms

    Reply from 2001:1:1::1

    bytes=56 Sequence=2 hop limit=62  time = 2 ms

    Reply from 2001:1:1::1

    bytes=56 Sequence=3 hop limit=62  time = 1 ms

    Reply from 2001:1:1::1

    bytes=56 Sequence=4 hop limit=62  time = 1 ms

 

  --- 2001:1:1::1 ping statistics ---

    5 packet(s) transmitted

    5 packet(s) received

    0.00% packet loss

    round-trip min/avg/max = 1/1/2 ms

 

Router C可以ping通Router A的IPv4侧接口地址1.0.0.2对应的IPv6地址3001::0100:0002,说明PC能通过NAT-PT从IPv6网络访问IPv4网络。

<RouterC> ping ipv6 3001::0100:0002

  PING 3001::1:2 : 56  data bytes, press CTRL_C to break

    Reply from 3001::1:2

    bytes=56 Sequence=0 hop limit=254  time = 1 ms

    Reply from 3001::1:2

    bytes=56 Sequence=1 hop limit=254  time = 1 ms

    Reply from 3001::1:2

    bytes=56 Sequence=2 hop limit=254  time = 1 ms

    Reply from 3001::1:2

    bytes=56 Sequence=3 hop limit=254  time = 1 ms

    Reply from 3001::1:2

    bytes=56 Sequence=4 hop limit=254  time = 1 ms

 

  --- 3001::1:2 ping statistics ---

    5 packet(s) transmitted

    5 packet(s) received

    0.00% packet loss

    round-trip min/avg/max = 1/1/1 ms

3.7  配置文件

·     Router A:

#

 sysname RouterA

#

 ipv6

#

interface Ethernet0/1

 port link-mode route

 ipv6 address 2001:1:1::1/64

#

interface Ethernet0/0

 port link-mode route

 ip address 1.0.0.2 255.255.255.0

#

interface Tunnel0

 ipv6 address 2002:200:1::1/64

 tunnel-protocol ipv6-ipv4 6to4

 source Ethernet0/0

#

 ip route-static 3.0.0.0 24 1.0.0.1

 ipv6 route-static 2002:100:1:: 64 Tunnel0

#

·     Router B:

#

 sysname RouterB

#

 ipv6

#

 natpt address-group 1 3.0.0.1 3.0.0.100

 natpt prefix 3001::

 natpt v6bound dynamic prefix 3001:: address-group 1

#

interface Ethernet0/0

 ip address 1.0.0.1 255.255.255.0

 natpt enable

#

interface Ethernet0/1

 ipv6 address 2002:100:1:1::1/64

 natpt enable

#

#

interface Tunnel0

 ipv6 address 2002:100:1::1/64

 tunnel-protocol ipv6-ipv4 6to4

 source Ethernet0/0

#

 ipv6 route-static :: 0 2002:200:1::1

 ipv6 route-static 2002:200:1:: 64 Tunnel0

#

·     Router C:

#

 sysname RouterC

#

 ipv6

#

interface Ethernet0/1

 ipv6 address 2002:201:101:1::2/64

#

 ipv6 route-static :: 0 2002:201:101:1::1

 ipv6 route-static 3001:: 16 2002:201:101:1::1

#

4  相关资料

·     H3C MSR 系列路由器 命令参考(V5)-R2311

·     H3C MSR 系列路由器 配置指导(V5)-R2311

不同款型规格的资料略有差异, 详细信息请向具体销售和400咨询。H3C保留在没有任何通知或提示的情况下对资料内容进行修改的权利!

联系我们 联系我们
联系我们
回到顶部 回到顶部