H3C S5500-SI Series Ethernet Switches Command Manual-Release 1205-(V1.03)

HomeSupportSwitchesH3C S5500 Switch SeriesReference GuidesCommand ReferencesH3C S5500-SI Series Ethernet Switches Command Manual-Release 1205-(V1.03)
04-VLAN Command
Title Size Download
04-VLAN Command 173 KB

Chapter 1  VLAN Configuration Commands

1.1  VLAN Configuration Commands

1.1.1  description

Syntax

description text

undo description

View

VLAN view/VLAN interface view

Parameter

text: A string that describes the current VLAN or VLAN interface (Space can be included), case sensitive.

l           For VLAN, this is a string of 1 to 32 characters.

l           For VLAN interface, this is a string of 1 to 80 characters.

Description

Use the description command to configure the descriptive string of the current VLAN or VLAN interface.

Use the undo description command to restore the descriptive string to the default.

By default, the descriptive string for a VLAN is the VLAN ID, for example, “VLAN 0001"; for a VLAN interface is name of the current VLAN interface, for example, “Vlan-interface1 Interface”

Example

# Assign a descriptive string “RESEARCH” for VLAN 1.

<Sysname> system-view

[Sysname] vlan 1

[Sysname-vlan1] description RESEARCH

# Assign a descriptive string “VLAN-INTERFACE-2” for VLAN-interface2

<Sysname> system-view

[Sysname] vlan 2

[Sysname-vlan2] quit

[Sysname] interface vlan-interface 2

[Sysname-Vlan-interface2] description VLAN-INTERFACE-2

1.1.2  display interface Vlan-interface

Syntax

display interface Vlan-interface [ vlan-interface-id ]

View

Any view

Parameter

vlan-interface-id: VLAN interface ID.

Description

Use the display interface Vlan-interface command to display the relevant information of a VLAN interface.

Execution of the command with the parameter included will display the information of a specified VLAN interface; otherwise, information on all created VLAN interfaces will be displayed.

Related command: interface Vlan-interface.

Example

# Display the information of VLAN-interface 2.

<Sysname> display interface vlan-interface 2

Vlan-interface2 current state: DOWN

Line protocol current state: DOWN

Description: Vlan-interface2 Interface

The Maximum Transmit Unit is 1500

Internet Address is 10.1.1.1/24 Primary

IP Packet Frame Type: PKTFMT_ETHNT_2,  Hardware Address: 00e0-fc00-5503

IPv6 Packet Frame Type: PKTFMT_ETHNT_2,  Hardware Address: 00e0-fc00-5503

Table 1-1 Description on the fields of  the display interface Vlan-interface command

Field

Description

Vlan-interface2 current state

 The physical state of a VLAN interface

Line protocol current state

The link layer protocol state of a VLAN interface

Description

The description of a VLAN interface

The Maximum Transmit Unit

The MTU of a VLAN interface

Internet Address :

IP address of the VLAN interface. “Primary” indicates the address is the primary IP address of the current interface.

IP Packet Frame Type

IPv4 outgoing frame format

Hardware Address

MAC address corresponding to a VLAN interface

IPv6 Packet Frame Type

IPv6 outgoing frame format

 

1.1.3  display vlan

Syntax

display vlan [ vlan-id1 [ to vlan-id2 ] | all | dynamic | static | reserved ]

View

Any view

Parameter

vlan-id1: Displays information of a VLAN specified by the VLAN ID, which is in the range of 1 to 4,094.

vlan-id1 to vlan-id2: Displays the information of a range of VLANs specified by a VLAN ID range. vlan-id1 and vlan-id2 are VLAN IDs in the range of 1 to 4,094, and vlan-id2 cannot be smaller than vlan-id1.

all: Displays information about all the current VLANs of the system except for the reserved VLANs.

static: Displays information about statically created VLANs.

dynamic: Displays the information of dynamically created VLANs

reserved: Displays information of reserved VLANs. Protocol modules determine reserved VLANs according to function implementation, and reserved VLANs serve protocol modules. Reserved VLANs cannot be modified.

Description

Use the display vlan command to display VLAN information.

Related command: vlan.

Example

# Display VLAN 2 information.

<Sysname> display vlan 2

 VLAN ID: 2

 VLAN Type: static

 Route interface: configured

 IP Address: 10.1.1.1

 Subnet Mask: 255.255.255.0   

 Description: VLAN 0001

 Tagged   Ports: none

 Untagged Ports: 

    GigabitEthernet1/0/2     GigabitEthernet1/0/4     GigabitEthernet1/0/5

Table 1-2 Description on the fields of the display vlan command

Field

Description

VLAN ID

VLAN ID

VLAN Type

VLAN type (static or dynamic)

Route interface

Whether the VLAN interface is configured for the VLAN: not configured or configured

IP Address

IP address of the VLAN interface (unavailable if the VLAN interface has no IP address configured)

Subnet Mask

Subnet mask of the IP address (unavailable if the VLAN interface has no IP address configured)

Tagged Ports

Ports through which packets are forwarded with tags unchanged

Untagged Ports

Port through which packets are forwarded with tags stripped

 

1.1.4  interface Vlan-interface

Syntax

interface Vlan-interface vlan-interface-id

undo interface Vlan-interface vlan-interface-id

View

System view

Parameter

vlan-interface-id: VLAN interface ID, in the range of 1 to 4,094.

Description

Use the interface Vlan-interface command to enter the specified VLAN interface view. If the specified VLAN interface does not exist, the command will first create the VLAN interface then enter its view.

Use the undo interface Vlan-interface command to delete the specified VLAN interface.

Before creating a VLAN interface, make sure the corresponding VLAN has been created; otherwise, the VLAN interface cannot be created.

Related command: display interface Vlan-interface.

Example

# Create VLAN-interface2.

<Sysname> system-view

[Sysname] vlan 2

[Sysname-vlan2] quit

[Sysname] interface vlan-interface 2

[Sysname-Vlan-interface2]

1.1.5  ip address

Syntax

ip address ip-address { mask | mask-length } [ sub ]

undo ip address [ ip-address { mask | mask-length } [ sub ] ]

View

VLAN interface view

Parameter

ip-address: IP address of a VLAN interface, in dotted decimal format.

mask: Subnet mask that corresponds to the IP address of a VLAN interface, in dotted decimal format.

mask-length: Length of a subnet mask, that is, the number of 1s of the subnet mask in binary notation.

sub: Indicates the address is a sub-IP address of the VLAN interface.

Description

Use the ip address command to specify the IP address and subnet mask for a VLAN interface.

Use the undo ip address command to remove the IP address and sub-net mask for a VLAN interface.

By default, no IP address is configured.

An interface normally has one IP address. To enable a device to connect to multiple subnets, a maximum of 5 IP addresses can be configured on a VLAN interface, in which only one is the primary IP address and all the rest are secondary IP addresses. Their relationship is illustrated as follows:

l           A newly configured main IP address will replace the original one, if there is one.

l           Execution of the undo ip address command indicates that all IP addresses will be deleted from the VLAN interface.

l           Use the undo ip address ip-address { mask | mask-length } command to delete the primary IP address.

l           Use the undo ip address ip-address { mask | mask-length } sub command to delete a specified secondary IP address.

l           Note that before deleting the primary IP address you must delete all the secondary IP addresses.

Related command: display ip interface (refer to IP Address and Performance  Command Manual).

Example

# Specify the IP address as 129.12.0.1, the sub-net mask as 255.255.255.0 for VLAN-interface 1.

<Sysname> system-view

[Sysname] interface vlan-interface 1

[Sysname-Vlan-interface1] ip address 129.12.0.1 255.255.255.0

1.1.6  shutdown

Syntax

shutdown

undo shutdown

View

VLAN interface view

Parameter

 None

Description

Use the shutdown command to shut down a VLAN interface.

Use the undo shutdown command to bring up a VLAN interface.

By default, the VLAN interface is down if all ports in the VLAN are down, as long as one port in the VLAN is up, the VLAN interface will be up

You can use the undo shutdown command to bring up a VLAN interface after configurations of the related parameter and protocol. When there is a fault in a VLAN interface, you can use the shutdown command to shut down the interface and then bring it up using the undo shutdown command. In this way, the interface may be resume.

Shutting down/bringing up a VLAN interface does not affect any Ethernet ports in the VLAN. The state of an Ethernet port does not change with the VLAN interface state.

Example

# Shut down the VLAN-interface2 and then bring it up.

<Sysname> system-view

[Sysname] interface vlan-interface 2

[Sysname-Vlan-interface2] shutdown

[Sysname-Vlan-interface2] undo shutdown

1.1.7  vlan

Syntax

vlan { vlan-id1 [ to vlan-id2 ] | all }

undo vlan { vlan-id1 [ to vlan-id2 ] | all }

View

System view

Parameter

vlan vlan-id1: Creates or deletes a specified VLAN or enter specified VLAN view. vlan-id1 is VLAN ID, in the range of 1 to 4,094.

vlan-id1 to vlan-id2: Creates or deletes a specified range of VLANs. vlan-id1 and vlan-id2 are VLAN IDs in the range of 1 to 4,094, and vlan-id2 cannot be smaller than vlan-id1.

all: Creates or deletes all VLANs.

Description

Use the vlan command to create VLAN(s).

Use the vlan vlan-id command to enter VLAN view. If the specified VLAN does not exist, the command will first create the VLAN then enter its view.

Use the vlan vlan-id1 to vlan-id2 command to create a range of VLANs from vlan-id1 to vlan-id2 in a bulk, except for the reserved VLANs.

Use the undo vlan command to delete specified VLAN(s).

 

&  Note:

l      As the default VLAN, VLAN 1 cannot be created, or removed.

l      You cannot create/remove reserved VLANs that are reserved for specific function implementation.

l      A VLAN configured with QoS policies cannot be removed.

 

Related command: display vlan.

Example

# Enter VLAN 1 view.

<Sysname> system-view

[Sysname] vlan 1

[Sysname-vlan1]

# Create VLAN 4 through VLAN 100.

<Sysname> system-view

[Sysname] vlan 4 to 100

Please wait............. Done.

1.2  Port-Based VLAN Configuration Commands

1.2.1  port

Syntax

port interface-list

undo port interface-list

View

VLAN view

Parameter

interface-list: Ethernet interface list to be added to or removed from the VLAN, provided in the format of interface-list = { interface-type interface-number [ to interface-type interface-number ] }&<1-10>, where interface-type interface-number is the port type and port number; &<1-10> indicates that you can specify up to 10 ports or port ranges.

Description

Use the port command to add one Access port or a group of Access ports to a VLAN. Use the undo port command to remove one Access port or a group of Access ports from a VLAN.

Note:

l           This command is only applicable to Access ports.

l           All ports have their default link type configured as Access, however, users can manually configure the port type. For more information, refer to port link-type.

Related command: display vlan.

Example

# Add the ports from GigabitEthernet 1/0/1 to GigabitEthernet 1/0/3 to VLAN 2.

<Sysname> system-view

[Sysname] vlan 2

[Sysname-vlan2] port GigabitEthernet 1/0/1 to GigabitEthernet 1/0/3

1.2.2  port access vlan

Syntax

port access vlan vlan-id

undo port access vlan

View

Ethernet port view/port group view

Parameter

vlan-id: VLAN ID, in the range of 1 to 4,094.

Description

Use the port access vlan command to add the current Access port to a specified VLAN.

Use the undo port access vlan command to add the current Access port to the default VLAN.

After executing the undo vlan command on an Access port to remove the default VLAN, VLAN 1 will become the default VLAN.

Execution of the above command under Ethernet port view will apply the configurations to the current port only whereas under port group view will apply the configurations to all ports in the port group. (For related configurations on port group, refer to the Port Correlation Configuration part of the manual).

Ensure the VLAN specified by the vlan-id parameter exists before issuing the above commands.

Example

# Add port GigabitEthernet 1/0/2 to VLAN 3.

<Sysname> system-view

[Sysname] vlan 3

[Sysname-vlan3] quit

[Sysname] interface GigabitEthernet 1/0/2

[Sysname-GigabitEthernet 1/0/2] port access vlan 3

1.2.3  port hybrid pvid vlan

Syntax

port hybrid pvid vlan vlan-id

undo port hybrid pvid

View

Ethernet port view/port group view

Parameter

vlan-id: VLAN ID, in the range of 1 to 4,094.

Description

Use the port hybrid pvid vlan command to configure the default VLAN ID of the Hybrid port.

Use the undo port hybrid pvid command to restore the default, VLAN 1.

Execution of the undo vlan command on a Hybrid port to remove the default VLAN does not affect the default VLAN configuration. That is to say, the non-existent VLAN can still be the default VLAN.

Execution of the above commands under Ethernet port view will apply to the current port only whereas under port group view will apply to all ports in the port group. (For related configurations on port group, refer to Port Correlation Configuration part of the manual)

Related command: port link-type.

Example

# Configure the default VLAN ID for the Hybrid port GigabitEthernet1/0/4 to be 100.

<Sysname> system-view

[Sysname] vlan 100

[Sysname-vlan100] quit

[Sysname] interface GigabitEthernet 1/0/4

[Sysname-GigabitEthernet1/0/4] port link-type hybrid

[Sysname-GigabitEthernet1/0/4] port hybrid pvid vlan 100

1.2.4  port hybrid vlan

Syntax

port hybrid vlan vlan-id-list { tagged | untagged }

undo port hybrid vlan vlan-id-list

View

Ethernet port view/port group view

Parameter

vlan-id-list: The range of VLANs that the Hybrid ports will be added to, vlan-id-list = [ vlan-id1 [ to vlan-id2 ] ]&<1-10>, where vlan-id1 and vlan-id2 range from 1 to 4,094, and vlan-id2 cannot be smaller than vlan-id1. &<1-10> indicates that you can specify up to 10 VLANs or 10 VLAN ranges.

tagged: Specifies to tag the packets of the specified VLAN (s).

untagged: Specifies not to tag the specified VLAN(s).

Description

Use the port hybrid vlan command to add the current Hybrid port to the specified VLAN(s).

Use the undo port hybrid vlan command to remove the current Hybrid port from the specified VLAN(s).

The Hybrid port can allow multiple VLANs. If you execute the port hybrid vlan command for multiple times, the VLANs allowed on the Hybrid port will be the set of VLANs specified by vlan-id-list for these times.

Execution of the above commands in Ethernet port view will apply to the current port only whereas under port group view will apply to all ports in the port group. (For related configurations on port group, refer to the Port Correlation Configuration part of the manual).

Related command: port link-type.

Example

# Add the Hybrid port GigabitEthernet1/0/4 to VLAN 2, VLAN 4, and the range of VLANs from VLAN 50 to VLAN 100 (these VLANs all exist). Configure to keep the VLAN tags of all packets of these VLANs when the packets are sent from GigabitEthernet1/0/4.

<Sysname> system-view

[Sysname] interface GigabitEthernet 1/0/4

[Sysname-GigabitEthernet1/0/4] port link-type hybrid

[Sysname-GigabitEthernet1/0/4] port hybrid vlan 2 4 50 to 100 tagged

Please wait... Done.

# Add Hybrid ports of port group 2 to VLAN 2. Packets are untagged.

<Sysname> system-view

[Sysname] vlan 2

[Sysname-vlan2] quit

[Sysname] port-group manual 2

[Sysname-port-group-manual-2] group-member GigabitEthernet 1/0/1 to e GigabitEthernet 1/0/6

[Sysname-port-group-manual-2] port link-type hybrid

[Sysname-port-group-manual-2] port hybrid vlan 2 untagged

 Configuring GigabitEthernet 1/0/1... Done.

 Configuring GigabitEthernet 1/0/2... Done.

 Configuring GigabitEthernet 1/0/3... Done.

 Configuring GigabitEthernet 1/0/4... Done.

 Configuring GigabitEthernet 1/0/5... Done.

 Configuring GigabitEthernet 1/0/6... Done.

1.2.5  port link-type

Syntax

port link-type { access | hybrid | trunk }

undo port link-type

View

Ethernet port view/port group view

Parameter

access: Configures the link type of a port as Access.

hybrid: Configures the link type of a port as Hybrid.

trunk: Configures the link type of a port as Trunk.

Description

Use the port link-type command to configure the link type of a port.

Use the undo port link-type command to restore the default link type of a port.

By default, the link type of a port is Access.

Execution of the above commands in Ethernet port view  will apply to the current port only whereas under port group view will apply to all ports in the port group (for port group information, refer to the Port Correlation Configuration part of the manual).

 

&  Note:

 

Example

# Configure GigabitEthernet1/0/1 to be a Trunk port.

<Sysname> system-view

[Sysname] interface GigabitEthernet 1/0/1

[Sysname-GigabitEthernet 1/0/1] port link-type trunk

1.2.6  port trunk permit vlan

Syntax

port trunk permit vlan { vlan-id-list | all }

undo port trunk permit vlan { vlan-id-list | all }

View

Ethernet port view/port group view

Parameter

vlan-id-list: The range of VLANs that the Trunk ports will be added to, in the format of vlan-id-list = [ vlan-id1 [ to vlan-id2 ] ]&<1-10>, where vlan-id1 and vlan-id2  range from 1 to 4,094 and vlan-id2 cannot be smaller than vlan-id1. &<1-10> indicates that you can specify up to 10 VLANs or VLAN ranges.

all: Adds the Trunk port to all VLANs.

Description

Use the port trunk permit vlan command to add a Trunk port to a specified VLAN, a selection of VLANs, or all VLANs.

Use the undo port trunk permit vlan command to remove the Trunk port from a specified VLAN, a selection of VLANs, or all VLANs.

The Trunk port can allow multiple VLANs. If you execute the port trunk permit vlan command for multiple times, the VLANs allowed on the Trunk port will be the set of VLANs specified by vlan-id-list for these times.

Execution of the above commands in Ethernet port view will apply to the current port only whereas under port group view will apply to all ports in the port group. (For related configurations on port group, refer to Port Correlation Configuration Part of the manual)

Related command: port link-type.

Example

# Add the Trunk port GigabitEthernet1/0/4 to VLAN 2, VLAN 4, and the range of VLANs from VLAN 50 to VLAN 100 (these VLANs all exist).

<Sysname> system-view

[Sysname] interface GigabitEthernet1/0/4

[Sysname-GigabitEthernet1/0/4] port link-type trunk

[Sysname-GigabitEthernet1/0/4] port trunk permit vlan 2 4 50 to 100

Please wait........... Done.

1.2.7  port trunk pvid vlan

Syntax

port trunk pvid vlan vlan-id

undo port trunk pvid

View

Ethernet port view/port group view

Parameter

vlan-id: VLAN ID, in the range of 1 to 4,094

Description

Use the port trunk pvid vlan command to configure the default VLAN ID for the Trunk port.

Use the undo port trunk pvid command to restore the default.

By default, the default VLAN on a Trunk port is VLAN 1.

Execution of the undo vlan command on a Trunk port to remove a default VLAN does not affect the default VLAN configurations. That is to say, a non-existent VLAN can still be the default VLAN.

Execution of the above commands in Ethernet port view will apply to the current port only whereas under port group view will apply to all ports in the port group. (For related configurations on port group, refer to the Port Correlation Configuration part of the manual ).

You must configure the same default VLAN ID for the Trunk port of both the local device and remote device. Otherwise, the packets of the default VLAN cannot be transmitted correctly from the local end to the peer end.

Related command: port link-type.

Example

# Configure the link type of GigabitEthernet1/0/4 as Trunk, and the default VLAN of GigabitEthernet1/0/4 as VLAN 100.

<Sysname> system-view

[Sysname] interface GigabitEthernet1/0/4

[Sysname-GigabitEthernet1/0/4] port link-type trunk

[Sysname-GigabitEthernet1/0/4] port trunk pvid vlan 100

 


Chapter 2  Voice VLAN Configuration Commands

2.1  Voice VLAN Configuration Commands

2.1.1  display voice vlan oui

Syntax

display voice vlan oui

View

Any view

Parameter

None

Description

Use the display voice vlan oui command to display the Organizationally Unique Identifier (OUI) address(es), the OUI address mask, and the descriptive string currently supported by system.

Related command: voice vlan, voice vlan enable.

 

&  Note:

As the first 24 bits of a MAC address (in binary format), an OUI address is a globally unique identifier assigned to a vendor by IEEE.

 

Example

# Display the OUI address of a voice VLAN.

<Sysname> display voice vlan oui

Oui Address     Mask            Description

0001-e300-0000  ffff-ff00-0000  Siemens phone

0003-6b00-0000  ffff-ff00-0000  Cisco phone

00d0-1e00-0000  ffff-ff00-0000  Pingtel phone

00e0-7500-0000  ffff-ff00-0000  Polycom phone

00e0-bb00-0000  ffff-ff00-0000  3com phone

Table 2-1 Description on the fields of the display voice vlan oui command

Field

Description

Oui Address

OUI addresses that are allowed to pass

Mask

Mask of the OUI addresses that are allowed to pass

Description

Description of the OUI addresses that are allowed to pass

 

2.1.2  display voice vlan state

Syntax

display voice vlan state

View

Any view

Parameter

None

Description

Use the display voice vlan state command to display the voice VLAN configuration.

Related command: voice vlan, voice vlan enable.

Example

# Display the voice VLAN configurations.

<Sysname> display voice vlan state

 Voice VLAN status: ENABLE

 Voice VLAN ID: 2

 Voice VLAN security mode: Security

 Voice VLAN aging time: 1440 minutes

 Voice VLAN enabled port and its mode:

 PORT               MODE

 -------------------------------

 GigabitEthernet1/0/2    MANUAL

 GigabitEthernet1/0/3    MANUAL

 GigabitEthernet1/0/4    MANUAL

 GigabitEthernet1/0/5    AUTO

Table 2-2 Description on the fields of  the display voice vlan state command

Field

Description

Voice VLAN status

The current voice VLAN status, that is, whether it is enabled or disabled.

Voice VLAN ID

ID of a voice VLAN

Voice VLAN security mode

Security mode of a voice VLAN

Voice VLAN aging time

Aging time of a voice VLAN

Current voice vlan enabled port and its mode

The port that is currently enabled with the voice VLAN function and its working mode

PORT

port ID

MODE

Voice VLAN working mode: manual or automatic.

 

2.1.3  voice vlan

Syntax

voice vlan vlan-id enable

undo voice vlan enable

View

System view

Parameter

vlan-id: ID of the VLAN to be enabled with the voice VLAN function, in the range of 2 to 4,094.

Description

Use the voice vlan command to enable the voice VLAN function globally.

Use the undo voice vlan enable command to disable the voice VLAN function globally.

l           At one particular moment, only one VLAN of a certain device can have the voice VLAN function enabled.

l           Ensure that a VLAN exists before enabling its voice VLAN function and that it is not VLAN 1. Otherwise, the configurations will fail.

l           If a VLAN to be deleted has the voice VLAN function enabled, you need to disable the voice VLAN function first before deleting the VLAN.

By default, the voice VLAN function is not enabled globally.

Related command: display voice vlan state.

Example

# Enable the voice VLAN function on VLAN 2 (assuming that VLAN 2 already exists).

<Sysname> system-view

[Sysname] voice vlan 2 enable

2.1.4  voice vlan aging

Syntax

voice vlan aging minutes

undo voice vlan aging

View

System view

Parameter

minutes: Aging time of a voice VLAN, in the range 5 to 43,200 minutes. This value is 1,440 by default.

Description

Use the voice vlan aging command to configure the aging time of a voice VLAN.

Use the undo voice vlan aging command to restore the aging time of a voice VLAN.

By default, the aging time of a voice VLAN is 1,440 minutes.

Under automatic mode, the system will decide whether to add a port to a voice VLAN based on the source MAC address contained in its inbound voice packets. After adding a port to the voice VLAN, the system will start the aging timer at the same time. If no voice packet is received from the port within the aging time, the port is removed from the voice VLAN.

Related command: display voice vlan state.

Example

# Configure the aging time of the voice VLAN as 100 minutes.

<Sysname> system-view

[Sysname] voice vlan aging 100

2.1.5  voice vlan enable

Syntax

voice vlan enable

undo voice vlan enable

View

Ethernet port view

Parameter

None

Description

Use the voice vlan enable command to enable the voice VLAN function on an Ethernet port.

Use the undo voice vlan enable command to disable the voice VLAN function on an Ethernet port.

Voice VLAN function is not enabled on a port by default.

l           Under automatic mode, only Trunk or Hybrid port can be configured with the voice VLAN function, and an Access port cannot be configured with this function.

l           Before enabling the voice VLAN function on a port, ensure that its is enabled globally first

l           Only after the voice VLAN function is enabled under both system view and Ethernet port view will it function properly.

Example

# Enable the voice VLAN function on port GigabitEthernet1/0/2.

<Sysname> system-view

[Sysname] interface GigabitEthernet 1/0/2

[Sysname-GigabitEthernet1/0/2] voice vlan enable

2.1.6  voice vlan mac-address

Syntax

voice vlan mac-address oui mask oui-mask [ description text ]

undo voice vlan mac-address oui

View

System view

Parameter

oui: Source MAC address of voice packets, in the format of H-H-H, such as 1234-1234-1234. The OUI address cannot be a broadcast or multicast address, or an all 0s or fs address either.

oui-mask: Valid length of the OUI address, represented in mask, in the format of H-H-H, from left to right are consecutive fs and 0s, for example, ffff-f000-0000.

text: A case sensitive string that describes the OUI address, in the range of 1 to 30 characters.

Description

Use the voice vlan mac-address command to make a specified OUI address identified by the voice VLAN.

Use the undo voice vlan mac-address command to remove an OUI address from being identified by the voice VLAN.

A maximum of 16 OUI addresses can be supported by the system.

By default, there are 5 default OUI addresses, which can be removed or then added, as illustrated in.Table 2-3.

Table 2-3 Default OUI addresses

Number

OUI

Vendor

1

0001-e300-0000

Siemens phone

2

0003-6b00-0000

Cisco phone

3

00d0-1e00-0000

Pingtel phone

4

00e0-7500-0000

Polycom phone

5

00e0-bb00-0000

3com phone

 

Related command: display voice vlan oui.

Example

# Make the OUI address 00AA-BB00-0000 with the mask being ffff-ff00-0000 and the descriptive string being ABC be identified by the voice VLAN.

<Sysname> system-view

[Sysname] voice vlan mac-address 00aa-bb00-0000 mask ffff-ff00-0000 description ABC

# Display OUI address information.

[Sysname] display voice vlan oui

Oui Address     Mask            Description

0001-e300-0000  ffff-ff00-0000  Siemens phone

0003-6b00-0000  ffff-ff00-0000  Cisco phone

00aa-bb00-0000  ffff-ff00-0000  ABC

00d0-1e00-0000  ffff-ff00-0000  Pingtel phone

00e0-7500-0000  ffff-ff00-0000  Polycom phone

00e0-bb00-0000  ffff-ff00-0000  3com phone   

2.1.7  voice vlan mode auto

Syntax

voice vlan mode auto

undo voice vlan mode auto

View

Ethernet port view

Parameter

None

Description

Use the voice vlan mode auto command to configure the voice VLAN working mode on a port to be automatic.

Use the undo voice vlan mode auto command to configure the voice VLAN working mode on a port to be manual.

By default, the voice VLAN working mode is automatic.

Example

 # Configure the voice VLAN working mode on GigabitEthernet1/0/1 to be manual.

<Sysname> system-view

[Sysname] interface GigabitEthernet 1/0/1

[Sysname-GigabitEthernet1/0/1] undo voice vlan mode auto

2.1.8  voice vlan security enable

Syntax

voice vlan security enable

undo voice vlan security enable

View

System view

Parameter

None

Description

Use the voice vlan security enable command to enable the security mode for voice VLAN.

Use the undo voice vlan security enable command to disable the security mode for  voice VLAN.

By default, the security mode of voice VLAN is enabled.

With the security mode enabled, voice packets with source MAC addresses not listed in the OUI address list will be filtered out on the incoming port. However, this feature does not affect other VLANs.

Example

# Disable the security mode of the voice VLAN.

<Sysname> system-view

[Sysname] undo voice vlan security enable

 


Chapter 3  GARP/GVRP Configuration Commands

3.1  GARP Configuration Commands

3.1.1  display garp statistics

Syntax

display garp statistics [ interface interface-list ]

View

Any view

Parameter

interface-list: Ethernet port list, in the format of { interface-type interface-number [ to interface-type interface-number ] }&<1-10>, where interface-type is the port type and interface-number is the port number; &<1-10> indicates that you can specify 1 to 10 ports or port ranges. .

Description

Use the display garp statistics command to display statistics about GARP for specified or all ports.

Example

# Display statistics about GARP for port GigabitEthernet1/0/1.

<Sysname> display garp statistics interface GigabitEthernet1/0/1

 

        GARP statistics on port GigabitEthernet1/0/1

 

        Number of GVRP Frames Received          : 0

        Number of GVRP Frames Transmitted       : 0

        Number of Frames Discarded              : 0

3.1.2  display garp timer

Syntax

display garp timer [ interface interface-list ]

View

Any view

Parameter

interface-list: Ethernet port list, in the format of { interface-type interface-number [ to interface-type interface-number ] }&<1-10>, where interface-type is the port type and interface-number is the port number; &<1-10> indicates that you can specify 1 to 10 ports or port ranges.

Description

Use the display garp timer command to display GARP timers.

Related command: garp timer, garp timer leaveall.

Example

# Display GARP timers on port GigabitEthernet1/0/1.

<Sysname> display garp timer interface GigabitEthernet1/0/1

 

        GARP timers on port GigabitEthernet1/0/1

 

                Garp Join Time          : 20 centiseconds

                Garp Leave Time         : 60 centiseconds

                Garp LeaveAll Time      : 1000 centiseconds

                Garp Hold Time          : 10 centiseconds

3.1.3  garp timer

Syntax

garp timer { hold | join | leave } timer-value

undo garp timer { hold | join | leave }

View

Ethernet port view, port group view

Parameter

hold: Sets the hold timer. When a GARP application entity receives the first registration request, it starts a hold timer and collects succeeding requests. When the timer expires, the entity sends all these requests in one Join message, thus saving bandwidth.

join: Sets the join timer. Each GARP application entity can send a Join message twice for reliability sake and uses a join timer to set the sending interval.

leave: Sets the leave timer. This timer starts upon receipt of a Leave message sent for deregistering some attribute information. If no Join message is received before this timer expires, the GARP application entity removes the attribute information as requested.

timer-value: Timer value in centiseconds. Set it in steps of five.

Description

Use the garp timer command to set a GARP timer for an Ethernet port or all ports in a port group in compliance with the timer setting dependencies shown in Table 3-1.

Use the undo garp timer command to restore the default of a GARP timer. This may fail if the default does not satisfy the dependencies shown in Table 3-1.

The default is 10 centiseconds for the hold timer, 20 centiseconds for the join timer, and 60 centiseconds for the leave timer.

Configured in Ethernet port view, the setting is effective on the current port only; configured in port group view, the setting is effective on all ports in the port group.

Note that:

l           When restoring the default GARP timers, you are recommended to do that on the timers in the order of hold, join, leave, and leaveall.

l           When configuring GARP timers, note that their values are dependent on each other and must be a multiplier of five centiseconds. If the value range for a timer is not desired, you may change it by tuning the value of another timer as shown in the following table:

Table 3-1 Dependencies of GARP timers

Timer

Lower limit

Upper limit

Hold

10 centiseconds

Not greater than half of the join timer setting

Join

Not less than two times the hold timer setting

Less than half of the leave timer setting

Leave

Greater than two times the join timer setting

Less than the leaveall timer setting

Leaveall

Greater than the leave timer setting

32765 centiseconds

 

Related command: display garp timer.

Example

# Set the GARP join timer of port GigabitEthernet1/0/1 to 25 centiseconds, assuming that both the hold timer and the leave timer are using the default.

<Sysname> system-view

[Sysname] interface GigabitEthernet 1/0/1

[Sysname-GigabitEthernet1/0/1] garp timer join 25

3.1.4  garp timer leaveall

Syntax

garp timer leaveall timer-value

undo garp timer leaveall

View

System view

Parameter

timer-value: Leaveall timer value in the range 65 to 32765 centiseconds in steps of 5. This value must be greater than the leave timer values of all ports.

Description

Use the garp timer leaveall command to set the leaveall timer of GARP.

Use the undo garp timer leaveall command to restore the default. This may fail if the default is less than the setting of the current leave timer.

The default leaveall timer is 1000 centiseconds, that is, 10 seconds.

A leaveall timer starts upon the start of a GARP application entity. When this timer expires, the entity sends a LeaveAll message so that other entities can re-register its attribute information and starts another leaveall timer at the same time.

Each time a device on the network receives a LeaveAll message, it resets its leaveall timer. Therefore, a GARP application entity may send LeaveAll messages at the interval set by its leaveall timer or the leaveall timer on another device on the network, whichever is smaller.

Related command: display garp timer.

Example

# Set the leaveall timer to 100 centiseconds, assuming that the leave timer is 60 centiseconds.

<Sysname> system-view

[Sysname] garp timer leaveall 100

3.1.5  reset garp statistics

Syntax

reset garp statistics [ interface interface-list ]

View

User view

Parameter

interface-list: Ethernet port list, in the format of { interface-type interface-number [ to interface-type interface-number ] }&<1-10>, where interface-type is the port type and interface-number is the port number; &<1-10> indicates that you can specify 1 to 10 ports or port ranges.

Description

Use the reset garp statistics command to clear statistics about GARP on the specified or all ports.

Related command: display gvrp statistics.

Example

# Clear statistics about GARP on all ports.

<Sysname> reset garp statistics

3.2  GVRP Configuration Commands

3.2.1  display gvrp statistics

Syntax

display gvrp statistics [ interface interface-list ]

View

Any view

Parameter

interface-list: Ethernet port list, in the format of { interface-type interface-number [ to interface-type interface-number ] }&<1-10>, where interface-type is the port type and interface-number is the port number; &<1-10> indicates that you can specify 1 to 10 ports or port ranges.

Description

Use the display gvrp statistics command to display statistics about GVRP for specified or all trunk ports.

Note that if the interface interface-list is not provided, the GVRP statistics of all trunk ports will be displayed. Otherwise, only the GVRP statistics of the specified trunk port will be displayed.

Example

# Display statistics about GVRP for trunk port GigabitEthernet1/0/1.

<Sysname> display gvrp statistics interface GigabitEthernet1/0/1

 

        GVRP statistics on port GigabitEthernet1/0/1

 

                GVRP Status                     : Enabled

                GVRP Running                    : YES

                GVRP Failed Registrations       : 0

                GVRP Last Pdu Origin            : 0000-0000-0000

                GVRP Registration Type          : Normal

Table 3-2 Description on the fields of the display gvrp statistics command

Field

Description

GVRP Status

Indicates whether GVRP is enabled or disabled.

GVRP Running

Indicates whether GVRP is running.

GVRP Failed Registrations

Indicates the number of GVRP registration failures.

GVRP Last Pdu Origin

Indicates the source MAC address in the last GVRP PDU.

GVRP Registration Type

Indicates the GVRP registration type on the port.

 

3.2.2  display gvrp status

Syntax

display gvrp status

View

Any view

Parameter

None

Description

Use the display gvrp status command to display the global enable/disable state of GVRP.

Example

# Display the global GVRP enable/disable state.

<Sysname> display gvrp status

GVRP is enabled

The above output information indicates that GVRP is enabled globally.

3.2.3  gvrp

Syntax

gvrp

undo gvrp

View

System view, Ethernet port view, port group view

Parameter

None

Description

Use the gvrp command to enable GVRP globally, on a port, or on all ports in a port group depending on the view you entered.

Use the undo gvrp command to disable GVRP globally, on a port, or on all ports in a port group depending on the view you entered.

By default, GVRP is disabled.

Configured in system view, the setting is effective for the device globally; configured in Ethernet port view, the setting is effective on the current port only; configured in port group view, the setting is effective on all ports in the port group.

Note that:

l           You need enable GVRP globally before you can enable GVRP on a port.

l           If GVRP is disabled globally, it is disabled on ports too, and you cannot change the GVRP state on ports.

l           You can only enable/disable GVRP on a trunk port.

l           BPDU TUNNEL is incompatible with GVRP. Therefore, you cannot apply the two functions simultaneously on an Ethernet port. Before enabling GVRP on a port, disable the BPDU TUNNEL function (if the BPDU TUNNEL function is enabled on the port).

Related command: display gvrp status.

Example

# Enable GVRP globally.

<Sysname> system-view

[Sysname] gvrp

GVRP is enabled globally.

3.2.4  gvrp registration

Syntax

gvrp registration { fixed | forbidden | normal }

undo gvrp registration

View

Ethernet port view, port group view

Parameter

fixed: Sets the registration type to fixed.

forbidden: Sets the registration type to forbidden.

normal: Sets the registration type to normal.

Description

Use the gvrp registration command to configure the GVRP registration type on a port or all ports in a port group.

Use the undo gvrp registration command to restore the default.

The default GVRP registration type is normal.

Configured in Ethernet port view, the setting is effective on the current port only; configured in port group view, the setting is effective on all ports in the port group.

GVRP provides the following three registration types on a port:

l           Normal –– Enables the port to dynamically register/deregister VLANs, and to propagate both dynamic and static VLAN information.

l           Fixed –– Disables the port to dynamically register VLANs or propagate information about dynamic VLANs, but allows the port to propagate information about static VLANs. A trunk port with fixed registration type thus allows only manually configured VLANs to pass through even though it is configured to carry all VLANs.

l           Forbidden –– Disables the port to dynamically register VLANs, and to propagate VLAN information except information about VLAN 1. A trunk port with forbidden registration type thus allows only the default VLAN (VLAN 1) to pass through even though it is configured to carry all VLANs.

Note that this command is only available on trunk ports.

Related command: display garp statistics.

Example

# Set the GVRP registration type to fixed on port GigabitEthernet1/0/1.

<Sysname> system-view

[Sysname] interface GigabitEthernet 1/0/1

[Sysname-GigabitEthernet1/0/1] port link-type trunk

[Sysname-GigabitEthernet1/0/1] port trunk permit vlan all

[Sysname-GigabitEthernet1/0/1] gvrp registration fixed

 

  • Cloud & AI
  • InterConnect
  • Intelligent Computing
  • Security
  • SMB Products
  • Intelligent Terminal Products
  • Product Support Services
  • Technical Service Solutions
All Services
  • Resource Center
  • Policy
  • Online Help
All Support
  • Become a Partner
  • Partner Resources
  • Partner Business Management
All Partners
  • Profile
  • News & Events
  • Online Exhibition Center
  • Contact Us
All About Us
新华三官网