05-Comware 9 CLI-based configuration examples (AC+fit AP deployment)

HomeSupportDoc SetsDoc PackagesH3C Wireless Products All-in-One-6W10105-Comware 9 CLI-based configuration examples (AC+fit AP deployment)
Table of Contents
Related Documents
72-WLAN Probe Configuration Examples
Title Size Download
72-WLAN Probe Configuration Examples 463.15 KB

 

H3C Access Controllers

WLAN Probe Configuration Examples

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Copyright © 2023 New H3C Technologies Co., Ltd. All rights reserved.

No part of this manual may be reproduced or transmitted in any form or by any means without prior written consent of New H3C Technologies Co., Ltd.

Except for the trademarks of New H3C Technologies Co., Ltd., any trademarks that may be mentioned in this document are the property of their respective owners.

The information in this document is subject to change without notice.



Introduction

The following information provides examples for configuring WLAN probe.

Prerequisites

The following information applies to Comware-based access controllers and access points. Procedures and information in the examples might be slightly different depending on the software or hardware version of the access controllers and access points.

The configuration examples were created and verified in a lab environment, and all the devices were started with the factory default configuration. When you are working on a live network, make sure you understand the potential impact of every command on your network.

The following information is provided based on the assumption that you have basic knowledge of WIPS.

Example: Configuring WLAN probe

Network configuration

As shown in Figure 1, AP 1 and AP 2 provide wireless services for clients through SSID service.

Enable WLAN probe on the sensor, and configure the sensor to report the received wireless device information to the AC.

Figure 1 Network diagram

 

Procedures

Configuring the AC

1.     Configure interfaces on the AC:

# Configure VLAN-interface 100 and assign it an IP address. The AC will use this IP address to establish CAPWAP tunnels with APs.

<AC> system-view

[AC] vlan 100

[AC-vlan100] quit

[AC] interface vlan-interface 100

[AC-Vlan-interface100] ip address 112.12.1.25 16

[AC-Vlan-interface100] quit

# Configure VLAN-interface 200 and assign it an IP address. The AC will use VLAN 200 for client access.

[AC] vlan 200

[AC-vlan200] quit

[AC] interface vlan-interface 200

[AC-Vlan-interface200] ip address 112.13.1.25 16

[AC-Vlan-interface200] quit

# Configure GigabitEthernet 1/0/1 that connects the AC to the switch as a trunk port.

[AC] interface gigabitethernet1/0/1

[AC-GigabitEthernet1/0/1] port link-type trunk

# Remove the trunk port from VLAN 1, and assign the port to VLANs 100 and 200.

[AC-GigabitEthernet1/0/1] undo port trunk permit vlan 1

[AC-GigabitEthernet1/0/1] port trunk permit vlan 100 200

[AC-GigabitEthernet1/0/1] quit

2.     Configure DHCP:

# Enable DHCP.

[AC] dhcp enable

# Create DHCP address pool vlan100 to assign IP addresses for APs, and specify the IP address range for the DHCP address pool.

[AC] dhcp server ip-pool vlan100

[AC-dhcp-pool-vlan100] network 112.12.0.0 mask 255.255.0.0

# Specify gateway IP address 112.12.1.25 in the DHCP address pool.

[AC-dhcp-pool-vlan100] gateway-list 112.12.1.25

[AC-dhcp-pool-vlan100] quit

# Create DHCP address pool vlan200 to assign IP addresses for clients, and specify the IP address range for the DHCP address pool.

[AC] dhcp server ip-pool vlan200

[AC-dhcp-pool-vlan200] network 112.13.0.0 mask 255.255.0.0

# Specify gateway IP address 112.13.1.25 in the DHCP address pool.

[AC-dhcp-pool-vlan200] gateway-list 112.13.1.25

# Configure the DNS server according to the actual network plan. In this example, the gateway is specified as the DNS server.

[AC-dhcp-pool-vlan200] dns-list 112.13.1.25

[AC-dhcp-pool-vlan200] quit

3.     Configure the AP:

 

 

NOTE:

In a large-scale network, configure AP groups instead of single APs as a best practice.

 

# Create a service template named service.

[AC] wlan service-template service

# Set the SSID to service.

[AC-wlan-st-service] ssid service

# Assign the service template to VLAN 200.

[AC-wlan-st-service] vlan 200

# Set the AKM mode to PSK and specify plaintext string 12345678 as the preshared key.

[AC-wlan-st-service] akm mode psk

[AC-wlan-st-service] preshared-key pass-phrase simple 12345678

# Specify the cipher suite as CCMP and the security IE as RSN.

[AC-wlan-st-service] cipher-suite ccmp

[AC-wlan-st-service] security-ie rsn

# Configure the AC to forward client data traffic. You can skip this step if the AC is the client traffic forwarder by default.

[AC-wlan-st-service] client forwarding-location ac

# Enable the service template.

[AC-wlan-st-service] service-template enable

[AC-wlan-st-service] quit

# Create AP group group1, add the APs to the AP group, and specify the AP model.

[AC] wlan ap-group group1

[AC-wlan-ap-group-group1] ap ap1 ap2

[AC-wlan-ap-group-group1] ap-model WA6320

# Bind the service template to the radio interface.

[AC-wlan-ap-group-group1-ap-model-WA6320] radio 1

[AC-wlan-ap-group-group1-ap-model-WA6320-radio-1] service-template service

[AC-wlan-ap-group-group1-ap-model-WA6320-radio-1] radio enable

[AC-wlan-ap-group-group1-ap-model-WA6320-radio-1] quit

[AC-wlan-ap-group-group1-ap-model-WA6320] quit

[AC-wlan-ap-group-group1] quit

# Create AP ap1, and specify its model and serial ID.

[AC] wlan ap ap1 model WA6320

[AC-wlan-ap-ap1] serial-id 219801A28N819CE0002X

# Create AP ap2, and specify its model and serial ID.

[AC] wlan ap ap2 model WA6320

[AC-wlan-ap-ap2] serial-id 219801A28N819CE0002T

# Create AP sensor and specify its model and serial ID.

[AC] wlan ap sensor model WA6330

[AC-wlan-ap-sensor] serial-id 219801A23V8192E00021

# Enable WLAN probe for the radio.

[AC-wlan-ap-sensor] radio 1

 [AC-wlan-ap-sensor-radio-1] scan scan-time 100

[AC-wlan-ap-sensor-radio-1] client-proximity-sensor enable

[AC-wlan-ap-sensor-radio-1] radio enable

[AC-wlan-ap-sensor-radio-1] quit

[AC-wlan-ap-sensor] return

Configuring the switch

# Create VLANs 100 and 200. The switch will use VLAN 100 to forward the traffic on CAPWAP tunnels between the AC and APs, and use VLAN 200 to forward client traffic.

<Switch> system-view

[Switch] vlan 100

[Switch-vlan100] quit

[Switch] vlan 200

[Switch-vlan200] quit

# Configure GigabitEthernet 1/0/1 that connects the switch to the AC as a trunk port.

[Switch] interface gigabitethernet1/0/1

[Switch-GigabitEthernet1/0/1] port link-type trunk

# Remove the trunk port from VLAN 1, and assign the port to VLAN 100 and VLAN 200.

[Switch-GigabitEthernet1/0/1] undo port trunk permit vlan 1

[Switch-GigabitEthernet1/0/1] port trunk permit vlan 100 200

[Switch-GigabitEthernet1/0/1] quit

# Configure GigabitEthernet 1/0/2 as an access port and assign the port to VLAN 100.

[Switch] interface gigabitethernet1/0/2

[Switch-GigabitEthernet1/0/2] port link-type access

[Switch-GigabitEthernet1/0/2] port access vlan 100

# Enable PoE.

[Switch-GigabitEthernet1/0/2] poe enable

[Switch-GigabitEthernet1/0/2] quit

# Configure GigabitEthernet 1/0/3 that connects the switch to the AP 1 as a trunk port.

[Switch] interface gigabitEthernet 1/0/3

[Switch-GigabitEthernet1/0/3] port link-type trunk

# Remove the trunk port from VLAN 1, and assign the port to VLAN 100.

[Switch-GigabitEthernet1/0/3] undo port trunk permit vlan 1

[Switch-GigabitEthernet1/0/3] port trunk permit vlan 100

# Specify the PVID of the trunk port as VLAN 100.

[Switch-GigabitEthernet1/0/3] port trunk pvid vlan 100

# Enable PoE.

[Switch-GigabitEthernet1/0/3] poe enable

[Switch-GigabitEthernet1/0/3] quit

# Configure GigabitEthernet 1/0/4 that connects the switch to the AP 2 as a trunk port.

[Switch] interface gigabitEthernet 1/0/4

[Switch-GigabitEthernet1/0/4] port link-type trunk

# Remove the trunk port from VLAN 1, and assign the port to VLAN 100.

[Switch-GigabitEthernet1/0/4] undo port trunk permit vlan 1

[Switch-GigabitEthernet1/0/4] port trunk permit vlan 100

# Specify the PVID of the trunk port as VLAN 100.

[Switch-GigabitEthernet1/0/4] port trunk pvid vlan 100

# Enable PoE.

[Switch-GigabitEthernet1/0/4] poe enable

[Switch-GigabitEthernet1/0/4] quit

Verifying the configuration

# Display wireless device information detected by the sensor

<Sysname> display client-proximity-sensor device

Total 3 detected devices

 

MAC address    Type      Duration    Sensors Channel Status

0AFB-423B-893C AP        00h 10m 46s 1       11      Active

0AFB-423B-893D AP        00h 10m 46s 1       6       Active

0AFB-423B-893E AP        00h 10m 46s 1       1       Active

Configuration files

·     AC:

#

dhcp enable

#

vlan 100

#

vlan 200

#

dhcp server ip-pool vlan100

 gateway-list 112.12.1.25

 network 112.12.0.0 mask 255.255.0.0

#

dhcp server ip-pool vlan200

 gateway-list 112.13.1.25

 network 112.13.0.0 mask 255.255.0.0

 dns-list 112.13.1.25

#

wlan service-template service

 ssid service

 vlan 200

akm mode psk

preshared-key pass-phrase simple 12345678

cipher-suite ccmp

security-ie rsn

client forwarding-location ac

service-template enable

#

interface Vlan-interface100

 ip address 112.12.1.25 255.255.0.0

#

interface Vlan-interface200

 ip address 112.13.1.25 255.255.0.0

#

interface GigabitEthernet1/0/1

 port link-type trunk

 undo port trunk permit vlan 1

 port trunk permit vlan 100 200

#

wlan ap-group group1

ap ap1 ap2

ap-model WA6320

radio 1

service-template service

radio enable

#

 wlan ap ap1 model WA6320

serial-id 219801A28N819CE0002X

#

wlan ap ap2 model WA6320

 serial-id 219801A28N819CE0002T

#

wlan ap sensor model WA6330

 serial-id 219801A23V8192E00021

 radio 1

  scan scan-time 100

  client-proximity-sensor enable

  radio enable

#

·     Switch:

#

vlan 100

#

vlan 200

#

interface GigabitEthernet1/0/1

 port link-type trunk

 undo port trunk permit vlan 1

 port trunk permit vlan 100 200

#

interface GigabitEthernet1/0/2

 port access vlan 100

 poe enable

#

interface GigabitEthernet1/0/3

port link-type trunk

 undo port trunk permit vlan 1

 port trunk permit vlan 100

 port trunk pvid vlan 100

 poe enable

#

interface GigabitEthernet1/0/4

 port link-type trunk

 undo port trunk permit vlan 1

 port trunk permit vlan 100

 port trunk pvid vlan 100

 poe enable

#

Related documentation

·     WLAN Advanced Features Command Reference in H3C Access Controllers Command References

·     WLAN Advanced Features Configuration Guide in H3C Access Controllers Configuration Guides

  • Cloud & AI
  • InterConnect
  • Intelligent Computing
  • Security
  • SMB Products
  • Intelligent Terminal Products
  • Product Support Services
  • Technical Service Solutions
All Services
  • Resource Center
  • Policy
  • Online Help
All Support
  • Become a Partner
  • Partner Resources
  • Partner Business Management
All Partners
  • Profile
  • News & Events
  • Online Exhibition Center
  • Contact Us
All About Us
新华三官网