05-Comware 9 CLI-based configuration examples (AC+fit AP deployment)

HomeSupportDoc SetsDoc PackagesH3C Wireless Products All-in-One-6W10105-Comware 9 CLI-based configuration examples (AC+fit AP deployment)
Table of Contents
Related Documents
87-Mesh Link Establishment Between Fit APs Configuration Examples

 

H3C Access Controllers

Mesh Link Establishment Between Fit APs

Configuration Examples

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Copyright © 2023 New H3C Technologies Co., Ltd. All rights reserved.

No part of this manual may be reproduced or transmitted in any form or by any means without prior written consent of New H3C Technologies Co., Ltd.

Except for the trademarks of New H3C Technologies Co., Ltd., any trademarks that may be mentioned in this document are the property of their respective owners.

The information in this document is subject to change without notice.



Introduction

The following information provides an example of configuring a mesh link between fit APs.

Prerequisites

The following information applies to Comware-based access controllers and access points. Procedures and information in the examples might be slightly different depending on the software or hardware version of the access controllers and access points.

The configuration examples were created and verified in a lab environment, and all the devices were started with the factory default configuration. When you are working on a live network, make sure you understand the potential impact of every command on your network.

The following information is provided based on the assumption that you have basic knowledge of WLAN mesh.

Example: Configuring a mesh link between fit APs

Network configuration

As shown in Figure 1, in centralized forwarding mode, the AC is connected to the switch, and the switch assigns an IP address to APs and clients as a DHCP server. Configure devices to meet the following requirements:

·     AP 1 and AP 2 obtain an IP address from the address pool on VLAN 10 configured on the switch and come online from the AC.

·     The wired client and wireless client are assigned to the same VLAN and are reachable to each other at Layer 2.

Figure 1 Network diagram

 

Restrictions and guidelines

·     Use the actual serial ID of an AP to uniquely identify that AP.

·     To avoid too many packets in VLAN 1, configure GE1/0/4 that connects the switch to AP 1 as a trunk port, and remove the port from VLAN 1.

Procedures

Configuring the switch

1.     Configure interfaces on the switch:

# Create VLAN 10 and VLAN-interface 10, and assign an IP address to the VLAN interface. The AC will use this IP address to establish a CAPWAP tunnel with the AP.

<Switch> system-view

[Switch] vlan 10

[Switch-vlan10] quit

[Switch] interface vlan-interface 10

[Switch-Vlan-interface10] ip address 172.16.1.1 255.255.255.0

[Switch-Vlan-interface10] quit

# Create VLAN 20 and VLAN-interface 20, and assign an IP address to the VLAN interface. This VLAN will be used as the gateway for the clients.

[Switch] vlan 20

[Switch-vlan20] quit

[Switch] interface vlan-interface 20

[Switch-Vlan-interface20] ip address 192.168.10.1 255.255.255.0

[Switch-Vlan-interface20] quit

# Configure GigabitEthernet 1/0/1 that connects the switch to the AC as a trunk port, and assign the port to all VLANs.

[Switch] interface gigabitEthernet 1/0/1

[Switch-GigabitEthernet1/0/1] port link-type trunk

[Switch-GigabitEthernet1/0/1] port trunk permit vlan all

[Switch-GigabitEthernet1/0/1] quit

# Configure GigabitEthernet 1/0/4 that connects the switch to AP 1 as a trunk port, remove the port from VLAN 1, and assign the port to all the other VLANs.

[Switch] interface gigabitEthernet 1/0/4

[Switch-GigabitEthernet1/0/4] port link-type trunk

[Switch-GigabitEthernet1/0/4] port trunk permit vlan all

[Switch-GigabitEthernet1/0/4] undo port trunk permit vlan 1

# Set the PVID of GigabitEthernet 1/0/4 to VLAN 10.

[Switch-GigabitEthernet1/0/4] port trunk pvid vlan 10

[Switch-GigabitEthernet1/0/4] quit

# Assign GigabitEthernet 1/0/2 that connects the switch to Client 1 to VLAN 20.

[Switch] interface gigabitEthernet 1/0/2

[Switch-GigabitEthernet1/0/2] port access vlan 20

[Switch-GigabitEthernet1/0/2] quit

[Switch] quit

2.     Configure the DHCP server:

# Enable DHCP.

<Switch> system-view

[Switch] dhcp enable

# Specify 172.16.1.0/24 as the address range for dynamic allocation in DHCP address pool 1, and specify 172.16.1.1 as the gateway address.

[Switch] dhcp server ip-pool 1

[Switch-dhcp-pool-1] network 172.16.1.0 mask 255.255.255.0

[Switch-dhcp-pool-1] gateway-list 172.16.1.1

# Exclude 172.16.1.2 from dynamic allocation.

[Switch-dhcp-pool-1] forbidden-ip 172.16.1.2

[Switch-dhcp-pool-1] quit

# Configure DHCP address pool 2. In the address pool, specify 192.168.10.1 as the gateway IP address, 192.168.10.0/24 as the subnet for dynamic allocation, and 192.168.10.1 as the DNS server address.

[Switch] dhcp server ip-pool 2

[Switch-dhcp-pool-2] network 192.168.10.0 mask 255.255.255.0

[Switch-dhcp-pool-2] gateway-list 192.168.10.1

[Switch-dhcp-pool-2] dns-list 192.168.10.1

[Switch-dhcp-pool-2] quit

Configuring the AC

1.     Configure interfaces on the AC:

# Create VLAN 10 and VLAN-interface 10, and assign an IP address to the VLAN interface. The AC will use this IP address to establish a CAPWAP tunnel with the AP.

[AC] vlan 10

[AC-vlan10] quit

[AC] interface vlan-interface 10

[AC-Vlan-interface10] ip address 172.16.1.2 255.255.255.0

[AC-Vlan-interface10] quit

# Create VLAN 20.

[AC] vlan 20

[AC-vlan20] quit

# Configure GigabitEthernet 1/0/1 that connects the AC to the switch as a trunk port, and assign the port to all VLANs.

[AC] interface gigabitethernet 1/0/1

[AC-GigabitEthernet1/0/1] port link-type trunk

[AC-GigabitEthernet1/0/1] port trunk permit vlan all

[AC-GigabitEthernet1/0/1] quit

2.     Configure a wireless service:

# Create service template office.

[AC] wlan service-template office

# Set the SSID to Documents.

[AC-wlan-st-office] ssid Documents

# Specify VLAN 20 for the service. Clients will join the VLAN after coming online from the service.

[AC-wlan-st-office] vlan 20

# Set the AKM mode to PSK, and specify the plaintext preshared key as 12345678.

[AC-wlan-st-office] akm mode psk

[AC-wlan-st-office] preshared-key pass-phrase simple 12345678

# Set the cipher suite to CCMP and set the security IE to WPA.

[AC-wlan-st-office] cipher-suite ccmp

[AC-wlan-st-office] security-ie wpa

# Configure the AC to forward client data traffic. If the AC acts as the client traffic forwarder by default, skip this step.

[AC-wlan-st-office] client forwarding-location ac

# Enable the service template.

[AC-wlan-st-office] service-template enable

[AC-wlan-st-office] quit

3.     Configure AP 1:

 

 

NOTE:

In a large-scale network, configure AP settings in AP group view instead of AP view as a best practice.

 

# Create a manual AP named ap1, and specify the AP model and serial ID.

[AC] wlan ap ap1 model WA6330

[AC-wlan-ap-ap1] serial-id 219801A23V8192E00021

# Create AP group group1, and configure a grouping rule by AP name to add AP ap1 to the group.

[AC] wlan ap-group group1

[AC-wlan-ap-group-group1] ap ap1

# Specify the radio type as dot11an, and specify the channel as 36.

[AC-wlan-ap-group-group1] ap-model WA6330

[AC-wlan-ap-group-group1-ap-model-WA6330] radio 1

[AC-wlan-ap-group-group1-ap-model-WA6330-radio-1] type dot11an

[AC-wlan-ap-group-group1-ap-model-WA6330-radio-1] channel 36

# Enable radio 1.

[AC-wlan-ap-group-group1-ap-model-WA6330-radio-1] radio enable

[AC-wlan-ap-group-group1-ap-model-WA6330-radio-1] quit

[AC-wlan-ap-group-group1-ap-model-WA6330] quit

[AC-wlan-ap-group-group1] quit

4.     Configure AP 2:

 

 

NOTE:

In a large-scale network, configure AP settings in AP group view instead of AP view as a best practice.

 

# Create a manual AP named ap2, and specify the AP model and serial ID.

[AC] wlan ap ap2 model WA6330

[AC-wlan-ap-ap2] serial-id 219801A23V8192E00022

# Create AP group group2, and configure a grouping rule by AP name to add AP ap2 to the group.

[AC] wlan ap-group group2

[AC-wlan-ap-group-group2] ap ap2

# Specify the radio type as dot11an, and specify the channel as 36.

[AC-wlan-ap-group-group2] ap-model WA6330

[AC-wlan-ap-group-group2-ap-model-WA6330] radio 1

[AC-wlan-ap-group-group2-ap-model-WA6330-radio-1] type dot11an

[AC-wlan-ap-group-group2-ap-model-WA6330-radio-1] channel 36

# Bind service template office to radio 1 and enable radio 1.

[AC-wlan-ap-group-group2-ap-model-WA6330-radio-1] service-template office

[AC-wlan-ap-group-group2-ap-model-WA6330-radio-1] radio enable

[AC-wlan-ap-group-group2-ap-model-WA6330-radio-1] quit

[AC-wlan-ap-group-group2-ap-model-WA6330] quit

[AC-wlan-ap-group-group2] quit

5.     Configure a mesh profile:

# Create mesh profile 1.

[AC] wlan mesh-profile 1

# Set the mesh ID to 1.

[AC-wlan-mesh-profile-1] mesh-id 1

# Set the authentication and key management (AKM) mode to sae.

[AC-wlan-mesh-profile-1] akm mode sae

# Configure simple character string meshlink as the PSK.

[AC-wlan-mesh-profile-1] preshared-key pass-phrase simple meshlink

# Enable the mesh profile.

[AC-wlan-mesh-profile-1] mesh-profile enable

[AC-wlan-mesh-profile-1] quit

# Bind radio 1 in AP group group1 to mesh profile 1. Bind radio 1 in AP group group2 to mesh profile 1 in the same way.

[AC] wlan ap-group group1

[AC-wlan-ap-group-group1] ap-model WA6330

[AC-wlan-ap-group-group1-ap-model-WA6330] radio 1

[AC-wlan-ap-group-group1-ap-model-WA6330-radio-1] mesh-profile 1

6.     Add the MAC address of AP 2 to the mesh peer whitelist for APs in group group1. Add the MAC address of AP 1 to the mesh peer whitelist for APs in group group2 in the same way.

[AC-wlan-ap-group-group1-ap-model-WA6330-radio-1] mesh peer-mac-address 90e7-1066-e060

[AC-wlan-ap-group-group1-ap-model-WA6330-radio-1] quit

[AC-wlan-ap-group-group1-ap-model-WA6330] quit

7.     Configure a WLAN-mesh interface: The following uses AP group group1 as an example. Configure a WLAN-mesh interface for AP group group2 in the same way.

# Create a WLAN-mesh interface.

[AC-wlan-ap-group-group1] interface wlan-mesh 1

# Configure WLAN-mesh interface 1 as a trunk port, and assign the port to all VLANs.

[AC-wlan-ap-group-group1-wlan-mesh-1] mesh-port link-type trunk

[AC-wlan-ap-group-group1-wlan-mesh-1] mesh-port trunk permit vlan all

[AC-wlan-ap-group-group1-wlan-mesh-1] quit

# Bind WLAN-mesh interface 1 to radio 1.

[AC-wlan-ap-group-group1] ap-model WA6330

[AC-wlan-ap-group-group1-ap-model-WA6330] radio 1

[AC-wlan-ap-group-group1-ap-model-WA6330-radio-1] mesh-interface 1

[AC-wlan-ap-ap1-radio-1] quit

[AC-wlan-ap-ap1] quit

8.     Editing the AP’s configuration file

# Edit the AP’s configuration file, name it map.txt.

system-view

vlan 20

quit

interface gigabitethernet 1/0/1

port link-type trunk

port trunk permit vlan all

quit

9.     Upload the configuration file to the AC.

[AC] wlan ap-group group1

[AC-wlan-ap-group-group1] ap-model WA6330

[AC-wlan-ap-group-group1-ap-model-WA6330] map-configuration map.txt

[AC-wlan-ap-group-group1-ap-model-WA6330] quit

[AC-wlan-ap-group-group1] quit

Verifying the configuration

1.     Verify that the APs have been associated with the AC. If the APs are in R/M state, the APs have been associated with the AC.

<AC> display wlan ap all

                                  AP information

 State : I = Idle,      J  = Join,       JA = JoinAck,    IL = ImageLoad

         C = Config,    DC = DataCheck,  R  = Run,   M = Master,  B = Backup

 

AP name                        APID  State Model           Serial ID

ap1                            1     R/M   WA6330          219801A23V8192E00021

ap2                            2     R/M   WA6330          219801A23V8192E00022

2.     Display mesh link information on the AC.

<AC> display wlan mesh-link ap

AP name: ap1

 Peer           Local          Status     RSSI Packets(Rx/Tx)

 90e7-1066-e060 542b-dea7-a8c0 Forwarding 57   6919/6452

 

AP name: ap2

 Peer           Local          Status     RSSI Packets(Rx/Tx)

 542b-dea7-a8c0 90e7-1066-e060 Forwarding 55   7726/6801

3.     Ping Client 2 from Client 1 to verify that they are reachable to each other.

C:\Users\system32> ping 192.168.10.3

 

Pinging 192.168.10.3 with 32 bytes of data:

Reply from 192.168.10.3: bytes=32 time<1ms TTL=255

Reply from 192.168.10.3: bytes=32 time<1ms TTL=255

Reply from 192.168.10.3: bytes=32 time<1ms TTL=255

Reply from 192.168.10.3: bytes=32 time<1ms TTL=255

 

Ping statistics for 192.168.10.3:

    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),

Approximate round trip times in milli-seconds:

    Minimum = 0ms, Maximum = 0ms, Average = 0ms

Configuration files

·     Switch:

#

 dhcp enable

#

vlan 10

#

vlan 20

#

dhcp server ip-pool 1

 gateway-list 172.16.1.1

 network 172.16.1.0 mask 255.255.255.0

 forbidden-ip 172.16.1.2

#

dhcp server ip-pool 2

 gateway-list 192.168.10.1

 network 192.168.10.0 mask 255.255.255.0

 dns-list 192.168.10.1

#

interface Vlan-interface10

 ip address 172.16.1.1 255.255.255.0

#

interface Vlan-interface20

 ip address 192.168.10.1 255.255.255.0

#

interface GigabitEthernet1/0/1

 port link-type trunk

 port trunk permit vlan all

#

interface GigabitEthernet1/0/2

 port access vlan 20

#

interface GigabitEthernet1/0/4

 port link-type trunk

 undo port trunk permit vlan 1

 port trunk permit vlan 2 to 4094

 port trunk pvid vlan 10

#

·     AC:

#

wlan mesh-profile 1

 mesh-id 1

 akm mode sae

 preshared-key pass-phrase cipher $c$3$qVXx1KuNn4FeEi3nMUkQ7A8jcIMrN8JH2AOv

 mesh-profile enable

#

vlan 10

#

vlan 20

#

wlan service-template office

 ssid Documents

 vlan 20

 client forwarding-location ac

 akm mode psk

 preshared-key pass-phrase cipher $c$3$hqxvBKKM0Go5NmRe1XGhiy/nVnzusK20fzlz

 cipher-suite ccmp

 security-ie wpa

 service-template enable

#

interface Vlan-interface10

 ip address 172.16.1.2 255.255.255.0

#

interface GigabitEthernet1/0/1

 port link-type trunk

 port trunk permit vlan all

#

wlan ap-group group1

 vlan 1

 ap ap1

 interface wlan-mesh 1

  mesh-port link-type trunk

  mesh-port trunk permit vlan all

 ap-model WA6330

  radio 1

   type dot11an

   channel 36

   radio enable

   service-template 1

   mesh-interface 1

   mesh-profile 1

   mesh peer-mac-address 90e7-1066-e060

#

wlan ap-group group2

 map-configuration flash:/map.txt

 vlan 1

 ap ap2

 interface wlan-mesh 1

  mesh-port link-type trunk

  mesh-port trunk permit vlan all

 ap-model WA6330

  radio 1

   type dot11an

   channel 36

   radio enable

   mesh-interface 1

   mesh-profile 1

   mesh peer-mac-address 542b-dea7-a8c0

#

wlan ap ap1 model WA6330

 serial-id 219801A23V8192E00021

#

wlan ap ap2 model WA6330

 serial-id 219801A23V8192E00022

#

Related documentation

·     AP Management Command Reference in H3C Access Controllers Command References

·     AP Management Configuration Guide in H3C Access Controllers Configuration Guides

·     WLAN Mesh Command Reference in H3C Access Controllers Command References

·     WLAN Mesh Configuration Guide in H3C Access Controllers Configuration Guides

  • Cloud & AI
  • InterConnect
  • Intelligent Computing
  • Security
  • SMB Products
  • Intelligent Terminal Products
  • Product Support Services
  • Technical Service Solutions
All Services
  • Resource Center
  • Policy
  • Online Help
All Support
  • Become a Partner
  • Partner Resources
  • Partner Business Management
All Partners
  • Profile
  • News & Events
  • Online Exhibition Center
  • Contact Us
All About Us
新华三官网