• 产品与解决方案
  • 行业解决方案
  • 服务
  • 支持
  • 合作伙伴
  • 新华三人才研学中心
  • 关于我们

H3C S12500X-AF系列交换机 典型配置举例(R26xx系列)-6W100

目录

58-IRF典型配置举例

本章节下载 58-IRF典型配置举例  (271.16 KB)

docurl=/cn/Service/Document_Software/Document_Center/Switches/Catalog/S12500/S12500X-AF/Configure/Typical_Configuration_Example/H3C_S12500X-AF_CE(R26xx)-6W100/201703/976312_30005_0.htm

58-IRF典型配置举例

H3C S12500X-AF产品IRF配置举例

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

H3C_彩色.emf

 



1  简介

本文介绍了如何搭建IRF以及在IRF上配置链路聚合和路由功能。

2  配置前提

本文档中的配置均是在实验室环境下进行的配置和验证,配置前设备的所有参数均采用出厂时的缺省配置。如果您已经对设备进行了配置,为了保证配置效果,请确认现有配置和以下举例中的配置不冲突。

本文档假设您已了解IRF特性。

3  使用限制

3.1  硬件限制

在本系列交换机中,只有相同型号的机型之间才能建立IRF。

本系列交换机最多支持使用两台设备建立IRF。

建议您在IRF中所有成员设备上均使用相同的单板配置方案,即选用的单板数量及型号、安装槽位号等都保持一致。

3.2  软件版本限制

加入IRF的所有成员设备必须使用相同的软件版本。

3.3  软件功能限制

使用S12516X-AF或S12512X-AF交换机组建IRF时,成员编号只能使用1或5;使用S12508X-AF交换机组建IRF时,成员编号只能使用1或3;使用S12504X-AF交换机组建IRF时,成员编号只能使用1或2。

在多台设备形成IRF之前,请确保在各设备上以下功能的配置保持一致。

·     系统工作模式(通过system-working-mode命令配置)。

·     IPv4等价路由增强模式(通过ecmp mode enhanced命令配置)。

3.4  IRF物理端口使用限制

S12500X-AF系列交换机业务板上任意10GE、40GE或100GE端口可以作为IRF物理端口。

3.5  IRF连接限制

本设备上与IRF-Port1绑定的IRF物理端口只能和邻居成员设备IRF-Port2口上绑定的IRF物理端口相连,本设备上与IRF-Port2口绑定的IRF物理端口只能和邻居成员设备IRF-Port1口上绑定的IRF物理端口相连。否则,不能形成IRF。

3.6  License使用限制

请确保IRF中各成员设备上安装的特性License一致,否则,可能会导致这些License对应的特性不能正常运行。

4  两台成员设备的IRF配置举例

4.1  组网需求

·     如图1所示,Device A为公司的核心设备,但由于公司网络规模日益增大,汇聚层SW设备扩展至N台,Device A单台设备的转发能力已无法达到公司网络的需求。为了拓展核心设备的转发能力,又尽量不改变现有网络。现公司希望增加Device B,与Device A组成IRF,来满足当前网络的需求。

·     IRF的上行设备(Router A和Router B)为公司网络的出口路由器;IRF的下行交换机(SW 1、SW 2等)为各个服务器集群的汇聚层设备。

图1 IRF典型配置组网图

设备

接口

IP地址

设备

接口

IP地址

Router A

Vlan-int30

172.24.2.2/24

Router B

Vlan-int30

172.24.2.3/24

 

Vlan-int40

172.24.40.2/24

 

Vlan-int41

172.24.41.3/24

 

Vlan-int50

172.24.1.2/24

 

Vlan-int50

172.24.4.2/24

IRF

Vlan-int10

172.24.10.254/24

 

 

 

 

Vlan-int20

172.24.20.254/24

 

 

 

 

Vlan-int40

172.24.40.254/24

 

 

 

 

Vlan-int41

172.24.41.254/24

 

 

 

 

4.2  配置思路

·     为避免成员设备的单点故障影响到正常的业务转发,可在IRF中配置跨框聚合端口进行业务转发。

·     为尽量降低IRF分裂对业务造成的影响,可在IRF中配置LACP MAD检测。LACP MAD检测只需在一个聚合组中配置即可,其他聚合组中无需配置。LACP MAD检测使用的中间设备必须为H3C的交换机设备且使用的软件版本必须能够识别、处理携带了ActiveID值的LACPDU协议报文,在本例中使用SW 1作为LACP MAD检测的中间设备。

4.3  使用版本

本举例在R2609版本上进行配置和验证。

4.4  配置步骤

4.4.1  搭建IRF

1. Device A的配置

(1)     设置Device A的成员编号为1。

<DeviceA> system-view

[DeviceA] irf member 1

(2)     创建IRF端口2,并将它与物理端口HundredGigE 3/0/1和HundredGigE 3/0/2绑定。

[DeviceA] irf-port 2

[DeviceA-irf-port2] port group interface hundredgige 3/0/1

[DeviceA-irf-port2] port group interface hundredgige 3/0/2

[DeviceA-irf-port2] quit

(3)     开启端口HundredGigE 3/0/1和HundredGigE 3/0/2。

[DeviceA] interface range hundredgige 3/0/1 hundredgige 3/0/2

[DeviceA-if-range] undo shutdown

[DeviceA-if-range] quit

(4)     将当前配置保存到下次启动配置文件。

切换运行模式后,设备会自动重启,使新的运行模式生效。为防止配置丢失,请在切换模式前,保存当前配置。

[DeviceA] save

(5)     参照图1和端口连接表连接Device A和Device B之间的IRF物理端口。

(6)     将Device A的运行模式切换到IRF模式,之后设备会自动重启。

[DeviceA] chassis convert mode irf

The device will switch to IRF mode and reboot.

You are recommended to save the current running configuration and specify the co

nfiguration file for the next startup. Continue? [Y/N]:y

Do you want to convert the content of the next startup configuration file cfa0:/

irf.cfg to make it available in stack mode? [Y/N]:y

Now rebooting, please wait...

2. Device B的配置

(1)     设置Device B的成员编号为2。

<DeviceB> system-view

[DeviceB] irf member 2

(2)     创建设备的IRF端口1,并将它与物理端口HundredGigE 3/0/1和HundredGigE 3/0/2绑定。

[DeviceB] irf-port 1

[DeviceB-irf-port1] port group interface hundredgige 3/0/1

[DeviceB-irf-port1] port group interface hundredgige 3/0/2

[DeviceB-irf-port1] quit

(3)     开启端口HundredGigE 3/0/1和HundredGigE 3/0/2。

[DeviceB] interface range hundredgige 3/0/1 hundredgige 3/0/2

[DeviceB-if-range] undo shutdown

[DeviceB-if-range] quit

(4)     保存配置。

[DeviceB] save

(5)     参照图1和端口连接表连接Device A和Device B之间的IRF端口。

(6)     将设备的运行模式切换到IRF模式。

[DeviceB] chassis convert mode irf

The device will switch to IRF mode and reboot.

You are recommended to save the current running configuration and specify the co

nfiguration file for the next startup. Continue? [Y/N]:y

Do you want to convert the content of the next startup configuration file cfa0:

/irf.cfg to make it available in stack mode? [Y/N]:y

Now rebooting, please wait...

4.4.2  LACP MAD配置

在前面配置完成并重新启动后,IRF已经组建完成,此时可以进行各个业务模块的配置。IRF形成之后,可以从任何一台成员设备登录进行配置,设备名称缺省为Master的名称(此例中为Device A)。

# 创建连接接入层交换机SW 1的动态聚合组,编号为1,并使能LACP MAD检测功能。

<DeviceA> system-view

[DeviceA] interface bridge-aggregation 1

[DeviceA-Bridge-Aggregation1] undo shutdown

[DeviceA-Bridge-Aggregation1] link-aggregation mode dynamic

[DeviceA-Bridge-Aggregation1] mad enable

You need to assign a domain ID (range: 0-4294967295)

[Current domain is: 0]:

The assigned domain ID is: 0

MAD LACP only enable on dynamic aggregation interface.

[DeviceA-Bridge-Aggregation1] quit

# 配置连接SW 1的端口加入聚合组1

[DeviceA] interface hundredgige 1/3/0/3

[DeviceA-HundredGigE1/3/0/3] port link-aggregation group 1

[DeviceA-HundredGigE1/3/0/3] undo shutdown

[DeviceA-HundredGigE1/3/0/3] quit

[DeviceA] interface hundredgige 2/3/0/3

[DeviceA-HundredGigE2/3/0/3] port link-aggregation group 1

[DeviceA-HundredGigE2/3/0/3] undo shutdown

[DeviceA-HundredGigE2/3/0/3] quit

4.4.3  IRF下行业务配置

1. IRF的配置

# 创建连接接入层交换机SW 2的聚合组,编号为2

[DeviceA] interface bridge-aggregation 2

[DeviceA-Bridge-Aggregation2] undo shutdown

[DeviceA-Bridge-Aggregation2] quit

# 配置连接SW 2的端口加入聚合组2

[DeviceA] interface hundredgige 1/3/0/4

[DeviceA-HundredGigE1/3/0/4] port link-aggregation group 2

[DeviceA-HundredGigE1/3/0/4] undo shutdown

[DeviceA-HundredGigE1/3/0/4] quit

[DeviceA] interface hundredgige 2/3/0/4

[DeviceA-HundredGigE2/3/0/4] port link-aggregation group 2

[DeviceA-HundredGigE2/3/0/4] undo shutdown

[DeviceA-HundredGigE2/3/0/4] quit

# 配置与SW 1之间通过Vlan-interface 10连接。

[DeviceA] vlan 10

[DeviceA-vlan10] quit

[DeviceA] interface vlan-interface 10

[DeviceA-Vlan-interface10] undo shutdown

[DeviceA-Vlan-interface10] ip address 172.24.10.254 24

[DeviceA-Vlan-interface10] quit

[DeviceA] interface bridge-aggregation 1

[DeviceA-Bridge-Aggregation1] port link-type trunk

[DeviceA-Bridge-Aggregation1] undo port trunk permit vlan 1

[DeviceA-Bridge-Aggregation1] port trunk permit vlan 10

[DeviceA-Bridge-Aggregation1] quit

# 配置与SW 2之间通过Vlan-interface 20连接。

[DeviceA] vlan 20

[DeviceA-vlan20] quit

[DeviceA] interface vlan-interface 20

[DeviceA-Vlan-interface20] undo shutdown

[DeviceA-Vlan-interface20] ip address 172.24.20.254 24

[DeviceA-Vlan-interface20] quit

[DeviceA] interface bridge-aggregation 2

[DeviceA-Bridge-Aggregation2] port link-type trunk

[DeviceA-Bridge-Aggregation2] undo port trunk permit vlan 1

[DeviceA-Bridge-Aggregation2] port trunk permit vlan 20

[DeviceA-Bridge-Aggregation2] quit

2. SW 1的配置

# 创建连接IRF的动态聚合组,编号为1,该聚合组同时用于IRF的LACP MAD检测。

<SW1> system-view

[SW1] interface bridge-aggregation 1

[SW1-Bridge-Aggregation1] undo shutdown

[SW1-Bridge-Aggregation1] link-aggregation mode dynamic

[SW1-Bridge-Aggregation1] quit

# 配置连接IRF的端口加入聚合组1

[SW1] interface hundredgige 4/0/1

[SW1-HundredGigE4/0/1] port link-aggregation group 1

[SW1-HundredGigE4/0/1] undo shutdown

[SW1-HundredGigE4/0/1] quit

[SW1] interface hundredgige 4/0/2

[SW1-HundredGigE4/0/2] port link-aggregation group 1

[SW1-HundredGigE4/0/2] undo shutdown

[SW1-HundredGigE4/0/2] quit

# 接入设备SW1上创建所有VLAN。

[SW1] vlan all

# 配置与IRF连接的端口。

[SW1] interface bridge-aggregation 1

[SW1-Bridge-Aggregation1] port link-type trunk

[SW1-Bridge-Aggregation1] undo port trunk permit vlan 1

[SW1-Bridge-Aggregation1] port trunk permit vlan 10

[SW1-Bridge-Aggregation1] quit

# 配置连接服务器的端口Ten-GigabitEthernet3/0/1。

[SW1] interface ten-gigabitethernet 3/0/1

[SW1-Ten-GigabitEthernet3/0/1] undo shutdown

[SW1-Ten-GigabitEthernet3/0/1] port link-type trunk

[SW1-Ten-GigabitEthernet3/0/1] port trunk permit vlan all

[SW1-Ten-GigabitEthernet3/0/1] undo port trunk permit vlan 1

[SW1-Ten-GigabitEthernet3/0/1] quit

3. SW 2的配置

# 创建连接IRF的聚合组,编号为1

<SW2> system-view

[SW2] interface bridge-aggregation 1

[SW2-Bridge-Aggregation1] undo shutdown

[SW2-Bridge-Aggregation1] quit

# 配置连接IRF的端口加入聚合组1

[SW2] interface hundredgige 4/0/1

[SW2-HundredGigE4/0/1] port link-aggregation group 1

[SW2-HundredGigE4/0/1] undo shutdown

[SW2-HundredGigE4/0/1] quit

[SW2] interface hundredgige 4/0/2

[SW2-HundredGigE4/0/2] port link-aggregation group 1

[SW2-HundredGigE4/0/2] undo shutdown

[SW2-HundredGigE4/0/2] quit

# 接入设备SW 2上创建所有VLAN。

[SW2] vlan all

# 配置与IRF连接的端口。

[SW2] interface bridge-aggregation 1

[SW2-Bridge-Aggregation1] port link-type trunk

[SW2-Bridge-Aggregation1] undo port trunk permit vlan 1

[SW2-Bridge-Aggregation1] port trunk permit vlan 20

[SW2-Bridge-Aggregation1] quit

# 配置连接服务器的端口Ten-GigabitEthernet3/0/1。

[SW2] interface ten-gigabitethernet 3/0/1

[SW2-Ten-GigabitEthernet3/0/1] undo shutdown

[SW2-Ten-GigabitEthernet3/0/1] port link-type trunk

[SW2-Ten-GigabitEthernet3/0/1] port trunk permit vlan all

[SW2-Ten-GigabitEthernet3/0/1] undo port trunk permit vlan 1

[SW2-Ten-GigabitEthernet3/0/1] quit

4.4.4  IRF上行业务配置

1. IRF的配置

# 创建连接出口路由器Router A的聚合组,编号为1023。

[DeviceA] interface bridge-aggregation 1023

[DeviceA-Bridge-Aggregation1023] undo shutdown

[DeviceA-Bridge-Aggregation1023] quit

# 配置连接Router A的端口加入聚合组1023

[DeviceA] interface hundredgige 1/3/0/7

[DeviceA-HundredGigE1/3/0/7] port link-aggregation group 1023

[DeviceA-HundredGigE1/3/0/7] undo shutdown

[DeviceA-HundredGigE1/3/0/7] quit

[DeviceA] interface hundredgige 2/3/0/7

[DeviceA-HundredGigE2/3/0/7] port link-aggregation group 1023

[DeviceA-HundredGigE2/3/0/7] undo shutdown

[DeviceA-HundredGigE2/3/0/7] quit

# 配置与Router A之间通过Vlan-interface40连接。

[DeviceA] vlan 40

[DeviceA-vlan40] quit

[DeviceA] interface vlan-interface 40

[DeviceA-Vlan-interface40] undo shutdown

[DeviceA-Vlan-interface40] ip address 172.24.40.254 24

[DeviceA-Vlan-interface40] quit

[DeviceA] interface bridge-aggregation 1023

[DeviceA-Bridge-Aggregation1023] port access vlan 40

[DeviceA-Bridge-Aggregation1023] quit

# 创建连接出口路由器Router B的聚合组,编号为1024

[DeviceA] interface bridge-aggregation 1024

[DeviceA-Bridge-Aggregation1024] undo shutdown

[DeviceA-Bridge-Aggregation1024] quit

# 配置连接Router B的端口加入聚合组1024

[DeviceA] interface hundredgige 1/3/0/8

[DeviceA-HundredGigE1/3/0/8] port link-aggregation group 1024

[DeviceA-HundredGigE1/3/0/8] undo shutdown

[DeviceA-HundredGigE1/3/0/8] quit

[DeviceA] interface hundredgige 2/3/0/8

[DeviceA-HundredGigE2/3/0/8] port link-aggregation group 1024

[DeviceA-HundredGigE2/3/0/8] undo shutdown

[DeviceA-HundredGigE2/3/0/8] quit

# 配置与Router B之间通过Vlan-interface41连接。

[DeviceA] vlan 41

[DeviceA-vlan41] quit

[DeviceA] interface vlan-interface 41

[DeviceA-Vlan-interface41] undo shutdown

[DeviceA-Vlan-interface41] ip address 172.24.41.254 24

[DeviceA-Vlan-interface41] quit

[DeviceA] interface bridge-aggregation 1024

[DeviceA-Bridge-Aggregation1024] port access vlan 41

[DeviceA-Bridge-Aggregation1024] quit

# 配置IRF与出口路由器之间运行OSPF路由协议。

[DeviceA] ospf

[DeviceA-ospf-1] import-route direct

[DeviceA-ospf-1] area 0

[DeviceA-ospf-1-area-0.0.0.0] network 172.24.40.0 0.0.0.255

[DeviceA-ospf-1-area-0.0.0.0] network 172.24.41.0 0.0.0.255

[DeviceA-ospf-1-area-0.0.0.0] quit

[DeviceA-ospf-1] quit

2. Router A的配置

说明

出口路由器配置本用例只描述与IRF连接的部分,外网使用何种路由协议不予描述。

 

# 创建连接IRF的聚合组,编号为1

<RouterA> system-view

[RouterA] interface bridge-aggregation 1

[RouterA-Bridge-Aggregation1] undo shutdown

[RouterA-Bridge-Aggregation1] quit

# 配置连接IRF的端口加入聚合组1

[RouterA] interface hundredgige 4/0/1

[RouterA-HundredGigE4/0/1] port link-mode bridge

[RouterA-HundredGigE4/0/1] port link-aggregation group 1

[RouterA-HundredGigE4/0/1] undo shutdown

[RouterA-HundredGigE4/0/1] quit

[RouterA] interface hundredgige 2/0/1

[RouterA-HundredGigE2/0/1] port link-mode bridge

[RouterA-HundredGigE2/0/1] port link-aggregation group 1

[RouterA-HundredGigE2/0/1] undo shutdown

[RouterA-HundredGigE2/0/1] quit

# 配置与IRF之间通过Vlan-interface 40连接。

[RouterA] vlan 40

[RouterA-vlan40] quit

[RouterA] interface vlan-interface 40

[RouterA-Vlan-interface40] undo shutdown

[RouterA-Vlan-interface40] ip address 172.24.40.2 24

[RouterA-Vlan-interface40] quit

[RouterA] interface bridge-aggregation 1

[RouterA-Bridge-Aggregation1] port access vlan 40

[RouterA-Bridge-Aggregation1] quit

# 配置与RouterB之间通过Vlan-interface 30连接。

[RouterA] vlan 30

[RouterA-vlan30] quit

[RouterA] interface vlan-interface 30

[RouterA-Vlan-interface30] undo shutdown

[RouterA-Vlan-interface30] ip address 172.24.2.2 24

[RouterA-Vlan-interface30] quit

[RouterA] interface bridge-aggregation 2

[RouterA-Bridge-Aggregation2] undo shutdown

[RouterA-Bridge-Aggregation2] port link-type access

[RouterA-Bridge-Aggregation2] port access vlan 30

[RouterA-Bridge-Aggregation2] quit

[RouterA] interface hundredgige 4/0/2

[RouterA-HundredGigE4/0/2] port link-mode bridge

[RouterA-HundredGigE4/0/2] port link-aggregation group 2

[RouterA-HundredGigE4/0/2] undo shutdown

[RouterA-HundredGigE4/0/2] quit

[RouterA] interface hundredgige 2/0/2

[RouterA-HundredGigE2/0/2] port link-mode bridge

[RouterA-HundredGigE2/0/2] port link-aggregation group 2

[RouterA-HundredGigE2/0/2] undo shutdown

[RouterA-HundredGigE2/0/2] quit

# 配置Router A通过Vlan-interface 50连接外网。

[RouterA] vlan 50

[RouterA-vlan50] quit

[RouterA] interface vlan-interface 50

[RouterA-Vlan-interface50] undo shutdown

[RouterA-Vlan-interface50] ip address 172.24.1.2 24

[RouterA-Vlan-interface50] quit

[RouterA] interface hundredgige 4/0/3

[RouterA-HundredGigE4/0/3] port link-mode bridge

[RouterA-HundredGigE4/0/3] port access vlan 50

[RouterA-HundredGigE4/0/3] undo shutdown

[RouterA-HundredGigE4/0/3] quit

# 配置Router A与IRF之间运行OSPF路由协议。

[RouterA] ospf

[RouterA-ospf-1] import-route direct

[RouterA-ospf-1] area 0

[RouterA-ospf-1-area-0.0.0.0] network 172.24.40.0 0.0.0.255

[RouterA-ospf-1-area-0.0.0.0] network 172.24.2.0 0.0.0.255

[RouterA-ospf-1-area-0.0.0.0] quit

[RouterA-ospf-1] quit

3. Router B的配置

# 配置与IRF之间通过Vlan-interface 41连接。

<RouterB> system-view

[RouterB] vlan 41

[RouterB-vlan41] quit

[RouterB] interface vlan-interface 41

[RouterB-Vlan-interface41] undo shutdown

[RouterB-Vlan-interface41] ip address 172.24.41.3 24

[RouterB-Vlan-interface41] quit

[RouterB] interface bridge-aggregation 1

[RouterB-Bridge-Aggregation1] port access vlan 41

[RouterB-Bridge-Aggregation1] undo shutdown

[RouterB-Bridge-Aggregation1] quit

[RouterB] interface hundredgige 4/0/1

[RouterB-HundredGigE4/0/1] port link-mode bridge

[RouterB-HundredGigE4/0/1] port link-aggregation group 1

[RouterB-HundredGigE4/0/1] undo shutdown

[RouterB-HundredGigE4/0/1] quit

[RouterB] interface hundredgige 2/0/1

[RouterB-HundredGigE2/0/1] port link-mode bridge

[RouterB-HundredGigE2/0/1] port link-aggregation group 1

[RouterB-HundredGigE2/0/1] undo shutdown

[RouterB-HundredGigE2/0/1] quit

# 配置与Router A之间通过Vlan-interface 30连接。

[RouterB] vlan 30

[RouterB-vlan30] quit

[RouterB] interface vlan-interface 30

[RouterB-Vlan-interface30] undo shutdown

[RouterB-Vlan-interface30] ip address 172.24.2.3 24

[RouterB-Vlan-interface30] quit

[RouterB] interface bridge-aggregation 2

[RouterB-Bridge-Aggregation2] port link-type access

[RouterB-Bridge-Aggregation2] port access vlan 30

[RouterB-Bridge-Aggregation2] undo shutdown

[RouterB-Bridge-Aggregation2] quit

[RouterB] interface hundredgige 4/0/2

[RouterB-HundredGigE4/0/2] port link-aggregation group 2

[RouterB-HundredGigE4/0/2] undo shutdown

[RouterB-HundredGigE4/0/2] quit

[RouterB] interface hundredgige 2/0/2

[RouterB-HundredGigE2/0/2] port link-aggregation group 2

[RouterB-HundredGigE2/0/2] undo shutdown

[RouterB-HundredGigE2/0/2] quit

# 配置Router B通过Vlan-interface 50连接外网。

[RouterB] vlan 50

[RouterB-vlan50] quit

[RouterB] interface vlan-interface 50

[RouterB-Vlan-interface50] undo shutdown

[RouterB-Vlan-interface50] ip address 172.24.4.2 24

[RouterB-Vlan-interface50] quit

[RouterB] interface hundredgige 4/0/3

[RouterB-HundredGigE4/0/3] port link-mode bridge

[RouterB-HundredGigE4/0/3] port access vlan 50

[RouterB-HundredGigE4/0/3] undo shutdown

[RouterB-HundredGigE4/0/3] quit

# 配置Router B与IRF之间运行OSPF路由协议。

[RouterB] ospf

[RouterB-ospf-1] import-route direct

[RouterB-ospf-1] area 0

[RouterB-ospf-1-area-0.0.0.0] network 172.24.41.0 0.0.0.255

[RouterB-ospf-1-area-0.0.0.0] network 172.24.2.0 0.0.0.255

[RouterB-ospf-1-area-0.0.0.0] quit

[RouterB-ospf-1] quit

4.5  验证配置

(1)     验证IRF建立成功。

[DeviceA] display irf

MemberID  Slot  Role    Priority  CPU-Mac         Description

 *+1      0     Master  1         0210-fc01-0000  ---

   2      0     Standby 1         0210-fc02-0000  ---

--------------------------------------------------

 * indicates the device is the master.

 + indicates the device through which the user logs in.

 

 The Bridge MAC of the IRF is: 3822-d60f-2800

 Auto upgrade                : yes

 Mac persistent              : always

 Domain ID                   : 0

 Auto merge                  : yes

从命令行的显示看,当前两台设备IRF成功建立。

(2)     验证跨框聚合有链路备份的作用。

从serverGroup 1任意挑选一台PC ping外网IP,关闭IRF的上行端口HundredGigE 1/3/0/8,出现短暂中断后仍然可以ping通外网。

C:\Users>ping 202.108.22.5 –t

 

正在 Ping 202.108.22.5 具有 32 字节的数据:

来自 202.108.22.5 的回复: 字节=32 时间=1ms TTL=122

来自 202.108.22.5 的回复: 字节=32 时间=13ms TTL=122

来自 202.108.22.5 的回复: 字节=32 时间<1ms TTL=122

请求超时。

来自 202.108.22.5 的回复: 字节=32 时间<1ms TTL=122

来自 202.108.22.5 的回复: 字节=32 时间<1ms TTL=122

来自 202.108.22.5 的回复: 字节=32 时间<1ms TTL=122

重新开启端口HundredGigE 1/3/0/8,持续ping,将另外一个上行端口HundredGigE 2/3/0/8关闭,出现短暂中断后仍然可以ping通外网。

C:\Users>ping 202.108.22.5 –t

 

正在 Ping 202.108.22.5 具有 32 字节的数据:

来自 202.108.22.5 的回复: 字节=32 时间=1ms TTL=122

来自 202.108.22.5 的回复: 字节=32 时间=13ms TTL=122

来自 202.108.22.5 的回复: 字节=32 时间<1ms TTL=122

请求超时。

来自 202.108.22.5 的回复: 字节=32 时间<1ms TTL=122

来自 202.108.22.5 的回复: 字节=32 时间<1ms TTL=122

来自 202.108.22.5 的回复: 字节=32 时间<1ms TTL=122

(3)     验证IRF物理链路的冗余备份

断开IRF物理链路中的任意一条,IRF仍能正常工作、没有分裂。

4.6  配置文件

·     IRF:

#

irf mac-address persistent always

irf auto-update enable

irf auto-merge enable

undo irf link-delay

irf member 1 priority 1

irf member 2 priority 1

#

ospf 1

 import-route direct

 area 0.0.0.0

  network 172.24.40.0 0.0.0.255

  network 172.24.41.0 0.0.0.255

#

vlan 10

#

vlan 20

#

vlan 40

#

vlan 41

#

irf-port 1/2

 port group interface HundredGigE1/3/0/1 mode enhanced

 port group interface HundredGigE1/3/0/2 mode enhanced

#

irf-port 2/1

 port group interface HundredGigE2/3/0/1 mode enhanced

 port group interface HundredGigE2/3/0/2 mode enhanced

#

interface bridge-aggregation 1

 port link-type trunk

 undo port trunk permit vlan 1

 port trunk permit vlan 10

 link-aggregation mode dynamic

 mad enable

#

interface bridge-aggregation 2

 port link-type trunk

 undo port trunk permit vlan 1

 port trunk permit vlan 20

#

interface bridge-aggregation 1023

 port access vlan 40

#

interface bridge-aggregation 1024

 port access vlan 41

#

interface vlan-interface 10

 ip address 172.24.10.254 255.255.255.0

#

interface vlan-interface 20

 ip address 172.24.20.254 255.255.255.0

#

interface vlan-interface 40

 ip address 172.24.40.254 255.255.255.0

#

interface HundredGigE 1/3/0/3

 port link-mode bridge

 port link-type trunk

 undo port trunk permit vlan 1

 port trunk permit vlan 10

 port link-aggregation group 1

#

interface HundredGigE 1/3/0/4

 port link-mode bridge

 port link-type trunk

 undo port trunk permit vlan 1

 port trunk permit vlan 20

 port link-aggregation group 2

#

interface HundredGigE 1/3/0/7

 port link-mode bridge

 port access vlan 40

 port link-aggregation group 1023

#

interface HundredGigE 1/3/0/8

 port link-mode bridge

 port access vlan 41

 port link-aggregation group 1024

#

interface HundredGigE 2/3/0/3

 port link-mode bridge

 port link-type trunk

 undo port trunk permit vlan 1

 port trunk permit vlan 10

 port link-aggregation group 1

#

interface HundredGigE 2/3/0/4

 port link-mode bridge

 port link-type trunk

 undo port trunk permit vlan 1

 port trunk permit vlan 20

 port link-aggregation group 2

#

interface HundredGigE 2/3/0/7

 port link-mode bridge

 port access vlan 40

 port link-aggregation group 1023

#

interface HundredGigE 2/3/0/8

 port link-mode bridge

 port access vlan 41

 port link-aggregation group 1024

#

·     SW1:

#

vlan 2 to 4094

#

interface bridge-aggregation 1

 port link-type trunk

 undo port trunk permit vlan 1

 port trunk permit vlan 10

 link-aggregation mode dynamic

#

interface ten-gigabitethernet 3/0/1

 port link-mode bridge

 port link-type trunk

 undo port trunk permit vlan 1

 port trunk permit vlan 2 to 4094

#

interface HundredGigE 4/0/1

 port link-mode bridge

 port link-type trunk

 undo port trunk permit vlan 1

 port trunk permit vlan 10

 port link-aggregation group 1

#

interface HundredGigE 4/0/2

 port link-mode bridge

 port link-type trunk

 undo port trunk permit vlan 1

 port trunk permit vlan 10

 port link-aggregation group 1

#

·     SW2:

#

vlan 2 to 4094

#

interface bridge-aggregation 1

 port link-type trunk

 undo port trunk permit vlan 1

 port trunk permit vlan 20

#

interface ten-gigabitethernet 3/0/1

 port link-mode bridge

 port link-type trunk

 undo port trunk permit vlan 1

 port trunk permit vlan 2 to 4094

#

interface HundredGigE 4/0/1

 port link-mode bridge

 port link-type trunk

 undo port trunk permit vlan 1

 port trunk permit vlan 20

 port link-aggregation group 1

#

interface HundredGigE 4/0/2

 port link-mode bridge

 port link-type trunk

 undo port trunk permit vlan 1

 port trunk permit vlan 20

 port link-aggregation group 1

#

·     RouterA:

#

ospf 1

 import-route direct

 area 0.0.0.0

  network 172.24.2.0 0.0.0.255

  network 172.24.40.0 0.0.0.255

#

vlan 30

#

vlan 40

#

vlan 50

#

interface bridge-aggregation 1

 port access vlan 40

#

interface bridge-aggregation 2

 port access vlan 30

#

interface vlan-interface 30

 ip address 172.24.2.2 255.255.255.0

#

interface vlan-interface 40

 ip address 172.24.40.2 255.255.255.0

#

interface vlan-interface 50

 ip address 172.24.1.2 255.255.255.0

#

interface HundredGigE 2/0/1

 port link-mode bridge

 port access vlan 40

 port link-aggregation group 1

#

interface HundredGigE 2/0/2

 port link-mode bridge

 port access vlan 30

 port link-aggregation group 2

#

interface HundredGigE 4/0/1

 port link-mode bridge

 port access vlan 40

 port link-aggregation group 1

#

interface HundredGigE 4/0/2

 port link-mode bridge

 port access vlan 30

 port link-aggregation group 2

#

interface HundredGigE 4/0/3

 port link-mode bridge

 port access vlan 50

#

·     RouterB:

#

ospf 1

 import-route direct

 area 0.0.0.0

  network 172.24.2.0 0.0.0.255

  network 172.24.41.0 0.0.0.255

#

vlan 30

#

vlan 41

#

vlan 50

#

interface bridge-aggregation 1

 port access vlan 41

#

interface bridge-aggregation 2

 port access vlan 30

#

interface vlan-interface 30

 ip address 172.24.2.3 255.255.255.0

#

interface vlan-interface 41

 ip address 172.24.41.3 255.255.255.0

#

interface vlan-interface 50

 ip address 172.24.4.2 255.255.255.0

#

interface HundredGigE 2/0/1

 port link-mode bridge

 port access vlan 41

 port link-aggregation group 1

#

interface HundredGigE 2/0/2

 port link-mode bridge

 port access vlan 30

 port link-aggregation group 2

#

interface HundredGigE 4/0/1

 port link-mode bridge

 port access vlan 41

 port link-aggregation group 1

#

interface HundredGigE 4/0/2

 port link-mode bridge

 port access vlan 30

 port link-aggregation group 2

#

interface HundredGigE 4/0/3

 port link-mode bridge

 port access vlan 50

#

5  相关资料

·     H3C S12500X-AF系列交换机 IRF配置指导-R26xx

·     H3C S12500X-AF系列交换机 IRF命令参考- R26xx

不同款型规格的资料略有差异, 详细信息请向具体销售和400咨询。H3C保留在没有任何通知或提示的情况下对资料内容进行修改的权利!

联系我们