• 产品与解决方案
  • 行业解决方案
  • 服务
  • 支持
  • 合作伙伴
  • 新华三人才研学中心
  • 关于我们

H3C S12500X-AF系列交换机 典型配置举例(R26xx系列)-6W100

目录

54-Smart Link典型配置举例

本章节下载 54-Smart Link典型配置举例  (362.62 KB)

docurl=/cn/Service/Document_Software/Document_Center/Switches/Catalog/S12500/S12500X-AF/Configure/Typical_Configuration_Example/H3C_S12500X-AF_CE(R26xx)-6W100/201703/976308_30005_0.htm

54-Smart Link典型配置举例

H3C S12500X-AF产品Smart Link配置举例

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

H3C_彩色.emf

 



1  简介

本文档介绍了Smart Link配置举例。

2  配置前提

本文档不严格与具体软、硬件版本对应,如果使用过程中与产品实际情况有差异,请参考相关产品手册,或以设备实际情况为准。

本文档中的配置均是在实验室环境下进行的配置和验证,配置前设备的所有参数均采用出厂时的缺省配置。如果您已经对设备进行了配置,为了保证配置效果,请确认现有配置和以下举例中的配置不冲突。

本文档假设您已了解Smart Link、Monitor Link和IRF特性。

3  使用限制

请勿将一个端口同时加入聚合组和Smart Link组,否则该端口在Smart Link组中将不会生效,也无法使用display smart-link group命令查看到。

4  Smart Link组负载分担配置举例

4.1  组网需求

图1所示,某企业财务部和市场部分别使用VLAN 10和VLAN 11,出于可靠性考虑,接入设备Device A提供两条链路双上行到汇聚设备Device D。现要求如下:

·     通过配置Smart Link来实现链路备份和负载分担。财务部优先使用Device A—>Device B路径转发数据流量,市场部优先使用Device A—>Device C路径转发数据流量。

·     当Device A到Device B、Device C的两条上行链路都正常时,财务部和市场部的数据流量分别通过不同路径转发;当其中一条链路出现故障时,Smart Link功能会将故障链路上的流量快速切换到另一条链路上;当链路故障恢复时,Smart Link功能又会将数据流量及时切换回原来的转发路径。

图1 Smart Link组配置组网图

设备

接口

VLAN

设备

接口

VLAN

Device A

HGE1/0/1

10、11

Device C

HGE1/0/1

10、11

 

HGE1/0/2

10、11

 

HGE1/0/2

10、11

 

HGE1/0/3

10

Device D

HGE1/0/1

10、11

 

HGE1/0/4

11

 

HGE1/0/2

10、11

Device B

HGE1/0/1

10、11

 

HGE1/0/3

10、11

 

HGE1/0/2

10、11

 

 

 

 

4.2  配置思路

为了实现流量在两条上行链路上的负载分担,需在Device A创建两个Smart Link组,不同Smart Link组包含相同的成员端口,但同一端口在不同Smart Link组内角色不同,且财务部和市场部使用的VLAN分别为这两个Smart Link组的保护VLAN。

为了实现链路故障恢复时,财务部和市场部的数据流量仍能切换回各自原来的路径转发,需要为两个Smart Link组都配置角色抢占模式。

为了避免当Smart Link组中的主从链路切换时,由于上游设备上的MAC地址转发表项和ARP/ND表项没有及时更新,而导致下行数据流量发生中断,需要在Device A上配置发送Flush报文功能,处于从Device A到Device D主、从链路上的端口都需要使能接收Flush报文功能。

4.3  使用版本

本举例是在R2609版本上进行配置和验证的。

4.4  配置注意事项

·     如果欲配置某端口为Smart Link组的成员端口(主端口或从端口),请先手工关闭该端口,并待Smart Link组配置完成后再开启该端口,以避免形成环路,导致广播风暴。

·     在配置Smart Link组的成员端口及其直连端口之前,请确认端口未启用STP或者RRPP功能。

·     上游设备上配置的接收处理Flush报文的控制VLAN和在Smart Link设备上配置的发送控制VLAN需要相同。

·     不同的Smart Link组需要配置不同的控制VLAN。Smart Link组的控制VLAN应同时为该Smart Link组的保护VLAN,且不要将已配置为控制VLAN的VLAN删除,否则会影响Flush报文的发送。

4.5  配置步骤

4.5.1  Device A的配置

# 关闭端口HundredGigE1/0/1和HundredGigE1/0/2,并配置端口为Trunk端口,允许VLAN 10、VLAN 11流量通过,并关闭STP。

<DeviceA> system-view

[DeviceA] vlan 10 to 11

[DeviceA] interface hundredgige 1/0/1

[DeviceA-HundredGigE1/0/1] shutdown

[DeviceA-HundredGigE1/0/1] port link-type trunk

[DeviceA-HundredGigE1/0/1] port trunk permit vlan 10 11

[DeviceA-HundredGigE1/0/1] undo port trunk permit vlan 1

[DeviceA-HundredGigE1/0/1] undo stp enable

[DeviceA-HundredGigE1/0/1] quit

[DeviceA] interface hundredgige 1/0/2

[DeviceA-HundredGigE1/0/2] shutdown

[DeviceA-HundredGigE1/0/2] port link-type trunk

[DeviceA-HundredGigE1/0/2] port trunk permit vlan 10 11

[DeviceA-HundredGigE1/0/2] undo port trunk permit vlan 1

[DeviceA-HundredGigE1/0/2] undo stp enable

[DeviceA-HundredGigE1/0/2] quit

# 配置端口HundredGigE1/0/3、HundredGigE1/0/4为Access端口,分别允许VLAN 10和VLAN 11流量通过。

[DeviceA] interface hundredgige 1/0/3

[DeviceA-HundredGigE1/0/3] port access vlan 10

[DeviceA-HundredGigE1/0/3] quit

[DeviceA] interface hundredgige 1/0/4

[DeviceA-HundredGigE1/0/4] port access vlan 11

[DeviceA-HundredGigE1/0/4] quit

# 将VLAN 10映射到MSTI 1、VLAN 11映射到MSTI 2上,并激活MST域的配置。

[DeviceA] stp region-configuration

[DeviceA-mst-region] instance 1 vlan 10

[DeviceA-mst-region] instance 2 vlan 11

[DeviceA-mst-region] active region-configuration

[DeviceA-mst-region] quit

# 创建Smart Link组1,并配置其保护VLAN为MSTI 1所映射的VLAN。

[DeviceA] smart-link group 1

[DeviceA-smlk-group1] protected-vlan reference-instance 1

# 配置端口HundredGigE1/0/1为主端口,HundredGigE1/0/2为从端口。

[DeviceA-smlk-group1] port HundredGigE 1/0/1 primary

[DeviceA-smlk-group1] port HundredGigE 1/0/2 secondary

# 使能发送Flush报文。

[DeviceA-smlk-group1] flush enable control-vlan 10

# 配置抢占模式,配置延时抢占时间为10秒。

[DeviceA-smlk-group1] preemption mode role

[DeviceA-smlk-group1] preemption delay 10

[DeviceA-smlk-group1] quit

# 创建Smart Link组2,并配置其保护VLAN为MSTI 2所映射的VLAN。

[DeviceA] smart-link group 2

[DeviceA-smlk-group2] protected-vlan reference-instance 2

# 配置端口HundredGigE1/0/2为主端口,HundredGigE1/0/1为从端口。

[DeviceA-smlk-group2] port HundredGigE 1/0/2 primary

[DeviceA-smlk-group2] port HundredGigE 1/0/1 secondary

# 使能发送Flush报文。

[DeviceA-smlk-group2] flush enable control-vlan 11

# 配置抢占模式,配置默认的延时抢占时间为10秒。

[DeviceA-smlk-group2] preemption mode role

[DeviceA-smlk-group2] preemption delay 10

[DeviceA-smlk-group2] quit

# 开启端口HundredGigE1/0/1和HundredGigE1/0/2。

[DeviceA] interface hundredgige 1/0/1

[DeviceA-HundredGigE1/0/1] undo shutdown

[DeviceA-HundredGigE1/0/1] quit

[DeviceA] interface hundredgige 1/0/2

[DeviceA-HundredGigE1/0/2] undo shutdown

[DeviceA-HundredGigE1/0/2] quit

4.5.2  Device B的配置

# 配置端口HundredGigE1/0/1为Trunk端口,允许VLAN 10、VLAN 11流量通过,在该端口上关闭STP并使能Flush报文接收,并指定接收Flush报文的控制VLAN为VLAN 10和11。

<DeviceB> system-view

[DeviceB] vlan 10 to 11

[DeviceB] interface hundredgige 1/0/1

[DeviceB-HundredGigE1/0/1] port link-type trunk

[DeviceB-HundredGigE1/0/1] port trunk permit vlan 10 11

[DeviceB-HundredGigE1/0/1] undo port trunk permit vlan 1

[DeviceB-HundredGigE1/0/1] undo stp enable

[DeviceB-HundredGigE1/0/1] smart-link flush enable control-vlan 10 11

[DeviceB-HundredGigE1/0/1] undo shutdown

[DeviceB-HundredGigE1/0/1] quit

# 配置端口HundredGigE1/0/2为Trunk端口,允许VLAN 10、VLAN 11流量通过,使能Flush报文接收,并指定接收Flush报文的控制VLAN为VLAN 10和11。

[DeviceB] interface hundredgige 1/0/2

[DeviceB-HundredGigE1/0/2] port link-type trunk

[DeviceB-HundredGigE1/0/2] port trunk permit vlan 10 11

[DeviceB-HundredGigE1/0/2] undo port trunk permit vlan 1

[DeviceB-HundredGigE1/0/2] smart-link flush enable control-vlan 10 11

[DeviceB-HundredGigE1/0/2] undo shutdown

[DeviceB-HundredGigE1/0/2] quit

4.5.3  Device C的配置

# 配置端口HundredGigE1/0/1为Trunk端口,允许VLAN 10、VLAN 11流量通过,在该端口上关闭STP并使能Flush报文接收,并指定接收Flush报文的控制VLAN为VLAN 10和11。

<DeviceC> system-view

[DeviceC] vlan 10 to 11

[DeviceC] interface hundredgige 1/0/1

[DeviceC-HundredGigE1/0/1] port link-type trunk

[DeviceC-HundredGigE1/0/1] port trunk permit vlan 10 11

[DeviceC-HundredGigE1/0/1] undo port trunk permit vlan 1

[DeviceC-HundredGigE1/0/1] undo stp enable

[DeviceC-HundredGigE1/0/1] smart-link flush enable control-vlan 10 11

[DeviceC-HundredGigE1/0/1] undo shutdown

[DeviceC-HundredGigE1/0/1] quit

# 配置端口HundredGigE1/0/2为Trunk端口,允许VLAN 10、VLAN 11流量通过,使能Flush报文接收,并指定接收Flush报文的控制VLAN为VLAN 10和11。

[DeviceC] interface hundredgige 1/0/2

[DeviceC-HundredGigE1/0/2] port link-type trunk

[DeviceC-HundredGigE1/0/2] port trunk permit vlan 10 11

[DeviceC-HundredGigE1/0/2] undo port trunk permit vlan 1

[DeviceC-HundredGigE1/0/2] smart-link flush enable control-vlan 10 11

[DeviceC-HundredGigE1/0/2] undo shutdown

[DeviceC-HundredGigE1/0/2] quit

4.5.4  Device D的配置

# 配置端口HundredGigE1/0/1、HundredGigE1/0/2、HundredGigE1/0/3为Trunk端口,允许VLAN 10、VLAN 11的流量通过;HundredGigE1/0/1、HundredGigE1/0/2使能Flush报文接收,并指定接收Flush报文的控制VLAN为VLAN 10和11。

<DeviceD> system-view

[DeviceD] vlan 10 to 11

[DeviceD] interface hundredgige 1/0/1

[DeviceD-HundredGigE1/0/1] port link-type trunk

[DeviceD-HundredGigE1/0/1] port trunk permit vlan 10 11

[DeviceD-HundredGigE1/0/1] undo port trunk permit vlan 1

[DeviceD-HundredGigE1/0/1] smart-link flush enable control-vlan 10 11

[DeviceD-HundredGigE1/0/1] undo shutdown

[DeviceD-HundredGigE1/0/1] quit

[DeviceD] interface hundredgige 1/0/2

[DeviceD-HundredGigE1/0/2] port link-type trunk

[DeviceD-HundredGigE1/0/2] port trunk permit vlan 10 11

[DeviceD-HundredGigE1/0/2] undo port trunk permit vlan 1

[DeviceD-HundredGigE1/0/2] smart-link flush enable control-vlan 10 11

[DeviceD-HundredGigE1/0/2] undo shutdown

[DeviceD-HundredGigE1/0/2] quit

[DeviceD] interface hundredgige 1/0/3

[DeviceD-HundredGigE1/0/3] port link-type trunk

[DeviceD-HundredGigE1/0/3] port trunk permit vlan 10 11

[DeviceD-HundredGigE1/0/3] undo port trunk permit vlan 1

[DeviceD-HundredGigE1/0/3] undo shutdown

[DeviceD-HundredGigE1/0/3] quit

4.6  验证配置

(1)     当Device A正常工作时,查看Smart Link组的信息

# 查看Device A上的Smart Link组的信息。

[DeviceA] display smart-link group all

Smart link group 1 information:

  Device ID       : 0000-fc00-2500

  Preemption mode : Role

  Preemption delay: 10(s)

  Control VLAN    : 10

  Protected VLAN  : Reference Instance 1

 

  Member                  Role      State   Flush-count     Last-flush-time

  -----------------------------------------------------------------------------

  HGE1/0/1                PRIMARY   ACTIVE  0               NA

  HGE1/0/2                SECONDARY STANDBY 2               16:22:40 2014/12/29

 

Smart link group 2 information:

  Device ID       : 0000-fc00-2500

  Preemption mode : Role

  Preemption delay: 10(s)

  Control VLAN    : 11

  Protected VLAN  : Reference Instance 2

 

  Member                  Role      State   Flush-count     Last-flush-time

  -----------------------------------------------------------------------------

  HGE1/0/2                PRIMARY   ACTIVE  2               16:22:40 2014/12/29

  HGE1/0/1                SECONDARY STANDBY 0               NA

上述信息表示,在Smart Link组1中,Device A的HundredGigE1/0/1是主端口,负责转发VLAN 10的流量;在Smart Link组2中,Device A的HundredGigE1/0/2是主端口,负责转发VLAN 11的流量。

(2)     当Device A的HundredGigE1/0/1接口Down时,查看Smart Link组的信息

# 查看Device A上的Smart Link组的信息。

[DeviceA] display smart-link group all

Smart link group 1 information:

  Device ID       : 0000-fc00-2500

  Preemption mode : Role

  Preemption delay: 10(s)

  Control VLAN    : 10

  Protected VLAN  : Reference Instance 1

 

  Member                  Role      State   Flush-count     Last-flush-time

  -----------------------------------------------------------------------------

  HGE1/0/1                PRIMARY   DOWN    0               NA

  HGE1/0/2                SECONDARY ACTIVE  3               16:43:06 2014/12/29

 

Smart link group 2 information:

  Device ID       : 0000-fc00-2500

  Preemption mode : Role

  Preemption delay: 10(s)

  Control VLAN    : 11

  Protected VLAN  : Reference Instance 2

 

  Member                  Role      State   Flush-count     Last-flush-time

  -----------------------------------------------------------------------------

  HGE1/0/2                PRIMARY   ACTIVE  2               16:22:40 2014/12/29

  HGE1/0/1                SECONDARY DOWN    0               NA

上述信息表示,HundredGigE1/0/1接口Down时,在Smart Link组1中,Device A的HundredGigE1/0/2负责转发VLAN 10的流量;在Smart Link组2中,Device A的HundredGigE1/0/2仍然是主端口,负责转发VLAN 11的流量。

# 通过使用display smart-link flush命令可以查看Device B上收到的Flush报文信息。

[DeviceB] display smart-link flush

 Received flush packets                       : 1

 Receiving interface of the last flush packet : HundredGigE1/0/1

 Receiving time of the last flush packet      : 16:43:08 2014/10/29

 Device ID of the last flush packet           : 0000-fc00-2500

 Control VLAN of the last flush packet        : 10

4.7  配置文件

·     Device A:

#

vlan 1

#

vlan 10 to 11

#

stp region-configuration

 instance 1 vlan 10

 instance 2 vlan 11

 active region-configuration

#

smart-link group 1

 preemption mode role

 preemption delay 10

 flush enable control-vlan 10

 protected-vlan reference-instance 1

#

smart-link group 2

 preemption mode role

 preemption delay 10

 flush enable control-vlan 11

 protected-vlan reference-instance 2

#

interface HundredGigE1/0/1

 port link-mode bridge

 port link-type trunk

 undo port trunk permit vlan 1

 port trunk permit vlan 10 to 11

 undo stp enable

 port smart-link group 1 primary

 port smart-link group 2 secondary

#

interface HundredGigE1/0/2

 port link-mode bridge

 port link-type trunk

 undo port trunk permit vlan 1

 port trunk permit vlan 10 to 11

 undo stp enable

 port smart-link group 1 secondary

 port smart-link group 2 primary

#

interface HundredGigE1/0/3

 port link-mode bridge

 port access vlan 10

#

interface HundredGigE1/0/4

 port link-mode bridge

 port access vlan 11

#

·     Device B:

#

vlan 1

#

vlan 10 to 11

#

interface HundredGigE1/0/1

 port link-mode bridge

 port link-type trunk

 undo port trunk permit vlan 1

 port trunk permit vlan 10 to 11

 undo stp enable

 smart-link flush enable control-vlan 10 to 11

#

interface HundredGigE1/0/2

 port link-mode bridge

 port link-type trunk

 undo port trunk permit vlan 1

 port trunk permit vlan 10 to 11

 smart-link flush enable control-vlan 10 to 11

#

·     Device C:

#

vlan 1

#

vlan 10 to 11

#

interface HundredGigE1/0/1

 port link-mode bridge

 port link-type trunk

 undo port trunk permit vlan 1

 port trunk permit vlan 10 to 11

 undo stp enable

 smart-link flush enable control-vlan 10 to 11

#

interface HundredGigE1/0/2

 port link-mode bridge

 port link-type trunk

 undo port trunk permit vlan 1

 port trunk permit vlan 10 to 11

 smart-link flush enable control-vlan 10 to 11

#

·     Device D:

#

vlan 1

#

vlan 10 to 11

#

interface HundredGigE1/0/1

 port link-mode bridge

 port link-type trunk

 undo port trunk permit vlan 1

 port trunk permit vlan 10 to 11

 smart-link flush enable control-vlan 10 to 11

#

interface HundredGigE1/0/2

 port link-mode bridge

 port link-type trunk

 undo port trunk permit vlan 1

 port trunk permit vlan 10 to 11

 smart-link flush enable control-vlan 10 to 11

#

interface HundredGigE1/0/3

 port link-mode bridge

 port link-type trunk

 undo port trunk permit vlan 1

 port trunk permit vlan 10 to 11

#

5  Smart Link与Monitor Link联动配置举例

5.1  组网需求

图2所示,区域A和区域B分别使用VLAN 10和VLAN 11,出于可靠性考虑,接入层设备Device A和Device B都提供两条链路分别双上行到汇聚层设备Device C和Device D。现要求如下:

·     Device A和Device B设备通过配置Smart Link来实现链路备份。

·     当Device A到Device C和Device D的两条上行链路都正常时,区域A的数据流量优先通过Device A—>Device C的路径转发。当该链路出现故障时,Smart Link功能会将故障链路上的流量快速切换到Device A—>Device D的链路上。当链路故障恢复时,Smart Link功能又会将数据流量及时切换回原来的转发路径。

·     当Device B到Device C和Device D的两条上行链路都正常时,区域B的数据流量优先通过Device B—>Device D的路径转发。当该链路出现故障时,Smart Link功能会将故障链路上的流量快速切换到Device B—>Device C的链路上。当链路故障恢复时,Smart Link功能又会将数据流量及时切换回原来的转发路径。

·     通过配置Smart Link和Monitor Link联动,确保Device C和Device D的上行接口出现故障时能够快速感知并将下行接口的状态变为Down,触发Smart Link进行链路切换,从而最大可能地避免区域A和区域B与外部通信中断。

图2 Smart Link+Monitor Link组配置组网图

 

设备

接口

VLAN

设备

接口

VLAN

Device A

HGE1/0/1

10

Device D

HGE1/0/1

11

 

HGE1/0/2

10

 

HGE1/0/2

10、11

 

HGE1/0/3

10

 

HGE1/0/3

10

Device B

HGE1/0/1

11

Device E

HGE1/0/1

10、11

 

HGE1/0/2

11

 

HGE1/0/2

10、11

 

HGE1/0/3

11

 

HGE1/0/3

10、11

Device C

HGE1/0/1

10

 

 

 

 

HGE1/0/2

10、11

 

 

 

 

HGE1/0/3

11

 

 

 

 

5.2  配置思路

为了实现Device A和Device B的链路备份,需在Device A和Device B上分别创建一个Smart Link组,区域A和区域B的VLAN分别为这两个Smart Link组的保护VLAN。

为了实现链路故障恢复时,区域A和区域B的数据流量仍能切换回各自原来的路径转发,需要为两个Smart Link组都配置角色抢占模式。

为了避免当Smart Link组中的主从链路切换时,由于上游设备上的MAC地址转发表项和ARP/ND表项没有及时更新,而导致下行数据流量发生中断,需要在Device A和Device B上配置发送Flush报文功能,Device C和Device D的下行端口都需要使能接收Flush报文功能。

5.3  使用版本

本举例是在R2609版本上进行配置和验证的。

5.4  配置注意事项

·     如果欲配置某端口为Smart Link组的成员端口(主端口或从端口),请先手工关闭该端口,并待Smart Link组配置完成后再开启该端口,以避免形成环路,导致广播风暴。

·     在配置Smart Link组的成员端口及其直连端口之前,请确认端口未启用STP或者RRPP功能。

·     上游设备上配置的接收处理Flush报文的控制VLAN和在Smart Link设备上配置的发送控制VLAN需要相同。

·     不同的Smart Link组需要配置不同的控制VLAN。Smart Link组的控制VLAN应同时为该Smart Link组的保护VLAN,且不要将已配置为控制VLAN的VLAN删除,否则会影响Flush报文的发送。

·     一个接口只能属于一个Monitor Link组。

·     请勿通过shutdownundo shutdown命令手动开启或关闭接口来改变Monitor Link组中下行接口的状态。

5.5  配置步骤

5.5.1  Device A的配置

# 关闭端口HundredGigE1/0/1和HundredGigE1/0/2,并配置端口为Trunk端口,允许VLAN 10流量通过,并关闭STP。

<DeviceA> system-view

[DeviceA] vlan 10 to 11

[DeviceA] interface hundredgige 1/0/1

[DeviceA-HundredGigE1/0/1] shutdown

[DeviceA-HundredGigE1/0/1] port link-type trunk

[DeviceA-HundredGigE1/0/1] port trunk permit vlan 10

[DeviceA-HundredGigE1/0/1] undo port trunk permit vlan 1

[DeviceA-HundredGigE1/0/1] undo stp enable

[DeviceA-HundredGigE1/0/1] quit

[DeviceA] interface hundredgige 1/0/2

[DeviceA-HundredGigE1/0/2] shutdown

[DeviceA-HundredGigE1/0/2] port link-type trunk

[DeviceA-HundredGigE1/0/2] port trunk permit vlan 10

[DeviceA-HundredGigE1/0/2] undo port trunk permit vlan 1

[DeviceA-HundredGigE1/0/2] undo stp enable

[DeviceA-HundredGigE1/0/2] quit

# 配置端口HundredGigE1/0/3为Access端口,允许VLAN 10流量通过。

[DeviceA] interface hundredgige 1/0/3

[DeviceA-HundredGigE1/0/3] port access vlan 10

[DeviceA-HundredGigE1/0/3] quit

# 将VLAN 10映射到MSTI 1上,并激活MST域的配置。

[DeviceA] stp region-configuration

[DeviceA-mst-region] instance 1 vlan 10

[DeviceA-mst-region] active region-configuration

[DeviceA-mst-region] quit

# 创建Smart Link组1,并配置其保护VLAN为MSTI 1所映射的VLAN。

[DeviceA] smart-link group 1

[DeviceA-smlk-group1] protected-vlan reference-instance 1

# 配置端口HundredGigE1/0/1为主端口,HundredGigE1/0/2为从端口。

[DeviceA-smlk-group1] port HundredGigE 1/0/1 primary

[DeviceA-smlk-group1] port HundredGigE 1/0/2 secondary

# 使能发送Flush报文。

[DeviceA-smlk-group1] flush enable control-vlan 10

# 配置抢占模式,配置延时抢占时间为10秒。

[DeviceA-smlk-group1] preemption mode role

[DeviceA-smlk-group1] preemption delay 10

[DeviceA-smlk-group1] quit

# 开启端口HundredGigE1/0/1和HundredGigE1/0/2。

[DeviceA] interface hundredgige 1/0/1

[DeviceA-HundredGigE1/0/1] undo shutdown

[DeviceA-HundredGigE1/0/1] quit

[DeviceA] interface hundredgige 1/0/2

[DeviceA-HundredGigE1/0/2] undo shutdown

[DeviceA-HundredGigE1/0/2] quit

5.5.2  Device B的配置

# 关闭端口HundredGigE1/0/1和HundredGigE1/0/2,并配置端口为Trunk端口,允许VLAN 11流量通过,并关闭STP。

<DeviceB> system-view

[DeviceB] vlan 10 to 11

[DeviceB] interface hundredgige 1/0/1

[DeviceB-HundredGigE1/0/1] shutdown

[DeviceB-HundredGigE1/0/1] port link-type trunk

[DeviceB-HundredGigE1/0/1] port trunk permit vlan 11

[DeviceB-HundredGigE1/0/1] undo port trunk permit vlan 1

[DeviceB-HundredGigE1/0/1] undo stp enable

[DeviceB-HundredGigE1/0/1] quit

[DeviceB] interface hundredgige 1/0/2

[DeviceB-HundredGigE1/0/2] shutdown

[DeviceB-HundredGigE1/0/2] port link-type trunk

[DeviceB-HundredGigE1/0/2] port trunk permit vlan 11

[DeviceB-HundredGigE1/0/2] undo port trunk permit vlan 1

[DeviceB-HundredGigE1/0/2] undo stp enable

[DeviceB-HundredGigE1/0/2] quit

# 配置端口HundredGigE1/0/3为Access端口,分别允许VLAN 11流量通过。

[DeviceB] interface hundredgige 1/0/3

[DeviceB-HundredGigE1/0/3] port access vlan 11

[DeviceB-HundredGigE1/0/3] quit

# 将VLAN 11映射到MSTI 1上,并激活MST域的配置。

[DeviceB] stp region-configuration

[DeviceB-mst-region] instance 1 vlan 11

[DeviceB-mst-region] active region-configuration

[DeviceB-mst-region] quit

# 创建Smart Link组1,并配置其保护VLAN为MSTI 1所映射的VLAN。

[DeviceB] smart-link group 1

[DeviceB-smlk-group1] protected-vlan reference-instance 1

# 配置端口HundredGigE1/0/1为主端口,HundredGigE1/0/2为从端口。

[DeviceB-smlk-group1] port HundredGigE 1/0/1 primary

[DeviceB-smlk-group1] port HundredGigE 1/0/2 secondary

# 使能发送Flush报文。

[DeviceB-smlk-group1] flush enable control-vlan 11

# 配置抢占模式,配置延时抢占时间为10秒。

[DeviceB-smlk-group1] preemption mode role

[DeviceB-smlk-group1] preemption delay 10

[DeviceB-smlk-group1] quit

# 开启端口HundredGigE1/0/1和HundredGigE1/0/2。

[DeviceB] interface hundredgige 1/0/1

[DeviceB-HundredGigE1/0/1] undo shutdown

[DeviceB-HundredGigE1/0/1] quit

[DeviceB] interface hundredgige 1/0/2

[DeviceB-HundredGigE1/0/2] undo shutdown

[DeviceB-HundredGigE1/0/2] quit

5.5.3  Device C的配置

# 配置端口HundredGigE1/0/1为Trunk端口,允许VLAN 10流量通过,在该端口上关闭STP并使能Flush报文接收,并指定接收Flush报文的控制VLAN为VLAN 10。

<DeviceC> system-view

[DeviceC] vlan 10 to 11

[DeviceC] interface hundredgige 1/0/1

[DeviceC-HundredGigE1/0/1] port link-type trunk

[DeviceC-HundredGigE1/0/1] port trunk permit vlan 10

[DeviceC-HundredGigE1/0/1] undo port trunk permit vlan 1

[DeviceC-HundredGigE1/0/1] undo stp enable

[DeviceC-HundredGigE1/0/1] smart-link flush enable control-vlan 10

[DeviceC-HundredGigE1/0/1] undo shutdown

[DeviceC-HundredGigE1/0/1] quit

# 配置端口HundredGigE1/0/2为Trunk端口,允许VLAN 10、VLAN11流量通过,并使能Flush报文接收。

[DeviceC] interface hundredgige 1/0/2

[DeviceC-HundredGigE1/0/2] port link-type trunk

[DeviceC-HundredGigE1/0/2] port trunk permit vlan 10 11

[DeviceC-HundredGigE1/0/2] undo port trunk permit vlan 1

[DeviceC-HundredGigE1/0/2] smart-link flush enable control-vlan 10 11

[DeviceC-HundredGigE1/0/2] undo shutdown

[DeviceC-HundredGigE1/0/2] quit

# 配置端口HundredGigE1/0/3为Trunk端口,允许VLAN 11流量通过,在该端口上关闭STP并使能Flush报文接收,并指定接收Flush报文的控制VLAN为VLAN 11。

[DeviceC] interface hundredgige 1/0/3

[DeviceC-HundredGigE1/0/3] port link-type trunk

[DeviceC-HundredGigE1/0/3] port trunk permit vlan 11

[DeviceC-HundredGigE1/0/3] undo port trunk permit vlan 1

[DeviceC-HundredGigE1/0/3] undo stp enable

[DeviceC-HundredGigE1/0/3] smart-link flush enable control-vlan 11

[DeviceC-HundredGigE1/0/3] undo shutdown

[DeviceC-HundredGigE1/0/3] quit

# 创建Monitor Link组1。

[DeviceC] monitor-link group 1

# 配置触发Monitor Link组状态切换的上行接口阈值为1。

[DeviceC-mtlk-group1] uplink up-port-threshold 1

# HundredGigE1/0/2配置为上行接口,HundredGigE1/0/1和HundredGigE1/0/3配置为下行接口。

[DeviceC-mtlk-group1] port HundredGigE 1/0/2 uplink

[DeviceC-mtlk-group1] port HundredGigE 1/0/1 downlink

[DeviceC-mtlk-group1] port HundredGigE 1/0/3 downlink

[DeviceC-mtlk-group1] quit

5.5.4  Device D的配置

# 配置端口HundredGigE1/0/1为Trunk端口,允许VLAN 11流量通过,在该端口上关闭STP并使能Flush报文接收,并指定接收Flush报文的控制VLAN为VLAN 11。

<DeviceD> system-view

[DeviceD] vlan 10 to 11

[DeviceD] interface hundredgige 1/0/1

[DeviceD-HundredGigE1/0/1] port link-type trunk

[DeviceD-HundredGigE1/0/1] port trunk permit vlan 11

[DeviceD-HundredGigE1/0/1] undo port trunk permit vlan 1

[DeviceD-HundredGigE1/0/1] undo stp enable

[DeviceD-HundredGigE1/0/1] smart-link flush enable control-vlan 11

[DeviceD-HundredGigE1/0/1] undo shutdown

[DeviceD-HundredGigE1/0/1] quit

# 配置端口HundredGigE1/0/2为Trunk端口,允许VLAN 10、VLAN11流量通过,并使能Flush报文接收。

[DeviceD] interface hundredgige 1/0/2

[DeviceD-HundredGigE1/0/2] port link-type trunk

[DeviceD-HundredGigE1/0/2] port trunk permit vlan 10 11

[DeviceD-HundredGigE1/0/2] undo port trunk permit vlan 1

[DeviceD-HundredGigE1/0/2] smart-link flush enable control-vlan 10 11

[DeviceD-HundredGigE1/0/2] undo shutdown

[DeviceD-HundredGigE1/0/2] quit

# 配置端口HundredGigE1/0/3为Trunk端口,允许VLAN 10流量通过,在该端口上关闭STP并使能Flush报文接收,并指定接收Flush报文的控制VLAN为VLAN 10。

[DeviceD] interface hundredgige 1/0/3

[DeviceD-HundredGigE1/0/3] port link-type trunk

[DeviceD-HundredGigE1/0/3] port trunk permit vlan 10

[DeviceD-HundredGigE1/0/3] undo port trunk permit vlan 1

[DeviceD-HundredGigE1/0/3] undo stp enable

[DeviceD-HundredGigE1/0/3] smart-link flush enable control-vlan 10

[DeviceD-HundredGigE1/0/3] undo shutdown

[DeviceD-HundredGigE1/0/3] quit

# 创建Monitor Link组1。

[DeviceD] monitor-link group 1

# 配置触发Monitor Link组状态切换的上行接口阈值为1。

[DeviceD-mtlk-group1] uplink up-port-threshold 1

# HundredGigE1/0/2配置为上行接口,HundredGigE1/0/1和HundredGigE1/0/3配置为下行接口。

[DeviceD-mtlk-group1] port HundredGigE 1/0/2 uplink

[DeviceD-mtlk-group1] port HundredGigE 1/0/1 downlink

[DeviceD-mtlk-group1] port HundredGigE 1/0/3 downlink

[DeviceD-mtlk-group1] quit

5.5.5  Device E的配置

# 配置端口HundredGigE1/0/1、HundredGigE1/0/2、HundredGigE1/0/3为Trunk端口,允许VLAN 10、VLAN 11的流量通过;HundredGigE1/0/1、HundredGigE1/0/2使能Flush报文接收,并指定接收Flush报文的控制VLAN为VLAN 10和11。

<DeviceE> system-view

[DeviceE] vlan 10 to 11

[DeviceE] interface hundredgige 1/0/1

[DeviceE-HundredGigE1/0/1] port link-type trunk

[DeviceE-HundredGigE1/0/1] port trunk permit vlan 10 11

[DeviceE-HundredGigE1/0/1] undo port trunk permit vlan 1

[DeviceE-HundredGigE1/0/1] smart-link flush enable control-vlan 10 11

[DeviceE-HundredGigE1/0/1] undo shutdown

[DeviceE-HundredGigE1/0/1] quit

[DeviceE] interface hundredgige 1/0/2

[DeviceE-HundredGigE1/0/2] port link-type trunk

[DeviceE-HundredGigE1/0/2] port trunk permit vlan 10 11

[DeviceE-HundredGigE1/0/2] undo port trunk permit vlan 1

[DeviceE-HundredGigE1/0/2] smart-link flush enable control-vlan 10 11

[DeviceE-HundredGigE1/0/2] undo shutdown

[DeviceE-HundredGigE1/0/2] quit

[DeviceE] interface hundredgige 1/0/3

[DeviceE-HundredGigE1/0/3] port link-type trunk

[DeviceE-HundredGigE1/0/3] port trunk permit vlan 10 11

[DeviceE-HundredGigE1/0/3] undo port trunk permit vlan 1

[DeviceE-HundredGigE1/0/3] undo shutdown

[DeviceE-HundredGigE1/0/3] quit

5.6  验证配置

(1)     当Device A和Device B正常工作时,查看Smart Link组的信息

# 查看Device A上的Smart Link组的信息。

[DeviceA] display smart-link group all

Smart link group 1 information:

  Device ID       : 0000-fc00-2500

  Preemption mode : Role

  Preemption delay: 10(s)

  Control VLAN    : 10

  Protected VLAN  : Reference Instance 1

 

  Member                  Role      State   Flush-count     Last-flush-time

  -----------------------------------------------------------------------------

  HGE1/0/1                PRIMARY   ACTIVE  1               17:37:49 2014/12/29

  HGE1/0/2                SECONDARY STANDBY 3               17:43:06 2014/12/29

# 查看Device B上的Smart Link组的信息。

[DeviceB] display smart-link group all

Smart link group 1 information:

  Device ID       : 0000-fc01-2501

  Preemption mode : Role

  Preemption delay: 10(s)

  Control VLAN    : 11

  Protected VLAN  : Reference Instance 2

 

  Member                  Role      State   Flush-count     Last-flush-time

  -----------------------------------------------------------------------------

  HGE1/0/1                PRIMARY   ACTIVE  2               17:22:40 2014/12/29

  HGE1/0/2                SECONDARY STANDBY 0               NA

上述信息表示,在Device A设备的Smart Link组1中,Device A的HundredGigE1/0/1是主端口,负责转发VLAN 10的流量;在Device B设备的Smart Link组1中,Device B的HundredGigE1/0/1是主端口,负责转发VLAN 11的流量。

(2)     当Device C和Device D正常工作时,查看Monitor Link组的信息

# 查看Device C上的Monitor Link组的信息。

[DeviceC] display monitor-link group all

Monitor link group 1 information:

  Group status     : UP

  Downlink up-delay: 0(s)

  Last-up-time     : 17:07:26 2014/12/29

  Last-down-time   : -

  Up-port-threshold: 1

 

  Member                    Role       Status

  --------------------------------------------

  HGE1/0/2                  UPLINK     UP

  HGE1/0/1                  DOWNLINK   UP

  HGE1/0/3                  DOWNLINK   UP

 

# 查看Device D上的Monitor Link组的信息。

[DeviceD] display monitor-link group all

Monitor link group 1 information:

  Group status     : UP

  Downlink up-delay: 0(s)

  Last-up-time     : 17:09:33 2014/12/29

  Last-down-time   : -

  Up-port-threshold: 1

 

  Member                    Role       Status

  --------------------------------------------

  HGE1/0/2                  UPLINK     UP

  HGE1/0/1                  DOWNLINK   UP

  HGE1/0/3                  DOWNLINK   UP

上述信息表示,Device C设备的Monitor Link 1中,HundredGigE1/0/2为上行接口,HundredGigE1/0/1和HundredGigE1/0/3为下行接口;Device D设备的Monitor Link 2中,HundredGigE1/0/2为上行接口,HundredGigE1/0/1和HundredGigE1/0/3为下行接口。

(3)     当Device A的HundredGigE1/0/1接口Down时,查看Smart Link组的信息

# 查看Device A上的Smart Link组的信息。

[DeviceA] display smart-link group all

Smart link group 1 information:

  Device ID       : 0000-fc00-2500

  Preemption mode : Role

  Preemption delay: 10(s)

  Control VLAN    : 10

  Protected VLAN  : Reference Instance 1

 

  Member                  Role      State   Flush-count     Last-flush-time

  -----------------------------------------------------------------------------

  HGE1/0/1                PRIMARY   DOWN    1               17:37:49 2014/12/29

  HGE1/0/2                SECONDAR  ACTIVE  4               17:49:06 2014/12/29

上述信息表示,Device A的HundredGigE1/0/1接口Down时,在Smart Link组1中, HundredGigE1/0/2负责转发VLAN 10的流量。

# 通过使用display smart-link flush命令可以查看Device C上收到的Flush报文信息。

[DeviceC] display smart-link flush

 Received flush packets                       : 1

 Receiving interface of the last flush packet : HundredGigE1/0/1

 Receiving time of the last flush packet      : 17:49:08 2014/12/29

 Device ID of the last flush packet           : 0000-fc00-2500

 Control VLAN of the last flush packet        : 10

(4)     当Device C的上行接口HundredGigE1/0/2的状态变为Down时,查看Monitor Link组的信息

# 查看Device C上的Monitor Link组的信息。

[DeviceC] display monitor-link group all

Monitor link group 1 information:

  Group status     : DOWN

  Downlink up-delay: 0(s)

  Last-up-time     : 17:07:26 2014/12/29

  Last-down-time   : 18:01:05 2014/12/29

  Up-port-threshold: 1

 

  Member                    Role       Status

  --------------------------------------------

  HGE1/0/2                  UPLINK     DOWN

  HGE1/0/1                  DOWNLINK   DOWN

  HGE1/0/3                  DOWNLINK   DOWN

# 查看Device D上的Monitor Link组的信息。

[DeviceD] display monitor-link group all

Monitor link group 1 information:

  Group status     : UP

  Downlink up-delay: 0(s)

  Last-up-time     : 17:09:33 2014/12/29

  Last-down-time   : -

  Up-port-threshold: 1

 

  Member                    Role       Status

  --------------------------------------------

  HGE1/0/2                  UPLINK     UP

  HGE1/0/1                  DOWNLINK   UP

  HGE1/0/3                  DOWNLINK   UP

上述信息表示,Device C设备的HundredGigE1/0/2状态变为Down时,Device C上的Monitor Link 1的状态变为Down,所有下行接口的状态变为Down。

# 查看Device A上的Smart Link组的信息。

[DeviceA] display smart-link group all

Smart link group 1 information:

  Device ID       : 0000-fc00-2500

  Preemption mode : Role

  Preemption delay: 10(s)

  Control VLAN    : 10

  Protected VLAN  : Reference Instance 1

 

  Member                  Role      State   Flush-count     Last-flush-time

  -----------------------------------------------------------------------------

  HGE1/0/1                PRIMARY   DOWN    2               17:57:49 2014/12/29

  HGE1/0/2                SECONDAR  ACTIVE  5               18:01:06 2014/12/29

上述信息表示,Device A的HundredGigE1/0/1状态也变为Down,在Smart Link组1中, HundredGigE1/0/2负责转发VLAN 10的流量。

5.7  配置文件

·     Device A:

#

vlan 1

#

vlan 10

#

stp region-configuration

 instance 1 vlan 10

active region-configuration

#

smart-link group 1

 preemption mode role

 preemption delay 10

 flush enable control-vlan 10

 protected-vlan reference-instance 1

#

interface HundredGigE1/0/1

 port link-mode bridge

 port link-type trunk

 undo port trunk permit vlan 1

 port trunk permit vlan 10

 undo stp enable

 port smart-link group 1 primary

#

interface HundredGigE1/0/2

 port link-mode bridge

 port link-type trunk

 undo port trunk permit vlan 1

 port trunk permit vlan 10

 undo stp enable

 port smart-link group 1 secondary

#

interface HundredGigE1/0/3

 port link-mode bridge

 port access vlan 10

#

·     Device B:

#

vlan 1

#

vlan 11

#

stp region-configuration

 instance 1 vlan 11

active region-configuration

#

smart-link group 1

 preemption mode role

 preemption delay 10

 flush enable control-vlan 11

 protected-vlan reference-instance 1

#

interface HundredGigE1/0/1

 port link-mode bridge

 port link-type trunk

 undo port trunk permit vlan 1

 port trunk permit vlan 11

 undo stp enable

 port smart-link group 1 primary

#

interface HundredGigE1/0/2

 port link-mode bridge

 port link-type trunk

 undo port trunk permit vlan 1

 port trunk permit vlan 11

 undo stp enable

 port smart-link group 1 secondary

#

interface HundredGigE1/0/3

 port link-mode bridge

 port access vlan 11

#

·     Device C:

#

vlan 1

#

vlan 10 to 11

#

monitor-link group 1

#

interface HundredGigE1/0/1

 port link-mode bridge

 port link-type trunk

 undo port trunk permit vlan 1

 port trunk permit vlan 10

 undo stp enable

 smart-link flush enable control-vlan 10

 port monitor-link group 1 downlink

#

interface HundredGigE1/0/2

 port link-mode bridge

 port link-type trunk

 undo port trunk permit vlan 1

 port trunk permit vlan 10 to 11

 smart-link flush enable control-vlan 10 to 11

 port monitor-link group 1 uplink

#

interface HundredGigE1/0/3

 port link-mode bridge

 port link-type trunk

 undo port trunk permit vlan 1

 port trunk permit vlan 11

 undo stp enable

 smart-link flush enable control-vlan 11

 port monitor-link group 1 downlink

#

·     Device D:

#

vlan 1

#

vlan 10 to 11

#

monitor-link group 1

#

interface HundredGigE1/0/1

 port link-mode bridge

 port link-type trunk

 undo port trunk permit vlan 1

 port trunk permit vlan 11

 undo stp enable

 smart-link flush enable control-vlan 11

 port monitor-link group 1 downlink

#

interface HundredGigE1/0/2

 port link-mode bridge

 port link-type trunk

 undo port trunk permit vlan 1

 port trunk permit vlan 10 to 11

 smart-link flush enable control-vlan 10 to 11

 port monitor-link group 1 uplink

#

interface HundredGigE1/0/3

 port link-mode bridge

 port link-type trunk

 undo port trunk permit vlan 1

 port trunk permit vlan 10

 undo stp enable

 smart-link flush enable control-vlan 10

 port monitor-link group 1 downlink

#

·     Device E:

#

vlan 1

#

vlan 10 to 11

#

interface HundredGigE1/0/1

 port link-mode bridge

 port link-type trunk

 undo port trunk permit vlan 1

 port trunk permit vlan 10 to 11

 smart-link flush enable control-vlan 10 to 11

#

interface HundredGigE1/0/2

 port link-mode bridge

 port link-type trunk

 undo port trunk permit vlan 1

 port trunk permit vlan 10 to 11

 smart-link flush enable control-vlan 10 to 11

#

interface HundredGigE1/0/3

 port link-mode bridge

 port link-type trunk

 undo port trunk permit vlan 1

 port trunk permit vlan 10 to 11

#

6  在IRF中应用Smart Link典型配置举例

6.1  组网需求

图3所示,某企业财务部和市场部分别使用VLAN 10和VLAN 11接入Device A和Device B。为了扩展性考虑,接入层设备Device A和Device B组成IRF,接入汇聚层设备Device C和Device D。现要求如下:

·     接入层设备通过配置Smart Link来实现链路备份。

·     当Device A和Device B的上行链路都正常时,财务部和市场部的数据流量通过Device A—>Device C的路径进行转发;当该链路出现故障时,Smart Link功能会将故障链路上的流量快速切换到另一条链路上;当链路故障恢复时,Smart Link功能又会将数据流量及时切换回原来的转发路径。

图3 Smart Link +IRF组配置组网图

 

设备

接口

VLAN

设备

接口

VLAN

Device A

HGE1/0/1

10、11

Device B

HGE2/0/1

10、11

 

HGE1/0/3

10

 

HGE2/0/3

11

Device C

HGE1/0/1

10、11

Device D

HGE1/0/1

10、11

 

HGE1/0/2

10、11

 

HGE1/0/2

10、11

 

6.2  配置思路

为了实现Device A和Device B的链路备份,需在Device A 和Device B上创建一个Smart Link组,财务部和市场部的VLAN为这个Smart Link组的保护VLAN。

为了实现链路故障恢复时,财务部和市场部的数据流量仍能切换回各自原来的路径转发,需要为两个Smart Link组都配置角色抢占模式。

为了避免当Smart Link组中的主从链路切换时,由于上游设备上的MAC地址转发表项和ARP/ND表项没有及时更新,而导致下行数据流量发生中断,需要在Device A和Device B上配置发送Flush报文功能,Device C、Device D的HundredGigE 1/0/1端口需要使能接收Flush报文功能。

6.3  使用版本

本举例是在R2609版本上进行配置和验证的。

6.4  配置注意事项

·     如果欲配置某端口为Smart Link组的成员端口(主端口或从端口),请先手工关闭该端口,并待Smart Link组配置完成后再开启该端口,以避免形成环路,导致广播风暴。

·     在配置Smart Link组的成员端口及其直连端口之前,请确认端口未启用STP或者RRPP功能。

·     上游设备上配置的接收处理Flush报文的控制VLAN和在Smart Link设备上配置的发送控制VLAN需要相同。

·     Smart Link组的控制VLAN应同时为该Smart Link组的保护VLAN,且不要将已配置为控制VLAN的VLAN删除,否则会影响Flush报文的发送。

·     有关IRF的配置注意事项,请参见“虚拟化技术配置指导”中的“IRF”。

6.5  配置步骤

6.5.1  搭建IRF

1. Device A的配置

# 将Device A的成员编号配置为1。

<DeviceA> system-view

[DeviceA] irf member 1

# 配置IRF端口1/2,并将它与物理端口HundredGigE1/0/2绑定,并保存配置。

[DeviceA] interface gigabitethernet 1/0/2

[DeviceA-HundredGigE1/0/2] shutdown

[DeviceA-HundredGigE1/0/2] quit

[DeviceA] irf-port 1/2

[DeviceA-irf-port1/2] port group interface gigabitethernet 1/0/2

[DeviceA-irf-port1/2] quit

[DeviceA] interface gigabitethernet 1/0/2

[DeviceA-HundredGigE1/0/2] undo shutdown

[DeviceA-HundredGigE1/0/2] quit

[DeviceA] save

# 激活IRF端口下的配置。

[DeviceA] irf-port-configuration active

2. Device B的配置

# 将Device B的成员编号配置为2,并重启设备使新编号生效。

<DeviceB> system-view

[DeviceB] irf member 1 renumber 2

Warning: Renumbering the member ID may result in configuration change or loss. Continue? [Y/N]:y

[DeviceB] quit

<DeviceB> reboot

# 参照图3进行物理连线。

# 重新登录到设备,配置IRF端口2/1,并将它与物理端口HundredGigE1/0/2绑定,并保存配置。

<DeviceB> system-view

[DeviceB] interface gigabitethernet 1/0/2

[DeviceB-HundredGigE1/0/2] shutdown

[DeviceB-HundredGigE1/0/2] quit

[DeviceB] irf-port 2/1

[DeviceB-irf-port2/1] port group interface gigabitEthernet 1/0/2

[DeviceB-irf-port2/1] quit

[DeviceB] interface gigabitethernet 1/0/2

[DeviceB-HundredGigE1/0/2] undo shutdown

[DeviceB-HundredGigE1/0/2] quit

[DeviceB] save

# 激活IRF端口下的配置。

[DeviceB] irf-port-configuration active

Device A和Device B间将会进行主设备竞选,竞选失败的一方将重启,重启完成后,IRF形成。

6.5.2  配置Smart Link

1. Device A的配置

# 关闭端口HundredGigE1/0/1和HundredGigE2/0/1,并配置端口为Trunk端口,允许VLAN 10、VLAN 11流量通过,并关闭STP。

<DeviceA> system-view

[DeviceA] vlan 10 to 11

[DeviceA] interface gigabitethernet 1/0/1

[DeviceA-HundredGigE1/0/1] shutdown

[DeviceA-HundredGigE1/0/1] port link-type trunk

[DeviceA-HundredGigE1/0/1] port trunk permit vlan 10 11

[DeviceA-HundredGigE1/0/1] undo port trunk permit vlan 1

[DeviceA-HundredGigE1/0/1] undo stp enable

[DeviceA-HundredGigE1/0/1] quit

[DeviceA] interface gigabitethernet 2/0/1

[DeviceA-HundredGigE2/0/1] shutdown

[DeviceA-HundredGigE2/0/1] port link-type trunk

[DeviceA-HundredGigE2/0/1] port trunk permit vlan 10 11

[DeviceA-HundredGigE2/0/1] undo port trunk permit vlan 1

[DeviceA-HundredGigE2/0/1] undo stp enable

[DeviceA-HundredGigE2/0/1] quit

# 配置端口HundredGigE1/0/3为Access端口,允许VLAN 10流量通过。

[DeviceA] interface gigabitethernet 1/0/3

[DeviceA-HundredGigE1/0/3] port access vlan 10

[DeviceA-HundredGigE1/0/3] quit

# 配置端口HundredGigE2/0/3为Access端口,允许VLAN 11流量通过。

[DeviceA] interface gigabitethernet 2/0/3

[DeviceA-HundredGigE2/0/3] port access vlan 11

[DeviceA-HundredGigE2/0/3] quit

# 将VLAN 10和VLAN 11映射到MSTI 1上,并激活MST域的配置。

[DeviceA] stp region-configuration

[DeviceA-mst-region] instance 1 vlan 10 11

[DeviceA-mst-region] active region-configuration

[DeviceA-mst-region] quit

# 创建Smart Link组1,并配置其保护VLAN为MSTI 1所映射的VLAN。

[DeviceA] smart-link group 1

[DeviceA-smlk-group1] protected-vlan reference-instance 1

# 配置端口HundredGigE1/0/1为主端口,HundredGigE2/0/1为从端口。

[DeviceA-smlk-group1] port gigabitethernet 1/0/1 primary

[DeviceA-smlk-group1] port gigabitethernet 2/0/1 secondary

# 使能发送Flush报文。

[DeviceA-smlk-group1] flush enable control-vlan 10

# 配置抢占模式,配置延时抢占时间为10秒。

[DeviceA-smlk-group1] preemption mode role

[DeviceA-smlk-group1] preemption delay 10

[DeviceA-smlk-group1] quit

# 开启端口HundredGigE1/0/1和HundredGigE2/0/1。

[DeviceA] interface gigabitethernet 1/0/1

[DeviceA-HundredGigE1/0/1] undo shutdown

[DeviceA-HundredGigE1/0/1] quit

[DeviceA] interface gigabitethernet 2/0/1

[DeviceA-HundredGigE2/0/1] undo shutdown

[DeviceA-HundredGigE2/0/1] quit

2. Device C的配置

# 配置端口HundredGigE1/0/1为Trunk端口,允许VLAN 10和11流量通过,在该端口上关闭STP并使能Flush报文接收,并指定接收Flush报文的控制VLAN为VLAN 10和11。

<DeviceC> system-view

[DeviceC] vlan 10 to 11

[DeviceC] interface hundredgige 1/0/1

[DeviceC-HundredGigE1/0/1] port link-type trunk

[DeviceC-HundredGigE1/0/1] port trunk permit vlan 10 11

[DeviceC-HundredGigE1/0/1] undo port trunk permit vlan 1

[DeviceC-HundredGigE1/0/1] undo stp enable

[DeviceC-HundredGigE1/0/1] smart-link flush enable control-vlan 10 11

[DeviceC-HundredGigE1/0/1] undo shutdown

[DeviceC-HundredGigE1/0/1] quit

# 配置端口HundredGigE1/0/2为Trunk端口,允许VLAN 10和11流量通过,使能Flush报文接收,并指定接收Flush报文的控制VLAN为VLAN 10和11。

[DeviceC] interface hundredgige 1/0/2

[DeviceC-HundredGigE1/0/2] port link-type trunk

[DeviceC-HundredGigE1/0/2] port trunk permit vlan 10 11

[DeviceC-HundredGigE1/0/2] undo port trunk permit vlan 1

[DeviceC-HundredGigE1/0/2] smart-link flush enable control-vlan 10 11

[DeviceC-HundredGigE1/0/2] undo shutdown

[DeviceC-HundredGigE1/0/2] quit

3. Device D的配置

# 配置端口HundredGigE1/0/1为Trunk端口,允许VLAN 10和11流量通过,在该端口上关闭STP并使能Flush报文接收,并指定接收Flush报文的控制VLAN为VLAN 10和11。

<DeviceD> system-view

[DeviceD] vlan 10 to 11

[DeviceD] interface hundredgige 1/0/1

[DeviceD-HundredGigE1/0/1] port link-type trunk

[DeviceD-HundredGigE1/0/1] port trunk permit vlan 10 11

[DeviceD-HundredGigE1/0/1] undo port trunk permit vlan 1

[DeviceD-HundredGigE1/0/1] undo stp enable

[DeviceD-HundredGigE1/0/1] smart-link flush enable control-vlan 10 11

[DeviceD-HundredGigE1/0/1] undo shutdown

[DeviceD-HundredGigE1/0/1] quit

# 配置端口HundredGigE1/0/2为Trunk端口,允许VLAN 10和11流量通过,并使能Flush报文接收,并指定接收Flush报文的控制VLAN为VLAN 10和11。

[DeviceD] interface hundredgige 1/0/2

[DeviceD-HundredGigE1/0/2] port link-type trunk

[DeviceD-HundredGigE1/0/2] port trunk permit vlan 10 11

[DeviceD-HundredGigE1/0/2] undo port trunk permit vlan 1

[DeviceD-HundredGigE1/0/2] smart-link flush enable control-vlan 10 11

[DeviceD-HundredGigE1/0/2] undo shutdown

[DeviceD-HundredGigE1/0/2] quit

6.6  验证配置

(1)     配置完成后,查看IRF的相关信息

# 在Device A上查看IRF的相关信息。(集中式设备)

<Sysname> display irf

MemberID  Role     Priority    CPU-Mac           Description

 *+1      Master   1           0210-fc01-0001    -----

   2      Standby  1           0210-fc02-0002    -----

--------------------------------------------------------

 

 * indicates the device is the master.

 + indicates the device through which the user logs in.

 

 The Bridge MAC of the IRF is: 00e0-fc00-1000

 Auto upgrade                   : yes

 Mac persistent                 : 6 min

 Domain ID                      : 0

 IRF mode                       : normal

以上显示信息表明IRF已经成功建立。

# 在Device A上查看IRF的相关信息。(分布式设备)

[DeviceA] display irf

MemberID  Slot  Role    Priority  CPU-Mac         Description

 *+1      1     Master  1         0210-fc01-0001  -----

   2      0     Standby 1         0210-fc02-0002  -----

--------------------------------------------------

 * indicates the device is the master.

 + indicates the device through which the user logs in.

 

 The bridge MAC of the IRF is: 00e0-fc00-c518

 Auto upgrade                : yes

 Mac persistent              : 6 min

 Domain ID                   : 0

 Auto merge                  : yes

 IRF mode                    : normal

以上显示信息表明IRF已经成功建立。

(2)     当Device A正常工作时,查看Smart Link组的信息

# 查看Device A上的Smart Link组的信息。

[DeviceA] display smart-link group all

Smart link group 1 information:

  Device ID       : 00e0-fc00-c518

  Preemption mode : Role

  Preemption delay: 10(s)

  Control VLAN    : 10

  Protected VLAN  : Reference Instance 1

 

  Member                  Role      State   Flush-count     Last-flush-time

  -----------------------------------------------------------------------------

  HGE1/0/1                PRIMARY   ACTIVE  3               18:16:44 2014/12/29

  HGE2/0/1                SECONDARY STANDBY 0               NA

上述信息表示,在Smart Link组1中,Device A的HundredGigE1/0/1是主端口,负责转发VLAN 10和VLAN 11的流量,Device B的HundredGigE2/0/1是从端口,作为备份端口。

(3)     当Device A的HundredGigE1/0/1接口Down时,查看Smart Link组的信息

# 查看Device A上的Smart Link组的信息。

[DeviceA] display smart-link group all

Smart link group 1 information:

  Device ID       : 00e0-fc00-c518

  Preemption mode : Role

  Preemption delay: 10(s)

  Control VLAN    : 10

  Protected VLAN  : Reference Instance 1

 

  Member                  Role      State   Flush-count     Last-flush-time

  -----------------------------------------------------------------------------

  HGE1/0/1                PRIMARY   DOWN    3               18:16:44 2014/12/29

  HGE2/0/1                SECONDARY ACTIVE  1               18:22:37 2014/12/29

上述信息表示,Device A的HundredGigE1/0/1接口Down时,在Smart Link组1中,Device B的HundredGigE2/0/1负责转发VLAN 10和VLAN 11的流量。

# 通过使用display smart-link flush命令可以查看Device C上收到的Flush报文信息。

[DeviceC] display smart-link flush

 Received flush packets                       : 1

 Receiving interface of the last flush packet : HundredGigE1/0/1

 Receiving time of the last flush packet      : 18:22:39 2014/12/29

 Device ID of the last flush packet           : 00e0-fc00-c518

 Control VLAN of the last flush packet        : 10

# 通过使用display smart-link flush命令可以查看Device D上收到的Flush报文信息。

[DeviceD] display smart-link flush

 Received flush packets                       : 1

 Receiving interface of the last flush packet : HundredGigE1/0/1

 Receiving time of the last flush packet      : 18:22:38 2014/12/29

 Device ID of the last flush packet           : 00e0-fc00-c518

 Control VLAN of the last flush packet        : 10

6.7  配置文件

·     Device A

#

 sysname DeviceA

#

vlan 10 to 11

#

 irf mac-address persistent always

 irf auto-update enable

 irf auto-merge enable

 undo irf link-delay

 irf member 1 priority 1

 irf member 2 priority 1

 irf mode normal

#

irf-port 1/2

 port group 1 interface HundredGigE1/0/2

 port group mdc 1 interface HundredGigE1/0/2

#

irf-port 2/1

 port group 1 interface HundredGigE2/0/2

 port group mdc 1 interface HundredGigE2/0/2

#

stp region-configuration

 instance 1 vlan 10 to 11

 active region-configuration

#

smart-link group 1

 preemption mode role

 preemption delay 10

 flush enable control-vlan 10

 protected-vlan reference-instance 1

#

interface HundredGigE1/0/1

 port link-mode bridge

 port link-type trunk

 undo port trunk permit vlan 1

 port trunk permit vlan 10 to 11

 undo stp enable

 port smart-link group 1 primary

#

interface HundredGigE1/0/3

 port link-mode bridge

 port access vlan 10

#

interface HundredGigE2/0/1

 port link-mode bridge

 port link-type trunk

 undo port trunk permit vlan 1

 port trunk permit vlan 10 to 11

 undo stp enable

port smart-link group 1 secondary

#

interface HundredGigE2/0/3

 port link-mode bridge

 port access vlan 11

#

·     Device C

#

 sysname DeviceC

#

vlan 10 to 11

#

interface HundredGigE1/0/1

 port link-mode bridge

 port link-type trunk

 undo port trunk permit vlan 1

 port trunk permit vlan 10 to 11

 undo stp enable

 smart-link flush enable control-vlan 10 to 11

#

interface HundredGigE1/0/2

 port link-mode bridge

 port link-type trunk

 undo port trunk permit vlan 1

 port trunk permit vlan 10 to 11

 smart-link flush enable control-vlan 10 to 11

#

·     Device D

#

 sysname DeviceD

#

vlan 10 to 11

#

interface HundredGigE1/0/1

 port link-mode bridge

 port link-type trunk

 undo port trunk permit vlan 1

 port trunk permit vlan 10 to 11

 undo stp enable

 smart-link flush enable control-vlan 10 to 11

#

interface HundredGigE1/0/2

 port link-mode bridge

 port link-type trunk

 undo port trunk permit vlan 1

 port trunk permit vlan 10 to 11

 smart-link flush enable control-vlan 10 to 11

#

7  相关资料

·     H3C S12500X-AF系列交换机 二层技术-以太网交换配置指导-R26xx

·     H3C S12500X-AF系列交换机 二层技术-以太网交换命令参考-R26xx

·     H3C S12500X-AF系列交换机 可靠性配置指导-R26xx

·     H3C S12500X-AF系列交换机 可靠性命令参考-R26xx

·     H3C S12500X-AF系列交换机 虚拟化技术配置指导-R26xx

·     H3C S12500X-AF系列交换机 虚拟化技术命令参考-R26xx

不同款型规格的资料略有差异, 详细信息请向具体销售和400咨询。H3C保留在没有任何通知或提示的情况下对资料内容进行修改的权利!

联系我们