• 产品与解决方案
  • 行业解决方案
  • 服务
  • 支持
  • 合作伙伴
  • 新华三人才研学中心
  • 关于我们

H3C S12500X-AF系列交换机 典型配置举例(R26xx系列)-6W100

目录

09-VLAN典型配置举例

本章节下载 09-VLAN典型配置举例  (164.13 KB)

docurl=/cn/Service/Document_Software/Document_Center/Switches/Catalog/S12500/S12500X-AF/Configure/Typical_Configuration_Example/H3C_S12500X-AF_CE(R26xx)-6W100/201703/976263_30005_0.htm

09-VLAN典型配置举例

H3C S12500X-AF产品VLAN典型配置举例

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

H3C_彩色.emf

 



1  简介

本文档介绍基于端口的VLAN的典型应用场景和配置举例。

2  配置前提

本文档中的配置均是在实验室环境下进行的配置和验证,配置前设备的所有参数均采用出厂时的缺省配置。如果您已经对设备进行了配置,为了保证配置效果,请确认现有配置和以下举例中的配置不冲突。

本文档假设您已了解VLAN特性。

3  基于端口的VLAN典型配置举例

3.1  组网需求

图1所示,Host A和Host C属于部门A,但是通过不同的设备接入公司网络;Host B和Host D属于部门B,也通过不同的设备接入公司网络。为了通信的安全性,以及避免广播报文泛滥,公司网络中使用VLAN技术来隔离部门间的二层流量。其中部门A使用VLAN 100,部门B使用VLAN 200。

现要求同一VLAN内的主机能够互通,即Host A和Host C能够互通,Host B和Host D能够互通。

图1 基于端口的VLAN组网图

 

3.2  使用版本

本举例是在R2609版本上进行配置和验证的。

3.3  配置步骤

(1)     配置Device A

# 创建VLAN 100,并将HundredGigE1/0/11加入VLAN 100。

<DeviceA> system-view

[DeviceA] interface hundredgige 1/0/11

[DeviceA-HundredGigE1/0/11] undo shutdown

[DeviceA-HundredGigE1/0/11] quit

[DeviceA] vlan 100

[DeviceA-vlan100] port HundredGigE 1/0/11

[DeviceA-vlan100] quit

# 创建VLAN 200,并将HundredGigE1/0/12加入VLAN 200。

[DeviceA] interface hundredgige 1/0/12

[DeviceA-HundredGigE1/0/12] undo shutdown

[DeviceA-HundredGigE1/0/12] quit

[DeviceA] vlan 200

[DeviceA-vlan200] port HundredGigE 1/0/12

[DeviceA-vlan200] quit

# 为了使Device A上VLAN 100和VLAN 200的报文能发送给Device B,将HundredGigE1/0/13的链路类型配置为Trunk,并允许VLAN 100和VLAN 200的报文通过。

[DeviceA] interface HundredGigE 1/0/13

[DeviceA-HundredGigE1/0/13] port link-type trunk

[DeviceA-HundredGigE1/0/13] port trunk permit vlan 100 200

[DeviceA-HundredGigE1/0/13] undo shutdown

(2)     Device B上的配置与Device A上的配置相同,不再赘述。

(3)     将Host A和Host C配置在一个网段,例如192.168.100.0/24;将Host B和Host D配置在一个网段,比如192.168.200.0/24。

3.4  验证配置

(1)     Host A和Host C能够互相ping通,但是均不能ping通Host B。Host B和Host D能够互相ping通,但是均不能ping通Host A。

(2)     通过查看显示信息验证配置是否成功。

# 查看Device A上VLAN 100和VLAN 200的配置信息,VLAN 100的报文仅允许通过接口HGE1/0/13和HGE1/0/11,VLAN 200的报文仅允许通过接口HGE1/0/13和HGE1/0/12。

[DeviceA-HundredGigE1/0/13] display vlan 100

 VLAN ID: 100

 VLAN type: Static

 Route interface: Not configured

 Description: VLAN 0100

 Name: VLAN 0100

 Tagged ports:

    HundredGigE1/0/13

 Untagged ports:

    HundredGigE1/0/11

[DeviceA-HundredGigE1/0/13] display vlan 200

 VLAN ID: 200

 VLAN type: Static

 Route interface: Not configured

 Description: VLAN 0200

 Name: VLAN 0200

 Tagged ports:

    HundredGigE1/0/13

 Untagged ports:

    HundredGigE1/0/12

3.5  配置文件

Device B上的配置与Device A上的配置相同,此处仅以Device A的配置文件举例。

#

vlan 100

#

vlan 200

#

interface HundredGigE1/0/11

 port link-mode bridge

 port access vlan 100

#

interface HundredGigE1/0/12

 port link-mode bridge

 port access vlan 200

#

interface HundredGigE1/0/13

 port link-mode bridge

 port link-type trunk

 port trunk permit vlan 1 100 200

#

4  相关资料

·     H3C S12500X-AF系列交换机 二层技术-以太网交换机配置指导-R26xx

·     H3C S12500X-AF系列交换机 二层技术-以太网交换机命令参考-R26xx

 

不同款型规格的资料略有差异, 详细信息请向具体销售和400咨询。H3C保留在没有任何通知或提示的情况下对资料内容进行修改的权利!

联系我们