H3C S12500X-AF系列交换机 典型配置举例(R26xx系列)-6W100

目录

48-SPBM典型配置举例

本章节下载 48-SPBM典型配置举例  (318.45 KB)

docurl=/cn/Service/Document_Software/Document_Center/Switches/Catalog/S12500/S12500X-AF/Configure/Typical_Configuration_Example/H3C_S12500X-AF_CE(R26xx)-6W100/201703/976302_30005_0.htm

48-SPBM典型配置举例

H3C S12500X-AF产品SPBM配置举例

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

H3C_彩色.emf



1  简介

本文档介绍了SPBM(Shortest Path Bridging MAC,最短路径桥MAC模式)的配置举例。

2  配置前提

本文档中的配置均是在实验室环境下进行的配置和验证,配置前设备的所有参数均采用出厂时的缺省配置。如果您已经对设备进行了配置,为了保证配置效果,请确认现有配置和以下举例中的配置不冲突。

本文假设您已了解SPBM特性。

3  使用限制

·     SPBM功能受License限制,请在使用本功能前安装有效的License。有关License的详细介绍,请参见“基础配置指导”中的“License管理”。

·     配置SPBM时,要求生成树的工作模式使用MSTP模式(缺省模式)。

·     所有使能了SPBM协议的设备必须将B-VLAN映射到MSTI 4092实例且设备间链路可达才能互相建立SPBM邻居关系;另外,它们必须属于同一MST域才能使邻居间的链路承载流量。有关MST域、MSTI的介绍,请参见“二层技术-以太网交换配置指导”中的“生成树”。

·     SPBM控制报文为Untagged报文,为了不影响SPBM控制报文的转发,请在使能SPBM功能的接口上配置允许PVID通过,并保证该PVID在设备上已创建。

·     对于IRF设备,配置SPBM时,必须通过irf mac-address persistent always命令配置IRF的桥MAC永久保留。

·     BEB设备的上行口和BCB设备的接口要求为Trunk/Hybrid类型,且允许所有B-VLAN带Tag通过。

·     当SPBN中的B-MAC与用户静态配置的MAC存在冲突时,用户需手动删除冲突的静态MAC,在解决冲突前SPBM报文会转发不通。

4  SPBM典型配置举例

4.1  组网需求

图1所示:

·     BEB 1、BEB 2、BEB 3、BEB 4分别为Site 1、2、3、4的SPBN接入设备。Site 1、2、3、4都属于VLAN 100。

·     所有BEB设备使用I-SID为3001的SPB VSI来承载Site之间的二层流量。该 VSI使用B-VLAN 3001传输数据。

要求通过SPBM功能实现各Site间二层互通。由于SPBN中组播流量较多,要求I-SID为3001的VSI采用核心复制组播转发模式。

图1 SPBN组网图

 

说明

图1中BCB 2的端口编号规则与BCB 1相同,BEB 2~4的端口编号规则与BEB 1相同。

 

4.2  使用版本

本举例是在R2609版本上进行配置和验证的。

4.3  配置注意事项

·     SPBN设备(包括BCB和BEB设备)必须在同一个MST域,因此要对这些设备配置相同的如下参数:

¡     域名(本例中配置为spb)

¡     修订级别(缺省情况下MSTP的修订级别为0,无需配置)

¡     VLAN映射表(本例将B-VLAN 3001映射到MSTI 4092上)

·     配置SPBM组播转发模式时,要求SPBN中所有SPBM设备的组播转发模式保持一致。

4.4  配置步骤

4.4.1  配置BEB 1

# 创建VLAN 100和VLAN 3001。

<BEB1> system-view

[BEB1] vlan 100

[BEB1-vlan100] quit

[BEB1] vlan 3001

[BEB1-vlan3001] quit

# 激活MST 4092实例:将VLAN 3001加入4092实例,实例名称为spb。

[BEB1] stp region-configuration

[BEB1-mst-region] region-name spb

[BEB1-mst-region] instance 4092 vlan 3001

[BEB1-mst-region] active region-configuration

[BEB1-mst-region] quit

# 全局使能SPBM功能。在所有公网侧接口上使能SPBM功能,并允许B-VLAN 3001的流量通过。

[BEB1] spbm

[BEB1-spbm] quit

[BEB1] interface range HundredGigE 1/1/0/2 to HundredGigE 1/1/0/3

[BEB1-if-range] port link-type trunk

[BEB1-if-range] port trunk permit vlan 3001

[BEB1-if-range] spbm enable

[BEB1-if-range] quit

# 配置用户侧基本功能:使能L2VPN,创建名为test的SPB VSI(I-SID 3001)并为该VSI指定B-VLAN 3001,配置该VSI的组播复制模式为核心复制;配置下行口HundredGigE1/1/0/1,将用户侧从该接口进入的VLAN 100流量映射到该VSI。

[BEB1] l2vpn enable

[BEB1] vsi test

[BEB1-vsi-test] spb i-sid 3001

[BEB1-vsi-test-3001] b-vlan 3001

[BEB1-vsi-test-3001] multicast replicate-mode tandem

[BEB1-vsi-test-3001] quit

[BEB1-vsi-test] quit

[BEB1] interface HundredGigE1/1/0/1

[BEB1-HundredGigE1/1/0/1] port link-type trunk

[BEB1-HundredGigE1/1/0/1] port trunk permit vlan 100

[BEB1-HundredGigE1/1/0/1] service-instance 1

[BEB1-HundredGigE1/1/0/1-srv1] encapsulation s-vid 100

[BEB1-HundredGigE1/1/0/1-srv1] xconnect vsi test

[BEB1-HundredGigE1/1/0/1-srv1] quit

[BEB1-HundredGigE1/1/0/1] quit

4.4.2  配置BEB 2、BEB 3、BEB 4

其他BEB设备的配置与BEB 1相同。

4.4.3  配置BCB 1

# 创建VLAN 3001。

<BCB1> system-view

[BCB1] vlan 3001

[BCB1-vlan3001] quit

# 激活MST 4092实例:将VLAN 3001加入4092实例,实例名称为spb。

[BCB1] stp region-configuration

[BCB1-mst-region] region-name spb

[BCB1-mst-region] instance 4092 vlan 3001

[BCB1-mst-region] active region-configuration

[BCB1-mst-region] quit

# 全局使能SPBM功能。在所有接口上使能SPBM功能,并允许B-VLAN 3001的流量通过。

[BCB1] spbm

[BCB1-spbm] quit

[BCB1] interface range HundredGigE 1/1/0/1 to HundredGigE 1/1/0/4

[BCB1-if-range] port link-type trunk

[BCB1-if-range] port trunk permit vlan 3001

[BCB1-if-range] spbm enable

[BCB1-if-range] quit

4.4.4  配置BCB 2

BCB 2的配置与BCB 1相同。

4.5  验证配置

# 查看SPBM邻居信息(以BEB1为例,其他BEB使用相同命令查看)。

[BEB1] display spbm peer

                           Peer information for SPBM

                           -------------------------

 System ID         Port                        Circuit ID    State    Holdtime

 0011.2200.1501    HGE1/1/0/2                  2             Up       29s

 0011.2200.1601    HGE1/1/0/3                  3             Up       29s

其中0011.2200.1501和0011.2200.1601分别为BCB 1和BCB 2的System ID。以上信息表明,BEB 1已和BCB 1及BCB 2建立邻居关系。

# 查看名为test的VSI的详细信息。

[BEB1] display l2vpn vsi name test verbose

VSI Name: test

  VSI Index               : 0

  VSI State               : Up

  MTU                     : 1500

  Bandwidth               : -

  Broadcast Restrain      : 4294967295 kbps

  Multicast Restrain      : 4294967295 kbps

  Unknown Unicast Restrain: 4294967295 kbps

  MAC Learning            : Enabled

  MAC Table Limit         : -

  Drop Unknown            : -

  SPB I-SID               : 3001

  SPB Connections:

    BMAC            BVLAN            Link ID    Type

    0011-2200-1201  3001             64         Unicast

    0011-2200-1301  3001             65         Unicast

    0011-2200-1401  3001             66         Unicast

    6380-ff00-0bb9  3001             -          Multicast

  ACs:

    AC                               Link ID    State    Type

    HGE1/1/0/1 srv1                  0          Up       Manual

其中0011-2200-1201为BEB 2的MAC地址,0011-2200-1301为BEB 3的MAC地址,0011-2200-1401为BEB 4的MAC地址。以上信息表明,BEB 1与其他BEB间已成功建立MAC-in-MAC类型的隧道。其中Type为Multicast的隧道由核心复制模式所产生。

4.6  配置文件

·     BEB 1、BEB 2、BEB 3、BEB 4

vlan 100

#

vlan 3001

#

stp region-configuration

 region-name spb

 instance 4092 vlan 3001

 active region-configuration

#

spbm

#

l2vpn enable

#

vsi test

 spb i-sid 3001

  b-vlan 3001

  multicast replicate-mode tandem

#

interface HundredGigE1/1/0/1

 port link-mode bridge

 port link-type trunk

 port trunk permit vlan 1 100

 service-instance 1

  encapsulation s-vid 100

  xconnect vsi test

#

interface HundredGigE1/1/0/2

 port link-mode bridge

 port link-type trunk

 port trunk permit vlan 1 3001

 spbm enable

#

interface HundredGigE1/1/0/3

 port link-mode bridge

 port link-type trunk

 port trunk permit vlan 1 3001

 spbm enable

#

·     BCB 1、BCB 2

vlan 3001

#

stp region-configuration

 region-name spb

 instance 4092 vlan 3001

 active region-configuration

#

spbm

#

interface HundredGigE1/1/0/1

 port link-mode bridge

 port link-type trunk

 port trunk permit vlan 1 3001

 spbm enable

#

interface HundredGigE1/1/0/2

 port link-mode bridge

 port link-type trunk

 port trunk permit vlan 1 3001

 spbm enable

#

interface HundredGigE1/1/0/3

 port link-mode bridge

 port link-type trunk

 port trunk permit vlan 1 3001

 spbm enable

#

interface HundredGigE1/1/0/4

 port link-mode bridge

 port link-type trunk

 port trunk permit vlan 1 3001

 spbm enable

#

5  SPBM组播头端复制配置举例

5.1  组网需求

图2所示:

·     BEB 1、BEB 2、BEB 3分别为Site 1、2、3的SPBN接入设备,Site 1、2、3都属于VLAN 100。

·     BEB 1、BEB 2、BEB 3使用I-SID为3001的SPB VSI来承载Site之间的二层流量。该VSI使用B-VLAN 3001传输数据。

要求通过SPBM功能实现各Site间二层互通。由于网络规模小,组播流量较少,要求I-SID为3001的VSI采用头端复制组播转发模式。

图2 SPBN组网图

 

5.2  使用版本

本举例是在R2609版本上进行配置和验证的。

5.3  配置注意事项

·     SPBN设备(包括BCB和BEB设备)必须在同一个MST域,因此要对这些设备配置相同的如下参数:

¡     域名(本例中配置为spb)

¡     修订级别(缺省情况下MSTP的修订级别为0,无需配置)

¡     VLAN映射表(本例将B-VLAN 3001映射到MSTI 4092上)

·     要求SPBN中所有SPBM设备的组播转发模式保持一致。

5.4  配置步骤

5.4.1  配置BEB 1

# 创建VLAN 100和 VLAN 3001。

<BEB1> system-view

[BEB1] vlan 100

[BEB1-vlan100] quit

[BEB1] vlan 3001

[BEB1-vlan3001] quit

# 激活MST 4092实例:将VLAN 3001加入4092实例,实例名称为spb。

[BEB1] stp region-configuration

[BEB1-mst-region] region-name spb

[BEB1-mst-region] instance 4092 vlan 3001

[BEB1-mst-region] active region-configuration

[BEB1-mst-region] quit

# 全局使能SPBM功能。在公网侧接口HundredGigE1/1/0/2上使能SPBM功能,并允许B-VLAN 3001的流量通过。

[BEB1] spbm

[BEB1-spbm] quit

[BEB1] interface HundredGigE1/1/0/2

[BEB1-HundredGigE1/1/0/2] port link-type trunk

[BEB1-HundredGigE1/1/0/2] port trunk permit vlan 3001

[BEB1-HundredGigE1/1/0/2] spbm enable

[BEB1-HundredGigE1/1/0/2] quit

# 配置用户侧基本功能:使能L2VPN,创建名为test的SPB VSI(I-SID 3001)并为该VSI指定B-VLAN 3001;缺省情况下,SPB VSI的组播转发模式为头端复制模式,无需配置;配置下行口HundredGigE1/1/0/1,将用户侧从该接口进入的VLAN 100流量映射到名为test的VSI。

[BEB1] l2vpn enable

[BEB1] vsi test

[BEB1-vsi-test] spb i-sid 3001

[BEB1-vsi-test-3001] b-vlan 3001

[BEB1-vsi-test-3001] quit

[BEB1-vsi-test] quit

[BEB1] interface HundredGigE1/1/0/1

[BEB1-HundredGigE1/1/0/1] port link-type trunk

[BEB1-HundredGigE1/1/0/1] port trunk permit vlan 100

[BEB1-HundredGigE1/1/0/1] service-instance 1

[BEB1-HundredGigE1/1/0/1-srv1] encapsulation s-vid 100

[BEB1-HundredGigE1/1/0/1-srv1] xconnect vsi test

[BEB1-HundredGigE1/1/0/1-srv1] quit

[BEB1-HundredGigE1/1/0/1] quit

5.4.2  配置BEB 2、BEB 3

BEB 2、BEB 3的配置与BEB 1相同。

5.4.3  配置BCB

# 创建VLAN 3001。

<BCB> system-view

[BCB] vlan 3001

[BCB-vlan3001] quit

# 激活MST 4092实例:将VLAN 3001加入4092实例,实例名称为spb。

[BCB] stp region-configuration

[BCB-mst-region] region-name spb

[BCB-mst-region] instance 4092 vlan 3001

[BCB-mst-region] active region-configuration

[BCB-mst-region] quit

# 全局使能SPBM功能。在所有接口上使能SPBM功能,并允许B-VLAN 3001的流量通过。

[BCB] spbm

[BCB-spbm] quit

[BCB] interface range HundredGigE 1/1/0/1 to HundredGigE 1/1/0/3

[BCB-if-range] port link-type trunk

[BCB-if-range] port trunk permit vlan 3001

[BCB-if-range] spbm enable

[BCB-if-range] quit

5.5  验证配置

# 查看SPBM邻居信息(以BEB1为例,其他BEB使用相同命令查看)。

[BEB1] display spbm peer

                           Peer information for SPBM

                           -------------------------

 System ID         Port                        Circuit ID    State    Holdtime

 0000.eeee.0101    HGE1/1/0/2                  2             Up       29s

其中0000.eeee.0101为BCB的System ID。以上信息表明,BEB 1已和BCB建立邻居关系。

# 查看名为test的VSI的详细信息。

[BEB1] display l2vpn vsi name test verbose

VSI Name: test

  VSI Index               : 0

  VSI State               : Up

  MTU                     : 1500

  Bandwidth               : -

  Broadcast Restrain      : 4294967295 kbps

  Multicast Restrain      : 4294967295 kbps

  Unknown Unicast Restrain: 4294967295 kbps

  MAC Learning            : Enabled

  MAC Table Limit         : -

  Drop Unknown            : -

  SPB I-SID               : 3001

  SPB Connections:

    BMAC            BVLAN            Link ID    Type

    0000-eeee-0141  3001             64         Unicast

    0000-9999-0141  3001             65         Unicast

  ACs:

    AC                               Link ID    State    Type

    HGE1/1/0/1 srv1                  0          Up       Manual

其中0000-eeee-0141为BEB 2的MAC地址,0000-9999-0141为BEB 3的MAC地址。以上信息表明,BEB 1与其他BEB间已成功建立MAC-in-MAC类型的隧道。

5.6  配置文件

·     BEB 1、BEB 2、BEB 3

vlan 100

#

vlan 3001

#

stp region-configuration

 region-name spb

 instance 4092 vlan 3001

 active region-configuration

#

spbm

#

l2vpn enable

#

vsi test

 spb i-sid 3001

  b-vlan 3001

#

interface HundredGigE1/1/0/1

 port link-mode bridge

 port link-type trunk

 port trunk permit vlan 1 100

 service-instance 1

  encapsulation s-vid 100

  xconnect vsi test

#

interface HundredGigE1/1/0/2

 port link-mode bridge

 port link-type trunk

 port trunk permit vlan 1 3001

 spbm enable

#

·     BCB

vlan 3001

#

stp region-configuration

 region-name spb

 instance 4092 vlan 3001

 active region-configuration

#

spbm

#

interface HundredGigE1/1/0/1

 port link-mode bridge

 port link-type trunk

 port trunk permit vlan 1 3001

 spbm enable

#

interface HundredGigE1/1/0/2

 port link-mode bridge

 port link-type trunk

 port trunk permit vlan 1 3001

 spbm enable

#

interface HundredGigE1/1/0/3

 port link-mode bridge

 port link-type trunk

 port trunk permit vlan 1 3001

 spbm enable

#

6  ECT迁移配置举例

6.1  组网需求

SPBN已实现“SPBM典型配置举例”中的组网需求,现需要将I-SID 3001的流量从B-VLAN 3001迁移至B-VLAN 3003,使用ECT 9算法来决策转发路径。

图3 SPBN组网图

 

6.2  配置思路

ECT迁移的目标是达到流量精细调整,同时在转发路径切换过程中尽可能少丢包。其基本思想是新建一条转发路径,在新路径建立的过程中流量一直走原路径(即,用B-VLAN 3001承载流量),新路径建好之后流量平滑切换至新路径。具体步骤如下:

(1)     整网新增B-VLAN 3003,并将该B-VLAN加入MSTI 4092,同时配置设备公网侧接口允许通过该B-VLAN的流量。

(2)     整网新增B-VLAN 3003与ECT 9算法的映射关系(相关命令为ect,缺省情况下所有B-VLAN映射到ECT 1)。

(3)     保证整网都正确配置B-VLAN与ECT算法的映射关系后,在所有BEB设备上修改SPB VSI(I-SID 3001)指定的B-VLAN为3003。整网BEB都修改后,流量将完全切到新的B-VLAN 3003。

6.3  使用版本

本举例是在R2609版本上进行配置和验证的。

6.4  ECT迁移前的配置步骤

6.4.1  配置BEB 1

# 创建B-VLAN 3003。

<BEB1> system-view

[BEB1] vlan 3003

[BEB1-vlan3003] quit

# 将B-VLAN 3003加入4092实例。

[BEB1] stp region-configuration

[BEB1-mst-region] instance 4092 vlan 3003

[BEB1-mst-region] active region-configuration

[BEB1-mst-region] quit

# 配置所有公网侧接口允许B-VLAN 3003的流量通过。

[BEB1] interface range HundredGigE 1/1/0/2 to HundredGigE 1/1/0/3

[BEB1-if-range] port trunk permit vlan 3003

[BEB1-if-range] quit

# 配置B-VLAN 3003的流量与ECT 9算法进行映射。

[BEB1] spbm

[BEB1-spbm] ect 9 b-vlan 3003

[BEB1-spbm] quit

6.4.2  配置BEB 2、BEB 3、BEB 4

其他BEB设备的配置与BEB 1相同。

6.4.3  配置BCB 1

# 创建B-VLAN 3003。

<BCB1> system-view

[BCB1] vlan 3003

[BCB1-vlan3003] quit

# 将B-VLAN 3003加入4092实例。

[BCB1] stp region-configuration

[BCB1-mst-region] instance 4092 vlan 3003

[BCB1-mst-region] active region-configuration

[BCB1-mst-region] quit

# 配置所有接口允许B-VLAN 3003的流量通过。

[BCB1] interface range HundredGigE 1/1/0/1 to HundredGigE 1/1/0/4

[BCB1-if-range] port trunk permit vlan 3003

[BCB1-if-range] quit

# 配置B-VLAN 3003的流量与ECT 9算法进行映射。

[BCB1] spbm

[BCB1-spbm] ect 9 b-vlan 3003

[BCB1-spbm] quit

6.4.4  配置BCB 2

BCB 2的配置与BCB 1相同。

6.5  ECT迁移前的配置验证

# 查看BEB设备上的I-SID 3001对应实例的ECT迁移状态(以BEB 1为例,其他BEB使用相同命令查看)。

[BEB1] display spbm ect-migration i-sid 3001

ECT            B-VLAN    T    R

00-80-c2-01    3001      1    1

以上信息表明,BEB 1使用B-VLAN 3001来承载流量。

6.6  ECT迁移配置步骤

6.6.1  配置BEB 1

# 修改名为test的VSI(I-SID 3001)的B-VLAN为3003。

[BEB1] vsi test

[BEB1-vsi-test] spb i-sid 3001

[BEB1-vsi-test-3001] b-vlan 3003

6.6.2  配置BEB 2、BEB 3、BEB 4

其他BEB设备的配置与BEB 1相同。

6.7  ECT迁移后的配置验证

# 在完成上述配置后,等大约2分钟,然后查看BEB设备上的I-SID 3001对应实例的ECT迁移状态(以BEB 1为例,其他BEB使用相同命令查看)。

[BEB1-spbm] display spbm ect-migration i-sid 3001

ECT            B-VLAN    T    R

00-80-c2-09    3003      1    1

以上信息表明,I-SID 3001 ECT迁移结束,此时BEB 1使用B-VLAN 3003来承载流量。

6.8  配置文件(ECT迁移前)

·     BEB 1、BEB 2、BEB 3、BEB 4

vlan 100

#

vlan 3001

#

vlan 3003

#

stp region-configuration

 region-name spb

 instance 4092 vlan 3001 3003

 active region-configuration

#

spbm

ect 9 b-vlan 3003

#

l2vpn enable

#

vsi test

 spb i-sid 3001

  b-vlan 3001

  multicast replicate-mode tandem

#

interface HundredGigE1/1/0/1

 port link-mode bridge

 port link-type trunk

 port trunk permit vlan 1 100

 service-instance 1

  encapsulation s-vid 100

  xconnect vsi test

#

interface HundredGigE1/1/0/2

 port link-mode bridge

 port link-type trunk

 port trunk permit vlan 1 3001 3003

 spbm enable

#

interface HundredGigE1/1/0/3

 port link-mode bridge

 port link-type trunk

 port trunk permit vlan 1 3001 3003

 spbm enable

#

·     BCB 1、BCB 2

vlan 3001

#

vlan 3003

#

stp region-configuration

 region-name spb

 instance 4092 vlan 3001 3003

 active region-configuration

#

spbm

ect 9 b-vlan 3003

#

interface HundredGigE1/1/0/1

 port link-mode bridge

 port link-type trunk

 port trunk permit vlan 1 3001 3003

 spbm enable

#

interface HundredGigE1/1/0/2

 port link-mode bridge

 port link-type trunk

 port trunk permit vlan 1 3001 3003

 spbm enable

#

interface HundredGigE1/1/0/3

 port link-mode bridge

 port link-type trunk

 port trunk permit vlan 1 3001 3003

 spbm enable

#

interface HundredGigE1/1/0/4

 port link-mode bridge

 port link-type trunk

 port trunk permit vlan 1 3001 3003

 spbm enable

#

7  相关资料

·     H3C S12500X-AF系列交换机SPB配置指导-R26xx

·     H3C S12500X-AF系列交换机SPB命令参考-R26xx

·     H3C S12500X-AF系列交换机 二层技术-以太网交换配置指导-R26xx

·     H3C S12500X-AF系列交换机 二层技术-以太网交换命令参考-R26xx

·     H3C S12500X-AF系列交换机 MPLS配置指导-R26xx

·     H3C S12500X-AF系列交换机 MPLS命令参考-R26xx

不同款型规格的资料略有差异, 详细信息请向具体销售和400咨询。H3C保留在没有任何通知或提示的情况下对资料内容进行修改的权利!

联系我们