H3C S12500X-AF系列交换机 典型配置举例(R26xx系列)-6W100

目录

06-以太网链路聚合典型配置举例

本章节下载 06-以太网链路聚合典型配置举例  (298.13 KB)

docurl=/cn/Service/Document_Software/Document_Center/Switches/Catalog/S12500/S12500X-AF/Configure/Typical_Configuration_Example/H3C_S12500X-AF_CE(R26xx)-6W100/201703/976260_30005_0.htm

06-以太网链路聚合典型配置举例

H3C S12500X-AF以太网链路聚合配置举例

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

H3C_彩色.emf

 



1  简介

本文档介绍以太网链路聚合特性的配置举例。

2  配置前提

本文档中的配置均是在实验室环境下进行的配置和验证,配置前设备的所有参数均采用出厂时的缺省配置。如果您已经对设备进行了配置,为了保证配置效果,请确认现有配置和以下举例中的配置不冲突。

本文档假设您已了解以太网链路聚合特性。

3  二层链路聚合配置举例

3.1  组网需求

图1所示:

·     Device A与Device B通过各自的二层以太网接口HundredGigE1/0/1~HundredGigE1/0/3相互连接。

·     Device A和DeviceB均参与VLAN 10、VLAN 20的数据流量转发。现要求两设备上相同VLAN可以互通。为提高设备间链路带宽及可靠性,可使用二层链路聚合特性实现。

图1 二层链路聚合配置示例图

 

 

3.2  配置思路

要使VLAN 10与VLAN 20的数据流量均能通过二层聚合接口1,可配置二层聚合接口的链路类型为Trunk端口,并允许VLAN 10和VLAN 20的报文通过。

3.3  使用版本

本举例是在R2609版本上进行配置和验证的。

3.4  配置注意事项

·     配置聚合组的成员端口过程中,建议配置顺序:在端口视图下使用display this命令查看端口上是否存在属性类配置(包括端口隔离配置、VLAN配置、VLAN映射),如果有这类配置,请使用对应的undo命令删除这些配置,使端口保持在缺省属性类配置状态,然后再把端口加入到新创建的聚合组内。

·     由于静态聚合组中端口选中状态不受对端端口是否在聚合组中及是否处于选中状态的影响。这样有可能导致两端设备所确定的Selected状态端口不一致,当两端都支持配置静态和动态聚合组的情况下,建议用户优选动态聚合组。

3.5  配置步骤

3.5.1  Device A的配置

# 创建VLAN 10,并将端口HundredGigE1/0/4加入到该VLAN 10中。

<DeviceA> system-view

[DeviceA] vlan 10

[DeviceA-vlan10] port hundredgige 1/0/4

[DeviceA-vlan10] quit

# 创建VLAN 20,并将端口HundredGigE1/0/5加入到该VLAN 20中。

[DeviceA] vlan 20

[DeviceA-vlan20] port hundredgige 1/0/5

[DeviceA-vlan20] quit

# 创建二层聚合接口1。(根据具体情况选择下面两种方式之一)

·     采用静态聚合模式:创建二层聚合接口1

[DeviceA] interface bridge-aggregation 1

[DeviceA-Bridge-Aggregation1] undo shutdown

[DeviceA-Bridge-Aggregation1] quit

·     采用动态聚合模式:创建二层聚合接口1,并配置动态聚合模式

[DeviceA] interface bridge-aggregation 1

[DeviceA-Bridge-Aggregation1] link-aggregation mode dynamic

[DeviceA-Bridge-Aggregation1] undo shutdown

[DeviceA-Bridge-Aggregation1] quit

# 将端口HundredGigE1/0/1~HundredGigE1/0/3加入到聚合组1中。

[DeviceA] interface range hundredgige 1/0/1 to hundredgige 1/0/3

[DeviceA-if-range] port link-aggregation group 1

[DeviceA-if-range] undo shutdown

[DeviceA-if-range] quit

# 配置二层聚合接口1为Trunk端口,并允许VLAN 10和VLAN 20的报文通过。

[DeviceA] interface bridge-aggregation 1

[DeviceA-Bridge-Aggregation1] port link-type trunk

Configuring HundredGigE1/0/1 done.

Configuring HundredGigE1/0/2 done.

Configuring HundredGigE1/0/3 done.

[DeviceA-Bridge-Aggregation1] port trunk permit vlan 10 20

Configuring HundredGigE1/0/1 done.

Configuring HundredGigE1/0/2 done.

Configuring HundredGigE1/0/3 done.

[DeviceA-Bridge-Aggregation1] quit

3.5.2  Device B的配置

Device B上的配置与Device A完全相同,此处不再赘述。

3.6  验证配置

# 通过display link-aggregation verbose命令来显示聚合组的相关信息,以验证配置是否成功。

·     采用静态聚合模式的链路聚合配置信息

[DeviceA] display link-aggregation verbose

Loadsharing Type: Shar -- Loadsharing, NonS -- Non-Loadsharing

Port Status: S -- Selected, U -- Unselected, I -- Individual

Port: A -- Auto port, M -- Management port, R -- Reference port

Flags:  A -- LACP_Activity, B -- LACP_Timeout, C -- Aggregation,

        D -- Synchronization, E -- Collecting, F -- Distributing,

        G -- Defaulted, H -- Expired

 

Aggregation Interface: Bridge-Aggregation1

Aggregation Mode: Static

Loadsharing Type: Shar

Management VLANs: None

  Port             Status  Priority  Oper-Key

  HGE1/0/1(R)      S       32768     1

  HGE1/0/2         S       32768     1

  HGE1/0/3         S       32768     1

结果说明:本端加入到静态聚合组内的成员端口都处于Selected状态,与对端对应端口是否是Selected状态无关。

·     采用动态聚合模式的链路聚合配置信息

[DeviceA] display link-aggregation verbose

Loadsharing Type: Shar -- Loadsharing, NonS -- Non-Loadsharing

Port Status: S -- Selected, U -- Unselected, I -- Individual

Port: A -- Auto port, M -- Management port, R -- Reference port

Flags:  A -- LACP_Activity, B -- LACP_Timeout, C -- Aggregation,

        D -- Synchronization, E -- Collecting, F -- Distributing,

        G -- Defaulted, H -- Expired

 

Aggregation Interface: Bridge-Aggregation1

Aggregation Mode: Dynamic

Loadsharing Type: Shar

Management VLANs: None

System ID: 0x8000, 000f-e234-5678

Local:

  Port                Status   Priority Index    Oper-Key               Flag

  HGE1/0/1            S        32768    2        1                      {ACDEF}

  HGE1/0/2            S        32768    3        1                      {ACDEF}

  HGE1/0/3            S        32768    4        1                      {ACDEF}

Remote:

  Actor               Priority Index    Oper-Key SystemID               Flag

  HGE1/0/1(R)         32768    2        1        0x8000, a4e5-c316-0100 {ACDEF}

  HGE1/0/2            32768    3        1        0x8000, a4e5-c316-0100 {ACDEF}

  HGE1/0/3            32768    4        1        0x8000, a4e5-c316-0100 {ACDEF}

结果说明:本端和对端设备上聚合组内的成员端口都处于Selected状态。原因是在动态链路聚合中通过LACP协议报文交互,可使两端聚合组内的成员端口选中状态达成一致,可顺利实现对用户数据的转发。

3.7  配置文件

·     Device A:

#

vlan 10

#

interface HundredGigE1/0/4

 port link-mode bridge

 port access vlan 10

#

vlan 20

#

interface HundredGigE1/0/5

 port link-mode bridge

 port access vlan 20

¡     采用静态聚合模式

#

interface Bridge-Aggregation1

 port link-type trunk

 port trunk permit vlan 10 20

¡     采用动态聚合模式

#

interface Bridge-Aggregation1

 port link-type trunk

 port trunk permit vlan 10 20

 link-aggregation mode dynamic

#

interface HundredGigE1/0/1

 port link-mode bridge

 port link-type trunk

 port trunk permit vlan 10 20

 port link-aggregation group 1

#

interface HundredGigE1/0/2

 port link-mode bridge

 port link-type trunk

 port trunk permit vlan 10 20

 port link-aggregation group 1

#

interface HundredGigE1/0/3

 port link-mode bridge

 port link-type trunk

 port trunk permit vlan 10 20

 port link-aggregation group 1

#

·     Device B:

Device B上的配置文件与Device A相同。

4  二层聚合负载分担配置举例

4.1  组网需求

图2所示:

·     Device A与Device B通过各自的二层以太网接口HundredGigE1/0/1~HundredGigE1/0/4相互连接。

·     Device A和DeviceB均参与VLAN 10、VLAN 20的数据流量转发。现要求两设备上相同VLAN可以互通,VLAN 10的流量通过聚合接口1,VLAN 20的流量通过聚合接口2。且VLAN 10的报文按照源MAC地址进行聚合负载分担,VLAN 20的报文按照逐包进行负载分担。为提高设备间链路带宽及可靠性可使用二层链路聚合特性实现。

图2 二层聚合负载分担配置组网图

 

4.2  配置思路

·     在系统视图和二层聚合接口视图下配置聚合负载分担类型,实现不同聚合组按照不同负载分担方式对报文进行处理。

·     要使VLAN 10的流量通过聚合接口1,须配置聚合接口1允许VLAN 10的报文通过;同理,须配置聚合接口2允许VLAN 20的报文通过。

4.3  使用版本

本举例是在R2609版本上进行配置和验证的。

4.4  配置注意事项

配置聚合组的成员端口过程中,建议配置顺序:在端口视图下使用display this命令查看端口上是否存在属性类配置(包括端口隔离配置、VLAN配置、VLAN映射),如果有这类配置,请使用对应的undo命令删除这些配置,使端口保持在缺省属性类配置状态,然后再把端口加入到新创建的聚合组内。

4.5  配置步骤

4.5.1  Device A的配置

# 创建VLAN 10,并将端口HundredGigE1/0/5加入到VLAN 10中。

<DeviceA> system-view

[DeviceA] vlan 10

[DeviceA-vlan10] port hundredgige 1/0/5

[DeviceA-vlan10] quit

# 创建VLAN 20,并将端口HundredGigE1/0/6加入到VLAN 20中。

[DeviceA] vlan 20

[DeviceA-vlan20] port hundredgige 1/0/6

[DeviceA-vlan20] quit

# 开启端口HundredGigE。

[DeviceA] interface hundredgige 1/0/5

[DeviceA-HundredGigE1/0/5] undo shutdown

[DeviceA-HundredGigE1/0/5] quit

# 开启端口HundredGigE1/0/6。

[DeviceA] interface hundredgige 1/0/6

[DeviceA-HundredGigE1/0/6] undo shutdown

[DeviceA-HundredGigE1/0/6] quit

# 配置聚合组按照源MAC地址进行聚合负载分担。

[DeviceA] link-aggregation global load-sharing mode source-mac

# 创建二层聚合接口1。

[DeviceA] interface bridge-aggregation 1

[DeviceA-Bridge-Aggregation1] undo shutdown

[DeviceA-Bridge-Aggregation1] quit

# 分别将端口HundredGigE1/0/1和HundredGigE1/0/2加入到聚合组1中。

[DeviceA] interface hundredgige 1/0/1

[DeviceA-HundredGigE1/0/1] undo shutdown

[DeviceA-HundredGigE1/0/1] port link-aggregation group 1

[DeviceA-HundredGigE1/0/1] quit

[DeviceA] interface hundredgige 1/0/2

[DeviceA-HundredGigE1/0/2] undo shutdown

[DeviceA-HundredGigE1/0/2] port link-aggregation group 1

[DeviceA-HundredGigE1/0/2] quit

# 配置二层聚合接口1允许VLAN 10的报文通过。

[DeviceA] interface bridge-aggregation 1

[DeviceA-Bridge-Aggregation1] port access vlan 10

Configuring HundredGigE1/0/1 done.

Configuring HundredGigE1/0/2 done.

[DeviceA-Bridge-Aggregation1] quit

# 创建二层聚合接口2,并配置该接口对应的聚合组内按照逐包进行聚合负载分担。

[DeviceA] interface bridge-aggregation 2

[DeviceA-Bridge-Aggregation2] undo shutdown

[DeviceA-Bridge-Aggregation2] link-aggregation load-sharing mode flexible

[DeviceA-Bridge-Aggregation2] quit

# 分别将端口HundredGigE1/0/3和HundredGigE1/0/4加入到聚合组2中。

[DeviceA] interface hundredgige 1/0/3

[DeviceA-HundredGigE1/0/3] undo shutdown

[DeviceA-HundredGigE1/0/3] port link-aggregation group 2

[DeviceA-HundredGigE1/0/3] quit

[DeviceA] interface hundredgige 1/0/4

[DeviceA-HundredGigE1/0/4] undo shutdown

[DeviceA-HundredGigE1/0/4] port link-aggregation group 2

[DeviceA-HundredGigE1/0/4] quit

# 配置二层聚合接口2允许VLAN 20的报文通过。

[DeviceA] interface bridge-aggregation 2

[DeviceA-Bridge-Aggregation2] port access vlan 20

Configuring HundredGigE1/0/3 done.

Configuring HundredGigE1/0/4 done.

[DeviceA-Bridge-Aggregation2] quit

4.5.2  Device B的配置

Device B上的配置与Device A完全相同,此处不再赘述。

4.6  验证配置

# 显示聚合组中选中端口信息

[DeviceA] display link-aggregation verbose

Loadsharing Type: Shar -- Loadsharing, NonS -- Non-Loadsharing

Port Status: S -- Selected, U -- Unselected , I -- Individual

Port: A -- Auto port, M -- Management port, R -- Reference port

Flags:  A -- LACP_Activity, B -- LACP_Timeout, C -- Aggregation,

        D -- Synchronization, E -- Collecting, F -- Distributing,

        G -- Defaulted, H -- Expired

 

Aggregation Interface: Bridge-Aggregation1

Aggregation Mode: Static

Loadsharing Type: Shar

Management VLANs: None

  Port             Status  Priority  Oper-Key

  HGE1/0/1(R)      S       32768     1

  HGE1/0/2         S       32768     1

 

Aggregation Interface: Bridge-Aggregation2

Aggregation Mode: Static

Loadsharing Type: Shar

Management VLANs: None

  Port             Status  Priority  Oper-Key

  HGE1/0/3(R)      S       32768     2

  HGE1/0/4         S       32768     2

结果说明:Bridge-aggregation 1与Bridge-aggregation 2均为静态聚合模式,并且两个聚合组都有两个成员端口处于选中状态,可以进行数据流量的转发。

# 显示聚合负载分担类型

[DeviceA]display link-aggregation load-sharing mode interface Bridge-Aggregation 1

Bridge-Aggregation1 Load-Sharing Mode:

source-mac address

[DeviceA]display link-aggregation load-sharing mode interface Bridge-Aggregation 2

Bridge-Aggregation2 Load-Sharing Mode:

packet type-based sharing

结果说明:Bridge-aggregation 1的聚合负载分担方式为根据源MAC地址(source-mac address)方式进行流量分担,Bridge-aggregation 2的聚合负载分担方式为逐包(packet type-based sharing)方式进行流量分担。

4.7  配置文件

·     Device A:

#

 link-aggregation global load-sharing mode source-mac

#

vlan 10

#

interface HundredGigE1/0/5

 port link-mode bridge

 port access vlan 10

#

vlan 20

#

interface HundredGigE1/0/6

 port link-mode bridge

 port access vlan 10

#

interface Bridge-Aggregation1

 port access vlan 10

#

interface HundredGigE1/0/1

 port link-mode bridge

 port access vlan 10

 port link-aggregation group 1

#

interface HundredGigE1/0/2

 port link-mode bridge

 port access vlan 10

 port link-aggregation group 1

#

interface Bridge-Aggregation2

 port access vlan 20

 link-aggregation load-sharing mode flexible

#

interface HundredGigE1/0/3

 port link-mode bridge

 port access vlan 20

 port link-aggregation group 2

#

interface HundredGigE1/0/4

 port link-mode bridge

 port access vlan 20

 port link-aggregation group 2

·     Device B:

Device B上的配置文件与Device A相同。

5  二层以太网链路聚合配合IRF典型配置举例

5.1  组网需求

图3所示,接入层和汇聚层都有两台设备,现要求使用链路聚合特性和IRF特性实现以下需求:

·     由于公司人员不断增加,要求接入层具有易管理能力和强扩展能力,可以提供更多的端口来满足PC的接入需求。

·     由于接入层的流量增加,要求增强接入层到汇聚层的链路具有较高可靠性,且可实现流量的负载分担。

图3 以太网链路聚合配置IRF配置组网图

 

 

5.2  配置思路

·     要使接入层具有易管理能力和强扩展能力,可通过配置IRF功能,轻松扩展接入层端口数量、带宽。

·     为了提高链路可靠性,可通过配置链路聚合配合IRF功能实现,每台接入层设备双上行连到汇聚层上,并且将四条上行链路进行聚合,当某个成员设备离开IRF,其它成员设备上的链路仍能收发报文,从而提高了链路的可靠性。

·     可以通过配置链路聚合的负载分担功能以实现流量均衡转发。

·     可以在汇聚层IRF和接入层IRF上同时开启LACP MAD功能,使两个IRF相互作为中间设备,完成各自的LACP MAD检测。以快速排查IRF分裂原因并及时恢复成员设备IRF状态。

5.3  使用版本

本举例是在R2609版本上进行配置和验证的。

5.4  配置注意事项

·     IRF物理端口必须工作在二层模式下,才能与IRF端口进行绑定。

·     与同一个IRF端口绑定的多个IRF物理端口必须工作在相同模式。

·     IRF中成员设备间相连的IRF物理端口必须配置为同一种工作模式。关于配置IRF物理端口的工作模式的介绍,请参见“IRF配置指导”。

·     配置聚合组的成员端口过程中,建议配置顺序:在端口视图下使用display this命令查看端口上是否存在属性类配置(包括端口隔离配置、VLAN配置、VLAN映射),如果有这类配置,请使用对应的undo命令删除这些配置,使端口保持在缺省属性类配置状态,然后再把端口加入到新创建的聚合组内。

·     由于静态聚合组中成员端口选中状态不受对端端口是否在聚合组中及是否处于选中状态的影响。这样有可能导致两端设备所确定的Selected状态端口不一致,并且LACP MAD必须在动态聚合接口上应用才能生效。所以本例要求用户选择配置动态聚合组。

5.5  配置步骤

(1)     Device A的IRF相关配置

# 关闭HundredGigE1/0/1。关于IRF配置的介绍,请参见“IRF配置指导”。

<DeviceA> system-view

[DeviceA] interface hundredgige 1/0/1

[DeviceA-HundredGigE1/0/1] shutdown

[DeviceA-HundredGigE1/0/1] quit

# 配置IRF端口1/1,并将它与物理端口HundredGigE1/0/1绑定。

[DeviceA] irf-port 1/1

[DeviceA-irf-port1/1] port group interface hundredgige 1/0/1

[DeviceA-irf-port1/1] quit

# 开启HundredGigE1/0/1端口,并保存配置。

[DeviceA] interface hundredgige 1/0/1

[DeviceA-HundredGigE1/0/1] undo shutdown

[DeviceA-HundredGigE1/0/1] quit

[DeviceA] save

# 激活IRF端口下的配置。

[DeviceA] irf-port-configuration active

(2)     Device B的IRF相关配置

# 将Device B的成员编号配置为2,并重启设备使新编号生效。

<DeviceB> system-view

[DeviceB] irf member 1 renumber 2

Renumbering the member ID may result in configuration change or loss. Continue? [Y/N]:y

[DeviceB] quit

<DeviceB> reboot

# IRF物理端口绑定要求与Device A相同,本例中以HundredGigE2/0/1为例,关闭该端口。关于IRF配置的介绍,请参见“IRF配置指导”。

<DeviceB> system-view

[DeviceB] interface hundredgige 2/0/1

[DeviceB-HundredGigE2/0/1] shutdown

[DeviceB-HundredGigE2/0/1] quit

# 配置IRF端口2/2,并将它与物理端口HundredGigE2/0/1绑定。

[DeviceB] irf-port 2/2

[DeviceB-irf-port2/2] port group interface hundredgige 2/0/1

[DeviceB-irf-port2/2] quit

# 开启HundredGigE2/0/1端口,并保存配置。

[DeviceB] interface hundredgige 2/0/1

[DeviceB-HundredGigE2/0/1] undo shutdown

[DeviceB-HundredGigE2/0/1] quit

[DeviceB] save

# 激活IRF端口下的配置。

[DeviceB] irf-port-configuration active

# Device A和Device B间将会进行Master竞选,竞选失败的一方将重启,重启完成后,IRF形成。

# 通过display irf命令来显示IRF相关信息,Device A为Master主设备。

[DeviceA] display irf

MemberID    Role    Priority  CPU-Mac         Description

 *+1        Master   1        00a0-fc00-5801  ---

   2        Standby  1        00e0-fc58-1235  ---

--------------------------------------------------

 * indicates the device is the master.

 + indicates the device through which the user logs in.

 

 The bridge MAC of the IRF is: 00a0-fc00-5800

 Auto upgrade                : yes

 Mac persistent              : 6 min

 Domain ID                   : 0

 Auto merge                  : yes

(3)     Device A的二层动态聚合组相关配置

# 创建二层动态聚合组1,并配置该接口对应的聚合组逐包进行聚合负载分担。

[DeviceA] interface bridge-aggregation 1

[DeviceA-Bridge-Aggregation1] link-aggregation mode dynamic

[DeviceA-Bridge-Aggregation1] link-aggregation load-sharing mode flexible

[DeviceA-Bridge-Aggregation1] quit

# 将HundredGigE1/0/9、HundredGigE1/0/10、HundredGigE2/0/9、HundredGigE2/0/10加入该聚合组中。

[DeviceA] interface range hundredgige 1/0/9 to hundredgige 1/0/10

hundredgige 2/0/9 to hundredgige 2/0/10

[DeviceA-if-range] port link-aggregation group 1

[DeviceA-if-range] quit

(4)     Device A的LACP MAD相关配置

# 设置IRF域编号为1。

[DeviceA] irf domain 1

# 在动态聚合组1上使能LACP MAD检测功能。

[DeviceA] interface Bridge-Aggregation 1

[DeviceA-Bridge-Aggregation1] mad enable

You need to assign a domain ID (range: 0-4294967295)

[Current domain is: 1]:

The assigned domain ID is: 1

MAD LACP only enable on dynamic aggregation interface.

(5)     Device C的IRF相关配置

# Device C上的IRF相关配置与Device A完全相同,此处不再赘述。

(6)     Device D的IRF相关配置

# Device D上的IRF相关配置与Device B完全相同,此处不再赘述。

# Device C和Device D间将会进行Master竞选,竞选失败的一方将重启,重启完成后,IRF形成,Device C为Master主设备。

(7)     Device C的二层动态聚合组相关配置。

# Device C上的二层动态聚合组相关配置与Device A完全相同,此处不再赘述。

(8)     Device C的LACP MAD相关配置

# 设置IRF域编号为2。

<DeviceC> system-view

[DeviceC] irf domain 2

# 在动态聚合组1上使能LACP MAD检测功能。

[DeviceC] interface Bridge-Aggregation 1

[DeviceC-Bridge-Aggregation1] mad enable

You need to assign a domain ID (range: 0-4294967295)

[Current domain is: 2]:

The assigned domain ID is: 2

MAD LACP only enable on dynamic aggregation interface.

5.6  验证配置

# 在Device A上通过display link-aggregation verbose命令来显示聚合组的相关信息,以验证配置是否成功。

[DeviceA] display link-aggregation verbose

Loadsharing Type: Shar -- Loadsharing, NonS -- Non-Loadsharing

Port Status: S -- Selected, U -- Unselected, I -- Individual

Port: A -- Auto port, M -- Management port, R -- Reference port

Flags:  A -- LACP_Activity, B -- LACP_Timeout, C -- Aggregation,

        D -- Synchronization, E -- Collecting, F -- Distributing,

        G -- Defaulted, H -- Expired

 

Aggregate Interface: Bridge-Aggregation1

Aggregation Mode: Dynamic

Loadsharing Type: Shar

Management VLANs: None

System ID: 0x8000, 00a0-fc00-5800

Local:

  Port                Status   Priority Index    Oper-Key               Flag

  HGE1/0/9(R)         S        32768    10       1                      {ACG}

  HGE1/0/10           S        32768    11       1                      {ACG}

  HGE2/0/9            S        32768    138      1                      {ACG}

  HGE2/0/10           S        32768    139      1                      {ACG}

Remote:

  Actor               Priority Index    Oper-Key SystemID               Flag

  HGE1/0/9            32768    0        0        0x8000, 0000-0000-0000 {EF}

  HGE1/0/10           32768    0        0        0x8000, 0000-0000-0000 {EF}

  HGE2/0/9            32768    0        0        0x8000, 0000-0000-0000 {EF}

  HGE2/0/10           32768    0        0        0x8000, 0000-0000-0000 {EF}

结果说明:本端和对端设备上聚合组内的成员端口都处于Selected状态。原因是在动态链路聚合中通过LACP协议报文交互,可使两端聚合组内的成员端口选中状态达成一致,可顺利实现对用户数据的转发。

# 显示聚合负载分担类型

[DeviceA] display link-aggregation load-sharing mode interface Bridge-Aggregation 1

Bridge-Aggregation1 load-sharing mode:

packet type-based sharing

结果说明:Bridge-aggregation 1的聚合负载分担方式为逐包进行聚合负载分担。

# 由于配置了LACP MAD功能,当IRF分裂时,设备会收到相关日志信息,提示IRF分裂原因。

[DeviceA]%Jul  9 16:52:41:734 2016 DeviceA STM/3/STM_LINK_DOWN: -MDC=1; IRF port 1 went down.

%Jul  9 16:52:41:800 2016 DeviceA IFNET/3/PHY_UPDOWN: -MDC=1; Physical state on the interface HundredGigE1/0/1 changed to down.

%Jul  9 16:52:41:854 2016 DeviceA IFNET/5/LINK_UPDOWN: -MDC=1; Line protocol state on the interface HundredGigE1/0/1 changed to down.

%Jul  9 16:52:41:867 2016 DeviceA DEV/3/BOARD_REMOVED: -MDC=1; Board was removed from slot 2, type is Simware.

结果说明:因为与IRF端口2/2绑定的HundredGigE2/0/1物理端口的物理状态为关闭,造成汇聚层IRF分裂。可通过检查物理连线或者线路故障来解决此问题。

5.7  配置文件

·     Device A:

#

 irf domain 1

 irf mac-address persistent timer

 irf auto-update enable

 irf auto-merge enable

 undo irf link-delay

 irf member 1 priority 1

 irf member 2 priority 1

#

irf-port 1/1

 port group interface HundredGigE1/0/1 mode enhanced

#

irf-port 2/2

 port group interface HundredGigE1/0/1 mode enhanced

#

 

interface Bridge-Aggregation1

 link-aggregation mode dynamic

 link-aggregation load-sharing mode flexible

#

interface HundredGigE1/0/9

 port link-mode bridge

 port link-aggregation group 1

#

interface HundredGigE1/0/10

 port link-mode bridge

 port link-aggregation group 1

#

interface HundredGigE2/0/9

 port link-mode bridge

 port link-aggregation group 1

#

interface HundredGigE2/0/10

 port link-mode bridge

 port link-aggregation group 1

#

·     Device C:

Device C上的配置文件与Device A类似。

6  三层链路聚合配置举例

6.1  组网需求

图4所示:

·     Device A与Device B通过各自的三层以太网接口HundredGigE1/0/1~HundredGigE1/0/3相互连接。

·     在Device A和Device B上分别配置三层链路聚合组,并为对应的三层聚合接口配置IP地址和子网掩码。

图4 三层聚合配置示例图

 

6.2  使用版本

本举例是在R2609版本上进行配置和验证的。

6.3  配置注意事项

由于静态聚合组中端口选中状态不受对端端口是否在聚合组中及是否处于选中状态的影响。这样有可能导致两端设备所确定的Selected状态端口不一致,当两端都支持配置静态和动态聚合模式的情况下,建议用户选择配置动态聚合模式。

6.4  配置步骤

6.4.1  Device A的配置

# 创建三层聚合接口1。(根据具体情况选择下面两种方式之一)

·     采用静态聚合模式

<DeviceA> system-view

[DeviceA] interface route-aggregation 1

·     采用动态聚合模式

<DeviceA> system-view

[DeviceA] interface route-aggregation 1

[DeviceA-Route-Aggregation1] link-aggregation mode dynamic

# 为三层聚合接口1配置IP地址和子网掩码。

[DeviceA-Route-Aggregation1] ip address 192.168.1.1 24

[DeviceA-Route-Aggregation1] undo shutdown

[DeviceA-Route-Aggregation1] quit

# 将接口HundredGigE1/0/1~HundredGigE1/0/3加入聚合组1。

[DeviceA] interface range hundredgige 1/0/1 to hundredgige 1/0/3

[DeviceA-if-range] port link-mode route

[DeviceA-if-range] undo shutdown

[DeviceA-if-range] port link-aggregation group 1

[DeviceA-if-range] quit

6.4.2  Device B的配置

Device B上的配置与Device A相同,配置过程略。

6.5  验证配置

# 通过display link-aggregation verbose命令来显示聚合组的相关信息,以验证配置是否成功。

·     采用静态聚合模式的聚合组信息

[DeviceA] display link-aggregation verbose

Loadsharing Type: Shar -- Loadsharing, NonS -- Non-Loadsharing

Port Status: S -- Selected, U -- Unselected, I -- Individual

Port: A -- Auto port, M -- Management port, R -- Reference port

Flags:  A -- LACP_Activity, B -- LACP_Timeout, C -- Aggregation,

        D -- Synchronization, E -- Collecting, F -- Distributing,

        G -- Defaulted, H -- Expired

 

Aggregate Interface: Route-Aggregation1

Aggregation Mode: Static

Loadsharing Type: Shar

Management VLANs: None

  Port             Status  Priority Oper-Key

  HGE1/0/1(R)      S       32768    1

  HGE1/0/2         S       32768    1

  HGE1/0/3         S       32768    1

结果说明:本端加入到静态聚合组内的成员端口都处于Selected状态,与对端对应端口是否是Selected状态无关。

·     采用动态聚合模式的聚合组信息

[DeviceA] display link-aggregation verbose

Loadsharing Type: Shar -- Loadsharing, NonS -- Non-Loadsharing

Port Status: S -- Selected, U -- Unselected, I -- Individual

Port: A -- Auto port, M -- Management port, R -- Reference port

Flags:  A -- LACP_Activity, B -- LACP_Timeout, C -- Aggregation,

        D -- Synchronization, E -- Collecting, F -- Distributing,

        G -- Defaulted, H -- Expired

 

Aggregate Interface: Route-Aggregation1

Aggregation Mode: Dynamic

Loadsharing Type: Shar

Management VLANs: None

System ID: 0x8000, 000f-e267-6c6a

Local:

  Port                Status   Priority Index    Oper-Key               Flag

  HGE1/0/1(R)         S        32768    2        1                      {ACDEF}

  HGE1/0/2            S        32768    3        1                      {ACDEF}

  HGE1/0/3            S        32768    4        1                      {ACDEF}

Remote:

  Actor               Priority Index    Oper-Key SystemID               Flag

  HGE1/0/1            32768    2        1        0x8000, 68fa-34f2-0200 {ACDEF}

  HGE1/0/2            32768    3        1        0x8000, 68fa-34f2-0200 {ACDEF}

  HGE1/0/3            32768    4        1        0x8000, 68fa-34f2-0200 {ACDEF}

结果说明:本端和对端设备上聚合组内的成员端口都处于Selected状态。原因是在动态链路聚合中通过LACP协议报文交互,可使两端聚合组内的成员端口选中状态达成一致,可顺利实现对用户数据的转发。

6.6  配置文件

·     Device A:

#

¡     采用静态聚合模式

#

interface route-aggregation1

 ip address 192.168.1.1 255.255.255.0

#

¡     采用动态聚合模式

#

interface route-aggregation1

 ip address 192.168.1.1 255.255.255.0

 link-aggregation mode dynamic

#

interface HundredGigE1/0/1

 port link-mode route

 port link-aggregation group 1

#

interface HundredGigE1/0/2

 port link-mode route

 port link-aggregation group 1

#

interface HundredGigE1/0/3

 port link-mode route

 port link-aggregation group 1

#

·     Device B:

Device B上的配置文件与Device A类似。

7  三层聚合负载分担配置举例

7.1  组网需求

图5所示:

·     Device A与Device B通过各自的三层以太网接口HundredGigE1/0/1~HundredGigE1/0/4相互连接。

·     在Device A和Device B上分别配置两个三层静态链路聚合组,并为对应的三层聚合接口都配置IP地址和子网掩码。

·     通过在聚合组1上按照源IP地址进行聚合负载分担、在聚合组2上按照逐包进行聚合负载分担的方式,来实现数据流量在各成员端口间的负载分担。

图5 三层聚合负载分担配置组网图

 

7.2  使用版本

本举例是在R2609版本上进行配置和验证的。

7.3  配置注意事项

聚合负载分担类型支持全局配置或在聚合组内配置两种方式;对于一个聚合组来说,优先采用该聚合组内的配置。

7.4  配置步骤

7.4.1  Device A的配置

# 配置该聚合组内按照源IP地址进行聚合负载分担。

<DeviceA> system-view

[DeviceA] link-aggregation global load-sharing mode source-ip

# 创建三层聚合接口1,并为其配置IP地址和子网掩码。

[DeviceA] interface route-aggregation 1

[DeviceA-Route-Aggregation1] ip address 192.168.1.1 24

[DeviceA-Route-Aggregation1] undo shutdown

[DeviceA-Route-Aggregation1] quit

# 创建三层聚合接口2,配置该接口对应的聚合组内按照逐包进行聚合负载分担,并为其配置IP地址和子网掩码。

[DeviceA] interface route-aggregation 2

[DeviceA-Route-Aggregation2] link-aggregation load-sharing mode flexible

[DeviceA-Route-Aggregation2] ip address 192.168.2.1 24

[DeviceA-Route-Aggregation2] undo shutdown

[DeviceA-Route-Aggregation2] quit

# 将接口HundredGigE1/0/1和HundredGigE1/0/2加入聚合组1,接口HundredGigE1/0/3和HundredGigE1/0/4加入聚合组2。

[DeviceA] interface range hundredgige 1/0/1 hundredgige 1/0/2

[DeviceA-if-range] port link-aggregation group 1

[DeviceA-if-range] undo shutdown

[DeviceA-if-range] quit

[DeviceA] interface range hundredgige 1/0/3 hundredgige 1/0/4

[DeviceA-if-range] port link-aggregation group 2

[DeviceA-if-range] undo shutdown

[DeviceA-if-range] quit

7.4.2  Device B的配置

Device B的配置与Device A相同,配置过程略。

7.5  验证配置

# 查看Device A上所有聚合组的详细信息。

[DeviceA] display link-aggregation verbose

Loadsharing Type: Shar -- Loadsharing, NonS -- Non-Loadsharing

Port Status: S -- Selected, U -- Unselected, I -- Individual

Port: A -- Auto port, M -- Management port, R -- Reference port

Flags:  A -- LACP_Activity, B -- LACP_Timeout, C -- Aggregation,

        D -- Synchronization, E -- Collecting, F -- Distributing,

        G -- Defaulted, H -- Expired

 

Aggregate Interface: Route-Aggregation1

Aggregation Mode: Static

Loadsharing Type: Shar

Management VLANs: None

  Port             Status  Priority Oper-Key

  HGE1/0/1(R)      S       32768    1

  HGE1/0/2         S       32768    1

 

Aggregate Interface: Route-Aggregation2

Aggregation Mode: Static

Loadsharing Type: Shar

Management VLANs: None

  Port             Status  Priority Oper-Key

  HGE1/0/3(R)      S       32768    2

  HGE1/0/4         S       32768    2

以上信息表明,聚合组1和聚合组2都是负载分担类型的三层静态聚合组,各包含有两个选中端口。

# 查看Device A上所有聚合接口所对应聚合组内采用的聚合负载分担类型。

[DeviceA] display link-aggregation load-sharing mode interface

Route-Aggregation1 Load-Sharing Mode:

source-ip address

 

Route-Aggregation2 Load-Sharing Mode:

packet type-based sharing

以上信息表明,三层聚合组1按照报文的源IP地址进行聚合负载分担,三层聚合组2按照逐包进行聚合负载分担。

7.6  配置文件

·     Device A:

#

 link-aggregation global load-sharing mode source-mac

#

interface Route-Aggregation1

 ip address 192.168.1.1 255.255.255.0

#

interface Route-Aggregation2

 ip address 192.168.2.1 255.255.255.0

 link-aggregation load-sharing mode destination-ip

#

interface HundredGigE1/0/1

 port link-mode route

 port link-aggregation group 1

#

interface HundredGigE1/0/2

 port link-mode route

 port link-aggregation group 1

#

interface HundredGigE1/0/3

 port link-mode route

 port link-aggregation group 2

#

interface HundredGigE1/0/4

 port link-mode route

 port link-aggregation group 2

#

·     Device B:

Device B上的配置文件与Device A类似。

8  相关资料

·     H3C S12500X-AF系列交换机 二层技术-以太网交换机配置指导-R26xx

·     H3C S12500X-AF系列交换机 二层技术-以太网交换机命令参考-R26xx

不同款型规格的资料略有差异, 详细信息请向具体销售和400咨询。H3C保留在没有任何通知或提示的情况下对资料内容进行修改的权利!

联系我们