H3C S12500X-AF系列交换机 典型配置举例(R26xx系列)-6W100

目录

34-优先级映射与队列调度典型配置举例

本章节下载 34-优先级映射与队列调度典型配置举例  (218.22 KB)

docurl=/cn/Service/Document_Software/Document_Center/Switches/Catalog/S12500/S12500X-AF/Configure/Typical_Configuration_Example/H3C_S12500X-AF_CE(R26xx)-6W100/201703/976288_30005_0.htm

34-优先级映射与队列调度典型配置举例

H3C S12500X-AF产品 优先级映射与队列调度配置举例

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

H3C_彩色.emf

 



1  简介

本文档介绍了优先级映射与队列调度的配置举例。

队列调度是指当设备的某个端口发生拥塞时,先通过配置队列调度策略修改各队列的调度参数,然后在该端口应用该策略来实现拥塞管理功能。

2  配置前提

本文档中的配置均是在实验室环境下进行的配置和验证,配置前设备的所有参数均采用出厂时的缺省配置。如果您已经对设备进行了配置,为了保证配置效果,请确认现有配置和以下举例中的配置不冲突。

本文假设您已了解队列调度特性。

3  优先级映射与队列调度典型配置举例

3.1  组网需求

某公司的网络结构如图1所示。现要求通过优先级映射和队列调度功能相结合,对公司内网流量和访问Internet的流量,在各设备上进行一定的调整,达到以下组网需求:

·     对内网服务器群的访问:管理部发送的数据要优先于研发部发送的数据进行传输,当拥塞发生时,按照2:1的比例依次发送管理部和研发部的报文。

·     对Internet的访问:管理部发送的数据优先于研发部发送的数据进行传输,当拥塞发生时,必须先将管理部的数据发送完成后,再发送研发部的数据。

·     两个部门内访问Internet的流量均有3种:HTTP、FTP和Email,报文中的DSCP位分别为33,35,27。现要求发送访问Internet的数据时,传输优先级如下:HTTP>FTP>Email。当拥塞发生时,按照2:1:1的比例依次发送三种报文。

图1 配置优先级映射与队列调度组网示意图

 

3.2  配置思路

1. 对内网流量的优先级配置

·     为了按照部门来划分报文优先级,可以使用交换机的端口优先级功能,在连接两个部门的端口上分别配置不同的端口优先级,即可为两个部门的报文标记不同的802.1p优先级。

·     要使标记的802.1p优先级对报文的传输产生实际影响,必须在数据传输路径中的所有接收端口上,都配置为信任802.1p优先级,设备才能够根据802.1p优先级确定报文的传输队列。

·     对于拥塞发生时按比例发送不同队列报文的需求,可以通过配置WRR队列调度算法,并为每个队列配置不同权重值的方式来实现。

2. 对Internet流量的优先级配置

·     当端口上发送拥塞时,如果要使管理部数据绝对优先于研发部数据发送,可以在端口上配置SP队列,同时将管理部的数据调度到比较优先的队列中,即可以实现该需求。

·     对于根据报文上层协议确定传输优先级的需求,需要在端口上配置为信任DSCP优先级,从而能够根据DSCP优先级将报文映射到不同队列。

·     当拥塞发生时的队列调度处理比例也可以通过在WRR队列中为各队列配置不同的权重来实现。

3.3  使用版本

本举例是在R2609版本上进行配置和验证的。

3.4  配置步骤

1. 对内网流量的传输优先级配置

(1)     Switch C的配置

# 创建VLAN10和VLAN20。

<SwitchC> system-view

[SwitchC] vlan 10

[SwitchC-vlan10] quit

[SwitchC] vlan 20

[SwitchC-vlan20] quit

# 将HundredGigE1/0/2端口加入VLAN10,配置端口优先级为6,即为所有管理部发出的报文标记802.1p优先级为6。

[SwitchC] interface hundredgige 1/0/2

[SwitchC-HundredGigE1/0/2] port access vlan 10

[SwitchC-HundredGigE1/0/2] qos priority 6

[SwitchC-HundredGigE1/0/2] quit

# 将HundredGigE1/0/3端口加入VLAN20,配置端口优先级为4,即为所有研发部发出的报文标记802.1p优先级为4。

[SwitchC] interface hundredgige 1/0/3

[SwitchC-HundredGigE1/0/3] port access vlan 20

[SwitchC-HundredGigE1/0/3] qos priority 4

[SwitchC-HundredGigE1/0/3] quit

# 由于802.1p优先级保存在VLAN Tag中,因此在HundredGigE1/0/1端口上需要配置报文以携带VLAN Tag的方式发送。此处以Trunk端口类型为例进行配置。配置端口允许VLAN10和VLAN20的报文通过,VLAN1作为缺省允许通过的VLAN,需要取消允许其通过。

[SwitchC] interface hundredgige 1/0/1

[SwitchC-HundredGigE1/0/1] port link-type trunk

[SwitchC-HundredGigE1/0/1] port trunk permit vlan 10 20

[SwitchC-HundredGigE1/0/1] undo port trunk permit vlan 1

[SwitchC-HundredGigE1/0/1] quit

(2)     Switch B的配置

# 创建VLAN10、VLAN20、VLAN30和VLAN40。

<SwitchB> system-view

[SwitchB] vlan 10

[SwitchB-vlan10] quit

[SwitchB] vlan 20

[SwitchB-vlan20] quit

[SwitchB] vlan 30

[SwitchB-vlan30] quit

[SwitchB] vlan 40

[SwitchB-vlan40] quit

# 将端口HundredGigE1/0/1配置为Trunk端口,允许VLAN10和VLAN20通过,取消允许VLAN1通过。

[SwitchB] interface hundredgige 1/0/1

[SwitchB-HundredGigE1/0/1] port link-type trunk

[SwitchB-HundredGigE1/0/1] port trunk permit vlan 10 20

[SwitchB-HundredGigE1/0/1] undo port trunk permit vlan 1

# 配置端口的优先级信任模式为信任802.1p优先级。

[SwitchB-HundredGigE1/0/1] qos trust dot1p

[SwitchB-HundredGigE1/0/1] quit

# 将端口HundredGigE1/0/10加入VLAN40。

[SwitchB] interface hundredgige 1/0/10

[SwitchB-HundredGigE1/0/10] port access vlan 40

[SwitchB-HundredGigE1/0/10] quit

# 将端口HundredGigE1/0/20加入VLAN30。

[SwitchB] interface hundredgige 1/0/20

[SwitchB-HundredGigE1/0/20] port access vlan 30

说明

在SwitchB上需要创建VLAN接口并配置路由协议,使各网段之间可以互通。配置过程这里省略,请参见S12500X-AF系列以太网交换机 三层技术-IP路由配置指导。

 

# 通过查找dot1p-lp优先级映射表,802.1p优先级为4的报文映射到本地优先级4,即队列4,802.1p优先级为6的报文映射到本地优先级6,即队列6。

# 在出端口HundredGigE1/0/20上,配置以字节数为调度权重的WRR队列,并配置队列6的权重为队列4的2倍(本例中以4和2为例)。

[SwitchB-HundredGigE1/0/20] qos wrr byte-count

[SwitchB-HundredGigE1/0/20] qos wrr 4 group 1 byte-count 2

[SwitchB-HundredGigE1/0/20] qos wrr 6 group 1 byte-count 4

[SwitchB-HundredGigE1/0/20] quit

2. 对发往Internet流量的传输优先级配置

(1)     Switch B的配置

# 配置端口HundredGigE1/0/10的队列调度算法为SP队列。

[SwitchB] interface hundredgige 1/0/10

[SwitchB-HundredGigE1/0/10] qos sp

(2)     Switch A的配置

# 配置端口HundredGigE1/0/1的优先级信任模式为信任DSCP优先级。

[SwitchA] interface hundredgige 1/0/1

[SwitchA-HundredGigE1/0/1] qos trust dscp

# 通过dscp-dot1pdot1p-lp映射表的两次映射找到DSCP优先级与本地优先级的映射关系。通过查找,DSCP优先级为33、35、27的报文分别映射到本地优先级为4、4、3。根据组网需求,需要将DSCP优先级为33的报文映射到更高的队列中,这里可以通过修改dscp-dot1p映射表来实现。此处以将DSCP优先级为33的报文映射到队列5为例,需要将DSCP优先级映射为802.1p优先级为5。

[SwitchA] qos map-table dscp-dot1p

[SwitchA-maptbl-dscp-dot1p] import 33 export 5

[SwitchA-maptbl-dscp-dot1p] quit

# 通过以上配置,已经将三种业务报文分别映射到队列5、4、3,配置端口HundredGigE1/0/2在发送报文时使用以字节数为调度权重的WRR队列,并配置三个队列的权重值比例为2:1:1(此处以6、3、3为例)。

[SwitchA] interface hundredgige 1/0/2

[SwitchA-HundredGigE1/0/2] qos wrr byte-count

[SwitchA-HundredGigE1/0/2] qos wrr 5 group 1 byte-count 6

[SwitchA-HundredGigE1/0/2] qos wrr 4 group 1 byte-count 3

[SwitchA-HundredGigE1/0/2] qos wrr 3 group 1 byte-count 3

3.5  验证配置

# 使用display qos queue wrr interface命令显示Switch A和Switch B接口的WRR(Weighted Round Robin,加权轮询)队列配置情况。此处以Switch A的接口HundredGigE1/0/2为例。

[SwitchA] display qos queue wrr interface hundredgige 1/0/2

Interface: HundredGigE1/0/2                                           

 Output queue: Weighted Round Robin queuing

 Queue ID     Queue name     Group     Byte count

 ---------------------------------------------------

 0            be             1         1

 1            af1            1         2

 2            af2            1         3

 3            af3            1         3

 4            af4            1         3

 5            ef             1         6

 6            cs6            1         7

 7            cs7            1         8

配置文件

·     Switch A的配置文件:

#

qos map-table dscp-dot1p

 import 33 export 5

#

interface HundredGigE1/0/1

 port link-mode bridge

 qos trust dscp

#

interface HundredGigE1/0/2

 port link-mode bridge

 qos wrr af3 group 1 byte-count 3                                              

 qos wrr af4 group 1 byte-count 3                                              

 qos wrr ef group 1 byte-count 6

#

return

·     Switch B的配置文件:

#

vlan 10

#

vlan 20

#

vlan 30

#

vlan 40 

#

interface HundredGigE1/0/1

 port link-mode bridge

 port link-type trunk

 undo port trunk permit vlan 1

 port trunk permit vlan 10 20

 qos trust dot1p

#

interface HundredGigE1/0/10

 port link-mode bridge

 port access vlan 40

#

interface HundredGigE1/0/20

 port link-mode bridge

 port access vlan 30

 qos wrr af4 group 1 byte-count 2                                              

 qos wrr cs6 group 1 byte-count 4

#

return

·     Switch C的配置文件:

#

vlan 10

#

vlan 20

#

interface HundredGigE1/0/1

 port link-mode bridge

 port link-type trunk

 undo port trunk permit vlan 1

 port trunk permit vlan 10 20

#

interface HundredGigE1/0/2

 port link-mode bridge

 port access vlan 10

 qos priority 6

#

interface HundredGigE1/0/3

 port link-mode bridge

 port access vlan 20

 qos priority 4

#

return

4  相关资料

·     H3C S12500X-AF系列交换机 ACL和QoS配置指导-R26xx

·     H3C S12500X-AF系列交换机 ACL和QoS命令参考-R26xx

不同款型规格的资料略有差异, 详细信息请向具体销售和400咨询。H3C保留在没有任何通知或提示的情况下对资料内容进行修改的权利!

联系我们