04-CLI configuration examples (AP standalone)

HomeSupportDoc SetsDoc PackagesH3C Wireless Products All-in-One-6W10004-CLI configuration examples (AP standalone)
05-Mesh WDS Configuration Examples
Title Size Download
05-Mesh WDS Configuration Examples 105.43 KB

 

H3C Access Points

Comware 7 Mesh WDS

Configuration Examples

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Copyright © 2022 New H3C Technologies Co., Ltd. All rights reserved.

No part of this manual may be reproduced or transmitted in any form or by any means without prior written consent of New H3C Technologies Co., Ltd.

Except for the trademarks of New H3C Technologies Co., Ltd., any trademarks that may be mentioned in this document are the property of their respective owners.

The information in this document is subject to change without notice.



Introduction

The following information provides examples for configuring mesh WDS.

Prerequisites

This document applies to Comware 7-based access points. Procedures and information in the examples might be slightly different depending on the software or hardware version of the access points.

The configuration examples in this document were created and verified in a lab environment, and all the devices were started with the factory default configuration. When you are working on a live network, make sure you understand the potential impact of every command on your network.

This document assumes that you have basic knowledge of WLAN mesh.

Mesh WDS configuration examples

Example: Configuring point-to-point WDS of fat APs

Network configuration

As shown in Figure 1, deploy a point-to-point WDS of two fat APs to provide Layer 2 wireless connectivity between two LANs. Configure the APs to use 802.11ax to establish a WDS link on channel 149.

 

 

NOTE:

Support for the 802.11ax mode depends on the device model.

 

Figure 1 Network diagram

 

Procedures

Configuring AP 1

1.     Configure AP interfaces:

# Create VLAN-interface 1, and assign an IP address to the VLAN interface.

<AP1> system-view

[AP1] interface vlan-interface 1

[AP1-Vlan-interface1] ip address 192.168.0.1 24

[AP1-Vlan-interface1] quit

# Create VLAN 100 and VLAN-interface 100, and assign an IP address to the VLAN interface. Hosts in LAN 1 will communicate with hosts in LAN 2 through this interface.

[AP1] vlan 100

[AP1-vlan100] quit

[AP1] interface vlan-interface 100

[AP1-Vlan-interface100] ip address 192.168.1.1 24

[AP1-Vlan-interface100] quit

# Assign GigabitEthernet 1/0/1 to VLAN 2.

[AP1] vlan 100

[AP1-vlan100] port GigabitEthernet 1/0/1

[AP1-vlan100] quit

2.     Configure a mesh profile:

# Create mesh profile 1.

[AP1] wlan mesh-profile 1

# Assign mesh ID 1 to the mesh profile.

[AP1-wlan-mesh-profile-1] mesh-id 1

# Set the AKM mode to SAE.

[AP1-wlan-mesh-profile-1] akm mode sae

# Configure simple character string 12345678 as the PSK.

[AP1-wlan-mesh-profile-1] preshared-key pass-phrase simple 12345678

# Enable the mesh profile.

[AP1-wlan-mesh-profile-1] mesh-profile enable

[AP1-wlan-mesh-profile-1] quit

3.     Configure the radio interface:

# Bind mesh profile 1 to interface WLAN-Radio 1/0/1.

[AP1] interface wlan-radio 1/0/1

[AP1-WLAN-Radio1/0/1] mesh-profile 1

# Specify the radio mode as 802.11ax.

[AP1-WLAN-Radio1/0/1] type dot11ax

# Specify channel 149 as the working channel.

[AP1-WLAN-Radio1/0/1] channel 149

# Add the MAC address of AP 2 to the mesh peer whitelist. This enables AP 1 to establish a mesh link only with AP 2 to avoid loops.

[AP1-WLAN-Radio1/0/1] mesh peer-mac-address d461-fe59-4d20

# Enable the radio interface.

[AP1-WLAN-Radio1/0/1] undo shutdown

[AP1-WLAN-Radio1/0/1] quit

4.     Configure a static route.

[AP1] ip route-static 192.168.2.0 255.255.255.0 192.168.0.2

Configuring AP 2

1.     Configure AP interfaces:

# Create VLAN-interface 1, and assign an IP address to the VLAN interface.

<AP2> system-view

[AP2] interface vlan-interface 1

[AP2-Vlan-interface1] ip address 192.168.0.2 24

[AP2-Vlan-interface1] quit

# Create VLAN 200 and VLAN-interface 200, and assign an IP address to the VLAN interface. Hosts in LAN 2 will communicate with hosts in LAN 1 through this interface.

[AP2] vlan 200

[AP2-vlan200] quit

[AP2] interface vlan-interface 200

[AP2-Vlan-interface200] ip address 192.168.2.1 24

[AP2-Vlan-interface200] quit

# Assign GigabitEthernet 1/0/1 to VLAN 200.

[AP2] vlan 200

[AP2-vlan200] port GigabitEthernet 1/0/1

[AP2-vlan200] quit

2.     Configure a mesh profile:

# Create mesh profile 1.

[AP2] wlan mesh-profile 1

# Assign mesh ID 1 to the mesh profile.

[AP2-wlan-mesh-profile-1] mesh-id 1

# Set the AKM mode to SAE.

[AP2-wlan-mesh-profile-1] akm mode sae

# Configure simple character string 12345678 as the PSK.

[AP2-wlan-mesh-profile-1] preshared-key pass-phrase simple 12345678

# Enable the mesh profile.

[AP2-wlan-mesh-profile-1] mesh-profile enable

[AP2-wlan-mesh-profile-1] quit

3.     Configure the radio interface:

# Bind mesh profile 1 to interface WLAN-Radio 1/0/1.

[AP2] interface wlan-radio 1/0/1

[AP2-WLAN-Radio1/0/1] mesh-profile 1

# Specify the radio mode as 802.11ax.

[AP2-WLAN-Radio1/0/1] type dot11ax

# Specify channel 149 as the working channel.

[AP2-WLAN-Radio1/0/1] channel 149

# Add the MAC address of AP 1 to the mesh peer whitelist. This enables AP 2 to establish a mesh link only with AP 1 to avoid loops.

[AP2-WLAN-Radio1/0/1] mesh peer-mac-address 84d9-316b-93a0

# Enable the radio interface.

[AP2-WLAN-Radio1/0/1] undo shutdown

[AP2-WLAN-Radio1/0/1] quit

4.     Configure a static route.

[AP2] ip route-static 192.168.1.0 255.255.255.0 192.168.0.1

Verifying the configuration

# Verify that you can view information about the mesh link on AP 1.

<AP1> display wlan mesh-link

Peer MAC       RSSI BSSID          Interface         Link state Online time   

d461-fe59-4d20 87   84d9-316b-93a0 WLAN-MeshLink51   Active     00h 00m 12s

# Verify that you can view information about the mesh link on AP 2.

<AP2> display wlan mesh-link

Peer MAC       RSSI BSSID          Interface         Link state Online time   

84d9-316b-93a0 84   d461-fe59-4d20 WLAN-MeshLink259  Active     00h 06m 31s

# Verify that hosts in LAN 1 and hosts in LAN 2 can ping each other successfully.

Configuration files

·     AP 1:

#                                                                              

 sysname AP1                                                                     

#                                                                               

 wlan mesh-profile 1                                                            

 mesh-id 1                                                                     

 akm mode sae                                                                   

 preshared-key pass-phrase cipher $c$3$vn2DU2ACd3o9CbivCPPh9issxj6Rmja5gMQA    

 mesh-profile enable                                                           

#                                                                               

vlan 1                                                                         

#                                                                              

vlan 100                                                                          

#                                                                              

interface Vlan-interface1                                                      

 ip address 192.168.0.1 255.255.255.0                                       

#                                                                              

interface Vlan-interface100                                                    

 ip address 192.168.1.1 255.255.255.0

#                                                                               

interface GigabitEthernet1/0/1                                                 

port access vlan 100

#                                                                              

interface WLAN-Radio1/0/1                                                      

 mesh-profile 1                                                                

 mesh peer-mac-address d461-fe59-4d20                                          

 type dot11ax                                                                   

 channel 149                                                                   

#                                                                              

 ip route-static 192.168.2.0 24 192.168.0.2

#                                                                              

return            

·     AP 2:

#                                                                              

 sysname AP2                                                                     

#                                                                              

 wlan mesh-profile 1                                                            

 mesh-id 1                                                                      

 akm mode sae                                                                  

 preshared-key pass-phrase cipher $c$3$vn2DU2ACd3o9CbivCPPh9issxj6Rmja5gMQA    

 mesh-profile enable                                                            

#                                                                              

vlan 1                                                                         

#                                                                              

vlan 200                                                                         

#                                                                              

interface Vlan-interface1                                                      

 ip address 192.168.0.2 255.255.255.0                                      

#                                                                              

interface Vlan-interface200                                                    

 ip address 192.168.2.1 255.255.255.0

#                                                                              

interface GigabitEthernet1/0/1                                                 

port access vlan 200

#                                                                               

interface WLAN-Radio1/0/1                                                      

 mesh-profile 1                                                                

 mesh peer-mac-address 84d9-316b-93a0                                           

 type dot11ax                                                                   

 channel 149                                                                   

#                                                                              

 ip route-static 192.168.1.0 24 192.168.0.1

#                                                                              

return            

Example: Configuring point-to-point WDS of both fat and fit APs

Network configuration

As shown in Figure 2, the MPP connects to the AC through a switch, and a server is attached to the switch. Deploy a point-to-point WDS of a fat AP and a fit AP to provide Layer 2 wireless connectivity between two LANs. Configure the APs to use 802.11ax to establish a WDS link on channel 149.

 

 

NOTE:

Support for the 802.11ax mode depends on the device model.

 

Figure 2 Network diagram

 

Procedures

Configuring the AC

1.     Configure the DHCP service:

# Enable DHCP.

<AC> system-view

[AC] dhcp enable

# Create DHCP address pool 1, specify subnet 192.168.0.0/24, and specify gateway address 192.168.0.1. The AC will use this address pool to assign IP addresses to the fit AP and the server.

[AC] dhcp server ip-pool 1

[AC-dhcp-pool-1] network 192.168.0.0 mask 255.255.255.0

[AC-dhcp-pool-1] gateway-list 192.168.0.1

[AC-dhcp-pool-1] quit

2.     Create VLAN-interface 1, and assign an IP address to the VLAN interface.

[AC] interface vlan-interface 1

[AC-Vlan-interface1] ip address 192.168.0.1 255.255.255.0

[AC-Vlan-interface1] quit

3.     Configure a mesh profile:

# Create mesh profile 1.

<AC> system-view

[AC] wlan mesh-profile 1

# Assign mesh ID 1 to the mesh profile.

[AC-wlan-mesh-profile-1] mesh-id 1

# Set the AKM mode to SAE.

[AC-wlan-mesh-profile-1] akm mode sae

# Configure simple character string 12345678 as the PSK.

[AC-wlan-mesh-profile-1] preshared-key pass-phrase simple 12345678

# Enable the mesh profile.

[AC-wlan-mesh-profile-1] mesh-profile enable

[AC-wlan-mesh-profile-1] quit

4.     Configure the MPP:

# Create AP mpp, and specify the AP model and serial ID.

[AC] wlan ap mpp model WA6620

[AC-wlan-ap-mpp] serial-id 219801A2BQ8207E0000S

# Bind mesh profile 1 to radio 1.

[AC-wlan-ap-mpp] radio 1

[AC-wlan-ap-mpp-radio-1] mesh-profile 1

# Set the radio mode to 802.11ax.

[AC-wlan-ap-mpp-radio-1] type dot11ax

# Specify channel 149 as the working channel.

[AC-wlan-ap-mpp-radio-1] channel 149

# Enable the radio.

[AC-wlan-ap-mpp-radio-1] radio enable

[AC-wlan-ap-mpp-radio-1] quit

# Disable an MPP from sending probe requests.

[AC-wlan-ap-mpp] portal-service enable

[AC-wlan-ap-mpp] quit

5.     Configure a static route.

[AC]ip route-static 192.168.1.0 255.255.255.0 192.168.0.2

Configuring the fat AP

1.     Configure a mesh profile:

# Create mesh profile 1.

<MAP> system-view

[MAP] wlan mesh-profile 1

# Assign mesh ID 1 to the mesh profile.

[MAP1-wlan-mesh-profile-1] mesh-id 1

# Set the AKM mode to SAE.

[MAP-wlan-mesh-profile-1] akm mode sae

# Configure simple character string 12345678 as the PSK.

[MAP-wlan-mesh-profile-1] preshared-key pass-phrase simple 12345678

# Enable the mesh profile.

[MAP-wlan-mesh-profile-1] mesh-profile enable

[MAP-wlan-mesh-profile-1] quit

2.     Create service template service1, set the SSID to mesh-network, and enable the service template.

[MAP] wlan service-template service1

[MAP-wlan-st-service1] ssid mesh-network

[MAP-wlan-st-service1] service-template enable

[MAP-wlan-st-service1] quit

3.     Configure the radio interface:

# Bind mesh profile 1 to interface WLAN-Radio 1/0/1.

[MAP] interface wlan-radio 1/0/1

[MAP-WLAN-Radio1/0/1] mesh-profile 1

# Bind service template service1 to interface WLAN-Radio 1/0/1.

[MAP-WLAN-Radio1/0/1] service-template service1

# Specify the radio mode as 802.11ax.

[MAP-WLAN-Radio1/0/1] type dot11ax

# Specify channel 149 as the working channel.

[MAP-WLAN-Radio1/0/1] channel 149

# Add the MAC address of the MPP to the mesh peer whitelist. This enables the MAP to establish a mesh link only with the MPP to avoid loops.

[MAP-WLAN-Radio1/0/1] mesh peer-mac-address ac74-090a-6420

# Enable the radio interface.

[MAP-WLAN-Radio1/0/1] undo shutdown

[MAP-WLAN-Radio1/0/1] quit

[MAP] quit

4.     Configure the DHCP service:

# Enable DHCP.

[MAP] dhcp enable

# Create a DHCP address pool named vlan100, specify subnet 192.168.1.0/24, and specify gateway address 192.168.1.1.

[MAP] dhcp server ip-pool vlan100

[MAP-dhcp-pool-vlan100] network 192.168.1.0 mask 255.255.255.0

[MAP-dhcp-pool-vlan100] gateway-list 192.168.1.1

[MAP-dhcp-pool-vlan100] quit

Verifying the configuration

# Execute the display wlan mesh-link ap command on the AC to verify that the MPP and the MAP have established a mesh link.

<AC>display wlan mesh-link ap                                                 

AP name: mpp                                                                  

 Peer           Local          Status     RSSI Packets(Rx/Tx)                  

 d461-fe59-4d20 ac74-090a-6420 Forwarding 84   75/206

# Execute the display wlan mesh-link command on the MAP to verify that the MAP and the MPP have established a mesh link.

<MAP> display wlan mesh-link

Peer MAC       RSSI BSSID          Interface         Link state Online time   

 ac74-090a-6420 82   d461-fe59-4d20 WLAN-MeshLink231  Active     00h 46m 53s

# Verify that the client and the server can ping each other successfully.

Configuration files

·     MAP:

#                                                                               

 sysname MAP                                                                   

#                                                                              

 dhcp enable                                                                    

#                                                                              

wlan mesh-profile 1                                                            

 mesh-id 1                                                                      

 akm mode sae                                                                  

 preshared-key pass-phrase cipher $c$3$MA+IbbyMk2HFZPOGPZtCOu/7tC0zlT4/9HuX    

 mesh-profile enable                                                            

#                                                                               

vlan 1                                                                         

#                                                                              

vlan 100                                                                        

#                                                                              

dhcp server ip-pool vlan100                                                    

 gateway-list 192.168.1.1                                                       

 network 192.168.1.0 mask 255.255.255.0                                         

#                                                                              

wlan service-template service1                                                 

 ssid mesh-network                                                             

 vlan 100                                                                      

 service-template enable                                                        

#                                                                              

interface NULL0                                                                

#                                                                               

interface Vlan-interface1                                                      

 ip address 192.168.0.2 255.255.255.0                                          

#                                                                              

interface Vlan-interface100                                                    

 ip address 192.168.1.1 255.255.255.0                                           

#                                                                               

interface WLAN-Radio1/0/1                                                      

 service-template service1                                                     

 mesh-profile 1                                                                 

 mesh peer-mac-address ac74-090a-6420                                          

 type dot11ax                                                                  

 channel 149                                                                    

#                                                                              

return

·     AC:

#                                                                              

 sysname AC                                                                

#                                                                              

 telnet server enable                                                          

#                                                                               

 dhcp enable                                                                   

#                                                                              

wlan mesh-profile 1                                                            

 mesh-id 1                                                                     

 akm mode sae                                                                  

 preshared-key pass-phrase cipher $c$3$L7PLM5cfBX+LuA9AXhbmYQgz0yU1pcc0y26/    

 mesh-profile enable                                                            

#                                                                              

vlan 1                                                                          

#                                                                              

dhcp server ip-pool 1                                                         

 gateway-list 192.168.0.1                                                     

 network 192.168.0.0 mask 255.255.255.0                                         

#                                                                              

interface Vlan-interface1                                                       

 ip address 192.168.0.1 255.255.255.0                                         

#                                                                              

 ip route-static 192.168.1.0 24 192.168.0.2                                    

#                                                                              

wlan ap mpp model WA6620                                                      

 serial-id 219801A2BQ8207E0000S                                                

 radio 1                                                                       

  type dot11ax                                                                 

  channel 149                                                                  

  radio enable                                                                  

  mesh-profile 1                                                               

#                                                                              

return

Related documentation

·     WLAN Mesh Command Reference in H3C Access Points Command References

·     WLAN Mesh Configuration Guide in H3C Access Points Configuration Guides

  • Cloud & AI
  • InterConnect
  • Intelligent Computing
  • Security
  • SMB Products
  • Intelligent Terminal Products
  • Product Support Services
  • Technical Service Solutions
All Services
  • Resource Center
  • Policy
  • Online Help
All Support
  • Become a Partner
  • Partner Resources
  • Partner Business Management
All Partners
  • Profile
  • News & Events
  • Online Exhibition Center
  • Contact Us
All About Us
新华三官网