04-CLI configuration examples (AP standalone)

HomeSupportDoc SetsDoc PackagesH3C Wireless Products All-in-One-6W10004-CLI configuration examples (AP standalone)
19-Anchor AC Mode Remote AP Configuration Examples

 

H3C Anchor Access Points in AC Mode

Remote AP Configuration Examples

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Copyright © 2022 New H3C Technologies Co., Ltd. All rights reserved.

No part of this manual may be reproduced or transmitted in any form or by any means without prior written consent of New H3C Technologies Co., Ltd.

Except for the trademarks of New H3C Technologies Co., Ltd., any trademarks that may be mentioned in this document are the property of their respective owners.

The information in this document is subject to change without notice.



Overview

The following information provides an example for configuring remote AP by an anchor AP that acts as an AC.

Prerequisites

This document applies to Comware 7-based access controllers and access points. Procedures and information in the examples might be slightly different depending on the software or hardware version of the access controllers and access points.

The configuration examples in this document were created and verified in a lab environment, and all the devices were started with the factory default configuration. When you are working on a live network, make sure you understand the potential impact of every command on your network.

This document assumes that you have basic knowledge of remote AP.

Example: Configuring remote AP

Network configuration

As shown in Figure 1, the AP connects to the AC through the switch, and the switch acts as a DHCP server to assign IP addresses to the AP and the clients. Configure remote AP on the AC so that the AP can still provide services for clients when the tunnel between the AP and the AC is disconnected.

Figure 1 Network diagram

 

Restrictions and guidelines

When you configure remote AP, follow these restrictions and guidelines:

·     Use the serial ID labeled on the AP's rear panel to specify an AP.

·     For new clients to come online, make sure the clients are associated with and authenticated at APs. In this case, use simple text or PSK encryption as a best practice.

·     Remote AP takes effect only on an AP that operates in local forwarding mode.

·     For GigabitEthernet 1/0/1 on the AP to join VLAN 200, edit the AP configuration file, and upload it to the storage media of the AC.

Procedures

Configuring the AC

1.     Configure interfaces on the AC:

# Create VLAN 100 and VLAN-interface 100, and assign an IP address to the VLAN interface. The AC will use this IP address to establish CAPWAP tunnels with APs.

<AC> system-view

[AC] vlan 100

[AC-vlan100] quit

[AC] interface vlan-interface 100

[AC-Vlan-interface100] ip address 192.1.0.1 16

[AC-Vlan-interface100] quit

# Create VLAN 200. The AC will use VLAN 200 for client access.

[AC] vlan 200

[AC-vlan200] quit

# Configure GigabitEthernet 1/0/1 that connects the AC and the switch as a trunk port, and assign it to VLAN 100.

[AC] interface gigabitethernet 1/0/1

[AC-GigabitEthernet1/0/1] port link-type trunk

[AC-GigabitEthernet1/0/1] port trunk permit vlan 100

[AC-GigabitEthernet1/0/1] quit

2.     Configure wireless services:

# Create service template named 1 and enter its view.

[AC] wlan service-template 1

# Configure the SSID of service template 1 as service.

[AC-wlan-st-1] ssid service

# Specify the AKM as PSK and specify plaintext pre-shared key 12345678.

[AC-wlan-st-1] akm mode psk

[AC-wlan-st-1] preshared-key pass-phrase simple 12345678

# Specify the cipher suite as CCMP and enable the RSN security IE.

[AC-wlan-st-1] cipher-suite ccmp

[AC-wlan-st-1] security-ie rsn

# Enable local forwarding.

[AC-wlan-st-1] client forwarding-location ap

# Configure clients to be associated with and authenticated at APs.

[AC-wlan-st-1] client-security authentication-location ap

[AC-wlan-st-1] client association-location ap

# Enable the service template.

[AC-wlan-st-1] service-template enable

[AC-wlan-st-1] quit

3.     Configure the AP:

 

 

NOTE:

In a large-scale network, configure AP groups instead of single APs as a best practice.

 

# Create a manual AP named officeap, and specify the AP model and serial ID.

[AC] wlan ap officeap model WA6320

[AC-wlan-ap-officeap] serial-id 219801A28N819CE0002T

# Add the AP to AP group group1.

[AC] wlan ap-group group1

[AC-wlan-ap-group-group1] ap officeap

# Bind service template 1 and VLAN 200 to radio 2.

[AC-wlan-ap-group-group1] ap-model WA6320

[AC-wlan-ap-group-group1-ap-model-WA6320] radio 2

[AC-wlan-ap-group-group1-ap-model-WA6320-radio-2] service-template 1 vlan 200

# Enable radio 2.

[AC-wlan-ap-group-group1-ap-model-WA6320-radio-2] radio enable

[AC-wlan-ap-group-group1-ap-model-WA6320-radio-2] quit

# Deploy configuration file apcfg.txt to the AP.

[AC-wlan-ap-group-group1-ap-model-WA6320] map-configuration flash:/apcfg.txt

[AC-wlan-ap-group-group1-ap-model-WA6320] quit

# Enable remote AP.

[AC-wlan-ap-group-group1] hybrid-remote-ap enable

[AC-wlan-ap-group-group1] quit

Configuring the switch

1.     Configure interfaces on the switch:

# Create VLAN 100 and VLAN-interface 100, and assign an IP address to the VLAN interface. The switch will use VLAN 100 to forward the traffic on the CAPWAP tunnel between the AC and AP.

<Switch> system-view

[Switch] vlan 100

[Switch-vlan100] quit

[Switch] interface vlan-interface 100

[Switch-Vlan-interface100] ip address 192.1.0.2 16

[Switch-Vlan-interface100] quit

# Create VLAN 200 and VLAN-interface 200, and assign an IP address to the VLAN interface. The switch will use VLAN 200 to forward client traffic.

[Switch] vlan 200

[Switch-vlan200] quit

[Switch] interface vlan-interface 200

[Switch-Vlan-interface200] ip address 192.2.0.2 16

[Switch-Vlan-interface200] quit

# Configure GigabitEthernet 1/0/1 that connects the switch and the AC as a trunk port, and assign the trunk port to VLAN 100.

[Switch] interface gigabitethernet 1/0/1

[Switch-GigabitEthernet1/0/1] port link-type trunk

[Switch-GigabitEthernet1/0/1] port trunk permit vlan 100

[Switch-GigabitEthernet1/0/1] quit

# Configure GigabitEthernet 1/0/2 that connects the switch to the AP as a trunk port, remove the port from VLAN 1, assign the trunk port to VLANs 100 and 200, and set the PVID to VLAN 100.

[Switch] interface gigabitethernet 1/0/2

[Switch-GigabitEthernet1/0/2] port link-type trunk

[Switch-GigabitEthernet1/0/2] undo port trunk permit vlan 1

[Switch-GigabitEthernet1/0/2] port trunk permit vlan 100 200

[Switch-GigabitEthernet1/0/2] port trunk pvid vlan 100

[Switch-GigabitEthernet1/0/2] quit

2.     Configure the DHCP service:

# Enable DHCP.

[Switch] dhcp enable

# Create DHCP address pool vlan100, specify subnet 192.1.0.0/16 for dynamic allocation, exclude 192.1.0.1 from dynamic allocation, and specify gateway IP address 192.1.0.2.

[Switch] dhcp server ip-pool vlan100

[Switch-dhcp-pool-vlan100] network 192.1.0.0 mask 255.255.0.0

[Switch-dhcp-pool-vlan100] forbidden-ip 192.1.0.1

[Switch-dhcp-pool-vlan100] gateway-list 192.1.0.2

[Switch-dhcp-pool-vlan100] quit

# Create DHCP address pool vlan200, specify subnet 192.2.0.0/16 for dynamic allocation, and exclude 192.2.0.1 from dynamic allocation. Specify gateway IP address 192.2.0.2, and specify the DNS server address. In this example, the gateway also acts as a DNS server.

[Switch] dhcp server ip-pool vlan200

[Switch-dhcp-pool-vlan200] network 192.2.0.0 mask 255.255.0.0

[Switch-dhcp-pool-vlan200] forbidden-ip 192.2.0.1

[Switch-dhcp-pool-vlan200] gateway-list 192.2.0.2

[Switch-dhcp-pool-vlan200] dns-list 192.2.0.2

[Switch-dhcp-pool-vlan200] quit

Configuring AP configuration file apcfg.txt

# Copy the following text to a text file and upload the file to the AC.

system-view

vlan 200

interface GigabitEthernet 1/0/1

port link-type trunk

port trunk permit vlan 200

Verifying the configuration

# Verify that clients remain online and the AP can still forward client traffic when the tunnel between the AP and the AC is disconnected. (Details not shown.)

Configuration files

·     AC (anchor AP):

#

vlan 100

#

vlan 200

#

wlan service-template 1

 ssid service

 client forwarding-location ap

 akm mode psk

 preshared-key pass-phrase cipher $c$3$N//5BVbsOqdBTxi+7MJZKT6Zqh5MAmYs2ZzM

 cipher-suite ccmp

 security-ie rsn

 client-security authentication-location ap

 client association-location ap

 service-template enable

#

interface Vlan-interface100

 ip address 192.1.0.1 255.255.0.0

#                                                                              

wlan ap-group group1                                                           

 hybrid-remote-ap enable

 ap ap1                                                                        

 ap-model WA6320                                                               

  radio 2                                                                       

   radio enable                                                                

   service-template 1 vlan 200

   map-configuration flash:/apcfg.txt

#

wlan ap officeap model WA6320

serial-id 219801A28N819CE0002T

 gigabitethernet 1

 gigabitethernet 2

#

·     apcfg.txt:

system-view

vlan 200

quit

interface GigabitEthernet 1/0/1

port link-type trunk

port trunk permit vlan 200

·     Switch:

#

dhcp enable

#

vlan 100

#

vlan 200

#

dhcp server ip-pool vlan100

 gateway-list 192.1.0.2

 network 192.1.0.0 mask 255.255.0.0

 forbidden-ip 192.1.0.1

#

dhcp server ip-pool vlan200

 gateway-list 192.2.0.2

 network 192.2.0.0 mask 255.255.0.0

 dns-list 192.2.0.2

 forbidden-ip 192.2.0.1

#

interface Vlan-interface100

 ip address 192.1.0.2 255.255.0.0

#

interface Vlan-interface200

 ip address 192.2.0.2 255.255.0.0

#

interface GigabitEthernet1/0/1

 port link-type trunk

port trunk permit vlan 100

#

interface GigabitEthernet1/0/2

 port link-type trunk

 undo port trunk permit vlan 1

 port trunk permit vlan 100 200

 port trunk pvid vlan 100

#

Related documentation

·     AP Management Command Reference in H3C Access Points Anchor AC Mode Command References

·     AP Management Configuration Guide in H3C Access Points Anchor AC Mode Configuration Guides

·     Network Connectivity Command Reference in H3C Access Points Anchor AC Mode Command References

·     Network Connectivity Configuration Guide in H3C Access Points Anchor AC Mode Configuration Guides

  • Cloud & AI
  • InterConnect
  • Intelligent Computing
  • Security
  • SMB Products
  • Intelligent Terminal Products
  • Product Support Services
  • Technical Service Solutions
All Services
  • Resource Center
  • Policy
  • Online Help
All Support
  • Become a Partner
  • Partner Resources
  • Partner Business Management
All Partners
  • Profile
  • News & Events
  • Online Exhibition Center
  • Contact Us
All About Us
新华三官网