04-Comware 7 CLI-based configuration examples (AC+fit AP deployment)

HomeSupportDoc SetsDoc PackagesH3C Wireless Products All-in-One-6W10104-Comware 7 CLI-based configuration examples (AC+fit AP deployment)
Table of Contents
Related Documents
64-Data Filtering Configuration Examples
Title Size Download
64-Data Filtering Configuration Examples 106.94 KB

 

H3C Access Controllers

Data Filtering Configuration Examples

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Copyright © 2023 New H3C Technologies Co., Ltd. All rights reserved.

No part of this manual may be reproduced or transmitted in any form or by any means without prior written consent of New H3C Technologies Co., Ltd.

Except for the trademarks of New H3C Technologies Co., Ltd., any trademarks that may be mentioned in this document are the property of their respective owners.

The information in this document is subject to change without notice.



Introduction

The following information provides an example of configuring data filtering.

Prerequisites

The following information applies to Comware-based access controllers and access points. Procedures and information in the examples might be slightly different depending on the software or hardware version of the access controllers and access points.

The configuration examples were created and verified in a lab environment, and all the devices were started with the factory default configuration. When you are working on a live network, make sure you understand the potential impact of every command on your network.

The following information is provided based on the assumption that you have basic knowledge of data filtering and security policy.

Example: Configuring data filtering

Network configuration

As shown in Figure 1, the AC connects to the external network.

Configure data filtering on the AC so the AC performs the following operations:

·     Blocks HTTP packets that contain the uri or abc.*abc string in the URI field or message body.

·     Blocks download FTP traffic that contains the www.abcd.com/ string.

·     Logs the blocked packets.

Figure 1 Network diagram

 

Restrictions and guidelines

·     Use the actual serial ID of an AP to uniquely identify that AP.

·     Configure the AC to forward client traffic.

Procedures

Configuring the AC

Configuring the basic AC features

1.     Configure interfaces on the AC:

# Create VLAN 100 and VLAN-interface 100, and assign an IP address to the VLAN interface. The AP will obtain this IP address to establish CAPWAP tunnels with the AC.

<AC> system-view

[AC] vlan 100

[AC-vlan100] quit

[AC] interface vlan-interface 100

[AC-Vlan-interface100] ip address 192.1.1.1 24

[AC-Vlan-interface100] quit

# Create VLAN 200 and VLAN-interface 200, and assign an IP address to the VLAN interface. The client will access the wireless network in this VLAN.

[AC] vlan 200

[AC-vlan200] quit

[AC] interface vlan-interface 200

[AC-Vlan-interface200] ip address 192.2.1.1 24

[AC-Vlan-interface200] quit

# Set the link type of GigabitEthernet 1/0/1 (the interface connected to the switch) to trunk, and allow traffic from VLAN 100 and VLAN 200 to pass through the interface.

[AC] interface gigabitethernet 1/0/1

[AC-GigabitEthernet1/0/1] port link-type trunk

[AC-GigabitEthernet1/0/1] port trunk permit vlan 100 200

[AC-GigabitEthernet1/0/1] quit

2.     Configure a wireless service:

# Create service template 1 and enter service template view.

[AC] wlan service-template 1

# Set the SSID to service.

[AC-wlan-st-1] ssid service

# Set the AKM mode to PSK and configure simple character string 12345678 as the PSK.

[AC-wlan-st-1] akm mode psk

[AC-wlan-st-1] preshared-key pass-phrase simple 12345678

# Set the AES-CCMP cipher suite for frame encryption, and enable the RSN IE in beacon and probe responses.

[AC-wlan-st-1] cipher-suite ccmp

[AC-wlan-st-1] security-ie rsn

# Configure the AC to forward client traffic. If the default client traffic forwarding location is the same as the configuration in this step, you can skip this step.

[AC-wlan-st-1] client forwarding-location ac

# Assign the client to VLAN 200 after it comes online.

[AC-wlan-st-1] vlan 200

# Enable the service template.

[AC-wlan-st-1] service-template enable

[AC-wlan-st-1] quit

3.     Configure the AP:

 

IMPORTANT

IMPORTANT:

In a large-scale network, configure AP groups as a best practice.

 

# Create a manual AP named ap1, and specify the AP model.

[AC] wlan ap ap1 model WA6320

# Set the serial ID to 219801A28N819CE0002T.

[AC-wlan-ap-ap1] serial-id 219801A28N819CE0002T

[AC-wlan-ap-ap1] quit

# Create AP group group1 and create an AP grouping rule by AP names to add AP ap1 to AP group group1.

[AC] wlan ap-group group1

[AC-wlan-ap-group-group1] ap ap1

# Bind service template 1 to radio 1 in AP group group1.

[AC-wlan-ap-group-group1] ap-model WA6320

[AC-wlan-ap-group-group1-ap-model-WA6320] radio 1

[AC-wlan-ap-group-group1-ap-model-WA6320-radio-1] service-template 1

# Enable radio 1.

[AC-wlan-ap-group-group1-ap-model-WA6320-radio-1] radio enable

[AC-wlan-ap-group-group1-ap-model-WA6320-radio-1] quit

# Bind service template 1 to radio 2 in AP group group1.

[AC-wlan-ap-group-group1-ap-model-WA6320] radio 2

[AC-wlan-ap-group-group1-ap-model-WA6320-radio-2] service-template 1

# Enable radio 2.

[AC-wlan-ap-group-group1-ap-model-WA6320-radio-2] radio enable

[AC-wlan-ap-group-group1-ap-model-WA6320-radio-2] return

Configuring an object group

# Configure an IP address object group named datafilter and specify subnet 192.2.1.0/24 for the object group.

<AC> system-view

[AC] object-group ip address datafilter

[AC-obj-grp-ip-datafilter] network subnet 192.2.1.0 24

[AC-obj-grp-ip-datafilter] quit

Configuring data filtering

1.     Configure keyword groups:

# Create a keyword group named kg1 and enter its view.

[AC] data-filter keyword-group kg1

# Create two keyword match patterns that match the uri text string and the abc.*abc regular expression string, respectively.

[AC-data-filter-kgroup-kg1] pattern 1 text uri

[AC-data-filter-kgroup-kg1] pattern 2 regex abc.*abc

[AC-data-filter-kgroup-kg1] quit

# Create a keyword group named kg2 and enter its view.

[AC] data-filter keyword-group kg2

# Create a keyword match pattern that matches the www.abcd.com/ text string.

[AC-data-filter-kgroup-kg2] pattern 1 text www.abcd.com

[AC-data-filter-kgroup-kg2] quit

2.     Configure a data filtering policy:

# Create a data filtering policy named p1 and enter its view.

[AC] data-filter policy p1

# Create a data filtering rule named r1 and enter its view.

[AC-data-filter-policy-p1] rule r1

# Configure the rule to drop and log both upload and download HTTP traffic that matches keyword group kg1.

[AC-data-filter-policy-p1-rule-r1] keyword-group kg1

[AC-data-filter-policy-p1-rule-r1] application type http

[AC-data-filter-policy-p1-rule-r1] direction both

[AC-data-filter-policy-p1-rule-r1] action drop logging

[AC-data-filter-policy-p1-rule-r1] quit

# Create a data filtering rule named r2 and enter its view.

[AC-data-filter-policy-p1] rule r2

# Configure the rule to drop and log download FTP traffic that matches keyword group kg2.

[AC-data-filter-policy-p1-rule-r2] keyword-group kg2

[AC-data-filter-policy-p1-rule-r2] application type ftp

[AC-data-filter-policy-p1-rule-r2] direction download

[AC-data-filter-policy-p1-rule-r2] action drop logging

[AC-data-filter-policy-p1-rule-r2] quit

[AC-data-filter-policy-p1] quit

Applying the data filtering policy to a DPI application profile

# Create a DPI application profile named profile1 and enter its view.

[AC] app-profile profile1

# Apply data filtering policy p1 to the DPI application profile.

[AC-app-profile-profile1] data-filter apply policy p1

[AC-app-profile-profile1] quit

# Activate the data filtering policy and rule settings.

[AC] inspect activate

Applying the DPI application profile to a security policy

# Enter IPv4 security policy view.

[AC] security-policy ip

# Create a security policy rule named inspect1. Configure the rule to permit packets from IP addresses in IP address object group datafilter and apply DPI application profile profile1 to the security policy.

[AC-security-policy-ip] rule name inspect1

[AC-security-policy-ip-14-inspect1] source-ip datafilter

[AC-security-policy-ip-14-inspect1] action pass

[AC-security-policy-ip-14-inspect1] profile profile1

[AC-security-policy-ip-14-inspect1] quit

# Activate rule matching acceleration.

[AC-security-policy-ip] accelerate enhanced enable

[AC-security-policy-ip] quit

Configuring the switch

1.     Configure interfaces on the switch:

# Create VLAN 100 and VLAN-interface 100, and assign an IP address to the VLAN interface. The switch will use this VLAN to forward CAPWAP tunnel traffic between the AC and the AP.

<Switch> system-view

[Switch] vlan 100

[Switch-vlan100] quit

[Switch] interface vlan-interface 100

[Switch-Vlan-interface100] ip address 192.1.1.2 24

[Switch-Vlan-interface100] quit

# Create VLAN 200 and VLAN-interface 200, and assign an IP address to the VLAN interface. This VLAN will be used to forward wireless client packets.

[Switch] vlan 200

[Switch-vlan200] quit

[Switch] interface vlan-interface 200

[Switch-Vlan-interface200] ip address 192.2.1.2 24

[Switch-Vlan-interface200] quit

# Set the link type of GigabitEthernet 1/0/1 (the interface connected to the AC) to trunk, and allow traffic from VLAN 100 and VLAN 200 to pass through the interface.

[Switch] interface gigabitethernet 1/0/1

[Switch-GigabitEthernet1/0/1] port link-type trunk

[Switch-GigabitEthernet1/0/1] port trunk permit vlan 100 200

[Switch-GigabitEthernet1/0/1] quit

# Set the link type of GigabitEthernet 1/0/2 (the interface connected to the AP) to access, and allow only traffic from VLAN 100 to pass through the interface.

[Switch] interface gigabitethernet1/0/2

[Switch-GigabitEthernet1/0/2] port link-type access

[Switch-GigabitEthernet1/0/2] port access vlan 100

# Enable PoE.

[Switch-GigabitEthernet1/0/2] poe enable

[Switch-GigabitEthernet1/0/2] quit

2.     Configure DHCP settings:

# Enable DHCP.

[Switch] dhcp enable

# Create a DHCP address pool named vlan100 to assign IP addresses and other configuration parameters to clients on subnet 192.1.1.0/24.

[Switch] dhcp server ip-pool vlan100

[Switch-dhcp-pool-vlan100] network 192.1.1.0 mask 255.255.255.0

# Exclude IP addresses 192.1.1.1 and 192.1.1.2 from dynamic allocation.

[Switch-dhcp-pool-vlan100] forbidden-ip 192.1.1.1 192.1.1.2

# Specify a gateway.

[Switch-dhcp-pool-vlan100] gateway-list 192.1.1.1

[Switch-dhcp-pool-vlan100] quit

# Create a DHCP address pool named vlan200 to assign IP addresses and other configuration parameters to clients on subnet 192.2.1.0/24.

[Switch] dhcp server ip-pool vlan200

[Switch-dhcp-pool-vlan200] network 192.2.1.0 mask 255.255.255.0

# Exclude IP addresses 192.2.1.1 and 192.2.1.2 from dynamic allocation.

[Switch-dhcp-pool-vlan200] forbidden-ip 192.2.1.1 192.2.1.2

# Specify a gateway and a DNS server.

[Switch-dhcp-pool-vlan200] dns-list 192.2.1.1

[Switch-dhcp-pool-vlan200] gateway-list 192.2.1.1

[Switch-dhcp-pool-vlan200] quit

Verifying the configuration

# Verify that the AC blocks and logs HTTP packets and FTP packets that meet the specified criteria. (Details not shown.)

Configuration files

·     AC:

#

vlan 100

#

vlan 200

#

wlan service-template 1

 ssid service

 vlan 200

 akm mode psk

 preshared-key pass-phrase cipher $c$3$29gn1DalRVhkcyZ1CKwevH+xb6Lxopy3eq/H

 cipher-suite ccmp

 security-ie rsn

 service-template enable

#

interface Vlan-interface100

 ip address 192.1.1.1 255.255.255.0

#

interface Vlan-interface200

 ip address 192.2.1.1 255.255.255.0

#

interface GigabitEthernet1/0/1

 port link-type trunk

 port trunk permit vlan 100 200

#

wlan ap ap1 model WA6320

 serial-id 219801A28N819CE0002T

#

wlan ap-group group1

 vlan 1

 ap ap1

 ap-model WA6320

 radio 1

  radio enable

  service-template 1

 radio 2

  radio enable

  service-template 1

 gigabitethernet 1

#

object-group ip address datafilter

 0 network subnet 192.2.1.0 255.255.255.0

#

data-filter keyword-group kg1

 pattern 1 text uri

 pattern 2 regex abc.*abc

#

data-filter keyword-group kg2

 pattern 1 text www.abcd.com

#

data-filter policy p1

 rule r1

  keyword-group kg1

  application type http

  direction both

  action drop logging

 rule r2

  keyword-group kg2

  application type ftp

  direction download

  action drop logging

#

app-profile profile1

 data-filter apply policy p1

#

security-policy ip

 rule 1 name inspect1

  action pass

  profile profile1

  source-ip datafilter

·     Switch:

#

 dhcp enable

#

vlan 100

#

vlan 200

#

interface Vlan-interface100

 ip address 192.1.1.2 255.255.255.0

#

interface Vlan-interface200

 ip address 192.2.1.2 255.255.255.0

#

dhcp server ip-pool vlan100

 network 192.1.0.0 mask 255.255.255.0

 forbidden-ip 192.1.1.1 192.1.1.2

 gateway-list 192.1.1.1

#

dhcp server ip-pool vlan200

 gateway-list 192.2.1.1

 network 192.2.1.0 mask 255.255.255.0

 forbidden-ip 192.2.1.1 192.2.1.2

 dns-list 192.2.1.1

#

interface GigabitEthernet1/0/1

 port link-type trunk

 port trunk permit vlan 100 200

#

interface GigabitEthernet1/0/2

 port link-type access

 port access vlan 100

 poe enable

Related documentation

·     Data Filtering Command Reference in H3C Access Controllers Command References

·     Data Filtering Configuration Guide in H3C Access Controllers Configuration Guides

·     Security Policy Command Reference in H3C Access Controllers Command References

·     Security Policy Configuration Guide in H3C Access Controllers Configuration Guides

  • Cloud & AI
  • InterConnect
  • Intelligent Computing
  • Security
  • SMB Products
  • Intelligent Terminal Products
  • Product Support Services
  • Technical Service Solutions
All Services
  • Resource Center
  • Policy
  • Online Help
All Support
  • Become a Partner
  • Partner Resources
  • Partner Business Management
All Partners
  • Profile
  • News & Events
  • Online Exhibition Center
  • Contact Us
All About Us
新华三官网