04-Comware 7 CLI-based configuration examples (AC+fit AP deployment)

HomeSupportDoc SetsDoc PackagesH3C Wireless Products All-in-One-6W10104-Comware 7 CLI-based configuration examples (AC+fit AP deployment)
Table of Contents
Related Documents
59-IP Source Guard (IPv4) Configuration Examples
Title Size Download
59-IP Source Guard (IPv4) Configuration Examples 126.39 KB

 

H3C Access Controllers

IP Source Guard (IPv4)

Configuration Examples

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Copyright © 2023 New H3C Technologies Co., Ltd. All rights reserved.

No part of this manual may be reproduced or transmitted in any form or by any means without prior written consent of New H3C Technologies Co., Ltd.

Except for the trademarks of New H3C Technologies Co., Ltd., any trademarks that may be mentioned in this document are the property of their respective owners.

The information in this document is subject to change without notice.



Introduction

The following information provides an example for configuring IPv4 source guard (IPv4SG).

Prerequisites

The following information applies to Comware-based access controllers and access points. Procedures and information in the examples might be slightly different depending on the software or hardware version of the access controllers and access points.

The configuration examples were created and verified in a lab environment, and all the devices were started with the factory default configuration. When you are working on a live network, make sure you understand the potential impact of every command on your network.

This document assumes that you have basic knowledge of IPv4SG and WLAN.

Example: Configuring IPv4SG

Network configuration

As shown in Figure 1, the DHCP server assigns IP addresses to Client 1 and the AP. Client 2 is assigned a static IPv4 address.

Configure network settings to meet the following requirements:

·     Both of the clients access the same wireless network.

·     Enable IPv4SG to generate IPv4SG bindings based on DHCP so that the AP forwards the packets only from Client 1.

Figure 1 Network diagram

 

Restrictions and guidelines

When you configure a serial ID for the AP, use the serial ID labeled on the AP's rear panel.

Procedures

Configuring the AC

1.     Configure interfaces on the AC:

# Create VLAN 100 and VLAN-interface 100, and assign IP address 192.168.1.1 to the VLAN interface. The AC will establish a CAPWAP tunnel with the AP in this VLAN.

<AC> system-view

[AC] vlan 100

[AC-vlan100] quit

[AC] interface vlan-interface 100

[AC-Vlan-interface100] ip address 192.168.1.1 24

[AC-Vlan-interface100] quit

# Create VLAN 200. The AC will use this VLAN for client access.

[AC] vlan 200

[AC-vlan200] quit

# Configure GigabitEthernet 1/0/1 (port that connects the AC and the switch) as a trunk port. Remove the port from VLAN 1, and assign the port to VLAN 100 and VLAN 200.

[AC] interface gigabitethernet 1/0/1

[AC-GigabitEthernet1/0/1] port link-type trunk

[AC-GigabitEthernet1/0/1] undo port trunk permit vlan 1

[AC-GigabitEthernet1/0/1] port trunk permit vlan 100 200

[AC-GigabitEthernet1/0/1] quit

2.     Configure a wireless service:

# Create service template 1 and enter its view.

[AC] wlan service-template 1

# Set the SSID to service.

[AC-wlan-st-1] ssid service

# Enable snooping DHCP packets on the service template.

[AC-wlan-st-1] client ipv4-snooping dhcp-learning enable

# Enable IPv4SG on the service template.

[AC-wlan-st-1] ip verify source

# Specify PSK as the AKM mode and specify 12345678 as the plaintext key.

[AC-wlan-st-1] akm mode psk

[AC-wlan-st-1] preshared-key pass-phrase simple 12345678

# Specify CCMP as the cipher suite and specify RSN as the security IE.

[AC-wlan-st-1] cipher-suite ccmp

[AC-wlan-st-1] security-ie rsn

# Configure the AC to forward client data traffic. If the default client data traffic forwarder is AC, skip this step.

[AC-wlan-st-1] client forwarding-location ac

# Enable service template 1.

[AC-wlan-st-1] service-template enable

[AC-wlan-st-1] quit

3.     Configure AP settings:

 

 

NOTE:

To simply AP configuration on a large-scale network, configure AP settings on a per AP group basis as a best practice.

 

# Create AP officeap, and specify the AP model and serial ID.

[AC] wlan ap officeap model WA6320

[AC-wlan-ap-officeap] serial-id 209801A28N819CE0002T

[AC-wlan-ap-officeap] quit

# Create AP group group1 and configure officeap as the AP grouping rule.

[AC] wlan ap-group group1

[AC-wlan-ap-group-group1] ap officeap

# Bind service template 1 and VLAN 200 to radio 1 for AP group group1.

[AC-wlan-ap-group-group1] ap-model WA6320

[AC-wlan-ap-group-group1-ap-model-WA6320] radio 1

[AC-wlan-ap-group-group1-ap-model-WA6320-radio-1] service-template 1 vlan 200

# Enable radio 1.

[AC-wlan-ap-group-group1-ap-model-WA6320-radio-1] radio enable

[AC-wlan-ap-group-group1-ap-model-WA6320-radio-1] quit

[AC-wlan-ap-group-group1-ap-model-WA6320] quit

[AC-wlan-ap-group-group1] quit

Configuring the switch

1.     Configure switch interfaces:

# Create VLAN 100. The switch will use this VLAN to forward the traffic on the CAPWAP tunnel between the AC and the AP.

<Switch> system-view

[Switch] vlan 100

[Switch-vlan100] quit

# Create VLAN 200. The switch will use this VLAN to forward packets for wireless clients.

[Switch] vlan 200

[Switch-vlan200] quit

# Create VLAN-interface 100 that acts as a gateway and assign IP address 192.168.1.254 to the interface.

[AC] interface vlan-interface 100

[AC-Vlan-interface100] ip address 192.168.1.254 24

[AC-Vlan-interface100] quit

# Create VLAN-interface 200 that acts as a gateway and assign IP address 192.168.2.254 to the interface.

[AC] interface vlan-interface 200

[AC-Vlan-interface200] ip address 192.168.2.254 24

[AC-Vlan-interface200] quit

# Configure GigabitEthernet 1/0/1 (port that connects the switch and the AC) as a trunk port, and assign the port to VLAN 100 and VLAN 200.

[Switch] interface GigabitEthernet1/0/1

[Switch-GigabitEthernet1/0/1] port link-type trunk

[Switch-GigabitEthernet1/0/1] port trunk permit vlan 100 200

[Switch-GigabitEthernet1/0/1] quit

# Configure GigabitEthernet 1/0/2 (port that connects the switch and the AP) as an access port, and assign the port to VLAN 100.

[Switch] interface GigabitEthernet1/0/2

[Switch-GigabitEthernet1/0/2] port link-type access

[Switch-GigabitEthernet1/0/2] port access vlan 100

# Enable PoE on GigabitEthernet 1/0/2.

[Switch-GigabitEthernet1/0/2] poe enable

[Switch-GigabitEthernet1/0/2] quit

# Configure GigabitEthernet 1/0/3 (port that connects the switch and the host) as an access port, and assign the port to VLAN 200.

[Switch] interface GigabitEthernet1/0/3

[Switch-GigabitEthernet1/0/3] port link-type access

[Switch-GigabitEthernet1/0/3] port access vlan 200

[Switch-GigabitEthernet1/0/3] quit

2.     Configure the DHCP server:

# Enable DHCP server.

[Switch] dhcp enable

# Create DHCP address pool 1 for dynamic IP allocation to the AP. Specify 192.168.1.0/24 as the subnet and 192.168.1.254 as the gateway address in the address pool.

[Switch] dhcp server ip-pool 1

[Switch-dhcp-pool-1] network 192.168.1.0 mask 255.255.255.0

[Switch-dhcp-pool-1] gateway-list 192.168.1.254

# Exclude the IP address of VLAN-interface 100 on the AC from dynamic IP allocation in DHCP address pool 1.

[Switch-dhcp-pool-1] forbidden-ip 192.168.1.1

[Switch-dhcp-pool-1] quit

# Create DHCP address pool 2 for dynamic IP allocation to Client 1 and the host. Specify 192.168.2.0/24 as the subnet and 192.168.2.254 as the gateway address in the address pool, and then specify the address of the DNS server. In this example, the gateway also acts as the DNS server.

[Switch] dhcp server ip-pool 2

[Switch-dhcp-pool-2] network 192.168.2.0 mask 255.255.255.0

[Switch-dhcp-pool-2] gateway-list 192.168.2.254

[Switch-dhcp-pool-2] dns-list 192.168.2.254

[Switch-dhcp-pool-2] quit

Verifying the configuration

# Client 1 at MAC address 0024-d774-e6f4 comes online and obtains IP address 192.168.2.2/24 through DHCP. (Details not shown.)

# Client 2 at MAC address 0024-0130-696b comes online and obtains statically configured IP address 192.168.2.3/24. (Details not shown.)

# Verify that Client 1 can ping the host on the same subnet.

C:\Users\>ping -S 192.168.2.2 192.168.2.1

 

Pinging 192.168.2.1 from 192.168.2.2 with 32 bytes of data:

Reply from 192.168.2.1 : time=22ms

Reply from 192.168.2.1 : time=61ms

Reply from 192.168.2.1 : time=32ms

Reply from 192.168.2.1 : time=16ms

 

Ping statistics for 192.168.2.1 :

    Packets: Sent = 4,Received = 4,Lost = 0 (0% loss),

Approximate round trip times in milli-seconds:

    Minimum = 16msMaximum = 61msAverage = 32ms

# Verify that Client 2 cannot ping the host.

C:\Users\>ping -S 192.168.2.3 192.168.2.1

 

Pinging 192.168.2.1 from 192.168.2.3 with 32 bytes of data:

Request timed out.

Request timed out.

Request timed out.

Request timed out.

 

Ping statistics for 192.168.2.1 :

    Packets: Sent = 4,Received = 0,Lost = 4 (100% loss),

Configuration files

·     AC

#

vlan 100

#

vlan 200

#

wlan service-template 1                                                        

 ssid service                                                                  

 client forwarding-location ac                                                 

 akm mode psk                                                                  

 preshared-key pass-phrase cipher $c$3$X2Rlxl49vpJ158WfBfCMdjt0NpHVdUHApNcS    

 cipher-suite ccmp                                                             

 security-ie rsn                                                               

 ip verify source                                                               

 client ipv4-snooping dhcp-learning enable

 

 service-template enable

#

interface Vlan-interface100

 ip address 192.168.1.1 255.255.255.0

#

interface GigabitEthernet1/0/1

 port link-type trunk

 undo port trunk permit vlan 1

 port trunk permit vlan 100 200

#                                                                              

wlan ap-group group1                                                           

 ap officeap                                                                    

 ap-model WA6320                                                               

  radio 1                                                                      

   radio enable                                                                 

   service-template 1 vlan 200                                                 

  radio 2 

#

wlan ap officeap model WA6320

 serial-id 209801A28N819CE0002T

#

·     Switch:

#

vlan 100

#

vlan 200

#

dhcp server ip-pool 1

 gateway-list 192.168.1.254

 network 192.168.1.0 mask 255.255.255.0

 forbidden-ip 192.168.1.1

#

dhcp server ip-pool 2

 gateway-list 192.168.2.254

 network 192.168.2.0 mask 255.255.255.0

 dns-list 192.168.2.254

#

interface Vlan-interface100

 ip address 192.168.1.254 255.255.255.0

#

interface Vlan-interface200

 ip address 192.168.2.254 255.255.255.0

#

interface GigabitEthernet1/0/1

 port link-mode bridge

 port link-type trunk

 port trunk permit vlan 100 200

#

interface GigabitEthernet1/0/2

 port link-mode bridge

 port access vlan 100

 poe enable

#

interface GigabitEthernet1/0/3

 port link-mode bridge

 port access vlan 200

#

Related documentation

·     Network Connectivity Command Reference in H3C Access Controllers Command References

·     Network Connectivity Configuration Guide in H3C Access Controllers Configuration Guides

·     Security Command Reference in H3C Access Controllers Command References

·     Security Configuration Guide in H3C Access Controllers Configuration Guides

·     AP and WT Management Command Reference in H3C Access Controllers Command References

·     AP and WT Management Configuration Guide in H3C Access Controllers Configuration Guides

  • Cloud & AI
  • InterConnect
  • Intelligent Computing
  • Security
  • SMB Products
  • Intelligent Terminal Products
  • Product Support Services
  • Technical Service Solutions
All Services
  • Resource Center
  • Policy
  • Online Help
All Support
  • Become a Partner
  • Partner Resources
  • Partner Business Management
All Partners
  • Profile
  • News & Events
  • Online Exhibition Center
  • Contact Us
All About Us
新华三官网