- Table of Contents
-
- H3C WX3000 Series Unified Switches Switching Engine Command Reference-6W103
- 00-Preface
- 01-CLI Command
- 02-Login Command
- 03-Configuration File Management Command
- 04-VLAN Command
- 05-Auto Detect Command
- 06-Voice VLAN Command
- 07-GVRP Command
- 08-Basic Port Configuration Command
- 09-Link Aggregation Command
- 10-Port Isolation Command
- 11-Port Security-Port Binding Command
- 12-DLDP Command
- 13-MAC Address Table Management Command
- 14-MSTP Command
- 15-802.1x and System Guard Command
- 16-AAA Command
- 17-MAC Address Authentication Command
- 18-IP Address and Performance Command
- 19-DHCP Command
- 20-ACL Command
- 21-QoS-QoS Profile Command
- 22-Mirroring Command
- 23-ARP Command
- 24-SNMP-RMON Command
- 25-Multicast Command
- 26-NTP Command
- 27-SSH Command
- 28-File System Management Command
- 29-FTP-SFTP-TFTP Command
- 30-Information Center Command
- 31-System Maintenance and Debugging Command
- 32-VLAN-VPN Command
- 33-HWPing Command
- 34-DNS Command
- 35-Smart Link-Monitor Link Command
- 36-PoE-PoE Profile Command
- 37-Routing Protocol Command
- 38-UDP Helper Command
- 39-Index
Title | Size | Download |
---|---|---|
08-Basic Port Configuration Command | 134.16 KB |
Table of Contents
1 Basic Port Configuration Commands
Basic Port Configuration Commands
loopback-detection control enable
loopback-detection interval-time
loopback-detection per-vlan enable
Basic Port Configuration Commands
broadcast-suppression
Syntax
broadcast-suppression { ratio | pps max-pps }
undo broadcast-suppression
View
System view or Ethernet port view
Parameters
ratio: Specifies the allowed maximum ratio of the broadcast traffic to the total bandwidth on one or each port. The value ranges form 1 to 100 and defaults to 100. The smaller the ratio is, the smaller the broadcast traffic is allowed.
max-pps: Maximum number of broadcast packets that can be received on an Ethernet port per second (in pps).
l In system view, the max-pps argument is in the range of 200 to 14,881,000.
l In Ethernet port view, the max-pps argument is in the range of 200 to 1,488,100.
Description
Use the broadcast-suppression command to define the broadcast traffic ratio allowed on one port or each of the ports.
Use the undo broadcast-suppression command to restore the default ratio.
l When you execute the command here in system view, the command takes effect on all ports.
l When you execute the command here in Ethernet port view, the command takes effect only on the current port.
Once broadcast traffic exceeds the value set by the user, the system maintains an appropriate broadcast traffic ratio by discarding the overflow traffic, so as to suppress broadcast storm, avoid network congestion and ensure normal network services.
By default, broadcast suppression is disabled.
Examples
# Allow the broadcast traffic passing through GigabitEthernet 1/0/1 to occupy at most 20% of the bandwidth.
<device> system-view
System View: return to User View with Ctrl+Z.
[device] interface GigabitEthernet1/0/1
[device-GigabitEthernet1/0/1] broadcast-suppression 20
# Configure the maximum number of broadcast packets that can be received on GigabitEthernet 1/0/1 per second as 1000.
[device-GigabitEthernet1/0/1] broadcast-suppression pps 1000
copy configuration
Syntax
copy configuration source { interface-type interface-number | aggregation-group source-agg-id } destination { interface-list [ aggregation-group destination-agg-id ] | aggregation-group destination-agg-id }
View
System view
Parameters
interface-type: Port type.
interface-number: Port number.
source-agg-id: Source aggregation group number, in the range of 1 to 12. The port with the smallest port number in the aggregation group is used as the source port.
interface-list: Destination port list, interface-list = { interface-type interface-number } [ to interface-type interface-number ] &<1-10. &<1-10> means that you can enter the former parameter ten times at most.
destination-agg-id: Destination aggregation group number, in the range of 1 to 12.
Description
Use the copy configuration command to copy the configuration on a port to some other ports to keep consistent configuration on them.
l If you specify a source aggregation group ID, the system uses the port with the smallest port number in the aggregation group as the source.
l If you specify a destination aggregation group ID, the configuration of the source port will be copied to all ports in the aggregation group and all ports in the group will have the same configuration as that of the source port.
The configuration that can be copied includes: VLAN configuration, protocol-based VLAN configuration, LACP configuration, QoS configuration, GARP configuration, STP configuration and initial port configuration.
l VALN configuration: includes IDs of the VLANs allowed on the port and the default VLAN ID of the port;
l Protocol-based VLAN configuration: includes IDs and indexes of the protocol-based VLANs allowed on the port;
l Link aggregation control protocol (LACP) configuration: includes LACP enable/disable status;
The copy command can only be used to copy the configuration of LACP’s enable state, but not to copy the configuration of aggregation group, i.e., you can not add a port to the aggregation group bye the command.
l QoS configuration: includes Traffic Policing, Packets Priority Marking, Port Priority, Traffic Shaping, Traffic Statistics, Traffic Redirecting, VLAN Mapping, Port Rate Limiting, Priority Trust Mode, QoS Profile ( excludes qos-profile port-based ), and so on;
l Generic attribute registration protocol (GARP) configuration: includes GVRP enable/disable status, timer settings, and registration mode;
l STP configuration: includes STP enable/disable status on the port, link attribute on the port (point-to-point or non-point-to-point), STP priority, path cost, packet transmission rate limit, whether loop protection is enabled, whether root protection is enabled, and whether the port is an edge port;
l Port configuration: includes link type of the port, port rate and duplex mode.
Examples
# Copy the configuration of GigabitEthernet 1/0/1 to GigabitEthernet 1/0/2.
<device> system-view
System View: return to User View with Ctrl+Z.
[device] copy configuration source GigabitEthernet1/0/1 destination GigabitEthernet1/0/2
Copying VLAN configuration...
Copying Protocol based VLAN configuration...
Copying LACP configuration...
Copying QOS configuration...
Copying GARP configuration...
Copying STP configuration...
Copying speed/duplex configuration...
description
Syntax
description text
undo description
View
Ethernet port view
Parameters
text: Port description, a string of up to 80 characters.
Description
Use the description command to set a port description string.
Use the undo description command to remove the port description string.
By default, no description is defined for a port.
Examples
# Set GigabitEthernet 1/0/1 description lanswitch-interface.
<device> system-view
System View: return to User View with Ctrl+Z.
[device] interface GigabitEthernet1/0/1
[device-GigabitEthernet1/0/1] description lanswitch-interface
display brief interface
Syntax
display brief interface [ interface-type interface-number ] [ | { begin | include | exclude } string ]
View
Any view
Parameters
interface-type: Port type.
interface-number: Port number.
|: Used to describe the details of configuration information entries to be displayed.
begin: Each entry must begin with a specified character string.
include: Each entry must include a specified character string.
exclude: Each entry must not include a specified character string.
string: A character string of 1 to 256 characters.
Description
Use the display brief interface command to display the brief configuration information about one or all interfaces, including: interface type, link state, link rate, duplex attribute, link type, and default VLAN ID.
This command is similar to the display interface command, but the information it displays is briefer.
Currently, for the port types other than Ethernet port, this command only displays the link state, and shows "--" in all other configuration information fields.
Related commands: display interface.
Examples
# Display the brief configuration information about GigabitEthernet 1/0/3.
<device> display brief interface GigabitEthernet 1/0/3
Interface:
Eth - Ethernet GE - GigabitEthernet TENGE - tenGigabitEthernet
Loop - LoopBack Vlan - Vlan-interface Cas - Cascade
Speed/Duplex:
A - auto-negotiation
Interface Link Speed Duplex Type PVID Description
-------------------------------------------------------------------------
GE1/0/3 UP A100M Afull access 1 office
Table 1-1 display brief interface command output description
Field |
Description |
Interface |
Port type |
Link |
Current link state: UP, DOWN or ADMINISTRATIVELY DOWN |
Speed |
Link rate |
Duplex |
Duplex attribute |
Type |
Link type: access, hybrid or trunk |
PVID |
Default VLAN ID |
Description |
The port’s description string |
display interface
Syntax
display interface [ interface-type | interface-type interface-number ]
View
Any view
Parameters
interface-type: Port type.
interface-number: Port number.
Description
Use the display interface command to display port configuration.
l If you specify neither port type nor port number, the command displays information about all ports.
l If specify only port type, the command displays information about all ports of this type.
l If specify both port type and port number, the command displays information about the specified port.
Examples
# Display the configuration information of GigabitEthernet 1/0/1.
<device> display interface GigabitEthernet1/0/1
GigabitEthernet1/0/1 current state : DOWN
IP Sending Frames' Format is PKTFMT_ETHNT_2, Hardware address is 0012-a990-2240
Media type is twisted pair, loopback not set
Port hardware type is 100_BASE_TX
100Mbps-speed mode, full-duplex mode
Link speed type is force link, link duplex type is force link
Flow-control is enabled
The Maximum Frame Length is 4096
Broadcast MAX-pps: 500
Unknown Multicast Packet drop: Disable
Unknown Unicast Packet drop: Disable
Allow jumbo frame to pass
PVID: 1
Mdi type: auto
Port link-type: access
Tagged VLAN ID : none
Untagged VLAN ID : 1
Last 300 seconds input: 0 packets/sec 0 bytes/sec
Last 300 seconds output: 0 packets/sec 0 bytes/sec
Input(total): 0 packets, 0 bytes
0 broadcasts, 0 multicasts, - pauses
Input(normal): - packets, - bytes
- broadcasts, - multicasts, - pauses
Input: 0 input errors, 0 runts, 0 giants, - throttles, 0 CRC
0 frame, - overruns, 0 aborts, 0 ignored, - parity errors
Output(total): 0 packets, 0 bytes
0 broadcasts, 0 multicasts, 0 pauses
Output(normal): - packets, - bytes
- broadcasts, - multicasts, - pauses
Output: 0 output errors, - underruns, - buffer failures
0 aborts, 0 deferred, 0 collisions, 0 late collisions
0 lost carrier, - no carrier
Table 1-2 display interface command output description
Field |
Description |
GigabitEthernet1/0/1 current state |
Current Ethernet port state: UP, DOWN or ADMINISTRATIVELY DOWN |
IP Sending Frames' Format |
Ethernet frame format |
Hardware address |
Port hardware address |
Media type |
Media type |
loopback not set |
No loopback is configured |
Port hardware type |
Port hardware type |
The Maximum Transmit Unit |
The maximum transmit unit |
1000Mbps-speed mode, full-duplex mode |
1000Mbps-speed mode, full-duplex mode |
Link speed type is force link, link duplex type is force link |
Link speed type is force link, link duplex type is force link |
Flow-control is not enabled |
Port flow control state |
The Maximum Frame Length |
The maximum frame length allowed on the port |
Broadcast MAX-ratio |
Port broadcast suppression ratio |
Unknown Multicast Packet drop: Disable |
The unknown multicast packet dropping function is disabled |
Unknown Unicast Packet drop: Disable |
The unknown multicast packet dropping function is disabled |
Allow jumbo frame to pass |
Jumbo frame allowed on the port |
PVID |
Default VLAN ID for the port |
Mdi type |
Network cable type |
Port link-type |
Port link type |
Tagged VLAN ID |
Assign tags to packets of which VLANs on the port. |
Untagged VLAN ID |
Do not assign tags to packets of which VLANs on the port. |
Last 300 seconds input: 0 packets/sec 0 bytes/sec Last 300 seconds output: 0 packets/sec 0 bytes/sec |
Rate and number of incoming and outgoing packets in the last 300 seconds |
Input(total): 0 packets, 0 bytes 0 broadcasts, 0 multicasts, - |
Statistics on the total incoming packets ( including normal packets, error packets and pauses frames ) on the port The “-” indicates that the statistical item is not supported. |
Input(normal): - packets, - bytes - broadcasts, - multicasts, - pauses |
Statistics on the normal incoming packets on the port |
Input: 0 input errors, 0 runts, 0 giants, - throttles, 0 CRC 0 frame, - overruns, 0 aborts, 0 ignored, - parity errors |
Statistics on the abnormal incoming packets on the port |
Output(total): 0 packets, 0 bytes 0 broadcasts, 0 multicasts, 0 pauses |
Statistics on the total outgoing packets ( including normal packets, error packets and pauses frames ) on the port The “-” indicates that the statistical item is not supported. |
Output(normal): - packets, - bytes - broadcasts, - multicasts, - pauses |
Statistics on the normal outgoing packets on the port |
Output: 0 output errors, - underruns, - buffer failures 0 aborts, 0 deferred, 0 collisions, 0 late collisions 0 lost carrier, - no carrier |
Statistics on the abnormal outgoing packets on the port |
display loopback-detection
Syntax
display loopback-detection
View
Any view
Parameters
None
Description
Use the display loopback-detection command to display the loopback detection status on the port. If loopback detection is enabled, this information will also be displayed: time interval for loopback detection and the loopback ports.
Examples
# Display the loopback detection status on the port.
<device> display loopback-detection
Port GigabitEthernet1/0/1 loopback-detection is running
System Loopback-detection is running
Detection interval time is 30 seconds
There is no port existing loopback link
Table 1-3 display loopback-detection command output description
Field |
Description |
Port GigabitEthernet1/0/1 loopback-detection is running |
Loopback detection is enabled on the port. |
System Loopback-detection is running |
Loopback detection is enabled globally. |
Detection interval time is 30 seconds |
Time interval for loopback detection is 30 seconds. |
There is no port existing loopback link |
No loopback port exists. |
display port
Syntax
display port { hybrid | trunk | combo }
View
Any view
Parameters
hybrid: Displays current hybrid ports.
trunk: Displays current trunk ports.
combo: Displays current combo ports.
Description
Use the display port command to display all current ports with their type indicated.
Examples
# Display current hybrid ports.
<device> display port hybrid
The following hybrid ports exist:
GigabitEthernet1/0/1 GigabitEthernet1/0/2
The above information shows that GigabitEthernet 1/0/1 and GigabitEthernet 1/0/2 are two hybrid ports.
# Displays current combo ports.
<device> display port combo
Combo-group Active Inactive
1 GigabitEthernet1/0/21 GigabitEthernet1/0/27
2 GigabitEthernet1/0/22 GigabitEthernet1/0/25
3 GigabitEthernet1/0/23 GigabitEthernet1/0/28
4 GigabitEthernet1/0/24 GigabitEthernet1/0/26
display port-group
Syntax
display port-group group-id
View
Any view
Parameters
group-id: Number of port group, in the range of 1 to 100.
Description
Use the display port-group command to display information for a specified port group .
Examples
# Display information for the port group 1.
<device> display port-group 1
Port Group 1:
Interface list: GigabitEthernet1/0/2-5
The above information indicates that port group 1 includes 4 ports: GigabitEthernet 1/0/2 through GigabitEthernet 1/0/5.
display unit
Syntax
display unit unit-id interface
View
Any view
Parameters
unit-id: Unit ID. For WX3000 series devices, this value can only be 1.
Description
Use the display unit command to display information about the ports on a specified unit.
Examples
# Display information about the ports on unit 1.
<device> display unit 1 interface
Aux1/0/0
Description : Aux Interface
GigabitEthernet1/0/1 current state : DOWN
IP Sending Frames' Format is PKTFMT_ETHNT_2, Hardware address is 000f-e20f-5111
Media type is twisted pair, loopback not set
Port hardware type is 1000_BASE_T
Unknown-speed mode, unknown-duplex mode
Link speed type is autonegotiation, link duplex type is autonegotiation
Flow-control is enabled
The Maximum Frame Length is 4096
Broadcast MAX-ratio: 100%
Unknown Multicast Packet drop: Disable
Unknown Unicast Packet drop: Disable
Allow jumbo frame to pass
PVID: 1
Mdi type: auto
Port link-type: access
Tagged VLAN ID : none
Untagged VLAN ID : 1
It belongs to a link-aggregation. It is the master port
Last 300 seconds input: 0 packets/sec 0 bytes/sec
Last 300 seconds output: 0 packets/sec 0 bytes/sec
Input(total): - packets, - bytes
- broadcasts, - multicasts, - pauses
Input(normal): 22 packets, 1497 bytes
1 broadcasts, 21 multicasts, - pauses
Input: 0 input errors, 0 runts, 0 giants, - throttles, 0 CRC
0 frame, 0 overruns, 0 aborts, - ignored, - parity errors
Output(total): - packets, - bytes
- broadcasts, - multicasts, - pauses
Output(normal): 22 packets, 1497 bytes
1 broadcasts, 21 multicasts, 0 pauses
Output: 0 output errors, - underruns, - buffer failures
0 aborts, 0 deferred, 0 collisions, 0 late collisions
- lost carrier, - no carrier
(The following displayed information is omitted. For the description on the output, refer to Table 1-2.)
duplex
Syntax
duplex { auto | full | half }
undo duplex
View
Ethernet port view
Parameters
auto: Auto-negotiation mode
full: Full duplex mode
half: Half duplex mode
Description
Use the duplex command to set port duplex attribute.
Use the undo duplex command to restore the default duplex mode (auto).
By default, a port is in auto duplex mode.
Related commands: speed.
Examples
# Set GigabitEthernet 1/0/1 in auto duplex mode.
<device> system-view
System View: return to User View with Ctrl+Z.
[device] interface GigabitEthernet1/0/1
[device-GigabitEthernet1/0/1] duplex auto
enable log updown
enable log updown
undo enable log updown
View
Ethernet port view
Parameters
None
Description
Use the enable log updown command to enable the port to output Up/Down log information.
Use the undo log enable updown command to disable the port from outputting Up/Down log information.
By default, a port is allowed to output Up/Down log information.
Examples
# By default, port GigabitEthernet 1/0/1 is allowed to output the Up/Down log information. Execute the shutdown command or the undo shutdown command on GigabitEthernet 1/0/1, and the system outputs Up/Down log information of GigabitEthernet 1/0/1.
<device> system-view
System View: return to User View with Ctrl+Z.
[device] interface GigabitEthernet 1/0/1
[device-GigabitEthernet1/0/1] shutdown
[device-GigabitEthernet1/0/1]
%Apr 2 08:11:14:220 2000 device L2INF/5/PORT LINK STATUS CHANGE:- 1 -
GigabitEthernet1/0/1 is DOWN
[device-GigabitEthernet1/0/1] undo shutdown
[device-GigabitEthernet1/0/1]
%Apr 2 08:11:32:253 2000 device L2INF/5/PORT LINK STATUS CHANGE:- 1 -
GigabitEthernet1/0/1 is UP
# Disable GigabitEthernet 1/0/1 from outputting Up/Down log information, execute the shutdown command or the undo shutdown command on GigabitEthernet 1/0/1, and no Up/Down log information is output for GigabitEthernet 1/0/1.
[device-GigabitEthernet1/0/1] undo enable log updown
[device-GigabitEthernet1/0/1] shutdown
[device-GigabitEthernet1/0/1] undo shutdown
flow-control
Syntax
flow-control
undo flow-control
View
Ethernet port view
Parameters
None
Description
Use the flow-control command to enable port flow control, to avoid packet loss in the event of network congestion.
Use the undo flow-control command to disable flow control on the port.
By default, port flow control is disabled.
Examples
# Enable flow control on GigabitEthernet 1/0/1.
<device> system-view
System View: return to User View with Ctrl+Z.
[device] interface GigabitEthernet1/0/1
[device-GigabitEthernet1/0/1] flow-control
flow interval
Syntax
flow-interval interval
undo flow-interval
View
Ethernet port view
Parameters
Interval: Interval (in seconds) to perform statistics on port information. This argument ranges from 5 to 300 (in step of 5) and is 300 by default.
Description
Use the flow-interval command to set the interval to perform statistics on port information.
Use the undo flow-interval command to restore the default interval.
By default, this interval is 300 seconds.
When you use the display interface interface-type interface-number command to display the information of a port, the system performs statistical analysis on the traffic flow passing through the port during the specified interval and displays the average rates in the interval. For example, if you set the interval to 100 seconds, the displayed information is as follows:
Last 100 seconds input: 0 packets/sec 0 bytes/sec
Last 100 seconds output: 0 packets/sec 0 bytes/sec
Related commands: display interface.
Examples
# Set the interval to perform statistics on GigabitEthernet 1/0/1 to 100 seconds.
<device> system-view
System View: return to User View with Ctrl+Z.
[device] interface GigabitEthernet 1/0/1
[device-GigabitEthernet1/0/1] flow-interval 100
interface
Syntax
interface interface-type interface-number
View
System view
Parameters
interface-type: Port type, it can be Aux, GigabitEthernet, LoopBack, NULL or Vlan-interface.
interface-number: Port number. For a GigabitEthernet port, it is in the format of slot number/subslot number/port number.
l The slot number is fixed to 1;
l The subslot number is 0 if the port is a GigabitEthernet port;
l The port number is relevant to the device.
Description
Use the interface command to enter Ethernet port view. To configure parameters for a port, you must enter the port view first.
Examples
# Enter GigabitEthernet1/0/1 port view.
<device> system-view
System View: return to User View with Ctrl+Z.
[device] interface GigabitEthernet1/0/1
jumboframe enable
Syntax
jumboframe enable
undo jumboframe enable
View
Ethernet port view
Parameters
None
Description
Use the jumboframe enable command to allow jumbo frames that are not larger than 4096 bytes to pass through the current Ethernet port.
Use the undo jumboframe enable command to allow frames that are not larger than 1536 bytes to pass through the current Ethernet port.
By default, frames that are not larger than 4096 bytes are allowed to pass through the Ethernet port.
Examples
# Allow frames that are not larger than 1536 bytes to pass through GigabitEthernet 1/0/1.
<device> system-view
System View: return to User View with Ctrl+Z.
[device] interface GigabitEthernet 1/0/1
[device-GigabitEthernet1/0/1] undo jumboframe enable
loopback
Syntax
loopback { external | internal }
View
Ethernet port view
Parameters
external: Performs external loop test. In the external loop test, self-loop headers (which are made from four cores of the 8-core cables) must be used on the port of the device. The external loop test can locate the hardware failures on the port.
internal: Performs internal loop test. In the internal loop test, self loop is established in the switching chip to locate the chip failure which is related to the port.
Description
Use the loopback command to perform a loopback test on the current Ethernet port to check whether the Ethernet port works normally. The loopback test terminates automatically after running for a specific period.
By default, no loopback test is performed on the Ethernet port.
Examples
# Perform an internal loop test on GigabitEthernet 1/0/1.
<device> system-view
System View: return to User View with Ctrl+Z.
[device] interface GigabitEthernet 1/0/1
[device-GigabitEthernet1/0/1] loopback internal
Loopback internal succeeded.
loopback-detection control enable
Syntax
loopback-detection control enable
undo loopback-detection control enable
View
Ethernet port view
Parameters
None
Description
Use the loopback-detection control enable command to enable loopback port control on the trunk or hybrid port.
Use the undo loopback-detection control enable command to disable loopback port control.
l When the loopback port control function is enabled on the trunk or hybrid port and loopback is found on the port, the system disables the port, sends a Trap message to the client and removes the corresponding MAC forwarding entry.
l When the loopback port control function is disabled, the system sends a Trap message to the client if a loopback port is found. The port still operates normally.
By default, the loopback port control function is disabled on the trunk or hybrid port.
This command is invalid for the access port, since the loopback port control function is always enabled on the access port.
Examples
# Enable loopback port control on trunk port GigabitEthernet1/0/1.
<device> system-view
System View: return to User View with Ctrl+Z.
[device] loopback-detection enable
[device] interface GigabitEthernet1/0/1
[device-GigabitEthernet1/0/1] loopback-detection enable
[device-GigabitEthernet1/0/1] loopback-detection control enable
loopback-detection enable
Syntax
loopback-detection enable
undo loopback-detection enable
View
System view, Ethernet port view
Parameters
None
Description
Use the loopback-detection enable command to enable loopback detection globally or on a specified port.
Use the undo loopback-detection enable command to disable loopback detection globally or on a specified port.
l To enable loopback detection on a specific port, you must use the loopback-detection enable command in both system view and the specified port view.
l After you use the undo loopback-detection enable command in system view, loopback detection will be disabled on all ports.
l If loopback is found on an access port, the system disables the port, sends a Trap message to the client and removes the corresponding MAC forwarding entry.
l If loopback is found on a trunk or hybrid port, the system sends a Trap message to the client. When the loopback port control function is enabled on these ports, the system disables the port, sends a Trap message to the client and removes the corresponding MAC forwarding entry.
By default, loopback port control is disabled.
Related commands: loopback-detection control enable.
Examples
# Enable loopback detection on GigabitEthernet 1/0/1.
<device> system-view
System View: return to User View with Ctrl+Z.
[device] loopback-detection enable
[device] interface GigabitEthernet1/0/1
[device-GigabitEthernet1/0/1] loopback-detection enable
loopback-detection interval-time
Syntax
loopback-detection interval-time time
undo loopback-detection interval-time
View
System view
Parameters
time: Time interval for loopback detection, in the range of 5 to 300 (seconds). It defaults to 30 seconds.
Description
Use the loopback-detection interval-time command to set time interval for loopback detection.
Use the undo loopback-detection interval-time command to restore the default time interval.
Related commands: display loopback-detection.
Examples
# Set time interval for loopback detection to 10 seconds.
<device> system-view
System View: return to User View with Ctrl+Z.
[device] loopback-detection interval-time 10
loopback-detection per-vlan enable
Syntax
loopback-detection per-vlan enable
undo loopback-detection per-vlan enable
View
Ethernet port view
Parameters
None
Description
Use the loopback-detection per-vlan enable command to configure the system to run loopback detection on all VLANs for the trunk and hybrid ports.
Use the undo loopback-detection per-vlan enable command to restore the default setting.
By default, the system runs loopback detection only on the default VLAN for the trunk and hybrid ports.
This command is invalid for the access port.
Examples
# Configure the system to run loopback detection on all VLANs for trunk port GigabitEthernet 1/0/1.
<device> system-view
System View: return to User View with Ctrl+Z.
[device] interface GigabitEthernet1/0/1
[device-GigabitEthernet1/0/1] loopback-detection per-vlan enable
mdi
Syntax
mdi { across | auto | normal }
undo mdi
View
Ethernet port view
Parameters
across: Sets the port to support MDIX.
auto: Sets the port to support auto-MDI/MDIX.
normal: Sets the port to support MDI.
Description
Use the mdi command to set port MDI attribute.
Use the undo mdi command to restore the default setting.
By default, the port MDI attribute is auto.
The mdi and undo mdi commands cannot be configured on the combo ports.
Examples
# Set the port to support auto-MDI/MDIX.
<device> system-view
System View: return to User View with Ctrl+Z.
[device] interface GigiabitEthernet1/0/1
[device-GigabitEthernet1/0/1] mdi auto
port
Syntax
port interface-list
undo port interface-list
View
Port group view
Parameters
interface-list: Ethernet interface list, in the format of interface-type interface-number [ to interface-type interface-number ] &<1-10>, where &<1-10> indicates that you can specify up to 10 port ranges.
Description
Use the port command to add Ethernet interface(s) to a specified port group.
Use the undo port command to remove specified Ethernet interface(s) from a port group.
By default, a port group is empty, that is, there is no Ethernet interface in it.
You cannot add a member port in an aggregate group to a port group. The opposite is also true.
Examples
# Add GigabitEthernet 1/0/2 through GigabitEthernet1/0/5 to port group 1.
<device> system-view
[device] port-group 1
[device-port-group-1] port GigabitEthernet 1/0/2 to GigabitEthernet 1/0/5
port-group
Syntax
port-group
undo port-group
View
System view
Parameters
group-id: Number of port group, in the range of 1 to 100.
Description
Use the port-group command to create a port group or enter the specified port group view.
Use the undo port-group command to remove a port group.
By default, no port group is configured.
Examples
# Create port group 1.
<device> system-view
[device] port-group 1
[device-port-group-1]
port access vlan
Syntax
port access vlan vlan-id
undo port access vlan
View
Ethernet port view
Parameters
vlan-id: VLAN ID, in the range of 1 to 4094.
Description
Use the port access vlan command to add the access port into the specified VLAN.
Use the undo port access vlan command to remove the access port from the specified VLAN.
You must specify the ID of an existing VLAN in the command.
Examples
# Add port GigabitEthernet 1/0/1 into VLAN 3.
<device> system-view
System View: return to User View with Ctrl+Z.
[device] vlan 3
[device-vlan3] quit
[device] interface GigabitEthernet1/0/1
[device-GigabitEthernet1/0/1] port access vlan 3
port hybrid pvid vlan
Syntax
undo port hybrid pvid
View
Ethernet port view
Parameters
vlan-id: VLAN ID, in the range of 1 to 4094. It defaults to 1.
Description
Use the port hybrid pvid vlan command to set the default VLAN ID for the hybrid port.
Use the undo port hybrid pvid command to restore the default setting.
To guarantee the proper packet transmission, the default VLAN ID of the local hybrid port should be identical with that of the hybrid port on the peer device.
Related commands: port link-type.
Examples
# Set the default VLAN ID for hybrid port GigabitEthernet1/0/1 to 100.
<device> system-view
System View: return to User View with Ctrl+Z.
[device] interface GigabitEthernet1/0/1
[device-GigabitEthernet1/0/1] port hybrid pvid vlan 100
port hybrid vlan
Syntax
port hybrid vlan vlan-id-list { tagged | untagged }
undo port hybrid vlan vlan-id-list
View
Ethernet port view
Parameters
vlan-id-list: vlan-id-list = [ vlan-id1 [ to vlan-id2 ] ]&<1-10>, VLAN range to which the hybrid ports are added. vlan-id is in the range of 1 to 4094 and can be discrete. &<1-10> means you can enter the parameter for ten times at most.
tagged: The packets of the specified VLAN will be assigned with tags.
untagged: The packets of the specified VLAN will not be assigned with tags.
Description
Use the port hybrid vlan command to add the hybrid port into the specified VLAN.
Use the undo port hybrid vlan command to remove the hybrid port from the specified VLAN.
A hybrid port can belong to multiple VLANs. When you use the command several times, all VLAN specified in the commands will be allowed to pass the port.
Related commands: port link-type.
Examples
# Add hybrid port GigabitEthernet 1/0/1 to VLAN 2, VLAN 5 and VLAN 50 through VLAN 100, with tags assigned to their packets.
<device> system-view
System View: return to User View with Ctrl+Z.
[device] interface GigabitEthernet1/0/1
[device-GigabitEthernet1/0/1] port hybrid vlan 2 4 50 to 100 tagged
port link-type
Syntax
port link-type { access | hybrid | trunk }
undo port link-type
View
Ethernet port view
Parameters
access: Specifies the link type as access.
hybrid: Specifies the link type as hybrid.
trunk: Specifies the link type as trunk.
Description
Use the port link-type command to set link type for the Ethernet port.
Use the undo port link-type command to restore the default link type, that is, access.
You can configure all the three port types on a device. However, note that you cannot directly change a trunk port to a hybrid port or a hybrid port to a trunk port. To do that, you need to set the link type of the trunk or hybrid port to access first.
By default, the link type for all ports is access.
Examples
# Set the link type of GigabitEthernet 1/0/1 to trunk.
<device> system-view
System View: return to User View with Ctrl+Z.
[device] interface GigabitEthernet1/0/1
[device-GigabitEthernet1/0/1] port link-type trunk
port trunk permit vlan
Syntax
port trunk permit vlan { vlan-id-list | all }
undo port trunk permit vlan { vlan-id-list | all }
View
Ethernet port view
Parameters
vlan-id-list: vlan-id-list = [ vlan-id1 [ to vlan-id2 ] ]&<1-10>, VLAN range to which the trunk ports are added. vlan-id is in the range of 1 to 4094 and can be discrete. &<1-10> means you can enter the parameter for ten times at most.
all: Adds the trunk port into all VLANs.
Description
Use the port trunk permit vlan command to add the trunk port into the specified VLAN.
Use the undo port trunk permit vlan command to remove the hybrid port from the specified VLAN.
A trunk port can belong to multiple VLANs. When you use the command several times, all VLAN specified in the commands will be allowed to pass the port.
Related commands: port link-type.
Examples
# Add trunk port GigabitEthernet 1/0/1 to VLAN 2, VLAN 5 and VLAN 50 through VLAN 100.
<device> system-view
System View: return to User View with Ctrl+Z.
[device] interface GigabitEthernet1/0/1
[device-GigabitEthernet1/0/1] port trunk permit vlan 2 4 50 to 100
Please wait...
Done.
port trunk pvid vlan
Syntax
port trunk pvid vlan vlan-id
undo port trunk pvid
View
Ethernet port view
Parameters
vlan-id: VLAN ID, in the range of 1 to 4094. It defaults to 1.
Description
Use the port trunk pvid vlan command to set the default VLAN ID for the trunk port.
Use the undo port trunk pvid command to restore the default setting.
To guarantee the proper packet transmission, the default VLAN ID of the local trunk port should be identical with that of the trunk port on the peer device.
Related commands: port link-type.
Examples
# Set the default VLAN ID for trunk port GigabitEthernet 1/0/1 to 100.
<device> system-view
System View: return to User View with Ctrl+Z.
[device] interface GigabitEthernet1/0/1
[device-GigabitEthernet1/0/1] port trunk pvid vlan 100
reset counters interface
Syntax
reset counters interface [ interface-type | interface-type interface-number ]
View
User view
Parameters
interface-type: Port type.
interface-number: Port number.
For details about the parameters, see the description part of the interface command.
Description
Use the reset counters interface command to clear the statistics of the port, preparing for a new statistics collection.
l If you specify neither port type nor port number, the command clears statistics of all ports.
l If specify only port type, the command clears statistics of all ports of this type.
l If specify both port type and port number, the command clears statistics of the specified port.
Examples
# Clear the statistics of port GigabitEthernet 1/0/1.
<device> reset counters interface GigabiEthernet1/0/1
shutdown
Syntax
shutdown
undo shutdown
View
Ethernet port view
Parameters
None
Description
Use the shutdown command to disable an Ethernet port.
Use the undo shutdown command to enable an Ethernet port.
By default, an Ethernet port is enabled.
Examples
# Disable then enable port GigabitEthernet 1/0/1.
<device> system-view
System View: return to User View with Ctrl+Z.
[device] interface GigabitEthernet1/0/1
[device-GigabitEthernet1/0/1] undo shutdown
speed
Syntax
speed { 10 | 100 | 1000 | auto }
undo speed
View
Ethernet port view
Parameters
10: 10 Mbps port rate.
100: 100 Mbps port rate.
1000: 1000 Mbps port rate.
auto: Auto-negotiation rate mode.
Description
Use the speed command to set port rate.
Use the undo speed command to restore default setting.
By default, the port is in auto-negotiation rate mode.
Related commands: duplex.
The speed and undo speed commands cannot be configured on a combo port.
Examples
# Set the rate of port GigabitEthernet 1/0/1 to 100 Mbps.
<device> system-view
System View: return to User View with Ctrl+Z.
[device] interface GigabitEthernet1/0/1
[device-GigabitEthernet1/0/1] speed 100
speed auto
Syntax
speed auto [ 10 | 100 | 1000 ]*
View
Ethernet port view
Parameters
10: Configures 10 Mbps as an auto-negotiation speed of the port.
100: Configures 100 Mbps as an auto-negotiation speed of the port.
1000: Configures 1000 Mbps as an auto-negotiation speed of the port.
Description
Use the speed auto [ 10 | 100 | 1000 ]* command to configure auto-negotiation speed(s) for the current port.
By default, the port speed is auto-negotiated.
The last configuration will take effect if you configure the command for multiple times.
Examples
# Configure 10 Mbps and 1000 Mbps as the auto-negotiation speeds of GigabitEthernet 1/0/1.
<device> system-view
System View: return to User View with Ctrl+Z.
[device] interface GigabitEthernet 1/0/1
[device-GigabitEthernet1/0/1] speed auto 10 1000
virtual-cable-test
Syntax
virtual-cable-test
View
Ethernet port view
Parameters
None
Description
Use the virtual-cable-test command to enable the system to test the cable connected to a specific port and to display the results. The system can test these attributes of the cable:
l Cable status, including normal, abnormal, abnormal-open, abnormal-short and failure
l Cable length
l If the cable is in normal state, the displayed length value is the total length of the cable.
l If the cable is in any other state, the displayed length value is the length from the port to the faulty point.
The testing functions that are available on the WX3000 series devices vary with port state as follows:
l For ports that are Down, the cable status testing and cable length testing are available.
l For ports that are Up, the cable status testing, cable length testing, and Pair skew testing are available.
l Pair impedance mismatch
l Pair skew
l Pair swap
l Pair polarity
l Insertion loss
l Return loss
l Near-end crosstalk
By default, the system does not test the cable connected to the Ethernet port.
l Optical port (including Combo optical port) does not support VCT (virtual-cable-test) function.
l Combo electrical port supports VCT function only when it is in UP condition (using undo shutdown command), normal Ethernet electrical port always supports this function.
l A hyphen (-) indicates that the corresponding test item is not supported.
Examples
# Enable the system to test the cable connected.
<device> system-view
System View: return to User View with Ctrl+Z.
[device] interface GigabitEthernet1/0/1
[device-GigabitEthernet0/1] virtual-cable-test
Cable status: normal, 6 metres
Pair Impedance mismatch: -
Pair skew: 8 ns
Pair swap: -
Pair polarity: -
Insertion loss: - db
Return loss: - db
Near-end crosstalk: - db