H3C MSR Routers Configuration Examples-6W100

HomeSupportResource CenterConfigure & DeployConfiguration ExamplesH3C MSR Routers Configuration Examples-6W100
10-H3C MSR Routers BGP Configuration Examples (Comware V7)

H3C MSR Routers BGP Configuration Examples (Comware V7)

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Copyright © 2017 New H3C Technologies Co., Ltd. All rights reserved.

No part of this manual may be reproduced or transmitted in any form or by any means without prior written consent of New H3C Technologies Co., Ltd.

Except for the trademarks of New H3C Technologies Co., Ltd., any trademarks that may be mentioned in this document are the property of their respective owners.

The information in this document is subject to change without notice.



Introduction

This document provides BGP configuration examples.

Prerequisites

This document applies to Comware V7-based MSR routers. Procedures and information in the examples might be slightly different depending on the software or hardware version of the router.

The configuration examples in this document were created and verified in a lab environment, and all the devices were started with the factory default configuration. When you are working on a live network, make sure you understand the potential impact of every command on your network.

This document assumes that you have basic knowledge of BGP.

Example: Configuring basic BGP

Network requirements

As shown in Figure 1, run EBGP between Router A and Router B, and run IBGP between Router B and Router C to allow Router C to access network 8.1.1.0/24.

Figure 1 Network diagram

 

Requirements analysis

To enable Router B to communicate with Router C through loopback interfaces, enable OSPF in AS 65009.

By default, BGP does not advertise local networks. To enable Router C to access network 8.1.1.0/24 directly connected to Router A, perform the following tasks:

·     Add network 8.1.1.0/24 to the BGP routing table of Router A.

·     Add networks 3.1.1.0/24 and 9.1.1.0/24 to the BGP routing table of Router B.

Software version used

This configuration example was created and verified on R0106.

Configuration restrictions and guidelines

When you configure basic BGP, follow these restrictions and guidelines:

·     Use loopback interfaces to establish IBGP connections to prevent route flapping caused by port state changes.

·     Loopback interfaces are virtual interfaces. Use the peer connect-interface command to specify the loopback interface as the source interface for establishing BGP connections.

·     The EBGP peers, Router A and Router B, are located in different ASs. Typically, their loopback interfaces are not reachable to each other, so the routers use directly connected interfaces to establish EBGP sessions.

Configuration procedures

1.     Configure IP addresses for interfaces:

# Configure IP addresses for interfaces on Router A.

<RouterA> system-view

[RouterA] interface loopback 0

[RouterA-LoopBack0] ip address 1.1.1.1 255.255.255.255

[RouterA-LoopBack0] quit

[RouterA] interface gigabitethernet 0/1

[RouterA-GigabitEthernet0/1] port link-mode route

[RouterA-GigabitEthernet0/1] ip address 3.1.1.2 255.255.255.0

[RouterA-GigabitEthernet0/1] quit

[RouterA] interface gigabitethernet 0/2

[RouterA-GigabitEthernet0/2] port link-mode route

[RouterA-GigabitEthernet0/2] ip address 8.1.1.1 255.255.255.0

[RouterA-GigabitEthernet0/2] quit

# Configure IP addresses for interfaces on Router B.

<RouterB> system-view

[RouterB] interface loopback 0

[RouterB-LoopBack0] ip address 2.2.2.2 255.255.255.255

[RouterB-LoopBack0] quit

[RouterB] interface gigabitethernet 0/1

[RouterB-GigabitEthernet0/1] port link-mode route

[RouterB-GigabitEthernet0/1] ip address 3.1.1.1 255.255.255.0

[RouterB-GigabitEthernet0/1] quit

[RouterB] interface gigabitethernet 0/2

[RouterB-GigabitEthernet0/2] port link-mode route

[RouterB-GigabitEthernet0/2] ip address 9.1.1.1 255.255.255.0

[RouterB-GigabitEthernet0/2] quit

# Configure IP addresses for interfaces on Router C.

<RouterC> system-view

[RouterC] interface loopback 0

[RouterC-LoopBack0] ip address 3.3.3.3 255.255.255.255

[RouterC-LoopBack0] quit

[RouterC] interface gigabitethernet 0/2

[RouterC-GigabitEthernet0/2] port link-mode route

[RouterC-GigabitEthernet0/2] ip address 9.1.1.2 255.255.255.0

[RouterC-GigabitEthernet0/2] quit

2.     Configure IBGP:

# On Router B, configure the router ID as 2.2.2.2.

[RouterB] bgp 65009

[RouterB-bgp] router-id 2.2.2.2

# On Router B, create IBGP peer 3.3.3.3 and specify interface Loopback 0 as the source interface for TCP connections to the peer.

[RouterB-bgp] peer 3.3.3.3 as-number 65009

[RouterB-bgp] peer 3.3.3.3 connect-interface loopback 0

# On Router B, enable BGP to exchange IPv4 unicast routing information with the peer.

[RouterB-bgp] address-family ipv4 unicast

[RouterB-bgp-ipv4] peer 3.3.3.3 enable

[RouterB-bgp-ipv4] quit

[RouterB-bgp] quit

# On Router B, configure OSPF.

[RouterB] ospf 1

[RouterB-ospf-1] area 0

[RouterB-ospf-1-area-0.0.0.0] network 2.2.2.2 0.0.0.0

[RouterB-ospf-1-area-0.0.0.0] network 9.1.1.0 0.0.0.255

[RouterB-ospf-1-area-0.0.0.0] quit

[RouterB-ospf-1] quit

# On Router C, configure the router ID as 3.3.3.3.

[RouterC] bgp 65009

[RouterC-bgp] router-id 3.3.3.3

# On Router C, create IBGP peer 2.2.2.2 and specify interface Loopback 0 as the source interface for TCP connections to the peer.

[RouterC-bgp] peer 2.2.2.2 as-number 65009

[RouterC-bgp] peer 2.2.2.2 connect-interface loopback 0

# On Router C, enable BGP to exchange IPv4 unicast routing information with the peer.

[RouterC-bgp] address-family ipv4 unicast

[RouterC-bgp-ipv4] peer 2.2.2.2 enable

[RouterC-bgp-ipv4] quit

[RouterC-bgp] quit

# On Router C, configure OSPF.

[RouterC] ospf 1

[RouterC-ospf-1] area 0

[RouterC-ospf-1-area-0.0.0.0] network 3.3.3.3 0.0.0.0

[RouterC-ospf-1-area-0.0.0.0] network 9.1.1.0 0.0.0.255

[RouterC-ospf-1-area-0.0.0.0] quit

[RouterC-ospf-1] quit

# Display brief information about all BGP IPv4 unicast peers. The following shows the output on Router C. The output shows that Router C has established an IBGP peer relationship with Router B.

[RouterC] display bgp peer ipv4

 

 BGP local router ID : 3.3.3.3

 Local AS number : 65009

 Total number of peers : 1                 Peers in established state : 1

 

  Peer                    AS  MsgRcvd  MsgSent OutQ PrefRcv Up/Down  State

 

  2.2.2.2              65009        2        2    0       0 00:00:13 Established

3.     Configure EBGP:

# On Router A, configure the router ID as 1.1.1.1.

[RouterA] bgp 65008

[RouterA-bgp] router-id 1.1.1.1

# On Router A, create EBGP peer 3.1.1.1 and specify its AS number as 65009.

[RouterA-bgp] peer 3.1.1.1 as-number 65009

# On Router A, enable BGP to exchange IPv4 unicast routing information with the peer.

[RouterA-bgp] address-family ipv4 unicast

[RouterA-bgp-ipv4] peer 3.1.1.1 enable

# On Router A, add local network 8.1.1.0/24 to the BGP routing table.

[RouterA-bgp-ipv4] network 8.1.1.0 24

[RouterA-bgp-ipv4] quit

[RouterA-bgp] quit

# On Router B, create EBGP peer 3.1.1.2 and specify its AS number as 65008.

[RouterB] bgp 65009

[RouterB-bgp] peer 3.1.1.2 as-number 65008

# On Router B, enable BGP to exchange IPv4 unicast routing information with the peer.

[RouterB-bgp] address-family ipv4 unicast

[RouterB-bgp-ipv4] peer 3.1.1.2 enable

[RouterB-bgp-ipv4] quit

[RouterB-bgp] quit

# Display BGP peer information on Router B.

[RouterB] display bgp peer ipv4

 

 BGP local router ID : 2.2.2.2

 Local AS number : 65009

 Total number of peers : 2                 Peers in established state : 2

 

  Peer                    AS  MsgRcvd  MsgSent OutQ PrefRcv Up/Down  State

 

  3.3.3.3              65009        4        4    0       0 00:02:49 Established

  3.1.1.2              65008        2        2    0       0 00:00:05 Established

The output shows that Router B has established an IBGP peer relationship with Router C and an EBGP peer relationship with Router A.

# Display the BGP routing table on Router A.

[RouterA] display bgp routing-table ipv4

 

 Total number of routes: 1

 

 BGP local router ID is 1.1.1.1

 Status codes: * - valid, > - best, d - dampened, h - history,

               s - suppressed, S - stale, i - internal, e - external

               Origin: i - IGP, e - EGP, ? - incomplete

 

     Network            NextHop         MED        LocPrf     PrefVal Path/Ogn

 

* >  8.1.1.0/24         8.1.1.1         0                     32768   i

# Display the BGP routing table on Router B.

[RouterB] display bgp routing-table ipv4

 

 Total number of routes: 1

 

 BGP local router ID is 2.2.2.2

 Status codes: * - valid, > - best, d - dampened, h - history,

               s - suppressed, S - stale, i - internal, e - external

               Origin: i - IGP, e - EGP, ? - incomplete

 

     Network            NextHop         MED        LocPrf     PrefVal Path/Ogn

 

* >e 8.1.1.0/24         3.1.1.2         0                     0       65008i

# Display the BGP routing table on Router C.

[RouterC] display bgp routing-table ipv4

 

 Total number of routes: 1

 

 BGP local router ID is 3.3.3.3

 Status codes: * - valid, > - best, d - dampened, h - history,

               s - suppressed, S - stale, i - internal, e - external

               Origin: i - IGP, e - EGP, ? - incomplete

 

     Network            NextHop         MED        LocPrf     PrefVal Path/Ogn

 

   i 8.1.1.0/24         3.1.1.2         0          100        0       65008i

The outputs show that Router A has learned no route to AS 65009, and Router C has learned network 8.1.1.0, but the next hop 3.1.1.2 is unreachable. As a result, the route is invalid.

4.     Configure BGP route redistribution:

# Create the BGP IPv4 unicast address family and enter its view.

[RouterB] bgp 65009

[RouterB-bgp] address-family ipv4 unicast

# Configure BGP to redistribute direct routes on Router B.

[RouterB-bgp-ipv4] network 3.1.1.0 24

[RouterB-bgp-ipv4] network 9.1.1.0 24

[RouterB-bgp-ipv4] quit

[RouterB-bgp] quit

# Display the BGP routing table on Router A.

[RouterA] display bgp routing-table ipv4

 

 Total number of routes: 3

 

 BGP local router ID is 1.1.1.1

 Status codes: * - valid, > - best, d - dampened, h - history,

               s - suppressed, S - stale, i - internal, e - external

               Origin: i - IGP, e - EGP, ? - incomplete

 

     Network            NextHop         MED        LocPrf     PrefVal Path/Ogn

 

* >e 3.1.1.0/24         3.1.1.1         0                     0       65009?

* >  8.1.1.0/24         8.1.1.1         0                     32768   i

* >e 9.1.1.0/24         3.1.1.1         0                     0       65009i

The output shows that route 9.1.1.0/24 has been added into the routing table of Router A.

# Display the BGP routing table on Router C.

[RouterC] display bgp routing-table ipv4

 

 Total number of routes: 3

 

 BGP local router ID is 3.3.3.3

 Status codes: * - valid, > - best, d - dampened, h - history,

               s - suppressed, S - stale, i - internal, e - external

               Origin: i - IGP, e - EGP, ? - incomplete

 

     Network            NextHop         MED        LocPrf     PrefVal Path/Ogn

 

* >i 3.1.1.0/24         2.2.2.2         0          100        0       ?

* >i 8.1.1.0/24         3.1.1.2         0          100        0       65008i

* >i 9.1.1.0/24         2.2.2.2         0          100        0       i 

The output shows that route 8.1.1.0 has become valid and the next hop is Router A.

Verifying the configuration

# Verify that Router C can ping 8.1.1.1.

[RouterC] ping 8.1.1.1

Ping 8.1.1.1 (8.1.1.1): 56 data bytes, press CTRL_C to break

56 bytes from 8.1.1.1: icmp_seq=0 ttl=254 time=10.000 ms

56 bytes from 8.1.1.1: icmp_seq=1 ttl=254 time=4.000 ms

56 bytes from 8.1.1.1: icmp_seq=2 ttl=254 time=4.000 ms

56 bytes from 8.1.1.1: icmp_seq=3 ttl=254 time=3.000 ms

56 bytes from 8.1.1.1: icmp_seq=4 ttl=254 time=3.000 ms

 

--- Ping statistics for 8.1.1.1 ---

5 packet(s) transmitted, 5 packet(s) received, 0.0% packet loss

round-trip min/avg/max/std-dev = 3.000/4.800/10.000/2.638 ms

Configuration files

·     Router A:

#

interface Loopback0

 ip address 1.1.1.1 255.255.255.255

#

interface GigabitEthernet0/1

 ip address 3.1.1.2 255.255.255.0

#

interface GigabitEthernet0/2

 ip address 8.1.1.1 255.255.255.0

#

bgp 65008

 router-id 1.1.1.1

 peer 3.1.1.1 as-number 65009

#

 address-family ipv4 unicast

  network 8.1.1.0 255.255.255.0

  peer 3.1.1.1 enable

#

·     Router B:

#

interface Loopback0

 ip address 2.2.2.2 255.255.255.255

#

interface GigabitEthernet0/1

 ip address 3.1.1.1 255.255.255.0

#

interface GigabitEthernet0/2

 ip address 9.1.1.1 255.255.255.0

#

bgp 65009

 router-id 2.2.2.2

 peer 3.1.1.2 as-number 65008

 peer 3.3.3.3 as-number 65009

 peer 3.3.3.3 connect-interface Loopback0

#

 address-family ipv4 unicast

  network 3.1.1.0 24

  network 9.1.1.0 24

  peer 3.1.1.2 enable

  peer 3.3.3.3 enable

#

ospf 1

 area 0.0.0.0

  network 2.2.2.2 0.0.0.0

  network 9.1.1.0 0.0.0.255

#

·     Router C:

#

interface Loopback0

 ip address 3.3.3.3 255.255.255.255

#

interface GigabitEthernet0/2

 ip address 9.1.1.2 255.255.255.0

#

bgp 65009

 router-id 3.3.3.3

 peer 2.2.2.2 as-number 65009

 peer 2.2.2.2 connect-interface Loopback0

#

 address-family ipv4 unicast

  peer 2.2.2.2 enable

#

ospf 1

 area 0.0.0.0

  network 3.3.3.3 0.0.0.0

  network 9.1.1.0 0.0.0.255

#

Example: Configuring BGP and IGP route redistribution

Network requirements

As shown in Figure 2, run EBGP between Router A and Router B, and run OSPF between Router B and Router C to allow communication between networks 9.1.2.0/24 and 8.1.1.0/24.

Figure 2 Network diagram

 

Requirements analysis

To enable Router B to communicate with Router C through loopback interfaces, enable OSPF in AS 65009.

To enable Router A to obtain the route to 9.1.2.0/24, configure BGP to redistribute routes from OSPF on Router B. To enable Router C to obtain the route to 8.1.1.0/24, configure OSPF to redistribute routes from BGP on Router B.

Software version used

This configuration example was created and verified on R0106.

Configuration restrictions and guidelines

When you configure BGP and IGP route redistribution, follow these restrictions and guidelines:

·     Use loopback interfaces to establish IBGP connections to prevent route flapping caused by port state changes.

·     Loopback interfaces are virtual interfaces. Use the peer connect-interface command to specify the loopback interface as the source interface for establishing BGP connections.

·     The EBGP peers, Router A and Router B, are located in different ASs. Typically, their loopback interfaces are not reachable to each other, so the routers use directly connected interfaces to establish EBGP sessions.

Configuration procedures

1.     Configure IP addresses for interfaces:

# Configure IP addresses for interfaces on Router A.

<RouterA> system-view

[RouterA] interface loopback 0

[RouterA-LoopBack0] ip address 1.1.1.1 255.255.255.255

[RouterA-LoopBack0] quit

[RouterA] interface gigabitethernet 0/0

[RouterA-GigabitEthernet0/0] port link-mode route

[RouterA-GigabitEthernet0/0] ip address 8.1.1.1 255.255.255.0

[RouterA-GigabitEthernet0/0] quit

[RouterA] interface gigabitethernet 0/1

[RouterA-GigabitEthernet0/1] port link-mode route

[RouterA-GigabitEthernet0/1] ip address 3.1.1.2 255.255.255.0

[RouterA-GigabitEthernet0/1] quit

[RouterA] interface gigabitethernet 0/2

[RouterA-GigabitEthernet0/2] port link-mode route

[RouterA-GigabitEthernet0/2] ip address 8.1.2.1 255.255.255.0

[RouterA-GigabitEthernet0/2] quit

# Configure IP addresses for interfaces on Router B.

<RouterB> system-view

[RouterB] interface loopback 0

[RouterB-LoopBack0] ip address 2.2.2.2 255.255.255.255

[RouterB-LoopBack0] quit

[RouterB] interface gigabitethernet 0/1

[RouterB-GigabitEthernet0/1] port link-mode route

[RouterB-GigabitEthernet0/1] ip address 3.1.1.1 255.255.255.0

[RouterB-GigabitEthernet0/1] quit

[RouterB] interface gigabitethernet 0/2

[RouterB-GigabitEthernet0/2] port link-mode route

[RouterB-GigabitEthernet0/2] ip address 9.1.1.1 255.255.255.0

[RouterB-GigabitEthernet0/2] quit

# Configure IP addresses for interfaces on Router C.

<RouterC> system-view

[RouterC] interface loopback 0

[RouterC-LoopBack0] ip address 3.3.3.3 255.255.255.255

[RouterC-LoopBack0] quit

[RouterC] interface gigabitethernet 0/0

[RouterC-GigabitEthernet0/0] port link-mode route

[RouterC-GigabitEthernet0/0] ip address 9.1.2.1 255.255.255.0

[RouterC-GigabitEthernet0/0] quit

[RouterC] interface gigabitethernet 0/1

[RouterC-GigabitEthernet0/1] port link-mode route

[RouterC-GigabitEthernet0/1] ip address 9.1.3.1 255.255.255.0

[RouterC-GigabitEthernet0/1] quit

[RouterC] interface gigabitethernet 0/2

[RouterC-GigabitEthernet0/2] port link-mode route

[RouterC-GigabitEthernet0/2] ip address 9.1.1.2 255.255.255.0

[RouterC-GigabitEthernet0/2] quit

2.     Configure OSPF:

# Configure Router B.

[RouterB] ospf 1

[RouterB-ospf-1] area 0

[RouterB-ospf-1-area-0.0.0.0] network 2.2.2.2 0.0.0.0

[RouterB-ospf-1-area-0.0.0.0] network 9.1.1.0 0.0.0.255

[RouterB-ospf-1-area-0.0.0.0] quit

[RouterB-ospf-1] quit

# Configure Router C.

[RouterC] ospf 1

[RouterC-ospf-1] area 0

[RouterC-ospf-1-area-0.0.0.0] network 9.1.1.0 0.0.0.255

[RouterC-ospf-1-area-0.0.0.0] network 9.1.2.0 0.0.0.255

[RouterC-ospf-1-area-0.0.0.0] quit

[RouterC-ospf-1] quit

3.     Configure the EBGP connection:

# On Router A, configure the router ID as 1.1.1.1.

[RouterA] bgp 65008

[RouterA-bgp] router-id 1.1.1.1

# On Router A, create EBGP peer 3.1.1.1 and specify its AS number as 65009.

[RouterA-bgp] peer 3.1.1.1 as-number 65009

# On Router A, enable BGP to exchange IPv4 unicast routing information with the peer.

[RouterA-bgp] address-family ipv4 unicast

[RouterA-bgp-ipv4] peer 3.1.1.1 enable

# On Router A, add network 8.1.1.0/24 to the BGP routing table.

[RouterA-bgp-ipv4] network 8.1.1.0 24

[RouterA-bgp-ipv4] quit

[RouterA-bgp] quit

# On Router B, configure the router ID as 2.2.2.2.

[RouterB] bgp 65009

[RouterB-bgp] router-id 2.2.2.2

# On Router B, create EBGP peer 3.1.1.2 and specify its AS number as 65008.

[RouterB-bgp] peer 3.1.1.2 as-number 65008

# On Router B, enable BGP to exchange IPv4 unicast routing information with the peer.

[RouterB-bgp] address-family ipv4 unicast

[RouterB-bgp-ipv4] peer 3.1.1.2 enable

[RouterB-bgp-ipv4] quit

[RouterB-bgp] quit

4.     Configure BGP and IGP route redistribution:

# In BGP IPv4 unicast address family view, configure BGP to redistribute OSPF routes.

[RouterB] bgp 65009

[RouterB-bgp] address-family ipv4 unicast

[RouterB-bgp-ipv4] import-route ospf 1

[RouterB-bgp-ipv4] quit

[RouterB-bgp] quit

# In OSPF view, configure OSPF to redistribute BGP routes.

[RouterB] ospf 1

[RouterB-ospf-1] import-route bgp

[RouterB-ospf-1] quit

# Display the BGP routing table on Router A.

[RouterA] display bgp routing-table ipv4

 

 Total number of routes: 3

 

 BGP local router ID is 1.1.1.1

 Status codes: * - valid, > - best, d - dampened, h - history,

               s - suppressed, S - stale, i - internal, e - external

               Origin: i - IGP, e - EGP, ? - incomplete

 

     Network            NextHop         MED        LocPrf     PrefVal Path/Ogn

 

* >  8.1.1.0/24         8.1.1.1         0                     32768   i

* >e 9.1.2.0/24         3.1.1.1         1                     0       65009?

The output shows that Router A has obtained the route to 9.1.2.0/24.

# Display the OSPF routing table on Router C.

[RouterC] display ospf routing

 

          OSPF Process 1 with Router ID 3.3.3.3

                   Routing Tables

 

 Routing for Network

 Destination        Cost     Type    NextHop         AdvRouter       Area

 9.1.1.0/24         1        Transit 9.1.1.2         3.3.3.3         0.0.0.0

9.1.2.0/24         1        Stub    9.1.2.1         192.168.0.63    0.0.0.0

 2.2.2.2/32         1        Stub    9.1.1.1         2.2.2.2         0.0.0.0

 

 Routing for ASEs

 Destination        Cost     Type    Tag         NextHop         AdvRouter

 8.1.1.0/24         1        Type2   1           9.1.1.1         2.2.2.2

 

 Total Nets: 3

 Intra Area: 2  Inter Area: 0  ASE: 1  NSSA: 0

The output shows that Router C has obtained the route to 8.1.1.0/24.

Verifying the configuration

# Verify that 8.1.1.1 on Router A can ping 9.1.2.1 on Router C.

[RouterA] ping -a 8.1.1.1 9.1.2.1

Ping 9.1.2.1 (9.1.2.1) from 8.1.1.1: 56 data bytes, press CTRL_C to break

56 bytes from 9.1.2.1: icmp_seq=0 ttl=254 time=10.000 ms

56 bytes from 9.1.2.1: icmp_seq=1 ttl=254 time=12.000 ms

56 bytes from 9.1.2.1: icmp_seq=2 ttl=254 time=2.000 ms

56 bytes from 9.1.2.1: icmp_seq=3 ttl=254 time=7.000 ms

56 bytes from 9.1.2.1: icmp_seq=4 ttl=254 time=9.000 ms

 

--- Ping statistics for 9.1.2.1 ---

5 packet(s) transmitted, 5 packet(s) received, 0.0% packet loss

round-trip min/avg/max/std-dev = 2.000/8.000/12.000/3.406 ms

# Verify that 9.1.2.1 on Router C can ping 8.1.1.1 on Router A.

[RouterC] ping -a 9.1.2.1 8.1.1.1

Ping 8.1.1.1 (8.1.1.1) from 9.1.2.1: 56 data bytes, press CTRL_C to break

56 bytes from 8.1.1.1: icmp_seq=0 ttl=254 time=9.000 ms

56 bytes from 8.1.1.1: icmp_seq=1 ttl=254 time=4.000 ms

56 bytes from 8.1.1.1: icmp_seq=2 ttl=254 time=3.000 ms

56 bytes from 8.1.1.1: icmp_seq=3 ttl=254 time=3.000 ms

56 bytes from 8.1.1.1: icmp_seq=4 ttl=254 time=3.000 ms

 

--- Ping statistics for 8.1.1.1 ---

5 packet(s) transmitted, 5 packet(s) received, 0.0% packet loss

round-trip min/avg/max/std-dev = 3.000/4.400/9.000/2.332 ms

# Verify that 8.1.2.1 on Router A cannot ping 9.1.2.1 and 9.1.3.1 on Router C.

[RouterA] ping –a 8.1.2.1 9.1.2.1

Ping 9.1.2.1 (9.1.2.1) from 8.1.2.1: 56 data bytes, press CTRL_C to break

Request time out

Request time out

Request time out

Request time out

Request time out

 

--- Ping statistics for 9.1.2.1 ---

5 packet(s) transmitted, 0 packet(s) received, 100.0% packet loss

 

[RouterA] ping –a 8.1.2.1 9.1.3.1

Ping 9.1.3.1 (9.1.3.1) from 8.1.2.1: 56 data bytes, press CTRL_C to break

Request time out

Request time out

Request time out

Request time out

Request time out

 

--- Ping statistics for 9.1.3.1 ---

5 packet(s) transmitted, 0 packet(s) received, 100.0% packet loss

# Verify that 9.1.3.1 on Router C cannot ping 8.1.1.1 and 8.1.2.1 on Router A.

[RouterC] ping –a 9.1.3.1 8.1.1.1

Ping 8.1.1.1 (8.1.1.1) from 9.1.3.1: 56 data bytes, press CTRL_C to break

Request time out

Request time out

Request time out

Request time out

Request time out

 

--- Ping statistics for 8.1.1.1 ---

5 packet(s) transmitted, 0 packet(s) received, 100.0% packet loss

 

[RouterC] ping –a 9.1.3.1 8.1.2.1

Ping 8.1.2.1 (8.1.2.1) from 9.1.3.1: 56 data bytes, press CTRL_C to break

Request time out

Request time out

Request time out

Request time out

Request time out

 

--- Ping statistics for 8.1.2.1 ---

5 packet(s) transmitted, 0 packet(s) received, 100.0% packet loss

Configuration files

·     Router A:

#

interface Loopback0

 ip address 1.1.1.1 255.255.255.255

#

interface GigabitEthernet0/0

 ip address 8.1.1.1 255.255.255.0

#

interface GigabitEthernet0/1

 ip address 3.1.1.2 255.255.255.0

#

interface GigabitEthernet0/2

ip address 8.1.2.1 255.255.255.0

#

bgp 65008

 router-id 1.1.1.1

 peer 3.1.1.1 as-number 65009

#

 address-family ipv4 unicast

  network 8.1.1.0 255.255.255.0

  peer 3.1.1.1 enable

#

·     Router B:

#

interface Loopback0

 ip address 2.2.2.2 255.255.255.255

#

interface GigabitEthernet0/1

 ip address 3.1.1.1 255.255.255.0

#

interface GigabitEthernet0/2

 ip address 9.1.1.1 255.255.255.0

#

bgp 65009

 router-id 2.2.2.2

 peer 3.1.1.2 as-number 65008

#

 address-family ipv4 unicast

  import-route ospf 1

  peer 3.1.1.2 enable

#

ospf 1

 import-route bgp

 area 0.0.0.0

  network 2.2.2.2 0.0.0.0

  network 9.1.1.0 0.0.0.255

#

·     Router C:

#

interface Loopback0

 ip address 3.3.3.3 255.255.255.255

#

interface GigabitEthernet0/0

 ip address 9.1.2.1 255.255.255.0

#

interface GigabitEthernet0/1

 ip address 9.1.3.1 255.255.255.0

#

interface GigabitEthernet0/2

 ip address 9.1.1.2 255.255.255.0

#

ospf 1

 area 0.0.0.0

  network 9.1.1.0 0.0.0.255

  network 9.1.2.0 0.0.0.255

#

Related documentation

·     H3C MSR Series Routers Layer 3IP Routing Command Reference(V7)

·     H3C MSR Series Routers Layer 3—IP Routing Configuration Guide(V7)

  • Cloud & AI
  • InterConnect
  • Intelligent Computing
  • Security
  • SMB Products
  • Intelligent Terminal Products
  • Product Support Services
  • Technical Service Solutions
All Services
  • Resource Center
  • Policy
  • Online Help
All Support
  • Become a Partner
  • Partner Resources
  • Partner Business Management
All Partners
  • Profile
  • News & Events
  • Online Exhibition Center
  • Contact Us
All About Us
新华三官网