H3C S6850&S9850&S9820-64H Config Examples-Release 655x-6W100

HomeSupportResource CenterH3C S6850&S9850&S9820-64H Config Examples-Release 655x-6W100
Table of Contents
Related Documents
54-MAC Address Table Configuration Examples
Title Size Download
54-MAC Address Table Configuration Examples 83.42 KB

 

H3C S6850 & S9850 & S9820-64H

MAC Address Table Configuration Examples

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Copyright © 2020 New H3C Technologies Co., Ltd. All rights reserved.

No part of this manual may be reproduced or transmitted in any form or by any means without prior written consent of New H3C Technologies Co., Ltd.

Except for the trademarks of New H3C Technologies Co., Ltd., any trademarks that may be mentioned in this document are the property of their respective owners.

The information in this document is subject to change without notice.



Introduction

This document provides MAC address table configuration examples.

Prerequisites

The configuration examples in this document were created and verified in a lab environment, and all the devices were started with the factory default configuration. When you are working on a live network, make sure you understand the potential impact of every command on your network.

This document assumes that you have basic knowledge of the MAC address table.

Example: Configuring static MAC address entries

Network configuration

As shown in Figure 1, for secure communication between users in VLAN 100 and the server, perform the following tasks:

·           Assign HundredGigE 1/0/2 and HundredGigE 1/0/3 to VLAN 100.

·           Add a static MAC address entry on Device to bind the server MAC address to HundredGigE 1/0/2.

Figure 1 Network diagram

 

Applicable hardware and software versions

The following matrix shows the hardware and software versions to which this configuration example is applicable:

 

Hardware

Software version

S6850 switch series

S9850 switch series

Release 6555P01

S9820-64H switch

Release 6555P01

 

Procedures

# Create VLAN 100, and assign HundredGigE 1/0/2 to VLAN 100.

<Device> system-view

[Device] vlan 100

[Device-vlan100] quit

[Device] interface hundredgige 1/0/2

[Device-HundredGigE1/0/2] port access vlan 100

[Device-HundredGigE1/0/2] quit

# Configure HundredGigE 1/0/3 (port connected to the LAN switch) as a trunk port, and assign the port to VLAN 100.

[Device] interface hundredgige 1/0/3

[Device-HundredGigE1/0/3] port link-type trunk

[Device-HundredGigE1/0/3] port trunk permit vlan 100

[Device-HundredGigE1/0/3] quit

# Add a static entry for MAC address 0000-fc00-a249 on HundredGigE 1/0/2 that belongs to VLAN 100.

[Device] mac-address static 0000-fc00-a249 interface hundredgige 1/0/2 vlan 100

Verifying the configuration

# Verify that any 10.0.0.0/24 host in VLAN 100 can communicate with the server. (Details not shown.)

# Verify that the static MAC address entry has been added.

[Device] display mac-address

MAC Address      VLAN ID    State            Port/NickName            Aging

0000-fc00-a249   100        Static           HGE1/0/2                 N

7425-8a02-4d00   100        Learned          HGE1/0/3                 Y

Configuration files

#

sysname Device

#

vlan 1

#

vlan 100

#

interface HundredGigE1/0/2

 port access vlan 100

 mac-address static 0000-fc00-a249 vlan 100

#

interface HundredGigE1/0/3

 port link-type trunk

 port trunk permit vlan 1 100

#

Example: Configuring MAC address move suppression

Network configuration

As shown in Figure 2, Devices A, B, and C form a loop because of cable misconnection, and spanning tree protocols are not enabled on the devices. As a result, MAC addresses are frequently moves among Devices A, B, and C. To deal with loop-triggered MAC flapping, perform the following tasks:

·           Display MAC address move records to locate the Layer 2 loop.

·           Configure MAC address move suppression on Device A to eliminate the Layer 2 loop.

Figure 2 Network diagram

 

Analysis

To meet the network requirements, you must perform the following tasks:

·           For Devices A, B, and C to communicate with each other, assign all inter-connected ports to VLAN 100.

·           Configure MAC address move suppression on one or more ports of Device A.

·           To monitor the port status change of Device A, enable the log monitoring of the current terminal feature.

·           For loop detection, create VLAN-interface 100 and assign an IP address to the interface on each device.

·           To display MAC address move records, ping Device B from Device A.

Applicable hardware and software versions

The following matrix shows the hardware and software versions to which this configuration example is applicable:

 

Hardware

Software version

S6850 switch series

S9850 switch series

Release 6555P01

S9820-64H switch

Release 6555P01

 

Procedures

Configuring Device A

# Enable the monitoring of logs on the current terminal.

<DeviceA> terminal monitor

<DeviceA> terminal debugging

# Create VLAN 100.

<DeviceA> system-view

[DeviceA] vlan 100

[DeviceA-vlan100] quit

# Configure HundredGigE 1/0/1 and HundredGigE 1/0/2 as trunk ports, and assign the ports to VLAN 100.

[DeviceA] interface range hundredgige 1/0/1 hundredgige 1/0/2

[DeviceA-if-range] port link-type trunk

[DeviceA-if-range] port trunk permit vlan 100

[DeviceA-if-range] quit

# Set the suppression interval to 300 seconds. A suppressed port will automatically come up after 300 seconds.

[DeviceA] mac-address notification mac-move suppression interval 300

# Set the suppression threshold to 0. A port will be shut down when the system detects a MAC address move on the port within a MAC move detection interval (1 minute by default).

[DeviceA] mac-address notification mac-move suppression threshold 0

# Enable MAC address move suppression on HundredGigE 1/0/1.

[DeviceA] interface hundredgige 1/0/1

[DeviceA-HundredGigE1/0/1] mac-address notification mac-move suppression

[DeviceA-HundredGigE1/0/1] quit

# Create VLAN-interface 100, and assign an IP address to the interface.

[DeviceA] interface vlan-interface 100

[DeviceA-Vlan-interface100] ip address 10.0.0.1 24

[DeviceA-Vlan-interface100] quit

Configuring Device B and Device C

1.      Configure Device B:

# Create VLAN 100.

<DeviceB> system-view

[DeviceB] vlan 100

[DeviceB-vlan100] quit

# Configure HundredGigE 1/0/1 and HundredGigE 1/0/2 as trunk ports, and assign the ports to VLAN 100.

[DeviceB] interface range hundredgige 1/0/1 hundredgige 1/0/2

[DeviceB-if-range] port link-type trunk

[DeviceB-if-range] port trunk permit vlan 100

[DeviceB-if-range] quit

# Create VLAN-interface 100, and assign an IP address to the interface.

[DeviceB] interface vlan-interface 100

[DeviceB-Vlan-interface100] ip address 10.0.0.2 24

[DeviceB-Vlan-interface100] quit

2.      Configure Device C in the same way Device B was configured. (Details not shown.)

Verifying the configuration

# Ping Device B from Device A. (Details not shown.)

# Verify that HundredGigE 1/0/1 on Device A is shut down.

[DeviceA] %Dec 11 09:51:06:309 2016 DeviceA IFNET/3/PHY_UPDOWN: -MDC=1; Physical state on the HundredGigE1/0/1 changed to down.

%Dec 11 09:51:06:323 2016 DeviceA IFNET/5/LINK_UPDOWN: -MDC=1; Line protocol state on

the interface HundredGigE1/0/1 changed to down.

# Verify that HundredGigE 1/0/1 is shut down because a MAC address move is detected.

[DeviceA] display interface hundredgige 1/0/1

HundredGigE1/0/1

Current state: mac-address moving down

Line protocol state: DOWN

...

# Verify that HundredGigE 1/0/1 comes up automatically after 300 seconds.

[DeviceA] %Dec 11 09:56:07:002 2016 DeviceA IFNET/3/PHY_UPDOWN: -MDC=1; Physical state on the HundredGigE1/0/1 changed to up.

%Dec 11 09:56:07:004 2016 DeviceA IFNET/5/LINK_UPDOWN: -MDC=1; Line protocol state on

the interface HundredGigE1/0/1 changed to up.

# Verify that the MAC address of Device B's VLAN-interface 100 moves between HundredGigE 1/0/1 and HundredGigE 1/0/2. You can manually shut down either port to eliminate the loop.

[DeviceA] display mac-address mac-move

MAC address    VLAN Current port  Source port   Last time              Times

0000-fc00-6506 100  HGE1/0/2      HGE1/0/1      2014-12-11 09:29:48    3

0000-fc00-6506 100  HGE1/0/1      HGE1/0/2      2014-12-11 09:51:03    4

 

---  2 MAC address moving records found  ---

Configuration files

·           Device A:

#

sysname DeviceA

#

mac-address notification mac-move suppression interval 300

mac-address notification mac-move suppression threshold 0

#

vlan 1

#

vlan 100

#

interface Vlan-interface100

 ip address 10.0.0.1 255.255.255.0

#

interface HundredGigE1/0/1

 port link-type trunk

 port trunk permit vlan 1 100

 mac-address notification mac-move suppression

#

interface HundredGigE1/0/2

 port link-type trunk

 port trunk permit vlan 1 100

#

·           Device B:

#

sysname DeviceB

#

vlan 1

#

vlan 100

#

interface Vlan-interface100

 ip address 10.0.0.2 255.255.255.0

#

interface HundredGigE1/0/1

 port link-type trunk

 port trunk permit vlan 1 100

#

interface HundredGigE1/0/2

 port link-type trunk

 port trunk permit vlan 1 100

#

·           Device C:

#

sysname DeviceC

#

vlan 1

#

vlan 100

#

interface Vlan-interface100

 ip address 10.0.0.3 255.255.255.0

#

interface HundredGigE1/0/1

 port link-type trunk

 port trunk permit vlan 1 100

#

interface HundredGigE1/0/2

 port link-type trunk

 port trunk permit vlan 1 100

#

Related documentation

·           H3C S6850 & S9850 Switch Series Layer 2—LAN Switching Configuration Guide-Release 655x

·           H3C S6850 & S9850 Switch Series Layer 2—LAN Switching Command Reference-Release 655x

·           H3C S9820-64H Switch Layer 2—LAN Switching Configuration Guide-Release 655x

·           H3C S9820-64H Switch Layer 2—LAN Switching Command Reference-Release 655x