H3C S6850&S9850&S9820-64H Config Examples-Release 655x-6W100

HomeSupportResource CenterH3C S6850&S9850&S9820-64H Config Examples-Release 655x-6W100
Table of Contents
Related Documents
15-GRE Tunnel Configuration Examples
Title Size Download
15-GRE Tunnel Configuration Examples 87.07 KB

 

H3C S6850 & S9850 & S9820-64H

IPv6 over IPv4 GRE Tunnel

Configuration Examples

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Copyright © 2020 New H3C Technologies Co., Ltd. All rights reserved.

No part of this manual may be reproduced or transmitted in any form or by any means without prior written consent of New H3C Technologies Co., Ltd.

Except for the trademarks of New H3C Technologies Co., Ltd., any trademarks that may be mentioned in this document are the property of their respective owners.

The information in this document is subject to change without notice.



Introduction

This document provides IPv6 over IPv4 GRE tunnel configuration examples.

Prerequisites

The configuration examples in this document were created and verified in a lab environment, and all the devices were started with the factory default configuration. When you are working on a live network, make sure you understand the potential impact of every command on your network.

This document assumes that you have basic knowledge of GRE.

Example: Configuring an IPv6 over IPv4 GRE tunnel

Network configuration

As shown in Figure 1, Device A, Device B, and Device C are all on an IPv4 network. Dual stack devices Device A and Device B each connect to an IPv6 host.

Configure a GRE/IPv4 tunnel between Device A and Device B, so PC A and PC B can communicate with each other over the IPv4 network.

Figure 1 Network diagram

 

Analysis

To meet the network requirements, perform the following tasks:

·           To enable the IPv6 hosts to communicate over the IPv4 network, specify the GRE tunnel mode as GRE/IPv4 and configure IPv6 addresses for the tunnel interfaces.

·           To transmit packets between PC A and PC B through the GRE tunnel, configure a route reaching the destination network through the tunnel interface on Device A and Device B. You can configure the routes by using either of the following methods:

¡  Configure static routes, using the peer tunnel interface as the next hop or using the local tunnel interface as the outgoing interface.

¡  Enable a dynamic routing protocol on both the tunnel interfaces and the Layer 3 interfaces connected to PC A and PC B.

·           For both ends of the GRE tunnel to reach each other, configure a static route reaching the remote end on Device A and Device B.

Applicable hardware and software versions

The following matrix shows the hardware and software versions to which this configuration example is applicable:

 

Hardware

Software version

S6850 switch series

S9850 switch series

Release 6555P01

S9820-64H switch

Release 6555P01

 

Restrictions and guidelines

When you configure the GRE tunnel, follow these restrictions and guidelines:

·           You must configure the tunnel source address and destination address at both ends of the tunnel. The tunnel source or destination address at one end must be the tunnel destination or source address at the other end.

·           Encapsulated packets cannot be forwarded on Layer 3 according to the destination IP addresses and routing tables. You must create a service loopback group of the tunnel service type to loop encapsulated packets back to the forwarding module for Layer 3 forwarding.

Procedures

Configuring Device A

# Configure VLAN-interface 20.

<DeviceA> system-view

[DeviceA] vlan 20

[DeviceA-vlan20] port hundredgige 1/0/1

[DeviceA-vlan20] quit

[DeviceA] interface vlan-interface 20

[DeviceA-vlan-interface20] ipv6 address 1001::1 64

[DeviceA-vlan-interface20] quit

# Configure other interfaces in the same way VLAN-interface 20 is configured. (Details not shown.)

# Create service loopback group 1, and specify its service type as tunnel.

[DeviceA] service-loopback group 1 type tunnel

# Add HundredGigE 1/0/3 to service loopback group 1.

[DeviceA] interface hundredgige 1/0/3

[DeviceA-HundredGigE1/0/3] port service-loopback group 1

[DeviceA-HundredGigE1/0/3] quit

# Create a tunnel interface named Tunnel 0, and specify the tunnel mode as GRE/IPv4.

[DeviceA] interface tunnel 0 mode gre

# Configure an IPv6 address for tunnel interface Tunnel 0.

[DeviceA-Tunnel0] ipv6 address 3001::1 64

# Configure the source address of tunnel interface Tunnel 0 as the IP address of VLAN-interface 10.

[DeviceA-Tunnel0] source 192.13.2.2

# Configure the destination address of tunnel interface Tunnel 0 as the IP address of VLAN-interface 11 on Device B.

[DeviceA-Tunnel0] destination 131.108.5.2

[DeviceA-Tunnel0] quit

# Configure a static route reaching PC B through tunnel interface Tunnel 0.

[DeviceA] ipv6 route-static 2001:: 64 tunnel 0

# Configure a static route reaching the remote end of the GRE tunnel.

[DeviceA] ip route-static 131.108.5.2 255.255.255.0 192.13.2.1

Configuring Device B

# Configure VLAN-interface 20.

<DeviceB> system-view

[DeviceB] vlan 20

[DeviceB-vlan20] port hundredgige 1/0/1

[DeviceB] interface vlan-interface 20

[DeviceB-Vlan-interface20] ipv6 address 2001::1 64

[DeviceB-Vlan-interface20] quit

# Configure other interfaces in the same way VLAN-interface 20 is configured. (Details not shown.)

# Create service loopback group 1, and specify its service type as tunnel.

[DeviceB] service-loopback group 1 type tunnel

# Add HundredGigE 1/0/3 to service loopback group 1.

[DeviceB] interface hundredgige 1/0/3

[DeviceB-HundredGigE1/0/3] port service-loopback group 1

[DeviceB-HundredGigE1/0/3] quit

# Create a tunnel interface named Tunnel 0, and specify the tunnel mode as GRE/IPv4.

[DeviceB] interface tunnel 0 mode gre

# Configure an IPv6 address for tunnel interface Tunnel 0.

[DeviceB-Tunnel0] ipv6 address 3001::2 64

# Configure the source address of tunnel interface Tunnel 0 as the IP address of VLAN-interface 11.

[DeviceB-Tunnel0] source 131.108.5.2

# Configure the destination address of tunnel interface Tunnel 0 as the IP address of VLAN-interface 10 on Device A.

[DeviceB-Tunnel0] destination 192.13.2.2

[DeviceB-Tunnel0] quit

# Configure a static route reaching PC A through tunnel interface Tunnel 0.

[DeviceB] ipv6 route-static 1001:: 64 Tunnel 0

# Configure a static route reaching the remote end of the GRE tunnel.

[DeviceB] ip route-static 192.13.2.2 255.255.255.0 131.108.5.1

Configuring Device C

# Configure VLAN-interface 10.

<DeviceC> system-view

[DeviceC] vlan 10

[DeviceC-vlan10] port hundredgige 1/0/1

[DeviceC-vlan10] quit

[DeviceC] interface Vlan-interface 10

[DeviceC-Vlan-interface10] ip address 192.13.2.1 24

[DeviceC-Vlan-interface10] quit

# Configure VLAN-interface 11.

[DeviceC] vlan 11

[DeviceC-vlan11] port hundredgige 1/0/2

[DeviceC-vlan11] quit

[DeviceC] interface vlan-interface 11

[DeviceC-Vlan-interface11] ip address 131.108.5.1 24

[DeviceC-Vlan-interface11] quit

Verifying the configuration

# Verify that PC A and PC B can ping each other successfully. This example uses PC A to ping PC B.

C:\>ping6 2001::2

 

Pinging 2001::2

from 1001::1 with 32 bytes of data:

 

Reply from 2001::2: bytes=32 time<1ms

Reply from 2001::2: bytes=32 time<1ms

Reply from 2001::2: bytes=32 time<1ms

Reply from 2001::2: bytes=32 time<1ms

 

Ping statistics for 2001::2:

    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),

Approximate round trip times in milli-seconds:

    Minimum = 0ms, Maximum = 0ms, Average = 0ms

Configuration files

·           Device A:

#

 service-loopback group 1 type tunnel

#

vlan 10

#

vlan 20

#

interface Vlan-interface10

 ip address 192.13.2.2 255.255.255.0

#

interface Vlan-interface20

 ipv6 address 1001::1/64

#

interface HundredGigE1/0/1

 port link-mode bridge

 port access vlan 20

#

interface HundredGigE1/0/2

 port link-mode bridge

 port access vlan 10

#

interface HundredGigE1/0/3

 port link-mode bridge

 port service-loopback group 1

#

interface Tunnel0 mode gre

 ipv6 address 3001::1/64

 source 192.13.2.2

 destination 131.108.5.2

#

 ip route-static 131.108.5.2 255.255.255.0 192.13.2.1

#

 ipv6 route-static 2001:: 64 Tunnel 0

#

·           Device B:

#

 service-loopback group 1 type tunnel

#

vlan 11

#

vlan 20

#

interface Vlan-interface11

 ip address 131.108.5.2 255.255.255.0

#

interface Vlan-interface20

 ipv6 address 2001::1/64

#

interface HundredGigE1/0/1

 port link-mode bridge

 port access vlan 20

#

interface HundredGigE1/0/2

 port link-mode bridge

 port access vlan 11

#

interface HundredGigE1/0/3

 port link-mode bridge

 port service-loopback group 1

#

interface Tunnel0 mode gre

 ipv6 address 3001::2/64

 source 131.108.5.2

 destination 192.13.2.2

#

ip route-static 192.13.2.2 255.255.255.0 131.108.5.1

#

ipv6 route-static 1001:: 64 Tunnel 0

#

·           Device C:

#

vlan 10 to 11

#

interface Vlan-interface10

 ip address 192.13.2.1 255.255.255.0

#

interface Vlan-interface11

 ip address 131.108.5.1 255.255.255.0

#

interface HundredGigE1/0/1

 port link-mode bridge

 port access vlan 10

#

interface HundredGigE1/0/2

 port link-mode bridge

 port access vlan 11

#

Related documentation

·           H3C S6850 & S9850 Switch Series Layer 3—IP Services Configuration Guide-Release 655x

·           H3C S6850 & S9850 Switch Series Layer 3—IP Services Command Reference-Release 655x

·           H3C S9820-64H Switch Layer 3—IP Services Configuration Guide-Release 655x

·           H3C S9820-64H Switch Layer 3—IP Services Command Reference-Release 655x

·           H3C S6850 & S9850 Switch Series Layer 3—IP Routing Configuration Guide-Release 655x

·           H3C S6850 & S9850 Switch Series Layer 3—IP Routing Command Reference-Release 655x

·           H3C S9820-64H Switch Layer 3—IP Routing Configuration Guide-Release 655x

·           H3C S9820-64H Switch Layer 3—IP Routing Command Reference-Release 655x