- Table of Contents
-
- 02-Configuration Examples
- 01-H3C_AAA_Configuration_Examples
- 02-H3C_ACL_Configuration_Examples
- 03-H3C_IGMP_Configuration_Examples
- 04-H3C_IP_Source_Guard_Configuration_Examples
- 05-H3C_Ethernet_OAM_Configuration_Examples
- 06-H3C_NQA_Configuration_Examples
- 07-H3C_QinQ_Configuration_Examples
- 08-H3C_OSPF_Configuration_Examples
- 09-H3C_MPLS_TE_Configuration_Examples
- 10-H3C_OpenFlow_Configuration_Examples
- 11-H3C_NAT_Configuration_Examples
- 12-H3C_RBAC_Configuration_Examples
- 13-H3C_DHCP_Relay_Redundancy_Configuration_Examples
- 14-H3C_DLDP_Configuration_Examples
- 15-H3C_IS-IS_Configuration_Examples
- 16-H3C_MPLS_L3VPN_Configuration_Examples
- 17-H3C_SSH_Configuration_Examples
- 18-H3C_Login_Management_Configuration_Examples
- 19-H3C_SNMP_Configuration_Examples
- 20-H3C_Priority_Marking_and_Queue_Scheduling_Configuration_Examples
- 21-H3C_Multicast_VPN_Configuration_Examples
- 22-H3C_BGP_Configuration_Examples
- 23-H3C_HoVPN_Configuration_Examples
- 24-H3C_L2TP_Configuration_Examples
- 25-H3C_VRRP_Configuration_Examples
- 26-H3C_Traffic_Filtering_Configuration_Examples
- 27-H3C_Samplers_and_IPv4_NetStream_Configuration_Examples
- 28-H3C_MPLS_L2VPN_Configuration_Examples
- 29-H3C_NetStream_Configuration_Examples
- 30-H3C_Policy-Based_Routing_Configuration_Examples
- 31-H3C_Traffic_Policing_Configuration_Examples
- 32-H3C_BFD_Configuration_Examples
- 33-H3C_OSPFv3_Configuration_Examples
- 34-H3C_VPLS_Configuration_Examples
- 35-H3C_GTS_and_Rate_Limiting_Configuration_Examples
- 36-H3C_IPv6_IS-IS_Configuration_Examples
- 37-H3C_MPLS OAM_Configuration_Examples
- 38-H3C_BGP_Route_Selection_Configuration_Examples
- 39-H3C_IS-IS_Route_Summarization_Configuration_Examples
- 40-H3C_SRv6 Configuration Examples
- 41-H3C_Attack_Protection_Configuration_Examples
- 42-H3C_OSPF_Multi-Process_Configuration_Examples
- 43-H3C_OSPF_with_Multi-Instance_Configuration_Examples
- 44-H3C_ARP_Attack_Protection_Configuration_Examples
- 45-H3C_DHCPv6_Server_and_DHCPv6_Prefix_Client_Configuration_Examples
- 46-General QoS Configuration Examples
- 47-GRE Tunnel Establishment Using OSPF Configuration Examples
- 48-GRE Tunnel Establishment Using Static Routes Configuration Examples
- 49-QoS Configuration Examples for the Financial Industry
- Related Documents
-
Title | Size | Download |
---|---|---|
15-H3C_IS-IS_Configuration_Examples | 110.36 KB |
Introduction
This document provides IS-IS configuration examples.
Prerequisites
The configuration examples in this document were created and verified in a lab environment, and all the devices were started with the factory default configuration. When you are working on a live network, make sure you understand the potential impact of every command on your network.
This document assumes that you have basic knowledge of IS-IS.
Example: Configuring IS-IS
Network configuration
As shown in Figure 1, the company's headquarters and the branch run IS-IS. The partner runs OSPF.
Configure the routers to meet the following requirements:
· Reduce traffic for Router A and Router B because they have relative low performance.
· The Marketing department can reach the Finance department, the branch, and the partner.
· The Finance department and the branch cannot reach each other, and the branch does not have a route to the Finance department.
· When the IS-IS process on Router C restarts, the communication is not interrupted.
Analysis
To meet the network requirements, you must perform the following tasks:
· To reduce traffic for Router A and Router B, configure them as Level-1 routers to allow communication only between the Marketing department and the Finance department.
· Configure route redistribution between IS-IS and OSPF on Router D to allow communication between the Marketing department and the partner.
· Configure Router C to use a prefix list to advertise only network 10.100.1.0/24 to Level-2 to ensure that the branch does not have a route to the Finance department.
· Enable IS-IS Graceful Restart (GR) on Router C to ensure that the communication is not interrupted when the IS-IS process on Router C restarts.
Restrictions and guidelines
To avoid blackhole routes, do not change the network topology during the IS-IS GR process.
Procedures
Configuring Router A
# Configure an IP address for Ten-GigabitEthernet 0/0/15.
<RouterA> system-view
[RouterA] interface ten-gigabitethernet 0/0/15
[RouterA-Ten-GigabitEthernet0/0/15] ip address 192.168.1.1 24
[RouterA-Ten-GigabitEthernet0/0/15] quit
# Configure IP addresses for other interfaces, as shown in Figure 1. (Details not shown.)
# Configure IS-IS.
[RouterA] isis 1
[RouterA-isis-1] is-level level-1
[RouterA-isis-1] network-entity 10.1921.6800.1001.00
[RouterA-isis-1] quit
[RouterA] interface ten-gigabitethernet 0/0/15
[RouterA–Ten-GigabitEthernet0/0/15] isis enable 1
[RouterA–Ten-GigabitEthernet0/0/15] quit
[RouterA] interface ten-gigabitethernet 0/0/16
[RouterA–Ten-GigabitEthernet0/0/16] isis enable 1
[RouterA–Ten-GigabitEthernet0/0/16] quit
Configuring Router B
# Configure an IP address for Ten-GigabitEthernet 0/0/15.
<RouterB> system-view
[RouterB] interface ten-gigabitethernet 0/0/15
[RouterB-Ten-GigabitEthernet0/0/15] ip address 192.168.2.1 24
[RouterB-Ten-GigabitEthernet0/0/15] quit
# Configure IP addresses for other interfaces, as shown in Figure 1. (Details not shown.)
# Configure IS-IS.
[RouterB] isis 1
[RouterB-isis-1] is-level level-1
[RouterB-isis-1] network-entity 10.1921.6800.2001.00
[RouterB-isis-1] quit
[RouterB] interface ten-gigabitethernet 0/0/15
[RouterB–Ten-GigabitEthernet0/0/15] isis enable 1
[RouterB–Ten-GigabitEthernet0/0/15] quit
[RouterB] interface ten-gigabitethernet 0/0/16
[RouterB–Ten-GigabitEthernet0/0/16] isis enable 1
[RouterB–Ten-GigabitEthernet0/0/16] quit
Configuring Router C
# Configure an IP address for Ten-GigabitEthernet 0/0/15.
<RouterC> system-view
[RouterC] interface ten-gigabitethernet 0/0/15
[RouterC-Ten-GigabitEthernet0/0/15] ip address 192.168.1.2 24
[RouterC-Ten-GigabitEthernet0/0/15] quit
# Configure IP addresses for other interfaces, as shown in Figure 1. (Details not shown.)
# Configure IS-IS.
[RouterC-isis-1] network-entity 10.1921.6801.0001.00
[RouterC-isis-1] quit
[RouterC] interface ten-gigabitethernet 0/0/15
[RouterC–Ten-GigabitEthernet0/0/15] isis enable 1
[RouterC–Ten-GigabitEthernet0/0/15] quit
[RouterC] interface ten-gigabitethernet 0/0/16
[RouterC–Ten-GigabitEthernet0/0/16] isis enable 1
[RouterC–Ten-GigabitEthernet0/0/16] quit
[RouterC] interface ten-gigabitethernet 0/0/17
[RouterC–Ten-GigabitEthernet0/0/17] isis enable 1
[RouterC–Ten-GigabitEthernet0/0/17] quit
# Configure route leaking from Level-1 to Level-2, and use prefix list 1 to advertise only network 10.100.1.0/24 to Level-2.
[RouterC] ip prefix-list 1 permit 10.100.1.0 24
[RouterC] isis 1
[RouterC-isis-1] address-family ipv4
[RouterC-isis-1-ipv4] import-route isis level-1 into level-2 filter-policy prefix-list 1
[RouterC-isis-1-ipv4] quit
# Enable IS-IS GR.
[RouterC-isis-1] graceful-restart
[RouterC-isis-1] quit
Configuring Router D
# Configure an IP address for Ten-GigabitEthernet 0/0/15.
<RouterD> system-view
[RouterD] interface ten-gigabitethernet 0/0/15
[RouterD-Ten-GigabitEthernet0/0/15] ip address 192.168.10.2 24
[RouterD-Ten-GigabitEthernet0/0/15] quit
# Configure IP addresses for other interfaces, as shown in Figure 1. (Details not shown.)
# Configure IS-IS.
[RouterD] isis 1
[RouterD-isis-1] is-level level-2
[RouterD-isis-1] network-entity 20.1921.6802.0001.00
[RouterD-isis-1] quit
[RouterD] interface ten-gigabitethernet 0/0/15
[RouterD–Ten-GigabitEthernet0/0/15] isis enable 1
[RouterD–Ten-GigabitEthernet0/0/15] quit
[RouterD] interface ten-gigabitethernet 0/0/16
[RouterD–Ten-GigabitEthernet0/0/16] isis enable 1
[RouterD–Ten-GigabitEthernet0/0/16] quit
# Configure OSPF.
[RouterD] ospf
[RouterD-ospf-1] area 0
[RouterD-ospf-1-area-0.0.0.0] network 192.168.20.0 0.0.0.255
[RouterD-ospf-1-area-0.0.0.0] quit
[RouterD-ospf-1] quit
# Redistribute OSPF and direct routes into IS-IS
[RouterD] isis 1
[RouterD-isis-1] address-family ipv4
[RouterD-isis-1-ipv4] import-route ospf
[RouterD-isis-1-ipv4] import-route direct
[RouterD-isis-1-ipv4] quit
[RouterD-isis-1] quit
# Redistribute IS-IS and direct routes into OSPF.
[RouterD] ospf 1
[RouterD-ospf-1] import-route isis 1
[RouterD-ospf-1] import-route direct
Configuring Router E
# Configure an IP address for Ten-GigabitEthernet 0/0/15.
<RouterE> system-view
[RouterE] interface ten-gigabitethernet 0/0/15
[RouterE-Ten-GigabitEthernet0/0/15] ip address 192.168.20.2 24
[RouterE-Ten-GigabitEthernet0/0/15] quit
# Configure IP addresses for other interfaces, as shown in Figure 1. (Details not shown.)
# Configure OSPF.
[RouterE] ospf
[RouterE-ospf-1] area 0
[RouterE-ospf-1-area-0.0.0.0] network 192.168.20.0 0.0.0.255
[RouterE-ospf-1-area-0.0.0.0] network 10.200.1.0 0.0.0.255
[RouterE-ospf-1-area-0.0.0.0] quit
[RouterE-ospf-1] quit
Verifying the configuration
# Verify that the branch can reach the Marketing department, but cannot reach the Finance department.
[RouterD] display isis route
Route information for IS-IS(1)
------------------------------
Level-2 IPv4 Forwarding Table
-----------------------------
IPv4 Destination IntCost ExtCost ExitInterface NextHop Flags
-------------------------------------------------------------------------------
192.168.10.0/24 10 NULL XGE0/0/15 Direct D/L/-
192.168.1.0/24 20 NULL XGE0/0/15 192.168.10.1 R/-/-
10.100.1.0/24 30 NULL XGE0/0/15 192.168.10.1 R/-/-
192.168.2.0/24 20 NULL XGE0/0/15 192.168.10.1 R/-/-
Flags: D-Direct, R-Added to Rib, L-Advertised in LSPs, U-Up/Down Bit Set
# Verify that the company can communicate with the partner.
· Display the IS-IS routing table on Router C.
[RouterC] display isis route
Route information for IS-IS(1)
-----------------------------
Level-1 IPv4 Forwarding Table
-----------------------------
IPv4 Destination IntCost ExtCost ExitInterface NextHop Flags
-------------------------------------------------------------------------------
192.168.10.0/24 10 NULL XGE0/0/17 Direct D/L/-
192.168.1.0/24 10 NULL XGE0/0/15 Direct D/L/-
10.100.1.0/24 20 NULL XGE0/0/15 192.168.1.1 R/L/-
10.100.2.0/24 20 NULL XGE0/0/16 192.168.2.1 R/-/-
192.168.2.0/24 10 NULL XGE0/0/16 Direct D/L/-
Flags: D-Direct, R-Added to Rib, L-Advertised in LSPs, U-Up/Down Bit Set
Level-2 IPv4 Forwarding Table
-----------------------------
IPv4 Destination IntCost ExtCost ExitInterface NextHop Flags
-------------------------------------------------------------------------------
192.168.10.0/24 10 NULL XGE0/0/17 Direct D/L/-
10.200.1.0/24 10 0 XGE0/0/17 192.168.10.2 R/-/-
192.168.20.0/24 10 0 XGE0/0/17 192.168.10.2 R/-/-
192.168.1.0/24 10 NULL XGE0/0/15 Direct D/L/-
192.168.2.0/24 10 NULL XGE0/0/16 Direct D/L/-
Flags: D-Direct, R-Added to Rib, L-Advertised in LSPs, U-Up/Down Bit Set
· Ping 10.200.1.1 from XGE3/1/23/0/2 on Router A.
[RouterA] ping –a 10.100.1.1 10.200.1.1
Ping 10.200.1.1 (10.200.1.1): 56 data bytes, press CTRL_C to break
56 bytes from 10.200.1.1: icmp_seq=0 ttl=252 time=1.862 ms
56 bytes from 10.200.1.1: icmp_seq=1 ttl=252 time=2.969 ms
56 bytes from 10.200.1.1: icmp_seq=2 ttl=252 time=1.402 ms
56 bytes from 10.200.1.1: icmp_seq=3 ttl=252 time=1.324 ms
56 bytes from 10.200.1.1: icmp_seq=4 ttl=252 time=1.510 ms
--- Ping statistics for 10.200.1.1 ---
5 packet(s) transmitted, 5 packet(s) received, 0.0% packet loss
round-trip min/avg/max/std-dev = 1.324/1.813/2.969/0.606 ms
# Verify that the communication is not interrupted when the IS-IS process restarts.
· Ping Router B from Router A.
[RouterA] ping -c 10000 10.100.2.1
Ping 10.100.2.1 (10.100.2.1): 56 data bytes, press CTRL_C to break
56 bytes from 10.100.2.1: icmp_seq=0 ttl=254 time=1.185 ms
56 bytes from 10.100.2.1: icmp_seq=1 ttl=254 time=1.087 ms
…
· Restart the IS-IS process on Router C.
<RouterC> reset isis all graceful-restart
Reset IS-IS process? [Y/N] :y
# Ping Router B from Router A.
[RouterA] ping -c 10000 10.100.2.1
Ping 10.100.2.1 (10.100.2.1): 56 data bytes, press CTRL_C to break
56 bytes from 10.100.2.1: icmp_seq=0 ttl=254 time=1.185 ms
56 bytes from 10.100.2.1: icmp_seq=1 ttl=254 time=1.087 ms
56 bytes from 10.100.2.1: icmp_seq=2 ttl=254 time=1.672 ms
56 bytes from 10.100.2.1: icmp_seq=3 ttl=254 time=1.751 ms
56 bytes from 10.100.2.1: icmp_seq=4 ttl=254 time=1.816 ms
56 bytes from 10.100.2.1: icmp_seq=5 ttl=254 time=1.814 ms
# Check the IS-IS GR state on Router C.
[RouterC] display isis graceful-restart status
Restart information for IS-IS(1)
--------------------------------
Restart status: COMPLETE
Restart phase: Finish
Restart t1: 3, count 10; Restart t2: 60; Restart t3: 300
SA Bit: supported
Level-1 restart information
---------------------------
Total number of interfaces: 3
Number of waiting LSPs: 0
Level-2 restart information
---------------------------
Total number of interfaces: 3
Number of waiting LSPs: 0
Configuration files
Router A
#
isis 1
is-level level-1
network-entity 10.1921.6800.1001.00
#
interface ten-gigabitethernet 0/0/15
ip address 192.168.1.1 255.255.255.0
isis enable 1
#
interface ten-gigabitethernet 0/0/16
ip address 10.100.1.1 255.255.255.0
isis enable 1
#
Router B
#
isis 1
is-level level-1
network-entity 10.1921.6800.2001.00
#
interface ten-gigabitethernet 0/0/15
ip address 192.168.2.1 255.255.255.0
isis enable 1
#
interface ten-gigabitethernet 0/0/16
ip address 10.100.2.1 255.255.255.0
isis enable 1
#
Router C
isis 1
graceful-restart
network-entity 10.1921.6801.0001.00
#
address-family ipv4 unicast
import-route isis level-1 into level-2 filter-policy prefix-list 1
#
interface ten-gigabitethernet 0/0/15
ip address 192.168.1.2 255.255.255.0
isis enable 1
#
interface ten-gigabitethernet 0/0/16
ip address 192.168.2.2 255.255.255.0
isis enable 1
#
interface ten-gigabitethernet 0/0/17
ip address 192.168.10.1 255.255.255.0
isis enable 1
#
ip prefix-list 1 index 10 permit 10.100.1.0 24
#
Router D
#
isis 1
is-level level-2
network-entity 20.1921.6802.0001.00
#
address-family ipv4 unicast
import-route direct
import-route ospf 1
#
ospf 1
import-route direct
import-route isis 1
area 0.0.0.0
network 192.168.20.0 0.0.0.255
#
Interface ten-gigabitethernet 0/0/15
ip address 192.168.10.2 255.255.255.0
isis enable 1
#
interface ten-gigabitethernet 0/0/16
ip address 192.168.20.1 255.255.255.0
#
Router E
#
ospf 1
area 0.0.0.0
network 10.200.1.0 0.0.0.255
network 192.168.20.0 0.0.0.255
#
interface ten-gigabitethernet 0/0/15
ip address 192.168.20.2 255.255.255.0
#
interface ten-gigabitethernet 0/0/17
ip address 10.200.1.1 255.255.255.0
#
Related documentation
· H3C CR16000-M1A Routers Layer—3 IP Routing Configuration Guide
· H3C CR16000-M1A Routers Layer—3 IP Routing Command Reference