12-WLAN advanced features

HomeSupportResource CenterConfigure & DeployConfiguration ExamplesH3C Access Controllers Configuration Examples(V7)-6W10212-WLAN advanced features
04-Inter-AC Roaming Configuration Examples
Title Size Download
04-Inter-AC Roaming Configuration Examples 237.12 KB

 

H3C Access Controllers

Comware 7 Inter-AC Roaming

Configuration Examples

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Copyright © 2021 New H3C Technologies Co., Ltd. All rights reserved.

No part of this manual may be reproduced or transmitted in any form or by any means without prior written consent of New H3C Technologies Co., Ltd.

Except for the trademarks of New H3C Technologies Co., Ltd., any trademarks that may be mentioned in this document are the property of their respective owners.

The information in this document is subject to change without notice.



Introduction

The following information provides an inter-AC roaming configuration example.

Prerequisites

This document applies to Comware 7-based access controllers and access points. Procedures and information in the examples might be slightly different depending on the software or hardware version of the access controllers and access points.

The configuration examples in this document were created and verified in a lab environment, and all the devices were started with the factory default configuration. When you are working on a live network, make sure you understand the potential impact of every command on your network.

This document assumes that you have basic knowledge of WLAN access and WLAN roaming.

Example: Configuring inter-AC roaming

Network requirements

As shown in Figure 1, AP 1 and AP 2 are managed by AC 1 and AC 2, respectively. Clients associated with AC 1 belong to VLAN 200. Clients associated with AC 2 belong to VLAN 400.

Complete the following tasks:

·     Configure inter-AC roaming to enable clients to roam between AP 1 and AP 2.

·     Configure VLAN-based user isolation to improve user security and reduce radio resources consumption caused by multicast and broadcast packets.

Figure 1 Network diagram

 

Table 1 Interface and IP address assignment

Device

Interface

IP address

Device

Interface

IP address

AC 1

VLAN-interface 100

192.1.0.2/16

Switch

VLAN-interface 100

192.1.0.1/16

 

VLAN-interface 200

192.2.0.2/16

 

VLAN-interface 200

192.2.0.1/16

AC 2

VLAN-interface 100

192.1.0.3/16

 

VLAN-interface 300

192.3.0.1/16

 

VLAN-interface 400

192.4.0.2/16

 

VLAN-interface 400

192.4.0.1/16

 

Configuration restrictions and guidelines

When you configure inter-AC roaming, follow these restrictions and guidelines:

·     Configure the same SSID, authentication mode, AKE mode, and cipher suite for the service templates to be bound to the APs that are used during WLAN roaming.

·     To implement fast roaming, configure RSN + 802.1X authentication for clients.

·     Add the two ACs to the same mobility group.

·     Use the serial ID labeled on the AP's rear panel to specify an AP.

Configuration procedures

Configuring AC 1

1.     Configure interfaces on AC 1:

# Create VLAN 100 and VLAN-interface 100, and assign an IP address to the VLAN interface. The AC will use this IP address to establish CAPWAP tunnels with APs.

<AC1> system-view

[AC1] vlan 100

[AC1-vlan100] quit

[AC1] interface vlan-interface 100

[AC1-Vlan-interface100] ip address 192.1.0.2 16

[AC1-Vlan-interface100] quit

# Create VLAN 200 and VLAN-interface 200, and assign an IP address to the VLAN interface. The AC will use VLAN 200 for client access.

[AC1] vlan 200

[AC1-vlan200] quit

[AC1] interface vlan-interface 200

[AC1-Vlan-interface200] ip address 192.2.0.2 16

[AC1-Vlan-interface200] quit

# Create VLAN 400. The AC will use VLAN 400 to forward data of the client after the client roams from AP 2 to AP 1.

<AC1> system-view

[AC1] vlan 400

[AC1-vlan400] quit

# Configure the interface that is connected to the switch as a trunk port, and assign the port to VLAN 100, VLAN 200, and VLAN 400.

[AC1] interface gigabitethernet 1/0/1

[AC1-GigabitEthernet1/0/1] port link-type trunk

[AC1-GigabitEthernet1/0/1] port trunk permit vlan 100 200 400

[AC1-GigabitEthernet1/0/1] quit

# Configure the interface that is connected to AP 1 as an access port, and assign the port to VLAN 100.

[AC1] interface gigabitethernet 1/0/2

[AC1-GigabitEthernet1/0/2] port link-type access

[AC1-GigabitEthernet1/0/2] port access vlan 100

[AC1-GigabitEthernet1/0/2] quit

2.     Configure 802.1X authentication:

# Set the EAP message handling method to EAP.

[AC1] dot1x authentication-method eap

# Create a RADIUS scheme named office and enter its view.

[AC1] radius scheme office

# Specify the server at 192.3.0.2 as the primary authentication server.

[AC1-radius-office] primary authentication 192.3.0.2

# Specify the server at 192.3.0.2 as the primary accounting server.

[AC1-radius-office] primary accounting 192.3.0.2

# Set the shared key to 12345678 for secure communication with the primary authentication server and accounting server.

[AC1-radius-office] key authentication simple 12345678

[AC1-radius-office] key accounting simple 12345678

# Set the source IP address to 192.1.0.2 for outgoing RADIUS packets.

[AC1-radius-office] nas-ip 192.1.0.2

[AC1-radius-office] quit

# Create an ISP domain named office and enter its view.

[AC1] domain office

# Configure the ISP domain to use RADIUS scheme office for authentication, authorization, and accounting of LAN users.

[AC1-isp-office] authentication lan-access radius-scheme office

[AC1-isp-office] authorization lan-access radius-scheme office

[AC1-isp-office] accounting lan-access radius-scheme office

[AC1-isp-office] quit

3.     Configure the wireless service:

# Create service template 1 and enter its view.

[AC1] wlan service-template 1

# Set the SSID to service.

[AC1-wlan-st-1] ssid service

# Assign clients coming online through the service template to VLAN 200.

[AC1-wlan-st-1] vlan 200

# Use the AC to forward client traffic.

[AC1-wlan-st-1] client forwarding-location ac

# Set the AKE mode to 802.1X.

[AC1-wlan-st-1] akm mode dot1x

# Set the authentication mode to 802.1X for wireless clients.

[AC1-wlan-st-1] client-security authentication-mode dot1x

# Specify ISP domain office as the authentication domain for 802.1X clients.

[AC1-wlan-st-1] dot1x domain office

# Specify AES-CCMP as the cipher suite used for frame encryption.

[AC1-wlan-st-1] cipher-suite ccmp

# Enable the RSN IE in beacon and probe responses.

[AC1-wlan-st-1] security-ie rsn

# Enable the service template.

[AC1-wlan-st-1] service-template enable

[AC1-wlan-st-1] quit

4.     Configure an AP:

# Create an AP named ap1, and specify its model and the serial ID.

[AC1] wlan ap ap1 model WA4320i-ACN

[AC1-wlan-ap-ap1] serial-id 210235A1GQC14C000225

# Enter radio view of radio 1, and bind service template 1 to the radio.

[AC1-wlan-ap-ap1] radio 1

[AC1-wlan-ap-ap1-radio-1] service-template 1

# Enable radio 1.

[AC1-wlan-ap-ap1-radio-1] radio enable

[AC1-wlan-ap-ap1-radio-1] quit

[AC1-wlan-ap-ap1] quit

5.     Configure WLAN roaming:

# Create mobility group 1.

[AC1] wlan mobility group 1

# Set the source IP address for establishing IACTP tunnels to 192.1.0.2.

[AC1-wlan-mg-1] source ip 192.1.0.2

# Add AC 2 to the mobility group.

[AC1-wlan-mg-1] member ip 192.1.0.3

# Enable the mobility group.

[AC1-wlan-mg-1] group enable

[AC1-wlan-mg-1] quit

6.     Configure user isolation:

# Enable user isolation for VLAN 200.

[AC1] user-isolation vlan 200 enable

# Specify the MAC address of the gateway for VLAN 200 as a permitted MAC address for VLAN 200.

[AC1] user-isolation vlan 200 permit-mac 000f-e212-7788

7.     Configure a default route:

# Configure a default route for AC 1. Set the next hop to 192.1.0.1.

[AC1] ip route-static 0.0.0.0 0.0.0.0 192.1.0.1

Configuring AC 2

1.     Configure interfaces on AC 2:

# Create VLAN 100 and VLAN-interface 100, and assign an IP address to the VLAN interface. The AC will use this IP address to establish CAPWAP tunnels with APs.

<AC2> system-view

[AC2] vlan 100

[AC2-vlan100] quit

[AC2] interface vlan-interface 100

[AC2-Vlan-interface100] ip address 192.1.0.3 16

[AC2-Vlan-interface100] quit

# Create VLAN 200. The AC will use VLAN 200 to forward data of the client after the client roams from AP 1 to AP 2.

<AC2> system-view

[AC2] vlan 200

[AC2-vlan200] quit

# Create VLAN 400 and VLAN-interface 400, and assign an IP address to the VLAN interface. The AC will use VLAN 400 for client access.

[AC2] vlan 400

[AC2-vlan400] quit

[AC2] interface vlan-interface 400

[AC2-Vlan-interface400] ip address 192.4.0.2 16

[AC2-Vlan-interface400] quit

# Configure the interface that is connected to the switch as a trunk port, and assign the port to VLAN 100, VLAN 200, and VLAN 400.

[AC2] interface gigabitethernet 1/0/1

[AC2-GigabitEthernet1/0/1] port link-type trunk

[AC2-GigabitEthernet1/0/1] port trunk permit vlan 100 200 400

[AC2-GigabitEthernet1/0/1] quit

# Configure the interface that is connected to AP 2 as an access port, and assign the port to VLAN 100.

[AC2] interface gigabitethernet 1/0/2

[AC2-GigabitEthernet1/0/2] port link-type access

[AC2-GigabitEthernet1/0/2] port access vlan 100

[AC2-GigabitEthernet1/0/2] quit

2.     Configure 802.1X authentication:

# Set the EAP message handling method to EAP.

[AC2] dot1x authentication-method eap

# Create a RADIUS scheme named office and enter its view.

[AC2] radius scheme office

# Specify the server at 192.3.0.2 as the primary authentication server.

[AC2-radius-office] primary authentication 192.3.0.2

# Specify the server at 192.3.0.2 as the primary accounting server.

[AC2-radius-office] primary accounting 192.3.0.2

# Set the shared key to 12345678 in plaintext form for secure authentication communication.

[AC2-radius-office] key authentication simple 12345678

# Set the shared key to 12345678 in plaintext form for secure accounting communication.

[AC2-radius-office] key accounting simple 12345678

# Set the source IP address to 192.1.0.3 for outgoing RADIUS packets.

[AC2-radius-office] nas-ip 192.1.0.3

[AC2-radius-office] quit

# Create an ISP domain named office and enter its view.

[AC2] domain office

# Configure the ISP domain to use RADIUS scheme office for authentication, authorization, and accounting of LAN users.

[AC2-isp-office] authentication lan-access radius-scheme office

[AC2-isp-office] authorization lan-access radius-scheme office

[AC2-isp-office] accounting lan-access radius-scheme office

[AC2-isp-office] quit

3.     Configure the wireless service:

# Create service template 1 and enter its view.

[AC2] wlan service-template 1

# Set the SSID to service.

[AC2-wlan-st-1] ssid service

# Assign clients coming online through the service template to VLAN 200.

[AC2-wlan-st-1] vlan 200

# Use the AC to forward client traffic.

[AC1-wlan-st-1] client forwarding-location ac

# Set the AKE mode to 802.1X.

[AC2-wlan-st-1] akm mode dot1x

# Set the authentication mode to 802.1X for wireless clients.

[AC2-wlan-st-1] client-security authentication-mode dot1x

# Specify ISP domain office as the authentication domain for 802.1X clients.

[AC2-wlan-st-1] dot1x domain office

# Specify AES-CCMP as the cipher suite used for frame encryption.

[AC2-wlan-st-1] cipher-suite ccmp

# Enable the RSN IE in beacon and probe responses.

[AC2-wlan-st-1] security-ie rsn

# Enable the service template.

[AC2-wlan-st-1] service-template enable

[AC2-wlan-st-1] quit

4.     Configure an AP:

# Create an AP named ap2, and specify its model and the serial ID.

[AC2] wlan ap ap2 model WA4320i-ACN

[AC2-wlan-ap-ap2] serial-id 210235A1GQC14C000224

# Enter radio view of radio 1, and bind service template 1 to the radio.

[AC2-wlan-ap-ap2] radio 1

[AC2-wlan-ap-ap2-radio-1] service-template 1

# Enable radio 1.

[AC2-wlan-ap-ap2-radio-1] radio enable

[AC2-wlan-ap-ap2-radio-1] quit

[AC2-wlan-ap-ap2] quit

5.     Configure WLAN roaming:

# Create mobility group 1.

[AC2] wlan mobility group 1

# Set the source IP address for establishing IACTP tunnels to 192.1.0.3.

[AC2-wlan-mg-1] source ip 192.1.0.3

# Add AC 1 to the mobility group.

[AC2-wlan-mg-1] member ip 192.1.0.2

# Enable the mobility group.

[AC2-wlan-mg-1] group enable

[AC2-wlan-mg-1] quit

6.     Configure user isolation:

# Enable user isolation for VLAN 400.

[AC2] user-isolation vlan 400 enable

# Specify the MAC address of the gateway for VLAN 400 as a permitted MAC address for VLAN 400.

[AC2] user-isolation vlan 400 permit-mac 000f-eeee-1212

7.     Configure a default route:

# Configure a default route for AC 2. Set the next hop to 192.1.0.1.

[AC2] ip route-static 0.0.0.0 0.0.0.0 192.1.0.1

Configuring the switch

1.     Configure interfaces on the switch:

# Create VLAN 100 and VLAN-interface 100, and assign an IP address to the VLAN interface. The switch will use VLAN 100 to forward the traffic on CAPWAP tunnels between the AC and APs.

<Switch> system-view

[Switch] vlan 100

[Switch-vlan100] quit

[Switch] interface vlan-interface 100

[Switch-Vlan-interface100] ip address 192.1.0.1 16

[Switch-Vlan-interface100] quit

# Create VLAN 200 and VLAN-interface 200, and assign an IP address to the VLAN interface. The switch will use VLAN 200 to forward client traffic of AC 1.

[Switch] vlan 200

[Switch-vlan200] quit

[Switch] interface vlan-interface 200

[Switch-Vlan-interface200] ip address 192.2.0.1 16

[Switch-Vlan-interface200] quit

# Create VLAN 400 and VLAN-interface 400, and assign an IP address to the VLAN interface. The switch will use VLAN 400 to forward client traffic of AC 2.

[Switch] vlan 400

[Switch-vlan400] quit

[Switch] interface vlan-interface 400

[Switch-Vlan-interface400] ip address 192.4.0.1 16

[Switch-Vlan-interface400] quit

# Create VLAN 300 and VLAN-interface 300, and assign an IP address to the VLAN interface. The switch will use VLAN 300 to forward traffic to the RADIUS server.

[Switch] vlan 300

[Switch-vlan300] quit

[Switch] interface vlan-interface 300

[Switch-Vlan-interface300] ip address 192.3.0.1 16

[Switch-Vlan-interface300] quit

# Configure the interface that is connected to AC 1 as a trunk port, and assign the port to VLAN 100, VLAN 200, and VLAN 400.

[Switch] interface gigabitethernet 1/0/1

[Switch-GigabitEthernet1/0/1] port link-type trunk

[Switch-GigabitEthernet1/0/1] port trunk permit vlan 100 200 400

[Switch-GigabitEthernet1/0/1] quit

# Configure the interface that is connected to AC 2 as a trunk port, and assign the port to VLAN 100, VLAN 200, and VLAN 400.

[Switch] interface gigabitethernet 1/0/2

[Switch-GigabitEthernet1/0/2] port link-type trunk

[Switch-GigabitEthernet1/0/2] port trunk permit vlan 100 200 400

[Switch-GigabitEthernet1/0/2] quit

# Configure the interface that is connected to the RADIUS server as an access port, and assign the port to VLAN 300.

[Switch] interface gigabitethernet 1/0/3

[Switch-GigabitEthernet1/0/3] port link-type access

[Switch-GigabitEthernet1/0/3] port access vlan 300

[Switch-GigabitEthernet1/0/3] quit

2.     Configure the DHCP server:

# Enable the DHCP service.

[Switch] dhcp enable

# Create a DHCP address pool named vlan100 for the APs. Specify the 192.1.0.0/16 subnet for the pool and exclude IP addresses 192.1.0.2 and 192.1.0.3 from dynamic allocation. Set the gateway IP address to 192.1.0.1.

[Switch] dhcp server ip-pool vlan100

[Switch-dhcp-pool-vlan100] network 192.1.0.0 mask 255.255.0.0

[Switch-dhcp-pool-vlan100] forbidden-ip 192.1.0.2 192.1.0.3

[Switch-dhcp-pool-vlan100] gateway-list 192.1.0.1

[Switch-dhcp-pool-vlan100] quit

# Create a DHCP address pool named vlan200 for the clients. Specify the 192.2.0.0/16 subnet for the pool and exclude IP address 192.2.0.2 from dynamic allocation. Set the gateway IP address to 192.2.0.1 and specify the DNS server address. In this example, the gateway also acts as a DNS server.

[Switch] dhcp server ip-pool vlan200

[Switch-dhcp-pool-vlan200] network 192.2.0.0 mask 255.255.0.0

[Switch-dhcp-pool-vlan200] forbidden-ip 192.2.0.2

[Switch-dhcp-pool-vlan200] gateway-list 192.2.0.1

[Switch-dhcp-pool-vlan200] dns-list 192.2.0.1

[Switch-dhcp-pool-vlan200] quit

# Create a DHCP address pool named vlan400 for the clients. Specify the 192.4.0.0/16 subnet for the pool and exclude IP address 192.4.0.2 from dynamic allocation. Set the gateway IP address to 192.4.0.1 and specify the DNS server address. In this example, the gateway also acts as a DNS server.

[Switch] dhcp server ip-pool vlan400

[Switch-dhcp-pool-vlan400] network 192.4.0.0 mask 255.255.0.0

[Switch-dhcp-pool-vlan400] forbidden-ip 192.4.0.2

[Switch-dhcp-pool-vlan400] gateway-list 192.4.0.1

[Switch-dhcp-pool-vlan400] dns-list 192.4.0.1

[Switch-dhcp-pool-vlan400] quit

Configuring the RADIUS server

 

NOTE:

In this example, the RADIUS server runs on iMC PLAT 7.2 (E0403P06) and iMC EIA 7.2 (E0409).

 

1.     Add the ACs to the IMC Platform as access devices:

a.     Log in to IMC.

b.     Click the User tab.

c.     From the navigation tree, select User Access Policy > Access Device Management > Access Device.

d.     Click Add to add AC 1 as an access device.

e.     Configure the following parameters:

-     Enter 192.1.0.2 for AC 1 and 192.1.0.3 for AC 2 in the Device IP field.

-     Enter 12345678 in the Shared Key field.

-     Use the default settings for other parameters.

f.     Click OK.

g.     Use the same procedure to add AC 2 as an access device.

Figure 2 Adding an access device

 

2.     Add an access policy:

a.     Click the User tab.

b.     From the navigation tree, select User Access Policy > Access Policy.

c.     Click Add to add an access policy that uses the following settings:

-     Access Policy Namedot1x.

-     Preferred EAP TypeEAP-PEAP.

-     SubtypeEAP-MSCHAPv2. The subtype must match the client authentication method.

Figure 3 Adding an access policy

 

3.     Add an access service:

a.     Click the User tab.

b.     From the navigation tree, select User Access Policy > Access Service.

c.     Click Add to add an access service that uses the following settings:

-     Service Namedot1x.

-     Default Access Policydot1x.

Figure 4 Adding an access service

 

4.     Add an access user:

a.     Click the User tab.

b.     From the navigation tree, select All Access Users.

c.     Click Add to add an access user that uses the following settings:

-     User Nameuser.

-     Account Namedot1x.

-     Passworddot1x.

d.     Select the dot1x service for the user.

Figure 5 Adding an access user

 

Verifying the configuration

# Enable the client to come online from AP 1. (Details not shown.)

# On AC 1, verify that the client is associated with AP 1.

<AC1> display wlan client verbose

Total number of clients: 1

 

MAC address                       : 0015-00ba-0428

 IPv4 address                      : 138.200.0.1

 IPv6 address                      : N/A

 Username                          : wjh1x

 AID                               : 1

 AP ID                             : 1

 AP name                           : ap1

 Radio ID                          : 1

 SSID                              : service

 BSSID                             : 5866-ba71-3960

 VLAN ID                           : 200

 Sleep count                       : 0

 Wireless mode                     : 802.11ac

 Channel bandwidth                 : 40MHz

 SM power save                     : Disabled

 Short GI for 20MHz                : Supported

 Short GI for 40MHz                : Supported

 STBC RX capability                : Supported

 STBC TX capability                : Not supported

 LDPC RX capability                : Not supported

 Block Ack                         : N/A

 Supported HT MCS set              : 0, 1, 2, 3, 4, 5, 6, 7,

                                     8, 9, 10, 11, 12, 13, 14,

                                     15

 Supported rates                   : 6, 9, 12, 18, 24, 36,

                                     48, 54 Mbps

 QoS mode                          : WMM

 Listen interval                   : 250

 RSSI                              : 0

 Rx/Tx rate                        : 0/0

 Authentication method             : Open system

 Security mode                     : RSN

 AKM mode                          : 802.1X

 Cipher suite                      : CCMP

 User authentication mode          : 802.1X

 Authorization ACL ID              : N/A

 Authorization user profile        : N/A

 Roam status                       : N/A

 Key derivation                    : SHA1

 PMF status                        : N/A

 Forwarding policy name            : N/A

 Online time                       : 0days 0hours 0minutes 17seconds

 FT status                         : Inactive

# Enable the client to roam to AP 2.

# On AC 2, verify that the client is associated with AP 2.

<AC2> display wlan client verbose

Total number of clients: 1

 

MAC address                       : 0015-00ba-0428

 IPv4 address                      : 138.200.0.1

 IPv6 address                      : N/A

 Username                          : wjh1x

 AID                               : 1

 AP ID                             : 1

 AP name                           : ap2

 Radio ID                          : 1

 SSID                              : service

 BSSID                             : 5860-ba71-3960

 VLAN ID                           : 200

 Sleep count                       : 0

 Wireless mode                     : 802.11ac

 Channel bandwidth                 : 40MHz

 SM power save                     : Disabled

 Short GI for 20MHz                : Supported

 Short GI for 40MHz                : Supported

 STBC RX capability                : Supported

 STBC TX capability                : Not supported

 LDPC RX capability                : Not supported

 Block Ack                         : N/A

 Supported HT MCS set              : 0, 1, 2, 3, 4, 5, 6, 7,

                                     8, 9, 10, 11, 12, 13, 14,

                                     15

 Supported rates                   : 6, 9, 12, 18, 24, 36,

                                     48, 54 Mbps

 QoS mode                          : WMM

 Listen interval                   : 250

 RSSI                              : 0

 Rx/Tx rate                        : 0/0

 Authentication method             : Open system

 Security mode                     : RSN

 AKM mode                          : 802.1X

 Cipher suite                      : CCMP

 User authentication mode          : 802.1X

 Authorization ACL ID              : N/A

 Authorization user profile        : N/A

 Roam status                       : Inter-AC roam

 Key derivation                    : SHA1

 PMF status                        : N/A

 Forwarding policy name            : N/A

 Online time                       : 0days 0hours 0minutes 17seconds

 FT status                         : Inactive

# Verify that clients in VLAN 200 and VLAN 400 can access the Internet but cannot access a client in the same VLAN. (Details not shown.)

Configuration files

·     Switch:

#

dhcp enable

#

vlan 100

#

vlan 200

#

vlan 300

#

vlan 400

#

dhcp server ip-pool vlan100

 network 192.1.0.0 mask 255.255.0.0

 gateway-list 192.1.0.1

 forbidden-ip 192.1.0.2

 forbidden-ip 192.1.0.3

#

dhcp server ip-pool vlan200

 gateway-list 192.2.0.1

 network 192.2.0.0 mask 255.255.0.0

 dns-list 192.2.0.1

 forbidden-ip 192.2.0.2

#

dhcp server ip-pool vlan400

 gateway-list 192.4.0.1

 network 192.4.0.0 mask 255.255.0.0

 dns-list 192.4.0.1

 forbidden-ip 192.4.0.2

#

interface Vlan-interface100

 ip address 192.1.0.1 255.255.0.0

#

interface Vlan-interface200

 ip address 192.2.0.1 255.255.0.0

#

interface Vlan-interface300

 ip address 192.3.0.1 255.255.0.0

#

interface Vlan-interface400

 ip address 192.4.0.1 255.255.0.0

#

interface GigabitEthernet1/0/1

 port link-type trunk

 port trunk permit vlan 100 200 400

#

interface GigabitEthernet1/0/2

 port link-type trunk

 port trunk permit vlan 100 200 400

#

interface GigabitEthernet1/0/3

 port access vlan 300

#

·     AC 1:

#

dot1x authentication-method eap

#

vlan 100

#

vlan 200

#

vlan 400

#

wlan service-template 1

 ssid service

 vlan 200

 akm mode dot1x

 cipher-suite ccmp

 security-ie rsn

client-security authentication-mode dot1x

 dot1x domain office

 service-template enable

#

interface Vlan-interface100

 ip address 192.1.0.2 255.255.0.0

#

interface Vlan-interface200

 ip address 192.2.0.2 255.255.0.0

#

interface GigabitEthernet1/0/1

 port link-type trunk

 port trunk permit vlan 100 200 400

#

interface GigabitEthernet1/0/2

 port link-type access

 port access vlan 100

#

ip route-static 0.0.0.0 0.0.0.0 192.1.0.1

#

radius scheme office

 primary authentication 192.3.0.2

 primary accounting 192.3.0.2

 key authentication simple 12345678

 key accounting simple 12345678

 nas-ip 192.1.0.2

#

domain office

 authentication lan-access radius-scheme office

 authorization lan-access radius-scheme office

 accounting lan-access radius-scheme office

#

user-isolation vlan 200 enable

user-isolation vlan 200 permit-mac 000f-e212-7788

#

wlan ap ap1 model WA4320i-ACN

 serial-id 210235A1GQC14C000225

 radio 1

  radio enable

  service-template 1

 radio 2

#

wlan mobility group 1

 source ip 192.1.0.2

 member ip 192.1.0.3

 group enable

·     AC 2:

#

dot1x authentication-method eap

#

vlan 100

#

vlan 200

#

vlan 400

#

wlan service-template 1

 ssid service

 vlan 200

 akm mode dot1x

 cipher-suite ccmp

 security-ie rsn

 client-security authentication-mode dot1x

 dot1x domain office

 service-template enable

#

interface Vlan-interface100

 ip address 192.1.0.3 255.255.0.0

#

interface Vlan-interface400

 ip address 192.4.0.2 255.255.0.0

#

interface GigabitEthernet1/0/1

 port link-type trunk

 port trunk permit vlan 100 200 400

#

interface GigabitEthernet1/0/2

 port link-type access

 port access vlan 100

#

ip route-static 0.0.0.0 0.0.0.0 192.1.0.1

#

radius scheme office

primary authentication 192.3.0.2

 primary accounting 192.3.0.2

 key authentication simple 12345678

 key accounting simple 12345678

 nas-ip 192.1.0.3

#

domain office

 authentication lan-access radius-scheme office

 authorization lan-access radius-scheme office

 accounting lan-access radius-scheme office

#

user-isolation vlan 400 enable

user-isolation vlan 400 permit-mac 000f-eeee-1212

#

wlan ap ap1 model WA4320i-ACN

 serial-id 210235A1GQC14C000225

 radio 1

  radio enable

  service-template 1

 radio 2

#

wlan mobility group 1

 source ip 192.1.0.3

 member ip 192.1.0.2

 group enable

Related documentation

·     AP and WT Management Command Reference in H3C Access Controllers Command References

·     AP and WT Management Configuration Guide in H3C Access Controllers Configuration Guides

·     User Access and Authentication Command Reference in H3C Access Controllers Command References

·     User Access and Authentication Configuration Guide in H3C Access Controllers Configuration Guides

·     WLAN Access Command Reference in H3C Access Controllers Command References

·     WLAN Access Configuration Guide in H3C Access Controllers Configuration Guides

·     WLAN Roaming Command Reference in H3C Access Controllers Command References

·     WLAN Roaming Configuration Guide in H3C Access Controllers Configuration Guides