12-WLAN advanced features

HomeSupportResource CenterH3C Access Controllers Configuration Examples(V7)-6W10212-WLAN advanced features
06-WLAN Load Balancing Configuration Examples
Title Size Download
06-WLAN Load Balancing Configuration Examples 94.10 KB

 

H3C Access Controllers

Comware 7 WLAN Load Balancing

Configuration Examples

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Copyright © 2021 New H3C Technologies Co., Ltd. All rights reserved.

No part of this manual may be reproduced or transmitted in any form or by any means without prior written consent of New H3C Technologies Co., Ltd.

Except for the trademarks of New H3C Technologies Co., Ltd., any trademarks that may be mentioned in this document are the property of their respective owners.



Introduction

The following information provides a WLAN load balancing configuration example.

Prerequisites

The following information applies to Comware 7-based access controllers and access points. Procedures and information in the examples might be slightly different depending on the software or hardware version of the access controllers and access points.

The configuration examples were created and verified in a lab environment, and all the devices were started with the factory default configuration. When you are working on a live network, make sure you understand the potential impact of every command on your network.

The following information is provided based on the assumption that you have basic knowledge of WLAN load balancing.

Example: Configuring WLAN load balancing

Network requirements

As shown in Figure 1, the DHCP server assigns IP addresses to the APs and clients. AP 1 and AP 2 are managed by the AC and the clients can discover the APs.

Configure the AC to perform session-based load balancing on radio 2 of AP 1 and AP 2 when the following conditions are met:

·     The number of sessions on one radio reaches 2.

·     The session gap between the radios reaches 1.

Figure 1 Network diagram

 

Configuration restrictions and guidelines

When you configure WLAN load balancing, follow these restrictions and guidelines:

·     Bind the same service template to the relevant APs.

·     Configure the interface that the AC uses to connect to the network as a trunk port so the port can forward traffic from multiple VLANs.

·     Use the serial ID labeled on the AP's rear panel to specify an AP.

Configuration procedures

Configuring the AC

1.     Configure interfaces on the AC:

# Create VLAN 100 and VLAN-interface 100, and assign an IP address to the VLAN interface. The AC will use this IP address to establish CAPWAP tunnels with APs.

<AC> system-view

[AC] vlan 100

[AC-vlan100] quit

[AC] interface vlan-interface 100

[AC-Vlan-interface100] ip address 192.1.0.1 16

[AC-Vlan-interface100] quit

# Create VLAN 200 and VLAN-interface 200, and assign an IP address to the VLAN interface. The AC will use VLAN 200 for client access.

[AC] vlan 200

[AC-vlan200] quit

[AC] interface vlan-interface 200

[AC-Vlan-interface200] ip address 192.2.0.1 16

[AC-Vlan-interface200] quit

# Configure the interface that is connected to the switch as a trunk port, and assign the port to VLAN 100 and VLAN 200.

[AC] interface gigabitethernet 1/0/1

[AC-GigabitEthernet1/0/1] port link-type trunk

[AC-GigabitEthernet1/0/1] port trunk permit vlan 100 200

[AC-GigabitEthernet1/0/1] quit

2.     Configure the wireless service:

# Create wireless service template 1 and enter its view.

[AC] wlan service-template 1

# Set the SSID to service.

[AC-wlan-st-1] ssid service

# Assign clients coming online through service template 1 to VLAN 200.

[AC-wlan-st-1] vlan 200

# Enable service template 1.

[AC-wlan-st-1] service-template enable

[AC-wlan-st-1] quit

# Create AP officeap1, and specify its model and serial ID.

[AC] wlan ap officeap1 model WA4320i-ACN

[AC-wlan-ap-officeap1] serial-id 210235A1GQC152001076

# Bind service template 1 to radio 2 of the AP and enable radio 2.

[AC-wlan-ap-officeap1] radio 2

[AC-wlan-ap-officeap1-radio-2] service-template 1

[AC-wlan-ap-officeap1-radio-2] radio enable

[AC-wlan-ap-officeap1-radio-2] quit

[AC-wlan-ap-officeap1] quit

# Create AP officeap2, and specify its model and serial ID.

[AC] wlan ap officeap2 model WA4320i-ACN

[AC-wlan-ap-officeap2] serial-id 210235A1GQC152001078

# Bind service template 1 to radio 2 of the AP and enable radio 2.

[AC-wlan-ap-officeap2] radio 2

[AC-wlan-ap-officeap2-radio-2] service-template 1

[AC-wlan-ap-officeap2-radio-2] radio enable

[AC-wlan-ap-officeap2-radio-2] quit

[AC-wlan-ap-officeap2] quit

3.     Configure load balancing:

# Set the load balancing mode to session mode, and set the session threshold and session gap threshold to 2 and 1, respectively.

[AC] wlan load-balance mode session 2 gap 1

# Create load balancing group 1 and enter its view.

[AC] wlan load-balance-group 1

# Add radio 2 of AP 1 and AP 2 to load balancing group 1.

[AC-wlan-lb-group-1] ap name officeap1 radio 2

[AC-wlan-lb-group-1] ap name officeap2 radio 2

# Set the maximum number of denials to 5 for association requests.

[AC] wlan load-balance access-denial 5

# Enable WLAN load balancing.

[AC] wlan load-balance enable

Configuring the switch

# Create VLAN 100 and VLAN 200. The switch will use VLAN 100 to forward the traffic on CAPWAP tunnels between the AC and APs, and will use VLAN 200 to forward client traffic.

<Switch> system-view

[Switch] vlan 100

[Switch-vlan100] quit

[Switch] vlan 200

[Switch-vlan200] quit

# Configure the interface that is connected to the AC as a trunk port, and assign the port to VLAN 100 and VLAN 200.

[Switch] interface gigabitethernet 1/0/1

[Switch-GigabitEthernet1/0/1] port link-type trunk

[Switch-GigabitEthernet1/0/1] port trunk permit vlan 100 200

[Switch-GigabitEthernet1/0/1] quit

# Configure the interface that is connected to AP 1 as an access port, and assign the port to VLAN 100.

[Switch] interface gigabitethernet 1/0/2

[Switch-GigabitEthernet1/0/2] port link-type access

[Switch-GigabitEthernet1/0/2] port access vlan 100

# Enable PoE on GigabitEthernet 1/0/2.

[Switch-GigabitEthernet1/0/2] poe enable

[Switch-GigabitEthernet1/0/2] quit

# Configure the interface that is connected to AP 2 as an access port, and assign the port to VLAN 100.

[Switch] interface gigabitethernet 1/0/3

[Switch-GigabitEthernet1/0/3] port link-type access

[Switch-GigabitEthernet1/0/3] port access vlan 100

# Enable PoE on GigabitEthernet 1/0/3.

[Switch-GigabitEthernet1/0/3] poe enable

[Switch-GigabitEthernet1/0/3] quit

# Configure the interface that is connected to the DHCP server as a trunk port, and assign the port to VLAN 100 and VLAN 200.

[Switch] interface gigabitethernet 1/0/4

[Switch-GigabitEthernet1/0/4] port link-type trunk

[Switch-GigabitEthernet1/0/4] port trunk permit vlan 100 200

[Switch-GigabitEthernet1/0/4] quit

Verifying the configuration

# Verify that a third client associates with AP 2 when the number of sessions on either AP reaches 2 and the session gap between the APs reaches 1.

[AC] display wlan client

Total number of clients: 3

 

MAC address     Username   AP name         RID  IP address      IPv6 address   VLAN

0015-005c-8b2c  N/A        officeap1       2    192.2.0.3       N/A            200

109a-dd9f-aaa2  N/A        officeap2       2    192.2.0.5       N/A            200

2c1f-2332-7f78  N/A        officeap1       2    192.2.0.4       N/A            200

Configuration files

·     AC:

#

 wlan load-balance mode session 2 gap 1

 wlan load-balance enable

 wlan load-balance access-denial 5

#

vlan 100

#

vlan 200

#

wlan service-template 1

 ssid service

 vlan 200

 service-template enable

#

interface Vlan-interface100

 ip address 192.1.0.1 255.255.0.0

#

interface Vlan-interface200

 ip address 192.2.0.1 255.255.0.0

#

interface GigabitEthernet1/0/1

 port link-type trunk

 port trunk permit vlan 100 200

#

 

wlan ap officeap1 model WA4320i-ACN

 serial-id 210235A1GQC152001076

 radio 1

 radio 2

  service-template 1

  radio enable

#

wlan ap officeap2 model WA4320i-ACN

 serial-id 210235A1GQC152001078

 radio 1

 radio 2

  service-template 1

  radio enable

#

·     Switch:

#

vlan 100

#

vlan 200

#

interface GigabitEthernet1/0/1

 port link-mode bridge

 port link-type trunk

 port trunk permit vlan 100 200

#

interface GigabitEthernet1/0/2

 port access vlan 100

 poe enable

#

interface GigabitEthernet1/0/3

 port access vlan 100

 poe enable

#

interface GigabitEthernet1/0/4

 port link-type trunk

 port trunk permit vlan 100 200

#

Related documentation

·     Radio Resources Management Command Reference in H3C Access Controllers Command References

·     Radio Resources Management Configuration Guide in H3C Access Controllers Configuration Guides