10-Segment Routing配置指导

01-MPLS SR配置

本章节下载 01-MPLS SR配置  (597.48 KB)

docurl=/cn/Service/Document_Software/Document_Center/Routers/Catalog/SR_Router/SR8800-F/Configure/Operation_Manual/H3C_SR8800-F_CG-R7951PXX-6W102/10/202008/1323177_30005_0.htm

01-MPLS SR配置

目 

1 MPLS SR

1.1 MPLS SR简介

1.1.1 MPLS SR的特点

1.1.2 MPLS SR基本概念

1.1.3 MPLS SR运行机制

1.1.4 静态配置Segment

1.1.5 通过IGP协议动态分配SID

1.1.6 根据SID建立标签转发表项

1.1.7 建立SRLSP

1.1.8 MPLS SR报文转发过程

1.2 SR与LDP互通

1.2.1 SR over LDP

1.3 MPLS SR配置任务简介

1.3.1 SRLSP转发IP流量配置任务简介

1.3.2 MPLS TE隧道采用静态SRLSP转发流量配置任务简介

1.4 静态配置Segment

1.4.1 配置准备

1.4.2 配置静态Adjacency Segment

1.4.3 配置静态Prefix Segment

1.5 配置通过IGP扩展通告SID

1.5.1 通过IGP分配SID配置任务简介

1.5.2 配置准备

1.5.3 开启IGP支持MPLS SR功能

1.5.4 配置前缀SID

1.5.5 开启IGP邻接标签分配功能

1.5.6 配置基于MPLS的SRGB的标签范围

1.6 配置优先使用SRLSP转发流量

1.6.1 功能简介

1.6.2 配置限制和指导

1.6.3 配置优先使用IS-IS SR建立的SRLSP转发流量

1.6.4 配置优先使用OSPF SR建立的SRLSP转发流量

1.7 配置MPLS TE隧道采用静态SRLSP

1.7.1 MPLS TE隧道采用静态SRLSP配置任务简介

1.7.2 配置用于MPLS TE的静态SRLSP

1.7.3 配置MPLS TE隧道采用静态SRLSP

1.8 配置SR和LDP互通

1.8.1 SR和LDP互通配置限制和指导

1.8.2 SR over LDP配置任务简介

1.8.3 SR和LDP互通配置准备

1.9 MPLS SR显示和维护

1.10 MPLS SR典型配置举例

1.10.1 静态配置Segment配置举例

1.10.2 通过IS-IS通告SID配置举例

1.10.3 通过OSPF通告SID配置举例

1.10.4 MPLS SR over LDP网络互通配置举例

 


1 MPLS SR

1.1  MPLS SR简介

SR(Segment Routing,分段路由)采用源路径选择机制,预先在源节点封装好路径所要经过节点分配的SID(Segment Identifier,段标识),当报文经过SR节点时,该节点根据报文的SID对报文进行转发。除源节点外,其它节点无需维护路径状态。MPLS SR(Segment Routing with MPLS,MPLS段路由)是指在MPLS网络中使用SR、将标签作为SID对报文进行转发。

1.1.1  MPLS SR的特点

MPLS SR具有以下优点:

·     直接应用现有的MPLS框架进行转发,无需对网络进行改造。MPLS网络架构的详细介绍,请参见“MPLS配置指导”中的“MPLS基础”。

·     通过对现有的IGP协议进行扩展和优化,可以直接利用IGP协议来进行标签的分发。

·     能够更加简单地实现MPLS TE等网络功能,解决了现有网络为实现上述功能而带来的部署路由协议过多、部署过程复杂等问题。

1.1.2  MPLS SR基本概念

SR主要涉及如下概念:

·     SR节点:开启MPLS SR功能的设备通常被称为SR节点。其中,负责为进入MPLS SR网络的报文添加标签的入口节点称为源节点;负责剥离报文中标签、并将报文转发给目的网络的出口节点称为尾节点。

·     段:用来指明节点对入报文所执行的操作。

·     SID:段标识,在MPLS SR中为MPLS标签。

·     分段类型:根据SID分配形式不同,SR的分段类型有如下两种:

¡     Prefix Segment:前缀类型的段,按目的IP地址前缀为网络的节点分配SID并建立转发表项。

¡     Adjacency Segment:邻接类型的段,为节点的不同邻接链路分别分配SID。

·     SRLSP(Segment Routing Label Switched Path,基于段路由的LSP):以标签作为SID对报文进行段路由转发,报文所经过的路径称为SRLSP。

·     SRGB(Segment Routing Global Block,分段路由全局标签段):专门用于MPLS SR前缀类型SID(Prefix SID)的全局标签范围,各个节点的SRGB范围可以不同,SRGB的标签范围由标签段基值和Range确定,其中标签段基值表示SRGB标签段的最小值,Range表示标签数目。目前,MPLS为SRGB预留的标签段为16000~24000。

1.1.3  MPLS SR运行机制

要想通过SRLSP转发报文,需要完成以下工作:

(1)     进行标签分配,为报文转发路径中的每个节点和链路规划标签信息,可以使用静态配置Segment或者动态分配SID两种方式。

(2)     建立标签转发表项,运行MPLS SR的设备组成的分段路由域内的设备根据分配的标签信息形成本地的标签转发表项。

(3)     建立SRLSP,SRLSP可以手工配置,也可以通过IGP协议动态建立或通过控制器下发。

(4)     将MPLS TE隧道和SRLSP关联,以便MPLS TE隧道采用SRLSP进行报文转发。

完成上述步骤后,SRLSP即可用来转发流量。当源节点接收到用户网络的报文后,会为报文封装所经过路径上的标签信息,并通过SRLSP将报文转发给尾节点;尾节点从SRLSP接收到报文后,会剥离报文中的标签,根据原始报文的目的地址查找路由表进行报文转发。

如果将SRLSP与上层应用关联,如MPLS TE,则可以实现通过SRLSP来转发MPLS TE等流量。

1.1.4  静态配置Segment

静态配置Segment的方式为:

·     Prefix Segment:在每台SR节点上为目的IP地址前缀手工指定入标签、出标签和下一跳。

·     Adjacency Segment:在每台SR节点上为与邻接设备相连的链路手工指定入标签和下一跳对应关系。

1.1.5  通过IGP协议动态分配SID

对IGP协议(如IS-IS、OSPF)进行扩展后,可以在IGP协议报文中通告SID。动态分配和通告SID的方式为:

·     Prefix SID:每个SR节点均手工为自己的Loopback地址指定SID,该SID用来标识特定的SR节点。运行MPLS SR的设备组成的分段路由域内,通过IGP通告SR节点的Prefix SID,其他节点根据收到的报文自动计算到达该SR节点的Prefix SID。通告的形式有两种:

¡     通告绝对值:直接将Prefix SID和本地SRGB标签段通告出去;

¡     通告索引值:为每个SR节点分配一个全局唯一的Index,即每个SR节点的前缀与Index一一对应。通过IGP扩展通告各个SR节点的SRGB标签段和段内Index。SR节点的SRGB基值+前缀的Index即为该节点为该前缀分配的Prefix SID。

说明

目前,设备仅支持以索引值的形式进行Prefix SID的通告。

 

·     Adjacency SID:开启了Adjacency SID分配功能的SR节点为与IGP邻接设备连接的链路分配的SID,用来标识本地设备的特定邻接链路。

1.1.6  根据SID建立标签转发表项

1. 根据IGP Prefix SID建立标签转发表项

通过Prefix SID建立的标签转发表项可以分为:

·     静态标签转发表项:设备根据手工指定的入标签、出标签以及下一跳的对应关系形成本地的标签转发表项;

·     动态标签转发表项:设备通过IGP协议将本地SRGB和为本地Loopback接口地址分配的Prefix SID的索引值在分段路由域内进行泛洪。分段路由域内的其他设备根据收到的信息计算出本地的标签转发表项,入标签为本地SRGB标签段基值+Index,出标签为下一跳的SRGB基值+Index。

图1-1 根据IGP Prefix SID建立标签转发表项

 

图1-1所示,以动态分配Prefix SID为例。网络管理员将索引值201分配给Device C上的Loopback地址1.1.1.1/32。Device C通过IGP协议报文将该索引值以及本地SRGB通告出去。运行IGP SR的节点,形成的标签转发表项如下:

·     Device C上标签转发表项的入标签为18201;

·     Device B收到该通告后,形成SRLSP标签转发表项,入标签为17201,出标签为18201,下一跳为Device C;

·     Device A收到该通告后,形成SRLSP标签转发表项,入标签为16201,出标签为17201,下一跳为Device B。

2. 根据Adjacency SID建立标签转发表项

当采用Adjacency方式时,设备为与邻接设备相连的链路静态或动态分配入标签。该标签值只在本地有效,不同设备上的Adjacency SID可以相同。

图1-2 根据Adjacency SID建立标签转发表项

 

图1-2所示,设备之间运行IGP协议,当IGP邻居建立后,Device A为与Device B连接的链路分配的标签为203,Device B为与Device C连接的链路分配的标签为202,Device C为与Device D连接的链路分配的标签为201。各设备上形成的标签转发表项如下:

·     Device A形成标签转发表项的入标签203、下一跳为Device B;

·     Device B形成标签转发表项的入标签为202、下一跳为Device C;

·     Device C形成标签转发表项的入标签为201、下一跳为Device D。

1.1.7  建立SRLSP

SRLSP建立方式包括:

·     静态配置:根据转发路径需要,在隧道头节点上指定报文转发时携带的标签栈。标签栈中的每个标签对应一个Prefix SID或Adjacency SID,根据Prefix SID或Adjacency SID可以找到报文的出标签、下一跳等信息。

·     根据IGP协议动态建立:SR节点通过IGP协议搜集MPLS SR网络中的前缀SID信息,并根据该信息及IGP网络拓扑信息,计算出到达MPLS SR网络中各个SR节点的最短路径,并在该路径上建立SRLSP。

·     控制器下发:由控制器下发配置,在设备上创建SRLSP。该方式的详细介绍请参见控制器相关资料。

1.1.8  MPLS SR报文转发过程

根据SID分配方式的不同,MPLS SR报文转发过程主要分为以下几种:

·     Prefix方式:在源节点将为尾节点分配的Prefix SID封装到报文中,各中间节点查找标签转发表项进行转发。

·     Adjacency方式:在源节点将所有经过节点为邻接链路分配的Adjacency SID组成的标签栈封装到报文中,各中间节点根据标签栈最外层标签查找下一跳邻居,并在转发报文时删除标签栈最外层标签。

·     Prefix/Adjacency方式:采用Prefix和Adjacency组合方式进行报文转发。

1. Prefix方式同一AS内报文转发过程

图1-3所示,Device A通过SRLSP将报文转发到Device E时,需要为报文指定出标签为21201。Prefix方式报文转发过程如下:

(1)     在源节点Device A根据21201查找标签转发表项,判断该标签对应的下一跳为Device B,出标签为20201,Device A为报文封装标签20201,发送给中间节点Device B。

(2)     中间节点Device B的入标签为20201,出标签为19201,将20201替换为19201,发送给下一个中间节点Device C继续转发。

(3)     中间节点Device C及Device D的转发过程和Device B类似。

(4)     报文到达尾节点Device E后,Device E删除报文中的标签17201,按IP继续转发即可。

图1-3 Prefix方式同一AS内报文转发过程示意图

 

2. Adjacency方式报文转发过程

图1-4所示,Device A、Device B、Device C、Deivce D为链路分配的Adjacency SID分别为200、201、202、203。Device A通过SRLSP将报文转发到Device E时,需要为报文指定出标签栈为(200,201,202,203)。Adjacency方式报文转发过程如下:

(1)     在源节点Device A根据栈顶标签200查找标签转发表项,判断该标签对应的下一跳为Device B。Device A为报文封装标签栈(201,202,203)后,将该报文转发给Device B。

(2)     中间节点Device B接收到报文后,根据入标签201查找标签转发表项,判断该标签对应的下一跳为Device C。Device B删除标签栈最外层标签201后,发送给下一个中间节点Device C继续转发。

(3)     中间节点Device C接收到报文后,根据入标签202查找标签转发表项,判断该标签对应的下一跳为Device D。Device C删除标签栈最外层标签202后,发送给下一个中间节点Device D继续转发。

(4)     中间节点Device D接收到报文后,根据入标签203查找标签转发表项,判断该标签对应的下一跳为Device E。Device D删除标签栈最外层标签203后,发送给Device E继续转发。

(5)     Device E收到是一个IP报文,按IP转发即可。

图1-4 Adjacency方式报文转发过程示意图

 

3. Prefix/Adjacency组合方式报文转发过程

图1-5所示,Device C为本节点分配的Prefix SID索引值为1,Device A、Device B、Device C上对应的Prefix SID分别为18001、17001、16001,Device C、Device D为邻接链路分配的Adjacency SID分别为16、17,Device A通过SRLSP将报文转发到Device E时,需要为报文指定出标签栈为(18001,16,17)。

Adjacency/Prefix组合方式报文转发过程如下:

(1)     在源节点Device A根据18001查找标签转发表项,判断该标签对应的下一跳为Device B,出标签为17001,Device A为报文封装标签栈(17001,16,17),发送给中间节点Device B。

(2)     中间节点Device B前缀路径入标签为17001,出标签为16001,将17001替换为16001,发送给下一个中间节点Device C继续转发。

(3)     中间节点DeviceC前缀路径入标签16001,邻接路径入标签为16,删除标签栈最外层标签(16001,16)后,根据邻接路径将报文发送给下一个中间节点Device D继续转发。

(4)     中间节点Device D删除标签栈最外层标签17后,将报文发送给尾节点Device E,Device E收到是一个IP报文,按IP转发即可。

图1-5 Adjacency/Prefix组合方式报文转发过程示意图

 

1.2  SR与LDP互通

在MPLS SR和LDP共存的网路环境中,需要解决SR网络和LDP网络之间互通的问题。SR与LDP互通是一项让SR协议和LDP协议在同一网络中共同工作的技术。通过此技术可以让SR网络连接到LDP网络中,实现两个网络之间的MPLS转发。

SR与LDP互通的组网方式:SR over LDP,SR网络跨越LDP网络交互数据流量。

1.2.1  SR over LDP

SR网络需要跨越LDP网络交互数据,这种组网被称为SR over LDP。在SR over LDP组网环境下,需要边界设备将一个协议的无效出标签替换为另一个协议的有效出标签,完成标签的连接。SR over LDP组网主要包含如下两种情况:

·     MPLS SR到LDP标签连接:当MPLS SR出标签不存在时,如果存在有效的LDP出标签,则将LDP出标签作为SR出标签。

·     LDP到MPLS SR标签连接:当LDP出标签不存在时,如果存在有效的MPLS SR出标签,则将MPLS SR出标签作为LDP出标签。

图1-6 SR over LDP网络互通示意图

 

图1-6所示,Device A、Device B、Device D和Device E运行MPLS SR功能,网络管理员将索引值201分配给Device E上的Loopback地址3.3.3.3/32,Device E通过IGP协议报文将该索引值以及本地SRGB通告出去,Device A、Device B、Device D收到通告信息后,形成MPLS SR标签转发表;Device B、Device C和Device D运行LDP协议,为目的地址3.3.3.3/32分发标签,形成LDP标签转发表项。当Device A通过SRLSP将报文转发到Device E时,报文转发过程如下:

(2)     源节点Device A为报文封装标签18201,发送给中间节点Device B。

(3)     中间节点Device B根据报文的入标签18201,查找MPLS SR标签转发表项,发现出标签不存在,此时设备上存在关于目的地址3.3.3.3/32的有效LDP出标签20,将出标签20作为SR的出标签,发送报文给下一个中间节点Device C继续转发。

(4)     Device C收到报文后根据LDP标签转发表项将报文转发给下一跳Device D,出标签为30。

(5)     Device D收到报文后,根据报文的入标签30查找对应的LDP标签转发表项,发现出标签不存在,此时设备上存在关于目的地址3.3.3.3/32的有效MPLS SR出标签16201,将出标签16201作为LDP的出标签,发送报文给尾节点Device E。

(6)     报文到达尾节点Device E后,Device E删除报文中的标签16201,按IP继续转发即可。

1.3  MPLS SR配置任务简介

1.3.1  SRLSP转发IP流量配置任务简介

SRLSP转发IP流量配置任务如下:

(1)     配置Segment

请选择以下一项任务进行配置:

¡     静态配置Segment

¡     配置通过IGP扩展通告SID

(2)     (可选)配置优先使用SRLSP转发流量

(3)     (可选)配置SR和LDP互通

1.3.2  MPLS TE隧道采用静态SRLSP转发流量配置任务简介

MPLS TE隧道采用静态SRLSP转发流量配置任务如下:

(1)     配置Segment

请选择以下一项任务进行配置:

¡     静态配置Segment

¡     配置通过IGP扩展通告SID

(2)     配置MPLS TE隧道采用静态SRLSP

(3)     (可选)配置SR和LDP互通

1.4  静态配置Segment

1.4.1  配置准备

在静态配置Segment之前,需完成以下任务:

·     确定静态SRLSP的头节点、中间节点和尾节点。

·     规划每个节点到下一跳的邻接路径的入标签值,规划每个节点的前缀路径标签值。需要注意的是,静态SRLSP与静态LSP、静态CRLSP使用相同的标签空间,在同一台设备上静态SRLSP、静态CRLSP和静态LSP的入标签不能相同。关于CRLSP的介绍请参见“MPLS配置指导”中的“MPLS TE”。

·     在参与MPLS转发的各个节点和接口上开启MPLS能力,配置方法请参见“MPLS配置指导”中的“MPLS基础”。

1.4.2  配置静态Adjacency Segment

1. 配置限制和指导

如果指定下一跳IP地址,设备上必须存在到达该地址的路由且路由出接口上必须使能MPLS能力;如果指定出接口,该出接口必须处于UP状态并且能够接收到直连路由,且必须使能MPLS能力。

如果所指定的入标签与已经存在的静态LSP/静态PW/静态CRLSP的入标签相同,则会导致标签冲突,所配置的邻接路径不可用。即使修改静态LSP/静态PW/静态CRLSP的入标签,该邻接路径仍不可用,需要手工删除该邻接路径并重新配置。

本命令需要在静态SRLSP的所有节点上执行。

如果多条静态SRLSP存在公共路径,公共路径节点的邻接路径信息一致,不需要进行多次配置。

2. 配置步骤

(1)     进入系统视图。

system-view

(2)     配置静态Adjacency Segment

static-sr-mpls adjacency adjacency-path-name in-label label-value { nexthop ip-address | outgoing-interface interface-type interface-number }

指定的下一跳地址不能是本地设备上的公网IP地址。

1.4.3  配置静态Prefix Segment

1. 配置限制和指导

指定的下一跳或出接口必须与路由表中最优路由的下一跳或出接口保持一致,同一台设备上,如果最优路由有多个下一跳或者出接口,那么就能配置多个到该目的地址的前缀路径用于负载分担,但是需要注意的是到达同一目的地址前缀路径的名称、入标签值需要保持一致。

本命令需要在静态SRLSP的所有节点上执行。

执行undo static-sr-mpls prefix命令时,如果只配置了prefix-path-name参数,则将所有同名的前缀路径配置全部删除。如果携带了所有的关键字,则将匹配下一跳或出接口的配置删除。

如果多条静态SRLSP的目的地址相同,公共路径节点的前缀路径信息一致,不需要进行多次配置。

2. 配置步骤

(1)     进入系统视图。

system-view

(2)     配置静态Prefix Segment。

static-sr-mpls prefix prefix-path-name destination ip-address { mask-length | mask } in-label in-label-value [ { nexthop ip-address | outgoing-interface interface-type interface-number } out-label out-label-value ]

指定的下一跳地址不能是本地设备上的公网IP地址。

1.5  配置通过IGP扩展通告SID

1.5.1  通过IGP分配SID配置任务简介

在SRLSP可能经过的各节点上执行如下配置:

(1)     开启IGP支持MPLS SR功能

(2)     配置前缀SID或邻接链路的SID

请至少选择其中一项任务进行配置:

¡     配置前缀SID

¡     开启IGP邻接标签分配功能

(3)     配置基于MPLS的SRGB的标签范围

本配置仅适用于前缀SID。

1.5.2  配置准备

配置通过IGP扩展通告SID之前,需完成以下任务:

·     确定SRLSP的头节点、中间节点和尾节点。

·     规划每个节点的前缀SID索引值和SRGB标签范围。

·     在参与MPLS转发的各个节点和接口上开启MPLS能力,配置方法请参见“MPLS配置指导”中的“MPLS基础”。

1.5.3  开启IGP支持MPLS SR功能

1. 配置准备

开启IGP支持MPLS SR功能前,需进行以下配置,否则MPLS SR功能不会生效:

·     当IGP协议为IS-IS时,需确保IS-IS开销值的类型为wide、compatible或wide-compatible。关于IS-IS开销值类型的配置请参见“三层技术-IP路由配置指导”中的“IS-IS”。

·     当IGP协议为OSPF时,需使能OSPF的Opaque LSA发布接收能力。关于OSPF使能Opaque LSA发布接收能力的配置请参见“三层技术-IP路由配置指导”中的“OSPF”。

2. 配置IS-IS支持MPLS SR功能

(1)     进入系统视图。

system-view

(2)     进入IS-IS视图。

isis process-id

(3)     进入IS-IS IPv4单播地址族视图。

address-family ipv4

(4)     开启MPLS SR功能。

segment-routing mpls

缺省情况下,基于MPLS的SR功能处于关闭状态。

3. 配置OSPF支持MPLS SR功能

(1)     进入系统视图。

system-view

(2)     进入OSPF视图。

ospf process-id

(3)     开启MPLS SR功能。

segment-routing mpls

缺省情况下,基于MPLS的SR功能处于关闭状态。

1.5.4  配置前缀SID

1. 功能简介

通过在设备的Lookback接口下配置前缀SID,可以确定SID和IP前缀的绑定关系。前缀SID包含绝对值和索引值两种配置方式。

配置IS-IS前缀SID时,必须按照以下规则执行:

·     当配置前缀SID绝对值时,绝对值的取值即为前缀SID的值,该值必须在SRGB的范围内。

·     当配置前缀SID相对值时,相对值加上SRGB最小值的大小即为前缀SID的值,前缀SID的值必须在SRGB的范围内。

2. 配置限制和指导

在Anycast使用场景中,当需要使用同一个前缀SID标识一组SR节点时,需要通过指定n-flag-clear参数将Node-SID(前缀SID标志位,置位时,表示前缀SID为到达某一台SR节点的SID)标志位置为0。

配置前缀SID时,需注意以下三点:

·     当配置IS-IS SR前缀SID时,必须在Loopback接口上使能IS-IS进程。

·     当配置OSPF SR前缀SID时,必须保证Loopback接口上使能的OSPF进程和前缀SID关联的进程一致,否则配置不会生效。

·     对于绑定了VPN实例的LoopBack接口,不支持指定explicit-null参数。

3. 配置IS-IS SR前缀SID

(1)     进入系统视图。

system-view

(2)     进入Loopback接口视图。

interface loopback interface-number

(3)     配置前缀SID。

isis prefix-sid { absolute absolute-value | index index-value } [ n-flag-clear | { explicit-null | no-php } ] *

缺省情况下,未配置IS-IS前缀SID。

4. 配置OSPF SR前缀SID

(1)     进入系统视图。

system-view

(2)     进入Loopback接口视图。

interface loopback interface-number

(3)     配置前缀SID。

ospf process-id prefix-sid { absolute absolute-value | index index-value } [ n-flag-clear ] [ explicit-null ]

缺省情况下,未配置OSPF前缀SID。

1.5.5  开启IGP邻接标签分配功能

1. 配置限制和指导

开启邻接标签分配功能时,需确保MPLS SR处于开启状态,否则该功能不会生效。

2. 配置IS-IS SR邻接标签分配功能

(1)     进入系统视图。

system-view

(2)     进入IS-IS视图。

isis process-id

(3)     进入IPv4单播地址族视图。

address-family ipv4

(4)     开启邻接标签分配功能。

segment-routing adjacency enable

缺省情况下,基于MPLS的SR邻接标签分配功能处于关闭状态。

3. 配置OSPF SR邻接标签分配功能

(1)     进入系统视图。

system-view

(2)     进入OSPF视图。

ospf process-id

(3)     开启邻接标签分配功能。

segment-routing adjacency enable

缺省情况下,基于MPLS的SR邻接标签分配功能处于关闭状态。

1.5.6  配置基于MPLS的SRGB的标签范围

1. 配置限制和指导

配置SRGB的范围时,若已配置前缀SID,需确保配置的SRGB标签范围包含已配置的前缀SID值,否则SRGB配置失败。

MPLS为SRGB预留的标签范围为16000~24000,配置的SRGB值必须在本范围内。

2. 配置IS-IS SR的SRGB的标签范围

(1)     进入系统视图。

system-view

(2)     进入IS-IS视图。

isis process-id

(3)     配置基于MPLS的SRGB的标签范围。

segment-routing global-block minivalue maxivalue

缺省情况下,基于MPLS的SRGB的最小标签值为16000,最大标签值为24000。

3. 配置OSPF SR的SRGB的标签范围

(1)     进入系统视图。

system-view

(2)     进入OSPF视图。

ospf process-id

(3)     配置基于MPLS的SRGB的标签范围。

segment-routing global-block minivalue maxivalue

缺省情况下,基于MPLS的SRGB的最小标签值为16000,最大标签值为24000。

1.6  配置优先使用SRLSP转发流量

1.6.1  功能简介

当到达同一目的网络同时存在SRLSP和LDP LSP两种标签转发路径时,设备优先使用LDP LSP转发流量。通过配置本功能,可以指定转发到达该目的网络的流量时优先使用SRLSP路径。

1.6.2  配置限制和指导

配置本功能时,请开启MPLS SR功能,并确保SRLSP路径标签为前缀SID。

1.6.3  配置优先使用IS-IS SR建立的SRLSP转发流量

(1)     进入系统视图。

system-view

(2)     进入IS-IS视图。

isis process-id

(3)     配置优先使用SRLSP转发流量。

segment-routing sr-prefer [ prefix-list prefix-list-name ]

缺省情况下,设备优先使用LDP LSP转发流量。

1.6.4  配置优先使用OSPF SR建立的SRLSP转发流量

(1)     进入系统视图。

system-view

(2)     进入OSPF视图。

ospf process-id

(3)     配置优先使用SRLSP转发流量。

segment-routing sr-prefer [ prefix-list prefix-list-name ]

缺省情况下,设备优先使用LDP LSP转发流量。

1.7  配置MPLS TE隧道采用静态SRLSP

1.7.1  MPLS TE隧道采用静态SRLSP配置任务简介

(1)     开启MPLS TE能力

在MPLS TE隧道经过的所有节点上执行本配置,配置方法请参见“MPLS配置指导”中的“MPLS TE”。

(2)     配置用于MPLS TE的静态SRLSP

在MPLS TE隧道的头节点上执行本配置。

(3)     创建Tunnel接口,并指定隧道的目的端地址

在MPLS TE隧道的头节点上执行本配置,配置方法请参见“MPLS配置指导”中的“MPLS TE”。

(4)     配置MPLS TE隧道采用静态SRLSP

在MPLS TE隧道的头节点上执行本配置。

(5)     配置静态路由或策略路由,将流量引入MPLS TE隧道。

在MPLS TE隧道的头节点执行本配置,配置方法请参见“MPLS配置指导”中的“MPLS TE”。

1.7.2  配置用于MPLS TE的静态SRLSP

(1)     进入系统视图。

system-view

(2)     配置用于MPLS TE隧道的静态SRLSP。

static-sr-mpls lsp lsp-name out-label out-label-value&<1-14>

1.7.3  配置MPLS TE隧道采用静态SRLSP

(1)     进入系统视图。

system-view

(2)     进入模式为MPLS TE隧道的Tunnel接口视图。

interface tunnel tunnel-number [ mode mpls-te ]

(3)     配置使用静态方式建立MPLS TE隧道。

mpls te signaling static

缺省情况下,MPLS TE使用RSVP-TE信令协议建立隧道。

本命令的详细介绍,请参见“MPLS命令参考”中的“MPLS TE”。

(4)     指定隧道引用的SRLSP。

mpls te static-sr-mpls lsp-name [ backup ]

缺省情况下,隧道没有引用任何静态SRLSP。

MPLS TE隧道所引用的静态SRLSP,必须已经通过static-sr-mpls lsp命令创建。

只有当主用和备用SRLSP均采用Adjacency方式建立时,才允许通过指定backup参数配置隧道引用备用SRLSP。

1.8  配置SR和LDP互通

1.8.1  SR和LDP互通配置限制和指导

配置MPLS SR和LDP互通时,需要确保SRLSP的路径标签为前缀SID。

1.8.2  SR over LDP配置任务简介

SR over LDP配置任务如下:

(1)     开启IGP支持MPLS SR功能

(2)     配置前缀SID

(3)     配置基于MPLS的SRGB的标签范围

1.8.3  SR和LDP互通配置准备

配置SR和LDP互通之前,需完成以下任务:

·     确定SRLSP的头节点、中间节点和尾节点。

·     规划每个节点的前缀SID索引值和SRGB标签范围。

·     在参与MPLS转发的各个节点和接口上开启MPLS能力,配置方法请参见“MPLS配置指导”中的“MPLS基础”。

1.9  MPLS SR显示和维护

在完成上述配置后,在任意视图下执行display命令可以显示配置MPLS SR后的运行情况,用户可以通过查看显示信息验证配置的效果。

表1-1 MPLS SR显示和维护

操作

命令

显示基于IS-IS SR邻接段信息

display isis segment-routing adjacency [ process-id ]

显示IS-IS SR的全局标签段信息

display isis segment-routing global-block [ level-1 | level-2 ] [ process-id ]

显示静态SRLSP信息或静态配置的邻接段信息

display mpls static-sr-lsp { lsp [ lsp-name ] | adjacency [ adjacency-path-name ] }

显示静态配置的前缀段信息

display mpls static-sr-mpls prefix [ path lsp-name | destination ip-address [ mask | mask-length ] ]

显示OSPF SR的全局标签段信息

display ospf [ process-id ] [ area area-id ] segment-routing global-block

 

1.10  MPLS SR典型配置举例

1.10.1  静态配置Segment配置举例

1. 组网需求

·     设备Router A、Router B、Router C、Router D和Router E运行IS-IS。

·     使用静态SRLSP建立一条Router A到Router D的MPLS TE隧道,实现两个IP网络通过MPLS TE隧道传输数据流量。静态SRLSP经过三个段,#1段:Router A到Router B的邻接段,#2段:Router B到Router C的邻接段,#3段:Router C到Router D的邻接段。

·     使用静态SRLSP建立一条Router A到Router E的MPLS TE隧道,实现两个IP网络通过MPLS TE隧道传输数据流量。静态SRLSP经过三个段,#1段:Router A到Router B的邻接段,#2段:Router B到Router C的前缀段,#3段:Router C到Router E的邻接段。

2. 组网图

图1-7 静态配置Segment组网图

 

设备

接口

IP地址

设备

接口

IP地址

Router A

Loop0

1.1.1.9/32

Router B

Loop0

2.2.2.9/32

 

GE3/1/1

100.1.1.1/24

 

GE3/1/1

10.1.1.2/24

 

GE3/1/2

10.1.1.1/24

 

GE3/1/2

20.1.1.1/24

 

 

 

 

GE3/1/3

60.1.1.1/24

Router C

Loop0

3.3.3.9/32

Router D

Loop0

4.4.4.9/32

 

GE3/1/1

30.1.1.1/24

 

GE3/1/1

100.1.2.1/24

 

GE3/1/2

20.1.1.2/24

 

GE3/1/2

30.1.1.2/24

 

GE3/1/3

50.1.1.1/24

 

 

 

 

GE3/1/4

60.1.1.2/24

 

 

 

Router E

Loop0

5.5.5.9/32

 

 

 

 

GE3/1/1

200.1.2.1/24

 

 

 

 

GE3/1/2

50.1.1.2/24

 

 

 

 

3. 配置步骤

(1)     配置各接口的IP地址

按照图1-7配置各接口的IP地址和掩码,具体配置过程略。

(2)     配置IS-IS协议发布接口所在网段的路由,包括Loopback接口,具体配置过程略。

配置完成后,在各设备上执行display ip routing-table命令,可以看到相互之间都学到了到对方的路由,包括Loopback接口对应的主机路由。

(3)     配置LSR ID、开启MPLS能力和MPLS TE能力

# 配置Router A。

<RouterA> system-view

[RouterA] mpls lsr-id 1.1.1.9

[RouterA] mpls te

[RouterA-te] quit

[RouterA] interface gigabitethernet 3/1/2

[RouterA-GigabitEthernet3/1/2] mpls enable

[RouterA-GigabitEthernet3/1/2] quit

# 配置Router B。

<RouterB> system-view

[RouterB] mpls lsr-id 2.2.2.9

[RouterB] mpls te

[RouterB-te] quit

[RouterB] interface gigabitethernet 3/1/1

[RouterB-GigabitEthernet3/1/1] mpls enable

[RouterB-GigabitEthernet3/1/1] quit

[RouterB] interface gigabitethernet 3/1/2

[RouterB-GigabitEthernet3/1/2] mpls enable

[RouterB-GigabitEthernet3/1/2] quit

[RouterB] interface gigabitethernet 3/1/3

[RouterB-GigabitEthernet3/1/3] mpls enable

[RouterB-GigabitEthernet3/1/3] quit

# 配置Router C。

<RouterC> system-view

[RouterC] mpls lsr-id 3.3.3.9

[RouterC] mpls te

[RouterC-te] quit

[RouterC] interface gigabitethernet 3/1/1

[RouterC-GigabitEthernet3/1/1] mpls enable

[RouterC-GigabitEthernet3/1/1] quit

[RouterC] interface gigabitethernet 3/1/2

[RouterC-GigabitEthernet3/1/2] mpls enable

[RouterC-GigabitEthernet3/1/2] quit

[RouterC] interface gigabitethernet 3/1/3

[RouterC-GigabitEthernet3/1/3] mpls enable

[RouterC-GigabitEthernet3/1/3] quit

[RouterC] interface gigabitethernet 3/1/4

[RouterC-GigabitEthernet3/1/4] mpls enable

[RouterC-GigabitEthernet3/1/4] quit

# 配置Router D。

<RouterD> system-view

[RouterD] mpls lsr-id 4.4.4.9

[RouterD] mpls te

[RouterD-te] quit

[RouterD] interface gigabitethernet 3/1/2

[RouterD-GigabitEthernet3/1/2] mpls enable

[RouterD-GigabitEthernet3/1/2] quit

# 配置Router E。

<RouterE> system-view

[RouterE] mpls lsr-id 5.5.5.9

[RouterE] mpls te

[RouterE-te] quit

[RouterE] interface gigabitethernet 3/1/2

[RouterE-GigabitEthernet3/1/2] mpls enable

[RouterE-GigabitEthernet3/1/2] quit

(4)     配置节点的邻接路径标签和前缀路径标签

# 配置Router A的邻接标签,为下一跳地址10.1.1.2绑定标签16。

[RouterA] static-sr-mpls adjacency adjacency-1 in-label 16 nexthop 10.1.1.2

# 配置Router B的邻接标签,为下一跳地址20.1.1.2绑定标签21。

[RouterB] static-sr-mpls adjacency adjacency-2 in-label 21 nexthop 20.1.1.2

# 配置Router B的前缀标签,为下一跳地址20.1.1.2、60.1.1.2绑定相同的前缀路径名称、入标签16000、出标签16001,在Router B和Router C之间形成负载分担。

[RouterB] static-sr-mpls prefix prefix-1 destination 5.5.5.9 32 in-label 16000 nexthop 20.1.1.2 out-label 16001

[RouterB] static-sr-mpls prefix prefix-1 destination 5.5.5.9 32 in-label 16000 nexthop 60.1.1.2 out-label 16001

# 配置Router C的邻接标签,为下一跳地址30.1.1.2、50.1.1.2分别绑定标签30、31。

[RouterC] static-sr-mpls adjacency adjacency-1 in-label 30 nexthop 30.1.1.2

[RouterC] static-sr-mpls adjacency adjacency-2 in-label 31 nexthop 50.1.1.2

# 配置Router C的前缀标签,为目的地址5.5.5.9绑定标签16001。

[RouterC] static-sr-mpls prefix prefix-1 destination 5.5.5.9 32 in-label 16001

(5)     创建静态SRLSP

# 配置Router A为静态SRLSP的头节点,static-sr-lsp-1出标签栈为[16,21,30],建立到Router D的静态SRLSP。

[RouterA] static-sr-mpls lsp static-sr-lsp-1 out-label 16 21 30

# 配置Router A为静态SRLSP的头节点,static-sr-lsp-2的出标签栈为[16,16000,31]建立到Router E的静态SRLSP。

[RouterA] static-sr-mpls lsp static-sr-lsp-2 out-label 16 16000 31

(6)     配置MPLS TE隧道

# 在Router A上配置到Router D的MPLS TE隧道Tunnel1:目的地址为Router D的LSR ID(4.4.4.9);采用静态SRLSP建立MPLS TE隧道,引用的SRLSP为static-sr-lsp-1。

[RouterA] interface tunnel 1 mode mpls-te

[RouterA-Tunnel1] ip address 6.1.1.1 255.255.255.0

[RouterA-Tunnel1] destination 4.4.4.9

[RouterA-Tunnel1] mpls te signaling static

[RouterA-Tunnel1] mpls te static-sr-mpls static-sr-lsp-1

[RouterA-Tunnel1] quit

# 在Router A上配置到Router E的MPLS TE隧道Tunnel2:目的地址为Router E的LSR ID(5.5.5.9);采用静态SRLSP建立MPLS TE隧道,引用的SRLSP为static-sr-lsp-2。

[RouterA] interface tunnel 2 mode mpls-te

[RouterA-Tunnel2] ip address 7.1.1.1 255.255.255.0

[RouterA-Tunnel2] destination 5.5.5.9

[RouterA-Tunnel2] mpls te signaling static

[RouterA-Tunnel2] mpls te static-sr-mpls static-sr-lsp-2

[RouterA-Tunnel2] quit

(7)     配置静态路由使流量沿MPLS TE隧道转发

# 在Router A上配置静态路由,使得到达网络100.1.2.0/24的流量通过MPLS TE隧道接口Tunnel1转发,到达网络200.1.2.0/24的流量通过MPLS TE隧道接口Tunnel2转发。

[RouterA] ip route-static 100.1.2.0 24 tunnel 1 preference 1

[RouterA] ip route-static 200.1.2.0 24 tunnel 2 preference 1

4. 验证配置

# 在Router A上执行display mpls te tunnel-interface命令,可以看到MPLS TE隧道的建立情况。

[RouterA] display mpls te tunnel-interface

Tunnel Name            : Tunnel 1

Tunnel State           : Up (Main CRLSP up)

Tunnel Attributes      :

  LSP ID               : 1               Tunnel ID            : 0

  Admin State          : Normal

  Ingress LSR ID       : 1.1.1.9         Egress LSR ID        : 4.4.4.9

  Signaling            : Static          Static CRLSP Name    : -

  Static SRLSP Name    : static-sr-lsp-1/-

  Resv Style           : -

  Tunnel mode          : -

  Reverse-LSP name     : -

  Reverse-LSP LSR ID   : -               Reverse-LSP Tunnel ID: -

  Class Type           : -               Tunnel Bandwidth     : -

  Reserved Bandwidth   : -

  Setup Priority       : 0               Holding Priority     : 0

  Affinity Attr/Mask   : -/-

  Explicit Path        : -

  Backup Explicit Path : -

  Metric Type          : TE

  Record Route         : -               Record Label         : -

  FRR Flag             : -               Backup Bandwidth Flag: -

  Backup Bandwidth Flag: -               Backup Bandwidth Type: -

  Backup Bandwidth     : -

  Bypass Tunnel        : -               Auto Created         : -

  Route Pinning        : -

  Retry Limit          : 3               Retry Interval       : 2 sec

  Reoptimization       : -               Reoptimization Freq  : -

  Backup Type          : -               Backup LSP ID        : -

  Auto Bandwidth       : -               Auto Bandwidth Freq  : -

  Min Bandwidth        : -               Max Bandwidth        : -

  Collected Bandwidth  : -

 

Tunnel Name            : Tunnel 2

Tunnel State           : Up (Main CRLSP up)

Tunnel Attributes      :

  LSP ID               : 1               Tunnel ID            : 1

  Admin State          : Normal

  Ingress LSR ID       : 1.1.1.9         Egress LSR ID        : 5.5.5.9

  Signaling            : Static          Static CRLSP Name    : -

  Static SRLSP Name    : static-sr-lsp-2/-

  Resv Style           : -

  Tunnel mode          : -

  Reverse-LSP name     : -

  Reverse-LSP LSR ID   : -               Reverse-LSP Tunnel ID: -

  Class Type           : -               Tunnel Bandwidth     : -

  Reserved Bandwidth   : -

  Setup Priority       : 0               Holding Priority     : 0

  Affinity Attr/Mask   : -/-

  Explicit Path        : -

  Backup Explicit Path : -

  Metric Type          : TE

  Record Route         : -               Record Label         : -

  FRR Flag             : -               Bandwidth Protection : -

  Backup Bandwidth Flag: -               Backup Bandwidth Type: -

  Backup Bandwidth     : -

  Bypass Tunnel        : -               Auto Created         : -

  Route Pinning        : -

  Retry Limit          : 3               Retry Interval       : 2 sec

  Reoptimization       : -               Reoptimization Freq  : -

  Backup Type          : -               Backup LSP ID        : -

  Auto Bandwidth       : -               Auto Bandwidth Freq  : -

  Min Bandwidth        : -               Max Bandwidth        : -

  Collected Bandwidth  : -

# 在各设备上执行display mpls lspdisplay mpls static-sr-lsp命令,可以看到静态SRLSP的建立情况。

[RouterA] display mpls lsp

FEC                         Proto       In/Out Label    Out Inter/NHLFE/LSINDEX

1.1.1.9/0/46565             StaticCR    -/21            GE3/1/2

                                        30  

1.1.1.9/1/46565             StaticCR    -/16000         GE3/1/2

                                        31

-                           StaticCR    16/-            GE3/1/2

10.1.1.2                    Local       -/-             GE3/1/2

Tunnel0                     Local       -/-             NHLFE1

Tunnel1                     Local       -/-             NHLFE2

[RouterB] display mpls lsp

FEC                         Proto       In/Out Label    Out Inter/NHLFE/LSINDEX

5.5.5.9/32                  StaticCR    16000/16001     GE3/1/2

5.5.5.9/32                  StaticCR    16000/16001     GE3/1/3

-                           StaticCR    21/-            GE3/1/2

20.1.1.2                    Local       -/-             GE3/1/2

60.1.1.2                    Local       -/-             GE3/1/3

[RouterC] display mpls lsp

FEC                         Proto       In/Out Label    Out Inter/NHLFE/LSINDEX

5.5.5.9/32                  StaticCR    16001/-         -

-                           StaticCR    30/-            GE3/1/1

-                           StaticCR    31/-            GE3/1/3

30.1.1.2                    Local       -/-             GE3/1/1

50.1.1.2                    Local       -/-             GE3/1/3

1.10.2  通过IS-IS通告SID配置举例

1. 组网需求

·     设备Router A、Router B、Router C、Router D运行IS-IS实现互通。

·     在设备的Loopback接口地址之间采用动态方式分配SID,并根据分配的SID建立从Router A到Router D的SRLSP,MPLS TE隧道通过该SRLSP转发流量。

2. 组网图

图1-8 通过IS-IS通告SID组网图

 

设备

接口

IP地址

设备

接口

IP地址

Router A

Loop1

1.1.1.1/32

Router B

Loop1

2.2.2.2/32

 

GE3/1/1

10.0.0.1/24

 

GE3/1/1

10.0.0.2/24

 

 

 

 

GE3/1/2

11.0.0.1/24

Router C

Loop1

3.3.3.3/32

Router D

Loop1

4.4.4.4/32

 

GE3/1/1

11.0.0.2/24

 

GE3/1/1

12.0.0.2/24

 

GE3/1/2

12.0.0.1/24

 

GE3/1/2

100.1.2.1/24

 

3. 配置步骤

(1)     请按照图1-8配置各接口的IP地址和子网掩码,具体配置过程略

(2)     配置IS-IS协议实现网络层互通,开销值类型wide

# 配置Router A。

<RouterA> system-view

[RouterA] isis 1

[RouterA-isis-1] network-entity 00.0000.0000.0001.00

[RouterA-isis-1] cost-style wide

[RouterA-isis-1] quit

[RouterA] interface gigabitethernet 3/1/1

[RouterA-GigabitEthernet3/1/1] isis enable 1

[RouterA-GigabitEthernet3/1/1] quit

[RouterA] interface loopback 1

[RouterA-LoopBack1] isis enable 1

[RouterA-LoopBack1] quit

# 配置Router B。

<RouterB> system-view

[RouterB] isis 1

[RouterB-isis-1] network-entity 00.0000.0000.0002.00

[RouterB-isis-1] cost-style wide

[RouterB-isis-1] quit

[RouterB] interface gigabitethernet 3/1/1

[RouterB-GigabitEthernet3/1/1] isis enable 1

[RouterB-GigabitEthernet3/1/1] quit

[RouterB] interface gigabitethernet 3/1/2

[RouterB-GigabitEthernet3/1/2] isis enable 1

[RouterB-GigabitEthernet3/1/2] quit

[RouterB] interface loopback 1

[RouterB-LoopBack1] isis enable 1

[RouterB-LoopBack1] quit

# 配置Router C。

<RouterC> system-view

[RouterC] isis 1

[RouterC-isis-1] network-entity 00.0000.0000.0003.00

[RouterC-isis-1] cost-style wide

[RouterC-isis-1] quit

[RouterC] interface gigabitethernet 3/1/1

[RouterC-GigabitEthernet3/1/1] isis enable 1

[RouterC-GigabitEthernet3/1/1] quit

[RouterC] interface gigabitethernet 3/1/2

[RouterC-GigabitEthernet3/1/2] isis enable 1

[RouterC-GigabitEthernet3/1/2] quit

[RouterC] interface loopback 1

[RouterC-LoopBack1] isis enable 1

[RouterC-LoopBack1] quit

# 配置Router D。

<RouterD> system-view

[RouterD] isis 1

[RouterD-isis-1] network-entity 00.0000.0000.0004.00

[RouterD-isis-1] cost-style wide

[RouterD-isis-1] quit

[RouterD] interface gigabitethernet 3/1/1

[RouterD-GigabitEthernet3/1/1] isis enable 1

[RouterD-GigabitEthernet3/1/1] quit

[RouterD] interface gigabitethernet 3/1/2

[RouterD-GigabitEthernet3/1/2] isis enable 1

[RouterD-GigabitEthernet3/1/2] quit

[RouterD] interface loopback 1

[RouterD-LoopBack1] isis enable 1

[RouterD-LoopBack1] quit

(3)     配置节点的MPLS LSR ID、开启MPLS能力和MPLS TE能力

# 配置Router A。

[RouterA] mpls lsr-id 1.1.1.1

[RouterA] mpls te

[RouterA-te] quit

[RouterA] interface gigabitethernet 3/1/1

[RouterA-GigabitEthernet3/1/1] mpls enable

[RouterA-GigabitEthernet3/1/1] quit

# 配置Router B。

[RouterB] mpls lsr-id 2.2.2.2

[RouterB] mpls te

[RouterB-te] quit

[RouterB] interface gigabitethernet 3/1/1

[RouterB-GigabitEthernet3/1/1] mpls enable

[RouterB-GigabitEthernet3/1/1] quit

[RouterB] interface gigabitethernet 3/1/2

[RouterB-GigabitEthernet3/1/2] mpls enable

[RouterB-GigabitEthernet3/1/2] quit

# 配置Router C。

[RouterC] mpls lsr-id 3.3.3.3

[RouterC] mpls te

[RouterC-te] quit

[RouterC] interface gigabitethernet 3/1/1

[RouterC-GigabitEthernet3/1/1] mpls enable

[RouterC-GigabitEthernet3/1/1] quit

[RouterC] interface gigabitethernet 3/1/2

[RouterC-GigabitEthernet3/1/2] mpls enable

[RouterC-GigabitEthernet3/1/2] quit

# 配置Router D。

[RouterD] mpls lsr-id 4.4.4.4

[RouterD] mpls te

[RouterD-te] quit

[RouterD] interface gigabitethernet 3/1/1

[RouterD-GigabitEthernet3/1/1] mpls enable

[RouterD-GigabitEthernet3/1/1] quit

(4)     配置IS-IS SR的SRGB,同时在IS-IS IPv4单播地址族视图下开启MPLS SR功能。

# 配置Router A。

[RouterA] isis 1

[RouterA-isis-1] segment-routing global-block 16000 16999

[RouterA-isis-1] address-family ipv4

[RouterA-isis-1-ipv4] segment-routing mpls

[RouterA-isis-1-ipv4] quit

[RouterA-isis-1] quit

# 配置Router B。

[RouterB] isis 1

[RouterB-isis-1] segment-routing global-block 17000 17999

[RouterB-isis-1] address-family ipv4

[RouterB-isis-1-ipv4] segment-routing mpls

[RouterB-isis-1-ipv4] quit

[RouterB-isis-1] quit

# 配置Router C。

[RouterC] isis 1

[RouterC-isis-1] segment-routing global-block 18000 18999

[RouterC-isis-1] address-family ipv4

[RouterC-isis-1-ipv4] segment-routing mpls

[RouterC-isis-1-ipv4] quit

[RouterC-isis-1] quit

# 配置Router D。

[RouterD] isis 1

[RouterD-isis-1] segment-routing global-block 19000 19999

[RouterD-isis-1] address-family ipv4

[RouterD-isis-1-ipv4] segment-routing mpls

[RouterD-isis-1-ipv4] quit

[RouterD-isis-1] quit

(5)     配置各设备的前缀SID索引。

# 配置Router A。

[RouterA] interface loopback 1

[RouterA-LoopBack1] isis prefix-sid index 10

# 配置Router B。

[RouterB] interface loopback 1

[RouterB-LoopBack1] isis prefix-sid index 20

# 配置Router C。

[RouterC] interface loopback 1

[RouterC-LoopBack1] isis prefix-sid index 30

# 配置Router D。

[RouterD] interface loopback 1

[RouterD-LoopBack1] isis prefix-sid index 40

(6)     配置MPLS TE隧道

# 配置用于MPLS TE隧道的静态SRLSP,出标签为源节点Router A为尾节点Router D分配的前缀标签16040。

[RouterA] static-sr-mpls lsp static-sr-lsp-1 out-label 16040

# 在Router A上配置到Router D的MPLS TE隧道Tunnel1:目的地址为Router D的LoopBack口地址4.4.4.4;同时,配置Tunnel1引用静态SRLSP。

[RouterA] interface tunnel 1 mode mpls-te

[RouterA-Tunnel1] ip address 6.1.1.1 255.255.255.0

[RouterA-Tunnel1] destination 4.4.4.4

[RouterA-Tunnel1] mpls te signaling static

[RouterA-Tunnel1] mpls te static-sr-mpls static-sr-lsp-1

[RouterA-Tunnel1] quit

(7)     配置静态路由使流量沿MPLS TE隧道转发

# 在Router A上配置静态路由,使得到达网络100.1.2.0/24的流量通过MPLS TE隧道接口Tunnel1转发。

[RouterA] ip route-static 100.1.2.0 24 tunnel 1 preference 1

4. 验证配置

# 在Router A上执行display isis可以看到IS-IS的配置情况。

[RouterA] display isis

 

           IS-IS(1) Protocol Information

 

Network entity                  : 00.0000.0000.0001.00

IS level                        : level-1

Cost style                      : Wide

Fast reroute                    : Disabled

Preference                      : 15

LSP length receive              : 1497

LSP length originate

    level-1                     : 1497

Maximum imported routes         : 100000

Timers

    LSP-max-age                 : 1200

    LSP-refresh                 : 900

    SPF mode                    : Normal

    SPF intervals               : 5 50 200

Segment routing

    MPLS                        : Enabled

    Adjacency                   : Disabled

    global block                : 16000 16999

# 在Router A上执行display isis interface verbose可以看到Loopback接口上的SID配置情况。

[RouterA] display isis interface verbose

 

                       Interface information for IS-IS(1)

                       ----------------------------------

  Interface:  LoopBack1

  Index     IPv4 state      IPv6 state     Circuit ID   MTU   Type   DIS

  00002     Up              Down           1            1536  L1/L2  --

  SNPA address                     : 0000-0000-0000

  IP address                       : 1.1.1.1

  Secondary IP address(es)         :

  IPv6 link-local address          :

  Extended circuit ID              : 2

  CSNP timer value                 : L1        10  L2        10

  Hello timer value                :           10

  Hello multiplier value           :            3

  LSP timer value                  : L12       33

  LSP transmit-throttle count      : L12        5

  Cost                             : L1         0  L2         0

  IPv6 cost                        : L1         0  L2         0

  Priority                         : L1        64  L2        64

  Retransmit timer value           : L12        5

  MPLS TE status                   : L1  Disabled  L2  Disabled

  IPv4 BFD                         : Disabled

  IPv6 BFD                         : Disabled

  IPv4 FRR LFA backup              : Enabled

  IPv6 FRR LFA backup              : Enabled

  IPv4 prefix suppression          : Disabled

  IPv6 prefix suppression          : Disabled

  IPv4 tag                         : 0

  IPv6 tag                         : 0

  Prefix-SID type                  : Index

  Value                            : 10

  Prefix-SID validity              : Valid

# 在Router A上执行display isis segment-routing global-block可以查看全网的SRGB信息。

[RouterA] display isis segment-routing global-block

 

             Segment routing global block information for IS-IS(1)

             -----------------------------------------------------

 

                                  Level-1 SRGB

                                  ------------

 

System ID                          Base                Range

-------------------------------------------------------------------------------

0000.0000.0001                     16000               1000

0000.0000.0002                     17000               1000

0000.0000.0003                     18000               1000

0000.0000.0004                     19000               1000

# 在Router A上执行display isis route verbose可以查看绑定标签的路由信息。

[RouterA] display isis route verbose

 

                         Route information for IS-IS(1)

                         ------------------------------

 

                         Level-1 IPv4 Forwarding Table

                         -----------------------------

 

 IPv4 Dest : 10.0.0.0/24         Int. Cost  : 10               Ext. Cost  : NULL

 Admin Tag : -                   Src Count  : 2                Flag       : D/L/-

 InLabel   : 4294967295          InLabel Flag: -/-/-/-/-/-

 NextHop   :                     Interface  :                  ExitIndex  :

    Direct                             GE3/1/1                    0x00000102

 Nib ID    : 0x0                 OutLabel   : 4294967295       OutLabelFlag: -

 

 IPv4 Dest : 11.0.0.0/24         Int. Cost  : 20               Ext. Cost  : NULL

 Admin Tag : -                   Src Count  : 2                Flag       : R/-/-

 InLabel   : 4294967295          InLabel Flag: -/-/-/-/-/-

 NextHop   :                     Interface  :                  ExitIndex  :

    10.0.0.2                           GE3/1/1                    0x00000102

 Nib ID    : 0x14000004          OutLabel   : 4294967295       OutLabelFlag: -

 

 IPv4 Dest : 12.0.0.0/24         Int. Cost  : 30               Ext. Cost  : NULL

 Admin Tag : -                   Src Count  : 2                Flag       : R/-/-

 InLabel   : 4294967295          InLabel Flag: -/-/-/-/-/-

 NextHop   :                     Interface  :                  ExitIndex  :

    10.0.0.2                           GE3/1/1                    0x00000102

 Nib ID    : 0x14000004          OutLabel   : 4294967295       OutLabelFlag: -

 

 IPv4 Dest : 1.1.1.1/32          Int. Cost  : 0                Ext. Cost  : NULL

 Admin Tag : -                   Src Count  : 1                Flag       : D/L/-

 InLabel   : 16010               InLabel Flag: -/N/-/-/-/-

 NextHop   :                     Interface  :                  ExitIndex  :

    Direct                             Loop1                      0x00000584

 Nib ID    : 0x0                 OutLabel   : 4294967295       OutLabelFlag: -

 

 IPv4 Dest : 2.2.2.2/32          Int. Cost  : 10               Ext. Cost  : NULL

 Admin Tag : -                   Src Count  : 1                Flag       : R/-/-

 InLabel   : 16020               InLabel Flag: -/N/-/-/-/-

 NextHop   :                     Interface  :                  ExitIndex  :

    10.0.0.2                           GE3/1/1                    0x00000102

 Nib ID    : 0x14000003          OutLabel   : 17020            OutLabelFlag: I

 

 IPv4 Dest : 3.3.3.3/32          Int. Cost  : 20               Ext. Cost  : NULL

 Admin Tag : -                   Src Count  : 1                Flag       : R/-/-

 InLabel   : 16030               InLabel Flag: -/N/-/-/-/-

 NextHop   :                     Interface  :                  ExitIndex  :

    10.0.0.2                           GE3/1/1                    0x00000102

 Nib ID    : 0x14000002          OutLabel   : 17030            OutLabelFlag: -

 

 IPv4 Dest : 4.4.4.4/32          Int. Cost  : 20               Ext. Cost  : NULL

 Admin Tag : -                   Src Count  : 1                Flag       : R/-/-

 InLabel   : 16040               InLabel Flag: -/N/-/-/-/-

 NextHop   :                     Interface  :                  ExitIndex  :

    10.0.0.2                           GE3/1/1                    0x00000102

 Nib ID    : 0x14000002          OutLabel   : 17040            OutLabelFlag: -

 

      Flags: D-Direct, R-Added to Rib, L-Advertised in LSPs, U-Up/Down Bit Set

 

      InLabel flags: R-Readvertisement, N-Node SID, P-no PHP

                     E-Explicit null, V-Value, L-Local

 

      OutLabelFlags: E-Explicit null, I-Implicit null, N-Normal

# 在Router A上执行display mpls lsp可以看到MPLS标签转发路径信息。

[RouterA] display mpls lsp

FEC                         Proto     In/Out Label    Out Inter/NHLFE/LSINDEX

10.0.0.2                    Local     -/-             GE3/1/1

1.1.1.1/32                  ISIS      16010/-         -

2.2.2.2/32                  ISIS      16020/3         GE3/1/1

2.2.2.2/32                  ISIS      -/3             GE3/1/1

3.3.3.3/32                  ISIS      16030/17030     GE3/1/1

3.3.3.3/32                  ISIS      -/17030         GE3/1/1

4.4.4.4/32                  ISIS      16040/17040     GE3/1/1

4.4.4.4/32                  ISIS      -/17040         GE3/1/1

1.10.3  通过OSPF通告SID配置举例

1. 组网需求

·     设备Router A、Router B、Router C、Router D运行OSPF实现互通。

·     在设备的Loopback接口地址之间采用动态方式分配SID,并根据分配的SID建立从Router A到Router D的SRLSP,MPLS TE隧道通过该SRLSP转发流量。

2. 组网图

图1-9 通过OSPF通告SID组网图

 

设备

接口

IP地址

设备

接口

IP地址

Router A

Loop1

1.1.1.1/32

Router B

Loop1

2.2.2.2/32

 

GE3/1/1

10.0.0.1/24

 

GE3/1/1

10.0.0.2/24

 

 

 

 

GE3/1/2

11.0.0.1/24

Router C

Loop1

3.3.3.3/32

Router D

Loop1

4.4.4.4/32

 

GE3/1/1

11.0.0.2/24

 

GE3/1/1

12.0.0.2/24

 

GE3/1/2

12.0.0.1/24

 

GE3/1/2

100.1.2.1/24

 

3. 配置步骤

(1)     请按照图1-9配置各接口的IP地址和子网掩码,具体配置过程略

(2)     配置OSPF协议实现网络层互通

# 配置Router A。

<RouterA> system-view

[RouterA] ospf 1 router-id 1.1.1.1

[RouterA-ospf-1] quit

[RouterA] interface gigabitethernet 3/1/1

[RouterA-GigabitEthernet3/1/1] ospf 1 area 0

[RouterA-GigabitEthernet3/1/1] quit

[RouterA] interface loopback 1

[RouterA-LoopBack1] ospf 1 area 0

[RouterA-LoopBack1] quit

# 配置Router B。

<RouterB> system-view

[RouterB] ospf 1 router-id 2.2.2.2

[RouterB-ospf-1] quit

[RouterB] interface gigabitethernet 3/1/1

[RouterB-GigabitEthernet3/1/1] ospf 1 area 0

[RouterB-GigabitEthernet3/1/1] quit

[RouterB] interface gigabitethernet 3/1/2

[RouterB-GigabitEthernet3/1/2] ospf 1 area 0

[RouterB-GigabitEthernet3/1/2] quit

[RouterB] interface loopback 1

[RouterB-LoopBack1] ospf 1 area 0

[RouterB-LoopBack1] quit

# 配置Router C。

<RouterC> system-view

[RouterC] ospf 1 router-id 3.3.3.3

[RouterC-ospf-1] quit

[RouterC] interface gigabitethernet 3/1/1

[RouterC-GigabitEthernet3/1/1] ospf 1 area 0

[RouterC-GigabitEthernet3/1/1] quit

[RouterC] interface gigabitethernet 3/1/2

[RouterC-GigabitEthernet3/1/2] ospf 1 area 0

[RouterC-GigabitEthernet3/1/2] quit

[RouterC] interface loopback 1

[RouterC-LoopBack1] ospf 1 area 0

[RouterC-LoopBack1] quit

# 配置Router D。

<RouterD> system-view

[RouterD] ospf 1 router-id 4.4.4.4

[RouterD-ospf-1] quit

[RouterD] interface gigabitethernet 3/1/1

[RouterD-GigabitEthernet3/1/1] ospf 1 area 0

[RouterD-GigabitEthernet3/1/1] quit

[RouterD] interface gigabitethernet 3/1/2

[RouterD-GigabitEthernet3/1/2] ospf 1 area 0

[RouterD-GigabitEthernet3/1/2] quit

[RouterD] interface loopback 1

[RouterD-LoopBack1] ospf 1 area 0

[RouterD-LoopBack1] quit

(3)     配置节点的MPLS LSR ID、开启MPLS能力和MPLS TE能力

# 配置Router A。

[RouterA] mpls lsr-id 1.1.1.1

[RouterA] mpls te

[RouterA-te] quit

[RouterA] interface gigabitethernet 3/1/1

[RouterA-GigabitEthernet3/1/1] mpls enable

[RouterA-GigabitEthernet3/1/1] quit

# 配置Router B。

[RouterB] mpls lsr-id 2.2.2.2

[RouterB] mpls te

[RouterB-te] quit

[RouterB] interface gigabitethernet 3/1/1

[RouterB-GigabitEthernet3/1/1] mpls enable

[RouterB-GigabitEthernet3/1/1] quit

[RouterB] interface gigabitethernet 3/1/2

[RouterB-GigabitEthernet3/1/2] mpls enable

[RouterB-GigabitEthernet3/1/2] quit

# 配置Router C。

[RouterC] mpls lsr-id 3.3.3.3

[RouterC] mpls te

[RouterC-te] quit

[RouterC] interface gigabitethernet 3/1/1

[RouterC-GigabitEthernet3/1/1] mpls enable

[RouterC-GigabitEthernet3/1/1] quit

[RouterC] interface gigabitethernet 3/1/2

[RouterC-GigabitEthernet3/1/2] mpls enable

[RouterC-GigabitEthernet3/1/2] quit

# 配置Router D。

[RouterD] mpls lsr-id 4.4.4.4

[RouterD] mpls te

[RouterD-te] quit

[RouterD] interface gigabitethernet 3/1/1

[RouterD-GigabitEthernet3/1/1] mpls enable

[RouterD-GigabitEthernet3/1/1] quit

(4)     配置OSPF SR的SRGB,同时在OSPF视图下开启MPLS SR功能

# 配置Router A。

[RouterA] ospf 1

[RouterA-ospf-1] segment-routing global-block 16000 16999

[RouterA-ospf-1] segment-routing mpls

[RouterA-ospf-1] quit

# 配置Router B。

[RouterB] ospf 1

[RouterB-ospf-1] segment-routing global-block 17000 17999

[RouterB-ospf-1] segment-routing mpls

[RouterB-ospf-1] quit

# 配置Router C。

[RouterC] ospf 1

[RouterC-ospf-1] segment-routing global-block 18000 18999

[RouterC-ospf-1] segment-routing mpls

[RouterC-ospf-1] quit

# 配置Router D。

[RouterD] ospf 1

[RouterD-ospf-1] segment-routing global-block 19000 19999

[RouterD-ospf-1] segment-routing mpls

[RouterD-ospf-1] quit

(5)     配置各设备的前缀SID索引

# 配置Router A。

[RouterA] interface loopback 1

[RouterA-LoopBack1] ospf 1 prefix-sid index 10

[RouterA-LoopBack1] quit

# 配置Router B。

[RouterB] interface loopback 1

[RouterB-LoopBack1] ospf 1 prefix-sid index 20

# 配置Router C。

[RouterC] interface loopback 1

[RouterC-LoopBack1] ospf 1 prefix-sid index 30

# 配置Router D。

[RouterD] interface loopback 1

[RouterD-LoopBack1] ospf 1 prefix-sid index 40

(6)     配置MPLS TE隧道

# 配置用于MPLS TE隧道的静态SRLSP,出标签为源节点Router A为尾节点Router D分配的前缀标签16040。

[RouterA] static-sr-mpls lsp static-sr-lsp-1 out-label 16040

# 在Router A上配置到Router D的MPLS TE隧道Tunnel1:目的地址为Router D的LoopBack口地址4.4.4.4;同时,配置Tunnel1引用静态SRLSP。

[RouterA] interface tunnel 1 mode mpls-te

[RouterA-Tunnel1] ip address 6.1.1.1 255.255.255.0

[RouterA-Tunnel1] destination 4.4.4.4

[RouterA-Tunnel1] mpls te signaling static

[RouterA-Tunnel1] mpls te static-sr-mpls static-sr-lsp-1

[RouterA-Tunnel1] quit

(7)     配置静态路由使流量沿MPLS TE隧道转发

# 在Router A上配置静态路由,使得到达网络100.1.2.0/24的流量通过MPLS TE隧道接口Tunnel1转发。

[RouterA] ip route-static 100.1.2.0 24 tunnel 1 preference 1

4. 验证配置

# 在Router A上查看OSPF的配置情况和Loopback接口上的SID配置情况。

[RouterA] display ospf

 

          OSPF Process 1 with Router ID 1.1.1.1

                  OSPF Protocol Information

 

 RouterID: 1.1.1.1          Router type:

 Route tag: 0

 Multi-VPN-Instance is not enabled

 Ext-community type: Domain ID 0x5, Route Type 0x306, Router ID 0x107

 Domain ID: 0.0.0.0

 Opaque capable

 ISPF is enabled

 SPF-schedule-interval: 5 50 200

 LSA generation interval: 5 50 200

 LSA arrival interval: 1000 500 500

 Transmit pacing: Interval: 20 Count: 3

 Default ASE parameters: Metric: 1 Tag: 1 Type: 2

 Route preference: 10

 ASE route preference: 150

 SPF calculation count: 16

 RFC 1583 compatible

 Graceful restart interval: 120

 SNMP trap rate limit interval: 10  Count: 7

 Area count: 1   NSSA area count: 0

 ExChange/Loading neighbors: 0

 MPLS segment routing: Enabled

   Segment routing adjacency    : Disabled

   Segment routing global block: 16000  16999

 

 Area: 0.0.0.0          (MPLS TE  not enabled)

 Authentication type: None    Area flag: Normal

 SPF scheduled count: 4

 ExChange/Loading neighbors: 0

 

 Interface: 10.0.0.1 (GigabitEthernet3/1/1)

 Cost: 1       State: DR        Type: Broadcast    MTU: 1500

 Priority: 1

 Designated router: 10.0.0.1

 Backup designated router: 10.0.0.2

 Timers: Hello 10, Dead 40, Poll 40, Retransmit 5, Transmit Delay 1

 FRR backup: Enabled

 Enabled by interface configuration (including secondary IP addresses)

 

 Interface: 1.1.1.1 (LoopBack1)

 Cost: 0       State: Loopback    Type: PTP       MTU: 1536

 Timers: Hello 10, Dead 40, Poll 40, Retransmit 5, Transmit Delay 1

 FRR backup: Enabled

 Enabled by interface configuration (including secondary IP addresses)

 Prefix-SID type: Index

   Value: 20

   Process ID: ospf 1

   Prefix-SID validity: Valid

# 在Router A上查看全网的SRGB信息。

[RouterA] display ospf segment-routing global-block

         OSPF Process 1 with Router ID 1.1.1.1

             Segment Routing Global Block

 

                    Area: 0.0.0.0

 Router ID       Min SID         Max SID         Total

 4.4.4.4         19000           19999           1000

 3.3.3.3         18000           18999           1000

 2.2.2.2         17000           17999           1000

 1.1.1.1         16000           16999           1000

# 在Router A上查看绑定标签的路由信息。

[RouterA] display ospf routing verbose

 

          OSPF Process 1 with Router ID 1.1.1.1

                   Routing Table

 

                 Topology base (MTID 0)

 

 Routing for network

 

 Destination: 11.0.0.0/24

    Priority: Low                     Type: Transit

   AdvRouter: 3.3.3.3                 Area: 0.0.0.0

  SubProtoID: 0x1               Preference: 10

     NextHop: 10.0.0.2           BkNextHop: N/A

      IfType: Broadcast           BkIfType: N/A

   Interface: GE3/1/1          BkInterface: N/A

       NibID: 0x13000005            Status: Normal

        Cost: 2

     InLabel: 4294967295

    OutLabel: 4294967295     OutLabel flag: N

 

 Destination: 10.0.0.0/24

    Priority: Low                     Type: Transit

   AdvRouter: 1.1.1.1                 Area: 0.0.0.0

  SubProtoID: 0x1               Preference: 10

     NextHop: 0.0.0.0            BkNextHop: N/A

      IfType: Broadcast           BkIfType: N/A

   Interface: GE3/1/1          BkInterface: N/A

       NibID: 0x13000001            Status: Direct

        Cost: 1

     InLabel: 4294967295

    OutLabel: 4294967295     OutLabel flag: N

 

 Destination: 4.4.4.4/32

    Priority: Medium                  Type: Stub

   AdvRouter: 4.4.4.4                 Area: 0.0.0.0

  SubProtoID: 0x1               Preference: 10

     NextHop: 10.0.0.2           BkNextHop: N/A

      IfType: Broadcast           BkIfType: N/A

   Interface: GE3/1/1          BkInterface: N/A

       NibID: 0x13000005            Status: Normal

        Cost: 2

     InLabel: 16040

    OutLabel: 17040          OutLabel flag: N

 

 Destination: 3.3.3.3/32

    Priority: Medium                  Type: Stub

   AdvRouter: 3.3.3.3                 Area: 0.0.0.0

  SubProtoID: 0x1               Preference: 10

     NextHop: 10.0.0.2           BkNextHop: N/A

      IfType: Broadcast           BkIfType: N/A

   Interface: GE13/1/1          BkInterface: N/A

       NibID: 0x13000005            Status: Normal

        Cost: 2

     InLabel: 16030

    OutLabel: 17030          OutLabel flag: N

 

 Destination: 2.2.2.2/32

    Priority: Medium                  Type: Stub

   AdvRouter: 2.2.2.2                 Area: 0.0.0.0

  SubProtoID: 0x1               Preference: 10

     NextHop: 10.0.0.2           BkNextHop: N/A

      IfType: Broadcast           BkIfType: N/A

   Interface: GE3/1/1          BkInterface: N/A

       NibID: 0x13000005            Status: Normal

        Cost: 1

     InLabel: 16020

    OutLabel: 17020          OutLabel flag: N

 

 Destination: 1.1.1.1/32

    Priority: Medium                  Type: Stub

   AdvRouter: 1.1.1.1                 Area: 0.0.0.0

  SubProtoID: 0x1               Preference: 10

     NextHop: 0.0.0.0            BkNextHop: N/A

      IfType: PTP                 BkIfType: N/A

   Interface: Loop1            BkInterface: N/A

       NibID: 0x13000002            Status: Direct

        Cost: 0

     InLabel: 16010

    OutLabel: 4294967295     OutLabel flag: N

 

 Total nets: 6

 Intra area: 6  Inter area: 0  ASE: 0  NSSA: 0

# 在Router A上查看MPLS标签转发路径信息。

[RouterA] display mpls lsp

FEC                         Proto     In/Out Label    Out Inter/NHLFE/LSINDEX

10.0.0.2                    Local     -/-             GE3/1/1

1.1.1.1/32                  OSPF      16010/-         -

2.2.2.2/32                  OSPF      16020/3         GE3/1/1

2.2.2.2/32                  OSPF      -/3             GE3/1/1

3.3.3.3/32                  OSPF      16030/17030     GE3/1/1

3.3.3.3/32                  OSPF      -/17030         GE3/1/1

4.4.4.4/32                  OSPF      16040/17040     GE3/1/1

4.4.4.4/32                  OSPF      -/17040         GE3/1/1

1.10.4  MPLS SR over LDP网络互通配置举例

1. 组网需求

·     设备Router A、Router B、Router C、Router D和Router E运行IS-IS实现互通。

·     设备Router B、Router C、Router D均配置LDP;Router A、Router B、Router D和Router E配置IS-IS SR功能。

·     当Router A通过SRLSP将流量转发给Router E时,需要在Router B和Router D上完成MPLS SR和LDP标签的连接。

2. 组网图

图1-10 MPLS SR over LDP网络互通组网图

 

设备

接口

IP地址

设备

接口

IP地址

Router A

Loop1

1.1.1.1/32

Router B

Loop1

2.2.2.2/32

 

GE3/1/1

10.0.0.1/24

 

GE3/1/1

10.0.0.2/24

Router C

Loop1

3.3.3.3/32

 

GE3/1/2

11.0.0.1/24

 

GE3/1/1

11.0.0.2/24

Router D

Loop1

4.4.4.4/32

 

GE3/1/2

12.0.0.1/24

 

GE3/1/1

12.0.0.2/24

Router E

Loop1

5.5.5.5/32

 

GE3/1/2

13.0.0.1/24

 

GE3/1/1

13.0.0.2/24

 

 

 

 

3. 配置步骤

(1)     请按照图1-10配置各接口的IP地址和子网掩码,具体配置过程略

(2)     配置IS-IS协议实现网络层互通,开销值类型为wide

# 配置Router A。

<RouterA> system-view

[RouterA] isis 1

[RouterA-isis-1] network-entity 00.0000.0000.0001.00

[RouterA-isis-1] cost-style wide

[RouterA-isis-1] quit

[RouterA] interface gigabitethernet 3/1/1

[RouterA-GigabitEthernet3/1/1] isis enable 1

[RouterA-GigabitEthernet3/1/1] quit

[RouterA] interface loopback 1

[RouterA-LoopBack1] isis enable 1

[RouterA-LoopBack1] quit

# 配置Router B。

<RouterB> system-view

[RouterB] isis 1

[RouterB-isis-1] network-entity 00.0000.0000.0002.00

[RouterB-isis-1] cost-style wide

[RouterB-isis-1] quit

[RouterB] interface gigabitethernet 3/1/1

[RouterB-GigabitEthernet3/1/1] isis enable 1

[RouterB-GigabitEthernet3/1/1] quit

[RouterB] interface gigabitethernet 3/1/2

[RouterB-GigabitEthernet3/1/2] isis enable 1

[RouterB-GigabitEthernet3/1/2] quit

[RouterB] interface loopback 1

[RouterB-LoopBack1] isis enable 1

[RouterB-LoopBack1] quit

# 配置Router C。

<RouterC> system-view

[RouterC] isis 1

[RouterC-isis-1] network-entity 00.0000.0000.0003.00

[RouterC-isis-1] cost-style wide

[RouterC-isis-1] quit

[RouterC] interface gigabitethernet 3/1/1

[RouterC-GigabitEthernet3/1/1] isis enable 1

[RouterC-GigabitEthernet3/1/1] quit

[RouterC] interface gigabitethernet 3/1/2

[RouterC-GigabitEthernet3/1/2] isis enable 1

[RouterC-GigabitEthernet3/1/2] quit

[RouterC] interface loopback 1

[RouterC-LoopBack1] isis enable 1

[RouterC-LoopBack1] quit

# 配置Router D。

<RouterD> system-view

[RouterD] isis 1

[RouterD-isis-1] network-entity 00.0000.0000.0004.00

[RouterD-isis-1] cost-style wide

[RouterD-isis-1] quit

[RouterD] interface gigabitethernet 3/1/1

[RouterD-GigabitEthernet3/1/1] isis enable 1

[RouterD-GigabitEthernet3/1/1] quit

[RouterD] interface gigabitethernet 3/1/2

[RouterD-GigabitEthernet3/1/2] isis enable 1

[RouterD-GigabitEthernet3/1/2] quit

[RouterD] interface loopback 1

[RouterD-LoopBack1] isis enable 1

[RouterD-LoopBack1] quit

# 配置Router E。

<RouterE> system-view

[RouterE] isis 1

[RouterE-isis-1] network-entity 00.0000.0000.0005.00

[RouterE-isis-1] cost-style wide

[RouterE-isis-1] quit

[RouterE] interface gigabitethernet 3/1/1

[RouterE-GigabitEthernet3/1/1] isis enable 1

[RouterE-GigabitEthernet3/1/1] quit

[RouterE] interface loopback 1

[RouterE-LoopBack1] isis enable 1

[RouterE-LoopBack1] quit

(3)     配置节点的MPLS LSR ID

# 配置Router A。

[RouterA] mpls lsr-id 1.1.1.1

# 配置Router B。

[RouterB] mpls lsr-id 2.2.2.2

# 配置Router C。

[RouterC] mpls lsr-id 3.3.3.3

# 配置Router D。

[RouterD] mpls lsr-id 4.4.4.4

# 配置Router E。

[RouterE] mpls lsr-id 5.5.5.5

(4)     配置节点的LDP功能

# 配置Router B。

[RouterB] mpls ldp

[RouterB-ldp] quit

[RouterB] interface gigabitEthernet3/1/2

[RouterB-GigabitEthernet3/1/2] mpls enable

[RouterB-GigabitEthernet3/1/2] mpls ldp enable

[RouterB-GigabitEthernet3/1/2] quit

# 配置Router C。

[RouterC] mpls ldp

[RouterC-ldp] quit

[RouterC] interface gigabitEthernet3/1/1

[RouterC-GigabitEthernet3/1/1] mpls enable

[RouterC-GigabitEthernet3/1/1] mpls ldp enable

[RouterC-GigabitEthernet3/1/1] quit

[RouterC] interface GigabitEthernet3/1/2

[RouterC-GigabitEthernet3/1/2] mpls enable

[RouterC-GigabitEthernet3/1/2] mpls ldp enable

[RouterC-GigabitEthernet3/1/2] quit

# 配置Router D。

[RouterD] mpls ldp

[RouterD-ldp] quit

[RouterD] interface gigabitEthernet3/1/1

[RouterD-GigabitEthernet3/1/1] mpls enable

[RouterD-GigabitEthernet3/1/1] mpls ldp enable

[RouterD-GigabitEthernet3/1/1] quit

(5)     开启IS-IS SR功能

# 配置Router A。

[RouterA] isis 1

[RouterA-isis-1] address-family ipv4

[RouterA-isis-1-ipv4] segment-routing mpls

[RouterA-isis-1-ipv4] quit

# 配置Router B。

[RouterB] isis 1

[RouterB-isis-1] address-family ipv4

[RouterB-isis-1-ipv4] segment-routing mpls

[RouterB-isis-1-ipv4] quit

# 配置Router D。

[RouterD] isis 1

[RouterD-isis-1] address-family ipv4

[RouterD-isis-1-ipv4] segment-routing mpls

[RouterD-isis-1-ipv4] quit

# 配置Router E。

[RouterE] isis 1

[RouterE-isis-1] address-family ipv4

[RouterE-isis-1-ipv4] segment-routing mpls

[RouterE-isis-1-ipv4] quit

(6)     配置IS-IS SR的SRGB

# 配置Router A。

[RouterA-isis-1] segment-routing global-block 16000 16999

[RouterA-isis-1] quit

# 配置Router B。

[RouterB-isis-1] segment-routing global-block 17000 17999

[RouterB-isis-1] quit

# 配置Router D。

[RouterD-isis-1] segment-routing global-block 18000 18999

[RouterD-isis-1] quit

# 配置Router E。

[RouterE-isis-1] segment-routing global-block 19000 19999

[RouterE-isis-1] quit

(7)     配置Router A、Router B、Router D和Router E的前缀SID索引

# 配置Router A。

[RouterA] interface loopback 1

[RouterA-LoopBack1] isis prefix-sid index 10

[RouterA-LoopBack1] quit

# 配置Router B。

[RouterB] interface loopback 1

[RouterB-LoopBack1] isis prefix-sid index 20

[RouterB-LoopBack1] quit

# 配置Router D。

[RouterD] interface loopback 1

[RouterD-LoopBack1] isis prefix-sid index 40

[RouterD-LoopBack1] quit

# 配置Router E。

[RouterE] interface loopback 1

[RouterE-LoopBack1] isis prefix-sid index 50

[RouterE-LoopBack1] quit

4. 验证配置

# 在Router B上查看LDP标签分配情况。

[RouterB] display mpls ldp lsp

Status Flags: * - stale, L - liberal, B - backup, N/A - unavailable

FECs: 5           Ingress: 3           Transit: 3           Egress: 2

 

FEC                In/Out Label        Nexthop         OutInterface

1.1.1.1/32         2171/-

                   -/2169(L)

2.2.2.2/32         2175/-

                   -/2170(L)

3.3.3.3/32         -/2174              11.0.0.2        GE3/1/2

                   2172/2174           11.0.0.2        GE3/1/2

4.4.4.4/32         -/2144              11.0.0.2        GE3/1/2

                   2167/2144           11.0.0.2        GE3/1/2

5.5.5.5/32         -/2162              11.0.0.2        GE3/1/2

                   2161/2162           11.0.0.2        GE3/1/2

# 在Router B上查看IS-IS SR到达Router D和Router E的出标签关联上了LDP标签。

[RouterB] display mpls lsp protocol isis

FEC                         Proto       In/Out Label    Out Inter/NHLFE/LSINDEX

1.1.1.1/32                  ISIS        17010/3         GE3/1/1

1.1.1.1/32                  ISIS        -/3             GE3/1/1

2.2.2.2/32                  ISIS        17020/-         -

4.4.4.4/32                  ISIS        17040/2144      GE3/1/2

4.4.4.4/32                  ISIS        -/2144          GE3/1/2

5.5.5.5/32                  ISIS        17050/2162      GE3/1/2

5.5.5.5/32                  ISIS        -/2162          GE3/1/2

 

不同款型规格的资料略有差异, 详细信息请向具体销售和400咨询。H3C保留在没有任何通知或提示的情况下对资料内容进行修改的权利!

联系我们