03-二层技术命令参考

03-VLAN命令

本章节下载  (227.50 KB)

docurl=/cn/Service/Document_Software/Document_Center/Wlan/WX/H3C_WX3000/Command/Command_Manual/H3C_CR(E3703P61_R2509P61_R3709P61)-6W108/03/201707/1012745_30005_0.htm

03-VLAN命令


1 VLAN

1.1  VLAN配置命令

1.1.1  default

【命令】

default

【视图】

VLAN接口视图

【缺省级别】

2:系统级

【参数】

【描述】

default命令用来恢复当前接口的缺省配置。

需要注意的是,执行default命令并不能保证接口下的所有命令都能恢复到缺省情况,某些命令可能会由于不满足必备条件而恢复失败。因此,执行default命令后建议通过display this命令确认执行效果。

【举例】

# 将VLAN接口1恢复为缺省配置。

<Sysname> system-view

[Sysname] interface vlan-interface 1

[Sysname-Vlan-interface1] default

This command will restore the default settings. Continue? [Y/N]:y

1.1.2  description

【命令】

description text

undo description

【视图】

VLAN视图/VLAN接口视图

【缺省级别】

2:系统级

【参数】

text:VLAN或VLAN接口的描述字符串,可以包含字母(区分大小写)、数字、特殊字符(包括~ ! @ # $ % ^ & * ( ) - _ + = { } [ ] | \ : ; " ' < > , . /)、空格以及符合unicode编码规范的其它文字和符号。VLAN和VLAN接口的描述信息的取值范围分别为:

·     VLAN的描述信息为1~32个字符的字符串。

·     VLAN接口的描述信息为1~80个字符的字符串。

说明

·     一个英文字符占用一个字符长度,一个unicode编码的字符占用两个字符长度,用户可以在描述字符串中混合输入英文字符和unicode字符,但字符串总长度不能超过规定的长度范围。

·     如果用户在设置描述字符时需要使用unicode编码的某种文字或符号,则必须具有相应的输入法软件,并使用支持该字符的远程登录软件登录到设备上进行配置。

·     一个unicode编码的字符占用两个字符长度,所以当所配置的描述信息长度达到或超过终端软件最大列宽时,终端软件会进行自动换行,此时可能导致unicode字符被截断,终端软件会在换行处之后显示乱码。

 

【描述】

description命令用来配置当前VLAN或VLAN接口的描述信息。undo description命令用来恢复缺省情况。

缺省情况下,VLAN的描述信息为“VLAN vlan-id”,其中vlan-id为该VLAN的编号。例如,VLAN 100的描述信息为“VLAN 0100”;VLAN接口的描述信息为该VLAN接口的接口名,如“Vlan-interface1 Interface”。

需要注意的是,当设备上配置的VLAN较多时,用户可以根据功能或者连接情况为VLAN或VLAN接口设置特定的描述信息,以便记忆和管理VLAN或VLAN接口。

相关配置可参考命令display interface vlan-interfacedisplay vlan

【举例】

# 将VLAN 2的描述信息配置为sales-private。

<Sysname> system-view

[Sysname] vlan 2

[Sysname-vlan2] description sales-private

# 将VLAN接口2的描述信息配置为linktoPC56。

<Sysname> system-view

[Sysname] vlan 2

[Sysname-vlan2] quit

[Sysname] interface vlan-interface 2

[Sysname-Vlan-interface2] description linktoPC56

1.1.3  display interface vlan-interface

【命令】

display interface [ vlan-interface ] [ brief [ down ] ] [ | { begin | exclude | include } regular-expression ]

display interface vlan-interface vlan-interface-id [ brief ] [ | { begin | exclude | include } regular-expression ]

【视图】

任意视图

【缺省级别】

1:监控级

【参数】

vlan-interface-id:VLAN接口的编号。

brief:显示接口的概要信息。不指定该参数时,将显示接口的详细信息。

down:显示当前状态为down的接口的信息以及down的原因。不指定该参数时,将不会根据接口状态来过滤显示信息。

|:使用正则表达式对显示信息进行过滤。有关正则表达式的详细介绍,请参见“基础配置指导”中的“CLI”。

begin:从包含指定正则表达式的行开始显示。

exclude:只显示不包含指定正则表达式的行。

include:只显示包含指定正则表达式的行。

regular-expression:表示正则表达式,为1~256个字符的字符串,区分大小写。

【描述】

display interface vlan-interface命令用来显示VLAN接口的相关信息。

需要注意的是:

·     如果不指定vlan-interface参数,将显示设备支持的所有接口的相关信息。

·     如果指定vlan-interface参数,不指定vlan-interface-id参数,将显示所有已创建的VLAN接口的相关信息。

相关配置可参考命令reset counters interface vlan-interface

【举例】

# 显示VLAN接口10的相关信息。

<Sysname> display interface vlan-interface 10

Vlan-interface10 current state: UP

Line protocol current state: UP

Description: Vlan-interface10 Interface

The Maximum Transmit Unit is 1500

Internet Address is 192.168.1.54/24 Primary

Internet Address is 6.4.4.4/24 Sub

IP Packet Frame Type: PKTFMT_ETHNT_2,  Hardware Address: 0023-89b6-d613

IPv6 Packet Frame Type: PKTFMT_ETHNT_2,  Hardware Address: 0023-89b6-d613

Last clearing of counters:  Never

# 显示VLAN接口2的概要信息。

<Sysname> display interface vlan-interface 2 brief

The brief information of interface(s) under route mode:

Link: ADM - administratively down; Stby - standby

Protocol: (s) - spoofing

Interface            Link Protocol Main IP         Description

Vlan2                DOWN DOWN     --

# 显示所有状态为down的VLAN接口的概要信息。

<Sysname> display interface vlan-interface brief down

The brief information of interface(s) under route mode:

Link: ADM - administratively down; Stby - standby

Interface            Link Cause

Vlan2                DOWN Not connected

表1-1 display interface vlan-interface命令显示信息描述表

字段

描述

Vlan-interface10 current state

VLAN接口的物理状态,状态可能为:

·     DOWN ( Administratively ):表示该VLAN接口已经通过shutdown命令被关闭,即管理状态为关闭

·     DOWN:表示该VLAN接口的管理状态为开启,但物理状态为关闭,即该接口对应的VLAN内没有处于up状态的物理端口(可能因为没有物理连线或者线路故障)

·     UP:该端口的管理状态和物理状态均为开启

Line protocol current state

VLAN接口的链路层协议状态,状态可能为:

·     DOWN:该VLAN接口的协议状态为关闭

·     UP:该VLAN接口的协议状态为开启

Description

VLAN接口的字符串描述

The Maximum Transmit Unit

VLAN接口允许通过的最大传输单元

Internet protocol processing : disabled

该接口还不具有处理IP报文的能力(当没有为该接口配置IP地址时会显示该信息)

Internet Address is 192.168.1.54/24 Primary

该接口的主IP地址为192.168.1.54/24(只有为该接口配置主IP地址后才会显示该信息)

Internet Address is 6.4.4.4/24 Sub

该接口的从IP地址为6.4.4.4/24(只有为该接口配置从IP地址后才会显示该信息)

IP Packet Frame Type

IPv4发送帧格式

Hardware address

VLAN接口对应的MAC地址

IPv6 Packet Frame Type

IPv6发送帧格式

Last clearing of counters

最近一次使用reset counters interface vlan-interface命令清除接口下的统计信息的时间(如果从设备启动一直没有执行reset counters interface vlan-interface命令清除过该接口下的统计信息,则显示Nerver)

The brief information of interface(s) under route mode:

三层模式下(route)的接口的概要信息,即三层接口的概要信息

Link: ADM - administratively down; Stby - standby

·     如果某接口的Link属性值为“ADM”,则表示该接口被管理员手工关闭了,需要在该接口下执行undo shutdown命令才能恢复端口本身的物理状态

·     如果某接口的Link属性值为“Stby”,则表示该接口是一个备份接口,使用display standby state命令可以查看该备份接口对应的主接口

Protocol: (s) - spoofing

如果某接口的Protocol属性值中带有“(s)”字符串,则表示该接口的网络层协议状态显示是UP的,但实际可能没有对应的链路,或者所对应的链路不是永久存在而是按需建立

Interface

接口名称缩写

Link

接口物理连接状态,取值可能为:

·     UP:表示本链路物理上是连通的

·     ADM:表示本链路被手工关闭了,需要执行undo shutdown命令才能恢复真实的物理状态

Protocol

接口协议连接状态,取值为UP(s)

Main IP

接口主IP地址

Description

接口的描述信息

Cause

接口物理连接状态为DOWN的原因

·     取值为Administratively时表示本链路被手工关闭了,需要执行undo shutdown命令才能恢复真实的物理状态

·     取值为Not connected时表示本链路没有物理连接

 

1.1.4  display vlan

【命令】

display vlan [ vlan-id1 [ to vlan-id2 ] | all | dynamic | reserved | static ] [ | { begin | exclude | include } regular-expression ]

【视图】

任意视图

【缺省级别】

1:监控级

【参数】

vlan-id1:显示指定VLAN的信息。vlan-id1为指定VLAN的编号,取值范围为1~4094。

vlan-id1 to vlan-id2:显示ID在指定范围内的VLAN的信息。vlan-id1vlan-id2为指定VLAN的编号,取值范围为1~4094。vlan-id2的值要大于或等于vlan-id1的值。

all:显示除保留VLAN外的其它VLAN的信息。

dynamic:显示系统动态创建的VLAN的数量和编号。动态VLAN是指通过通过Radius服务器下发的VLAN。

reserved:显示系统保留VLAN的信息。保留VLAN是设备根据功能实现的需要预留的VLAN。保留VLAN由协议模块来指定,为协议模块服务,用户不能对保留VLAN进行任何操作。

static:显示系统静态创建的VLAN的数量和VLAN编号。静态VLAN是指通过命令行手工创建的VLAN。

|:使用正则表达式对显示信息进行过滤。有关正则表达式的详细介绍,请参见“基础配置指导”中的“CLI”。

begin:从包含指定正则表达式的行开始显示。

exclude:只显示不包含指定正则表达式的行。

include:只显示包含指定正则表达式的行。

regular-expression:表示正则表达式,为1~256个字符的字符串,区分大小写。

【描述】

display vlan命令用来显示VLAN的相关信息。

相关配置可参考命令vlan

【举例】

# 显示VLAN 2的信息。

<Sysname> display vlan 2

 VLAN ID: 2

 VLAN Type: static

 Route interface: not configured

 Description: VLAN 0002

 Name: VLAN 0002

Tagged   Ports: none

 Untagged Ports: 

    GigabitEthernet1/0/1  GigabitEthernet1/0/2  GigabitEthernet1/0/3

# 显示VLAN 3的信息。

<Sysname> display vlan 3

 VLAN ID: 3

 VLAN Type: static

 Route Interface: configured

 IPv4 address: 1.1.1.1

 IPv4 subnet mask: 255.255.255.0

 IPv6 global unicast address(es):                  

    2001::1, subnet is 2001::/64 [TENTATIVE]   

    2002::1, subnet is 2002::/64 [TENTATIVE]

    2003::1, subnet is 2003::/32 [TENTATIVE]

 IPv6 joined group address(es):

    FF02::1:FF00:0

    FF02::1:FF00:1

    FF02::1:FFFF:1

    FF02::2

    FF02::1

 Description: VLAN 0003

 Name: VLAN 0003

 Tagged   Ports: none

 Untagged Ports: none

表1-2 display vlan命令显示信息描述表

字段

解释

VLAN ID

VLAN的编号

VLAN Type

VLAN的类型:static表示静态VLAN;dynamic表示动态VLAN

Route interface

设备上是否创建了对应的VLAN接口:not configured(没有创建)/configured(创建了)

Description

VLAN的描述信息

Name

VLAN的名称

IPv4 address

VLAN接口的主用IPv4地址(如果VLAN接口没有配置IPv4地址,则不显示该字段),如果VLAN接口上还配置了从IPv4地址,可以使用display interface vlan-interface或者在VLAN接口视图下使用display this命令查看

IPv4 subnet mask

VLAN接口的主用IPv4地址的子网掩码(如果VLAN接口没有配置IPv4地址,则不显示该字段)

IPv6 global unicast address(es)

VLAN接口上配置的全球单播IPv6地址(如果VLAN接口没有配置IPv6地址,则不显示该字段)

IPv6 joined group address(es)

VLAN接口加入的组播组IPv6地址(如果VLAN接口没有配置IPv6地址,则不显示该字段)

Tagged Ports

该VLAN报文从哪些端口发送时需要携带Tag标记

Untagged Ports

该VLAN报文从哪些端口发送时不需要携带Tag标记

 

1.1.5  interface vlan-interface

【命令】

interface vlan-interface vlan-interface-id

undo interface vlan-interface vlan-interface-id

【视图】

系统视图

【缺省级别】

2:系统级

【参数】

vlan-interface-id:VLAN接口的编号,取值范围为1~4094。

【描述】

interface vlan-interface命令用来创建VLAN接口并进入VLAN接口视图。如果该VLAN接口已经存在,则直接进入VLAN接口视图。undo interface vlan-interface命令用来删除指定的VLAN接口。

需要注意的是:

·     在创建VLAN接口之前,对应的VLAN必须已经存在,否则将不能创建指定的VLAN接口。

·     用户可以在VLAN接口视图下使用ip address命令配置IP地址,使得设备具有三层路由功能。

相关配置可参考命令display interface vlan-interface

【举例】

# 创建VLAN接口2并进入视图。

<Sysname> system-view

[Sysname] vlan 2

[Sysname-vlan2] quit

[Sysname] interface vlan-interface 2

[Sysname-Vlan-interface2]

1.1.6  ip address

【命令】

ip address ip-address { mask | mask-length } [ sub ]

undo ip address [ ip-address { mask | mask-length } [ sub ] ]

【视图】

VLAN接口视图

【缺省级别】

2:系统级

【参数】

ip-address:VLAN接口的IP地址,为点分十进制格式。

mask:子网掩码,为点分十进制格式。

mask-length:子网掩码长度,即子网掩码中“1”的个数,取值范围为0~32。

sub:表示该地址为VLAN接口的从IP地址。

【描述】

ip address命令用来给VLAN接口指定IP地址和掩码。undo ip address命令用来删除VLAN接口的IP地址和掩码。

缺省情况下,没有配置VLAN接口的IP地址。

一般情况下,一个接口配置一个IP地址即可,但为了使设备的一个VLAN可以与多个子网相连,VLAN接口可以配置两个IP地址,其中一个为主IP地址,另一个为从IP地址。主从地址的配置关系为:

·     当配置主IP地址时,如果接口上已经有主IP地址,则原主IP地址被新配置的地址取代。

·     undo ip address命令不带任何参数表示删除该接口的所有IP地址。

·     undo ip address ip-address { mask | mask-length }表示删除主IP地址。

·     undo ip address ip-address { mask | mask-length } sub表示删除从IP地址。

·     在删除主IP地址之前必须先删除从IP地址。

相关配置可参考“三层技术-IP业务命令参考/IP地址”中的命令display ip interface

【举例】

# 指定VLAN接口1的IP地址为1.1.0.1,子网掩码为255.255.255.0。

<Sysname> system-view

[Sysname] interface vlan-interface 1

[Sysname-Vlan-interface1] ip address 1.1.0.1 255.255.255.0

1.1.7  mtu

【命令】

mtu size

undo mtu

【视图】

VLAN接口视图

【缺省级别】

2:系统级

【参数】

size:表示接口允许通过的MTU(Maximum Transmission Unit,最大传输单元)值的大小,单位为字节。设备支持的取值范围为46~1748。

【描述】

mtu命令用来配置VLAN接口的MTU值。undo mtu命令用来恢复缺省情况。

缺省情况下,VLAN接口的MTU值为1500字节。

相关配置可参考命令display interface vlan-interface

【举例】

# 配置VLAN接口1的MTU值为1492字节。

<Sysname> system-view

[Sysname] interface vlan-interface 1

[Sysname-Vlan-interface1] mtu 1492

1.1.8  name

【命令】

name text

undo name

【视图】

VLAN视图

【缺省级别】

2:系统级

【参数】

text:VLAN名称,为1~32个字符的描述信息,可以包含字母(区分大小写)、数字、特殊字符(包括~ ! @ # $ % ^ & * ( ) - _ + = { } [ ] | \ : ; " ' < > , . /)、空格以及符合unicode编码规范的其它文字和符号。

【描述】

name命令用来指定当前VLAN的名称。当设备上配置了802.1X或MAC地址认证功能后,可以通过Radius服务器来对认证通过的端口下发VLAN。某些服务器可以向设备发送需要下发的VLAN编号或者VLAN名称,当VLAN数量很多的时候,使用名称可以更明确的定位VLAN。undo name命令用来恢复缺省情况。

缺省情况下,VLAN的名称为“VLAN vlan-id”,其中vlan-id为该VLAN的编号。例如,VLAN 100的名称为“VLAN 0100”。

需要注意的是,当设备上配置了802.1X或MAC地址认证功能后,可以通过RADIUS服务器来对认证通过的端口下发VLAN。某些服务器可以向设备发送需要下发的VLAN编号或者VLAN名称,当VLAN数量很多的时候,使用名称可以更明确的定位VLAN。

相关配置可参考命令display vlan

【举例】

# 指定VLAN 2的名称为Test VLAN。

<Sysname> system-view

[Sysname] vlan 2

[Sysname-vlan2] name Test VLAN

1.1.9  reset counters interface vlan-interface

【命令】

reset counters interface vlan-interface [ vlan-interface-id ]

【视图】

用户视图

【缺省级别】

2:系统级

【参数】

vlan-interface-id:VLAN接口的编号。

【描述】

reset counters interface vlan-interface命令用来清除VLAN接口的统计信息。

在某些情况下,需要统计一定时间内某接口的流量,这就需要在统计开始前清除该接口原有的统计信息,重新进行统计。

需要注意的是:

·     如果不指定vlan-interface-id,则清除所有VLAN接口的统计信息。

·     如果指定vlan-interface-id,则清除指定VLAN接口的统计信息。

相关配置可参考命令display interface vlan-interface

【举例】

# 清除VLAN接口2的统计信息。

<Sysname> reset counters interface vlan-interface 2

1.1.10  shutdown

【命令】

shutdown

undo shutdown

【视图】

VLAN接口视图

【缺省级别】

2:系统级

【参数】

【描述】

shutdown命令用来手工关闭VLAN接口。undo shutdown命令用来取消手工关闭VLAN接口。

缺省情况下,未手工关闭VLAN接口。此时VLAN接口状态受VLAN中端口状态的影响,即:当VLAN中所有以太网端口状态均为down时,VLAN接口为down状态,即关闭状态;当VLAN中有一个或一个以上的以太网端口处于up状态时,则VLAN接口处于up状态。

需要注意的是:

·     如果手工关闭VLAN接口,则VLAN接口的状态始终为down(Administratively),不受VLAN中端口状态的影响。

·     配置VLAN接口参数前,为了避免配置过程中对网络造成影响,建议先使用shutdown命令手工关闭接口,之后再配置参数。配置完成后,使用undo shutdown命令取消手工关闭接口,使配置的参数生效。

·     当VLAN接口出现故障时,可以使用shutdown命令手工关闭接口,然后再使用undo shutdown命令取消手工关闭接口,这样有可能使接口恢复正常。

·     关闭和打开VLAN接口对于属于这个VLAN的任何一个以太网端口本身都不起作用,以太网端口的状态不随VLAN接口状态的改变而改变。

【举例】

# 将VLAN接口2关闭后再重新打开。

<Sysname> system-view

[Sysname] interface vlan-interface 2

[Sysname-Vlan-interface2] shutdown

[Sysname-Vlan-interface2] undo shutdown

1.1.11  vlan

【命令】

vlan { vlan-id1 [ to vlan-id2 ] | all }

undo vlan { vlan-id1 [ to vlan-id2 ] | all }

【视图】

系统视图

【缺省级别】

2:系统级

【参数】

vlan-id1:VLAN的编号,取值范围为1~4094。

vlan-id1 to vlan-id2:指定VLAN的编号范围。vlan-id1vlan-id2为VLAN的编号,取值范围为1~4094。vlan-id2的值要大于或等于vlan-id1的值。

all:除保留VLAN外的其它VLAN,当设备允许创建的最大VLAN数小于4094时,不支持该参数。

【描述】

vlan vlan-id命令用来创建VLAN并进入VLAN视图。如果指定的VLAN已创建,则该命令直接用来进入该VLAN的视图。vlan vlan-id1 to vlan-id2命令用来批量创建vlan-id1vlan-id2之间的所有VLAN,保留VLAN除外。vlan all命令用来批量创建VLAN 1~VLAN 4094。undo vlan命令用来删除VLAN。

缺省情况下,系统只有一个缺省VLAN(VLAN 1)。

需要注意的是:

·     VLAN 1为系统缺省VLAN,用户不能创建和删除。

·     保留VLAN是系统为实现特定功能预留的VLAN,用户也不能手工创建和删除。

·     对于协议保留的VLAN、管理VLAN、动态学习到的VLAN、配置有QoS策略的VLAN,都不能使用undo vlan命令直接删除。只有将相关配置删除之后,才能删除相应的VLAN。

相关配置可参考命令display vlan

【举例】

# 创建VLAN 2,并进入该VLAN视图。

<Sysname> system-view

[Sysname] vlan 2

[Sysname-vlan2]

# 批量创建VLAN 4~VLAN 100。

<Sysname> system-view

[Sysname] vlan 4 to 100

Please wait............. Done.

1.2  基于端口的VLAN配置命令

1.2.1  display port

【命令】

display port { hybrid | trunk } [ | { begin | exclude | include } regular-expression ]

【视图】

任意视图

【缺省级别】

1:监控级

【参数】

hybrid:显示系统当前存在的Hybrid端口。

trunk:显示系统当前存在的Trunk端口。

|:使用正则表达式对显示信息进行过滤。有关正则表达式的详细介绍,请参见“基础配置指导”中的“CLI”。

begin:从包含指定正则表达式的行开始显示。

exclude:只显示不包含指定正则表达式的行。

include:只显示包含指定正则表达式的行。

regular-expression:表示正则表达式,为1~256个字符的字符串,区分大小写。

【描述】

display port命令用来显示设备上当前存在的Hybrid或Trunk端口。显示的信息包括端口对应的端口名、缺省VLAN ID和允许通过的VLAN ID。

【举例】

# 显示当前系统存在的Hybrid端口。

<Sysname> display port hybrid

Interface            PVID  VLAN passing

GE1/0/2               100   Tagged:  1000, 1002, 1500, 1600-1611, 2000,

                                    2555-2558, 3000, 4000

                           Untagged:1, 10, 15, 18, 20-30, 44, 55, 67, 100,

                                    150-160, 200, 255, 286, 300-302

# 显示当前系统存在的Trunk端口。

<Sysname> display port trunk

Interface            PVID  VLAN passing

GE1/0/3               2     1-4, 6-100, 145, 177, 189-200, 244, 289, 400,

                           555, 600-611, 1000, 2006-2008

表1-3 display port命令显示信息描述表

字段

描述

Interface

接口名称

PVID

该端口的缺省VLAN ID

VLAN passing

表示哪些VLAN的报文允许通过该端口

Tagged

表示哪些VLAN的报文通过该端口时必须携带VLAN Tag

Untagged

表示哪些VLAN的报文通过该端口时必须去掉VLAN Tag

 

1.2.2  port

【命令】

port interface-list

undo port interface-list

【视图】

VLAN视图

【缺省级别】

2:系统级

【参数】

interface-list:接口列表,表示方式为interface-list = { interface-type interface-number1 [ to interface-type interface-number2 ] }&<1-10>。其中,interface-type interface-number为指定接口类型和接口编号。&<1-10>表示前面的参数最多可以输入10次。

【描述】

port命令用来向当前VLAN中添加一个或一组Access端口。undo port命令用来从当前VLAN中删除一个或一组Access端口。

缺省情况下,系统将所有端口都加入到VLAN 1

需要注意的是:

·     通过本命令只能将Access端口加入到VLAN中,不能将Trunk和Hybrid端口加入到VLAN中。

·     设备上的所有端口的缺省链路类型都是Access类型,但用户可以自行切换端口类型,具体配置可参考命令port link-type

·     不支持二层聚合接口添加到当前VLAN。

相关配置可参考命令display vlan

【举例】

# 向VLAN 2中加入从GigabitEthernet1/0/1到 GigabitEthernet1/0/3的以太网端口。

<Sysname> system-view

[Sysname] vlan 2

[Sysname-vlan2] port GigabitEthernet1/0/1 to GigabitEthernet1/0/3

1.2.3  port access vlan

【命令】

port access vlan vlan-id

undo port access vlan

【视图】

WLAN-ESS接口视图/以太网接口视图/端口组视图/二层聚合接口视图

【缺省级别】

2:系统级

【参数】

vlan-id:指定的VLAN编号,取值范围为1~4094。该VLAN必须是设备上已创建的VLAN,否则,该命令执行失败。

【描述】

port access vlan命令用来将当前Access端口加入到指定的VLAN中。undo port access vlan命令用来恢复缺省情况。

缺省情况下,所有Access端口都属于VLAN 1。

需要注意的是:

·     WLAN-ESS接口和以太网接口视图下的配置都只对当前接口生效。

·     端口组视图下的配置对当前端口组中的所有端口生效。

·     二层聚合接口视图下的配置对当前二层聚合接口及其所有成员端口都生效,若配置某成员端口时失败,系统会自动跳过该成员端口继续配置其它成员端口,若配置二层聚合接口时失败,则不再配置其成员端口。

【举例】

# 将GigabitEthernet1/0/1端口加入到VLAN 3中。

<Sysname> system-view

[Sysname] vlan 3

[Sysname-vlan3] quit

[Sysname] interface GigabitEthernet 1/0/1

[Sysname-GigabitEthernet1/0/1] port access vlan 3

# 将二层聚合接口1以及其对应的成员端口加入到VLAN 3中。

<Sysname> system-view

[Sysname] vlan 3

[Sysname-vlan3] quit

[Sysname] interface bridge-aggregation 1

[Sysname-Bridge-Aggregation1] port access vlan 3

1.2.4  port hybrid pvid

【命令】

port hybrid pvid vlan vlan-id

undo port hybrid pvid

【视图】

WLAN-ESS接口视图/以太网接口视图/端口组视图/二层聚合接口视图

【缺省级别】

2:系统级

【参数】

vlan-id:指定接口的缺省的VLAN ID,取值范围为14094

【描述】

port hybrid pvid命令用来设置Hybrid端口的缺省VLANundo port hybrid pvid命令用来恢复缺省情况。

缺省情况下,Hybrid端口的缺省VLAN为VLAN 1。

需要注意的是:

·     对Hybrid端口,执行undo vlan命令删除端口的缺省VLAN后,端口的缺省VLAN配置不会改变,即可以使用已经不存在的VLAN作为缺省VLAN。

·     建议本机Hybrid端口的缺省VLAN和相连的对端设备的Hybrid端口的缺省VLAN保持一致。

·     配置缺省VLAN后,必须使用port hybrid vlan命令配置允许缺省VLAN的报文通过,出接口才能转发缺省VLAN的报文。

·     WLAN-ESS接口和以太网接口视图下的配置都只对当前接口生效。

·     端口组视图下的配置对当前端口组中的所有端口生效。

·     二层聚合接口视图下的配置对当前二层聚合接口及其所有成员端口都生效,若配置某成员端口时失败,系统会自动跳过该成员端口继续配置其它成员端口,若配置二层聚合接口时失败,则不再配置其成员端口。

相关配置可参考命令port link-typeport hybrid vlan

【举例】

# 配置端口GigabitEthernet1/0/1(Hybrid类型)的缺省VLAN设置为VLAN 100。

<Sysname> system-view

[Sysname] vlan 100

[Sysname-vlan100] quit

[Sysname] interface GigabitEthernet 1/0/1

[Sysname-GigabitEthernet1/0/1] port link-type hybrid

[Sysname-GigabitEthernet1/0/1] port hybrid pvid vlan 100

# 将二层聚合接口1(Hybrid类型)以及其对应的成员端口的缺省VLAN设置为VLAN 100。

<Sysname> system-view

[Sysname] interface bridge-aggregation 1

[Sysname-Bridge-Aggregation1] port link-type hybrid

[Sysname-Bridge-Aggregation1] port hybrid pvid vlan 100

1.2.5  port hybrid vlan

【命令】

port hybrid vlan vlan-list { tagged | untagged }

undo port hybrid vlan vlan-list

【视图】

WLAN-ESS接口视图/以太网接口视图/端口组视图/二层聚合接口视图

【缺省级别】

2:系统级

【参数】

vlan-list:VLAN列表,Hybrid端口允许通过的VLAN范围。表示方式为vlan-list = { vlan-id1 [ to vlan-id2 ] }&<1-10>。其中,vlan-id1vlan-id2为指定VLAN的编号,取值范围为1~4094,vlan-id2的值要大于或等于vlan-id1的值。&<1-10>表示前面的参数最多可以重复输入10次。该VLAN必须是设备上已创建的VLAN,否则,该命令执行失败。

tagged:该端口在转发指定的VLAN报文时将携带VLAN Tag。

untagged:该端口在转发指定的VLAN报文时将去掉VLAN Tag。

【描述】

port hybrid vlan命令用来允许指定的VLAN通过当前Hybrid端口。undo port hybrid vlan命令用来禁止指定的VLAN通过当前Hybrid端口。

缺省情况下,Hybrid端口只允许VLAN 1的报文以Untagged方式通过,即VLAN 1的报文从该端口发送出去后不携带VLAN Tag。

需要注意的是:

·     Hybrid端口允许多个VLAN通过。如果多次使用port hybrid vlan命令,那么Hybrid端口上允许通过的VLAN是这些vlan-list的合集。

·     WLAN-ESS接口和以太网接口视图下的配置都只对当前接口生效。

·     端口组视图下的配置对当前端口组中的所有端口生效。

·     二层聚合接口视图下的配置对当前二层聚合接口及其所有成员端口都生效,若配置某成员端口时失败,系统会自动跳过该成员端口继续配置其它成员端口,若配置二层聚合接口时失败,则不再配置其成员端口。

相关配置可参考命令port link-type

【举例】

# 配置端口GigabitEthernet1/0/1(Hybrid类型)允许VLAN 2、VLAN 4、VLAN 50~VLAN 100通过(假设指定的VLAN都已经创建),并且发送这些VLAN的报文时携带VLAN Tag。

<Sysname> system-view

[Sysname] interface GigabitEthernet 1/0/1

[Sysname-GigabitEthernet1/0/1] port link-type hybrid

[Sysname-GigabitEthernet1/0/1] port hybrid vlan 2 4 50 to 100 tagged

# 配置端口组2内的Hybrid端口允许VLAN 2通过,并且发送VLAN 2的报文时去掉VLAN Tag。

<Sysname> system-view

[Sysname] vlan 2

[Sysname-vlan2] quit

[Sysname] port-group manual 2

[Sysname-port-group-manual-2] group-member GigabitEthernet 1/0/1 to GigabitEthernet 1/0/2

[Sysname-port-group-manual-2] port link-type hybrid

[Sysname-port-group-manual-2] port hybrid vlan 2 untagged

 Configuring GigabitEthernet1/0/1... Done.

 Configuring GigabitEthernet1/0/2... Done.

# 将二层聚合接口1(Hybrid类型)以及其对应的成员端口允许VLAN 2通过,并且发送VLAN 2的报文时去掉VLAN Tag。

<Sysname> system-view

[Sysname] interface bridge-aggregation 1

[Sysname-Bridge-Aggregation1] port link-type hybrid

[Sysname-Bridge-Aggregation1] port hybrid vlan 2 untagged

 Please wait... Done.

 Configuring GigabitEthernet1/0/1... Done.

 Configuring GigabitEthernet1/0/2... Done.

 Configuring GigabitEthernet1/0/3... Done.

接口GigabitEthernet1/0/1、 GigabitEthernet1/0/2和 GigabitEthernet1/0/3是二层聚合接口1对应的成员端口。

1.2.6  port link-type

【命令】

port link-type { access | hybrid | trunk }

undo port link-type

【视图】

WLAN-ESS接口视图/以太网接口视图/端口组视图/二层聚合接口视图

【缺省级别】

2:系统级

【参数】

access:设置端口的链路类型为Access类型。

hybrid:设置端口的链路类型为Hybrid类型。

trunk:设置端口的链路类型为Trunk类型。WALN-ESS接口视图不支持此类型。

【描述】

port link-type命令用来设置当前端口的链路类型。undo port link-type命令用来恢复缺省情况。

缺省情况下,所有端口的链路类型均为Access类型。

需要注意的是:

·     Trunk端口和Hybrid端口之间不能直接切换,只能先设为Access端口,再设置为其它类型端口。

·     WLAN-ESS接口和以太网接口视图下的配置都只对当前接口生效。

·     端口组视图下的配置对当前端口组中的所有端口生效。

·     二层聚合接口视图下的配置对当前二层聚合接口及其所有成员端口都生效,若配置某成员端口时失败,系统会自动跳过该成员端口继续配置其它成员端口,若配置二层聚合接口时失败,则不再配置其成员端口。

【举例】

# 将以太网端口GigabitEthernet1/0/1设置为Trunk类型端口。

<Sysname> system-view

[Sysname] interface GigabitEthernet 1/0/1

[Sysname-GigabitEthernet1/0/1] port link-type trunk

# 将手工端口组group1内的所有端口都设置为Hybrid端口。

<Sysname> system-view

[Sysname] port-group manual group1

[Sysname-port-group manual group1] group-member GigabitEthernet 1/0/1

[Sysname-port-group manual group1] group-member GigabitEthernet 1/0/2

[Sysname-port-group manual group1] port link-type hybrid

# 将二层聚合接口1以及其对应的成员端口的链路类型设置为Hybrid。

<Sysname> system-view

[Sysname] interface bridge-aggregation 1

[Sysname-Bridge-Aggregation1] port link-type hybrid

1.2.7  port trunk permit vlan

【命令】

port trunk permit vlan { vlan-list | all }

undo port trunk permit vlan { vlan-list | all }

【视图】

以太网接口视图/端口组视图/二层聚合接口视图

【缺省级别】

2:系统级

【参数】

vlan-list:VLAN列表,Trunk端口允许通过的VLAN范围。表示方式为vlan-list = { vlan-id1 [ to vlan-id2 ] }& <1-10>。其中,vlan-id1vlan-id2为指定VLAN的编号,取值范围为1~4094,vlan-id2的值要大于或等于vlan-id1的值。&<1-10>表示前面的参数最多可以重复输入10次。

all:表示允许所有VLAN通过该Trunk端口,建议用户谨慎使用port trunk permit vlan all命令,以防止未授权VLAN的用户通过该端口访问受限资源。

【描述】

port trunk permit vlan命令用来允许指定的VLAN通过当前Trunk端口。undo port trunk permit vlan命令用来禁止指定的VLAN通过当前Trunk端口。

缺省情况下,Trunk端口只允许VLAN 1的报文通过。

需要注意的是:

·     Trunk端口可以允许多个VLAN通过。如果多次执行port trunk permit vlan命令,那么Trunk端口上允许通过的VLAN是这些vlan-list的集合。

·     Trunk端口发送出去的报文,只有缺省VLAN的报文去掉VLAN Tag,其它VLAN的报文均会携带VLAN Tag。

·     以太网接口视图下的配置都只对当前接口生效。

·     端口组视图下的配置对当前端口组中的所有端口生效。

·     二层聚合接口视图下的配置对当前二层聚合接口及其所有成员端口都生效,若配置某成员端口时失败,系统会自动跳过该成员端口继续配置其它成员端口,若配置二层聚合接口时失败,则不再配置其成员端口。

相关配置可参考命令port link-type

【举例】

# 配置端口GigabitEthernet1/0/1(Trunk类型)允许VLAN 2、4、50~100通过。

<Sysname> system-view

[Sysname] interface GigabitEthernet 1/0/1

[Sysname-GigabitEthernet1/0/1] port link-type trunk

[Sysname-GigabitEthernet1/0/1] port trunk permit vlan 2 4 50 to 100

Please wait........... Done.

# 将二层聚合接口1(Trunk类型)允许VLAN 2通过。

<Sysname> system-view

[Sysname] interface bridge-aggregation 1

[Sysname-Bridge-Aggregation1] port link-type trunk

[Sysname-Bridge-Aggregation1] port trunk permit vlan 2

 Please wait... Done.

 Configuring GigabitEthernet1/0/1... Done.

 Configuring GigabitEthernet1/0/2... Done.

 Configuring GigabitEthernet1/0/3... Done.

接口GigabitEthernet1/0/1、 GigabitEthernet1/0/2和 GigabitEthernet1/0/3是二层聚合接口1的成员端口。

1.2.8  port trunk pvid

【命令】

port trunk pvid vlan vlan-id

undo port trunk pvid

【视图】

以太网接口视图/端口组视图/二层聚合接口视图

【缺省级别】

2:系统级

【参数】

vlan-id:指定接口的缺省VLAN ID,取值范围为1~4094。

【描述】

port trunk pvid命令用来设置Trunk端口的缺省VLAN。undo port trunk pvid命令用来恢复缺省情况。

缺省情况下,Trunk端口的缺省VLAN为VLAN 1。

需要注意的是:

·     对Trunk端口,执行undo vlan命令删除端口的缺省VLAN后,端口的缺省VLAN配置不会改变,即使用已经不存在的VLAN作为缺省VLAN。

·     本端设备Trunk端口的缺省VLAN ID和相连的对端设备的Trunk端口的缺省VLAN ID必须一致,否则报文将不能正确传输。

·     配置缺省VLAN后,必须使用port trunk permit vlan命令配置允许缺省VLAN的报文通过,出接口才能转发缺省VLAN的报文。

·     以太网接口视图下的配置都只对当前接口生效。

·     端口组视图下的配置对当前端口组中的所有端口生效。

·     二层聚合接口视图下的配置对当前二层聚合接口及其所有成员端口都生效,若配置某成员端口时失败,系统会自动跳过该成员端口继续配置其它成员端口,若配置二层聚合接口时失败,则不再配置其成员端口。

相关配置可参考命令port link-typeport trunk permit vlan

【举例】

# 配置端口GigabitEthernet1/0/1(Trunk类型)的缺省VLAN设置为VLAN 100,并允许VLAN 100通过。

<Sysname> system-view

[Sysname] interface GigabitEthernet 1/0/1

[Sysname-GigabitEthernet1/0/1] port link-type trunk

[Sysname-GigabitEthernet1/0/1] port trunk pvid vlan 100

[Sysname-GigabitEthernet1/0/1] port trunk permit vlan 100

# 将二层聚合接口1(Trunk类型)的缺省VLAN设置为VLAN 100,并允许VLAN 100通过。

<Sysname> system-view

[Sysname] interface bridge-aggregation 1

[Sysname-Bridge-Aggregation1] port link-type trunk

[Sysname-Bridge-Aggregation1] port trunk pvid vlan 100

[Sysname-Bridge-Aggregation1] port trunk permit vlan 100

1.3  基于MAC的VLAN配置命令

1.3.1  display mac-vlan

【命令】

display mac-vlan { all | dynamic | mac-address mac-address [ mask mac-mask ] | static | vlan vlan-id } [ | { begin | exclude | include } regular-expression ]

【视图】

任意视图

【缺省级别】

1:监控级

【参数】

all:显示MAC-VLAN表的所有表项。

dynamic:显示动态配置的MAC-VLAN表项。

mac-address mac-address:按MAC显示MAC-VLAN表项。

mask mac-mask:显示指定范围的MAC-VLAN表项。

static:显示静态配置的MAC-VLAN表项。

vlan vlan-id:显示指定VLAN的MAC-VLAN表项。

|:使用正则表达式对显示信息进行过滤。有关正则表达式的详细介绍,请参见“基础配置指导”中的“CLI”。

begin:从包含指定正则表达式的行开始显示。

exclude:只显示不包含指定正则表达式的行。

include:只显示包含指定正则表达式的行。

regular-expression:表示正则表达式,为1~256个字符的字符串,区分大小写。

【描述】

display mac-vlan命令用来显示MAC-VLAN表项。

指定mac-address参数但不带mask参数,则显示单个MAC VLAN表项。

【举例】

# 显示MAC-VLAN表的所有表项。

<Sysname> display mac-vlan all

The following MAC-VLAN address exist:

S: Static   D: Dynamic

MAC ADDR           MASK                    VLAN ID   PRIO    STATE

-------------------------------------------------------------------

0008-0001-0000     FFFF-FF00-0000          5         3       S

0002-0001-0000     FFFF-FFFF-FFFF          5         3       S&D

 

Total MAC VLAN address count:2

表1-4 display mac-vlan命令显示信息描述表

字段

描述

The following MAC-VLAN address exist:

目前设备上存在以下MAC VLAN配置

S: Static

以下显示信息中,S表示静态配置的MAC VLAN

D: Dynamic

以下显示信息中,D表示动态配置的MAC VLAN

MAC ADDR

配置的MAC-VLAN的MAC地址

MASK

配置的MAC-VLAN的MAC地址对应的掩码

VLAN ID

用户配置的MAC地址所对应的VLAN

PRIO

用户配置的MAC地址所对应的802.1P优先级

STATE

该表项的属性,MAC-VLAN表中的表项有三种属性:

·     S表示该表项是通过用户静态配置生成的

·     D表示该表项是通过认证功能自动生成的

·     S&D表示该表项由静态和动态同时配置的

 

1.3.2  display mac-vlan interface

【命令】

display mac-vlan interface [ | { begin | exclude | include } regular-expression ]

【视图】

任意视图

【缺省级别】

1:监控级

【参数】

|:使用正则表达式对显示信息进行过滤。有关正则表达式的详细介绍,请参见“基础配置指导”中的“CLI”。

begin:从包含指定正则表达式的行开始显示。

exclude:只显示不包含指定正则表达式的行。

include:只显示包含指定正则表达式的行。

regular-expression:表示正则表达式,为1~256个字符的字符串,区分大小写。

【描述】

display mac-vlan interface命令用来显示所有使能了MAC-VLAN功能的接口。

相关配置可参考命令mac-vlan enable

【举例】

# 显示所有使能了MAC-VLAN功能的接口。

<Sysname> display mac-vlan interface

MAC VLAN is enabled on following ports:

---------------------------------------

 GigabitEthernet1/0/1 GigabitEthernet1/0/2  GigabitEthernet1/0/3

1.3.3  mac-vlan enable

【命令】

mac-vlan enable

undo mac-vlan enable

【视图】

WLAN-ESS接口视图/二层以太网接口视图

【缺省级别】

2:系统级

【参数】

【描述】

mac-vlan enable命令用来使能端口基于MAC地址划分VLAN的功能。undo mac-vlan enable 命令用来恢复缺省情况。

缺省情况下,没有使能端口基于MAC地址划分VLAN的功能。

需要注意的是,该命令只能在Hybrid端口配置。

【举例】

# 使能端口GigabitEthernet1/0/1的MAC VLAN功能。

<Sysname> system-view

[Sysname] interface GigabitEthernet 1/0/1

[Sysname–GigabitEthernet1/0/1] mac-vlan enable

1.3.4  mac-vlan mac-address

【命令】

mac-vlan mac-address mac-address [ mask mac-mask ] vlan vlan-id [ priority pri ]

undo mac-vlan { all | mac-address mac-address [ mask mac-mask ] | vlan vlan-id }

【视图】

系统视图

【缺省级别】

2:系统级

【参数】

mac-address mac-address:指定MAC地址。

mask mac-mask:指定MAC地址的掩码,二进制时高位必须为连续1。缺省值为全F。

vlan vlan-id:指定VLAN编号,取值为1~4094。

priority pri:指定MAC地址对应VLAN的802.1p优先级,取值为0~7,缺省值为0。

all:删除所有的静态MAC-VLAN表项。

【描述】

mac-vlan mac-address命令用来配置MAC地址所对应的VLAN以及其优先级。undo mac-vlan命令用来删除MAC地址与VLAN的关联。

设备维护两张MAC-VLAN表,一种是通过指定mask参数配置的MAC-VLAN表,该表里的表项描述的是一类MAC地址和VLAN、优先级之间的关系;一种是不指定mask参数直接配置的MAC-VLAN表,该表里的表项描述的是单个MAC地址和VLAN、优先级之间的关系。根据用户的配置,系统将自动往这两个表里添加/删除表项。

【举例】

# 配置单个MAC地址0-1-1与VLAN 100的关联,并指定优先级为7。

<Sysname> system-view

[Sysname] mac-vlan mac-address 0-1-1 vlan 100 priority 7

# 配置将MAC地址前6位为121122的用户与VLAN 100关联,优先级为4。

<Sysname> system-view

[Sysname] mac-vlan mac-address 1211-2222-3333 mask ffff-ff00-0000 vlan 100 priority 4

 

不同款型规格的资料略有差异, 详细信息请向具体销售和400咨询。H3C保留在没有任何通知或提示的情况下对资料内容进行修改的权利!

联系我们